Módulos e interfaces de Cisco : Módulos de red de Cisco

Ejemplo de configuración de módulo de red EtherSwitch (ESW)

23 Marzo 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (19 Marzo 2007) | Comentarios


Contenido

Introducción
Requisitos previos
      Requerimientos
      Componentes utilizados
      Productos relacionados
      Convenciones
Módulos EtherSwitch: conceptos
Configuración
      Diagrama de la red
      Configuraciones
      Configuración de las interfaces VLAN
      Configuración de VTP, tronco, canal de puerto y árbol de expansión
      Configuración de puertos de acceso
      Configuración de puerto de voz
      Configuración de la calidad del servicio (QoS)
Verificación
Resolución de problemas
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

Este documento proporciona un ejemplo de configuración para el módulo de red EtherSwitch instalado en el router de servicios integrados (ISR). Este documento no trata el ejemplo de configuración del módulo de servicio EtherSwitch.

Requisitos previos

Requerimientos

No hay requerimientos específicos para este documento.

Componentes utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware:

  • Routers de la serie 2800 de Cisco en software Cisco IOS® Software versión 12.4 o posteriores

  • NM-16ESW-PWR = Módulo de red (NM) EtherSwitch 10/100 de 16 puertos (NM)

La información que contiene este documento se creó a partir de los dispositivos en un entorno de laboratorio específico. Todos los dispositivos que se utilizan en este documento se iniciaron con una configuración sin definir (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Productos relacionados

Esta configuración también se puede utilizar con las siguientes versiones de hardware y software:

Convenciones

Consulte Convenciones sobre consejos técnicos de Cisco para obtener más información sobre las convenciones del documento.

Módulos EtherSwitch: conceptos

Existen dos tipos de módulos EtherSwitch disponibles para los ISR de Cisco. Son los siguientes:

  • Módulo de red EtherSwitch (ESW)

  • Módulo de servicio EtherSwitch (ES)

Los módulos ESW se configuran mediante IOS de router. Estos módulos no ejecutan software independiente. El software está integrado en IOS del router del host. Puede crear las VLAN y configurar las VLAN, el árbol de expansión, el protocolo de enlace troncal VLAN (VTP), etc. en el router del host. El router también almacena el archivo de base de datos de VLAN (vlan.dat) en la memoria Flash. Este documento muestra un ejemplo de configuración para el módulo ESW.

Los módulos ES tienen sus propios procesadores, motores de conmutación y memoria Flash que se ejecutan independientemente de los recursos del router del host. Después de instalar el módulo ES en el router, puede conectar la consola al módulo ES en el router del host. A continuación, puede crear las VLAN y configurar las VLAN, el árbol de expansión, VTP, etc. en el módulo ES. Los módulos ES se basan en la plataforma Catalyst 3750.

Configuración

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Utilice Command Lookup Tool (sólo para clientes registrados) para obtener más información acerca de los comandos utilizados en esta sección.

Diagrama de la red

En este documento se utiliza la siguiente configuración de red:

ether-switch-nm-config-1.gif

Configuraciones

En este documento se utilizan las siguientes configuraciones:

Configuración de las interfaces VLAN

De forma predeterminada, todos los puertos pertenecen a VLAN1. Puede crear VLAN solamente en el modo de base de datos de VLAN. Después de crear VLAN en el modo de base de datos de VLAN, el archivo vlan.dat se crea y se almacena en el sistema de archivos Flash del router. Puede ver las VLAN utilizando el comando show vlan-switch. En este ejemplo, el servidor de protocolo de configuración de host dinámico (DHCP) (172.16.10.20) está en la VLAN 10. El comando ip helper-address se configura en todas las VLAN, excepto en la VLAN 10, para obtener la dirección IP desde el servidor DHCP para los dispositivos localizados en esas VLAN.

Router1


Create VLANs


Router1#vlan database
Router1(vlan)#vlan 10
VLAN 10 added:
    Name: VLAN0010
Router1(vlan)#vlan 51
VLAN 51 added:
    Name: VLAN0051
Router1(vlan)#vlan 50
VLAN 50 added:
    Name: VLAN0050
Router1(vlan)#vlan 100
VLAN 100 added:
    Name: VLAN0100
Router1(vlan)#vlan 200
VLAN 200 added:
    Name: VLAN0200
Router1(vlan)#exit
APPLY completed.
Exiting....
Router1#



Configure VLANs


Router1(config)#interface vlan 10
Router1(config-if)#ip address 172.16.10.1 255.255.255.0

Router1(config-if)#interface vlan 50
Router1(config-if)#ip address 172.16.50.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 51
Router1(config-if)#ip address 172.16.51.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 100
Router1(config-if)#ip address 172.16.100.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 200
Router1(config-if)#ip address 172.16.200.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1#show vlan-switch

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/2, Fa1/3, Fa1/4, 
                                                Fa1/5, Fa1/6, Fa1/7, Fa1/8,
                                                Fa1/9, Fa1/10, Fa1/11, Fa1/12
                                                Fa1/13, Fa1/14, Fa1/15
10   VLAN0010                         active    
50   VLAN0050                         active    
51   VLAN0051                         active    
100  VLAN0100                         active    
200  VLAN0200                         active    
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
10   enet  100010     1500  -      -      -        -    -        0      0   
50   enet  100050     1500  -      -      -        -    -        0      0   
51   enet  100051     1500  -      -      -        -    -        0      0   
100  enet  100100     1500  -      -      -        -    -        0      0   

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
200  enet  100200     1500  -      -      -        -    -        0      0   
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0   
1005 trnet 101005     1500  -      -      1        ibm  -        0      0   

Configuración de VTP, tronco, canal de puerto y árbol de expansión

De forma predeterminada, el modo VTP es el servidor y el nombre del dominio está en blanco. VTP puede configurarse solamente en el modo de base de datos de VLAN. El único modo de árbol de expansión compatible es PVST+. La encapsulación troncal predeterminada es dot1q. Al configurar el puerto troncal para que admita solamente VLAN específicas, puede aparecer un mensaje de error que indique Bad VLAN allowed list(Lista incorrecta de VLAN admitidas). En este caso, puede que tenga que admitir las VLAN 1-2 predeterminadas, 1002-1005 junto con su lista de VLAN personalizadas. Por esta razón, también tiene que admitir las VLAN predeterminadas y las VLAN personalizadas en el switch vecino conectado al puerto troncal para evitar incoherencias troncales.

Router1


VTP Configuration


Router1#vlan database
Router1(vlan)#vtp transparent
Setting device to VTP TRANSPARENT mode.
Router1(vlan)#vtp domain LAB
Changing VTP domain name from NULL to LAB
Router1(vlan)#exit
APPLY completed.
Exiting....



Spanning-Tree Configuration


Router1(config)#spanning-tree vlan 1 root primary
Router1(config)#spanning-tree vlan 10 root primary
Router1(config)#spanning-tree vlan 50 root primary
Router1(config)#spanning-tree vlan 51 root primary
Router1(config)#spanning-tree vlan 100 root primary
Router1(config)#spanning-tree vlan 200 root primary



Trunk and Port Channel Configuration


Router1(config)#interface port-channel 1
Router1(config-if)#switchport mode trunk

!--- dot1q is the default encapsulation.

Router1(config-if)#switchport trunk allowed vlan 100,200
Command rejected: Bad VLAN allowed list. You have to include all default vlans,
e.g. 1-2,1002-1005.
Command rejected: Bad VLAN allowed list. You have to include all default vlans,
e.g. 1-2,1002-1005.
Router1(config-if)#switchport trunk allowed vlan 1,1002-1005,100,200
Router1(config-if)#exit

Router1(config)#interface range fastEthernet 1/0 - 1
Router1(config-if-range)#switchport mode trunk

!--- dot1q is the default encapsulation.

Router1(config-if-range)#switchport trunk allowed vlan 1,1002-1005,100,200
Router1(config-if-range)#channel-group 1 mode on
Router1(config-if-range)#exit

Access1


Access1 Switch Configuration


Access1(config)#vlan 100,200
Access1(config-vlan)#exit

Access1(config)#vtp mode transparent
Setting device to VTP TRANSPARENT mode.

Access1(config)#vtp domain LAB
Changing VTP domain name from NULL to LAB

Access1(config)#interface port-channel 1
Access1(config-if)#switchport trunk encapsulation dot1q
Access1(config-if)#switchport mode trunk
Access1(config-if)#switchport trunk allowed vlan 1,1002-1005,100,200
Access1(config-if)#exit

Access1(config)#interface range FastEthernet 0/1 - 2
Access1(config-if-range)#switchport trunk encapsulation dot1q
Access1(config-if-range)#switchport mode trunk
Access1(config-if-range)#switchport trunk allowed vlan 1,1002-1005,100,200
Access1(config-if-range)#channel-group 1 mode on
Access1(config-if-range)#exit

Router1#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 52
Number of existing VLANs        : 10
VTP Operating Mode              : Transparent
VTP Domain Name                 : LAB
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x8D 0x71 0x37 0x29 0x6C 0xB0 0xF2 0x0E
Configuration last modified by 172.22.1.197 at 2-20-07 22:31:06
Router1#
Router1#show interface fastethernet 1/0 trunk

Port      Mode         Encapsulation  Status        Native vlan
Fa1/0     on           802.1q         trunk-inbndl  1
                                      (Po1)

Port      Vlans allowed on trunk
Fa1/0     1,100,200,1002-1005

Port      Vlans allowed and active in management domain
Fa1/0     1,100,200

Port      Vlans in spanning tree forwarding state and not pruned
Fa1/0     1,100,200
Router1#show spanning-tree summary
Root bridge for: VLAN1, VLAN10, VLAN50, VLAN51, VLAN100, VLAN200.
PortFast BPDU Guard is disabled
UplinkFast is disabled
BackboneFast is disabled

Name                 Blocking Listening Learning Forwarding STP Active
-------------------- -------- --------- -------- ---------- ----------
VLAN1                0        0         0        1          1
VLAN10               0        0         0        1          1
VLAN50               0        0         0        1          1
VLAN51               0        0         0        1          1
VLAN100              0        0         0        1          1
VLAN200              0        0         0        1          1
-------------------- -------- --------- -------- ---------- ----------
             6 VLANs 0        0         0        6          6

Configuración de puertos de acceso

La configuración de puertos de acceso es similar a la configuración del switch LAN estándar.

Router1


Port for Server Configuration


Router1(config)#interface fastEthernet 1/2
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 10
Router1(config-if)#spanning-tree portfast
Router1(config-if)#speed 100
Router1(config-if)#duplex full
Router1(config-if)#exit



Port for Printer Configuration


Router1(config)#interface fastethernet 1/3
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 51
Router1(config-if)#spanning-tree portfast
Router1(config-if)#exit

Configuración de puerto de voz

La configuración de puerto de voz es similar a la configuración del switch LAN estándar.

Router1


Configure the port for Voice

Router1(config)#interface fastethernet 1/4
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 51
Router1(config-if)#switchport voice vlan 50
Router1(config-if)#spanning-tree portfast
Router1(config-if)#mls qos trust cos

Configuración de la calidad del servicio (QoS)

Ésta es la configuración predeterminada de QoS en el módulo ESW:

Router1#show wrr-queue bandwidth
WRR Queue  :   1   2   3   4

Bandwidth  :   1   2   4   8
wrr-queue bandwidth is disabled

Router1#show wrr-queue cos-map
CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  2  3  3  4  4
wrr-queue cos map is disabled

Router1#show mls qos maps cos-dscp
   Cos-dscp map:
        cos:   0  1  2  3  4  5  6  7
     --------------------------------
       dscp:   0  8 16 26 32 46 48 56

Router1#show mls qos maps dscp-cos

   Dscp-cos map:
       dscp:   0  8 10 16 18 24 26 32 34 40 46 48 56
     -----------------------------------------------
        cos:   0  1  1  2  2  3  3  4  4  5  5  6  7

Estas secciones explican las siguientes configuraciones:

Configuración de colas wrr

No puede configurar QoS basada en puertos en los puertos de switch de la capa 2. Las colas sólo se pueden configurar desde una configuración global. El ejemplo de configuración asigna los valores de CoS a las cuatro colas distintas. Cuando un paquete entra en el motor de la capa 2 directamente desde un puerto de switch, se coloca en una de las cuatro colas del búfer dinámico de 32 MB de memoria compartida. Cualquier paquete portador de voz que provenga de los teléfonos IP de Cisco de la VLAN de voz, se sitúa automáticamente en la prioridad más alta (cola 4) en función del valor de 802.1p (CoS 5) generado por el teléfono IP. A continuación, las colas se atienden según un ordenamiento cíclico ponderado (WRR). El control de tráfico, que utiliza un valor de CoS o tipo de servicio (ToS) de 3, se ubica en la cola 3.

Router1

Router1(config)#wrr-queue cos-map 1 0 1
Router1(config)#wrr-queue cos-map 2 2
Router1(config)#wrr-queue cos-map 3 3 4
Router1(config)#wrr-queue cos-map 4 5 6 7

!--- wrr-queue cos-map <queue-number> <cos values separated by space>

Router(config)#wrr-queue bandwidth 1 16 64 255

!--- wrr-queue bandwidth <Weight of Queue1> <Weight of Queue2> 
!--- <Weight of Queue3> <Weight of Queue4>

Verifique los parámetros de cola:

Router1#show wrr-queue bandwidth
WRR Queue  :   1   2   3   4

Bandwidth  :   1   2   4   8 

!--- Default values


WRR Queue  :   1   2   3   4

Bandwidth  :   1  16  64 255 

!--- Configured values


Router1#show wrr-queue cos-map
CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  2  3  3  4  4  

!--- Default values

CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  3  3  4  4  4  

!--- Configured values

Esta tabla muestra el número de cola, valor de CoS y el peso de cada cola después de su configuración.

Número de cola

Valor de CoS

Peso

1

0 1

1

2

2

16

3

3 4

64

4

5 6 7

255

Configuración de CoS de puerto seguro

Router1

Router1(config)#interface fastethernet1/4
Router1(config-if)#mls qos trust cos

!--- Trust the CoS value of the frames from the IP phone.

Router1(config-if)#mls qos cos override

!--- Reset the CoS value of the frames from PC to 0.

Router1(config-if)#exit

Router1(config)#interface range fastEthernet 1/0 - 1
Router1(config-if-range)#mls qos trust cos

!--- Trust the CoS value of the frames from this trunk link.

Router1(config-if-range)#exit

Configuración del regulador de tráfico

Esta sección muestra la configuración del regulador de tráfico en la interfaz fa1/2 para limitar el tráfico FTP a 5 Mbps.

Router1

Router1(config)#ip access-list extended ACTIVE-FTP
Router1(config-ext-nacl)#permit tcp any any eq ftp
Router1(config-ext-nacl)#permit tcp any any eq ftp-data
Router1(config-ext-nacl)#exit
Router1(config)#class-map ACTIVE-FTP-CLASS
Router1(config-cmap)#match class ACTIVE-FTP
Router1(config-cmap)#exit
Router1(config)#policy-map ACTIVE-FTP-POLICY
Router1(config-pmap)#class ACTIVE-FTP-CLASS
Router1(config-pmap-c)#police 5000000 conform-action transmit exceed-action drop
Router1(config-pmap-c)#exit
Router1(config-pmap)#exit
Router1(config)#interface fastethernet1/2
Router1(config-if)#service-policy input ACTIVE-FTP-POLICY
Router1(config-if)#exit

Existen algunas restricciones en la configuración del regulador de tráfico en los módulos ESW, las cuales se enumeran aquí:

  • No se admiten las asignaciones de políticas con clasificación ACL en la dirección de salida y no pueden asociarse a ninguna interfaz mediante el comando de configuración service-policy input policy-map-name interface.

  • En una asignación de política, la clase denominada class-default no es compatible. El switch no filtra el tráfico en función de la asignación de política definida mediante el comando de configuración class class-default policy-map.

  • Puede crear una asignación de política y aplicarla sólo a la entrada de las interfaces ESW. Y en la asignación de política, sólo es compatible el regulador de tráfico.

    Router1#show policy-map
      Policy Map FINANCE-POLICY
        Class FINANCE-CLASS
          set cos 4
    Router1(config)#interface fastethernet1/4
    Router1(config-if)#service-policy input FINANCE-POLICY
    %Error: FastEthernet1/4 Service Policy Configuration Failed.Only Police Action S
    upported
  • No se admite la regulación del tráfico en una VLAN o nivel de interfaz virtual conmutada (SVI).

Verificación

Actualmente, no hay ningún procedimiento de verificación disponible para esta configuración.

Resolución de problemas

Actualmente, no hay información específica disponible sobre resolución de problemas para esta configuración.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 82156