Tecnología inalámbrica / Movilidad : LAN inalámbrica (WLAN)

Ejemplo de configuración de QoS en controladores para redes LAN inalámbricas y AP ligeros

17 Abril 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (27 Junio 2008) | Comentarios

Contenido

Introducción
Requisitos previos
      Requerimientos
      Componentes utilizados
      Convenciones
Antecedentes
      Mejoras en marcación de paquetes de QoS de capa 3
      Configuración de la red
Configuración
      Configuración de la red inalámbrica para QoS
      Configuración de la red alámbrica para QoS
Verificación y resolución de problemas
      Comandos para resolución de problemas
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

Este documento proporciona un ejemplo de configuración que muestra cómo configurar la calidad de servicio (QoS) en una red inalámbrica unificada de Cisco mediante controladores para redes LAN inalámbricas de Cisco (WLC) y puntos de acceso ligeros (LAP).

Requisitos previos

Requerimientos

Asegúrese de que cumple estos requerimientos antes de intentar esta configuración:

  • Tener conocimiento básico acerca de la configuración de LAP y WLC de Cisco

  • Tener conocimiento sobre cómo configurar enrutamientos básicos y QoS en una red alámbrica

Componentes utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware:

  • WLC 2006 de Cisco que ejecuta firmware versión 4.0

  • LAP de la serie 1000 de Cisco

  • Adaptador de cliente inalámbrico 802.11a/b/g de Cisco que ejecuta firmware versión 2.6

  • Router 3725 de Cisco que ejecuta el software Cisco IOS® versión 12.3(4)T1

  • Router 3640 de Cisco que ejecuta el software Cisco IOS versión 12.2(26)

  • Dos switches de la serie 3500 XL de Cisco que ejecutan el software Cisco IOS versión 12.0(5)WC3b

La información que contiene este documento se creó a partir de los dispositivos en un entorno de laboratorio específico. Todos los dispositivos que se utilizan en este documento se iniciaron con una configuración sin definir (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones sobre consejos técnicos de Cisco para obtener más información sobre las convenciones del documento.

Antecedentes

QoS hace referencia a la capacidad de la red para proporcionar un servicio especial o mejor a un conjunto de usuarios o aplicaciones en detrimento de otros usuarios o aplicaciones.

Con QoS, el ancho de banda se administra de manera más eficaz a través de las LAN, incluidas las WLAN y WAN. Así es como QoS proporciona un servicio de red mejorado y confiable:

  • Admite ancho de banda dedicado para aplicaciones y usuarios críticos

  • Controla la fluctuación y la latencia (necesarias para el tráfico a tiempo real)

  • Administra y minimiza la congestión de la red

  • Modela el tráfico de la red para agilizar el flujo de tráfico

  • Establece prioridades del tráfico de red

Anteriormente, las WLAN se utilizaban principalmente para transportar tráfico de aplicaciones de datos de ancho de banda bajo. Actualmente, con la expansión vertical de las WLAN (como en el comercio, las finanzas y la educación) y en los sectores empresariales, las WLAN se utilizan para transportar aplicaciones de datos de ancho de banda alto junto con aplicaciones multimedia sensible al tiempo. Este requisito obliga a utilizar QoS inalámbrico.

El grupo de trabajo IEEE 802.11e del comité de estándares IEEE 802.11 ha creado la definición estándar. Sin embargo, la adopción del estándar 802.11e tiene lugar se encuentra en su primera fase y, tal y como sucede con muchos estándares, existen diferentes componentes opcionales. Tal y como ocurrió con el estándar de seguridad 802.11 en 802.11i, grupos como Wi-Fi Alliance, y líderes de la industria como Cisco, están definiendo los requisitos claves para QoS WLAN a través de sus programas de multimedia Wi-Fi (WMM) y de extensiones compatibles con Cisco (CCX). Esto asegura las características clave y la interoperación a través de sus programas de certificación.

Los productos inalámbricos unificados de Cisco admiten WMM, un sistema de QoS basado en el borrador IEEE 802.11e publicado por Wi-Fi Alliance.

Consulte la sección Cisco Unified Wireless QoS (QoS inalámbrico unificado de Cisco) de Enterprise Mobility Design Guide (Guía de diseño para movilidad empresarial) para obtener más información acerca del funcionamiento de QoS en una red inalámbrica unificada de Cisco.

Este documento proporciona un ejemplo de configuración que muestra cómo configurar QoS en controladores y cómo comunicarse con una red alámbrica configurada con QoS.

Mejoras en marcación de paquetes de QoS de capa 3

La red inalámbrica unificada de Cisco admite el marcado de punto de código de servicios diferenciados (DSCP) del IP de capa 3 de los paquetes que se envían a través de los WLC y LAP. Esta característica mejora el uso que los puntos de acceso (AP) hacen de la información de capa 3 para asegurarse de que los paquetes reciben la prioridad correcta en el aire desde el AP hasta el cliente inalámbrico.

En una arquitectura centralizada de WLAN, los datos WLAN se tunelizan entre el AP y el WLC a través del protocolo de punto de acceso ligero (LWAPP). Para mantener la clasificación QoS original a través de dicho túnel, la configuración QoS del paquete de datos encapsulado deben estar asignada correctamente a los campos de la capa 2 (802.1p) y de la capa 3 (IP DSCP) del paquete de túnel externo.

qos-wlc-lap1.gif

Por ejemplo, cuando un cliente WLAN envía tráfico 802.11e, éste tiene una clasificación de prioridad del usuario (UP) en su trama. El AP necesita asignar esta clasificación 802.11e a un valor DSCP para el paquete LWAPP que lleva la trama. De este modo se asegura de que al paquete se le asigna la prioridad adecuada en su recorrido hacia el WLC. Para los paquetes LWAPP que se dirigen al AP debe realizarse un proceso similar en el WLC. Asimismo, se necesita un mecanismo para clasificar el tráfico de clientes que no son 802.11e, tanto en el AP como en el WLC, de manera que se asigne también la prioridad adecuada a sus paquetes LWAPP. Esta tabla muestra cómo se administran los paquetes en cada dispositivo:

Desde

A

UP (802.1p/802.11e)

IP DSCP

1

Controlador

Punto de acceso

Traduzca el valor DSCP del paquete entrante al valor AVVID 802.1p UP.

Copie el valor DSCP del paquete entrante.

2

Punto de acceso

Cliente inalámbrico

Cliente WMM: traduzca el valor DSCP del paquete LWAPP entrante al valor 802.11e UP. Supervise el valor para asegurarse de que no excede del valor máximo permitido para la política QoS de WLAN asignado a dicho cliente. Coloque el paquete en la cola 802.11 Tx adecuada para el valor UP.

Cliente regular: coloque el paquete en la cola predeterminada 802.11 Tx para la política QoS de WLAN asignada a dicho cliente.

N/A (el valor DSCP original se mantiene)

3

Punto de acceso

Controlador

N/A (los puntos de acceso no admiten etiquetas 802.1Q/802.1p)

Cliente WMM: supervise el valor 802.11e UP para asegurarse de que no excede el valor máximo permitido para la política QoS asignada a dicho cliente; traduzca el valor al valor DSCP.

Cliente regular: utilice el valor 802.11e UP para la política QoS asignada a dicho cliente; traduzca el valor al valor DSCP.

4

Controlador

Switch Ethernet

Traduzca el valor DSCP de los paquetes LWAPP entrantes al valor AVVID 802.1p UP.

N/A (el valor DSCP original se mantiene)

La siguiente tabla proporciona las traducciones que se producen entre los valores 802.11e/802.1p UP e IP DSCP. Puesto que la arquitectura de voz, video y datos integrados (AVVID) de Cisco define la traducción de 802.1 UP a IP DSCP, y el IEEE define la traducción de IP DSCP a 802.11e UP, se deben utilizar dos conjuntos de traducciones diferentes.

Tipo de tráfico basado en Cisco AVVID 802.1p UP

Cisco AVVID IP DSCP

Cisco AVVID 802.1p UP

IEEE 802.11e UP

Notas

Control de red

-

7

-

Reservado sólo para control de red

Control de interconexión

48

6

7 (AC_VO)

Control de LWAPP

Voz

46 (EF)

5

6 (AC_VO)

Controlador: perfil platino de QoS

Video

34 (AF41)

4

5 (AC_VI)

Controlador: perfil Gold de QoS

Control de voz

26 (AF31)

3

4 (AC_VI)

-

Mejor esfuerzo

0 (BE)

0

3 (AC_BE)

0 (AC_BE)

Controlador: perfil plata de QoS

-

Segundo plano (segundo plano oro de Cisco AVVID)

18 (AF21)

2

2 (AC_BK)

-

Segundo plano (segundo plano plata de Cisco AVVID)

10 (AF11)

1

1 (AC_BK)

Controlador: perfil bronce de QoS

Configuración de la red

En este documento se utiliza la siguiente configuración de red:

  • La red alámbrica está formada por dos routers, Router1 y Router2 que utilizan OSPF entre ellos. Los hosts alámbricos están formados por un servidor FTP (F1), un cliente de voz (V1) y un cliente de video (Vi1). Los hosts alámbricos se conectan a la red a través del switch de capa 2 que se encuentra conectado al Fast Ethernet del router R1.

  • La red inalámbrica se conecta a la red a través del Router2 tal y como muestra el diagrama. Los hosts inalámbricos están formados por un cliente FTP (sin WMM), un cliente de voz V1 (teléfonos 7920) y un cliente de video Vi1 (con WMM activada).

  • La prioridad más alta se debe asignar a los paquetes de voz y, a continuación, a los de video. Los paquetes FTP deben recibir la prioridad más baja.

  • En la red alámbrica, la detección temprana aleatoria ponderada (WRED) se utiliza para implementar la QoS. Los diferentes tipos de tráfico se clasifican y priorizan de acuerdo con los valores DSCP. La WRED se implementa en los paquetes priorizados.

  • En la red inalámbrica, se deben crear tres WLAN para cada tipo de tráfico y para activar los perfiles QoS adecuados.

    • WLAN 1—Clientes FTP: perfil bronce de QoS

    • WLAN 2—Clientes de video: perfil Gold de QoS

    • WLAN 3—Clientes de voz: perfil platino de QoS

Es necesario configurar los dispositivos para conectividad IP básica y activación QoS en la red alámbrica e inalámbrica.

qos-wlc-lap4.gif

Configuración

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Utilice la herramienta Command Lookup Tool (sólo para clientes registrados) para obtener más información acerca de los comandos utilizados en este documento.

Para configurar los dispositivos con esta configuración, es necesario llevar a cabo los siguientes pasos:

Configuración de la red inalámbrica para QoS

Antes configurar QoS en los WLC, debe configurar el WLC para funcionamiento básico y registrar los LAP para el WLC. En este documento se asume que el WLC está configurado para el funcionamiento básico y que los LAP están registrados en el WLC. Si es un usuario nuevo que intenta configurar el WLC para el funcionamiento básico con los LAP, consulte Registro de AP ligero (LAP) en un controlador para redes LAN inalámbricas (WLC) (en inglés).

Una vez que se han registrado los LAP en el WLC, complete los siguientes pasos para establecer los LAP y el WLC conforme a esta configuración:

  1. Configure las WLAN para las diferentes clases de tráfico.

  2. Active los perfiles QoS para las WLAN.

Complete estos pasos para crear una WLAN en el WLC para clientes de voz:

  1. Haga clic en WLANs en la interfaz gráfica de usuario del controlador para crear una WLAN.

  2. Haga clic en New (Nueva) para configurar una WLAN nueva.

    En este ejemplo, la WLAN se llama VoiceClients y su ID es 1.

  3. Haga clic en Apply (Aplicar).

    qos-wlc-lap5.gif

  4. En la ventana WLANs > Edit (WLANs > Editar), defina los parámetros específicos de la WLAN VoiceClients (Clientes de voz).

    1. Para la WLAN, elija la interfaz adecuada del campo Interface Name (Nombre de interfaz).

      Este ejemplo asigna la interfaz Voice (Voz) a la WLAN VoiceClients (Clientes de voz).

    2. En el menú desplegable Quality of Service (QoS) (Calidad de servicio), elija el perfil QoS adecuado para la WLAN.

      En este ejemplo, se ha seleccionado el perfil de QoS Platinum (Platino). Este perfil ofrece la prioridad más alta a la WLAN de voz.

    3. Para el parámetro 7920 Phone Support (Soporte de teléfonos 7920), elija el tipo de control de admisión de llamadas (CAC).

      Este ejemplo utiliza AP CAC Limit (Límite CAC en AP).

    4. Seleccione el resto de parámetros, que depende de los requisitos de diseño.

      Este ejemplo utiliza valores predeterminados.

    5. Haga clic en Apply (Aplicar).

      qos-wlc-lap6.gif

      Nota: No active el modo WMM si la red utiliza teléfonos 7920 de Cisco. No puede activar los modos WMM y CAC controlado por el cliente de forma simultánea en la misma WLAN. Cuando se activa un CAC controlado por AP, el AP envía un elemento de información (IE) de CAC patentado por Cisco y no envía el IE QBSS estándar.

La implementación de una infraestructura de voz por WLAN implica mucho más que simplemente proporcionar QoS en una WLAN. Una WLAN de voz necesita tener en cuenta requisitos de cobertura de estudio del sitio, el comportamiento del usuario, los requisitos de roaming y el control de admisión. Este tema se trata en Cisco Wireless IP Phone 7920 Design and Deployment Guide (Guía de diseño e implementación del teléfono IP inalámbrico 7920 de Cisco).

De manera similar puede crear las WLAN para los clientes de video y los clientes FTP. Los clientes de video se asignan a la interfaz dinámica de video y los clientes FTP a la interfaz dinámica FTP. A continuación se muestran las capturas de pantalla correspondientes:

Nota: Este documento no explica cómo crear VLAN en WLC. Consulte Ejemplo de configuración de VLAN en controladores para redes LAN inalámbricas (en inglés) para obtener más información acerca de cómo configurar interfaces dinámicas en WLC.

qos-wlc-lap7.gif

qos-wlc-lap8.gif

Nota: Aunque los clientes WLAN admiten WMM, no significa que el tráfico de cliente se beneficie de WMM de manera automática. Las aplicaciones buscan beneficiarse de WMM asignan una clasificación de prioridad adecuada a su tráfico y el sistema operativo necesita pasar dicha clasificación a la interfaz WLAN. En dispositivos diseñados para ese fin, tales como auriculares VoWLAN, esto se realiza como parte del diseño. Sin embargo, si se implementa en una plataforma general, como un PC, la clasificación del tráfico de la aplicación y el soporte OS deben estar implementados antes de poder utilizar correctamente las características de WMM.

Para los clientes de video, se selecciona el perfil Gold de QoS y se activa WMM. Para los clientes FTP, se selecciona el perfil bronce de QoS y WMM se desactiva, ya que en este ejemplo los clientes FTP no admiten WMM.

qos-wlc-lap9.gif

qos-wlc-lap10.gif

Nota: Cuando el controlador está en el modo de capa 2 y WMM está desactivado, debe colocar los AP en un puerto troncal para permitirles incorporarse al controlador.

Ejecute estos comandos para configurar las WLAN y QoS en el WLC mediante la CLI:

  • Ejecute el comando config wlan create <id-wlan> <nombre-wlan> para crear una nueva WLAN. En id-wland introduzca un valor entre 1 y 16. En nombre-wlan introduzca un SSID que no supere los 31 caracteres alfanuméricos.

  • Ejecute el comando config wlan enable <id-wlan> para activar una WLAN.

  • Ejecute el comando config wlan qos id-wlan {bronze | silver | gold | platinum} para asignar un nivel de QoS a una WLAN.

  • Ejecute el comando config wlan wmm {disabled | allowed | required} id-wlan para activar el modo WMM.

  • Ejecute el comando config wlan 7920-support client-cac-limit {enabled | disabled} id-wlan para teléfonos que requieren CA controlada por cliente.

  • Ejecute el comando config wlan 7920-support ap-cac-limit {enabled | disabled} id-wlan para teléfonos que requieren CAC controlado por AP.

Configuración de la red alámbrica para QoS

Para configurar la red alámbrica en esta configuración, debe configurar los routers para conectividad básica y activar QoS en la red alámbrica. OSPF se utiliza como protocolo de enrutamiento de unidifusión.

La característica WRED se utiliza para implementar QoS en una red alámbrica. La característica DiffServ Compliant WRED permite a WRED utilizar el valor DSCP al calcular la probabilidad de caída de un paquete.

Éstas son las configuraciones de los routers R1 y R2:

Router1

Router1#show run
Building configuration...

Current configuration : 2321 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
!
ip subnet-zero
!
!
!
call rsvp-sync
!

!
class-map match-all FTP

!--- Classifies FTP Packets based on Access List 103.

  match access-group 103
class-map match-all Video

!--- Classifies Video Packets based on Access List 102.

  match access-group 102
class-map match-all Voice

!--- Classifies Voice Packets based on Access List 101.

  match access-group 101
!
!
policy-map Marking-For-FTP

!--- Sets DSCP value af11 for FTP packets.

  class FTP
   set ip dscp af11
policy-map Marking-For-Voice

!--- Sets DSCP value ef for Voice packets.

  class Voice
   set ip dscp ef
policy-map Marking-For-Video

!--- Sets DSCP value af41 for Video packets.

  class Video
   set ip dscp af41
!
!
!
interface Serial2/0
 description Connected to Router2
 ip address 10.2.3.2 255.255.255.0
 random-detect dscp-based

!--- Enables WRED based on DSCP Value of the packet.

 random-detect dscp 10 30 40

!--- Sets the Minimum and Maximum Threshold of Packets
!--- to 30 and 40 packets for the DSCP value 10.

 random-detect dscp 34 40 50

!--- Sets the Minimum and Maximum Threshold of Packets
!--- to 40 and 50 packets for the DSCP value 34.

 random-detect dscp 46 50 60

!--- Sets the Minimum and Maximum Threshold of Packets
!--- to 50 and 60 packets for the DSCP value 46.

 clockrate 56000
!
interface Serial2/1
 no ip address
 shutdown
!
interface Serial2/2
 no ip address
 shutdown
!
interface Serial2/3
 no ip address
 shutdown
!
interface Serial2/4
 no ip address
 shutdown
!
interface Serial2/5
 no ip address
 shutdown
!
interface Serial2/6
 no ip address
 shutdown
!
interface Serial2/7
 no ip address
 shutdown
!
interface FastEthernet3/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet3/0.1
 description Connected to Voice Clients
 encapsulation dot1Q 10
 ip address 192.168.0.1 255.255.0.0
 service-policy output Marking-For-Voice

!--- Applies the policy Marking-For-Voice to the interface.

!
interface FastEthernet3/0.2
 description Connected to Video Clients
 encapsulation dot1Q 20
 ip address 172.16.0.1 255.255.0.0
 service-policy output Marking-For-Video

!--- Applies the policy Marking-For-Video to the interface.

!
interface FastEthernet3/0.3
 description Connected to FTP Server
 encapsulation dot1Q 30
 ip address 30.0.0.1 255.0.0.0
 service-policy output Marking-For-FTP

!--- Applies the policy Marking-For-FTP to the interface.

!
interface FastEthernet3/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1

!--- Configures OSPF as the routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 30.0.0.0 0.0.0.255 area 0
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.0.0 0.0.255.255 area 0
!
ip classless
ip http server
!
access-list 101 permit ip 192.168.0.0 0.0.255.255 any

!--- Access list used to classify Voice packets.

access-list 102 permit ip 172.16.0.0 0.0.255.255 any

!--- Access list used to classify Video packets.

access-list 103 permit ip 30.0.0.0 0.0.0.255 any

!--- Access list used to classify FTP packets.

!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 destination-pattern 4085551234
 port 1/0/0
!
!
line con 0
line aux 0
line vty 0 4
!
end

Router2

Router2#show run
Building configuration...

Current configuration : 1551 bytes
!
version 12.3
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!

!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 description Connected to Voice Clients
 encapsulation dot1Q 40
 ip address 20.0.0.1 255.0.0.0
!
interface FastEthernet0/0.2
 description Connected to Video Clients
 encapsulation dot1Q 50
 ip address 40.0.0.1 255.0.0.0
!
interface FastEthernet0/0.3
 description Connected to FTP Clients
 encapsulation dot1Q 60
 ip address 50.0.0.1 255.0.0.0
!
interface Serial0/0
 description Connected to Router1
 ip address 10.2.3.1 255.255.255.0
 random-detect dscp-based

!--- Enables WRED based on DSCP Value of the packet.

 random-detect dscp 10 30 40

!--- Sets the Minimum and Maximum Threshold of Packets
!--- to 30 and 40 packets for the DSCP value 10.

 random-detect dscp 34 40 50

!--- Sets the Minimum and Maximum Threshold of Packets
!--- to 40 and 50 packets for the DSCP value 34.

 random-detect dscp 46 50 60

!--- Sets the Minimum and Maximum Threshold of Packets
!--- to 50 and 60 packets for the DSCP value 46.

!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Service-Engine2/0
 no ip address
 shutdown
 hold-queue 60 out
!
router ospf 1

!--- Configures OSPF as the routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 20.0.0.0 0.255.255.255 area 0
 network 40.0.0.0 0.255.255.255 area 0
 network 50.0.0.0 0.255.255.255 area 0
!
ip http server
ip classless
!
!
control-plane
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
gatekeeper
 shutdown
!
!
line con 0
line 65
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line aux 0
line vty 0 4
!
!
end

Verificación y resolución de problemas

Una vez que se han configurado las redes inalámbricas y alámbricas para conectividad básica y se ha implementado QoS, los paquetes se clasifican, marcan y envían de acuerdo con las políticas configuradas para cada tipo de tráfico.

En una red ligeramente cargada, puede que no se detecte la aplicación de las características QoS. Las características QoS comienzan a afectar al rendimiento de la aplicación a medida que la carga de la red aumenta. QoS intenta mantener la latencia, la fluctuación y la pérdida en los tipos de tráfico seleccionados dentro de unos límites aceptables.

Para clientes de video con WMM:

Cuando un cliente de video del lado alámbrico envía datos a un cliente video del lado inalámbrico, ocurre lo siguiente:

  1. En la interfaz FastEthernet del Router1, la política Marking-For-Video se aplica a los paquetes de video y dichos paquetes se marcan con el valor DSCP AF41.

  2. Los paquetes de video marcados pasan a través de las interfaces en serie S3/0 en Router1 y S0/0 en Router2. Aquí es donde la probabilidad de caída del paquete se coteja con el umbral configurado para WRED. Cuando la longitud media de la cola alcanza el umbral mínimo (40 paquetes en este caso para paquetes de video) WRED descarta de manera aleatoria algunos paquetes con AF41 como valor DSCP. De manera similar, cuando la longitud media de la cola excede el umbral máximo (50 paquetes en este caso para paquetes de video), WRED descarta todos los paquetes con AF41 como valor DSCP.

  3. Una vez que los paquetes de video alcanzan el WLC a través de fastethernet en Router2, el WLC traduce el valor DSCP del paquete entrante a un valor AVVID 802.1p UP y copia el valor DSCP del paquete entrante en el paquete LWAPP, como se muestra a continuación. En este ejemplo, el valor DSCP AF41 se traduce al correspondiente valor 4 de 802.1p.

    qos-wlc-lap11.gif

  4. Cuando el paquete alcanza el LAP, éste traduce el valor DSCP del paquete LWAPP entrante por el valor 802.11e UP y controla dicho valor para asegurarse de que no exceda del valor máximo permitido para la política QoS de WLAN asignada a dicho cliente. A continuación, el LAP coloca el paquete en la cola 802.11 Tx adecuada para el valor UP. En este ejemplo, el valor DSCP AF41 se traduce al correspondiente valor 5 de 802.11e UP.

    qos-wlc-lap12.gif

Cuando un cliente de video del lado inalámbrico envía datos al lado alámbrico, ocurre lo siguiente:

  1. Cuando un cliente WMM envía un paquete al LAP, el LAP controla el valor 802.11e UP para asegurarse de que no exceda del valor máximo permitido para la política QoS asignada a dicho cliente. A continuación, traduce el valor al valor DSCP. En este ejemplo, la WLAN de video se ha configurado de acuerdo con el perfil Gold de QoS, con el valor 4 de 802.11e UP. Este valor se traduce al correspondiente valor DSCP AF41 y se envía al controlador.

    qos-wlc-lap13.gif

  2. El controlador traduce el valor DSCP del paquete LWAPP entrante al valor 802.1p UP tal y como se muestra, y el valor DSCP original se envía sin ninguna alteración.

    qos-wlc-lap14.gif

  3. Los paquetes con un valor af41 de DSCP en la fasthernet del Router2 pasan a través de las interfaces en serie del Router2 y del Router1 y alcanzan a los clientes de video del lado alámbrico. Cuando el paquete atraviesa las interfaces en serie, la probabilidad de caída del paquete se coteja con el umbral configurado para WRED.

Para clientes FTP sin WNN:

Cuando el servidor FTP del lado alámbrico envía datos al cliente FTP del lado inalámbrico, ocurre lo siguiente:

  1. En la interfaz FastEthernet del Router1, la política Marking-For-FTP se aplica a los paquetes de FTP y dichos paquetes se marcan con el valor DSCP AF11.

  2. Los paquetes de FTP marcados pasan a través de las interfaces en serie S3/0 en Router1 y S0/0 en Router2. Aquí es donde la probabilidad de caída del paquete se coteja con el umbral configurado para WRED. Cuando la longitud media de la cola alcanza el umbral mínimo (30 paquetes en este caso para paquetes de FTP) WRED descarta de manera aleatoria algunos paquetes con AF11 como valor DSCP. De manera similar, cuando la longitud media de la cola excede el umbral máximo (40 paquetes en este caso para paquetes de FTP), WRED descarta todos los paquetes con AF11 como valor DSCP.

  3. Una vez que los paquetes FTP alcanzan el WLC a través de fastethernet en Router2, el WLC traduce el valor DSCP del paquete entrante a un valor AVVID 802.1p UP y copia el valor DSCP del paquete entrante en el paquete LWAPP, como se muestra a continuación. En este ejemplo, el valor AF11 de DSCP se traduce al correspondiente valor 1 de 802.1p.

  4. Cuando el paquete alcanza el LAP, éste coloca el paquete en la cola 802.11 Tx predeterminada para la política QoS de WLAN asignada a dicho cliente. En este ejemplo, el paquete se coloca en la cola de acuerdo con el perfil bronce de QoS.

Cuando un cliente de FTP del lado inalámbrico envía datos al lado alámbrico, ocurre lo siguiente:

  1. Cuando un cliente FTP de la red inalámbrica envía un paquete al LAP, éste utiliza el valor 802.11e UP para la política QoS asignada a dicho cliente. A continuación, el LAP traduce el valor al valor DSCP y envía el paquete al controlador. Puesto que el cliente FTP pertenece al perfil bronce de QoS, el valor 1 de IEEE 802.11e UP se traduce al valor AF11 de DSCP.

  2. El controlador traduce el valor DSCP del paquete LWAPP entrante al valor 802.1p UP tal y como se muestra, y el valor DSCP original se envía sin ninguna alteración. A continuación, el paquete se reenvía a Router2 a través del switchde capa 2.

  3. Los paquetes con un valor de DSCP AF11 en la fasthernet del Router2 pasan a través de las interfaces en serie del Router2 y del Router1 y alcanzan a los clientes de video del lado alámbrico. Cuando el paquete atraviesa las interfaces en serie, la probabilidad de caída del paquete se coteja con el umbral configurado para WRED.

Un proceso similar tiene lugar cuando un paquete de voz pasa de una red alámbrica a una inalámbrica y viceversa.

Comandos para resolución de problemas

La herramienta Output Interpreter (Intérprete de resultados) (OIT) (sólo para clientes registrados) admite determinados comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Nota: Consulte Información importante sobre comandos de depuración (en inglés) antes de utilizar los comandos de depuración.

Puede ejecutar estos comandos de Cisco IOS en los routers para llevar a cabo la resolución de problemas y verificar la configuración QoS:

  • show queue {nombre-interfaz número-interfaz}: muestra información acerca de los paquetes que esperan en una cola de la interfaz.

  • show queueing random-detect interface {nombre-interfaz número-interfaz}: muestra información de configuración y estadísticas relacionadas con la herramienta de cola de una interfaz.

  • show policy-map interface {nombre-interfaz número-interfaz}: muestra las estadísticas y la configuración de las políticas de entrada y salida asociadas a una interfaz. Asegúrese de que utiliza este comando en modo EXEC adecuado.

    Router1#show policy-map interface F3/0.1
     FastEthernet3/0.1
    
      Service-policy output: Marking-For-Voice
    
        Class-map: Voice (match-all)
          18 packets, 1224 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: access-group 101
          QoS Set
            dscp ef
              Packets marked 18
    
        Class-map: class-default (match-any)
          2 packets, 128 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any
  • debug qos set: muestra información acerca del marcado de paquetes QoS.

En el WLC, ejecute este comando para ver la configuración del perfil QoS:

  • show qos {bronze/silver/gold/platinum}: proporciona información acerca del perfil QoS configurado para las WLAN.

    Aquí se muestra un ejemplo de salida del comando show qos:

    (Cisco Controller) >show qos Platinum
    
    Description...................................... For Voice Applications
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length..................................... 100
    protocol......................................... none
    
    (Cisco Controller) >show qos Gold
    
    Description...................................... For Video Applications
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length.....................................  75
    protocol......................................... none
    
    (Cisco Controller) >show qos Bronze
    
    Description...................................... For Background
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length.....................................  25
    protocol......................................... none
  • show wlan <ID-LAN>: muestra información acerca de la WLAN. Este es un ejemplo de resultado:

    (Cisco Controller) >show wlan 1
    
    WLAN Identifier.................................. 1
    Network Name (SSID).............................. VoiceClients
    Status........................................... Enabled
    MAC Filtering.................................... Disabled
    Broadcast SSID................................... Enabled
    AAA Policy Override.............................. Disabled
    Number of Active Clients......................... 0
    Exclusionlist Timeout............................ 60 seconds
    Session Timeout.................................. 1800 seconds
    Interface........................................ management
    WLAN ACL......................................... unconfigured
    DHCP Server...................................... Default
    DHCP Address Assignment Required................. Disabled
    Quality of Service............................... Platinum (voice)
    WMM.............................................. Disabled
    CCX - AironetIe Support.......................... Enabled
    CCX - Gratuitous ProbeResponse (GPR)............. Disabled
    Dot11-Phone Mode (7920).......................... Disabled
    Wired Protocol................................... None
    IPv6 Support..................................... Disabled
    Radio Policy..................................... All
    Security
    
       802.11 Authentication:........................ Open System
       Static WEP Keys............................... Disabled
       802.1X........................................ Enabled
       Encryption:..................................... 104-bit WEP
       Wi-Fi Protected Access (WPA/WPA2)............. Disabled
       CKIP ......................................... Disabled
       IP Security Passthru.......................... Disabled
       Web Based Authentication...................... Disabled
       Web-Passthrough............................... Disabled
       Auto Anchor................................... Disabled
       H-REAP Local Switching........................ Disabled
       Management Frame Protection................... Enabled (Global MFP Disabled)

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 81831