Voz y Comunicaciones unificadas : Cisco Unified Communications Manager (CallManager)

Error de instalación de revisión para OS de Microsoft en un servidor MCS de Cisco

15 Abril 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (23 Enero 2007) | Comentarios

Contenido

Introducción
Requisitos previos
      Requerimientos
      Componentes utilizados
      Convenciones
Problema
Solución
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

Cuando un usuario intenta instalar la revisión MS06-040 del sistema operativo de Microsoft en un servidor Cisco CallManager, se produce un error en la instalación y aparece el mensaje You do not have permission to update <OS name>. Please contact your system administrator. (No tiene permiso para actualizar <nombre del OS>. Póngase en contacto con el administrador del sistema.) Observe que solamente la instalación de los parches de Microsoft suministrados por Cisco para los servidores Cisco CallManager son compatibles. Puede descargar estos parches en Centro de software de Cisco (en inglés) (sólo para clientes registrados).

Requisitos previos

Requerimientos

No hay requerimientos específicos para este documento.

Componentes utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Cisco CallManager 4.x y posteriores

  • Media Convergence Server (MCS) de la serie 7800 de Cisco que utiliza Microsoft Windows 2000, Microsoft Windows 2003 o Microsoft Windows XP

La información que contiene este documento se creó a partir de los dispositivos en un entorno de laboratorio específico. Todos los dispositivos que se utilizan en este documento se iniciaron con una configuración sin definir (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones sobre consejos técnicos de Cisco para obtener más información sobre las convenciones del documento.

Problema

Cuando un usuario intenta instalar la revisión MS06-040 del Microsoft Windows en un servidor Cisco CallManager 4.x, se produce un error en la instalación y aparece el mensaje You do not have permission to update <OS name>. Please contact your system administrator.

(No tiene permiso para actualizar <nombre del OS>. Póngase en contacto con el administrador del sistema.) Algunas actualizaciones del software de Microsoft utilizan el archivo Update.exe como programa de instalación. Las versiones 5.4.1.0 y posteriores de Update.exe precisan que el usuario que instala la actualización de software sea administrador con unos determinados derechos de usuario. Si un usuario no cuenta con los derechos de usuario necesarios e intenta instalar un paquete de actualización de software que utiliza Update.exe, puede aparecer este mensaje de error. Consulte el artículo 888791 de Microsoft Knowledge Base (Derechos de usuario necesarios para ejecutar Update.exe) leavingcisco.com (en inglés) para obtener información adicional de la configuración.

Nota: Para determinar si una actualización de software utiliza Update.exe como programa de instalación para paquetes de software comercializados después de julio 2004, examine el valor de Installer Engine (Motor instalador) en la ficha Version (Versión) del cuadro de diálogo Properties (Propiedades) del paquete de actualización de software. Para los paquetes comercializados antes de julio de 2004, debe extraer el contenido del paquete para determinar qué instalador se utiliza y qué versión.

Para determinar los derechos de usuario que faltan, examine el archivo de registro de instalación. El archivo de registro de instalación contiene este mensaje de error:

2.744: d:\aab949b8ae7e35434dde6b\update\update.exe (version X.X.X.X)
2.744: Failed To Enable SE_SECURITY_PRIVILEGE
2.754: Setup encountered an error: You do not have permission
to update OS_name. Please contact your system administrator. 
2.764: You do not have permission to update OS_name. 

Nota:  OS_name representa el nombre del sistema operativo, SE_SECURITY_PRIVILEGE representa el derecho que le falta del usuario y X.X.X.X representa el número de versión.

Solución

Para resolver el problema, modifique su cuenta local de administrador con el fin de disponer de los derechos de usuario necesarios. Estos derechos de usuario son necesarios para ejecutar Update.exe.

  • Copia de seguridad de archivos y directorios

  • Restauración de archivos y directorios

  • Administración de registros de seguridad y auditoría

  • Propiedad de archivos u otros objetos

  • Apagado del sistema

  • Depuración de programas

Siga estos pasos en la máquina local para ver y modificar los derechos de usuario.

  1. Seleccione Start > Programs > Administrative Tools > Local Security Policy (Inicio > Programas > Herramientas administrativas > Directiva de seguridad local)

  2. En Security Settings (Ajustes de seguridad), haga clic en Local Policies (Políticas locales) y, a continuación, haga clic en User Rights Assignments (Asignaciones de derechos de usuario).

  3. Para asignar las políticas necesarias enumeradas anteriormente en este documento, haga clic con el botón derecho en la política, haga clic en Security (Seguridad) y, a continuación, agregue el administrador local a la misma. ms-os-patch-mcs-fails-1.gif


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 72030