Voz y Comunicaciones unificadas : Cisco Unity Express

Ejemplo de configuración de interoperabilidad de ACD básica de Cisco CME y Auto-Attendant (AA) de Cisco Unity Express

20 Junio 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (4 Mayo 2007) | Comentarios

Contenidos

Introducción
Requisitos previos
     Requisitos
     Componentes utilizados
     Productos relacionados (opcionales)
     Convenciones
Antecedentes
Configuración
     Diagrama de la red
     Configuraciones
     Notas generales de la configuración de implementación
Escenario 1: Uso de ACD básica de Cisco CME con correo de voz de Cisco Unity Express
     Flujo de llamada
     Notas de configuración del escenario 1
     Configuración de Cisco CME para el escenario 1
     Configuración de Cisco Unity Express para el escenario 1
Escenario 2: Uso de AA de Cisco Unity Express como menú de primer nivel y ACD básica como menú de segundo nivel
     Flujo de llamada del escenario 2
     Notas de configuración del escenario 2
     Configuración de Cisco CME para el escenario 2
     Configuración de Cisco Unity Express para el escenario 2
     Variante 1 de la configuración del escenario 2: GDM individuales por grupo de búsqueda
     Variante 2 de la configuración del escenario 2: GDM individuales por grupo ACD
     Variante 3 de la configuración del escenario 2: Uso de la funcionalidad "drop-through" de ACD
Escenario 3: Uso de ACD básica como menú de primer nivel y AA de Cisco Unity Express como menú de segundo nivel
     Flujo de llamada del escenario 3
     Notas de configuración del escenario 3
     Configuración de Cisco CME para el escenario 3
     Configuración de Cisco Unity Express para el escenario 3
Verificación
Resolución de problemas

Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

En este documento se proporcionan ejemplos de configuración para utilizar las funciones de la distribución automática de llamadas básica (ACD básica) de Cisco CME y Auto-Attendant (AA) de Cisco Unity Express.

Requisitos previos

Requisitos

Es necesario tener experiencia general con las configuraciones de Cisco CME y Cisco Unity Express. Este documento se centra específicamente en las configuraciones de interoperabilidad de ACD básica de Cisco CME y AA de Cisco Unity Express.

A continuación se enumeran las versiones mínimas para las funcionalidades que se describen en este ejemplo de configuración:

  • Cisco CME 3.3

  • Versión 12.4.3 de Cisco IOS

  • Cisco Unity Express 2.1.3

Componentes utilizados

La información de este documento se basa en estas versiones de software y hardware:

  • Un router Cisco 2821 que ejecute Cisco CME y Cisco Unity Express

  • Versión 12.4.3 de Cisco IOS

  • Cisco CME 3.3

  • ACD básica versión de secuencia de comandos 2.1.0.0

  • Cisco Unity Express 2.1.3

  • Conjunto de funciones de Cisco IOS para voz IP

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración despejada (predeterminada). Si la red está en producción, asegúrese de comprender el impacto que pueda tener cualquier comando.

Productos relacionados (opcionales)

Esta configuración se puede utilizar además con los routers Cisco 2600XM, Cisco 3700, Cisco 2800 o Cisco 3800, en la versión 12.4.1 o posterior de Cisco IOS.

Convenciones

Consulte Cisco Technical Tips Conventions (Convenciones sobre consejos técnicos de Cisco) para obtener más información sobre las convenciones del documento.

Antecedentes

En este documento se describen los tres escenarios siguientes:

  • Escenario 1: uso de grupos de AA y ACD de Cisco CME con Cisco Unity Express sólo como destino del correo de voz

  • Escenario 2: uso de Cisco Unity Express como el punto de entrada principal de AA y AA de Cisco CME como “submenú” dentro de AA

  • Escenario 3: uso de AA de Cisco CME como el punto de entrada principal de AA y AA de Cisco Unity Express para proporcionar “anuncios” flexibles como parte de AA

El escenario 1 es idóneo para aplicarse cuando AA de Cisco CME se limita a proporcionar un menú para dirigir las llamadas a grupos ACD. En este escenario, Cisco CME se utiliza como el destino de AA para las llamadas entrantes, mientras que Cisco Unity Express se usa exclusivamente como servidor del correo de voz cuando los agentes ACD no están disponibles o no contestan a las llamadas en una cantidad determinada de tiempo. No se utiliza AA de Cisco Unity Express.

El escenario 2 es la configuración general más flexible para integrar ACD básica de Cisco CME y AA de Cisco Unity Express. El diseño utilizado en el escenario 2 incluye AA de Cisco Unity Express para la automatización general de la administración de llamadas y la administración de llamadas a agentes ACD. En este escenario, Cisco Unity Express se utiliza como el destino de AA para las llamadas entrantes; además, Cisco Unity Express proporciona una gama de opciones de menú para quien realice la llamada, por ejemplo, marcado por nombre o extensión, y segmentos de información grabada. Una de estas opciones dirige algunas llamadas a los grupos ACD de Cisco CME. El correo de voz de Cisco Unity Express se utiliza de forma similar al escenario 1.

El escenario 3 es una variante del 1, ya que AA de Cisco CME se utiliza como el destino de AA para las llamadas entrantes y la ACD es la función principal requerida por AA. Sin embargo, AA de Cisco Unity Express se utiliza como un “servidor de anuncios” con AA de Cisco CME. De este modo, es posible añadir algunos anuncios (como la ubicación y el horario de la oficina) que no están disponibles cuando se utiliza sólo AA de Cisco CME.

Nota: los procedimientos de configuración basados en la interfaz gráfica del usuario que facilita esta publicación se emplean para ilustrar los procesos de implementación asociados con este ejemplo de configuración y para resumir los pasos necesarios para implementar las funciones descritas en todo el documento. No obstante, no se facilitan procedimientos paso a paso. Esta publicación presupone un determinado nivel de experiencia de trabajo con las interfaces gráficas de usuario de Cisco CME y Cisco Unity Express, además de conocimientos sobre la CLI de Cisco IOS. Consulte la guía del administrador, guía de configuración y referencia de comandos correspondientes de Cisco CME y Cisco Unity Express, si desea información explícita de procedimientos y uso de comandos.

Configuración

En esta sección se presenta la información para configurar las funciones descritas en este documento.

Nota: emplee la herramienta de búsqueda de comandos ( sólo para clientes registrados) para obtener más información sobre los comandos utilizados en esta sección.

Diagrama de la red

Este documento utiliza esta configuración de red:

Figura 1 - Diagrama de red de ACD básica de Cisco CME y AA de Cisco Unity Express

135345.jpg

Configuraciones

Los tres escenarios de configuración presentan las características generales siguientes:

  • Sistema Cisco CME de un único sitio.

  • Troncales PSTN integradas en el router de Cisco CME.

  • La configuración define un plan de marcado de 4 dígitos con extensiones de teléfono IP en el rango de 2000 a 2010, extensiones sin teléfono (como los grupos de búsqueda) en el rango de 2020 a 2099, y puntos de entrada de Cisco Unity Express en el rango 21 xx.

  • Se definen nueve teléfonos IP, con las extensiones 2000-2009.

  • La configuración de ACN utiliza tres grupos de búsqueda con tres teléfonos IP en cada uno.

  • Se definen dos recepcionistas, que también forman parte de los nueve teléfonos IP en los grupos ACD.

La configuración de la red utiliza un router Cisco 2821 con las características siguientes:

  • Acceso a la red IP a través de la dirección IP b .168.1.1.

  • La configuración de Cisco CME con nueve teléfonos IP, cada uno con una extensión de 4 dígitos (2001-2010).

  • NM-CUE.

  • Dirección IP de Cisco Unity Express a .1.11.2.

Este documento usa estas configuraciones:

Notas generales de la configuración de implementación

La conectividad PSTN utilizada en esta configuración se efectúa a través de la troncal de una oficina de intercambio remota (FXO). Si tiene una troncal PRI, las configuraciones tendrán exactamente el mismo aspecto que las descritas en los ejemplos de configuración incluidos en esta publicación, con la adición de las siguientes entradas:

controller T1 2/1
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
interface Serial2/1:23
 no ip address
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
voice-port 2/1:23
!
dial-peer voice 777 pots
 incoming called-number .
 direct-inward-dial
 port 2/1:23

Las secuencias de comandos de AA de Cisco Unity Express que se utilizan en los ejemplos presentados en esta publicación son muy sencillas y, para mayor claridad, contienen la cantidad mínima de funciones necesaria para lograr la funcionalidad ilustrada en el documento. Las secuencias de comandos de AA de Cisco Unity Express implementadas en una red activa deben tener capacidad para administrar una cantidad significativamente mayor de llamadas entrantes, en comparación con las redes de prueba en laboratorio. Entre los “pasos” adicionales de administración de llamadas se pueden incluir:

  • Mejora del manejo de errores (como cuando la persona que llama pulsa dígitos que no están en el menú)

  • Administración del tiempo de espera (como repetir menús una cantidad fija de veces)

  • Capacidad para bloquear la transferencia externa de llamadas a destinos PSTN externos (para impedir el fraude de cargos de llamada)

Escenario 1: Uso de ACD básica de Cisco CME con correo de voz de Cisco Unity Express

En el escenario 1, las llamadas entrantes se envían a AA de Cisco CME (extensión 2040), que ofrece un saludo de bienvenida y un menú con tres opciones. En función de lo que elija la persona que llama, la llamada se dirige a uno de los tres grupos de búsqueda ACD. Si las llamadas no se responden en el grupo ACD, se reenvían a una casilla de correo de entrega general (GDM) para dejar un mensaje.

En el escenario descrito en esta sección, se emplea una única GDM a fin de que los nueve agentes ACD en los grupos ACD puedan iniciar sesión y recuperar mensajes. En otras variantes, incluidas como partes del escenario 2, se analiza la habilidad de contar con una GDM individual por grupo ACD.

Flujo de llamada

El flujo de llamada de la configuración en esta sección se ilustra en la figura 2.

Figura 2 - Flujo de llamada del escenario 1 de AA de Cisco Unity Express con ACD básica de Cisco CME

135346.jpg

Notas de configuración del escenario 1

Las llamadas PSTN desde el puerto FXO (0/3/0) se terminan de forma automática (a través del comando connection plar-opx 2040) en el número piloto de AA de Cisco CME (2040). AA de Cisco CME presenta un saludo de bienvenida y un menú con tres opciones. El contenido hablado de los mensajes se facilita en la imagen del flujo de llamada de la figura 2. La frase de bienvenida se ha grabado en el archivo Flash en_bacd_welcome.au, mientras que las frases sobre el menú se han grabado en el archivo en_bacd_options_menu.au.

El saludo de la GDM para la extensión 2070 indica lo siguiente: “Thank you for calling customer service; no one is available right now. Please leave a message and we will return your call as soon as we can.” (Gracias por llamar al servicio al cliente, en estos momentos no podemos atenderle. Por favor, deje un mensaje y le devolveremos la llamada lo antes posible.)

Para disponer de un indicador de mensaje en espera (MWI) para los mensajes en la GDM, se debe reenviar AA de Cisco CME (el comando param voice-mail 2070) a una extensión intermedia (2070), lo que produce una acción CFA (reenvío de todas las llamadas) al número piloto del correo de voz (2105). Se realiza este reenvío en lugar de dirigir AA de Cisco CME directamente al número piloto del correo de voz, lo cual se efectuaría con el comando param voice-mail 2105. La extensión 2070 es el botón 2 de los teléfonos de agente, y este botón indica MWI para la GDM, que se asocia con la extensión 2070, en lugar de con los números de los grupos de búsqueda ACD (2020, 2021 o 2022). Los números “finales” no se configuran en los grupos de búsqueda porque la lógica de ACD los omite en favor del número de reenvío de AA (comando param voice-mail).

Nota: siempre que realice un cambio en la secuencia de comandos, necesitará cargar la aplicación.

La secuencia de comandos de AA de Cisco CME se asocia con una dirección IP de bucle de retorno (a .1.1.1), para garantizar que la secuencia de comandos del lenguaje de comandos de herramienta (TCL) esté siempre activa, independientemente del estado de las interfaces LAN (comando dial-peer voice 2040 voip). Se utiliza un par de marcado adosado para dirigir las llamadas al punto de entrada de AA de Cisco CME AA (2040) para asegurarse de que las personas que efectúan llamadas PSTN (así como con teléfonos IP locales) puedan llamar a AA (comando dial-peer voice 2041 voip).

Configuración de Cisco CME para el escenario 1

Los siguientes pasos resumen la configuración de Cisco CME para el escenario 1:

  1. Elija Configure / System Parameters para configurar que los tres grupos de búsqueda ACD, 2020, 2021 y 2022, estén asociados con tres opciones de menú de AA de Cisco CME. Vea la figura 3.

    Figura 3 - Especificación de grupos de búsqueda ACD de Cisco Unity Express

    135352.jpg

  2. Elija Configure > System Parameters para configurar los detalles del grupo de búsqueda 2020 con los agentes 2001, 2002 y 2003. Vea la figura 4.

    Figura 4 - Configuración de datos del grupo de búsqueda 2020

    135353.jpg

  3. Elija Configure > Phones y haga clic en la dirección MAC del teléfono que desea modificar. Aparecerá la ventana Change Phone (vea la figura 5).

  4. Introduzca la extensión 2070 en el teléfono del agente ACD para tener MWI con los mensajes incluidos en la GDM.

    Figura 5 - Asociación de la extensión con un botón específico

    135354.jpg

A continuación se presenta la configuración completa (y comentada) de la CLI del router de Cisco CME para el escenario 1 resultante de los cambios específicos realizados en la configuración base.

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1
   default-router b.168.1.1
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!

               !--- Defina los parámetros para la secuencia de comandos TCL para ACD de Cisco CME.
!--- Los grupos de búsqueda para
!--- ACD son 2020, 2021 y 2022.
            
!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2022
  param queue-len 30
 !

               !--- Defina los parámetros para la secuencia de comandos TCL para AA de Cisco CME.
!--- El número piloto es 2040.
!--- El destino del correo de voz es la extensión 2070,
!--- que reenvía todas las llamadas (CFA) al correo de voz (2105).
            
!
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!

               !--- Defina la dirección de bucle de retorno a la que está conectada la secuencia de comandos TCL.
            
!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!

               !--- Las llamadas PSTN se terminan de forma automática en el número piloto 2040 de AA de Cisco CME.
            
!
voice-port 0/3/0
 connection plar opx 2040
!
voice-port 0/3/1
 connection plar opx 2040
!
voice-port 0/3/2
!
voice-port 0/3/3
!

               !--- Las llamadas al número piloto 2040 de AA de Cisco CME se asocian con una dirección de bucle de retorno
!--- a.1.11.1 para garantizar que la secuencia de comandos TCL esté siempre activa.
            
!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!

               !--- El par de marcado adosado para el número piloto
!--- 2040 de AA de Cisco CME señala la
!--- secuencia de comandos TCL de AA y garantiza que todas
!--- las llamadas internas y PSTN lleguen a AA.
            
!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!

               !--- Todas las llamadas en el rango 21xx se envían a Cisco Unity Express.
            
!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit
 time-webedit
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!

               !--- La sección siguiente muestra nueve extensiones de agentes ACD.
            
!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  7  dual-line
 number 2007
 name User27
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  8  dual-line
 number 2008
 name User28
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  9  dual-line
 number 2009
 name User29
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!

               !--- La extensión 2070 está asociada con la GDM.
!--- Esta extensión se utiliza para tener MWI
!--- en el teléfono de los agentes ACD.
            
!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!

               !--- La sección siguiente muestra definiciones de teléfonos para los nueve agentes ACD.
!--- Ephone-dn 11 (2070) se define como el botón 2 en cada teléfono,
!--- para que todos los agentes puedan tener MWI para la GDM.
            
!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:11
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:11
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:11
!

               !--- Las secuencias de comandos de ACD utilizan tres grupos de búsqueda.
!--- Hay tres agentes en cada grupo.
            
!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
ephone-hunt 3 longest-idle
 pilot 2022
 list 2007, 2008, 2009
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

Configuración de Cisco Unity Express para el escenario 1

Los siguientes pasos resumen la configuración de Cisco Unity Express para el escenario 1:

  1. Elija Configure > Groups. A continuación, haga clic en el grupo (custservice) que desea editar. Aparecerá la ventana Group Profile (vea la figura 6).

  2. De forma predeterminada, aparece la ficha Profile. Configure el grupo custservice asociado con la extensión 2070.

    Figura 6 - Configuración del perfil de grupo

    142424.jpg

  3. Haga clic en la ficha Owners/Members (vea la figura 7).

  4. Configure los miembros (los nueve usuarios de agentes ACD) del grupo custservice.

    Figura 7 - Configuración de miembros del grupo

    135356.jpg

A continuación se presenta la configuración completa (y comentada) de la CLI de Cisco Unity Express para el escenario 1 resultante de los cambios específicos realizados en la configuración base.

cue#show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1
groupname Administrators create
groupname Broadcasters create
!

               !--- El grupo custservice se define como todos los
!--- usuarios con acceso a la GDM.
            
!
groupname custservice create
!

               !--- Nueve agentes ACD se definen como usuarios.
            
!
username admin create
username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
username user27 create
username user28 create
username user29 create
!

               !--- El grupo custservice (y, por tanto, GDM)
!--- se asocia con la extensión 2070.
            
!
groupname custservice phonenumber "2070"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
username user27 phonenumber "2007"
username user28 phonenumber "2008"
username user29 phonenumber "2009"
groupname Administrators member admin
!

               !--- Nueve usuarios de agentes ACD son miembros del grupo
!--- custservice, así que pueden tener acceso
!--- a la GDM para recuperar mensajes.
            
!
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname custservice member user27
groupname custservice member user28
groupname custservice member user29
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
!

               !--- AA está definido en el sistema Cisco Unity Express
!--- de forma predeterminada, pero
!--- no se utiliza en este escenario.
            
!
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "false"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
!

               !--- Defina la GDM asociada con 2070,
!--- relacionada con el grupo custservice.
            
!
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
!

               !--- Defina casillas de correo personal para nueve agentes ACD.
            
!
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000
description "user26 mailbox"
end mailbox
voicemail mailbox owner "user27" size 3000
description "user27 mailbox"
end mailbox
voicemail mailbox owner "user28" size 3000
description "user28 mailbox"
end mailbox
voicemail mailbox owner "user29" size 3000
description "user29 mailbox"
end mailbox
end

Escenario 2: Uso de AA de Cisco Unity Express como menú de primer nivel y ACD básica como menú de segundo nivel

En el escenario 2, las llamadas entrantes se envían al AA personalizado de Cisco Unity Express (número piloto 2100), que ofrece un saludo de bienvenida y un menú con cuatro opciones. En función de la opción que elija la persona que llame, la llamada se envía a ACD de Cisco CME (opción 1), uno de los dos anuncios (opciones 2 y 3) o a una casilla de correo general (GDM para la extensión 2080) asociada con los recepcionistas (opción 4).

Si la persona que llama elige la opción 1, la llamada se transfiere a ACD de Cisco CME, donde el AA de Cisco CME ofrece un menú de segundo nivel similar al escenario 1.

Flujo de llamada del escenario 2

El flujo de llamada de la configuración en esta sección se ilustra en la figura 8.

Figura 8 - Flujo de llamada del escenario 2

135360.jpg

Notas de configuración del escenario 2

Las llamadas PSTN desde el puerto FXO (0/3/0) se terminan de forma automática en AA de Cisco Unity Express (2100).

El AA personalizado de Cisco Unity Express (archivo S10_Main_Menu.wav) proporciona el menú de primer nivel: “Thank you for calling Widget Systems; press 1 for customer service; press 2 for office location; press 3 for office hours; press 4 to leave a voice message.” (Gracias por llamar a Widget Systems; para servicio al cliente, pulse 1; para ubicación de oficina, pulse 2; para horario de oficina, pulse 3; para dejar un mensaje, pulse 4).

Los archivos de mensajes de AA de Cisco CME proporcionan el menú de segundo nivel: “To help redirect your call: Press 1 for hardware-related questions; press 2 for software-related questions; press 3 for general questions.” (Para que podamos transferir su llamada: preguntas relacionadas con hardware, pulse 1; preguntas relacionadas con software, pulse 2; preguntas generales, pulse 3). La primera frase (“To help redirect your call”) se incluye en el archivo Flash en_bacd_welcome.au, mientras que el resto de las instrucciones siguen igual que en la configuración del escenario 1 y están en el archivo Flash en_bacd_options_menu.au.

Puede omitir el saludo de bienvenida de Cisco CME si graba un pequeño archivo vacío o si elimina el archivo flash del router (lo cual hace que el software Cisco CME omita el saludo). En el ejemplo del escenario 2 descrito en esta sección, las frases de menú asociadas con los archivos de mensajes de Cisco Unity Express y Cisco CME se han estructurado para fluir como un único AA a la persona que llama. También se puede omitir el AA de Cisco CME por completo (el saludo de bienvenida y la lista de opciones) por medio del comando param drop-through-option number, con lo que se transfiere una llamada directamente a la ACD de Cisco CME y se omite el AA de Cisco CME.

La extensión 2080 y la GDM asociada se añaden a la configuración para proporcionar una casilla de correo general a los recepcionistas. Para registrar esta casilla de correo, elija la opción 4 del menú de primer nivel. Toda la casilla se administra dentro de Cisco Unity Express. La extensión 2080 se ha añadido a los teléfonos IP 2001 y 2004; se trata de teléfonos asociados con dos empleados que son recepcionistas (además de agentes ACD).

Si la persona que llama elige 1 en el menú de primer nivel y se transfiere a los grupos ACD, pero la llamada sigue sin responderse, ésta se reenvía a la extensión 2070, que es la GDM para los agentes ACD.

Configuración de Cisco CME para el escenario 2

Los siguientes pasos resumen la configuración de Cisco CME para el escenario 2:

  1. Elija Configure > Phones. A continuación, haga clic en la dirección MAC del teléfono que desea modificar. Aparecerá la ventana Change Phone (vea la figura 9).

  2. Introduzca la extensión 2080 para el botón 3 del teléfono del recepcionista, mientras que la GDM de ACD sigue en el botón 2. Con esta configuración, el empleado obtiene MWI para el recepcionista y las casillas de correo GDM de ACD.

    Figura 9 - Adición de un botón de extensión al teléfono del recepcionista

    135361.jpg

A continuación se presenta la configuración completa (y comentada) de la CLI del router de Cisco CME para el escenario 2 resultante de los cambios específicos realizados en la configuración base.

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1
   default-router b.168.1.1
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2022
  param queue-len 30
 !
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!

               !--- Las llamadas PSTN se terminan de forma automática en el número piloto 2100 de AA de Cisco CME.
            
!
voice-port 0/3/0
 connection plar opx 2100
!
voice-port 0/3/1
 connection plar opx 2100
!
voice-port 0/3/2
!
voice-port 0/3/3
!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit
 time-webedit
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  7  dual-line
 number 2007
 name User27
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  8  dual-line
 number 2008
 name User28
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  9  dual-line
 number 2009
 name User29
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!

               !--- La extensión 2080 está asociada con la GDM del recepcionista.
!--- Esta extensión se usa para tener MWI en los teléfonos de los recepcionistas.
            
!
ephone-dn  10
 number 2080
 description Reception GDM
 name Reception GDM
 call-forward all 2105
!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!

               !--- Ephone-dn 10 (2080) se define como el botón 3 en
!--- los teléfonos 2001 y 2004, para que
!--- los recepcionistas (ephones 1 y 4) tengan MWI para la GDM.
            
!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11 3:10
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11 3:10
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:11
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:11
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:11
!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
ephone-hunt 3 longest-idle
 pilot 2022
 list 2007, 2008, 2009
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

Configuración de Cisco Unity Express para el escenario 2

Los siguientes pasos resumen la configuración de Cisco Unity Express para el escenario 2:

  1. Abra la utilidad de editor de secuencia de comandos de Cisco Unity Express y cree la secuencia de comandos personalizada de Cisco Unity Express. Vea la figura 10.

    Figura 10 - Configuración de la secuencia de comandos de AA de Cisco Unity Express para el menú de primer nivel

    135362.jpg

  2. Elija Voice Mail > Auto Attendant y asocie la secuencia de comandos (S10_CUE-AA-BACD-script.aef) con el número piloto 2100. Vea la figura 11.

    Figura 11 - Asociación de la secuencia de comandos con un número piloto

    135363.jpg

  3. Grabe todos los mensajes para la secuencia de comandos de AA. Se puede efectuar la grabación desconectado y cargando los archivos .wav en Cisco Unity Express con el nombre correcto, o bien, por medio de AVT (administración a través de telefonía).

  4. (Opcional) Si utiliza AVT, Cisco Unity Express asigna un nombre de archivo genérico que puede cambiar más tarde al nombre que desee. Elija Voice Mail > Prompts y haga clic en el nombre de archivo del sistema.

  5. (Opcional) Edite los nombres de archivo como sea necesario en este cuadro de diálogo y haga clic en OK. La ventana Voice Mail / Prompts muestra ahora los nombres de archivo correctos en la lista (vea la figura 12).

    Figura 12 - Lista de mensajes para la secuencia de comandos de AA

    135364.jpg

  6. Elija Voice Mail > Auto Attendant y abra el AA generado en el paso 1. Seleccione Script Parameters y asocie los nombres de archivo de mensaje con el parámetro correspondiente en la secuencia de comandos.

  7. Elija Configure > Groups y haga clic en el grupo (recepción) que desea modificar. Aparecerá la ventana Group Profile (vea la ventana parcial en la parte superior de la figura 13). De forma predeterminada, aparece la ficha Profile.

  8. Haga clic en la ficha Owners/Members para configurar los miembros.

    Figura 13 - Definición del grupo de recepción

    142217.jpg

A continuación se presenta la configuración completa (y comentada) de la CLI de Cisco Unity Express para el escenario 2 resultante de los cambios específicos realizados en la configuración base.

cue#show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1

               !--- Agregue el grupo reception.
            
!
groupname Administrators create
groupname Broadcasters create
groupname custservice create
groupname reception create
username admin create

username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
username user27 create
username user28 create
username user29 create
!

               !--- El grupo reception (y, por tanto, GDM) está asociado con la extensión 2080.
            
!
groupname custservice phonenumber "2070"
groupname reception phonenumber "2080"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
username user27 phonenumber "2007"
username user28 phonenumber "2008"
username user29 phonenumber "2009"
!

               !--- Haga miembro al grupo reception.
            
!
groupname Administrators member admin
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname custservice member user27
groupname custservice member user28
groupname custservice member user29
groupname reception member user21
groupname reception member user24
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast

               !--- Defina una programación de negocio para AA de lunes a viernes, de 09:00 a 17:00.
            
!
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "true"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
!

               !--- Agregue la secuencia de comandos de AA para el menú de primer nivel.
            
!
ccn application s10-cue-aa-bacd
 description "s10-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s10-cue-aa-bacd-script.aef"
 parameter "S10_StoreHours" "S10_StoreHours.wav"
 parameter "S10_CustomerService" "2040"
 parameter "S10_GDM" "2080"
 parameter "S10_StoreLocation" "S10_StoreLocation.wav"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
!

               !--- Asocie la secuencia de comandos personalizada de AA con el número piloto 2100.
            
!
ccn trigger sip phonenumber 2100
 application "s10-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
!

               !--- Agregue la GDM para reception
            
!
voicemail mailbox owner "reception" size 3000
 description "Receptionists mailbox"
 end mailbox
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000
description "user26 mailbox"
end mailbox
voicemail mailbox owner "user27" size 3000
description "user27 mailbox"
end mailbox
voicemail mailbox owner "user28" size 3000
description "user28 mailbox"
end mailbox
voicemail mailbox owner "user29" size 3000
description "user29 mailbox"
end mailbox
end

Variante 1 de la configuración del escenario 2: GDM individuales por grupo de búsqueda

La configuración del escenario principal descrito en las secciones anteriores define una única GDM para todos los mensajes que han dejado las personas que han llamado en los tres grupos ACD (soporte de hardware, soporte de software y preguntas generales). Puede que este nivel no sea lo suficientemente detallado para algunas situaciones, porque es posible que los agentes de un grupo (por ejemplo, el soporte de software) no quieran pasar por los mensajes dejados para los grupos de soporte general y de hardware antes de encontrar los mensajes relativos al soporte de software. Si el volumen de mensajes es elevado, puede tener una casilla de correo independiente para cada grupo ACD.

Con grupos de búsqueda de Cisco CME normales (cuando no se utiliza ACD), puede definir una casilla de correo independiente para cada uno si asocia las GDM individuales con los números de grupos de búsqueda (2020, 2021, 2022) y señala el destino “final” del grupo de búsqueda en el correo de voz, como se indica en los ejemplos de configuración siguientes.

Configuración de Cisco CME para la variante 1 del escenario 2

A continuación se presentan variantes de la configuración de Cisco CME para obtener GDM individuales:

ephone-hunt 1 sequential
 pilot 2020
 list 2001, 2002, 2003
 final 2105
 timeout 10
!
!
ephone-hunt 2 sequential
 pilot 2021
 list 2004, 2005, 2006
 final 2105
 timeout 10
!
!
ephone-hunt 3 sequential
 pilot 2022
 list 2007, 2008, 2009
 final 2105
 timeout 10

Configuración de Cisco Unity Express para la variante 1 del escenario 2

Los siguientes pasos resumen la configuración de los grupos y las GDM en Cisco Unity Express para la variante 1 del escenario 2:

  1. Se definen los grupos individuales en Cisco Unity Express para cada uno de los tres grupos de búsqueda. Elija Configure > Groups para definir grupos. Vea la figura 14.

    Figura 14 - Definición de grupos individuales

    135357.jpg

  2. En Configure > Groups, haga clic en el grupo (hardware) que desea modificar. Aparecerá la ventana de la ficha Profile (vea la parte superior de la figura 15).

    Figura 15 - Configuración de grupos específicos

    135358.jpg

  3. Elija la ficha Owners/Members (vea parte inferior de la figura 15) y haga clic en la casilla de verificación situada a la izquierda para seleccionar propietarios y miembros.

    A continuación se presentan variantes de la configuración de Cisco Unity Express para obtener GDM individuales:

    groupname hardware create
    groupname software create
    groupname general create
    groupname hardware phonenumber "2020"
    groupname software phonenumber "2021"
    groupname general phonenumber "2022"
    groupname hardware member user21
    groupname hardware member user22
    groupname hardware member user23
    groupname software member user24
    groupname software member user25
    groupname software member user26
    groupname general member user27
    groupname general member user28
    groupname general member user29
    voicemail mailbox owner "general" size 5520
     description "general mailbox"
     end mailbox
    voicemail mailbox owner "hardware" size 5520
     description "Hardware mailbox"
     end mailbox
    voicemail mailbox owner "software" size 5520
     description "software mailbox"
     end mailbox

Variante 2 de la configuración del escenario 2: GDM individuales por grupo ACD

La configuración resumida en la sección “Variante 1 de la configuración del escenario 2: GDM individuales por grupo de búsqueda” presenta dos inconvenientes.

  • Sólo funciona si se llama directamente a los grupos de búsqueda (extensiones 2020, 2021 y 2022), no si los grupos de búsqueda se utilizan como una ACD cuando se llama al número piloto de ACD (2040).

  • No facilita ningún método para proporcionar MWI a los agentes, porque los miembros de los grupos de búsqueda no se pueden introducir en los teléfonos como botones.

A fin de solucionar estos dos inconvenientes, puede utilizar la secuencia de comandos del sistema xfermailbox en Cisco Unity Express. Defina tres grupos en Cisco Unity Express (para hardware, software y general) y asocie cada uno con una extensión provisional (como 2030, 2031 y 2032), las cuales se pueden colocar como botones y aparecerán en el teléfono de un agente (y, por tanto, proporcionará MWI). Esta configuración de grupos, extensiones y teléfonos se resume en la tabla 2.

Agente

Extensión

Número del grupo de búsqueda

Grupo ACD

Casilla de correo de grupo

user21

2001

2020

Hardware

2030

user22

2002

2020

Hardware

2030

user23

2003

2020

Hardware

2030

user24

2004

2021

Software

2031

user25

2005

2021

Software

2031

user26

2006

2021

Software

2031

user27

2007

2022

General

2032

user28

2008

2022

General

2032

user29

2009

2022

General

2032

El flujo de llamada ajustado para esta configuración modificada se ilustra en la figura 16.

Figura 16 - Flujo de llamada ajustado para la variante de la secuencia de comandos xfermailbox

135359.jpg

Para dirigir las llamadas a GDM individuales en Cisco Unity Express, es necesaria una secuencia de comandos personalizada que utilice la secuencia de comandos del sistema xfermailbox. Las llamadas a ACD de Cisco CME sólo se pueden enviar a Cisco Unity Express por medio del comando param voice-mail number (no se pueden utilizar los destinos finales individuales en los grupos de búsqueda para flujos de llamada ACD). Este comando envía una extensión única a Cisco Unity Express para su entrada en una casilla de correo (extensión 2070 en configuraciones anteriores). Cisco Unity Express no distingue qué grupo de búsqueda es el destino deseado y no puede determinar cuál de las tres GDM introducir.

Por el contrario, dirija el destino del correo de voz de ACD de Cisco CME a un número piloto de Cisco Unity Express (2110) que introduzca una secuencia de comandos (s12-xfer-to-mbox.aef). Este número piloto proporciona un menú al usuario en el que se ofrecen los grupos para los que se puede dejar un mensaje (hardware, software o general). El contenido de este menú aparece en la parte inferior del flujo de llamada de la figura 16. Según la respuesta de la persona que llama, la variable mbox se establece en la extensión adecuada (2030, 2031 o 2032) y la llamada se transfiere (a través de la secuencia de comandos del sistema xfermailbox) a una de las tres GDM.

Los pasos asociados con la modificación de la configuración del escenario 2 para administrar los cambios de configuración apuntados en la tabla 2 y la figura 16 se describen en los pasos siguientes:

  1. Abra la utilidad de editor de secuencia de comandos de Cisco Unity Express y escriba una secuencia de comandos personalizada de Cisco Unity Express denominada s12-xfer-to-mbox.aef. Vea la figura 17.

    Figura 17 - Ventana para crear una secuencia de comandos personalizada de Cisco Unity Express

    135347.jpg

  2. Elija Voice Mail > Auto Attendant. Vea la figura 18. Agregue un nuevo Auto-Attendant y asócielo con la secuencia de comandos elaborada en el paso 1.

  3. Asocie la secuencia de comandos personalizada s12-xfer-to-mbox.aef de Cisco Unity Express con el número piloto 2110. Vea la figura 18.

    Figura 18 - Asociación de la secuencia de comandos personalizada de Cisco Unity Express con un número piloto

    135348.jpg

  4. Grabe el mensaje (en este caso denominado S12_Main_Menu.wav) para la nueva secuencia de comandos de AA. Se puede efectuar la grabación desconectado y cargando el archivo .wav en Cisco Unity Express con el nombre correcto, o bien, por medio de AVT (administración a través de telefonía).

  5. (Opcional) Si utiliza AVT, Cisco Unity Express asigna un nombre de archivo genérico que puede cambiar más tarde al nombre que desee. Elija Voice Mail > Prompts y haga clic en el nombre de archivo del sistema.

  6. (Opcional) Edite el nombre de archivo como sea necesario en este cuadro de diálogo y haga clic en OK. La ventana Voice Mail / Prompts muestra ahora el nombre de archivo correcto en la lista (vea la figura 19).

  7. Elija Voice Mail > Auto Attendant y abra el AA creado en el paso 2. Seleccione Script Parameters y asocie el nombre de archivo de mensaje con el parámetro correspondiente en la secuencia de comandos.

    Figura 19 - Lista de mensajes grabados

    135349.jpg

  8. Seleccione Configure > Extension para definir que las extensiones 2030, 2031 y 2032 se asocien con las GDM. Vea la figura 20.

    Figura 20 - Definición de extensiones para asociar las GDM con grupos de búsqueda de ACD

    135350.jpg

  9. Elija Configure > Phones y haga clic en la dirección MAC del teléfono que desea modificar. Aparecerá la ventana Change Phone (vea la figura 21).

  10. Agregue botones para 2030, 2031 o 2032 en los teléfonos de los agentes ACD para proporcionar MWI.

    Figura 21 - Ventana que muestra la adición de botones

    135351.jpg

A continuación se presenta la configuración comentada de la CLI del router de Cisco CME con cambios y adiciones en la configuración de Cisco CME con respecto a la configuración del escenario base asociado con la sección “Configuración de Cisco CME para el escenario 2”.

            
               !--- Establezca el destino del correo de voz de AA de Cisco CME
!--- en 2110, el punto de entrada de la secuencia de comandos de
!--- Cisco Unity Express para la función de transferencia a la casilla de correo.
            
!
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2110
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!

               !--- Defina que las extensiones de grupo (2030, 2031 y 2032)
!--- se utilicen con aspectos de botón en los teléfonos de los
!--- agentes para que puedan obtener MWI para las GDM.
!--- Coloque la extensión en CFA
!--- para que nunca suenen y no molesten a los agentes.
            
!
ephone-dn  12
 number 2030
 description HW Cust Svc Mbox
 name HW Cust Svc Mbox
 call-forward all 2110
!
ephone-dn  13
 number 2031
 description SW Cust Svc Mbox
 name SW Cust Svc Mbox
 call-forward all 2110
!
ephone-dn  14
 number 2032
 description Gen Cust Svc Mbox
 name Gen Cust Svc Mbox
 call-forward all 2110
!

               !--- Agregue el aspecto de un botón de la extensión
!--- de grupo correcta a cada uno de
!--- los teléfonos de agentes ACD.
            
!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:12 3:10
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:12
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:12
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:13 3:10
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:13
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:13
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:14
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:14
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:14

A continuación se presenta la configuración comentada de la CLI de Cisco Unity Express con los cambios y adiciones en la configuración con respecto a la configuración del escenario base asociado con la sección “Configuración de Cisco Unity Express para el escenario 2” y los cambios anteriores en la interfaz gráfica de usuario:

            
               !--- Defina los tres grupos nuevos, Hardware, Software y General.
            
!
groupname hardware create
groupname software create
groupname general create
!

               !--- Defina que los nuevos grupos (y, por tanto, GDM) se asocien con
!--- las extensiones 2030, 2031 y 2032.
            
!
groupname hardware phonenumber "2030"
groupname software phonenumber "2031"
groupname general phonenumber "2032"
!

               !--- Defina el estado de miembro de los grupos Hardware, Software y General.
            
!
groupname hardware member user21
groupname hardware member user22
groupname hardware member user23
groupname software member user24
groupname software member user25
groupname software member user26
groupname general member user27
groupname general member user28
groupname general member user29
!

               !--- Defina la secuencia de comandos personalizada de AA que
!--- se ramificará a la secuencia de comandos del sistema xfermailbox.aef
!--- cuando la persona que llama seleccione la GDM correcta en el menú.
            
!
ccn application s12-xfer-to-mbox
 description "s12-xfer-to-mbox"
 enabled
 maxsessions 8
 script "s12_cue-aa-bacd-script.aef"
 end application
!

               !--- Defina el número piloto 2110 en la secuencia de comandos personalizada.
            
!
ccn trigger sip phonenumber 2110
 application "s12-xfer-to-mbox"
 enabled
 maxsessions 8
 end trigger
!

               !--- Defina las GDM para cada grupo.
            
!
voicemail mailbox owner "hardware" size 3000
 description "hardware mailbox"
 end mailbox
voicemail mailbox owner "software" size 3000
 description "software mailbox"
 end mailbox
voicemail mailbox owner "general" size 3000
 description "general mailbox"
 end mailbox

Variante 3 de la configuración del escenario 2: Uso de la funcionalidad "drop-through" de ACD

La función "drop-through" de la ACD de Cisco CME se puede utilizar para omitir el menú de AA de Cisco CME y transferir una llamada directamente a la ACD. Con esta función, todo el menú de AA se puede consolidar en la secuencia de comandos de AA de Cisco Unity Express. Aunque esta función necesita configuración adicional en el router de Cisco CME, simplifica el mantenimiento de la secuencia de comandos de AA (menús), en comparación con la división de los menús y las grabaciones de anuncios entre AA de Cisco Unity Express (menú de nivel 1) y AA de Cisco CME (menú de nivel 2).

En la configuración de la variante 3 del escenario 2, ambos niveles del menú de AA se incluyen en la secuencia de comandos de AA de Cisco Unity Express de la siguiente forma:

  • Thank you for calling Widget Systems (Gracias por llamar a Widget Systems)

    • Press 1 for Customer Service (para servicio al cliente, pulse 1)

      • Press 1 for Hardware related questions (preguntas relacionadas con hardware, pulse 1)

      • Press 2 for Software related questions (preguntas relacionadas con software, pulse 2)

      • Press 3 for General questions (preguntas generales, pulse 3)

    • Press 2 for Office location (para ubicación de oficina, pulse 2)

    • Press 3 for Office hours (para horario de oficina, pulse 3)

    • Press 4 to Leave a Voice Message (para dejar un mensaje, pulse 4)

Las opciones del menú de nivel 2 hacen que las llamadas se transmitan de Cisco Unity Express a un número piloto de ACD de Cisco CME para cada uno de estos grupos:

  • Hardware: número piloto 2040 de ACD de Cisco CME

  • Hardware: número piloto 2041 de ACD de Cisco CME

  • General: número piloto 2042 de ACD de Cisco CME

Las configuraciones presentadas anteriormente en este documento definían un único número piloto de ACD (2040). En esta variante, se definen tres números piloto diferentes de ACD de Cisco CME (2040, 2041 y 2042) y se ilustra cómo se puede habilitar la funcionalidad "drop-through". Con esta función, se omite el menú AA de Cisco CME y se especifica una opción concreta que se seguirá (especificada en el comando CLI correspondiente). El sistema actúa como si la persona que llama pulsara la opción especificada estáticamente en la CLI. En este escenario, la configuración de AA de Cisco CME incluye las siguientes adaptaciones:

  • La configuración del número piloto 2040 de ACD incluye el comando param drop-through-option 1

  • La configuración del número piloto 2041 de ACD incluye el comando param drop-through-option 2

  • La configuración del número piloto 2042 de ACD incluye el comando param drop-through-option 3

Configuración de Cisco CME para la variante 3 del escenario 2

Los siguientes pasos resumen la configuración de Cisco CME para la variante 3 del escenario 2:

  1. Agregue la configuración adicional para TCL de ACD y AA de Cisco CME con los números piloto 2040, 2041 y 2042, utilizando la CLI "drop-through".

  2. Agregue los pares de marcado para habilitar el marcado de los nuevos números piloto 2040, 2041 y 2042.

    A continuación se presenta la configuración comentada de la CLI del router de Cisco CME con los cambios y adiciones en la configuración de Cisco CME con respecto al escenario base asociado con la sección “Configuración de Cisco CME para el escenario 2”.

    application
     service acd flash:app-b-acd-2.1.0.0.tcl
      param queue-cme-debugs 1
      param aa-hunt1 2020
      param aa-hunt2 2021
      param number-of-hunt-grps 3
      param aa-hunt3 2022
      param queue-len 30
    !
    
                         !--- Defina la configuración de TCL para el grupo Hardware utilizando el número piloto 2040
    !--- y "drop-through-option 1". La extensión 2030 se asocia con la GDM del grupo
    !--- Hardware, que será el destino del correo de voz.
                      
    !
     service hardware-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param max-time-vm-retry 1
      paramspace english index 0
      param max-time-call-retry 60
      param voice-mail 2030
      param aa-pilot 2040
      param number-of-hunt-grps 1
      paramspace english language en
      param handoff-string hardware-aa
      param call-retry-timer 20
      paramspace english location flash:
      param service-name acd
      param drop-through-option 1
      param second-greeting-time 30
      paramspace english prefix en
    !
    
                         !--- Defina la configuración de TCL para el grupo Software,
    !--- utilizando el número piloto 2041
    !--- y "drop-through-option 2". La extensión 2031 se asocia con la GDM del grupo
    !--- Software, que será el destino del correo de voz.
                      
    !
     service software-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param number-of-hunt-grps 1
      paramspace english index 0
      param handoff-string software-aa
      paramspace english language en
      param call-retry-timer 20
      param service-name acd
      paramspace english location flash:
      param drop-through-option 2
      param second-greeting-time 30
      param max-time-vm-retry 1
      param voice-mail 2031
      paramspace english prefix en
      param max-time-call-retry 60
      param aa-pilot 2041
    !
    
                         !--- Defina la configuración de TCL para el grupo General utilizando el número piloto 2042
    !--- y "drop-through-option 3". La extensión 2032 se asocia con la GDM del grupo
    !--- General, que será el destino del correo de voz.
                      
    !
     service general-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param call-retry-timer 20
      paramspace english index 0
      param max-time-call-retry 60
      param voice-mail 2032
      param service-name acd
      param number-of-hunt-grps 1
      param drop-through-option 3
      paramspace english language en
      param handoff-string general-aa
      param max-time-vm-retry 1
      paramspace english location flash:
      param aa-pilot 2042
      param second-greeting-time 30
      paramspace english prefix en
    !
    
                         !--- Defina los pares de marcado del número piloto 2040 y conecte
    !--- la secuencia de comandos TCL de Hardware a este número.
                      
    !
    dial-peer voice 2040 voip
     destination-pattern 2040
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20400 voip
     service hardware-aa
     incoming called-number 2040
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    
                         !--- Defina los pares de marcado del número piloto 2041 y conecte
    !--- la secuencia de comandos TCL de Software a este número.
                      
    !
    dial-peer voice 2041 voip
     destination-pattern 2041
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20410 voip
     service software-aa
     incoming called-number 2041
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    ¡
    
                         !--- Defina los pares de marcado del número piloto 2042 y conecte
    !--- la secuencia de comandos TCL de General a este número.
                      
    !
    dial-peer voice 2042 voip
     destination-pattern 2042
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20420 voip
     service general-aa
     incoming called-number 2042
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad

Configuración de Cisco Unity Express para la variante 3 del escenario 2

Los siguientes pasos resumen la configuración de Cisco Unity Express para la variante 3 del escenario 2:

  1. Abra la utilidad de editor de secuencia de comandos de Cisco Unity Express y ajuste la secuencia de comandos s10-cue-aa-bacd.aef para que contenga ambos niveles del menú de AA. Vea la figura 22.

    Figura 22 - Configuración de la secuencia de comandos de AA de Cisco Unity Express para ambos niveles de menú

    142220.jpg

  2. Elija Voice Mail > Auto Attendant y asocie la nueva secuencia de comandos (S10A_CUE-AA-BACD-script.aef) con el número piloto 2100. Vea la figura 23.

    Figura 23 - Asociación de la secuencia de comandos con un número piloto

    142221.jpg

  3. Grabe todos los mensajes necesarios para la secuencia de comandos de AA. Se puede efectuar la grabación desconectado y cargando los archivos .wav en Cisco Unity Express con los nombres correctos, o bien, por medio de AVT (administración a través de telefonía).

  4. (Opcional) Si utiliza AVT, Cisco Unity Express asigna un nombre de archivo genérico que puede cambiar más tarde al nombre que desee. Elija Voice Mail > Prompts y haga clic en el nombre de archivo del sistema.

  5. (Opcional) Edite los nombres de archivo como sea necesario en este cuadro de diálogo y haga clic en OK. La ventana Voice Mail / Prompts muestra ahora el nombre de archivo correcto en la lista.

A continuación se presenta la configuración comentada de la CLI de Cisco Unity Express con los cambios y adiciones en la configuración de Cisco Unity Express con respecto a la configuración del escenario base asociado con la sección “Configuración de Cisco Unity Express para el escenario 2”.

            
               !--- Defina un nuevo AA con secuencias de comandos s10a-cue-aa-bacd.aef.
            
!
ccn application s10a-cue-aa-bacd
 description "s10a-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s10a_cue-aa-bacd-script.aef"
 parameter "S10_Hardware" "2040"
 parameter "S10_StoreHours" "S10_StoreHours.wav"
 parameter "S10_Software" "2041"
 parameter "S10_General" "2042"
 parameter "S10_GDM" "2080"
 parameter "S10_StoreLocation" "S10_StoreLocation.wav"
 end application
!

               !--- Asocie el número piloto 2100 de AA con la nueva secuencia de comandos.
            
!
ccn trigger sip phonenumber 2100
 application "s10a-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger

Escenario 3: Uso de ACD básica como menú de primer nivel y AA de Cisco Unity Express como menú de segundo nivel

En el tercer escenario de este documento, las llamadas entrantes se transfieren a AA de Cisco CME (número piloto 2040) de igual forma que en el escenario 1. La única diferencia es que sólo hay dos grupos ACD (hardware y software), mientras que la tercera opción del menú principal es acceder a un anuncio que describe la ubicación y las horas de funcionamiento del almacén.

Nota: no es posible elegir la forma de los anuncios con AA de Cisco CME, sino que es necesaria una secuencia de comandos personalizada de Cisco Unity Express.

Se puede lograr el mismo resultado (desde la perspectiva de la persona que llama) con una variante del escenario 2. El ejemplo del escenario 3 se ofrece para ilustrar otra forma de estructurar la aplicación por medio de la transferencia de una llamada de ACD de Cisco CME a AA de Cisco Unity Express. Probablemente la forma más habitual de generar esta aplicación es por medio de una variante del escenario 2.

Flujo de llamada del escenario 3

El flujo de llamada de la configuración en esta sección se ilustra en la figura 24.

Figura 24 - Flujo de llamada del escenario 3

135510.jpg

Notas de configuración del escenario 3

Las llamadas PSTN desde el puerto FXO (0/3/0) se terminan de forma automática en AA de Cisco CME (2040).

La ACD de Cisco CME sólo tiene dos grupos de agentes (2020 y 2021). La opción 3 del menú se utiliza para transferir la llamada a AA de Cisco Unity Express para el anuncio. En lugar de enumerar una cantidad de grupos de búsqueda, cuando las personas que llaman eligen la opción 3, el sistema transfiere a la persona que llama al número piloto de AA de Cisco Unity Express (2100), por medio del comando param aa-hunt3 2100.

Configuración de Cisco CME para el escenario 3

En el siguiente ejemplo, se muestra la configuración de la CLI para el router de Cisco CME:

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1
   default-router b.168.1.1
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!

               !--- Señale la opción 3 del menú (aa-hunt3) a
!--- AA de Cisco Unity Express (2100).
            
!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2100
  param queue-len 30
 !
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!
voice-port 0/3/0
 connection plar opx 2040
!
voice-port 0/3/1
 connection plar opx 2040
!
voice-port 0/3/2
!
voice-port 0/3/3
!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit
 time-webedit
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

Configuración de Cisco Unity Express para el escenario 3

Los siguientes pasos resumen la configuración de Cisco Unity Express para el escenario 3:

  1. Abra la utilidad de editor de secuencia de comandos de Cisco Unity Express y escriba la secuencia de comandos personalizada de Cisco Unity Express. Vea la figura 25.

    Figura 25 - Secuencia de comandos para ubicación y horario del almacén

    135367.jpg

  2. Grabe el mensaje (en este caso denominado S11_Announcement.wav) para la secuencia de comandos de AA (S11_CUE-AA-BACD-script.aef). Se puede efectuar la grabación desconectado y cargando el archivo .wav en Cisco Unity Express con el nombre correcto, o bien, por medio de AVT (administración a través de telefonía).

  3. (Opcional) Si utiliza AVT, Cisco Unity Express asigna un nombre de archivo genérico que puede cambiar más tarde al nombre que desee. Elija Voice Mail > Prompts y haga clic en el nombre de archivo del sistema.

  4. (Opcional) Edite el nombre de archivo en este cuadro de diálogo y haga clic en OK. La ventana Voice Mail / Prompts muestra ahora el nombre de archivo correcto en la lista (vea la figura 26).

  5. Elija Voice Mail > Auto Attendant y abra el AA creado en el paso 2. Seleccione Script Parameters y asocie el nombre de archivo de mensaje con el parámetro correspondiente en la secuencia de comandos.

    Figura 26 - Ventana con las opciones de mensajes

    135368.jpg

  6. Elija Voice Mail > Auto Attendant y asocie la secuencia de comandos con el número piloto 2100 de AA. Vea la figura 27.

    Figura 27 - Ventana con la asociación de la secuencia de comandos con el número piloto de AA

    135369.jpg

En el siguiente ejemplo se muestra la configuración de CLI para el sistema Cisco Unity Express:

cue#
show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1
groupname Administrators create
groupname Broadcasters create
groupname custservice create
username admin create
username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
groupname custservice phonenumber "2070"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
groupname Administrators member admin
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "true"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
!

               !--- Defina la secuencia de comandos de AA que proporcionará el anuncio.
            
!
ccn application s11-cue-aa-bacd
 description "s11-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s11_cue-aa-bacd-script.aef"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
!

               !--- Asocie la secuencia de comandos con el número piloto 2100 de AA.
            
!
ccn trigger sip phonenumber 2100
 application "s11-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000

description "user26 mailbox"
end mailbox
end

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Resolución de problemas

Actualmente, no hay información específica disponible sobre solución de problemas para esta configuración.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 67907