Voz y Comunicaciones unificadas : Cisco Unified Communications Manager (CallManager)

Ejemplo de configuración de red de voz interactiva para Unified SRST

10 Abril 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (16 Abril 2007) | Comentarios

Introducción

En esta serie de documentos interactivos, se utilizan una oficina central y una sucursal típicas para mostrar algunas de las configuraciones de red de voz más comunes. Este diagrama interactivo permite ver configuraciones de red:

Haga clic para ver las configuraciones y la resolución de problemas.
Haga clic para ver las configuraciones y la resolución de problemas.
Haga clic para ver las configuraciones y la resolución de problemas.
Haga clic para ver las configuraciones y la resolución de problemas.
Haga clic para ver las configuraciones y la resolución de problemas.
Haga clic para ver las configuraciones y la resolución de problemas.
Haga clic para ver las configuraciones y la resolución de problemas.
Haga clic para ver las configuraciones y la resolución de problemas. Haga clic para ver las configuraciones y la resolución de problemas. Haga clic para ver las configuraciones y la resolución de problemas.
Esta imagen es interactiva.
Haga clic en cualquiera de los componentes para ver información sobre la configuración
y la resolución de problemas.

Consulte Estudio de caso de configuración y resolución de problemas de una red de voz interactiva de Unified CallManager para obtener información acerca de los requerimientos que se asumen en esta serie de documentos interactivos.

Configuración

Para que SRST funcione correctamente, debe realizar estas ocho configuraciones:

  1. Creación de una referencia a SRST en CallManager
  2. Configuración del router RTP remoto
  3. Selección de la referencia a SRST en la agrupación de dispositivos remotos
  4. Configuración de pares de marcado para el marcado en modo SRST a la PSTN
  5. Configuración de la clase de restricción (COR) en el router SRST
  6. Configuración de la música en espera (MOH) de multidifusión desde la memoria Flash (opcional)
  7. Comprobación del mantenimiento del marcado de 4 dígitos a la oficina central
  8. Configuración del buzón de voz

Creación de una referencia a SRST en Unified CallManager

Para crear una referencia a SRST en Unified CallManager, siga estos pasos:

  1. Haga clic en System > SRST > Add a New SRST Reference. (Sistema > SRST > Agregar nueva referencia a SRST).
  2. Configure la referencia a SRST tal y como muestra la imagen:



    Nota: La dirección IP debe coincidir con la dirección de origen IP especificada en el router SRST, que es el router RTP en este ejemplo. Esta dirección está configurada en call-manager-fallback. Consulte Configuración del router RTP remoto.

Configuración del router RTP remoto

Para configurar el router RTP remoto, utilice la configuración indicada en este paso.

Nota: La configuración SRST relevante se muestra en negrita.

hostname RTP
!
!
application
global
service alternate default
!

controller T1 0/1
framing esf
linecode b8zs
cablelength short 133
channel-group 0 timeslots 1-24 speed 64
!
controller T1 1/0
framing esf
linecode b8zs
pri-group timeslots 1-2,24 service mgcp

interface Serial0/1:0
no ip address
encapsulation frame-relay
!
interface Serial0/1:0.100 point-to-point
bandwidth 128000
ip address 192.168.10.2 255.255.255.0
frame-relay interface-dlci 100
!
interface Serial1/0:23
no ip address
isdn switch-type primary-ni
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
interface Vlan10
ip address 172.69.103.225 255.255.255.0
ip helper-address 171.69.103.225
!
interface Vlan110
ip address 10.10.10.1 255.255.255.0
ip helper-address 171.69.103.225
!
router eigrp 1
network 10.0.0.0
network 171.69.0.0
network 172.69.0.0
network 192.168.10.0
no auto-summary
!

interface FastEthernet2/0
switchport trunk native vlan 10
switchport mode trunk
switchport voice vlan 110
switchport priority extend cos 0
!
interface FastEthernet2/1
switchport trunk native vlan 10
switchport mode trunk
switchport voice vlan 110
switchport priority extend cos 0
!
interface FastEthernet2/2
switchport trunk native vlan 10
switchport mode trunk
switchport voice vlan 110
switchport priority extend cos 0

!
interface Vlan10
ip address 172.69.103.225 255.255.255.0
ip helper-address 171.69.103.225
!
interface Vlan110
ip address 10.10.10.1 255.255.255.0
ip helper-address 171.69.103.225
!
router eigrp 1
network 10.0.0.0
network 171.69.0.0
network 172.69.0.0
network 192.168.10.0
no auto-summary

voice-port 1/0:23

ccm-manager fallback-mgcp
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 171.69.103.225
mgcp
mgcp call-agent 171.69.103.225 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
no mgcp package-capability fxr-package
mgcp package-capability pre-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
!
mgcp profile default

call-manager-fallback
max-conferences 8 gain -6
ip source-address 10.10.10.1 port 2000
max-ephones 3
max-dn 3
dialplan-pattern 1 9195014... extension-length 4

Selección de la referencia a SRST en la agrupación de dispositivos remotos

Para asegurarse de que el grupo de dispositivos donde se utiliza SRST se ha asignado al recurso de SRST apropiado, siga estos pasos:

  1. Haga clic en System > Device Pool > RTP (Sistema > Agrupación de dispositivos > RTP).
  2. Seleccione la referencia a SRST en la lista desplegable de SRST Reference (Referencia a SRST). En este ejemplo, Cisco3725.


Configuración de pares de marcado para el marcado en modo SRST a la PSTN

Para permitir que los usuarios realicen llamadas PSTN en modo SRST, configure los pares de marcado por voz de igual modo que el plan de marcado de CallManager:

dial-peer voice 123 pots !--- For incoming DID calls
incoming called-number .
direct-inward-dial
port 1/0:23
!
dial-peer voice 911 pots
destination-pattern 911
port 1/0:23
forward-digits 3
!
dial-peer voice 9911 pots
destination-pattern 9911
port 1/0:23
forward-digits 3
!
dial-peer voice 7 pots
destination-pattern 9[2-9]......
port 1/0:23
forward-digits 7
!
dial-peer voice 11 pots
destination-pattern 91[2-9]..[2-9]......
port 1/0:23
forward-digits 11
!
dial-peer voice 9011 pots
destination-pattern 9011T
port 1/0:23
prefix 011
!

Configuración de la clase de restricción (COR) en el router SRST

Para mantener la clase de servicio (CoS) para los usuarios en modo SRST, debe configurar la COR. Para obtener información detallada sobre la operación COR, consulte la sección Dial Plan (Plan de marcado) de Cisco Unified Communications SRND Based on Cisco Unified CallManager 4.x (SRND de Cisco Unified Communications basado en Cisco Unified CallManager 4.x)

Las configuraciones de COR relevantes para este documento se muestran en este resultado:

dial-peer cor custom
name int
name local
name ld
name intl
!
!
dial-peer cor list int
member int
!
dial-peer cor list local
member local
!
dial-peer cor list ld
member ld

!

dial-peer cor list intl
member intl
!
dial-peer cor list Restricted
member int
!
dial-peer cor list LocalCalls
member int
member local
!
dial-peer cor list LongDistance
member int
member local
member ld

!
dial-peer cor list International
member int
member local
member ld
member intl

dial-peer voice 911 pots
corlist outgoing int
destination-pattern 911
port 1/0:23
forward-digits 3
!
dial-peer voice 9911 pots
corlist outgoing int
destination-pattern 9911
port 1/0:23
forward-digits 3
!
dial-peer voice 7 pots
corlist outgoing local
destination-pattern 9[2-9]......
port 1/0:23
forward-digits 7
!
dial-peer voice 11 pots
corlist outgoing ld
destination-pattern 91[2-9]..[2-9]......
port 1/0:23
forward-digits 11

dial-peer voice 9011 pots
corlist outgoing intl
destination-pattern 9011T
port 1/0:23
prefix 011

call-manager-fallback
max-conferences 8 gain -6
ip source-address 10.10.10.1 port 2000
max-ephones 3
max-dn 3
dialplan-pattern 1 19195014... extension-length 4
cor incoming International 1 4001
cor incoming LocalCalls 2 4002
cor incoming LongDistance 3 4003

Configuración de la música en espera (MOH) de multidifusión desde la memoria Flash (opcional)

Para proporcionar MOH en modo SRST, puede configurar la MOH de multidifusión desde la memoria Flash, tal y como se muestra en el resultado de esta sección. Tenga en cuenta que en los teléfonos IP sólo se oye el tono de espera en el modo SRST. Sin embargo, las personas que llamanan por PSTN pueden oír música en espera.

call-manager-fallback
max-conferences 8 gain -6
ip source-address 10.10.10.1 port 2000
max-ephones 3
max-dn 3
dialplan-pattern 1 19195014... extension-length 4
moh music-on-hold
multicast moh 239.1.1.1 port 16384 route 10.10.10.1 172.69.103.225

Para obtener más información sobre las mejores prácticas de MOH, consulte la sección Music on Hold (Música en espera) de Cisco Unified Communications SRND Based on Cisco Unified CallManager 4.x (SRND de Cisco Unified Communications basado en Cisco Unified CallManager 4.x)

Comprobación del mantenimiento del marcado de 4 dígitos a la oficina central

Para mantener el marcado de 4 dígitos para que los usuarios puedan acceder la oficina central durante un error de SRST, debe configurar pares de marcado adicionales, tal y como se muestra en el siguiente resultado:

!
voice translation-rule 1 !--- Appends 14085015 to any called number starting with 5
rule 1 /^5/ /14085015/
!
!
voice translation-profile toHQ
translate called 1

dial-peer voice 5000 pots !--- Maintains 4-digit dialing to head office
translation-profile outgoing toHQ
destination-pattern 5...
port 1/0:23
!

Configuración del buzón de voz

Para obtener información sobre cómo configurar el buzón de voz, consulte estos documentos:

Verificación

Esta sección incluye información para comprobar la configuración. Cisco recomienda realizar esta comprobación fuera de horas de oficina, ya que causará una interrupción en la sucursal remota si SRST no se activa.

  1. Pruebe la configuración de SRST:

    Puede desconectar la interfaz WAN o agregar una ruta estática en null 0 para cualquier paquete IP que venga de Unified CallManager:

    ip route 171.69.103.225 255.255.255.255 null 0

    Precaución: Tenga mucho cuidado al utilizar la ruta estática anterior. Puede tener impacto sobre otros sitios dependiendo del entorno de enrutamiento IP.

    Debe ver aparecer los siguientes mensajes en el router de la sucursal remota (en este ejemplo de configuración, router RTP):
    *Nov 1 06:16:34.707: %IPPHONE-6-REGISTER_NEW: ephone-2:SEP000BBEF9E85E
                         IP:10.10.10.14 Socket:2 DeviceType:Phone has registered.
    *Nov 1 06:16:54.375: %IPPHONE-6-REG_ALARM: 15: Name=SEP00115C0E5EDA
                         Load=7.2(4.0) Last=CM-ICMP-Unreach
    *Nov 1 06:16:54.375: %IPPHONE-6-REGISTER_NEW: ephone-1:SEP00115C0E5EDA
                         IP:10.10.10.12 Socket:1 DeviceType:Phone has registered.
    
  2. Para probar el marcado PSTN, llame a varios números y asegúrese de que se mantiene el valor CoS de los usuarios.

  3. Pruebe las llamadas a la oficina central.

    Este resultado de depuración se produjo al marcar 5005 a la oficina central. Observe cómo este número se traduce a 14085015005.
    RTP#debug voice translation
    RTP# *Nov 1 06:27:46.363: //-1/xxxxxxxxxxxx/RXRULE/ regxrule_get_profile_from_trunkgroup_internal: Voice port 0x66A943AC does not belong to any trunk group *Nov 1 06:27:46.363: //-1/EC2B8D52804D/RXRULE/ regxrule_stack_pop_RegXruleNumInfo: stack=0x66A93B98; count=1 *Nov 1 06:27:46.367: //-1/EC2B8D52804D/RXRULE/ regxrule_stack_push_RegXruleNumInfo: stack=0x66A93B98; count=0 *Nov 1 06:27:47.627: //-1/EC2B8D52804D/RXRULE/ regxrule_stack_push_RegXruleNumInfo: stack=0x66A93B98; count=1 *Nov 1 06:27:47.627: //-1/EC2B8D52804D/RXRULE/ regxrule_profile_translate_internal: number=19195014003 type=unknown plan=unknown numbertype=calling *Nov 1 06:27:47.627: //-1/EC2B8D52804D/RXRULE/ regxrule_get_RegXrule: Invalid translation ruleset tag=0 *Nov 1 06:27:47.627: //-1/EC2B8D52804D/RXRULE/ regxrule_profile_match_internal: Error: ruleset for calling number not found *Nov 1 06:27:47.627: //-1/EC2B8D52804D/RXRULE/ regxrule_profile_translate_internal: No match: number=19195014003 type=unknown plan=unknown *Nov 1 06:27:47.627: //-1/EC2B8D52804D/RXRULE/ regxrule_profile_translate_internal: number=5005 type=unknown plan=unknown numbertype=called *Nov 1 06:27:47.627: //-1/EC2B8D52804D/RXRULE/ regxrule_profile_match_internal: Matched with rule 1 in ruleset 1 *Nov 1 06:27:47.627: //-1/EC2B8D52804D/RXRULE/ regxrule_profile_match_internal: Matched with rule 1 in ruleset 1 *Nov 1 06:27:47.627: //-1/EC2B8D52804D/RXRULE/ sed_subst: Successful substitution; pattern=5005 matchPattern=^5 replacePattern=14085015 replaced pattern=14085015005 *Nov 1 06:27:47.627: //-1/EC2B8D52804D/RXRULE/ regxrule_subst_num_type: Match Type = none, Replace Type = none Input Type = unknown *Nov 1 06:27:47.631: //-1/EC2B8D52804D/RXRULE/ regxrule_subst_num_plan: Match Plan = none, Replace Plan = none Input Plan = unknown *Nov 1 06:27:47.631: //-1/EC2B8D52804D/RXRULE/ regxrule_profile_translate_internal: xlt_number=14085015005 xlt_type=unknown xlt_plan=unknown *Nov 1 06:27:47.631: //-1/EC2B8D52804D/RXRULE/ regxrule_profile_translate_internal: number= type=unknown plan=unknown numbertype=redirect-called *Nov 1 06:27:47.631: //-1/EC2B8D52804D/RXRULE/ regxrule_get_RegXrule: Invalid translation ruleset tag=0 *Nov 1 06:27:47.631: //-1/EC2B8D52804D/RXRULE/ regxrule_profile_match_internal: Error: ruleset for redirect-called number not found *Nov 1 06:27:47.631: //-1/EC2B8D52804D/RXRULE/ regxrule_profile_translate_internal: No match: number= type=unknown lan=unknown *Nov 1 06:27:47.631: //-1/EC2B8D52804D/RXRULE/ regxrule_dp_translate: calling_number=19195014003 calling_octet=0x0 called_number=14085015005 called_octet=0x80 redirect_number= redirect_type=0
    redirect_plan=0 redirect_PI=0 redirect_SI=0 *Nov 1 06:27:47.631: //-1/EC2B8D52804D/RXRULE/ regxrule_vp_translate: No profile found in voice port or trunk group for outgoing direction *Nov 1 06:27:47.631: //-1/EC2B8D52804D/RXRULE/ regxrule_vp_translate: calling_number=19195014003 calling_octet=0x0 called_number=14085015005 called_octet=0x80 redirect_number= redirect_type=0
    redirect_plan=0

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 82056