IP : IP versión 6 (IPv6)

IPv6: Conexión a 6bone utilizando túneles 6to4

29 Agosto 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (10 Agosto 2005) | Comentarios


Contenido

IPv6: Conexión a 6bone utilizando túneles 6to4
Objetivos de la empresa
Posibles soluciones
Solución propuesta: nº 2, túneles 6to4
Instrumentación
Documentos relacionados

IPv6: Conexión a 6bone utilizando túneles 6to4


Historial de versiones

Número de versión Fecha Notas

1

28 de febrero de 2002

Fecha de de creación de este documento.

2

19 de mayo de 2003

Sección de documentos relacionados actualizada.

Este documento describe cómo un cliente de oficina corporativa (como una institución educativa, una empresa de software pequeña o una compañía de fabricación pequeña) puede conectarse a 6bone mediante túneles 6to4. 6bone es una red de prueba IP versión 6 (IPv6) configurada para ayudar en la evolución e implementación de IPv6 en Internet.

Este documento forma parte de un conjunto de documentos que respalda y complementa la publicación Estrategias de implementación IPv6, disponible en la siguiente URL:

http://www.cisco.com/univercd/cc/td/doc/cisintwk/intsolns/ipv6_sol/ipv6dswp.pdf

Debe leer este documento junto con Estrategias de implementación IPv6 para comprender mejor las actividades previas a la implementación de IPv6.

Este documento dispone de las secciones siguientes:

Objetivos de la empresa

Una compañía de software pequeña (a la que se considera un entorno empresarial típico) que tiene una red IPv4 está en tratativas para fusionarse con otra compañía que ejecuta IPv6 en su red. Para evaluar el impacto de conectividad que tendrá la fusión en las compañías fusionadas, el cliente desea aumentar sus conocimientos sobre IPv6 conectándose a 6bone. Los objetivos del cliente de oficina central corporativa tratados en este documento son los siguientes:

  • Por una inversión mínima, obtenga experiencia en IPv6 en una estructura básica de IPv6 utilizando su topología IPv4 existente.
  • Pruebe los procedimientos de transición y de funcionamiento en un entorno IPv6 real antes de implementar IPv6 en esta oficina central.

Los procesos de transición son aquellos necesarios para realizar la migración desde IPv4 a IPv6. Estos procedimientos incluyen la configuración de sistemas finales y de routers de pila dual, mecanismos de tunelización, servidores DNS (Sistema de nombres de dominio) y, en el futuro, la prueba de Traducción de dirección de red-Traducción de protocolo (NAT-PT).

Los procedimientos de funcionamiento están relacionados con la administración de red, administración de elementos de hosts de pila dual y sistemas finales, así como otras funciones similares.

  • Pruebe las aplicaciones e implementaciones de IPv6 en estaciones de trabajo locales.
  • Minimice la tara de administración asociada con una conexión 6bone.

  • Nota   Si bien 6bone comprende muchos tipos de organizaciones (por ejemplo, organizaciones académicas y gubernamentales, proveedores de hardware y de software, y proveedores de servicios), este documento utiliza el término ISP 6bone al hacer referencia a la organización que se encuentra en el extremo 6bone del túnel.

Topología de red inicial

La figura 1 muestra la topología de red inicial IPv4 para el cliente de oficina central corporativa. Esta red utiliza varios routers para proporcionar conectividad IP entre los usuarios locales. Una conexión IPv4 permanente a un Proveedor de servicios de Internet (ISP) proporciona conectividad externa.


Figura 1   Topología de red inicial IPv4 de la empresa


Posibles soluciones

Las dos posibles formas para que este cliente de oficina central corporativa se conecte a 6bone con su topología IPv4 y túneles existentes son los túneles configurados de forma manual y los túneles 6to4. La tunelización es la técnica de encapsulación de paquetes IPv6 en paquetes IPv4 para que se puedan enviar por infraestructura de enrutamiento IPv4. Ambas soluciones necesitan que el host o router de cada extremo del túnel ejecute la pila dual, lo que significa que admiten simultáneamente las pilas de protocolos IPv4 e IPv6. El software del IOS de Cisco admite estas dos posibles soluciones.

Posible solución nº 1: túneles configurados de forma manual

La IP Tunnelingv6 configurada de forma manual es una técnica en la que una dirección IPv6 se configura manualmente en una interfaz de túnel y las direcciones IPv4 se configuran manualmente en el origen y el destino del túnel. Los túneles configurados de forma manual pueden estar entre routers de borde o entre un router de borde y un host. Puesto que los túneles configurados de forma manual necesitan la configuración en ambos extremos del túnel, suponen una tara de administración mayor cuando se instrumentan varios túneles en comparación con el uso de túneles 6to4. Debido a que se configuran uno a uno entre puntos extremos conocidos, los túneles configurados de forma manual hacen que la información sobre el tráfico esté disponible en cada punto extremo y proporcionan una seguridad adicional frente a tráfico inyectado.

Posible solución nº 2: túneles 6to4

La tunelización 6to4 es una técnica en la que el punto extremo del túnel se determina mediante la dirección IPv4 globalmente única insertada en una dirección 6to4. Una dirección IPv6 6to4 es una combinación del prefijo de enrutamiento único 2002::/16 y una dirección IPv4 de 32 bits globalmente única. (Las direcciones IPv6 compatibles con IPv4 son un formato distinto de las direcciones IPv6 6to4. Las direcciones IPv6 compatibles con IPv4 no se utilizan en la tunelización 6to4.) Los túneles 6to4 se configuran entre routers de borde o entre un router de borde y un host. Los túneles 6to4 necesitan que se identifique un sitio de retransmisión 6to4 de 6bone para proporcionar el servicio de retransmisión 6to4 a la empresa. El sitio de retransmisión 6to4 configurará un router de borde de pila dual que se convertirá en el punto extremo del túnel 6to4 de la empresa. Después de que el sitio de retransmisión 6to4 se configure para la tunelización 6to4, su carga de administración será mínima. En el extremo de la empresa, una configuración de router simple permite el acceso a 6bone a través del túnel 6to4.

Aunque se pueden utilizar los túneles 6to4 para interconectar sitios IPv6 de la empresa, dicho uso queda fuera del alcance de este documento.

Solución propuesta: nº 2, túneles 6to4

La solución propuesta es conectarse a 6bone mediante túneles 6to4 porque es la solución más simple que cumple los objetivos de la empresa.

Información general

Los túneles 6to4 proporcionan un mecanismo para que los sitios extremos IPv6 accedan a 6bone mediante la tunelización por la Internet IPv4. Para evitar interferencias con la red de producción corporativa, la solución se debe implementar inicialmente en una red aislada, como por ejemplo un laboratorio.

Estrategia

Empiece con una red IPv4 que tenga una conexión IPv4 externa a un ISP. La conexión IPv4 es necesaria porque el túnel a 6bone que se configurará, utilizará IPv4 para transportar el tráfico IPv6.

Selección del entorno de prueba IPv6 inicial

Decida cuál de los siguientes dos entornos desea utilizar para instrumentar la conexión 6bone inicial:

  • Una red de prueba totalmente independiente, como por ejemplo un laboratorio
  • Una red de prueba conectada al resto de la red, pero aislada mediante un firewall que no deje pasar tráfico IPv6

En este documento se utiliza el segundo entorno, entorno aislado mediante un firewall, pero la configuración también se aplica al primero.

Suministro de la red de prueba IPv6

Instale los dispositivos que utilizará en la red de prueba IPv6. La figura 2 muestra un red de prueba IPv6 totalmente interconectada que está aislada de la red IPv4 corporativa mediante un firewall configurado para bloquear el tráfico IPv6. Todos los routers de la red de prueba están configurados para ejecutar la pila dual.


Figura 2   Topología de red inicial con la red de prueba IPv6 agregada


Identificación del router para conectarse a 6bone

En la red de prueba IPv6, identifique un router de borde que utilizará para conectarse al ISP 6bone. Este router de borde debe ser un router de pila dual que se configurará con el túnel para pasar el tráfico IPv6 por la internet IPv4.

Obtención de información de la dirección del ISP 6bone

Pida al ISP 6bone que configure su extremo del túnel y que, a continuación, le proporcione la dirección IPv4 de su router que utilizará para el acceso a 6bone.

Puesto que va a configurar un túnel 6to4 conectado a 6bone, la dirección IPv6 del router de borde será su dirección IPv4 (totalmente enrutable) concatenada al prefijo 2002::/16 de 6to4.


Nota   Es posible que el ISP utilizado para la conectividad de 6bone no sea el que utiliza para la conectividad de IPv4. El ISP 6bone normalmente será el socio más cercano que le proporcionará un servicio de retransmisión 6to4, para que usted no quede restringido a su ISP local para la conectividad a 6bone.

Configuración de router de borde 6bone

Mediante la dirección IPv4 del ISP 6bone, configure el router de borde designado para ejecutar la pila dual, con un túnel 6to4 para conectarse a 6bone. Se recomienda que cada sitio tenga sólo una dirección 6to4 asignada a la interfaz externa del router. Todos los sitios tienen que ejecutar un protocolo de enrutamiento interior IPv6 como, por ejemplo, Protocolo de información de enrutamiento de próxima generación (RIPng) para el enrutamiento IPv6 en el sitio, pero el enrutamiento exterior está controlado por el protocolo de enrutamiento exterior de IPv4 correspondiente.

Ahora usted tiene conectividad de 6bone a la red de prueba, como se muestra en la figura 3.


Figura 3   Conectividad establecida de la red de prueba al ISP 6bone


Conexión de la red corporativa a 6bone

Cuando esté listo para implementar IPv6 en la red corporativa, la conexión al ISP 6bone se realizará mediante el ISP IPv4. Configurará el router de borde enlazado al ISP IPv4 para ejecutar la pila dual y con un túnel 6to4 conectado al ISP 6bone. La dirección IPv4 del router de borde enlazado al ISP IPv4 cambiará según la dirección que le proporcione el ISP IPv4. Identifique otros routers y hosts de la red para los que desea tener conectividad de IPv6. Tendrá que configurar cada uno de estos dispositivos para que ejecuten la pila dual.

Puede eliminar el firewall entre la red corporativa y el laboratorio para permitir que el tráfico IPv6 pase por toda la red, y puede mantener una parte de la red sólo con IPv4 hasta que esté listo para implementar IPv6 en dicha red. La figura 4 muestra la red corporativa con la conectividad de IPv6 a 6bone mediante un túnel 6to4 a través del ISP IPv4.


Figura 4   Red corporativa con la conectividad de IPv6 a 6bone


Topología de red

La figura 5 muestra la topología de un típico túnel 6to4 conectado a 6bone.


Figura 5   Túnel 6to4 conectado a 6bone


Cómo funciona esta solución

Un túnel 6to4 se configura en un router de borde de pila dual de la empresa. Todo el tráfico empresarial IPv6 destinado al 6bone es enrutado por IPv4 a través del túnel al router de retransmisión 6bone ISP 6to4. El tráfico desde 6bone a un host de empresa se enruta por IPv4 a través del túnel hasta el router de borde de pila dual de la empresa y, a continuación, hasta el host de destino IPv6.

Beneficios

Las ventajas para la empresa derivadas del uso de túneles 6to4 son las siguientes:

  • El software del IOS de Cisco admite los túneles 6to4.
  • La configuración de host de usuario final es simple y necesita poca tara de administración.
  • El túnel es automático; no es necesaria ninguna configuración específica de la empresa en el sitio de retransmisión 6to4.
  • Túneles 6to4 gradúan bien.
  • Esta solución alberga direcciones IP dinámicas en la empresa.
  • El túnel permanece activo sólo durante el tiempo de la sesión.
  • Un túnel 6to4 sólo necesita configuración una única vez en el ISP, lo que permite que el servicio de retransmisión 6to4 esté disponible simultáneamente en varias empresas.
  • La conmutación por error (failover) a un router secundario se puede proporcionar sin implicar al ISP.

Consecuencias

Las consecuencias para la empresa derivadas del uso de túneles 6to4 son las siguientes:

  • El NAT administrado de forma independiente no está permitido en la ruta del túnel.
  • No se pueden implementar fácilmente varias conexiones.
  • El mecanismo de túnel 6to4 proporciona un bloque de 48 direcciones; no hay más direcciones disponibles.
  • Puesto que están configurados muchos-a-uno y el tráfico del túnel puede originarse en varios puntos extremo, los túneles 6to4 pueden proporcionar únicamente información de tráfico integral al ISP.
  • Puesto que el prefijo de la dirección IPv6 6to4 de la empresa está determinado por y depende de la dirección IPv4 subyacente, la migración a IPv6 nativo requiere volver a numerar la red.
  • Esta solución sólo se aplica al enrutamiento estático o BGP4+.

Instrumentación

Esta sección describe cómo un cliente corporativo puede instrumentar un túnel 6to4 para conectarse a 6bone. Contiene las siguientes secciones:

Requisitos previos y consideraciones de diseño

Antes de instrumentar un túnel 6to4 al 6bone, debe realizar las siguientes tareas:

  • Identifique el router de borde en su sitio que configurará para que ejecute la pila dual. Este router de borde debe tener una dirección IPv4 estática totalmente enrutable.
  • Solicite al ISP 6bone la dirección IPv4 del router de retransmisión 6to4 que utilizará para el acceso a 6bone.

Nota    Al configurar túneles para los routers de borde de la empresa, debe utilizar las direcciones IPv4 totalmente enrutables. Las direcciones de IPv4 usadas en las configuraciones de ejemplo de este documento no son enrutables totalmente y se proporcionan sólo con fines ilustrativos.

  • Asegúrese de que el DNS ejecute el dominio de nombres de Internet de Berkeley (BIND) versión 9, que proporciona una instrumentación de los principales componentes del DNS para IPv6, o bien que tenga las capacidades equivalentes de dicho dominio. Este documento no incluye la configuración DNS.
  • Reconozca que la actual implementación de la pila dual en el software del IOS de Cisco permite una solución de gestión de red provisional, que permite ejecutar aplicaciones como TFTP, ping, Telnet, y traceroute por un transporte IPv4 o IPv6.
  • Seleccione un protocolo de enrutamiento interior IPv6 como, por ejemplo, RIPng, que sea adecuado para la configuración de red. Para que sea más simple, la solución presentada en este documento utiliza una ruta estática. El enrutamiento exterior está controlado por el protocolo de enrutamiento exterior IPv4 correspondiente.
  • Configure todos los routers de pila dual para que utilicen RIP.

Para obtener más información sobre la configuración de la red para IPv6, consulte el siguiente documento que aparece en la sección "Documentos relacionados": IPv6 for Cisco IOS Software, File 2 of 3: Configuring (IPv6 para el software del IOS de Cisco, archivo 2 de 3: configuración).

Pasos del proceso de instrumentación

La dirección IPv4 del router de borde es 192.168.99.1. Derive el prefijo de 6to4 de la dirección IPv4 mediante la conversión de los componentes decimales de la dirección IPv4 a hexadecimales y, a continuación, coloque el prefijo "2002" a los números hexadecimales resultantes. Por lo tanto, el prefijo de 6to4 para los nodos IPv6 de su red es 2002:C0A8:6301::/48.

La parte C0A8:6301 de la dirección IPv6 anterior se forma a partir de la dirección IPv4 mediante la conversión de cada octeto de la notación decimal con puntos a su equivalente hexadecimal, como se muestra en la tabla 1.

Tabla 1   Conversión de decimal con puntos a hexadecimal

Decimal Hexadecimal

192

C0

168

A8

99

63

1

01

El ISP 6bone le ha proporcionado la dirección IPv4 de su router de borde 6bone: 192.168.33.1.

Utilizando la información de la dirección anterior, configure un túnel 6to4 en su router de borde de pila dual introduciendo los siguientes comandos:

Router de la empresa
enrutamiento de unidifusión IPv6
interfaz Ethernet0
 descripción de la conexión al ISP 6bone
 dirección IP 192.168.99.1 255.255.255.0
interfaz Tunnel2002
 descripción del túnel 6to4 conectado al ISP 6bone
 sin dirección de IP
 sin redireccionamiento IP
 dirección ipv6 2002:C0A8:6301::1/128
 origen del túnel ethernet0
 modo de túnel ipv6ip 6to4
ipv6 route 2002::/16 Tunnel2002
ipv6 route ::/0 2002:C0A8:2101::1

2002:C0A8:2101::1 en el segundo comando ipv6 route es la dirección IPv6 del router de retransmisión ISP 6to4 que proporciona acceso a 6bone. La parte C0A8:2101 de la dirección se deriva de la dirección IPv4 (192.168.33.1) del router de retransmisión 6to4 de forma similar a la de la tabla 1.

En el otro extremo del túnel, el router de borde en el ISP 6bone tendría una configuración similar a la siguiente:

Router de retransmisión ISP 6to4
enrutamiento de unidifusión IPv6
interfaz ethernet0/0
 descripción de la conexión a la empresa
 dirección IP 192.168.33.1 255.255.255.0
interfaz Tunnel2002
 descripción del servicio de retransmisión 6to4
 sin dirección de IP
 sin redireccionamiento IP
 dirección ipv6 2002:C0A8:2101::1/128
 origen del túnel ethernet0/0
 modo de túnel ipv6ip 6to4
ipv6 route 2002::/16 tunnel2002

Características del dispositivo

La tabla 2 describe los dispositivos utilizados en esta solución.

Tabla 2   Hardware y Software utilizados

Router de borde de la empresa Router ISP 6bone
Nombre del host

6bone-gw

ipv6-router

Tipo de chasis

Router Cisco 3660

Router Cisco 7206

Interfaces físicas

2 Ethernet
2 Fast Ethernet
Serial 4

4 Ethernet
2 Fast Ethernet
Serial 4

Software cargado

Versión de Cisco IOS 12.2(4)T

Versión de Cisco IOS 12.2(4)T

Memoria

64 MB de RAM; 16 MB de Flash

128 MB de RAM; 20 MB de Flash

Direcciones IP

Ethernet0:
IPv4  192.168.99.1

Tunnel2002:
IPv6  2002:C0A8:6301::1/128

Ethernet0/0:
IPv4  192.168.33.1

Tunnel2002:
IPv6  2002:C0A8:2101::1/128

Archivos de configuración comentados

Esta sección contiene los archivos de salida comentados del comando show running-configuration para los routers de borde de la empresa e ISP 6bone que se muestran en la figura 5.

Router de la empresa
! Identifique la versión del software de Cisco IOS que se ejecuta en el router
!
versión 12.2
!
! Incluya los sellos de fecha y hora en el registro y depure las entradas que son útiles para
! resolución de problemas y optimización de la red.
!
service timestamps debug datetime localtime show-timezone (servicio sellos de fecha hora depuración fecha/hora hora local mostrar zona horaria)
service timestamps log datetime localtime show-timezone (servicio sellos de fecha hora registro fecha/hora hora local mostrar zona horaria)
!
! Especifique que las contraseñas se encriptarán en la salida de configuración.
!
service password-encryption (cifrado de contraseña de servicio)
!
! Configure el nombre del router
!
hostname 6bone-gw (nombre del host 6bone-gw)
!
! Configure las opciones de encendido
!
boot system flash slot0:
boot system flash bootflash:
!
! Configure el registro
!logging buffered 10000 debugging
!
! Configure la contraseña secreta
!
enable secret 5 [removed] (activar secreto 5 [eliminado])
!
! Configure la zona horaria del reloj y la regla de verano
!
clock timezone PST -8 (zona horaria del reloj PST -8)
clock summer-time PDT recurring (horario de verano PDT periódico)
!
!
ip subnet-zero (subred-cero IP)
no ip source-route (sin ruta de origen de IP)
no ip rcmd domain-lookup (sin búsqueda de dominio rcmd IP)
!
! Configure el nombre de dominio del router
!
ip domain-name EnterpriseDomain.com (nombre de dominio de IP EnterpriseDomain.com)
!
! Configure los nombres de los servidores DNS
!
ip name-server 192.168.1.10
ip name-server 192.168.2.21
ip name-server 2002:C0A8:6301:1::21
!
! Active el enrutamiento IPv6
!
ipv6 unicast-routing (enrutamiento de unidifusión IPv6)
!
! Configure la interfaz del túnel
!
interface Tunnel2002 (interfaz Tunnel2002)
 description 6to4 tunnel to 6bone ISP (descripción del túnel 6to4 conectado al ISP 6bone)
 no ip address (sin dirección de IP)
 no ip redirects (sin redireccionamiento IP)
 ipv6 address 2002:C0A8:6301::1/128 (dirección ipv6 2002:C0A8:6301::1/128)
 tunnel source ethernet0 (origen del túnel ethernet0)
 tunnel mode ipv6ip 6to4 (modo de túnel ipv6ip 6to4)
!
! Configure la interfaz física
!
interface Ethernet0 (interfaz Ethernet0)
 description connection to 6bone ISP (descripción de la conexión al ISP 6bone)
 ip address 192.168.99.1 255.255.255.0 (dirección IP 192.168.99.1 255.255.255.0)
!
interface Ethernet1(interfaz Ethernet1)
 description connection to Lab interface router (descripción de la conexión del router de interfaz Lab)
 ip address 192.168.99.40 255.255.255.0 (dirección IP 192.168.99.40 255.255.255.0)
 ipv6 address 3FFE:FFFF:8023:100::1/64 (dirección IPv6 3FFE:FFFF:8023:100::1/64)
 ipv6 rip v6rip enable (ipv6 rip v6rip activa)
!
interface FastEthernet2/0 (interfaz FastEthernet2/0)
 description connection to core router (descripción de la conexión al router de núcleo)
  ip address 192.168.99.41 255.255.255.0 (dirección IP 192.168.99.41 255.255.255.0)
 ipv6 address 3FFE:FFFF:8023:200::1/64 (dirección IPv6 3FFE:FFFF:8023:200::1/64)
 ipv6 rip v6rip enable (ipv6 rip v6rip activa)
!
interface FastEthernet3/0 (interfaz FastEthernet3/0)
 description connection to IPv4-only core router (descripción de la conexión al router de núcleo sólo con IPv4)
 ip address 192.168.99.42 255.255.255.0 (dirección IP 192.168.99.42 255.255.255.0)
!
! El resto de las interfaces no se utilizan
!
interface Serial4/0 (interfaz Serial4/0)
 no ip address (sin dirección de IP)
 shutdown (cierre)
!
interface Serial4/1 (interfaz Serial4/1)
 no ip address (sin dirección de IP)
 shutdown (cierre)
!
interface Serial4/2 (interfaz Serial4/2)
 no ip address (sin dirección de IP)
 shutdown (cierre)
!
interface Serial4/3 (interfaz Serial4/3)
 no ip address (sin dirección de IP)
 shutdown (cierre)
!
! Configure el enrutamiento IP básico
!
ip default-gateway 192.168.33.1(puerta de enlace predeterminada de IP 192.168.33.1)
ip classless (IP sin clase)
ip route 0.0.0.0 0.0.0.0 192.168.33.1 (ruta IP 0.0.0.0 0.0.0.0 192.168.33.1)
!
! Configure la ruta IPv6 estática
!
ipv6 route 2002::/16 tunnel2002
ipv6 route ::/0 2002:C0A8:2101::1
ipv6 router rip v6rip
!
Finalizar
Router ISP 6bone
! Identifique la versión del software de Cisco IOS que se ejecuta en el router
!
versión 12.2
!
! Incluya los sellos de fecha y hora en el registro y depure las entradas que son útiles para
! resolución de problemas y optimización de la red.
!
service (servicio) timestamps (sellos de fecha hora) debug (depuración) datetime (fecha/hora) localtime (hora local) show-timezone (mostrar zona horaria)
service (servicio) timestamps (sellos de fecha y hora) log (registro) datetime (fecha/hora) localtime (hora local) show-timezone (mostrar zona horaria)
!
! Especifique que las contraseñas se encriptarán en la salida de configuración.
!
cifrado de contraseña de servicio
!
! Configure el nombre del router
!
hostname ipv6-router
!
! Configure las opciones de encendido
!
boot system flash slot0:
boot system flash bootflash:
!
! Configure el registro
!
logging buffered 10000 debugging
!
! Configure la contraseña secreta
!
enable secret 5 [removed] (activar secreto 5 [eliminado])
!
! Configure la zona horaria del reloj y la regla de verano
!
clock timezone PST -8 (zona horaria del reloj PST -8)
clock summer-time PDT recurring (horario de verano PDT periódico)
!
!
ip subnet-zero (subred-cero IP)
no ip source-route (sin ruta de origen de IP)
no ip rcmd domain-lookup (sin búsqueda de dominio rcmd IP)
!
! Configure el nombre de dominio del router
!
ip domain-name 6boneISP.com (nombre de dominio de IP 6boneISP.com)
!
! Configure los nombres de los servidores DNS
!
ip name-server 192.168.33.4
ip name-server 192.168.33.5
ip name-server 3FFE:FFFF:8001::4
!
! Active el enrutamiento IPv6
!
ipv6 unicast-routing (enrutamiento unidifusión IPv6)
!
! Configure la interfaz del túnel
!
interface Tunnel2002 (interfaz del Tunnel2002)
 description 6to4 relay service (descripción del servicio de retransmisión 6to4)
 no ip address (sin dirección de IP)
 no ip redirects (sin redireccionamiento IP)
 ipv6 address 2002:C0A8:2101::1/128 (dirección ipv6 2002:C0A8:2101::1/128)
 tunnel source ethernet0/0 (origen del túnel ethernet0/0)
 tunnel mode ipv6ip 6to4 (modo de túnel ipv6ip 6to4)
!
! Configure la interfaz física
!
interface Ethernet0/0 (interfaz Ethernet0/0)
 description connection to enterpris (descripción de la conexión a la empresa)
 ip address 192.168.33.1 255.255.255.0 (dirección IP 192.168.33.1 255.255.255.0)
!
interface Ethernet0/1 (interfaz Ethernet0/1)
 no ip address (sin dirección de IP)
 shutdown (cierre)
!
interface Ethernet0/2 (interfaz Ethernet0/2)
 no ip address (sin dirección de IP)
 shutdown (cierre)
!
interface Ethernet0/3 (interfaz Ethernet0/3)
 no ip address (sin dirección de IP)
 shutdown (cierre)
!
interface FastEthernet1/0 (interfaz FastEthernet1/0)
 description connection to ISP-core-A (descripción de la conexión al ISP-core-A)
 ip address 192.168.34.10 255.255.255.0 (dirección IP 192.168.34.10 255.255.255.0)
 ipv6 address 3FFE:FFFF:8023:2::6/64 (dirección IPv6 3FFE:FFFF:8023:2::6/64)
 duplex auto (dúplex automático)
 speed auto (velocidad automática)
!
interface FastEthernet2/0 (interfaz FastEthernet2/0)
 description connection to ISP-core-B (descripción de la conexión al ISP-core-B)
 ip address 192.168.35.22 255.255.255.0 (dirección IP 192.168.35.22 255.255.255.0)
 ipv6 address 3FFE:FFFF:8023:2::8/64 (dirección IPv6 3FFE:FFFF:8023:2::8/64)
 duplex auto (dúplex automático)
 speed auto (velocidad automática)
!
! El resto de las interfaces no se utilizan
!
interface Serial4/0 (interfaz Serial4/0)
 no ip address (sin dirección de IP)
 shutdown (cierre)
!
interface Serial4/1(interfaz Serial4/1)
 no ip address (sin dirección de IP)
 shutdown (cierre)
!
interface Serial4/2 (interfaz Serial4/2)
 no ip address (sin dirección de IP)
 shutdown (cierre)
!
interface Serial4/3 (interfaz Serial4/3)
 no ip address (sin dirección de IP)
 shutdown (cierre)
!
! Configure el enrutamiento IP básico
!
ip default-gateway 192.168.30.1(puerta de enlace predeterminada de IP 192.168.30.)
ip classless (IP sin clase)
ip route 0.0.0.0 0.0.0.0 192.168.30.1 (ruta IP 0.0.0.0 0.0.0.0 192.168.30.1)
!
! Configure la ruta IPv6 estática
!
ipv6 route 2002::/16 tunnel2002
!
Finalizar

Documentos relacionados

Consulte los siguientes documentos para obtener información adicional acerca de IPv6 para el software del IOS de Cisco, 6bone e IPv6 en general:

  • IPv6 Deployment Strategies (Estrategias de instrumentación IPv6)
  • IPv6: Connecting to the 6bone Using Manually Configured Tunnels (IPv6: conexión a 6bone mediante túneles configurados de forma manual)
  • IPv6: Providing IPv6 Services over an IPv4 Backbone Using Tunnels (IPv6: suministro de servicios IPv6 por una estructura básica de IPv4 mediante túneles)
  • Interconnecting IPv6 Domains Using Tunnels (Interconexión de dominios IPv6 mediante túneles)
  • Start Here: Cisco IOS Software Release Specifics for IPv6 Features (Cómo empezar: detalles de la versión del software del IOS de Cisco para características de IPv6)
  • Implementing IPv6 for Cisco IOS Software (Implementación de IPv6 para el software del IOS de Cisco)
  • Referencia de los comandos IPv6 para el software del IOS de Cisco
  • RFC 2185, Aspectos del enrutamiento de la transición IPv6 (informativo)
  • RFC 2373, versión 6 de la arquitectura de direccionamiento de IP
  • RFC 2374, Un formato de dirección de unidifusión global adicionable IPv6
  • RFC 2460, Especificación de la versión 6 (IPv6) del Protocolo de Internet
  • RFC 2464, Transmisión de paquetes IPv6 en redes Ethernet
  • RFC 2471, IPv6 probando asignación de direcciones
  • RFC 2893, Mecanismos de transmisión para hosts y routers IPv6
  • RFC 3056, Conexión de dominios IPv6 a través de nubes de IPv4.




Comunidad de Soporte de Cisco - Conversaciones Destacadas

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas. Aquí están algunas de las charlas más importantes presentadas en nuestro foro.


Document ID: 45741