Software Cisco IOS y NX-OS : Software Cisco IOS versión 12.2 T

NAT: Capacidad para usar mapas de ruta con traducciones estáticas

14 Abril 2008 - Traducción manual
Otras Versiones: PDFpdf | Inglés (14 Octubre 2001) | Comentarios


Contenidos

NAT—Capacidad para usar mapas de ruta con traducciones estáticas
Información general de características
Plataformas compatibles
Normas, MIB y RFC compatibles
Tareas de configuración
Ejemplos de configuración
Referencia de comandos
ip nat inside source

NAT—Capacidad para usar mapas de ruta con traducciones estáticas


Historial de características
Versión Modificación

12.2(4)T

Se ha introducido esta característica.

12.2(4)T2

Se ha agregado el soporte para los routers de la serie 7500 de Cisco.

En este documento, se describe la capacidad de NAT para usar mapas de ruta con la característica de traducciones estáticas. Incluye las secciones siguientes:

Información general de características

Plataformas compatibles

Normas, MIB y RFC compatibles

Tareas de configuración

Ejemplos de configuración

Referencia de comandos

Información general de características

Con anterioridad a esta característica, únicamente se admitía la asignación de ruta con la traducción dinámica de NAT (Traducción de direcciones de red).

La característica de la capacidad de NAT para usar mapas de ruta con traducciones estáticas activa la capacidad de varias conexiones de NAT con traducciones de direcciones estáticas. Ahora las redes internas con varias conexiones pueden alojar servicios comunes, como Internet y el Sistema de nombres de dominio (DNS), a los que se puede acceder desde diferentes redes exteriores.


Nota   Esta característica no incluye el soporte estático de red.


Beneficios

  • La capacidad de configurar sentencias del mapa de ruta proporciona la opción de usar la seguridad IP (IPSec) con NAT.
  • Se pueden tomar decisiones de traducción según la dirección IP de destino cuando se utilizan entradas de traducción estática.

Documentos relacionados

  • Cisco IOS IP Command Reference, Volume 1 of 3: Addressing and Services, Release 12.2
  • Cisco IOS IP Configuration Guide, Release 12.2

Plataformas compatibles

  • Serie 2500 de Cisco
  • Serie 2600 de Cisco
  • Router 3620 de Cisco
  • Router 3640 de Cisco
  • Router 3660 de Cisco
  • Serie 7100 de Cisco
  • Serie 7200 de Cisco
  • Serie 7500 de Cisco
Determinación de la compatibilidad de la plataforma a través del navegador de características

El software del IOS de Cisco está incluido en paquetes de conjuntos de características que son compatibles con plataformas específicas. Para obtener información actualizada sobre la compatibilidad de la plataforma para esta característica, acceda al navegador de características. El navegador de características actualiza de manera dinámica la lista de plataformas compatibles cuando se agrega un soporte nuevo de plataforma a la característica.

El navegador de características es una herramienta basada en la Web que le permite determinar de forma rápida qué imágenes del software del IOS de Cisco son compatibles con un conjunto específico de características y qué características son compatibles con una imagen específica del IOS de Cisco.

Para acceder al navegador de características, debe disponer de una cuenta en Cisco.com. Si ha olvidado o perdido la información de la cuenta, envíe un correo electrónico en blanco a cco-locksmith@cisco.com. Una prueba automática verificará que la cuenta de correo electrónico está registrada en Cisco.com. Si la prueba se realiza con éxito, se le enviará un correo electrónico con los detalles de la cuenta junto con una contraseña aleatoria nueva. Los usuarios calificados pueden seguir las instrucciones especificadas en http://www.cisco.com/cisco/web/LA/support/index.html para crear una cuenta en Cisco.com.

El navegador de características se actualiza cuando tienen lugar los principales lanzamientos tecnológicos y de software del IOS de Cisco. Desde mayo de 2001, el navegador de características es compatible con las versiones M, T, E, S, y ST. Puede acceder al navegador de características en la siguiente dirección URL:

http://www.cisco.com/cisco/web/LA/support/index.html

Normas, MIB y RFC compatibles

Normas

Esta característica no es compatible con normas nuevas ni modificadas.

MIB

Esta característica no es compatible con MIB nuevas ni modificadas.

Para obtener las listas de las MIB compatibles con la plataforma y por la versión de Cisco IOS, así como para descargar los módulos MIB, vaya al sitio Web de MIB de Cisco en Cisco.com que se encuentra en la siguiente dirección URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

RFC

Esta característica no es compatible con RFC nuevas ni modificadas.

Tareas de configuración

Consulte las siguientes secciones para obtener información acerca de las tareas de configuración relacionadas con la característica NAT—Capacidad para usar mapas de ruta con traducciones estáticas. Cada una de las tareas de la lista se identifica como necesaria u opcional:

  • Activación de asignación de ruta de NAT estática (necesaria)
  • Ejemplo de activación de asignación de ruta de NAT estática (opcional)

Activación de asignación de ruta de NAT estática

Para activar la asignación de ruta con configuraciones de NAT estáticas, utilice el siguiente comando en el modo de configuración global:

Comando Propósito
Router(config)# ip nat inside source {list {número-lista-acceso | nombre-lista-acceso} pool nombre-agrupación [overload] | static ip-local ip-global route-map nombre-mapa}

Activa la asignación de ruta con las traducciones NAT estáticas configuradas en la interfaz interior de NAT.

Ejemplo de activación de asignación de ruta de NAT estática

Para verificar la configuración de la asignación de ruta de NAT estática, utilice el siguiente comando en el modo EXEC privilegiado:

Comando Propósito
Router# show ip nat translations [verbose]

Muestra las traducciones NAT activas.

Ejemplos de configuración

En esta sección se muestra el siguiente ejemplo de configuración:

  • Activación de asignación de ruta de NAT estática

Ejemplo de activación de asignación de ruta de NAT estática

El siguiente ejemplo muestra el uso de la asignación de ruta con traducciones NAT estáticas:

interface Ethernet3
 ip address 172.68.1.100 255.255.255.0
 ip nat outside
 media-type 10BaseT
!
interface Ethernet4
 ip address 172.68.1.100 255.255.255.0
 ip nat outside
 media-type 10BaseT
!
interface Ethernet5
 ip address 11.1.1.100 255.255.255.0
 ip nat inside
 media-type 10BaseT
!
router rip
 network 172.68.0.0
 network 192.68.1.0
!
ip nat inside source static 11.1.1.2 192.68.1.21 route-map isp2
 ip nat inside source static 11.1.1.2 172.68.1.21 route-map isp1
 ip nat inside source static 11.1.1.1 192.68.1.11 route-map isp2
 ip nat inside source static 11.1.1.1 172.68.1.11 route-map isp1
 access-list 101 permit ip 11.1.1.0 0.0.0.255 172.0.0.0 0.255.255.255.
access-list 102 permit ip 11.1.1.0 0.0.0.255 192.0.0.0 0.255.255.255
!
route-map isp2 permit 10
 match ip address 102
 set ip next-hop 192.68.1.1
!
route-map isp1 permit 10
 match ip address 101

 set ip next-hop 172.68.1.1

Referencia de comandos

En esta sección se explica el comando ip nat inside source modificado. El resto de los comandos que se utilizan junto a esta característica se explican en las publicaciones de referencia de comandos de la versión 12.2 de Cisco IOS.

ip nat inside source

Para activar la traducción de direcciones de red (NAT) de la dirección de origen interna, utilice el comando ip nat inside source en el modo de configuración global. Para eliminar la traducción estática o la asociación dinámica a una agrupación, utilice la opción no de este comando.

ip nat inside source {list {número-lista-acceso | nombre-lista-acceso} pool nombre-agrupación [overload] | static ip-local ip-global route-map nombre-mapa}
no ip nat inside source {list {número-lista-acceso | nombre-lista-acceso} pool nombre-agrupación [overload] | static ip-local ip-global route-map nombre-mapa}

Descripción de la sintaxis

list número-lista-acceso

Número de lista de acceso de IP estándar. Los paquetes con direcciones de origen que transfieren la lista de acceso se traducen de forma dinámica mediante el uso de direcciones globales desde la agrupación designada.

list nombre-lista-acceso

Nombre de una lista de acceso de IP estándar. Los paquetes con direcciones de origen que transfieren la lista de acceso se traducen de forma dinámica mediante el uso de direcciones globales desde la agrupación designada.

pool nombre-agrupación

Nombre de la agrupación desde la que se asignan de manera dinámica las direcciones IP globales.

overload

(Opcional) Permite al router utilizar una dirección global para muchas direcciones locales. Cuando se ha configurado la opción de sobrecarga, el número de puerto TCP o UDP de cada host interno se distingue de entre las conversaciones múltiples mediante el uso de la misma dirección IP local.

static ip-local

Configura una única traducción estática. El argumento ip-local establece la dirección IP local asignada a un host en la red interna. La dirección se puede elegir de forma aleatoria, se puede asignar desde RFC 1918, o puede estar obsoleta.

ip-global

Configura una única traducción estática. El argumento ip-global establece la dirección IP única global de un host interno tal como aparece al mundo exterior.

route-map nombre-mapa

Nombre de la configuración de mapas de ruta en la interfaz NAT interior de las traducciones estáticas.

Valores predeterminados

Sin valores ni conducta predeterminados

Modos de comando

Configuración global

Historial de comando

Versión Modificación

11.2

Este comando fue ingresado.

12.2(4)T

Este comando se ha modificado para incluir la capacidad de usar mapas de ruta con traducciones estáticas, y se ha agregado la palabra clave/argumento route-map nombre-mapa.

Pautas de uso

Este comando tiene dos formas: traducción de dirección estática y dinámica. La forma con una lista de acceso establece la traducción dinámica. Los paquetes de direcciones que coinciden con la lista de acceso estándar se traducen mediante direcciones globales asignadas desde la agrupación designada con el comando ip nat pool.

Asimismo, la forma de sintaxis con la palabra clave static establece una única traducción estática.

Ejemplos

El siguiente ejemplo traduce de entre host internos dirigidos desde la red 192.168.1.0 o 192.168.2.0 a la red única global 171.69.233.208/28:

ip nat pool net-208 171.69.233.208 171.69.233.223 prefix-length 28
ip nat inside source list 1 pool net-208
!
interface ethernet 0
 ip address 171.69.232.182 255.255.255.240
 ip nat outside
!
interface ethernet 1
 ip address 192.168.1.94 255.255.255.0
 ip nat inside
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255

El siguiente ejemplo muestra el uso de la asignación de ruta con traducciones NAT estáticas:

!
interface Ethernet3
 ip address 172.68.1.100 255.255.255.0
 ip nat outside
 media-type 10BaseT
!
interface Ethernet4
 ip address 172.68.1.100 255.255.255.0
 ip nat outside
 media-type 10BaseT
!
interface Ethernet5
 ip address 11.1.1.100 255.255.255.0
 ip nat inside
 media-type 10BaseT
!
router rip
 network 172.68.0.0
 network 192.68.1.0
!
ip nat inside source static 11.1.1.2 192.68.1.21 route-map isp2
 ip nat inside source static 11.1.1.2 172.68.1.21 route-map isp1
 ip nat inside source static 11.1.1.1 192.68.1.11 route-map isp2
 ip nat inside source static 11.1.1.1 172.68.1.11 route-map isp1
 access-list 101 permit ip 11.1.1.0 0.0.0.255 172.0.0.0 0.255.255.255.
access-list 102 permit ip 11.1.1.0 0.0.0.255 192.0.0.0 0.255.255.255
!
route-map isp2 permit 10
 match ip address 102
 set ip next-hop 192.68.1.1
!
route-map isp1 permit 10
 match ip address 101
 set ip next-hop 172.68.1.1

Comandos relacionados

Comando Descripción

clear ip nat translation

Borra las traducciones NAT dinámicas de la tabla de traducción.

ip nat

Indica que el tráfico originado desde o destinado a la interfaz está sujeto a NAT.

ip nat inside destination

Activa la NAT de la dirección de destino interna.

ip nat outside source

Activa la NAT de la dirección de origen externa.

ip nat pool

Define una agrupación de direcciones IP para NAT.

show ip nat statistics

Muestra las estadísticas de NAT.

show ip nat translations

Muestra las traducciones NAT activas.