Switches : Switches Cisco Catalyst de la serie 6500

Ejemplo de configuración de migración del árbol de expansión de PVST+ a Rapid-PVST

1 Mayo 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (12 Enero 2007) | Comentarios

Contenido

Introducción
Requisitos previos
      Requerimientos
      Componentes utilizados
      Convenciones
Antecedentes
Configuración
      Diagrama de la red
      Configuraciones
      Configuración de PVST+
      UplinkFast y BackboneFast
      Migración Rapid-PVST+
      Resultado de la depuración: modo combinado
      Resultado de la depuración: modo Rapid-PVST+
Verificación
Resolución de problemas
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

Este documento proporciona una configuración de ejemplo para migrar el modo de árbol de expansión de PVST+ a rapid-PVST+ en la red de oficina central. También se explica la configuración de PVST+, el equilibrio de carga del árbol de expansión y las funciones UplinkFast y BackboneFast.

Requisitos previos

Requerimientos

Se recomienda leer Introducción al Rapid Spanning Tree Protocol [protocolo de árbol de expansión rápida] (802.1w) antes de configurar rapid-PVST+.

En esta tabla se muestra la compatibilidad del protocolo de árbol de expansión rápida (RSTP) en los switches Catalyst y el software mínimo necesario para dicha compatibilidad.

Plataforma Catalyst

Rapid-PVST+

Catalyst 2900 XL/3500 XL

No disponible.

Catalyst 2940

12.1(20)EA2

Catalyst 2950/2955/3550

12.1(13)EA1

Catalyst 2970/3750

12.1(14)EA1

Catalyst 3560

12.1(19)EA1

Catalyst 3750 Metro

12.1(14)AX

Catalyst 2948G-L3/4908G-L3

No disponible.

Catalyst 4000/2948G/2980G (CatOS)

7.5

Catalyst 4000/4500 (IOS)

12.1(19)EW

Catalyst 5000/5500

No disponible.

Catalyst 6000/6500

7.5

Catalyst 6000/6500 (IOS)

12.1(13)E

Catalyst 8500

No disponible.

Componentes utilizados

La información que contiene este documento se basa en el software Cisco IOS® versión 12.2(25) y CatOS 8.5(8). Sin embargo, la configuración se puede aplicar en la versión mínima de Cisco IOS que se muestra en la tabla.

La información que contiene este documento se creó a partir de los dispositivos en un entorno de laboratorio específico. Todos los dispositivos que se utilizan en este documento se iniciaron con una configuración sin definir (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones sobre consejos técnicos de Cisco para obtener más información sobre las convenciones del documento.

Antecedentes

El protocolo de árbol de expansión (STP) 802.1D presenta la desventaja de una convergencia lenta. Los switches Catalyst de Cisco admiten tres tipos de STP, que son PVST+, rapid-PVST+ y MST. PVST+ se basa en la norma IEEE802.1D e incluye extensiones patentadas por Cisco como BackboneFast, UplinkFast y PortFast. Rapid-PVST+ se basa en la norma IEEE 802.1w y tiene una convergencia más rápida que 802.1D. RSTP (IEEE 802.1w) incluye originariamente la mayoría de las mejoras patentadas por Cisco realizadas en el árbol de expansión 802.1D, como BackboneFast y UplinkFast. Rapid-PVST+ tiene estas características únicas:

  • Utiliza la versión 2 de la unidad de datos del protocolo de puente (BPDU) que es compatible con versiones anteriores a STP 802.1D, que utiliza la versión 0 de BPDU.

  • Todos los switches generan BPDU y las envían en todos los puertos cada 2 segundos, mientras que en STP 802.1D solamente el root bridge envía las BPDU de configuración.

  • Roles de puerto: puerto raíz, puerto designado, puerto alternativo y puerto de respaldo.

  • Estados de puerto: descartando, aprendiendo y enviando.

  • Tipos de puerto: puerto de borde (PortFast), punto a punto y puerto compartido.

Rapid-PVST utiliza RSTP para proporcionar una convergencia más rápida. Cuando cualquier puerto RSTP recibe la BPDU 802.1D heredada, vuelve al STP heredado y las ventajas de la convergencia rápida de 802.1w se pierden al interactuar con puentes heredados.

Configuración

Este ejemplo contiene dos secciones. La primera sección muestra la configuración PVST+ actual. La segunda sección muestra la configuración que se va a migrar de PVST+ a rapid-PVST+.

Nota: Utilice la herramienta Command Lookup Tool (sólo para clientes registrados) para obtener más información acerca de los comandos utilizados en esta sección.

Diagrama de la red

En este documento se utiliza la siguiente configuración de red:

Este diagrama tiene los siguientes switches:

  • Distribution1 y Distribution2, que están en la capa de distribución

  • Dos switches de capa de acceso denominados Access1 (IOS) y Access2 (CatOS)

  • Dos switches de agrupamiento de servidor denominados Services1 y Services2

Las redes VLAN 10, 30 y 100 transmiten tráfico de datos. Las redes VLAN 20, 40 y 200 transmiten tráfico de voz.

rapidpvst-mig-config1.gif

Configuraciones

En este documento se utilizan las configuraciones siguientes:

Configuración de PVST+

Los switches se configuran en PVST+ para transmitir el tráfico de datos y de voz según el diagrama de la red. Éste es un breve resumen de la configuración:

  • El switch Distribution1 se configura para convertirse en un root bridge primario para las redes VLAN de datos 10, 30, 100 mediante el comando Distribution1(config)# spanning-tree vlan 10,30,100 root primary y el root bridge secundario para las redes VLAN de voz 20, 40, 200 utiliza el comando Distribution1(config)# spanning-tree vlan 20,40,200 root secondary.

  • El switch Distribution2 se configura para convertirse en un root bridge primario para las redes VLAN de voz 20, 40, 200 mediante el comando Distribution2(config)# spanning-tree vlan 20,40,200 root primary y el root bridge secundario para las redes VLAN de datos 10, 30, 100 utiliza el comando Distribution2(config)# spanning-tree vlan 10,30,100 root secondary.

  • El comando spanning-tree backbonefast se configura en todos los switches para una conversión de STP más rápida en caso de un fallo de enlace directo en la red.

  • El comando spanning-tree uplinkfast se configura en los switches de capa de acceso para una conversión de STP más rápida en caso de fallo de enlace directo.

Distribution1

Distribution1#show running-config
 Building configuration...
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 24576
spanning-tree vlan 20,40,200 priority 28672
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
 !
 end

El puerto Fa1/0/24 se configura con el comando spanning-tree vlan 20,40,200 port-priority 64 como se indica. Distribution2 se configura como raíz para las redes VLAN 20, 40, 200. Distribution2 tiene dos enlaces a Distribution1: Fa1/0/23 y Fa1/0/24. Ambos puertos son puertos designados para las redes VLAN 20, 40, 200 porque Distribution2 es la raíz para dichas redes. Ambos puertos tienen la misma prioridad: 128 (predeterminada). Asimismo, estos dos enlaces tienen el mismo costo para Distribution1: fa1/0/23 y fa1/0/24. Distribution1 elige el número de puerto más bajo de los dos puertos para establecer el puerto en estado de reenvío. El número de puerto más bajo es Fa1/0/23. Sin embargo, según el diagrama de la red, las redes VLAN de voz 20, 40, 200 deben pasar por Fa1/0/24. Esto se consigue mediante los métodos siguientes:

  1. Disminuir el costo de puerto en Distribution1: Fa1/0/24

  2. Disminuir la prioridad de puerto en Distribution2: Fa1/0/24

En este ejemplo, la prioridad de puerto se disminuye para reenviar las redes VLAN 20, 40, 200 a través de Fa1/0/24.

Distribution2

Distribution2#show running-config
 Building configuration...
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 28672
spanning-tree vlan 20,40,200 priority 24576
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 20,40,200 port-priority 64
 switchport trunk allowed vlan 10,20,30,40,100,200

end

Puede ver que el puerto Fa0/5 en Services1 y los puertos Fa0/6 y Fa0/48 en Services2 tienen configuración de costo y prioridad de puerto de árbol de expansión. Aquí el STP se ajusta de modo que las redes VLAN 100 y 200 de Services1 y Services2 puedan pasar por los enlaces troncales entre ellos. Si no se aplica esta configuración, Services1 y 2 no pasarán por los enlaces troncales entre ellos. En su lugar, elige la ruta a través de Distribution1 y Distribution2.

Services2 ve dos rutas de igual costo a la raíz de la red VLAN 100 (Distribution1): una a través de Services1 y la segunda a través de Distribution2. El STP elige la mejor ruta (puerto raíz) en este orden:

  1. Costo de ruta

  2. ID de puente (bridge ID) del switch de reenvío

  3. Prioridad de puerto más baja

  4. Número de puerto interno más bajo

En este ejemplo, ambas las rutas tienen el mismo costo. Sin embargo, Distribution2 (24576) tiene una prioridad más baja que Services1 (32768) para la red VLAN 100. Por lo tanto, Services2 elige Distribution2. En este ejemplo, el costo de puerto en Services1: fa0/5 se establece en un valor más bajo para permitir que Services2 elija Services1. El costo de ruta anula el número de prioridad del switch de reenvío.

Services1

Services1#show running-config
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 100 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
!
 end

Se aplica el mismo concepto para que Services1 elija Services2 para reenviar la red VLAN 200. Después de reducir el costo de la red VLAN 200 en Services2: fa0/6, Services1 elije fa0/47 para reenviar la red VLAN 200. Sin embargo, el requerimiento aquí es reenviar la red VLAN 200 a través de fa0/48. Esto se consigue mediante los métodos siguientes:

  1. Disminuir el costo de puerto en Services1: Fa0/48

  2. Disminuir la prioridad de puerto en Services2: Fa0/48

En este ejemplo, la prioridad de puerto en Services2 se disminuye para reenviar la red VLAN 200 a través de fa0/48.

Services2

Services2#show running-config
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 port-priority 64
 switchport trunk allowed vlan 100,200
!
 !
 end

Access1

Access1#show running-config
 Building configuration...
!
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree backbonefast
!
vlan 10,20
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
 end

Access2

Access2> (enable)show config all

#mac address reduction
set spantree macreduction enable
!
#stp mode
set spantree mode pvst+
!
#uplinkfast groups
set spantree uplinkfast enable rate 15 all-protocols off
!
#backbonefast
set spantree backbonefast enable
!
#vlan parameters
set spantree priority 49152  1
set spantree priority 49152  30
set spantree priority 49152  40
!
#vlan(defaults)
set spantree enable  1,30,40
set spantree fwddelay 15     1,30,40
set spantree hello    2      1,30,40
set spantree maxage   20     1,30,40
!
#vtp
set vlan 1,30,40
!
#module 3 : 48-port 10/100BaseTX Ethernet
set trunk 3/3  on dot1q 30,40
set trunk 3/4  on dot1q 30,40
!
 end

UplinkFast y BackboneFast

Conviene conocer el comportamiento de UplinkFast y de BackboneFast antes de iniciar el proceso de migración. En el diagrama de la red, el switch Access1 ejecuta Cisco IOS. Se obtiene este resultado antes de la migración al modo rapid-PVST+:

Access1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    24586
             Address     0015.63f6.b700
             Cost        3019
             Port        107 (FastEthernet3/0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    49162  (priority 49152 sys-id-ext 10)
             Address     000f.f794.3d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300
  Uplinkfast enabled

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa3/0/1          Root FWD 3019      128.107  P2p
Fa3/0/2          Altn BLK 3019      128.108  P2p


Access1#show spanning-tree summary
Switch is in pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is enabled
BackboneFast                 is enabled
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

Se obtiene este resultado después de cambiar el modo a rapid-PVST+:

Access1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    24586
             Address     0015.63f6.b700
             Cost        3019
             Port        107 (FastEthernet3/0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    49162  (priority 49152 sys-id-ext 10)
             Address     000f.f794.3d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300
  UplinkFast enabled but inactive in rapid-pvst mode

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa3/0/1          Root FWD 3019      128.107  P2p
Fa3/0/2          Altn BLK 3019      128.108  P2p

Access1#show spanning-tree summary
Switch is in rapid-pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is enabled but inactive in rapid-pvst mode
BackboneFast                 is enabled but inactive in rapid-pvst mode
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

Puede ver en el resultado del comando show spanning-tree summary que UplinkFast y BackboneFast están activados, pero que están inactivos en el modo rapid-PVST. Es opcional eliminar ambos comandos. Aunque los comandos no se eliminen, no afectan a ninguna de las operaciones de rapid-PVST. Si desactiva UplinkFast con el comando de modo de configuración no spanning-tree uplinkfast, la prioridad de puente y el costo de puerto vuelven a los valores predeterminados. Se recomienda que la prioridad de puente del switch que no sea raíz tenga un número más alto. Este resultado se muestra después de desactivar la función UplinkFast en el modo rapid-PVST:

Access1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    24586
             Address     0015.63f6.b700
             Cost        19
             Port        107 (FastEthernet3/0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     000f.f794.3d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa3/0/1          Root FWD 19        128.107  P2p
Fa3/0/2          Altn BLK 19        128.108  P2p

Access1#show spanning-tree summary
Switch is in rapid-pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is disabled
BackboneFast                 is enabled but inactive in rapid-pvst mode
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

CatOS no permite cambiar el modo a rapid-PVST si la función BackboneFast está activada. Tiene que desactivar BackboneFast antes de la migración. UplinkFast actúa igual que se comporta en IOS.

Access2> (enable) set spantree mode rapid-pvst+
Cannot change the spantree mode to RAPID-PVST+ when backbonefast is enabled.

Migración Rapid-PVST+

Rapid-PVST+ utiliza el mismo formato de BPDU que 802.1D y es compatible con versiones anteriores. Es difícil convertir todos los switches de la red de empresa al mismo tiempo a rapid-PVST+. Gracias a la compatibilidad con versiones anteriores, puede realizar una conversión fase por fase. Se recomienda implementar los cambios en la ventana de mantenimiento programada porque la reconfiguración del árbol de expansión altera el flujo de tráfico. Las funciones UplinkFast y BackboneFast del árbol de expansión son funciones de PVST+. Éstas se desactivan al activar rapid-PVST+ porque dichas funciones están integradas en rapid-PVST+. Por lo tanto, durante la migración puede eliminar esos comandos. La configuración de las funciones tales como PortFast, BPDUguard, BPDUfilter, protector de raíz y protector de bucles también se aplica en el modo rapid-PVST+. El uso de estas funciones es el mismo que en modo PVST+. Si ya ha activado estas funciones en el modo PVST+, siguen activas después de la migración al modo rapid-PVST+. En este ejemplo, la migración se produce en este orden:

  1. Access1

  2. Access2

  3. Services1 y Services2

  4. Distribution1 y Distribution2

  1. Migración de Access1:

    Access1(config)#spanning-tree mode rapid-pvst
    Access1(config)#no spanning-tree uplinkfast
    Access1(config)#no spanning-tree backbonefast
    
    
    Access1#show spanning-tree vlan 10
    
    VLAN0010
      Spanning tree enabled protocol rstp
      Root ID    Priority    24586
                 Address     0015.63f6.b700
                 Cost        19
                 Port        107 (FastEthernet3/0/1)
                 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
    
      Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
                 Address     000f.f794.3d00
                 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
                 Aging Time 300
    
    Interface        Role Sts Cost      Prio.Nbr Type
    ---------------- ---- --- --------- -------- --------------------------------
    Fa3/0/1          Root FWD 19        128.107  P2p Peer(STP)
    Fa3/0/2          Altn BLK 19        128.108  P2p Peer(STP)
    
    
    !--- Type P2p Peer(STP) represents that the neighbor switch runs PVST.
    
    
  2. Migración de Access2:

    Access2> (enable) set spantree backbonefast disable
    Backbonefast disabled for all VLANs.
    
    Access2> (enable) set spantree mode rapid-pvst+
    PVST+ database cleaned up.
    Spantree mode set to RAPID-PVST+.
    
    
    Access2> (enable) clear spantree uplinkfast
    This command will cause all portcosts, portvlancosts, and the
    bridge priority on all vlans to be set to default.
    Do you want to continue (y/n) [n]? y
    VLANs 1-4094 bridge priority set to 32768.
    The port cost of all bridge ports set to default value.
    The portvlancost of all bridge ports set to default value.
    uplinkfast all-protocols field set to off.
    uplinkfast disabled for bridge.
  3. Migración de Services1 y Services2:

    Services1(config)#spanning-tree mode rapid-pvst
    Services1(config)#no spanning-tree backbonefast
    
    Services2(config)#spanning-tree mode rapid-pvst
    Services2(config)#no spanning-tree backbonefast
    
  4. Migración de Distribution1 y Distribution2:

    Distribution1(config)#spanning-tree mode rapid-pvst
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan200, changed state to
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    down
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    down
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    
    !--- Distribution1 switch has Layer3 VLAN interfaces and it goes
    !--- down and up during the conversion.
    
    
    Distribution1(config)#no spanning-tree backbonefast
    
    
    Distribution2(config)#spanning-tree mode rapid-pvst
    
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to
    own
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to
    p
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state t
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan200, changed state t
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    down
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    
    !--- Distribution2 switch has Layer3 VLAN interfaces and it goes
    !--- down and up during the conversion.
    
    
    Distribution2(config)#no spanning-tree backbonefast
    

Resultado de la depuración: modo combinado

En una gran red de empresas, el proceso de migración puede tardar varios días. Durante el proceso de migración, puede ejecutar la LAN en modo combinado, con algunos switches en PVST+ y otros en modo rapid-PVST+. En modo combinado, no aprovecha todas las ventajas de rapid-PVST+. El tiempo total de convergencia es el mismo que el del modo PVST+. Para aprovechar todas las ventajas de rapid-PVST+, todos los switches de la topología de árbol de expansión deben ejecutar rapid-PVST+. Para mostrar cómo se comporta el árbol de expansión en el modo combinado, a continuación se muestra el resultado del comando debug. Distribution1 y Distribution2 están en modo PVST+, y Access1 está en modo rapid-PVST+.

El resultado del comando debug spanning-tree muestra el funcionamiento del STP cuando falla el enlace entre Access1 y Distribution1.

Access1

00:55:13: RSTP(10): updt roles, root port Fa0/1 going down
00:55:13: RSTP(10): Fa0/2 is now root port
00:55:13: RSTP(10): Fa0/2 received a tc ack
00:55:15: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to adminis
tratively down
00:55:16: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, cha
nged state to down

Distribution1

00:55:20: STP: VLAN0010 Topology Change rcvd on Fa1/0/23
00:55:20: STP: VLAN0020 sent Topology Change Notice on Fa1/0/24
00:55:21: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1,
changed state to down
00:55:22: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to down

Distribution2

00:55:06: STP: VLAN0010 Topology Change rcvd on Fa1/0/2
00:55:06: STP: VLAN0010 sent Topology Change Notice on Fa1/0/23

El resultado del comando debug spanning-tree muestra el funcionamiento del STP cuando el enlace entre Access1 y Distribution1 está activo.

Access1

00:55:40: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
00:55:43:  STP: PVST vlan 10 port Fa0/1 created, ext id 2E42430, vp 3389640
00:55:43: RSTP(10): initializing port Fa0/1
00:55:43: RSTP(10): Fa3/0/1 is now designated
00:55:43:  STP: PVST vlan 20 port Fa0/1 created, ext id 2E42430, vp 300EC20
00:55:43: RSTP(20): initializing port Fa0/1
00:55:43: RSTP(20): Fa0/1 is now designated
00:55:43: RSTP(10): transmitting a proposal on Fa0/1
00:55:43: RSTP(20): transmitting a proposal on Fa0/1
00:55:43: RSTP(10): transmitting a proposal on Fa0/1
00:55:43: RSTP(20): transmitting a proposal on Fa0/1
00:55:43: RSTP(10): updt roles, received superior bpdu on Fa0/1
00:55:43: RSTP(10): Fa0/1 is now root port
00:55:43: RSTP(10): Fa0/2 blocked by re-root
00:55:43: RSTP(10): Fa0/2 is now alternate
00:55:44: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, cha
nged state to up
00:55:44: RSTP(20): updt roles, received superior bpdu on Fa0/1
00:55:44: RSTP(20): Fa0/1 is now alternate

Distribution1

00:55:49: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to up
00:55:50: set portid: VLAN0010 Fa1/0/1: new port id 8001
00:55:50:  STP: PVST vlan 10 port Fa1/0/1 created, ext id 2DA13A8, vp 3BDB708
00:55:50: STP: VLAN0010 Fa1/0/1 -> listening
00:55:50: set portid: VLAN0020 Fa1/0/1: new port id 8001
00:55:50:  STP: PVST vlan 20 port Fa1/0/1 created, ext id 2DA13A8, vp 3C06F20
00:55:50: STP: VLAN0020 Fa1/0/1 -> listening
00:55:51: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1,
changed state to up
00:56:05: STP: VLAN0010 Fa1/0/1 -> learning
00:56:05: STP: VLAN0020 Fa1/0/1 -> learning
00:56:20: STP: VLAN0010 Fa1/0/1 -> forwarding
00:56:20: STP: VLAN0020 sent Topology Change Notice on Fa1/0/24
00:56:20: STP: VLAN0020 Fa1/0/1 -> forwarding


!--- This output is evident that the Access1 switch waits for the
!--- standard 802.1D Spanning Tree process of listening, learning 
!--- and forwarding to complete in Distribution1.




Distribution2

00:55:06: STP: VLAN0020 Topology Change rcvd on Fa1/0/24
00:56:06: STP: VLAN0020 Topology Change rcvd on Fa1/0/24


!--- This output shows that Distribution2 is notified
!--- about the indirect link outage by TCN BPDUs.

Resultado de la depuración: modo Rapid-PVST+

Los switches Distribution1, Distribution2 y Access1 están en modo rapid-PVST+. El resultado del comando debug spanning-tree muestra el funcionamiento del STP cuando falla el enlace entre Access1 y Distribution1.

Access1

01:31:04: RSTP(10): updt roles, root port Fa0/1 going down
01:31:04: RSTP(10): Fa0/2 is now root port
01:31:06: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to adminis
tratively down
01:31:07: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, cha
nged state to down

Distribution1

01:31:13: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1,
changed state to down
01:31:14: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to down

El resultado del comando debug spanning-tree muestra el funcionamiento del STP cuando el enlace entre Access1 y Distribution1 está activo.

Access1

01:35:46: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
01:35:48:  STP: PVST vlan 10 port Fa3/0/1 created, ext id 2E42430, vp 3C8E360
01:35:48: RSTP(10): initializing port Fa3/0/1
01:35:48: RSTP(10): Fa3/0/1 is now designated
01:35:48:  STP: PVST vlan 20 port Fa3/0/1 created, ext id 2E42430, vp 3C8E3E0
01:35:48: RSTP(20): initializing port Fa3/0/1
01:35:48: RSTP(20): Fa3/0/1 is now designated
01:35:48: RSTP(10): updt roles, received superior bpdu on Fa3/0/1
01:35:48: RSTP(10): Fa3/0/1 is now root port
01:35:48: RSTP(10): Fa3/0/2 blocked by re-root
01:35:48: RSTP(10): synced Fa3/0/1
01:35:48: RSTP(10): Fa3/0/2 is now alternate
01:35:48: RSTP(20): updt roles, received superior bpdu on Fa3/0/1
01:35:48: RSTP(20): Fa3/0/1 is now alternate
01:35:48: RSTP(10): transmitting an agreement on Fa3/0/1 as a response to a prop
osal

Distribution1

01:35:55: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to up
01:35:56:  STP: PVST vlan 10 port Fa1/0/1 created, ext id 2DA13A8, vp 3BDCCD8
01:35:56: RSTP(10): initializing port Fa1/0/1
01:35:56: RSTP(10): Fa1/0/1 is now designated
01:35:56:  STP: PVST vlan 20 port Fa1/0/1 created, ext id 2DA13A8, vp 2D21C60
01:35:56: RSTP(20): initializing port Fa1/0/1
01:35:56: RSTP(20): Fa1/0/1 is now designated
01:35:56: RSTP(10): transmitting a proposal on Fa1/0/1
01:35:56: RSTP(20): transmitting a proposal on Fa1/0/1
01:35:56: RSTP(10): received an agreement on Fa1/0/1
01:35:57: RSTP(20): transmitting a proposal on Fa1/0/1
01:35:59: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:01: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:03: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:06: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:08: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:10: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:11: RSTP(20): Fa1/0/1 fdwhile Expired
01:36:12: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:14: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:16: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:18: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:20: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:22: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:24: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:26: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:26: RSTP(20): Fa1/0/1 fdwhile Expired


!--- Distribution1 puts the port Fa1/0/1 as designated for VLANs 10 and 20.
!--- It also proposes that Fa1/0/1 is designated for VLANs 10, 20. Access1 
!--- agrees with the proposal for VLAN10. However, it does not agree with
!--- the proposal for VLAN20 because it has the superior BPDU for VLAN20 
!--- from Distribution2.

Verificación

Utilice esta sección para confirmar que la configuración funciona correctamente.

La herramienta Output Interpreter (Intérprete de resultados) (OIT) (sólo para clientes registrados) admite determinados comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Se recomienda verificar la topología de árbol de expansión cada vez que se cambie la configuración.

Verifique que el switch Distribution1 es el root bridge para las redes VLAN de datos 10, 30, 100. Asimismo, verifique que la ruta de reenvío del árbol de expansión se corresponde con la ruta del diagrama de la red.

Distribution1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    24586
             Address     0015.63f6.b700
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    24586  (priority 24576 sys-id-ext 10)
             Address     0015.63f6.b700
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- ------------------------------
Fa1/0/1          Desg FWD 19        128.1    P2p
Fa1/0/3          Desg FWD 19        128.3    P2p
Fa1/0/5          Desg FWD 19        128.5    P2p
Fa1/0/23         Desg FWD 19        128.23   P2p
Fa1/0/24         Desg FWD 19        128.24   P2p


Access1#show spanning-tree summary
Switch is in rapid-pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is disabled
BackboneFast                 is disabled
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

Access2> (enable) show spantree 30
VLAN 30
Spanning tree mode          RAPID-PVST+
Spanning tree type          ieee
Spanning tree enabled

Designated Root             00-15-63-f6-b7-00
Designated Root Priority    24606
Designated Root Cost        19
Designated Root Port        3/3
Root Max Age   20 sec   Hello Time 2  sec   Forward Delay 15 sec

Bridge ID MAC ADDR          00-d0-00-50-30-1d
Bridge ID Priority          32768
Bridge Max Age 20 sec   Hello Time 2  sec   Forward Delay 15 sec

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- ----------------
 3/3                     forwarding    ROOT        19   32 P2P
 3/4                     blocking      ALTR        19   32 P2P

Access2> (enable) show spantree 40
VLAN 40
Spanning tree mode          RAPID-PVST+
Spanning tree type          ieee
Spanning tree enabled

Designated Root             00-15-c6-c1-30-00
Designated Root Priority    24616
Designated Root Cost        19
Designated Root Port        3/4
Root Max Age   20 sec   Hello Time 2  sec   Forward Delay 15 sec

Bridge ID MAC ADDR          00-d0-00-50-30-27
Bridge ID Priority          32768
Bridge Max Age 20 sec   Hello Time 2  sec   Forward Delay 15 sec

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- ----------------
 3/3                     blocking      ALTR        19   32 P2P
 3/4                     forwarding    ROOT        19   32 P2P


Services1#show spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol rstp
  Root ID    Priority    24676
             Address     0015.63f6.b700
             Cost        18
             Port        7 (FastEthernet0/5)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     0003.fd63.bb80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- -----------------------------
Fa0/5            Root FWD 18        128.7    P2p
Fa0/46           Desg FWD 19        128.50   P2p
Fa0/47           Desg FWD 19        128.51   P2p

Services1#show spanning-tree vlan 200

VLAN0200
  Spanning tree enabled protocol rstp
  Root ID    Priority    24776
             Address     0015.c6c1.3000
             Cost        37
             Port        51 (FastEthernet0/47)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     0003.fd63.bb80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- -----------------------------
Fa0/5            Altn BLK 19        128.7    P2p
Fa0/46           Altn BLK 19        128.50   P2p
Fa0/47           Root FWD 19        128.51   P2p

Services2#show spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol rstp
  Root ID    Priority    24676
             Address     0015.63f6.b700
             Cost        37
             Port        42 (GigabitEthernet0/42)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     00d0.2bfc.7d80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- -----------------------------
Fa0/6            Altn BLK 19        128.6    P2p
Fa0/42           Root FWD 19        128.42   P2p
Fa0/43           Altn BLK 19        128.43   P2p

Services2#show spanning-tree vlan 200

VLAN0200
  Spanning tree enabled protocol rstp
  Root ID    Priority    24776
             Address     0015.c6c1.3000
             Cost        18
             Port        6 (GigabitEthernet0/6)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     00d0.2bfc.7d80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- -----------------------------
Fa0/6            Root FWD 18        128.6    P2p
Fa0/42           Desg FWD 19        128.42   P2p
Fa0/43           Desg FWD 19         64.43   P2p

Resolución de problemas

Actualmente, no hay información específica disponible sobre resolución de problemas para esta configuración.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 72836