Seguridad y VPN : Negociación IPSec/Protocolos IKE

Ejemplo de configuración de IPSec dinámico a estático de router a PIX con NAT

23 Junio 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (8 Marzo 2007) | Comentarios

Contenidos

Introducción
Requisitos previos
     Requisitos
     Componentes utilizados
     Convenciones
Configuración
     Diagrama de la red
     Configuraciones
Verificación
Resolución de problemas
     Comandos para resolución de problemas
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

Este documento proporciona un ejemplo de configuración que muestra cómo permitir que el router acepte las conexiones IPSec dinámicas desde un PIX. El router remoto realiza la traducción de direcciones de red (NAT) si la red privada 10.0.0.x tiene acceso a Internet. El tráfico desde 10.0.0.x hacia la red privada 10.1.0.x detrás del PIX se excluye del proceso NAT. El router puede iniciar conexiones hacia el PIX, pero este dispositivo no puede iniciar conexiones hacia el router.

Para obtener más información sobre el escenario donde el PIX acepta conexiones IPSec dinámicas desde el router, consulte Configuración de IPSec dinámico a estático de PIX a router con NAT.

Consulte Ejemplo de configuración de IPSec entre un router de IOS estático y un PIX/ASA 7.x dinámico con NAT para obtener más información sobre el mismo escenario donde el dispositivo de seguridad PIX/ASA ejecuta la versión 7.x del software.

Requisitos previos

Requisitos

No hay requisitos específicos para este documento.

Componentes utilizados

La información de este documento se basa en estas versiones de software y hardware:

  • Versión 12.3.(8)T5 del software Cisco IOS®

  • Versión 6.3.4 del software de Cisco PIX Firewall

  • Cisco Secure PIX Firewall 515E

  • Router Cisco 2811

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración despejada (predeterminada). Si la red está en producción, asegúrese de comprender el impacto que pueda tener cualquier comando.

Convenciones

Consulte Cisco Technical Tips Conventions (Convenciones sobre consejos técnicos de Cisco) para obtener más información sobre las convenciones del documento.

Configuración

En esta sección se presenta la información para configurar las funciones descritas en este documento.

Nota: emplee la herramienta de búsqueda de comandos ( sólo para clientes registrados) para buscar más información sobre los comandos utilizados en este documento.

Diagrama de la red

Este documento utiliza esta configuración de red:

router-pix-dynm-static-config-1.gif

Configuraciones

Este documento usa estas configuraciones:

PIX 515E

PIX Version 6.3(4)
interface ethernet0 100full
interface ethernet1 100full
interface ethernet2 shut
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 intf2 security4
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname PIX515E
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names


                     !--- La lista de control de acceso (ACL) para evitar la traducción NAT en paquetes IPSec.
                  

                  access-list NO-NAT permit ip 10.1.0.0 255.255.255.0 10.0.0.0 255.255.255.0

                  
                     !--- La ACL que se aplica en la correspondencia de criptografía.
!--- Incluya el tráfico entre redes privadas
!--- en el proceso de cifrado.
                  

                  access-list 101 permit ip 10.1.0.0 255.255.255.0 10.0.0.0 255.255.255.0
pager lines 24
logging on
mtu outside 1500
mtu inside 1500
mtu intf2 1500
ip address outside 10.95.49.11 255.255.255.0
ip address inside 10.1.0.3 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
no failover
failover timeout 0:00:00
failover poll 15
no failover ip address outside
no failover ip address inside
no failover ip address intf2
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list NO-NAT
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 10.0.0.0 255.255.255.0 10.95.49.21 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec


                  
                     !--- Configuración de IPSec, Fase 2.
                  

                  crypto ipsec transform-set DYN-TS esp-des esp-md5-hmac
crypto map IPSEC 10 ipsec-isakmp
crypto map IPSEC 10 match address 101
crypto map IPSEC 10 set peer 10.95.49.21
crypto map IPSEC 10 set transform-set DYN-TS
crypto map IPSEC interface outside

                  
                     !--- Política del Protocolo de asociación de seguridad en Internet y administración
!--- de claves (ISAKMP), Fase 1.
!--- Nota: en el resultado real del comando show run, la clave previamente compartida aparece como *******.
                  

                  isakmp enable outside
isakmp key cisco123 address 10.95.49.21 netmask 255.255.255.255
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 86400

telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:f0294298e214a947fc2e03f173e4a405
: end

R2 (router Cisco 2811)

R2#show running-configuration
Building configuration...

Current configuration : 1916 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname r1800
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip ips deny-action ips-interface
!
no ftp-server write-enable
!
!

                     !--- Política ISAKMP, Fase 1.
                  

                  crypto isakmp policy 10
hash md5
authentication pre-share
crypto isakmp key 6 cisco123 address 0.0.0.0 0.0.0.0
!
!

                     !--- Política IPSec, Fase 2.
                  

                  crypto ipsec transform-set DYN-TS esp-des esp-md5-hmac
!
crypto dynamic-map DYN 10
set transform-set DYN-TS
match address 101
!
!
crypto map IPSEC 10 ipsec-isakmp dynamic DYN
!
!
!
interface FastEthernet0/0
ip address 10.95.49.21 255.255.255.0
ip nat outside
ip virtual-reassembly
load-interval 30
duplex auto
speed auto
crypto map IPSEC
!
interface FastEthernet0/1
ip address 10.0.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
ip classless
ip route 10.1.0.0 255.255.255.0 10.95.49.11
!
ip http server
no ip http secure-server

                     !--- Excluya la red privada del proceso NAT.
                  

                  ip nat inside source list 102 interface FastEthernet0/0 overload
!

                     !--- Incluya el tráfico entre redes privadas
!--- en el proceso de cifrado.
                  

                  access-list 101 permit ip 10.0.0.0 0.0.0.255 10.1.0.0 0.0.0.255


                  
                     !--- Excluya la red privada del proceso NAT.
                  

                  access-list 102 deny ip 10.0.0.0 0.0.0.255 10.1.0.0 0.0.0.255
access-list 102 permit ip 10.0.0.0 0.0.0.255 any
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
exec-timeout 0 0
login
!
end

Verificación

Utilice esta sección para confirmar que la configuración funciona de manera adecuada.

La herramienta intérprete de resultados ( sólo para clientes registrados) (OIT) admite algunos comandos show. Utilice OIT para ver un análisis de los resultados del comando show.

  • show crypto isakmp sa: muestra todas las asociaciones de seguridad (SA) IKE actuales de un par.

  • show crypto ipsec sa: muestra la configuración utilizada por las SA actuales (IPSec).

  • show crypto engine connections active: muestra información y conexiones actuales sobre paquetes cifrados y descifrados (router únicamente).

Debe verificar las asociaciones de seguridad en ambos pares.

Ejecute los siguientes comandos PIX en el modo de configuración.

  • clear crypto isakmp sa: borra las SA de la fase 1.

  • clear crypto ipsec sa: borra las SA de la fase 2.

Ejecute estos comandos de router en el modo habilitar.

  • clear crypto isakmp: borra las SA de la fase 1.

  • clear crypto sa: borra las SA de la fase 2.

Resolución de problemas

Utilice esta sección para solucionar los problemas de configuración.

Comandos para resolución de problemas

La herramienta intérprete de resultados ( sólo para clientes registrados) (OIT) admite algunos comandos show. Utilice OIT para ver un análisis de los resultados del comando show.

Nota: consulte Important Information on Debug Commands (Información importante sobre los comandos de depuración) antes de utilizar los comandos debug.

  • show crypto isakmp sa: muestra todas las SA IKE actuales en un par.

  • show crypto ipsec sa: muestra la configuración utilizada por las SA actuales (IPSec).

  • show crypto engine connections active: muestra información y conexiones actuales sobre paquetes cifrados y descifrados (router únicamente).


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 66173