Voz y Comunicaciones unificadas : Cisco Unified Communications Manager (CallManager)

Configuración de la gateway MGCP de Cisco IOS

23 Marzo 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (1 Noviembre 2006) | Comentarios

Contenidos

Introducción
Requisitos previos
     Requisitos
     Componentes utilizados
     Convenciones
Tareas que deben realizarse
     Paso a paso
Resumen
Configuraciones
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

Este documento:

  • Le ayudará con una configuración simple del protocolo de control de gateway de medios (MGCP)

  • Presenta el número mínimo de comandos necesarios para generar una configuración que funcione con un router con dos puertos de Oficina de intercambio remota (FXO) y dos puertos de Estación de intercambio remota (FXS)

Nota: Las instrucciones que se incluyen en este documento funcionan en routers Cisco Voice Gateway 200 (VG200) y Cisco de las series 2600 y 3600 que ejecutan la versión 12.1(5)T y versiones posteriores del software Cisco IOS®. Consulte la documentación del software Cisco IOS para obtener las versiones del software compatible de otras gateways MGCP de Cisco IOS.

Síntomas:

Es posible que se produzcan los siguientes síntomas al configurar Cisco CallManager en gateways Cisco IOS MGCP con puertos FXO y FXS analógicos:

  • La gateway MGCP no puede registrarse con Cisco CallManager. Consulte Error de registro de gateway MGCP con Cisco CallManager.

  • El identificador de llamada no funciona en los puertos FXO. Esto es debido a que el identificador de llamada no es compatible con los puertos FXO configurados para MGCP. En su lugar, configure la gateway en el modo H.323.

  • La paginación de taras bloquea los puertos FXO durante la función hookflash a menos que los usuarios se desconecten por completo. La desconexión seguida por reinicios sin desconectar el puerto. Este error está relacionado con el identificador de error de funcionamiento de Cisco CSCef62275 (solamente clientes registrados) al corregirse en la versión 12.3(14)T y posterior del software Cisco IOS.

Este documento es la cuarta parte de un conjunto de seis documentos:

Requisitos previos

Requisitos

Cisco recomienda tener conocimientos sobre los siguientes temas:

  • Una gateway de Cisco IOS que ejecute una versión del software Cisco IOS que sea compatible con MGCP con Cisco CallManager

  • Cisco VG200

Nota: Hay otras series de versiones del software Cisco IOS que soportan MGCP en routers Cisco, por ejemplo, la versión 12.1XM del software Cisco IOS.

precauciónPrecaución: La sintaxis de algunos comandos de MGCP es diferente en otras versiones del software Cisco IOS. Consulte la documentación de la configuración para determinar la sintaxis necesaria.

Componentes utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware:

  • 1 * Cisco VG200 / 2 X FXS / 2 X FXO / 1 Fast Ethernet 10/100; versión 12.1(5)T del software Cisco IOS

  • 1 * Cisco CallManager 3.0(5a) que se ejecuta en MCS7835

  • 2 * Auriculares analógicos

  • 2* Teléfonos IP 7960 de Cisco

Consulte Matriz de compatibilidad de Cisco CallManager para conocer la compatibilidad recomendada de las versiones de software entre Cisco CallManager y la gateway de Cisco IOS.

Nota: Se recomienda la versión 12.2(11)T y versiones posteriores del software Cisco IOS según las mejoras del comando ccm-manager. El comando ccm-manager requiere la versión 12.1(5)XM y versiones posteriores del software Cisco IOS en todos los routers (2600 y 3600) y VG200.

Los routers 2600 y 3600 soportan MGCP si ejecutan la versión 12.1(3)T o versiones posteriores del software Cisco IOS. Las versiones del software que se necesitan dependen de las funciones que desea habilitar. El servidor Cisco CallManager debe ejecutar la versión 3.0(5)a o posterior del software. La configuración del router es la misma para todos los tipos de router. La configuración de Cisco CallManager es también la misma para todos los tipos de router.

La versión 12.1(5)XM1 y versiones posteriores del software Cisco IOS soportan el VG200. Las versiones del software que se necesitan dependen de las funciones que desea habilitar. Use la versión 3.0(5)a y versiones posteriores del software aunque el VG200 es compatible con versiones anteriores del software Cisco CallManager.

Nota: Hay otras series de versiones del software Cisco IOS que soportan MGCP en routers Cisco, por ejemplo, la versión 12.1XM del software Cisco IOS.

precauciónPrecaución: La sintaxis de algunos comandos de MGCP es diferente en otras versiones del software Cisco IOS. Consulte la documentación de la configuración para determinar la sintaxis necesaria.

La información que contiene este documento se creó a partir de los dispositivos en un entorno de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración despejada (predeterminada). Si la red está funcionando, asegúrese de comprender el efecto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información acerca de convenciones del documento.

Tareas que deben realizarse

Complete estos pasos:

  1. Configure una dirección IP en la interfaz Ethernet de la gateway de Cisco IOS.

  2. Asigne un nombre único a la gateway de Cisco IOS.

  3. Configure la gateway de Cisco IOS para que ejecute MGCP como protocolo de señalización.

  4. Configure la dirección IP o el sistema de nombres de dominio (DNS) para el servidor Cisco CallManager.

  5. Seleccione el tipo de codec y la función de relé multifrecuencia de tono dual (DTMF).

  6. Informe a la gateway de Cisco IOS que se comunica con un servidor Cisco CallManager.

  7. Vincule la aplicación MGCP con los puertos de voz.

  8. Habilite los puertos de voz.

  9. Habilite la conectividad IP.

Paso a paso

Nota: El resto de este documento se refiere al VG200, el cual se inicia con la configuración predeterminada de fábrica.

Complete estos pasos:

  1. Configure una dirección IP en la interfaz Ethernet del VG200 y habilite la interfaz.

    router(config)#interface fastethernet 0/0
    
    router(config-if)#ip address 172.16.1.206 255.255.255.0
    
    router(config-if)#no shut
  2. Asigne un nombre único al VG200, para que el servidor Cisco CallManager pueda identificarlo.

    router(config)#hostname VG200A
    
    
    
    /* This is how CallManager keeps track of the MGCP network */
    
    /* devices it is communicating with. This name must be  */
    
    /* unique.         */
  3. Configure el VG200 para que ejecute MGCP como protocolo de señalización.

    VG200A(config)#mgcp
  4. Configure la dirección IP o el nombre DNS para el servidor Cisco CallManager.

    VG200A(config)#mgcp call-agent 172.16.1.252
    VG200A(config)#ccm-manager config server 172.16.1.252
    VG200A(config)#ccm-manager config

    El comando mgcp call-agent se usa para configurar la dirección y el protocolo del agente de llamadas para puntos finales de MGCP en una gateway de medios. Este comando se puede usar para especificar la versión del protocolo que se utiliza. Para obtener más información, consulte mgcp call-agent.

    El comando ccm-manager config server se usa para especificar el servidor TFTP desde el que la gateway de protocolo de control de gateway de medios (MGCP) descarga archivos de configuración XML de Cisco CallManager.

    El comando ccm-manager config es necesario para habilitar la descarga de archivos de configuración XML de Cisco CallManager.

    Nota: Ejecute estos comandos para configurar varios Cisco CallManager redundantes en el agrupamiento de Cisco CallManager.

    VG200(config)#ccm-manager redundant-host [ip-address |
    
    dns-name] [ip-address | dns-name]
    
    VG200(config)#ccm-manager switchback {graceful | immediate
    
    |schedule-time hh:mm | uptime-delay minutes} 
  5. Seleccione el tipo de codec y la función de relé DTMF.

    VG200A(config)#mgcp dtmf-relay codec all mode out-of-band
  6. Ejecute este comando para habilitar la compatibilidad con Cisco CallManager en MGCP:

    VG200A(config)#ccm-manager mgcp
  7. Vincule la aplicación MGCP con los puertos de voz.

    Nota: Ejecute el comando show voice port para determinar el tipo de puertos que el VG200 posee y el orden en el que están instalados.

    VG200A(config)#dial-peer voice 1 pots
    
    VG200A(config)#application MGCPAPP
    
    VG200A(config)#port 1/0/0
    
    
    
    /* FXO port */
    
    
    
    VG200A(config)#dial-peer voice 2 pots
    
    VG200A(config)#application MGCPAPP
    
    VG200A(config)#port 1/0/1
    
    
    
    /* FXO port */
    
    
    
    VG200A(config)#dial-peer voice 3 pots
    
    VG200A(config)#application MGCPAPP
    
    VG200A(config)#port 1/1/0
    
    
    
    /* FXS port */
    
    
    
    VG200A(config)#dial-peer voice 4 pots
    
    VG200A(config)#application MGCPAPP
    
    VG200A(config)#port 1/1/1
    
    
    
    /* FXS port */

    Nota: El comando MGCPAPP de aplicación distingue entre mayúsculas y minúsculas en algunas versiones del software Cisco IOS. Ejecute siempre este comando en mayúsculas a menos que tenga la certeza de que la versión del software no distingue entre mayúsculas y minúsculas. Consulte la salida del comando show running-config para comprobar si la versión del software distingue entre mayúsculas y minúsculas. La versión 12.1.(5)T del software Cisco IOS no distingue entre mayúsculas y minúsculas.

  8. Asegúrese de que los puertos de voz están habilitados.

    Nota: Los comandos shutdown y no shutdown afectan a ambos puertos en una tarjeta de interfaz de voz (VIC). Ejecute este comando únicamente en estos puertos.

    VG200A(config)#voice-port 1/0/0
    
    VG200A(config-voiceport)#no shutdown
    
    Both ports are in service
    
    
    
    /* FXO port */
    
    
    
    VG200A(config)#voice-port 1/1/0
    
    VG200A(config-voiceport)#no shutdown
    
    Both ports are in service
    
    
    
    /* FXS port */s
  9. Habilite la conectividad IP.

    Habilite el IP Routing si alguno de los dispositivos VoIP con los que el VG200 se comunica se encuentra en subredes o VLAN diferentes. También debe crear una red predeterminada o gateway de último recurso. En este paso se muestra cómo realizar ambas tareas:

    VG200A(config)#ip routing
    
    VG200A(config)#ip route 0.0.0.0 0.0.0.0 ip_address_of_gateway

    Nota: El VG200 no es un router IP. En este router no se pueden ejecutar protocolos de IP Routing como, por ejemplo, el Routing Information Protocol (RIP), el Interior Gateway Routing Protocol (IGRP) o el protocolo Open Shortest Path First (OSPF). Se comporta de forma parecida a una estación final (cliente), en lo relacionado con la conectividad IP.

    Nota: Puede configurar un protocolo de ruteo en lugar de rutas estáticas en las demás gateways de Cisco IOS, que son fundamentalmente routers con interfaces de voz. Lo más importante es garantizar la conectividad IP entre los dispositivos VoIP.

    Nota: El comando ip routing no se muestra en la configuración ya que normalmente no está habilitado de forma predeterminada cuando se habilita el IP Routing. Los comandos predeterminados no se muestran normalmente en la configuración de los routers de Cisco. Las imágenes de Cisco IOS del VG200 anulan este comportamiento predeterminado ya que el comando no ip routing se ha incluido en el código de la configuración inicial. Esta configuración se crea al iniciar la imagen:

    • En la plataforma en la que el comando write erase ha borrado la configuración

    • En un VG200 que nunca se haya configurado

    El comando ip route 0.0.0.0 0.0.0.0 ip_address_of_gateway permite que el VG200 instale una gateway de último recurso en la tabla de ruteo. Puede confirmarlo con el comando show ip route. En este ejemplo, la dirección IP de la gateway es 172.16.1.1.

    VG200A#show ip route
    
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    
      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    
      E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    
      i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    
      * - candidate default, U - per-user static route, o - ODR
    
      P - periodic downloaded static route
    
    
    
    La gateway de último recurso es 172.16.1.1 en la red 0.0.0.0
    
    
    
    C 172.16.0.0/16 is directly connected, FastEthernet0/0
    
    S* 0.0.0.0/0 [1/0] via 172.16.1.1
    
    VG200A#

    Nota: El comando ip classless también es necesario para que la gateway de último recurso sea efectivo. El comando ip classless está habilitado de forma predeterminada. Este comando es uno de los escasos comandos predeterminados del software Cisco IOS que se muestra en la configuración cuando está habilitado, además también se muestra cuando está inhabilitado precedido por un no. Ejecute el comando ip classless para habilitar ip classless si la configuración incluye la línea no ip classless.

precauciónPrecaución: Cisco CallManager controla todos los elementos de la configuración relativos al plan de marcado. No configure estos elementos en la gateway de MGCP para puntos finales administrados por MGCP (aquellos que incluyen el comando mgcpapp de aplicación en la sentencia de par de marcado). No configure ninguna de las siguientes funciones:

  • En los pares de marcado

    • destination-pattern

    • session target

  • En los puertos de voz

    • connection { plar | tie-line | trunk }

Resumen

El VG200 ya está preparado para comunicarse con el servidor Cisco CallManager. El VG200 enviará de forma periódica mensajes para intentar establecer una conexión. La conexión se establece automáticamente al completar la configuración del servidor Cisco CallManager. No es necesario realizar modificaciones adicionales en el VG200.

Nota: Reinicie los puertos de la gateway después de completar la configuración, como se muestra en este ejemplo:

router(config)#voice-port 1/0/0

router(config-voiceport)#shutdown

Both ports are out of service

router(config-voiceport)#no shutdown

Configuraciones

En la siguiente tabla se incluye la configuración completa del VG200A para este documento:

Configuración de VG200A

VG200A#show running-config 

Building configuration...



Current configuration : 1244 bytes

!

version 12.1

no service single-slot-reload-enable

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname VG200A

!

boot system flash

boot system rom

boot system tftp vg200 172.16.1.253

no logging buffered

logging rate-limit console 10 except errors

no logging console

enable secret #####

enable password #####

!

ip subnet-zero

no ip finger

no ip domain-lookup

!

mgcp

mgcp call-agent 172.16.1.252

mgcp dtmf-relay codec all mode out-of-band

mgcp sdp simple

call rsvp-sync

!

!

!

!

!

ccm-manager mgcp

!

!

interface FastEthernet0/0

 ip address 172.16.1.206 255.255.0.0

 no ip mroute-cache

 speed auto

 full-duplex

!

ip default-gateway 172.16.1.1

ip classless

no ip http server

!

snmp-server engineID local 000000090200000196983000

snmp-server community public RO

!

voice-port 1/0/0

!

voice-port 1/0/1

!

voice-port 1/1/0

!

voice-port 1/1/1

!

dial-peer voice 1 pots

 application mgcpapp

 port 1/0/0

!

dial-peer voice 2 pots

 application mgcpapp

 port 1/0/1

!

dial-peer voice 3 pots

 application mgcpapp

 port 1/1/0

!

dial-peer voice 4 pots

 application mgcpapp

 port 1/1/1

!

!

line con 0

 transport input none

line aux 0

line vty 0 4

 password ww

 login

!

end



VG200A#

Información de la versión del VG200A

VG200A>show version

Cisco Internetwork Operating System Software

IOS (tm) VG200 Software (VG200-I6S-M), Version 12.1(5)T,

RELEASE SOFTWARE (fc1)



Copyright (c) 1986-2000 by Cisco Systems, Inc.

Compiled Sat 11-Nov-00 10:33 by ccai

Image text-base: 0x80008088, data-base: 0x807D4784



ROM: System Bootstrap, Version 12.1(1r) [phanguye 1r], RELEASE

SOFTWARE (fc1)



VG200A uptime is 19 hours, 37 minutes

System returned to ROM by reload

System image file is "flash:vg200"



cisco VG200 (MPC860) processor (revision 0x102) with 28672K/

4096K bytes of memory

y.

Processor board ID JAB0414058X (0)

M860 processor: part number 0, mask 49

1 FastEthernet/IEEE 802.3 interface(s)

2 Voice FXO interface(s)

2 Voice FXS interface(s)

32K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read/Write)



Configuration register is 0x2102



VG200A>


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 42105