Switching de LAN : Switching de capa 3 y reenvío

Configuración de enrutamiento interVLAN con switches Catalyst de las series 3750/3560/3550

1 Mayo 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (23 Febrero 2012) | Comentarios

Contenidos

Introducción
Requisitos previos
     Requisitos
     Componentes utilizados
     Productos relacionados
     Convenciones
     Teoría precedente
Configurar
     Diagrama de la red
     Configuraciones
Verificación
Resolución de problemas
     Procedimiento de resolución de problemas
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

En este documento se explica cómo configurar el ruteo interVLAN con switches Catalyst de las series 3750/3560/3550. Este documento proporciona un ejemplo de configuración para el ruteo interVLAN con un switch Catalyst de la serie 3550 que ejecuta el software de imagen multicapa mejorada (EMI) en un escenario de red típico. El documento utiliza un switch Catalyst de la serie 2950 y un switch Catalyst de la serie 2948G como switches de armario de Capa 2 (L2) que se conectan al switch Catalyst 3550. La configuración de Catalyst 3550 también incluye un router predeterminado para todo el tráfico que va a Internet cuando el salto siguiente (next hop) apunta a un router Cisco 7200VXR. Puede sustituir un firewall u otros routers por el router Cisco 7200VXR.

Requisitos previos

Requisitos

Antes de utilizar esta configuración, asegúrese de que cumple con los siguientes requisitos:

Componentes utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware:

  • Catalyst 3550-48 que ejecuta la versión 12.1(12c)EA1 EMI de software Cisco IOS®

  • Catalyst 2950G-48 que ejecuta la versión 12.1(12c)EA1 EI de software Cisco IOS

  • Catalyst 2948G que ejecuta la versión 6.3(10) de Catalyst OS (CatOS)

Nota: La configuración del router Cisco 7200VXR no es relevante y, por lo tanto, no se muestra en este documento.

La información que contiene este documento se ha creado a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se han puesto en funcionamiento con una configuración despejada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Productos relacionados

Esta configuración también se puede utilizar con las siguientes versiones de hardware y software:

  • Cualquier router Catalyst 3750/3560/3550 que ejecute software EMI o una imagen multicapa estándar (SMI) de la versión 12.1(11)EA1 y posterior del software Cisco IOS

  • Cualquier modelo de switch Catalyst 2900XL/3500XL/2950/3550 o CatOS, que se utilice como switch de capa de acceso

Convenciones

Consulte Convenciones sobre consejos técnicos de Cisco para obtener más información sobre convenciones del documento.

Teoría precedente

En una red conmutada, las VLAN separan a los dispositivos en diferentes dominios de colisión y subredes de Capa 3 (L3). Los dispositivos dentro de una VLAN pueden comunicarse entre sí sin necesidad de ruteo. Los dispositivos en las VLAN separadas requieren un dispositivo de ruteo para que se comuniquen entre ellos.

Los switches de L2 solamente requieren un dispositivo de ruteo L3. El dispositivo puede ser externo al switch o estar en otro módulo en el mismo chasis. Los nuevos modelos de switches incorporan la capacidad de ruteo en el propio switch. Un ejemplo es el modelo 3550. El switch recibe un paquete, determina si pertenece a otra VLAN y envía el paquete al puerto que corresponde en la otra VLAN.

Un diseño de red típico segmenta la red según el grupo o la función a la que corresponde el dispositivo. Por ejemplo, la VLAN del departamento de ingeniería sólo tendrá dispositivos asociados con el departamento de ingeniería, mientras que en el departamento de finanzas la VLAN sólo tendrá dispositivos relacionados con finanzas. Si se habilita el ruteo, los dispositivos de cada VLAN pueden comunicarse entre ellos sin necesidad de que estén todos en el mismo dominio de transmisión. Este diseño de VLAN además cuenta con la ventaja adicional de permitir al administrador restringir la comunicación entre las VLAN utilizando listas de acceso. En el ejemplo de este documento, puede usar listas de acceso para evitar que la VLAN de ingeniería acceda a los dispositivos de la VLAN de finanzas.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Use la herramienta de búsqueda de comandos (solamente clientes registrados) para buscar más información sobre los comandos que se usan en este documento.

Diagrama de la red

Este documento utiliza esta configuración de red:

189-a.gif

En este diagrama, una pequeña red de ejemplo con Catalyst 3550 proporciona ruteo interVLAN entre diferentes segmentos. De forma predeterminada, el switch Catalyst 3550 actúa como dispositivo L2 con el IP Routing inhabilitado. Para que el router funcione como dispositivo L3 y proporcione ruteo interVLAN, debe habilitar el IP Routing de forma global.

Las siguientes VLAN son las tres VLAN definidas por el usuario:

  • VLAN 2: VLAN de usuario

  • VLAN 3: VLAN de servidor

  • VLAN 10: VLAN de administración

La configuración predeterminada de gateway de cada dispositivo servidor y host debe ser la dirección IP de la interfaz VLAN que corresponde a Catalyst 3550. Por ejemplo, en el caso de los servidores, la gateway predeterminada es 10.1.3.1. Los switches de capa de acceso, Catalyst 2950 y 2948G, tienen conexión troncal con el switch Catalyst 3550.

La ruta predeterminada para Catalyst 3550 apunta hacia el router Cisco 7200VXR. El Catalyst 3550 utiliza este router predeterminado para enrutar el tráfico destinado para Internet. Por lo tanto, el tráfico para el que Catalyst 3550 no tiene entrada en la tabla de ruteo pasa a Cisco 7200VXR para su procesamiento.

Consejos prácticos

  • Separe la VLAN de administración de la VLAN del usuario o del servidor, como se muestra en el diagrama. La VLAN de administración es diferente de la VLAN del usuario o del servidor. Con esta separación, cualquier tormenta de difusión/paquetes que se produzca en la VLAN del usuario o del servidor no afectará a la administración de switches.

  • No utilice la VLAN 1 para administración. Todos los puertos de los switches Catalyst utilizan de forma predeterminada VLAN 1 y cualquier dispositivo que se conecte a puertos no configurados se encuentra en VLAN 1. Si se utiliza VLAN 1 para la administración se pueden producir problemas en la administración de switches, como se explica en el primer consejo.

  • Use un puerto L3 (enrutado) para conectar al puerto predeterminado de la gateway. En este ejemplo, puede sustituir fácilmente un router Cisco 7200VXR por un firewall que se conecte al router de gateway de Internet.

  • No ejecute un protocolo de ruteo entre Catalyst 3550 y el router de gateway de Internet. En este ejemplo, se configura un router predeterminado estático en Catalyst 3550. Esta configuración funciona mejor si únicamente hay una ruta para Internet. Asegúrese de configurar las rutas estáticas (preferentemente resumidas) en el router de gateway (7200VXR) para subredes que pueden ser alcanzadas por Catalyst 3550. Este paso es muy importante ya que esta configuración no usa los protocolos de ruteo.

  • Si tienen dos switches Catalyst 3550 en la red, puede realizar una conexión dual de los switches de capa de acceso a ambos switches 3550 Catalyst. Ejecute el Hot Standby Router Protocol (HSRP) entre los switches para proporcionar redundancia a la red. Para obtener más información acerca de la configuración de HSRP, consulte la sección Configuración de HSRP de Configuración de servicios IP.

  • Si necesita ancho de banda adicional para los puertos de enlace ascendente, puede configurar EtherChannel. EtherChannel también proporciona redundancia de enlace en el caso de un fallo del enlace.

Configuraciones

Este documento usa estas configuraciones:

Catalyst 3550 (switch Catalyst 3550-48)

Cat3550#show running-config
Building configuration...

Current configuration : 3092 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3550
!
!
ip subnet-zero
!--- Habilite el IP Routing para el ruteo interVLAN
ip routing
!!
!
spanning-tree extend system-id
!
!
!
interface FastEthernet0/1
 no ip address
!
!--- Resultado suprimido.
!
interface FastEthernet0/5
 description to SERVER_1
!--- Configure el puerto del servidor para que esté en la VLAN del servidor: VLAN 3.
switchport access vlan 3
!--- Configure el puerto para que sea un puerto de acceso y
!--- evitar los retrasos en la negociación troncal.
 switchport mode access
 no ip address
!--- Configure PortFast para el retraso inicial del Spanning Tree Protocol (STP).
!--- Consulte Utilización de PortFast y otros comandos
!--- para solucionar retrasos al iniciar la conectividad de la estación de trabajo
!--- para obtener más información.
spanning-tree portfast
!
!--- Resultado suprimido.
!
interface FastEthernet0/48
 description To Internet_Router
!--- El puerto que se conecta al router se convierte en un puerto enrutado (L3).
no switchport
!--- Configure la dirección IP en este puerto. 
dirección IP 200.1.1.1 255.255.255.252
!
interface GigabitEthernet0/1
 description To 2950
!--- Configure la conexión troncal IEEE 802.1 (dot1q), con negociación, en el switch L2.
!--- Si el switch más alejado no soporta el Dynamic Trunking Protocol (DTP),
!--- ejecute el comando switchport mode trunk para forzar el modo troncal 
!--- en el puerto del switch.
!--- Nota: El modo de conexión troncal predeterminado es automático dinámico. 
!--- Si se establece un enlace troncal con el modo de conexión troncal predeterminado,
!--- el troncal no aparecerá en la configuración, aunque se establezca un troncal en
!--- interfaz. Utilice el comando show interfaces trunk para verificar
!--- el establecimiento del troncal. 
switchport trunk encapsulation dot1q
 no ip address
!
interface GigabitEthernet0/2
 description To 2948G
 switchport trunk encapsulation dot1q
 no ip address
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 description USER_VLAN
!--- Esta dirección IP es la gateway predeterminada para los usuarios.
 dirección IP 10.1.2.1 255.255.255.0
!
interface Vlan3
 description SERVER_VLAN
!--- Esta dirección IP es la gateway predeterminada para los servidores.
dirección IP 10.1.3.1 255.255.255.0
!
interface Vlan10
 description MANAGEMENT_VLAN
!--- Esta dirección IP es la gateway predeterminada para otros switches L2.
 dirección IP 10.1.10.1 255.255.255.0
!
ip classless
!--- Esta sentencia de ruta permite que Catalyst 3550 envíe el tráfico de Internet
!--- al router predeterminado, en este caso, Cisco 7200VXR (interfaz Fe 0/0).
ip route 0.0.0.0 0.0.0.0 200.1.1.2
ip http server
!
!
!
line con 0
line vty 5 15
!
end

Nota: Puesto que Catalyst 3550 está configurado como servidor de protocolo de troncal VLAN (VTP), el switch no muestra la configuración de VTP. Este comportamiento es normal. Este switch usa los siguientes comandos para crear un servidor VTP con tres VLAN definidas por el usuario desde el modo de configuración global:

Cat3550(config)#vtp domain cisco
Cat3550(config)#vtp mode server
Cat3550(config)#vlan 2
Cat3550(config-vlan)#name USER_VLAN
Cat3550(config-vlan)#exit
Cat3550(config)#vlan 3
Cat3550(config-vlan)#name SERVER_VLAN
Cat3550(config-vlan)#exit
Cat3550(config)#vlan 10
Cat3550(config-vlan)#name MANAGEMENT

Catalyst 2950 (switch Catalyst 2950G-48)

Cat2950#show running-config
Building configuration...

Current configuration : 2883 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat2950
!
!
ip subnet-zero
!
spanning-tree extend system-id
!
!
interface FastEthernet0/1
 no ip address
!
!--- Resultado suprimido.
interface FastEthernet0/16
 no ip address
!
interface FastEthernet0/17
 description SERVER_2
 switchport access vlan 3
 switchport mode access
 no ip address
 spanning-tree portfast
!
!--- Resultado suprimido.
!
interface FastEthernet0/33
 description HOST_1
!--- Configure HOST_1 como VLAN de usuario: VLAN 2.
 
 switchport access vlan 2
 switchport mode access
 no ip address
 spanning-tree portfast
!
!--- Resultado suprimido.
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 no ip address
!
interface GigabitEthernet0/2
 no ip address
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan10
 description MANAGEMENT
!--- Esta dirección IP administra este switch. 
dirección IP 10.1.10.2 255.255.255.0
 no ip route-cache
!
!--- Configure la gateway predeterminada para que el switch se pueda alcanzar 
!--- desde otras VLAN/subredes.
!--- La gateway apunta a la interfaz VLAN 10 de Catalyst 3550.
ip default-gateway 10.1.10.1
ip http server
!
!
line con 0
line vty 5 15
!
end

Nota: Puesto que Catalyst 2950 está configurado como cliente VTP, el switch no muestra la configuración VTP. Este comportamiento es normal. Catalyst 2950 adquiere la información de VLAN del servidor VTP: Catalyst 3550. Este switch Catalyst 2950 usa estos comandos para que el switch sea un cliente VTP en el dominio VTP cisco en el modo de configuración global:

Cat2950(config)#vtp domain cisco
Cat2950(config)#vtp mode client

Switch Catalyst 2948G

Cat2948G> (enable) show config
This command shows non-default configurations only.
Use 'show config all' to show both default and non-default configurations.
...........

..................
..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#time: Fri Jun 30 1995, 05:04:47
!
#version 6.3(10)
!
!
#system web interface version(s)
!
#test
!
#system
set system name Cat2948G
!
#frame distribution method
set port channel all distribution mac both
!
#vtp
!--- Configure el dominio VTP para que sea igual que Catalyst 3550, el servidor VTP.
set vtp domain cisco
!--- Elija el modo VTP como cliente para este switch.
set vtp mode client
!
#ip
!--- Configure la dirección IP de administración en VLAN 10.
set interface sc0 10 10.1.10.3/255.255.255.0 10.1.10.255

set interface sl0 down
set interface me1 down
!--- Defina la ruta predeterminada para que el switch se pueda alcanzar.
set ip route 0.0.0.0/0.0.0.0     10.1.10.1
!
#set boot command
set boot config-register 0x2
set boot system flash bootflash:cat4000.6-3-10.bin
!
#module 1 : 0-port Switching Supervisor
!
#module 2 : 50-port 10/100/1000 Ethernet
!--- Configure los puertos HOST_2 y SERVER_3 en las VLAN respectivas.
set vlan 2  2/2
set vlan 3  2/23
set port name    2/2 To HOST_2
set port name    2/23 to SERVER_3
!--- Configure el troncal para Catalyst 3550 con encapsulación dot1q.
set trunk 2/49 desirable dot1q 1-1005
end

Verificación

En esta sección encontrará información que puede utilizar para comprobar que su configuración funcione correctamente.

La herramienta intérprete de resultados (solamente clientes registrados) OIT) soporta algunos comandos show. Use la OIT para consultar un análisis de la salida del comando show

Catalyst 3550

  • show vtp status

    Cat3550#show vtp status
    VTP Version           : 2
    Configuration Revision     : 3
    Maximum VLANs supported locally : 1005
    Number of existing VLANs    : 8
    VTP Operating Mode       : Servidor
    VTP Domain Name         : cisco
    VTP Pruning Mode        : Disabled
    VTP V2 Mode           : Disabled
    VTP Traps Generation      : Disabled
    MD5 digest           : 0x54 0xC0 0x4A 0xCE 0x47 0x25 0x0B 0x49
    Configuration last modified by 200.1.1.1 at 3-1-93 01:06:24
    Local updater ID is 10.1.2.1 on interface Vl2 (lowest numbered VLAN interface found)
  • show interfaces trunk

    Cat3550#show interfaces trunk
    
    Port   Mode     Encapsulation Status    Native vlan
    Gi0/1   deseable  802.1q     trunking   1
    Gi0/2   deseable  802.1q     trunking   1
    
    Port   Vlans allowed on trunk
    Gi0/1   1-4094
    Gi0/2   1-4094
    
    Port   Vlans allowed and active in management domain
    Gi0/1   1-3,10
    Gi0/2   1-3,10
    
    Port   Vlans in spanning tree forwarding state and not pruned
    
    Gi0/1   1-3,10
    Gi0/2   1-3,10
  • show ip route

    Cat3550#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
        * - candidate default, U - per-user static route, o - ODR
        P - periodic downloaded static route
    
    Gateway of last resort is 200.1.1.2 to network 0.0.0.0
    
       200.1.1.0/30 is subnetted, 1 subnets
    C    200.1.1.0 is directly connected, FastEthernet0/48
       10.0.0.0/24 is subnetted, 3 subnets
    C    10.1.10.0 is directly connected, Vlan10
    C    10.1.3.0 is directly connected, Vlan3
    C    10.1.2.0 is directly connected, Vlan2
    S*  0.0.0.0/0 [1/0] via 200.1.1.2

Catalyst 2950

  • show vtp status

    Cat2950#show vtp status
    VTP Version           : 2
    Configuration Revision     : 3
    Maximum VLANs supported locally : 250
    Number of existing VLANs    : 8
    VTP Operating Mode       : Cliente
    VTP Domain Name         : cisco
    VTP Pruning Mode        : Disabled
    VTP V2 Mode           : Disabled
    VTP Traps Generation      : Disabled
    MD5 digest           : 0x54 0xC0 0x4A 0xCE 0x47 0x25 0x0B 0x49
    Configuration last modified by 200.1.1.1 at 3-1-93 01:06:24
  • show interfaces trunk

    Cat2950#show interfaces trunk
    
    Port   Mode     Encapsulation Status    Native vlan
    Gi0/1   deseable  802.1q     trunking   1
    
    Port   Vlans allowed on trunk
    Gi0/1   1-4094
    
    Port   Vlans allowed and active in management domain
    Gi0/1   1-3,10
    
    Port   Vlans in spanning tree forwarding state and not pruned
    Gi0/1   1-3,10

Catalyst 2948G

  • show vtp domain

    Cat2948G> (enable) show vtp domain
    Domain Name           Domain Index VTP Version Local Mode Password
    -------------------------------- ------------ ----------- ----------- ----------
    cisco              1      2      cliente   -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    8     1023       3        disabled
    
    Last Updater  V2 Mode Pruning PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    200.1.1.1    disabled disabled 2-1000
  • show trunk

    Cat2948G> (enable) show trunk
    * - indicates vtp domain mismatch
    Port   Mode     Encapsulation Status    Native vlan
    -------- ----------- ------------- ------------ -----------
     2/49   deseable  dot1q     trunking   1
    
    Port   Vlans allowed on trunk
    -------- ---------------------------------------------------------------------
     2/49   1-1005
    
    Port   Vlans allowed and active in management domain
    -------- ---------------------------------------------------------------------
     2/49   1-3,10
    
    Port   Vlans in spanning tree forwarding state and not pruned
    -------- ---------------------------------------------------------------------
     2/49   1-3,10

Resolución de problemas

Utilice esta sección para solucionar los problemas de configuración.

Procedimiento de resolución de problemas

Siga estas instrucciones:

  1. Si no puede enviar un ping a los dispositivos de la misma VLAN, compruebe la asignación VLAN de los puertos de origen y destino para asegurarse de que se encuentran en la misma VLAN.

    Para comprobar la asignación VLAN, ejecute el comando show port mod/port para CatOS o el comando show interface status para software Cisco IOS.

    si el origen y el destino no se encuentran en el mismo switch, asegúrese de que la conexión troncal está configurada correctamente. Para comprobar la configuración, ejecute el comando show trunk para CatOS o el comando show interfaces trunk para software Cisco IOS. Además, compruebe que la VLAN nativa coincide con el otro extremo. Asegúrese de que la máscara de subred coincide en los dispositivos de origen y de destino.

  2. Si no puede enviar un ping a los dispositivos de diferentes redes VLAN, asegúrese de que puede enviar un ping a la gateway predeterminada respectiva.

    Nota: Consulte el Paso 1.

    También, asegúrese de que la gateway predeterminada del dispositivo apunta a la dirección IP correcta de la interfaz VLAN. Asegúrese de que las máscaras de subred coinciden.

  3. Si no puede conectarse a Internet, asegúrese de que la ruta predeterminada en Catalyst 3550 apunta a la dirección IP correcta y que la dirección de subred coincide con el router de gateway de Internet.

    Para comprobarlo, ejecute los comandos show ip interface interface-id y show ip route. Asegúrese de que el router de gateway de Internet tiene rutas a Internet y a las redes internas.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 41260