IP : Routing IP

Especificación de una dirección IP de salto siguiente para rutas estáticas

19 Mayo 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (30 Octubre 2006) | Comentarios

Contenidos

Introducción
Requisitos previos
     Requisitos
     Componentes utilizados
     Teoría precedente
     Convenciones
Problema
Solución
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

Este documento introduce conceptos básicos sobre rutas estáticas y utiliza un ejemplo de problema para demostrar las circunstancias bajo las cuales es deseable especificar la interfaz a través de la cual se puede alcanzar la dirección IP de salto siguiente al configurar una ruta estática.

Requisitos previos

Requisitos

No hay requisitos específicos para este documento.

Componentes utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Teoría precedente

La capacidad para configurar una ruta estática se introdujo con la versión 10.0 del software Cisco IOS®. Las rutas estáticas se utilizan por una amplia variedad de razones y, a menudo, cuando no existe una ruta dinámica al destino o cuando la ejecución de un protocolo de ruteo dinámico no es factible.

De forma predeterminada, las rutas estáticas tienen una distancia administrativa de uno, que les otorga precedencia sobre rutas de protocolos de ruteo dinámico. Al aumentar la distancia administrativa a un valor mayor que el del protocolo de ruteo dinámico, la ruta estática puede ser una red de seguridad en el caso de que se produzca un error el ruteo dinámico. Por ejemplo, las rutas derivadas del Protocolo de ruteo de gateway interior (IGRP), tienen una distancia administrativa predeterminada de 100. Para configurar una ruta estática que podría ser anulada por una ruta IGRP, debería especificar una distancia administrativa mayor a 100 para la ruta estática.

Esta clase de ruta estática se denomina estática "flotante". Se instala en la tabla de ruteo sólo cuando la ruta de preferencia desaparece. Por ejemplo, ip route 172.31.10.0 255.255.255.0 10.10.10.2 101.

Nota: Una distancia administrativa de 255 se considera inalcanzable y las rutas estáticas con una distancia administrativa de 255 nunca se insertarán en la tabla de ruteo.

Si apunta una ruta estática hacia una interfaz de difusión, la ruta se insertará en la tabla de ruteo sólo cuando la interfaz de difusión está en funcionamiento. No se recomienda esta configuración, ya que cuando el salto siguiente de una ruta estática apunta hacia una interfaz, el enrutador considera que cada host dentro del rango de la ruta está directamente conectado a través de dicha interfaz. Por ejemplo, ip route 0.0.0.0 0.0.0.0 Ethernet0.

Con este tipo de configuración, un enrutador aplicará el Protocolo de resolución de direcciones (ARP) en la red Ethernet para cada destino que encuentre a través de la ruta predeterminada debido a que el enrutador considerará que todos estos destinos están directamente conectados a Ethernet 0.

Este tipo de ruta predeterminada, especialmente si la utilizan muchos paquetes hacia diferentes subredes de destino, puede provocar una alta utilización del procesador y un caché ARP muy grande (junto con errores de asignación de memoria del asistente).

La especificación de un salto siguiente numérico en una interfaz conectada directamente evitará que el enrutador realice ARP o cada dirección de destino. No obstante, si la interfaz con el salto siguiente deja de funcionar y el salto siguiente numérico se puede alcanzar a través de una ruta recurrente, debería especificar la dirección IP de salto siguiente y la interfaz a través de la cual debería encontrarse el salto siguiente. Por ejemplo, ip route 0.0.0.0 0.0.0.0 Serial 3/3 192.168.20.1.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones sobre los consejos técnicos de Cisco.

Problema

En el siguiente diagrama de red, existen dos rutas estáticas con el mismo destino (172.31.10.0/24). Una ruta es estática flotante, es el trayecto redundante o de "respaldo" hacia la red de destino en la LAN. El problema en el ejemplo es que la ruta estática flotante nunca se instala en la tabla de ruteo cuando el enlace principal está cerrado.

R1 tiene una ruta predeterminada dirigida al enrutador del Proveedor de servicios de Internet (ISP) para el acceso a Internet. R1 tiene dos enlaces hacia R2. T1 es el enlace principal y 56K es el enlace de respaldo. R1 tiene una ruta estática para 172.31.10.0/24 que se dirige a la dirección IP (10.10.10.2) serial 0 de R2 como salto siguiente. R1 también tiene una ruta estática flotante para 172.131.10.0/24 que se dirige a la dirección IP (192.168.20.2) serial 1 de R2, la distancia administrativa para la ruta estática flotante es 250. La idea es que los paquetes fluyan sobre la línea de 56K en ambas direcciones sólo si se produce un error en el enlace principal.

ip_static_routes_01.gif

Este ejemplo muestra la configuración de R1:

R1

hostname R1

!
ip subnet-zero
no ip domain-lookup
!
controller E1 2/0
!
controller E1 2/1
!
interface Serial3/0
 description ISP Link
 ip address 192.168.10.1 255.255.255.252
 clockrate 64000
!
interface Serial3/1
 no ip address
 shutdown
!
interface Serial3/2
 description Primary Link to R2
 ip address 10.10.10.1 255.255.255.252
!
interface Serial3/3
 description Backup Link to R2
 ip address  192.168.20.1 255.255.255.252
 clockrate 64000
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial3/0
!--- Ésta es la configuración de la ruta predeterminada hacia el enrutador ISP.
ip route 172.31.10.0 255.255.255.0 10.10.10.2
!--- Ésta es la ruta preferida hacia la LAN.
ip route 172.31.10.0 255.255.255.0 192.168.20.2 250
!--- Ésta es la ruta flotante hacia la LAN.

Este ejemplo muestra la tabla de ruteo de R1:

Tabla de ruteo R1

R1# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Serial3/2
     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial3/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial3/3
     172.31.0.0/24 is subnetted, 1 subnets
S       172.31.10.0 [1/0] via 10.10.10.2
--- La ruta estática preferida hacia la LAN a través de T1.
S*   0.0.0.0/0 is directly connected, Serial3/0
!--- La ruta estática predeterminada hacia Internet.

Este ejemplo muestra la configuración de R2:

R2

hostname R2
!
enable password ww
!
!
!
!
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
!
!
interface Ethernet0
 description Local LAN
 ip address 172.31.10.2 255.255.255.0
!
interface Serial0
 description Primary Link to R1
 ip address 10.10.10.2 255.255.255.252
 clockrate 56000
!
interface Serial1
 description Backup Link to R1
 ip address 192.168.20.2 255.255.255.252
!
interface TokenRing0
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.1
!--- Ésta es la ruta predeterminada principal.
ip route 0.0.0.0 0.0.0.0 192.168.20.1 250
!--- La ruta flotante predeterminada que se utilizará si se produce un error en T1.
no ip http server
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 password ww
 login
!
end

R2 tiene la ruta predeterminada instalada a través de 10.10.10.1 y cuando se utiliza el comando traceroute de R2 al enrutador ISP, los paquetes utilizan el enlace T1. R2 puede enviar pings al host de Internet 192.168.30.1 originados en 172.31.10.2. La ruta hacia 192.168.30.1 pasa a través de la ruta predeterminada 0.0.0.0 0.0.0.0.

Tabla de ruteo R2

R2# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 10.10.10.1 to network 0.0.0.0

     172.31.0.0/24 is subnetted, 1 subnets
C       172.31.10.0 is directly connected, Ethernet0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial1
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.10.10.0/30 is directly connected, Serial0
S*   0.0.0.0/0 [1/0] via 10.10.10.1
!--- Ésta es la ruta predeterminada principal.
R2# traceroute 192.168.10.2

Type escape sequence to abort.
Tracing the route to 192.168.10.2

  1 10.10.10.1 16 msec 20 msec 16 msec
  2 192.168.10.2 32 msec *  32 msec

R2# ping
Protocol [ip]:
Target IP address: 192.168.30.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.31.10.2
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms

Si cierra el serial 3/2 en R1 para probar la conmutación por error, R1 debería instalar la ruta estática flotante en la LAN local 172.31.10.0 y R2 debería instalar la ruta estática flotante en 0.0.0.0 a través de 192.168.20.1. El tráfico debería fluir sobre el enlace de 56K.

R1

R1# show ip int brief
Interface              IP-Address      OK? Method Status                Protocol
Serial3/0              192.168.10.1    YES manual up                    up
Serial3/1              unassigned      YES unset  administratively down down
Serial3/2              10.10.10.1      YES manual up                    up
Serial3/3              192.168.20.1    YES manual up                    up


R1# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int s3/2
R1(config-if)#shut
R1(config-if)#end
2d21h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/2, changed state to down
2d21h: %LINK-5-CHANGED: Interface Serial3/2, changed state to administratively down

R1# show ip int brief
Interface              IP-Address      OK? Method Status                Protocol
Serial3/0              192.168.10.1    YES manual up&                   up
Serial3/1              unassigned      YES unset  administratively down down
Serial3/2              10.10.10.1      YES manual administratively down down
Serial3/3              192.168.20.1    YES manual up                    up


R1# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial3/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial3/3
     172.31.0.0/24 is subnetted, 1 subnets
S       172.31.10.0 [1/0] via 10.10.10.2
!--- La ruta estática a través de T1 permanece en la tabla de ruteo.
!--- Esto no debería suceder cuando el serial 3/2 está cerrado.
S*   0.0.0.0/0 is directly connected, Serial3/0
!--- La ruta estática predeterminada hacia Internet.
R2# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 192.168.20.1 to network 0.0.0.0

     172.31.0.0/24 is subnetted, 1 subnets
C       172.31.10.0 is directly connected, Ethernet0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial1
S*   0.0.0.0/0 [250/0] via 192.168.20.1
!--- Ya no es posible hacer ping al host de Internet 192.168.20.1 si el ping
!--- se originó en la LAN en R2 porque R1 intentará enviar respuestas
!--- a través del serial 3/2, que está cerrado.
R2# ping
Protocol [ip]:
Target IP address: 192.168.30.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.31.10.2
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

La ruta estática flotante no se instaló en R1 y la ruta estática principal aún permanece en la tabla de ruteo de R1 aunque el enlace serial 3/2 está cerrado. Esto se debe a que las rutas estáticas son recurrentes por naturaleza. Siempre mantenga la ruta estática en la tabla de ruteo mientras tenga una ruta hacia el salto siguiente. En este caso, R1 considera que puede llegar a 10.10.10.2 a través de 192.168.10.2 porque 192.168.10.2 es el salto siguiente para 0.0.0.0 0.0.0.0.

La ruta hacia el salto siguiente puede ser una ruta más específica, menos específica o predeterminada. En el ejemplo de problema, podría pensar que dado que el enlace está cerrado, no debería tener una ruta hacia 10.10.10.2, pero si observa la tabla de ruteo en R1, verá que existe una ruta estática predeterminada dirigida hacia el enrutador ISP. Por lo tanto, R1 considera que puede alcanzar el salto siguiente (10.10.10.2) para 172.31.10.0/24 a través de esta ruta predeterminada, así la ruta estática hacia 172.31.10.0/24 a través de 10.10.10.2 permanece en la tabla de ruteo y la ruta estática flotante nunca se instala.

Existe una mejor manera para configurar rutas estáticas que le permitirá evitar este problema. Si especifica la interfaz a través de la cual deberá encontrarse el salto siguiente, instalará la ruta estática flotante sólo si la dirección IP de salto siguiente se puede alcanzar a través de la interfaz especificada. Antes de presentar la solución a este problema, deberá activar nuevamente la interfaz serial 3/2 en R1.

R1

R1# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int s 3/2
R1(config-if)#no shut
R1(config-if)#end
R1#
2d22h: %LINK-3-UPDOWN: Interface Serial3/2, changed state to up
2d22h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/2, changed state to up
2d22h: %SYS-5-CONFIG_I: Configured from console by console


R1# show ip int brief
Interface              IP-Address      OK? Method Status                Protocol
Serial3/0&             192.168.10.1    YES manual up                    up
Serial3/1              unassigned      YES unset  administratively down down
Serial3/2              10.10.10.1      YES manual up                    up
Serial3/3              192.168.20.1    YES manual up                    up


R1# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Serial3/2
     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial3/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial3/3
     172.31.0.0/24 is subnetted, 1 subnets
S       172.31.10.0 [1/0] via 10.10.10.2
S*   0.0.0.0/0 is directly connected, Serial3/0
R1#

Solución

La solución es quitar las antiguas rutas estáticas hacia la LAN (172.31.10.0) y configurar nuevas rutas estáticas; esta vez, especificando la interfaz a través de la cual debe alcanzarse el salto siguiente. Esto permitirá que la ruta estática flotante en R1 se instale cuando la interfaz serial 3/2 se cierre.

R1

R1# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#no ip route 172.31.10.0 255.255.255.0 10.10.10.2
R1(config)#no ip route 172.31.10.0 255.255.255.0 192.168.20.2 250
R1(config)#ip route 172.31.10.0 255.255.255.0 Serial3/2 10.10.10.2
R1(config)#ip route 172.31.10.0 255.255.255.0 Serial3/3 192.168.20.2 250
R1(config)#end
R1#
2d22h: %SYS-5-CONFIG_I: Configured from console by console

La ruta estática hacia 172.31.10.0 a través de 10.10.10.2 se instalará en la tabla de ruteo de R1 si 10.10.10.2 se ve desde el serial 3/2. Si no se cumple esta condición, la ruta estática a través de 10.10.10.2 se eliminará de la tabla de ruteo y se instalará la ruta estática flotante hacia 172.31.10.0 a través del serial 3/3 con salto siguiente 192.168.20.2.

Para probar el funcionamiento de esta solución y desactivar el enlace T1, cierre el serial 3/2 y observe si la ruta estática flotante se instala en la tabla de ruteo.

R1

R1# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int s 3/2
R1(config-if)#shut
R1(config-if)#end
R1#
3d00h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/2, changed state to down
3d00h: %SYS-5-CONFIG_I: Configured from console by console
3d00h: %LINK-5-CHANGED: Interface Serial3/2, changed state to administratively down

R1# show ip int brief
Interface              IP-Address      OK? Method Status                Protocol
Serial3/0              192.168.10.1    YES manual up                    up
Serial3/1              unassigned      YES unset  administratively down down
Serial3/2              10.10.10.1      YES manual administratively down down
Serial3/3              192.168.20.1    YES manual up                    up

R1# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     192.168.10.0/30 is subnetted, 1 subnets
C       192.168.10.0 is directly connected, Serial3/0
     192.168.20.0/30 is subnetted, 1 subnets
C       192.168.20.0 is directly connected, Serial3/3
     172.31.0.0/24 is subnetted, 1 subnets
S       172.31.10.0 [250/0] via 192.168.20.2, Serial3/3
S*   0.0.0.0/0 is directly connected, Serial3/0
R1#

Ahora, R1 puede hacer ping al host de Internet 192.168.20.1 con paquetes originados en la LAN.

R1

R2# ping
Protocol [ip]:
Target IP address: 192.168.20.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.31.10.2
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms

La ruta estática flotante se instala según lo esperado.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 27082