Voz : Protocolos de gateway

Información sobre el enrutamiento de llamadas de H.323 Gatekeeper de Cisco IOS

19 Mayo 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (4 Enero 2007) | Comentarios

Contenidos

Introducción
Antes de comenzar
Convenciones
Requisitos previos
Componentes utilizados
Mensajes ARQ y LRQ
Conceptos importantes sobre configuración: Prefijos de zona y tecnológicos
Prefijos de zona
Prefijos tecnológicos
Algoritmo de ruteo de llamadas de Gatekeeper / Proceso de decisión
Ejemplos de llamada de zona local
Escenario 1: No hay prefijos tecnológicos configurados
Escenario 2: Prefijos de tecnología configurados
Escenario 3: Prefijos de tecnología configurados como predeterminados
Ejemplos de llamada de zona remota
Escenario 1: Controladores de acceso de zona configurados con prefijos de tecnología predeterminados
Escenario 2: Gatekeepers de zona configurados sin prefijos de tecnología predeterminados
Comandos de verificación y resolución de problemas'
Discusiones relacionadas de la comunidad de soporte de Cisco
Información relacionada

Introducción

Los gatekeepers de Cisco se usan para agrupar gateways en zonas lógicas y para efectuar el ruteo de llamadas entre ellas. Las gateways son responsables de las decisiones de ruteo de borde entre la Red de telefonía pública conmutada (PSTN) y la red H.323. Los gatekeepers de Cisco gestionan el ruteo central de llamadas entre los dispositivos de la red H.323 y permiten la administración centralizada del plan de marcado. Si no se dispone de un gatekeeper de Cisco, se deberá configurar las direcciones IP explícitas para cada gateway de terminación en la gateway de origen y deberán coincidir con un par de marcado Voice over IP (VoIP). Si dispone de un gatekeeper de Cisco, las gateways consultan al gatekeeper cuando intentan establecer llamadas VoIP con gateways de VoIP remotos.

Por ejemplo, cuando se presenta con una llamada, la gateway determina si debe enviarla al tramo de telefonía o al tramo de IP según su plan de marcado. Para el tramo de IP, la gateway consulta el gatekeeper de Cisco para seleccionar el mejor punto final. El gatekeeper de Cisco determina a continuación si el punto final al que se llama es un dispositivo dentro de su zona local o si está ubicado en una zona remota controlada por un gatekeeper remoto de Cisco.

Antes de comenzar

Convenciones

Si desea obtener más información sobre las convenciones del documento, consulte Convenciones de consejos técnicos de Cisco.

Requisitos previos

Quienes lean este documento deben tener conocimiento de lo siguiente:

Componentes utilizados

La información que contiene este documento está basada en las versiones de software y hardware mencionadas a continuación.

  • Cisco 2500, 2600, 3600, 3700, 7200 y routers de la serie MC3810.

  • Este documento no es propio de ninguna versión de Cisco IOS. No obstante, las configuraciones de este documento se han probado en la versión del software Cisco IOS 12.2(19). Consulte Software Advisor (solamente clientes registrados) para confirmar el conjunto de características necesarias de Cisco IOS que son compatibles con la funcionalidad del gatekeeper H.323.

La información que se presenta en este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se han puesto en funcionamiento con una configuración despejada (predeterminada). Si está trabajando en una red activa, asegúrese de conocer el efecto de los comandos antes de ejecutarlos.

Mensajes ARQ y LRQ

ARQ y LRQ son los dos mensajes RAS/H.225 (registro, admisión y estado) que activa un gatekeeper para iniciar el proceso de decisión de ruteo de llamadas.

  • ARQ: mensajes de zona local que se envían mediante puntos finales H.323 (normalmente gateways) al gatekeeper de Cisco. Los gatekeepers reciben ARQ desde un punto final si:

    • Un punto extremo de una zona local inicia una llamada. O

    • Un punto final de una zona local solicita permiso para admitir una llamada entrante.

    Los gatekeepers responden a los mensajes ARQ con un mensaje de confirmación de admisión (ACF) o con un mensaje de rechazo de admisión (ARJ). Si el gatekeeper de Cisco se ha configurado para admitir la llamada, responde con un mensaje ACF (que incluye información como la dirección IP de la gateway de destino). Si no se ha configurado para recibir llamadas, responde con un mensaje ARJ.

  • LRQ: estos mensajes se intercambian entre gatekeepers y se usan en llamadas entre zonas (zona remota). El gatekeeper A recibe, por ejemplo, un ARQ de una gateway de una zona local que solicitó permiso para admitir una llamada de un dispositivo de zona remota. El gatekeeper A envía un mensaje LRQ al gatekeeper B. El gatekeeper B responde al mensaje LRQ con una confirmación de ubicación (Location Confirm, LCF) o un rechazo de ubicación (Location Reject, LRJ) en función de si se ha configurado para admitir o rechazar la solicitud de llamada entre zonas y de si se ha registrado el recurso solicitado.

Para obtener más información, consulte Introducción de gatekeepers para H.323: Flujo de llamadas de control de acceso a gateways.

Mensajes RAS H.225 relacionados

ARQ

Solicitud de admisión

LRQ

Petición de ubicación

ACF

Confirmación de admisión

LCF

Confirmación de ubicación

ARJ

Rechazo de admisión (ARJ)

LRJ

Rechazo de ubicación

Conceptos importantes sobre configuración: Prefijos de zona y tecnológicos

Para comprender el proceso de decisión de ruteo de llamadas del gatekeeper de Cisco es muy importante comprender los prefijos de zona y de tecnología. Generalmente (con muy pocas excepciones), el prefijo de zona determina el ruteo a una zona, mientras que el prefijo de tecnología determina la gateway en dicha zona.

Prefijos de zona

Un prefijo de zona es la parte del número al que se llama que identifica la zona en la que salta la llamada. Los prefijos de zona se usan habitualmente para asociar un código de área a una zona configurada.

El gatekeeper de Cisco determina si una llamada se ha enrutado a una zona remota o si se gestiona de forma local. Por ejemplo, según el siguiente extracto de configuración, el gatekeeper (GK) A reenvía las llamadas a 214....... a GK-B. Las llamadas al código de área (512) se gestionan de forma local.

gatekeeper
     zone local GK-A abc.com
     zone remote GK-B abc.com 172.22.2.3 1719
	!--- La dirección IP configurada antes
 !--- debería ser la dirección RAS de un gatekeeper remoto.
 !--- debería poder alcanzarse desde una gateway local.
 !--- Para buscar la dirección RAS de un gatekeeper remoto.
 !--- ejecute el comando show gatekeeper zone status en la gateway remota.
     zone prefix GK-B 214.......
     zone prefix GK-A 512.......

Prefijos tecnológicos

Un prefijo de tecnología es una función optativa basada en el estándar H.323, compatible con las gateways y los gatekeepers de Cisco, y que aporta más flexibilidad en el ruteo de llamadas dentro de una red VoIP H.323. El gatekeeper de Cisco usa los prefijos de tecnología para agrupar puntos finales del mismo tipo. Los prefijos de tecnología también se pueden usar para identificar un tipo, clase o grupo de gateways.

Los gatekeepers de Cisco usan los prefijos de tecnología para enrutar llamadas cuando no hay direcciones E.164 registradas (mediante una gateway) que coincidan con el número al que se llama. En realidad, es uno de los escenarios más habituales, ya que la mayoría de gateways de Cisco IOS sólo registran su ID H.323 (a no ser que se hayan configurado puertos de estación de intercambio remota (FXS)). Si no se han registrado las direcciones E.164, el gatekeeper de Cisco depende de dos opciones para tomar la decisión de ruteo de llamada:

  • Con la opción Technology Prefix Matches, usa el prefijo de tecnología agregado al número al que se llama para seleccionar la gateway o zona de destino.

  • Con la opción Prefijos de tecnología predeterminados, asigna gateways predeterminadas para enrutar direcciones de llamada sin resolver. Esta asignación se basa en el prefijo de tecnología registrado de la gateway.

La siguiente tabla resume las opciones de configuración disponibles.

En la gateway

Interfaz VoIP

Este comando registra la gateway de Cisco con el prefijo de tecnología definido. La información de registro del prefijo de tecnología se envía al gatekeeper de Cisco en el mensaje de solicitud de registro RAS (RRQ). Por ejemplo:

GWY-B1(config)#interface ethernet 0/0
GWY-B1(config-if)#h323-gateway voip tech-prefix ?
     WORD: A technology prefix that the interface will register
     with the Gatekeeper.

Par de marcado VoIP

Este comando añade un prefijo de tecnología al número al que se llama y que coincide mediante el par de marcado. No se usa para el registro, pero sí para configurar la llamada en el gatekeeper de Cisco. Por ejemplo, el número 5551010 se convierte en 1#5551010.

GWY-B1(config)#dial-peer voice 2 voip
GWY-B1(config-dial-peer)#tech-prefix ?
     WORD: A string.

Nota: El número al que se llama y que se ha modificado también se envía a la gateway de terminación en la configuración de llamada. Asegúrese de haber actualizado los pares de marcado del servicio telefónico analógico convencional (POTS) para completar la llamada.

En el gatekeeper

Prefijo de tecnología predeterminado del gatekeeper

Este comando define las gateways registradas con el prefijo de tecnología definido como valor predeterminado para el ruteo de direcciones de llamada sin resolver. Por ejemplo, si la mayoría de gateways de la zona enrutan el mismo tipo de llamadas, y se registran con el prefijo de tecnología 1#, puede configurar el gatekeeper de Cisco para que use 1# como prefijo de tecnología predeterminado. Por lo tanto, ya no es necesario que las gateways de origen asignen al número al que se llamó el prefijo 1#. Los números a los que se llama sin un prefijo de tecnología válido se enrutan a una de las gateways registradas con 1#.

GK-B(config)#gatekeeper
GK-B(config-gk)#gw-type-prefix 1# default-technology

Nota: Si hay más de una gateway predeterminada, puede influir en el uso de la prioridad de la gateway con el comando zone prefix gw-priority <0-10>.

Salto de zona Hop-Off del gatekeeper

Las configuraciones de salto de zona Hop-Off se usan para anular la selección del prefijo de zona y para obligar a la llamada a que salte a una zona especificada, al margen del prefijo de zona del número al que se llama. Por ejemplo, con la siguiente configuración, todas las llamadas con el prefijo de tecnología 2# se reenvían a la zona de GK-A.

GK-B(config)#gatekeeper
GK-B(config-gk)#gw-type-prefix 2# hopoff GK-A

Registro del prefijo de tecnología de la gateway estática del gatekeeper

Se usa para registrar de forma estática un prefijo de tecnología para una gateway. Consigue los mismos resultados en el gatekeeper que la configuración de la interfaz del gateway de VoIP en la gateway. Se recomienda configurarlo en las gateways si dispone de un gran número de gateways. En general, es mucho más fácil configurar cada gateway con un prefijo de tecnología que configurar el gatekeeper con todos los prefijos de tecnología de cada gateway.

GK-B(config)#gatekeeper
GK-B(config-gk)#gw-type-prefix 1# gw ipaddr ?
     A.B.C.D  RAS signaling IP address

Algoritmo de ruteo de llamadas de Gatekeeper / Proceso de decisión

Los siguientes diagramas muestran el proceso de decisión de ruteo de llamadas del gatekeeper tras recibir mensajes ARQ y LRQ.

gk-call-routing-1.gif

gk-call-routing-2.gif

Ejemplos de llamada de zona local

En los siguientes ejemplos, los dos gateways se registran en el gatekeeper de Cisco con sus respectivas ID de H.323. La gateway (GWY) A2 se registra además con una dirección E.164. El siguiente diagrama se usa para todos los ejemplos de esta sección.

gk-call-routing-3.gif

Las siguientes secciones explican, paso por paso, el proceso de decisión que usa el gatekeeper para enrutar llamadas basadas en mensajes ARQ.

Nota: En las siguientes capturas de configuración sólo se muestran los resultados importantes de la configuración.

Escenario 1: No hay prefijos tecnológicos configurados

GK-A

!
gatekeeper
zone local GK-A abc.com
no shutdown
!

GWY-A1

GWY-A2

!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718 
!--- La dirección IP configurada antes
!--- debería ser la dirección RAS de GK-A
!--- y debería poder alcanzarse desde una gateway.
!--- Para buscar la dirección RAS,
!--- ejecute el comando show gatekeeper zone status
!--- en GK-A.
h323-gateway voip h323-id GW-A1@abc.com
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!--- En llamadas salientes mediante pares de marcado POTS,
!--- se descartan todas las coincidencias de dígito explícitas,
!--- lo que es motivo
!--- para agregar el prefijo 512. No tiene ninguna relación
!--- con los prefijos de tecnología.
!
dial-peer voice 2 voip
destination-pattern 972.......
session target ras
!--- Usa mensajes RAS (GK) para obtener
!--- información de configuración de llamada.

!
gateway
!
!
interface FastEthernet0/0
ip address 172.22.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
!--- La dirección IP configurada antes
!--- debería ser la dirección RAS de GK-A.
!--- y debería poder alcanzarse desde una gateway.
!--- Para buscar la dirección RAS,
!--- ejecute el comando show gatekeeper zone status
!--- en GK-A.
h323-gateway voip h323-id GW-A2@abc.com
!
dial-peer voice 1 voip
destination-pattern 512.......
session target ras
!
dial-peer voice 2 pots
destination-pattern 9725551010
port 1/0/0
!--- Éste es el puerto FXS.
!
gateway
!

El siguiente resultado capturado en GK-A muestra los registros reales. Observe que GWY-A2 también registra la ID E.164 del puerto FXS.

GK-A#show gatekeeper endpoints
                    GATEKEEPER ENDPOINT REGISTRATION
                    ================================
CallSignalAddr  Port  RASSignalAddr   Port  Zone Name         Type    F
--------------- ----- --------------- ----- ---------         ----    --
172.22.1.1      1720  172.22.1.1      49317 GK-A              VOIP-GW
    H323-ID: GW-A1@abc.com
172.22.1.2      1720  172.22.1.2      58196 GK-A              VOIP-GW
    E164-ID: 9725551010
    H323-ID: GW-A2@abc.com
Total number of active registrations = 2

Acción de primera llamada: El usuario A1 llama al usuario A2 al 972-555-1010. Use el diagrama ARQ para seguir el proceso de decisión.

GK-A recibe un mensaje ARQ de la GWY-A1.

  1. ¿Coincide el prefijo de tecnología? No

  2. ¿Coincide el prefijo de zona? No

  3. ¿Se ha definido un rq reject-unknown-prefix? No, la zona de destino es igual a la zona local.

  4. ¿Es la zona de destino local?

  5. ¿Se ha encontrado un prefijo de tecnología en el paso 1? No

  6. ¿Se ha registrado la dirección de destino? Sí Enviar ACF.

Configuración de llamada correcta.

Nota: GWY-A2 tiene la ID E.164 de destino registrada (puerto FXS), por lo tanto, el gatekeeper pudo admitir la llamada.

Acción de segunda llamada: El usuario A2 marca 512-555-1212 para llamar al usuario A1.

GK-A recibe un mensaje ARQ de la GWY-A2.

  1. ¿Coincide el prefijo de tecnología? No

  2. ¿Coincide el prefijo de zona? No

  3. ¿Se ha definido el comando arq reject-unknown-prefix? No. La zona de destino es igual a la zona local.

  4. ¿Es la zona de destino local? Sí

  5. ¿Se ha encontrado un prefijo de tecnología en el paso 1? No

  6. ¿Se ha registrado la dirección de destino? No

  7. ¿Se ha definido el prefijo de tecnología predeterminado? No. Enviar ARJ.

Configuración de llamada incorrecta.

Nota: El escenario 2 explica cómo se puede solucionar el problema de ruteo de llamadas anterior con los prefijos de tecnología.

Escenario 2: Prefijos de tecnología configurados

En este escenario, se efectúan los siguientes cambios de configuración:

  • GWY-A1: Se ha agregado el comando h323-gateway voip tech-prefix 1#. GWY-A1 se registra en el GK-A con el prefijo de tecnología 1#.

  • GWY-A1: Se ha agregado un par de marcado POTS con un comando destination-pattern que coincida con el número al que se llamó entrante de la GWY-A2 con el prefijo de tecnología 1#.

  • GK-A: Se ha agregado el comando zone prefix GK-A. Define los prefijos de zona local que GK-A gestiona.

  • GK-A: Se ha agregado el comando arq reject-unknown-prefix. De esta forma se obliga al GK-A a aceptar solamente las llamadas ARQ de los prefijos de zona que gestiona. En el escenario 1, no se ha configurado de esta forma. Por lo tanto, la zona de destino se definió en la zona local como valor predeterminado.

  • GWY-A2: Se ha agregado el comando tech-prefix 1# en la configuración de par de marcado VoIP. De esta forma, GWY-A2 añade los dígitos 1# a las llamadas de VoIP salientes. GK-A identifica el modelo 1# para seleccionar GWY-A1 como la gateway de destino.

GK-A

gatekeeper
zone local GK-A abc.com
zone prefix GK-A 512.......
zone prefix GK-A 972.......
arq reject-unknown-prefix
no shutdown
!

GWY-A1

GWY-A2

!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1#
!
dial-peer voice 3 pots
incoming called-number 972.......
destination-pattern 1#512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern 972.......
session target ras
!
gateway
!
!
dial-peer voice 1 voip
destination-pattern 512.......
session target ras
tech-prefix 1#
!
dial-peer voice 2 pots
destination-pattern 9725551010
port 1/0/0
!
gateway
!
interface FastEthernet0/0
ip address 172.22.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A2@abc.com
!

El siguiente resultado capturado en GK-A muestra los prefijos de tecnología registrados.

GK-A#show gatekeeper gw-type-prefix

        GATEWAY TYPE PREFIX TABLE
        =========================
        Prefix: 1#*
        Zone GK-A master gateway list:
        172.22.1.1:1720 GW-A1

Nota: En lugar de configurar GW-A1 con el comando h323-gateway voip tech-prefix 1#, se podía haber conseguido el mismo resultado mediante la configuración manual de esta información en GK-A con el comando.

GK-A(config-gk)#gw-type-prefix 1#* gw ipaddr 172.22.1.1

Acción de llamada: El usuario A2 marca 512-555-1212 para llamar al usuario A1.

GK-A recibe un mensaje ARQ de la GWY-A2.

  1. ¿Coincide el prefijo de tecnología?

    Nota: Cuando el prefijo de tecnología coincide, el gatekeeper lo desglosa para analizar el prefijo de zona. Este desglose sólo lo ejecuta el análisis más profundo. La gateway de origen lo agrega a la configuración de la llamada de la gateway de terminación.

  2. ¿Coincide el prefijo de zona? Sí Definir la zona de destino para que sea igual a la zona local.

  3. ¿Es la zona de destino local?

  4. ¿Se ha encontrado un prefijo de tecnología en el paso 1?

  5. ¿Se ha encontrado una gateway local con un prefijo de tecnología? Sí Envíe ACF.

    Configuración de llamada correcta.

El siguiente resultado del comando debug de GK-A ilustra el comportamiento anterior.

Nota: El comando debug es un comado "debug" útil pero oculto. Por lo tanto, el analizador no va a mostrar la depuración.

GK-A#debug gatekeeper main 5

    *Jun 19 09:50:10.086: gk_rassrv_arq: arqp=0x631CC400, crv=0x82, answerCall=0
    *Jun 19 09:50:10.086: gk_dns_locate_gk(): No Name servers
    *Jun 19 09:50:10.086: rassrv_get_addrinfo(1#5125551010): Matched tech-prefix 1#
    *Jun 19 09:50:10.086: rassrv_get_addrinfo(1#5125551010): Matched zone prefix 512
    *Jun 19 09:50:10.118: gk_rassrv_arq: arqp=0x631CC400, crv=0x1A, answerCall=1

Nota: A continuación se muestra una configuración alternativa que puede ser más intuitiva:

  • Configurar GWY-A1 para que registre el prefijo de tecnología 512 mediante el comando h323-gateway voip tech-prefix 512.

  • De esta forma, GWY-A2 no tiene que transferir el prefijo en el tramo de llamada de par del marcado VoIP porque destination-pattern ya incluye 512. Por tanto, suprima el comando tech-prefix 1# de la configuración de GWY-A2 y suprima también 1# de destination-pattern en el par de marcado pots de GWY-A1.

Escenario 3: Prefijos de tecnología configurados como predeterminados

En este escenario, GWY-A1 se registra con el prefijo de tecnología 1# y GK-A se configura para enrutar llamadas sin un prefijo de tecnología coincidente con los prefijos de tecnología predeterminados de las gateways. Por lo tanto, GWY-A2 no necesita configurarse para transferir el prefijo de tecnología de destino.

GK-A

!
gatekeeper
zone local GK-A abc.com
zone prefix GK-A 512.......
zone prefix GK-A 972.......
gw-type-prefix 1#* default-technology
arq reject-unknown-prefix
no shutdown
!

GWY-A1

GWY-A2

!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1#
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern 972.......
session target ras
!
gateway
! 
!
dial-peer voice 1 voip
destination-pattern 512.......
session target ras
!
dial-peer voice 2 pots
destination-pattern 9725551010
port 1/0/0
!
gateway
!
interface FastEthernet0/0
ip address 172.22.1.2 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A2@abc.com
! 

El siguiente resultado capturado en GK-A muestra los prefijos de tecnología registrados.

GK-A#show gatekeeper gw-type-prefix

        GATEWAY TYPE PREFIX TABLE
        =========================
        Prefix: 1#* (Default gateway-technology)
        Zone GK-A master gateway list:
        172.22.1.1:1720 GW-A1

Acción de llamada: El usuario A2 marca 512-555-1212 para llamar al usuario A1.

GK-A recibe un mensaje ARQ de la GWY-A2.

  1. ¿Coincide el prefijo de tecnología? No

  2. ¿Coincide el prefijo de zona? Sí Definir la zona de destino para que sea igual a la zona local.

  3. ¿Es la zona de destino local?

  4. ¿Se ha encontrado un prefijo de tecnología en el paso 1? No

  5. ¿Se ha registrado la dirección de destino? No

  6. ¿Se ha definido el prefijo de tecnología predeterminado? Sí. Seleccione la gateway local con el prefijo de tecnología (sólo hay una disponible).

  7. Enviar ACF.

    Configuración de llamada correcta.

Ejemplos de llamada de zona remota

En estos ejemplos hay dos zonas H.323; una controlada por GK-A y otra, por GK-B.

gk-call-routing-4.gif

Las siguientes secciones explican, paso por paso, el proceso de decisión que usan los gatekeepers para enrutar llamadas basadas en mensajes ARQ y LRQ.

Nota: En las siguientes capturas de configuración sólo se muestran los resultados importantes de los ejemplos.

Escenario 1: Controladores de acceso de zona configurados con prefijos de tecnología predeterminados

En este escenario, GWY-A1 se registra en GK-A con el prefijo de tecnología 1# y GWY-B1 se registra en GK-B con el prefijo de tecnología 2#. Ambos gatekeepers se han configurado con gateways con prefijos de tecnología predeterminados.

GK-A

GK-B

!
gatekeeper
zone local GK-A abc.com
zone remote GK-B abc.com 172.22.2.3 1719
zone prefix GK-B 214.......
zone prefix GK-A 512.......
gw-type-prefix 1#* default-technology
arq reject-unknown-prefix
no shutdown
! 
!
gatekeeper
zone local GK-B abc.com 172.22.2.3
zone remote GK-A abc.com 172.22.1.3 1719
zone prefix GK-B 214.......
zone prefix GK-A 512.......
gw-type-prefix 2#* default-technology
no shutdown
!

GWY-A1

GWY-B1

!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1#
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern ..........
session target ras
!
gateway
!
interface Ethernet0/0
ip address 172.22.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-B ipaddr 172.22.2.3 1718
h323-gateway voip h323-id GWY-B1@abc.com
h323-gateway voip tech-prefix 2#
!
dial-peer voice 1 pots
destination-pattern 214.......
direct-inward-dial
port 3/0:23
prefix 214
!
dial-peer voice 2 voip
destination-pattern T
session target ras
!
gateway
!

Acción de llamada: El usuario A1 marca 214-555-1111 para llamar al usuario B1.

GK-A recibe un mensaje ARQ de la GWY-A1.

  1. ¿Coincide el prefijo de tecnología? No

  2. ¿Coincide el prefijo de zona? Sí Definir la zona de destino para que sea igual a la zona remota de GK-B (214).

  3. ¿Es la zona de destino local? No

  4. Enviar LRQ a GK-B.

GK-B recibe un mensaje LRQ de GK-A.

  1. ¿Coincide el prefijo de tecnología? No

  2. ¿Coincide el prefijo de zona? Sí Definir la zona de destino para que sea igual a la zona local.

  3. ¿Es la zona de destino local?

  4. ¿Se ha encontrado un prefijo de tecnología en el paso 1? No

  5. ¿Se ha registrado la dirección de destino? No

  6. ¿Se ha definido el prefijo de tecnología predeterminado? Sí Seleccionar la gateway local con el prefijo de tecnología (2#).

  7. Enviar LCF a GK-A.

    GK-A recibe el mensaje LCF de GK-B con la información de la gateway de terminación.

    GK-A envía el mensaje ACF a GWY-A1.

    La configuración de llamada es correcta.

Escenario 2: Gatekeepers de zona configurados sin prefijos de tecnología predeterminados

En este escenario, GWY-A1 se registra en GK-A con el prefijo de tecnología 1# y GWY-B1 se registra en GK-B con el prefijo de tecnología 2#. GWY-A1 añade el prefijo de tecnología 2# a la cadena del número al que se llama cuando efectúa llamadas a (214) y GWY-B1 añade el prefijo de tecnología 1# a la cadena del número al que se llama cuando efectúa llamadas a (512).

GK-A

GK-B

!
gatekeeper
zone local GK-A abc.com
zone remote GK-B abc.com 172.22.2.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
arq reject-unknown-prefix
no shutdown
!
!
gatekeeper
zone local GK-B abc.com 172.22.2.3
zone remote GK-A abc.com 172.22.1.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
no shutdown
!

GWY-A1

GWY-B1

!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1#
!
dial-peer voice 1 pots
destination-pattern 512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 2 voip
destination-pattern 214.......
session target ras
tech-prefix 2#
!
gateway
!
interface Ethernet0/0
ip address 172.22.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-B ipaddr 172.22.2.3 1718
h323-gateway voip h323-id GWY-B1@abc.com
h323-gateway voip tech-prefix 2#
!
dial-peer voice 1 pots
destination-pattern 214.......
direct-inward-dial
port 3/0:23
prefix 214
!
dial-peer voice 2 voip
destination-pattern T
session target ras
tech-prefix 1#
!
gateway
!

Acción de primera llamada: El usuario B1 marca 512-555-1212 para llamar al usuario A1.

GK-B recibe un mensaje ARQ de la GWY-B1.

  1. ¿Coincide el prefijo de tecnología? No

  2. ¿Coincide el prefijo de zona? No

    Nota: Como GK-B desconoce la existencia de un prefijo de tecnología 1#, presupone que forma parte del número al que se llamó y lo lee como un prefijo de zona.

  3. ¿Es la zona de destino local?

    Nota: GK-B selecciona el valor zona de destino es igual a zona local porque el comando arq reject-unknown-prefix no se ha definido.

  4. ¿Se ha encontrado un prefijo de tecnología en el paso 1? No

  5. ¿Se ha registrado la dirección de destino? No

  6. ¿Se ha definido el prefijo de tecnología predeterminado? No

  7. Envíe ARJ a GWY-A1.

    Configuración de llamada incorrecta.

El resultado siguiente se capturó en GK-B para ilustrar este comportamiento.

!--- De debug gatekeeper main 5.

GK-B#
gk_rassrv_arq: arqp=0x62F6A7E0, crv=0x22, answerCall=0
gk_dns_locate_gk(): No Name servers
rassrv_get_addrinfo(1#5125551212): Tech-prefix match failed
rassrv_get_addrinfo(1#5125551212): unresolved zone prefix, using source zone GK-B
rassrv_get_addrinfo(1#5125551212): unknown address and no default technology defined
gk_rassrv_sep_arq(): rassrv_get_addrinfo() failed (return code = 0x103)

!--- De debug ras.

GK-B#
RecvUDP_IPSockData successfully rcvd message of length 156 from 172.22.2.1:51141
ARQ (seq# 1796) rcvdparse_arq_nonstd: ARQ Nonstd decode succeeded, remlen= 156
IPSOCK_RAS_sendto: msg length 4 from 172.22.2.3:1719 to 172.22.2.1: 51141
RASLib::RASSendARJ: ARJ (seq# 1796) sent to 172.22.2.1

Para solucionar este problema, configure los gatekeepers para que puedan identificar los los prefijos de tecnología de zona remota.

  • Agregue lo siguiente a GK-B:

    GK-B(config-gk)#gw-type-prefix 1# hopoff GK-A
  • Agregue lo siguiente a GK-A:

    GK-A(config-gk)#gw-type-prefix 2# hopoff GK-B

Observe que el par de marcado POTS en las gateways de terminación debe actualizarse de modo que las cadenas de marcado entrantes coincidan con los prefijos de tecnología.

GK-A

GK-B

!
gatekeeper
zone local GK-A abc.com
zone remote GK-B abc.com 172.22.2.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
arq reject-unknown-prefix
gw-type-prefix 2# hopoff GK-B
no shutdown
!
!
gatekeeper
zone local GK-B abc.com 172.22.2.3
zone remote GK-A abc.com 172.22.1.3 1719
zone prefix GK-B 214*
zone prefix GK-A 512*
gw-type-prefix 1# hopoff GK-A
no shutdown
!

GK-B

GWY-B1

!
interface Ethernet0/0
ip address 172.22.1.1 255.255.255.0
half-duplex
h323-gateway voip interface
h323-gateway voip id GK-A ipaddr 172.22.1.3 1718
h323-gateway voip h323-id GW-A1@abc.com
h323-gateway voip tech-prefix 1#
!
!--- Este par de marcado se usa para
!--- las llamadas entrantes procedentes de PSTN.
dial-peer voice 1 pots
incoming called-number 512.......
direct-inward-dial
port 1/0:23
!
dial-peer voice 2 voip
destination-pattern 214.......
session target ras
tech-prefix 2#
!
!--- Este par de marcado se usa para
!--- terminar (512) llamadas procedentes
!--- de la red VoIP. Observe
!--- que el prefijo de tecnología
!--- se ha hecho coincidir para seleccionar el par de marcado
!--- pero no lo transfiere
!--- a PSTN.
dial-peer voice 3 pots
destination-pattern 1#512.......
direct-inward-dial
port 1/0:23
prefix 512
!
dial-peer voice 4 voip
destination-pattern 972.......
session target ras
!
gateway
!
interface Ethernet0/0
ip address 172.22.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id GK-B ipaddr 172.22.2.3 1718
h323-gateway voip h323-id GWY-B1@abc.com
h323-gateway voip tech-prefix 2#
!
dial-peer voice 1 pots
incoming called-number 214.......
direct-inward-dial
port 3/0:23
prefix 214
!
dial-peer voice 2 voip
destination-pattern T
session target ras
tech-prefix 1#
!
dial-peer voice 3 pots
destination-pattern 2#214.......
port 3/0:23
prefix 214
!
gateway
!

Acción de segunda llamada: El usuario B2 marca 512-555-1212 para llamar al usuario A1.

GK-B recibe un mensaje ARQ de la GWY-B1.

  1. ¿Coincide el prefijo de tecnología?

  2. ¿Se ha definido un prefijo de tecnología de salto de zona Hop-Off?

  3. Enviar LRQ a GK-A.

    Nota: El mensaje LRQ incluye el prefijo de tecnología en el número al que se llamó para el análisis de GK-A.

GK-A recibe un mensaje LRQ de GK-B.

  1. ¿Coincide el prefijo de tecnología?

  2. ¿Se ha definido un prefijo de tecnología de salto de zona Hop-Off? No

    Nota: Para continuar con el análisis del ruteo de llamada, GK-A desglosa el prefijo de tecnología. El prefijo de tecnología no se encuentra en la cadena del número al que se llama cuando las gateways configuran los tramos de llamada.

  3. ¿Coincide el prefijo de zona? Sí Definir la zona de destino para que sea igual a la zona local.

  4. ¿Es la zona de destino local?

  5. ¿Se ha encontrado un prefijo de tecnología en el paso 1?

  6. ¿Se ha encontrado una gateway local con un prefijo de tecnología?

  7. Enviar LCF a GK-B.

    GK-B recibe el mensaje LCF de GK-A con la información de la gateway de terminación.

    GK-B envía el mensaje ACF a GWY-B1.

    Configuración de llamada correcta.

El siguiente resultado de comando se capturó en GK-B para ilustrar este comportamiento.

!--- De debug gatekeeper main 5.

GK-B#
gk_rassrv_arq: arqp=0x62ED2D68, crv=0x24, answerCall=0
gk_dns_locate_gk(): No Name servers
rassrv_get_addrinfo(1#5125551212): Matched tech-prefix 1#
rassrv_put_remote_zones_from_zone_list() zone GK-A
gk_rassrv_irr: irrp=0x62F0D8FC, from 172.22.2.1:51141
GK-B#
GK-B#
     
!--- De debug ras.

RecvUDP_IPSockData successfully received message of
length 156 from 172.22.2.1:51141
ARQ (seq# 1809) rcvdparse_arq_nonstd: ARQ Nonstd decode
succeeded, remlen= 156
IPSOCK_RAS_sendto: msg length 104 from
172.22.2.3:1719 to 172.22.1.3: 1719
RASLib::RASSendLRQ: LRQ (seq# 1042) sent to 172.22.1.3
IPSOCK_RAS_sendto: msg length 7 from 172.22.2.3:1719 to 172.22.2.1: 51141
RASLib::RASSendRIP: RIP (seq# 1809) sent to 172.22.2.1
RecvUDP_IPSockData successfully rcvd message of length
131 from 172.22.1.3:1719
LCF (seq# 1042) rcvdparse_lcf_nonstd: LCF Nonstd
decode succeeded, remlen= 131
IPSOCK_RAS_sendto: msg length 34 from 172.22.2.3:1719
to 172.22.2.1: 51141
RASLib::RASSendACF: ACF (seq# 1809) sent to 172.22.2.1
RecvUDP_IPSockData successfully rcvd message of length
76 from 172.22.2.1:51141

Comandos de verificación y resolución de problemas'

A continuación se presenta una lista de comandos show y debug útiles que se usan para verificar y resolver problemas de ruteos de llamada del gatekeeper y de la gateway.

Algunos comandos show son soportados por la herramienta intérprete de resultados (solamente clientes registrados) , que permite visualizar un análisis del resultado de los comandos show.

Nota: Antes de ejecutar los comandos debug, consulte Información importante sobre Comandos de depuración.

  • show gateway: se usa para verificar el registro de alias de E.164 y H.323 de la gateway.

  • show gatekeeper endpoints: se usa para verificar el alias registrado de E.164 y H.323 en el gatekeeper.

  • show gatekeeper gw-type-prefix: se usa para verificar los registros de prefijo E.164 del gatekeeper.

  • show gatekeeper zone prefix | status: se usa para verificar el estado de la zona y los parámetros de configuración.

  • debug ras: se aplica a gateways y gatekeepers.

  • debug h225 asn1: se aplica a gateways y gatekeepers.

  • show dial-peer voice: se usa para verificar los prefijos de tecnología configurados en los pares de marcado.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 24462