Voz : Calidad de voz

QoS de voz: Marcación de paquetes ToS-CoS para usar con LLQ

19 Mayo 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (2 Febrero 2006) | Comentarios

Contenidos

Introducción
Requisitos previos
     Requisitos
     Componentes utilizados
     Convenciones
Configurar
     Diagrama de la red
     Configuraciones
Verificar
Resolución de problemas
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

En este documento, se describe la Calidad de Servicio (QoS) para Voz por IP (VoIP) en un entorno LAN mediante la asignación de Tipo de servicio (ToS) a parámetros de Clase de servicio (CoS).

Hasta hace poco, la opinión general era que la QoS nunca sería un problema desde el punto de vista de la empresa por la naturaleza congestionada del tráfico de red y la posibilidad del desbordamiento del búfer. La justificación de la QoS en la LAN es el almacenamiento en la memoria intermedia, y no la falta de ancho de banda. Por este motivo, son necesarias herramientas de QoS para gestionar estos búferes con el objetivo de reducir al mínimo las pérdidas, los retrasos y la variación del retraso. Los búferes de transmisión tienen la tendencia de llenarse en las redes de alta velocidad debido la combinación de la naturaleza congestionada de las redes de datos y el gran volumen de paquetes menores del Protocolo de control de transmisión (TCP). Si se llena un búfer de salida, las interfaces de ingreso no podrán colocar inmediatamente el nuevo tráfico en el búfer de salida. Cuando se llena el búfer de ingreso (lo que puede ocurrir rápidamente), se pierden paquetes. La pérdida de paquetes puede degradar la calidad de la voz.

El tráfico de VoIP es sensible tanto a los paquetes retrasados como a los perdidos. Un retraso no debería representar ningún problema, independientemente del tamaño del búfer de cola, gracias a la alta velocidad de los vínculos de la LAN. Las pérdidas, sin embargo, siempre influyen negativamente en la calidad de la voz en todas las redes. El uso de varias colas en las interfaces de transmisión es la única forma de eliminar las posibles pérdidas provocadas por búferes que funcionan al 100% de su capacidad. La separación de voz y vídeo (ambos sensibles a retrasos y pérdidas) en colas distintas puede impedir las pérdidas en la interfaz de ingreso, incluso aunque los flujos de datos llenen el búfer de transmisión de datos.

En las redes con mucho tráfico, es fundamental gestionar la entrega de tráfico controlado para garantizar al usuario una experiencia positiva con VoIP. Es muy fácil de explicar. Por ejemplo: cuando se descuelga un teléfono IP, le pregunta al Cisco CallManager qué tiene que hacer. Cisco CallManager indica al teléfono IP que reproduzca el tono de marcado. Si se pierde o retrasa la gestión del Protocolo de cliente delgado y el tráfico de control, el usuario se verá afectado negativamente. Para proporcionar la QoS, marque los encabezados de los paquetes con una precedencia más alta y asígnelos correctamente a los encabezados de Capa 2 para que lo comprendan los Catalysts. Así se garantiza la prioridad correcta a los paquetes de voz por la LAN.

Requisitos previos

Requisitos

No hay requisitos previos específicos para este documento.

Componentes utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Voice Gateway (Gateway de voz) Cisco 3725 con la versión 12.3(4)T del software Cisco IOS®.

  • Switch Catalyst 4000

  • Teléfonos IP y CallManagers de Cisco

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración despejada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Si desea más información sobre las convenciones del documento, consulte las Convenciones sobre consejos técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la herramienta de búsqueda de comandos (solamente clientes registrados).

Diagrama de la red

Este documento utiliza la configuración de red que se muestra en el siguiente diagrama.

tos-cos-1.gif

Configuraciones

Este documento usa estas configuraciones.

En esta configuración se muestra cómo asignar valores de ToS o de un punto de código de servicios diferenciados (DSCP) a un valor CoS en la parte del encabezado 802.1p. Hay muchas formas de implementar esto y las diferencias -poco importantes- dependen de su diseño. Los dos ejemplos de configuración aquí mostrados son equivalentes; se puede seguir cualquiera de los dos para llegar al mismo resultado. No olvide que únicamente debe permitir los paquetes VoIP que tengan una precedencia IP crítica (5) en el bit de ToS. No debe haber ningún otro tráfico con este bit configurado como crítico. Esto provocaría la superposición de tráfico no deseado en la cola de voz.

Nota: La configuración de LLQ se lleva a cabo en otros dispositivos de la red tales como el Catalyst 4000, que no se trata en este documento.

En este primer ejemplo, sólo se etiquetan los flujos RTP que tengan la precedencia 5 de IP, y no RTCP ni ningún paquete de señalización y mensajería H.225/245.

Cisco 3660 (ejemplo 1)

!
ip cef
!
!--- Es necesario que esté habilitado el mecanismo Cisco Express Forwarding (CEF) 
!--- para que surta efecto el comando set cos que se configura después.
!--- Si no está activado, el router se lo recordará con el error "CEF switching 
!--- needed for 'set' operations" (Conmutación CEF necesaria para operaciones 
!--- 'establecidas').
!
class-map match-all RTP
match ip precedence 5 
!--- Con este comando se detectan todos los paquetes con la precedencia IP de 5.
!
policy-map OutboundPolicy
class RTP
set CoS 5
!--- Ahora, se ha configurado el bit de CoS como 5 para todos los paquetes antes 
!--- detectados en class-map RTP con la precedencia de 5.
class class-default
set CoS 0
!--- El resto del tráfico tiene una CoS de 0 y una prioridad de entrega menor.
!
interface FastEthernet0/0
no ip address
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet0/0.816
encapsulation dot1Q 816
!--- Para que FastEthernet pueda habilitar la conexión troncal, tiene que haber 
!--- subinterfaces, así como encapsulación dot1q o isl.
ip address 10.120.16.112 255.255.255.0
service-policy output OutboundPolicy
!--- Aplique la QoS a la interfaz que conecte a la LAN a través del Catalyst 4000.
!
dial-peer voice 99131 voip
destination-pattern 9913109
session target ipv4:10.120.17.133
 ip qos dscp cs5 media
no vad
!

Nota: El comando ip qos dscp se presentó en la versión 12.2(2)T del software Cisco IOS. Sustituye al comando ip precedence (par de marcado). Todos los routers compatibles con la versión 12.2(2)T del software Cisco IOS y anteriores pueden usar ip precedence en la configuración de par de marcado.

En el segundo ejemplo hay parámetros de correspondencia distintos para las clases de policy-map (correspondencia de políticas). La configuración del Cisco 3660 coincide en los paquetes de configuración de llamadas H.225 y en los flujos de RTP. El criterio de correspondencia para el flujo de RTP también es algo distinto. No se fije en los encabezados IP, sólo en el rango de puertos UDP. Si están comprendidos entre 16384 y 32767, etiquételos y envíelos a policy-map.

Cisco 3660 (ejemplo 2)

!
ip cef
!
!--- Es necesario que esté habilitado el mecanismo Cisco Express Forwarding (CEF) 
!--- para que surta efecto el comando set cos que se configura después.
!--- Si no está activado, el router se lo recordará con el error "CEF switching 
!--- needed for 'set' operations" (Conmutación CEF necesaria para operaciones 
!--- 'establecidas').!
class-map match-all Call-Control
match access-group 101
!
class-map match-all RTP
match ip rtp 16384 16383
!--- Coincidencia en el rango de puertos UDP 16384-32767 con paquetes únicos VoIP 
!--- de salida para policy-map.
!
access-list 101 permit tcp host 10.120.16.112 any eq 1720
!--- Coincidencia en todos los paquetes que usan el puerto TCP 1720, que está 
!--- dedicado a la configuración de llamadas H.225. 
!
policy-map OutboundPolicy
class RTP
set CoS 5
!--- Configure el bit de CoS como 5 para todos los paquetes VoIP que coincidan 
!--- con el intervalo de puertos UDP antes citado.
class Call-Control
set CoS 3
set ip precedence 3
!--- Configure el bit de CoS como 3 y la precedencia IP como 3 para todos 
!--- los paquetes de señalización y control que coincidan con access-list 101.
class class-default
set CoS 0
!--- El resto del tráfico tiene una CoS de 0 y una prioridad de entrega menor.
!
interface FastEthernet0/0
no ip address
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet0/0.816
encapsulation dot1Q 816
ip address 10.120.16.112 255.255.255.0
service-policy output OutboundPolicy
!--- Aplique su QoS a la interfaz que conecte a la LAN a través del Catalyst 4000.
!
dial-peer voice 99131 voip
destination-pattern 9913109
session target ipv4:10.120.17.133
 ip qos dscp cs5 media
no vad
!

Verificar

En esta sección encontrará información que puede utilizar para confirmar que la configuración está funcionando correctamente.

Ciertos comandos show son compatibles con la herramienta intérprete de resultados (solamente clientes registrados) lo cual le permite ver un análisis de resultados del comando show.

  • show policy-map interface —Muestra los contadores de coincidencias de todas las clases de una policy-map de servicio especificada.

Ahora, los routers están configurados para asignar el bit de ToS al bit de CoS. Use el comando show policy-map interface para comprobar que el tráfico esté marcado según la configuración.

En la salida de este primer ejemplo, los paquetes VoIP 539 coinciden con la class-map, y todos los paquetes 539 tienen el bit de CoS marcado con un valor crítico como resultado. Este tipo de colocación en cola no tiene que esperar a una congestión para estar activa. Siempre y cuando discurra tráfico de voz por el enlace FastEthernet, marca todos los paquetes apropiadamente. En el segundo ejemplo, todos los paquetes VoIP 5 están marcados con un valor de CoS de 5, y todos los paquetes de señalización están marcados con un valor de CoS de 3 según la configuración.

En la configuración del ejemplo del primer 3660:

vdtl-3660-16a#show policy-map interface fastethernet 0/0.816
 FastEthernet0/0.816
  Service-policy output: OutboundPolicy

    Class-map: RTP (match-all)
      539 packets, 42042 bytes
      5 minute offered rate 2000 bps, drop rate 0 BPS
      Match: ip precedence 5
      QoS Set
        CoS 5
          Paquetes marcados con 539

    Class-map: class-default (match-any)
      13 packets, 1803 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: any
      QoS Set
        CoS 0
          Paquetes marcados con 13

En la configuración del ejemplo del segundo 3660:

vdtl-3660-16a#show policy-map interface fastethernet 0/0.816
 FastEthernet0/0.816

  Service-policy output: OutboundPolicy

    Class-map: RTP (match-all)
      370 packets, 28860 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: ip rtp 16384 16383
      QoS Set
        CoS 5
          Paquetes marcados con 370

    Class-map: Call-Control (match-all)
      26 packets, 2697 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: access-group 101
      QoS Set
        ip precedence 3
          Paquetes marcados con 26
        CoS 3
          Paquetes marcados con 26

    Class-map: class-default (match-any)
      4363 packets, 515087 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: any
      QoS Set
        CoS 0
          Paquetes marcados con 4363
vdtl-3660-16a#

Resolución de problemas

Actualmente, no hay información específica disponible sobre resolución de problemas para esta configuración.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 23442