IP : Servicios de direccionamiento IP

Configuración dinámica de las opciones del servidor DHCP

29 Abril 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (6 Agosto 2013) | Inglés (12 Octubre 2005) | Comentarios

Contenidos

Introducción
Requisitos previos
     Requisitos
     Componentes utilizados
     Convenciones
Configurar
     Diagrama de la red
     Configuraciones
Verifique
Resolución de problemas
     Comandos para resolución de problemas
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

DHCP le permite asignar automáticamente las direcciones IP reutilizables a clientes DHCP. En este documento se ofrece un ejemplo de cómo configurar opciones de DHCP tales como las direcciones del Sistema de nombres de dominio (DNS) y del Servicio de nombres de Internet de Windows (WINS), para responder a las solicitudes de DHCP de los clientes locales detrás de las instalaciones del cliente (CPE).

Previamente, los administradores de red tenían que manualmente configurar el server IOS® DHCP de Cisco en cada dispositivo que fuera habilitado con esta funcion. Después de que se instalaba un router, ir a cada ubicación y realizar modificaciones es una tarea trabajosa, costosa y que requiere tiempo.

Por consiguiente, el servidor Cisco IOS DHCP se ha optimizado para permitir que los datos de configuración se actualicen automáticamente. Los administradores de red pueden configurar uno o más servidores DHCP centralizados para actualizar opciones DHCP específicas dentro de los agrupamientos DHCP. Los servidores remotos pueden solicitar o importar, de los servidores centralizados, estos parámetros de opciones.

Requisitos previos

Requisitos

Cisco recomienda que los lectores de este documento tengan conocimientos sobre los siguientes temas:

  • DHCP

  • Sistema de nombres de dominio (DNS)

  • Servicio de nombres de Internet de Windows (WINS)

Componentes utilizados

Esta configuración fue desarrollada y probada con las siguientes versiones de software y hardware:

  • Versión 12.2(27) del software Cisco IOS®

  • Dos routers Cisco 3660 con NM-1E usados para la conexión de PC y clientes

La información que contiene este documento se ha creado a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se han puesto en funcionamiento con una configuración despejada (predeterminada). Si la red está funcionando, asegurese de entender el impacto potencial de cualquier comando.

Nota:: La función Servidor Cisco IOS DHCP se ha introducido en la versión 12.0(1)T del software Cisco IOS. Es necesaria la versión 12.0(2)T o posterior del software Cisco IOS® para su uso con los routers Cisco de la serie 1700. Si desea más información sobre los routers compatibles con la función Servidor DHCP, consulte la sección Plataformas soportadas del documento Servidor Cisco IOS DHCP.

Convenciones

Si desea más información sobre convenciones de documentos, consulte las Convenciones sobre consejos técnicos de Cisco.

Configurar

En esta sección, se presenta la información para configurar las opciones del servidor DHCP para DNS y WINS. El router 'Central' está configurado para estas opciones de Servidor, y el router 'Remoto' importa dichas opciones. El PC o cliente remoto recibe estas opciones importadas del router 'Remoto' durante su etapa DHCPACK.

Nota: Si desea más información sobre los comandos que se utilizan en este documento, consulte el documento Comandos DHCP o use la herramienta de búsqueda de comandos (solamente clientes registrados).

Diagrama de la red

Este documento utiliza la configuración de red que se muestra en este diagrama:

dhcp_ser_01.gif

Configuraciones

Este documento usa estas configuraciones:

Central (3660)

Central# show running-config
Building configuration...
.
.
.
ip dhcp excluded-address 10.0.0.1 10.0.0.5
!--- No se debe asignar este rango a clientes DHCP.
!
ip dhcp pool Central
   network 10.0.0.0 255.255.255.0
!--- Especifique el número y la máscara de red para los clientes DHCP.
   domain-name Central
!--- Especifique el nombre de dominio del cliente.
   dns-server 10.0.0.2
!--- Especifique el servidor DNS que desee que responda a los clientes 
!--- DHCP que necesiten correlacionar el nombre de host con
!--- la dirección IP.
   netbios-name-server 10.0.0.2
!--- Especifique el Sistema básico de entrada/salida de red (NetBIOS)
!--- Servidor WINS (para los clientes DHCP de Microsoft)
!
.
.
!
interface FastEthernet0/0
 ip address 10.0.0.1 255.255.255.0
 duplex auto
 speed auto
!
.
.
!
end

Remoto (3660)

Remote# show running-config
Building configuration...
.
.
.
ip dhcp excluded-address 192.168.1.1
!--- No se debe asignar esta dirección IP a clientes DHCP.
!
ip dhcp pool Client
   import all
!--- Importe los parámetros de opción DHCP a la base de datos.
   network 192.168.1.0 255.255.255.248
!--- Especifique el número y la máscara de red para los clientes DHCP.
   default-router 192.168.1.1
!--- Especifique la gateway predeterminada de los clientes DHCP.
!
.
.
!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.1.1 255.255.255.248
 duplex auto
 speed auto
!
end

Verifique

En esta sección encontrará información que puede utilizar para comprobar que su configuración funciona correctamente.

Ciertos comandos show son compatibles con la herramienta intérprete de resultados (solamente clientes registrados) lo cual le permite ver un análisis de resultados de estos comandos show.

  • show ip dhcp import: Muestra los parámetros de opción importados a la base de datos del servidor DHCP.

Remoto#show ip dhcp import
Address Pool Name: Client
Domain Name Server(s): 10.0.0.2
NetBIOS Name Server(s): 10.0.0.2
Domain Name Option: Central
Central#show ip dhcp server statistics
Memory usage         13906
Address pools        1
Database agents      1
Automatic bindings   1
Manual bindings      0
Expired bindings     0
Malformed messages   0

Message              Received
BOOTREQUEST          0
DHCPDISCOVER         1
DHCPREQUEST          1
DHCPDECLINE          0
DHCPRELEASE          0
DHCPINFORM           0

Message              Sent
BOOTREPLY            0
DHCPOFFER            1
DHCPACK              1
DHCPNAK              0
  • show ip dhcp binding: Muestra las vinculaciones de direcciones guardadas en el servidor Cisco IOS DHCP.

Central#show ip dhcp binding
IP address   Client-ID/Hardware address   Lease expiration       Type
10.0.0.6     0063.6973.636f.2d30.         Apr 25 2005 12:30 AM   Automatic
             3036.302e.3563.6634.
             2e61.3961.382d.4574.
             30

Resolución de problemas

En esta sección encontrará información que puede utilizar para solucionar problemas de configuración.

Comandos para resolución de problemas

Nota: Antes de ejecutar comandos debug, consulte Información importante sobre los comandos de depuración.

El resultado tomado de un PC o cliente que tenga un sistema operativo Microsoft Windows con el comando ipconfig /all da los valores de configuración de TCP/IP configurados por DHCP.

C:\>ipconfig /all

Windows 2000 IP Configuration

  Host Name . . . . . . . . . . . . : PC
  Primary DNS Suffix . . . . . . .  : cisco.com
  Node Type . . . . . . . . . . . . : Hybrid
  IP Routing Enabled. . . . . . . . : No
  WINS Proxy Enabled. . . . . . . . : No
  DNS Suffix Search List. . . . . . : cisco.com

Ethernet adapter Local Area Connection :

  Connection-specific DNS Suffix . : Central
  Description . . . . . . . . . .  : 3Com EtherLink XL 10/100 PCI TX NIC(3C905B-TX)
  Physical Address. . . . . . . .  : 00-10-5A-86-5A-CA
  DHCP Enabled. . . . . . . . . .  : Yes
  Autoconfiguration Enabled . . .  : Yes
  Dirección IP. . . . . . . . .: 192.168.1.2
  Máscara de subred . . . . . .: 255.255.255.248
  Gateway predeterminada . . . : 192.168.1.1
  Servidor DHCP . . . . . . . .: 10.0.0.6
  Servidores DNS . . . . . . . : 10.0.0.2
  Servidor WINS primario . . . : 10.0.0.2
  Lease Obtained. . . .  . . . . . : Tuesday, April 26, 2005 6:04:29 PM
  Lease Expires . . . . . . . .. . : Wednesday, April 27, 2005 6:04:29 PM

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 22920