Calidad de servicio (QoS) : Supervisión de QoS

Modelado del tráfico de retransmisión de tramas con QoS distribuido en las series Cisco 7500

23 Abril 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (10 Agosto 2005) | Comentarios

Contenidos

Introducción
Requisitos previos
     Requisitos
     Componentes utilizados
     Convenciones
Antecedentes
Pasos de configuración
FRF.12 y DTS
Problema conocido
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

Este documento explica las diferencias entre la aplicación del modelado del tráfico a interfaces de retransmisión de tramas en enrutadores de la serie 7500 de Cisco con procesadores de interfaces versátiles (VIP) y en otras plataformas. Las demás plataformas incluyen los enrutadores de la serie 7200, 3600 y 2600 de Cisco.

Requisitos previos

Requisitos

No hay requisitos específicos para este documento.

Componentes utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Si desea obtener más información sobre las convenciones utilizadas en este documento, consulte las Convenciones sobre consejos técnicos de Cisco.

Antecedentes

A partir de la versión 12.1(5)T del software Cisco IOS®, las políticas de Calidad de Servicio (QoS) deben ejecutarse en modo distribuido en el VIP; el QoS basado en Procesadores de switch de ruta (RSP) ya no es compatible. Ahora, debe utilizar el comando shape y otros comandos de la interfaz de la línea de comandos (MQC) de QoS modular para implementar el Modelado de tráfico distribuido (DTS) para interfaces de retransmisión de tramas en VIP de la serie 7500 de Cisco. DTS combina el Modelado de tráfico genérico (GTS) y el Modelado del tráfico de retransmisión de tramas (Frame Relay TS). Consulte Configuración del modelado de tráfico distribuido para ver un ejemplo de configuración.

Esta tabla explica cómo configurar el modelado del tráfico de retransmisión de tramas que depende de la plataforma:

Serie 7500

7200, 3600, 2600 y otras plataformas no VIP

Mecanismos de modelado compatibles

DTS

Modelado del tráfico de retransmisión de tramas

Comando de configuración

Comando shape según el mapa de políticas

frame-relay traffic-shaping en una interfaz principal; comandos de configuración map-class para especificar los parámetros de modelado de tráfico

Requiere dCEF1

Sí (Verificar con el comando show cef linecard).

No

1 dCEF = Cisco Express Forwarding distribuido

Nota: En las series 7500 de Cisco, la capacidad para configurar el Modelado del tráfico de retransmisión de tramas con el comando frame-relay traffic-shaping ahora está bloqueada porque el Modelado del tráfico de retransmisión de tramas sólo ejecuta RSP en modo no distribuido. Con dCEF y Modelado del tráfico de retransmisión de tramas, una adyacencia "de ubicación" CEF hace que el RSP conmute rápidamente todos los paquetes, lo que no es óptimo para el desempeño de reenvío.

Pasos de configuración

Siga estos pasos para configurar DTS en varias interfaces de retransmisión de tramas basadas en VIP:

  1. Habilite dCEF con este comando:

    router(config)# ip cef distributed
  2. Asegúrese de que la interfaz de retransmisión de tramas esté habilitada para una conmutación distribuida.

    router(config-if)# interface serial 8/0/0
     router(config-if)# ip route-cache distributed
    
    router# show ip interface serial 8/0/0
     Serial8/0/0 is up, line protocol is up
       Internet address is 24.0.0.2/24
       Broadcast address is 255.255.255.255
    
      !--- Resultado suprimido.
    
       ICMP redirects are always sent
       ICMP unreachables are always sent
       ICMP mask replies are never sent
       IP fast switching is enabled
       IP fast switching on the same interface is disabled
       IP Flow switching is disabled
      IP CEF switching is enabled
       IP Distributed switching is enabled
      IP Fast switching turbo vector
       IP CEF switching with tag imposition turbo vector
       IP multicast fast switching is enabled
       IP multicast distributed fast switching is disabled
       IP route-cache flags are Fast, Distributed, CEF
       Router Discovery is disabled
       IP output packet accounting is disabled
  3. Cree una política de servicio y aplíquela a la clase de correspondencia.

    Puede implementar una de las siguientes políticas:

    Nota: Mientras la versión 12.1(2)T del software Cisco IOS introdujo la colocación en Low Latency Queuing (LLQ) en otras plataformas distintas a la serie 7500 de Cisco, la versión 12.1(5)T del software Cisco IOS introdujo LLQ distribuido (dLLQ) en el VIP. La versión distribuida mejora el desempeño de esta función. Puede configurar una política de servicio única por cada Identificador de conexión de enlaces de datos (DLCI). No es necesario utilizar una clase de correspondencia. Puede aplicar el comando service-policy directamente a la subinterfaz o DLCI. No obstante, configure dLLQ dentro de una clase de correspondencia.

  4. Verifique el funcionamiento correcto de su política de servicio con los siguientes comandos:

    • show policy-map interface

    • show interface shape

    • show vip full-qos

    Ejemplo de configuración de DTS con una política jerárquica

    ip cef distributed
     !
     class-map 1
       match <>
    
       !--- Defina los criterios de concordancia.
    
     class-map 2
       match <>
    
       !--- Defina los criterios de concordancia.
    
     !
     policy-map CBWFQ
      class 1
        bandwidth <>
    
          !--- Defina el valor en kbps o porcentaje.
    
       class 2
         priority <>
    
         !--- Defina el valor en kbps o porcentaje.
    
     !
     policy-map SHAPE
        class class-default
         shape average
           service-policy CBWFQ
     !
     int s0/0   encapsulation frame-relay
       ip route-cache distributed
    
     !--- No configure frame-relay traffic-shaping.
    
    ! int s0/0.1 point-to-point
       ip address a.b.c.d
       frame-relay interface-dlci xxx
        class cisco
     !
     map-class frame-relay cisco
       service-policy output SHAPE
    
    

FRF.12 y DTS

La versión 12.1(5)T del software Cisco IOS introdujo una versión distribuida de fragmentación de retransmisión de tramas, FRF.12. Al aplicar FRF.12 distribuido a una interfaz de retransmisión de tramas, debe definir una clase de correspondencia y aplicar la política de servicio según la clase de correspondencia. Si intenta configurar una clase de correspondencia con la política de servicio aplicada directamente a la interfaz, su enrutador mostrará este mensaje de error con el comando logging console habilitado:

Frame Relay fragmentation works with dTS only. 
Please remove traffic-shaping from the interface serial 1/0/0

La configuración que presentamos en esta sección y los comandos de verificación de configuración fueron probados en un enrutador de la serie 7500 de Cisco que ejecuta la versión 12.2(5)T del software Cisco IOS en un RSP 8.

Nota: Consulte VoIP sobre retransmisión de tramas con calidad de servicio (fragmentación, diseño de tráfico y prioridad LLQ/IP RTP), para obtener más información sobre la selección de los valores de fragmentación.

Ejemplo de configuración de DTS y FRF.12

interface Ethernet4/1/3
  ip address 10.122.3.206 255.255.255.0
 !
 interface Serial5/0/0:0
  no ip address
  encapsulation frame-relay
  load-interval 30
  no fair-queue


 !--- No configure frame-relay traffic-shaping.

!
 interface Serial5/0/0:0.1 point-to-point
  ip address 10.1.1.2 255.255.255.0
  frame-relay interface-dlci 16
   class test
  frame-relay ip rtp header-compression
 !
 map-class frame-relay test
  no frame-relay adaptive-shaping
  service-policy output llq-shape
  frame-relay fragment 120

 !--- Aplique el comando frame-relay fragment a la
 !--- clase de correspondencia de retransmisión de tramas.

 access-list 101 permit udp any range 16384 32767 any  range 16384 32767

MS-7507-8A# show ip rtp head
 RTP/UDP/IP header compression statistics:
 DLCI 16 Link/Destination info: point-to-point dlci
 Interface Serial5/0/0:0:
 Distributed fast switched:
 4 seconds since line card sent last stats update
 Rcvd: 105475 total, 105472 compressed, 0 errors
 0 dropped, 0 buffer copies, 0 buffer failures
 Sent: 99451 total, 99447 compressed
  3776208 bytes saved, 2187963 bytes sent
 2.72 efficiency improvement factor
 Connect: 256 rx slots, 256 tx slots,
  0 long searches, 3 misses 0 collisions, 0 negative cache hits
 99% hit ratio, five minute miss rate 0 misses/sec, 0 max

 MS-7507-8A# show policy-map
  Policy Map llq-shape
  Class class-default
   shape peak 256000 1024 1024
   service-policy llq
 Policy Map llq
  Class voip
   priority percent 50

 MS-7507-8A# show policy-map interface s 5/0/0:0.1
 Serial5/0/0:0.1: DLCI 16 -
 Service-policy output: llq-shape
   queue stats for all priority classes:
   queue size 0, queue limit 32
   packets output 147008, packet drops 0
   tail/random drops 0, no buffer drops 0, other drops 0
  Class-map: class-default (match-any)
   148237 packets, 10393582 bytes
   30 second offered rate 24000 bps, drop rate 0 bps
   Match: any
     queue size 0, queue limit 64
    packets output 149563, packet drops 0
    tail/random drops 0, no buffer drops 0, other drops 0
   Shape: cir 256000, Bc 1024, Be 1024
    lower bound cir 0, adapt to fecn 0
    output bytes 6972057, shape rate 10000 bps
 Service-policy : llq
  Class-map: voip (match-all)
   146701 packets, 10325334 bytes
   30 second offered rate 24000 bps, drop rate 0 bps
   Match: access-group 101
   Priority: 50% (128 kbps), burst bytes 3200, b/w
    exceed drops: 0
   Class-map: class-default (match-any)
   1536 packets, 68248 bytes
  30 second offered rate 0 bps, drop rate 0 bps
   Match: any
    queue size 0, queue limit 32
   packets output 2555, packet drops 0
   tail/random drops 0, no buffer drops 0, other drops 0

 MS-7507-8A# show frame pvc 16
 PVC Statistics for interface Serial5/0/0:0 (Frame Relay DTE)
 DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial5/0/0:0.1
 input pkts 3036327   output pkts 199453
 in bytes 198958363
  out bytes 17271661   dropped pkts 0   in FECN pkts 0
  in BECN pkts 0 out FECN pkts 0  out BECN pkts 0
  in DE pkts 0         out DE pkts 0
  out bcast pkts 1071  out bcast bytes 371448
  5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 35000 bits/sec, 50 packets/sec
 pvc create time 17:51:42, last time pvc status changed 17:50:53
 fragment type end-to-end fragment size 120

  MS-7507-8A# show interface shape
 Serial5/0/0:0 nobuffer drop 0
 Serial5/0/0:0.1(class 0):
 cir 256000, Bc 1024, Be 1024
 lower bound cir 0, adapt to fecn 0
 packets output 152104, bytes output 6985505
 queue limit 64, queue size 0, drops 0
 last clear = 16:58:59 ago, shape rate = 10000 bps

MS-7507-8A# show ip rtp head
 RTP/UDP/IP header compression statistics:
 DLCI 16 Link/Destination info: point-to-point dlci
 Interface Serial5/0/0:0:
 Distributed fast switched:
 4 seconds since line card sent last stats update
 Rcvd: 105475 total, 105472 compressed, 0 errors
 0 dropped, 0 buffer copies, 0 buffer failures
 Sent: 99451 total, 99447 compressed,
  3776208 bytes saved, 2187963 bytes sent
 2.72 efficiency improvement factor
 Connect: 256 rx slots, 256 tx slots,
  0 long searches, 3 misses 0 collisions, 0 negative cache hits
 99% hit ratio, five minute miss rate 0 misses/sec, 0 max

MS-7507-8A# show policy-map
  Policy Map llq-shape
  Class class-default
   shape peak 256000 1024 1024
   service-policy llq
 Policy Map llq
  Class voip
   priority percent 50

 MS-7507-8A# show policy-map interface s 5/0/0:0.1
 Serial5/0/0:0.1: DLCI 16 -
 Service-policy output: llq-shape
   queue stats for all priority classes:
   queue size 0, queue limit 32
   packets output 147008, packet drops 0
   tail/random drops 0, no buffer drops 0, other drops 0
  Class-map: class-default (match-any)
  148237 packets, 10393582 bytes
  30 second offered rate 24000 bps, drop rate 0 bps
   Match: any
     queue size 0, queue limit 64
    packets output 149563, packet drops 0
    tail/random drops 0, no buffer drops 0, other drops 0
  Shape: cir 256000, Bc 1024, Be 1024
    lower bound cir 0, adapt to fecn 0
    output bytes 6972057, shape rate 10000 bps
 Service-policy : llq
   Class-map: voip (match-all)
  146701 packets, 10325334 bytes
  30 second offered rate 24000 bps, drop rate 0 bps
   Match: access-group 101
  Priority: 50% (128 kbps), burst bytes 3200, b/w
  exceed drops: 0
 Class-map: class-default (match-any)
 1536 packets, 68248 bytes
  30 second offered rate 0 bps, drop rate 0 bps
   Match: any
  queue size 0, queue limit 32
   packets output 2555, packet drops 0
   tail/random drops 0, no buffer drops 0, other drops 0

 MS-7507-8A# show frame pvc 16
 PVC Statistics for interface Serial5/0/0:0 (Frame Relay DTE)
 DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial5/0/0:0.1
 input pkts 3036327   output pkts 199453
 in bytes 198958363
 out bytes 17271661   dropped pkts 0   in FECN pkts 0
in BECN pkts 0       out FECN pkts 0  out BECN pkts 0
 in DE pkts 0         out DE pkts 0
out bcast pkts 1071  out bcast bytes 371448
  5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 35000 bits/sec, 50 packets/sec
pvc create time 17:51:42, last time pvc status changed 17:50:53
 fragment type end-to-end fragment size 120

MS-7507-8A# show interface shape
Serial5/0/0:0 nobuffer drop 0
Serial5/0/0:0.1(class 0):
cir 256000, Bc 1024, Be 1024
 lower bound cir 0, adapt to fecn 0
packets output 152104, bytes output 6985505
 queue limit 64, queue size 0, drops 0
last clear = 16:58:59 ago, shape rate = 10000 bps

Problema conocido

Si aún utiliza la versión 12.1E del software Cisco IOS, la interfaz VIP que está configurada con encapsulación de retransmisión de tramas puede fallar por una excepción de error de bus. Este fallo se produce si aplica una política de servicio cuando la interfaz está transmitiendo tráfico. La solución alternativa es detener el tráfico de fondo antes de actualizar la política de servicio. También puede actualizar a la versión 12.2 del software Cisco IOS o posterior.

Para obtener más información, consulte la sección Herramientas y recursos de Cisco.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 18660