IP : Routing IP

Protocolo de enrutamiento de gateway interior mejorado

23 Marzo 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (9 Septiembre 2005) | Comentarios

Interactivo: En este documento se ofrece un análisis personalizado de su dispositivo Cisco.


Contenidos

Introducción
Teoría de funcionamiento de EIGRP
     Revisiones principales del protocolo
     Teoría básica
     Detección y mantenimiento de vecino
     Creación de la tabla de topología
     Métricas EIGRP
     Distancia factible, distancia informada y sucesor factible
     Cómo decidir si un trayecto no tiene bucles
Mecanismos Split Horizon y Poison Reverse
     Modo de inicio
     Cambio de la tabla de topología
     Consultas
Rutas “stuck in active”
     Solución de problemas en rutas SIA
Redistribución
     Redistribución entre dos sistemas autónomos EIGRP
     Redistribución entre EIGRP e IGRP en dos sistemas autónomos diferentes
     Redistribución entre EIGRP e IGRP en el mismo sistema autónomo
     Redistribución a y de otros protocolos
     Redistribución de Rutas estáticas a las interfaces
Producción de resumen
     Resumen automático
     Resumen manual
     Resumen automático de rutas externas
Procesamiento y rango de consultas
     ¿Cómo afectan los puntos de resumen al rango de la consulta?
     Cómo influyen los límites del sistema autónomo en el rango de la consulta
     Cómo afectan las listas de distribución al rango de consultas
Resincronización de paquetes
ruteo predeterminado
Balance de carga
Uso de las métricas
Uso de etiquetas administrativas en redistribución
Información sobre la salida del comando EIGRP
     show ip eigrp topology
     show ip eigrp topology <red>
     show ip eigrp topology [active | pending | zero-successors]
     show ip eigrp topology all-links

Introducción

El Enhanced Interior Gateway Routing Protocol (EIGRP) es un protocolo de gateway interior apropiado para muchos tipos diferentes de topologías y dispositivos. En una red correctamente diseñada, EIGRP escala de forma óptima y ofrece tiempos de convergencia extremadamente rápidos con un mínimo tráfico de red.

Teoría de funcionamiento de EIGRP

Algunas de las varias ventajas de EIGRP son:

  • uso mínimo de los recursos de la red durante su funcionamiento normal; sólo se transmiten paquetes de saludo (hello) en una red estable.

  • cuando se produce un cambio, sólo se propagan los cambios en la tabla de ruteo, y no toda la tabla; con esto se consigue reducir la carga que el propio protocolo de ruteo deposita en la red.

  • tiempos de convergencia rápidos en la topología de la red (en determinadas situaciones, la convergencia puede llegar a ser casi instantánea).

EIGRP es un protocolo de vector de distancia mejorado basado en el Algoritmo de actualización difuso (DUAL) para calcular el trayecto más corto hasta un destino dentro de la red.

Revisiones principales del protocolo

Existen dos revisiones principales de EIGRP, las versiones 0 y 1. Las versiones de Cisco IOS anteriores a la 10.3(11), 11.0(8) y 11.1(3) ejecutarán la versión anterior de EIGRP; es posible que algunas explicaciones contenidas en este documento no se apliquen a dicha versión anterior. Se recomienda especialmente usar la versión más reciente de EIGRP, ya que ésta incluye varias mejoras de desempeño y estabilidad.

Teoría básica

Un protocolo de vector de distancia habitual guarda la siguiente información al calcular el mejor camino a un destino: la distancia (métrica total o distancia como, por ejemplo, el recuento de saltos) y el vector (el siguiente salto o "next hop"). Por ejemplo, todos los routers en la red de la figura 1 ejecutan el Routing Information Protocol (RIP). El Router Two elige el trayecto a la Red A tras examinar el recuento de saltos a través de cada trayecto disponible.

eigrp1.gif

Dado que el trayecto a través del Router Three contiene tres saltos, mientras que el trayecto a través del Router One contiene dos, el Router Two elegirá el trayecto a través del Router One y rechazará la información obtenida a través del Router Three. Si el trayecto entre el Router One y la Red A deja de funcionar, el Router Two perderá toda conectividad con este destino hasta que se agote el tiempo de espera de la ruta de su tabla de ruteo (tres períodos de actualización equivalentes a 90 segundos), y el Router Three anunciará nuevamente la ruta (lo cual se produce cada 30 segundos en RIP). Sin tener en cuenta el tiempo de retención, el Router 2 tardará entre 90 y 120 segundos para conmutar el trayecto del Router One al Router Three.

El protocolo EIGRP, en lugar de depender de actualizaciones periódicas completas para volver a converger, construye una tabla de topología a partir de cada uno de los anuncios de su vecino (en lugar de rechazar los datos) y realiza la convergencia ya sea buscando una ruta probable sin bucles en la tabla de topología o, si no conoce otra ruta, consultando a sus vecinos. El Router Two guarda la información que recibió de los Routers One y Three. Elige el trayecto a través del Router One como su mejor trayecto (el sucesor) y el trayecto a través del Router Three como un trayecto sin bucles (un sucesor factible). Cuando el trayecto a través del Router One no esté disponible, el Router Two examinará su tabla de topología y, al encontrar un sucesor factible, comenzará inmediatamente a usar el trayecto a través del Router Three.

A partir de esta breve explicación, es claro que EIGRP debe proporcionar los siguientes elementos:

  • un sistema en el que se envían únicamente las actualizaciones necesarias en un momento dado; esto se consigue mediante el descubrimiento y mantenimiento de vecinos.

  • una manera de determinar qué trayectos ha aprendido un router como libres de bucles

  • un proceso para eliminar rutas defectuosas de las tablas de topología de todos los routers de la red

  • un proceso de consulta a vecinos para encontrar rutas hacia destinos perdidos

Analizaremos cada uno de estos requisitos oportunamente.

Descubrimiento y mantenimiento de vecinos

Para distribuir la información de ruteo por toda una red, EIGRP emplea actualizaciones de ruteo graduales no periódicas. Es decir, EIGRP sólo envía actualizaciones de ruteo relativas a trayectos modificados cuando se modifican dichos trayectos.

El problema principal al enviar únicamente actualizaciones de ruteo es que es posible que no sepa cuándo deja de estar disponible un trayecto a través de un router vecino. No es posible agotar el tiempo de espera de las rutas con el objetivo de recibir una nueva tabla de ruteo de sus vecinos. EIGRP se basa en las relaciones de vecinos para propagar de un modo fiable las modificaciones de la tabla de ruteo por toda la red; dos routers pasan a ser vecinos cuando cada uno ve el paquete de saludo del otro en una red común.

EIGRP envía paquetes de saludo cada 5 segundos en enlaces de ancho de banda alto y cada 60 segundos en enlaces multipunto de ancho de banda bajo.

  • saludo de 5 segundos:

    • medios de difusión, como Ethernet, Token Ring y FDDI

    • enlaces seriales punto a punto, como PPP o circuitos dedicados HDLC, subinterfaces punto a punto Frame Relay y subinterfaz punto a punto ATM

    • circuitos multipunto de ancho de banda alto (mayor que T1), como ISDN PRI y Frame Relay

  • saludo de 60 segundos:

    • circuitos multipunto de ancho de banda T1 o más lentos, como interfaces multipunto Frame Relay, interfaces multipunto ATM, circuitos virtuales conmutados ATM o ISDN BRI

La velocidad con la que EIGRP envía los paquetes de saludo recibe el nombre de intervalo de saludo, que podrá ajustar para cada interfaz mediante el comando ip hello-interval eigrp. El tiempo en espera es la cantidad de tiempo que un router considera a un vecino activo sin que reciba un paquete de saludo. Este tiempo equivale por lo general a tres veces el intervalo de saludo; el valor predeterminado es de 15 segundos y 180 segundos. Para ajustar el tiempo en espera, utilice el comando ip hold-time eigrp.

Recuerde que, si cambia el intervalo de saludo, el tiempo en espera no se ajustará automáticamente para dar cuenta de este cambio, sino que deberá ajustarlo manualmente para que refleje el intervalo de saludo configurado.

Dos routers pueden también convertirse en vecinos EIGRP aunque no coincidan los temporizadores de saludo y de espera. El tiempo en espera se incluye en los paquetes de saludo de modo que cada vecino pueda permanecer activo aunque los temporizadores del intervalo de saludo y de tiempo en espera no coincidan.

Si bien no existe una manera directa de determinar el intervalo de saludo en un router, sí puede inferirlo desde el resultado del comando show ip eigrp neighbor en el router vecino.

Si tiene el resultado de un comando show ip eigrp neighbor del dispositivo Cisco, podrá utilizar la herramienta intérprete de resultados (solamente clientes registrados) para mostrar posibles problemas y sus soluciones. Para usar la herramienta intérprete de resultados, debe tener JavaScript habilitado.

router# show ip eigrp neighbor

IP-EIGRP neighbors for process 1

H   Address       Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type

                                        (sec)         (ms)       Cnt Num

1   10.1.1.2      Et1           13 12:00:53   12   300  0  620

0   10.1.2.2      S0           174 12:00:56   17   200  0  645





rp-2514aa# show ip eigrp neighbor

IP-EIGRP neighbors for process 1

H   Address        Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type

                                        (sec)         (ms)       Cnt Num

1   10.1.1.2       Et1           12 12:00:55   12   300  0  620

0   10.1.2.2       S0           173 12:00:57   17   200  0  645





rp-2514aa# show ip eigrp neighbor

IP-EIGRP neighbors for process 1

H   Address        Interface   Hold Uptime   SRTT   RTO  Q  Seq  Type

                                        (sec)         (ms)       Cnt Num

1   10.1.1.2       Et1           11 12:00:56   12   300  0  620

0   10.1.2.2       S0           172 12:00:58   17   200  0  645

El valor de la columna Hold (En espera) del resultado del comando no deberá superar nunca el tiempo en espera ni quedar por debajo del tiempo en espera menos el intervalo de saludo (a menos que, por supuesto, esté descartando paquetes de saludo). Si la columna Hold (En espera) oscila generalmente entre 10 y 15 segundos, el intervalo de saludo será de 5 segundos y el tiempo en espera de 15 segundos. Si la columna Hold (En espera) presenta generalmente un rango más amplio (entre 120 y 180 segundos), el intervalo de saludo será de 60 segundos y el tiempo en espera de 180 segundos. Si los números no parecen coincidir con ninguno de los valores predeterminados de los temporizadores, compruebe la interfaz en cuestión del router vecino, ya que es posible que los temporizadores de saludo y espera se hayan configurado manualmente.

Nota: 

  • EIGRP no crea relaciones de pares a través de direcciones secundarias. Todo el tráfico EIGRP se origina en la dirección primaria de la interfaz.

  • Al configurar EIGRP a través de una red Frame Relay con múltiples accesos (punto a multipunto, etc.), configure la palabra clave broadcast en las sentencias de frame-relay map. Si la palabra clave broadcast no se establecerían las adyacencias entre los dos routers EIGRP. Consulte Configuración y resolución de problemas del Frame Relay para obtener más información.

  • No existen limitaciones en el número de vecinos que EIGRP puede soportar. El número real de vecinos soportados dependerá de la capacidad del dispositivo como, por ejemplo:

    • capacidad de memoria

    • potencia de procesamiento

    • cantidad de información intercambiada como, por ejemplo, el número de rutas enviadas

    • complejidad de la topología

    • estabilidad de la red

Creación de la tabla de topología

Ahora que estos routers se comunican entre sí, ¿de qué hablan? ¡Sus tablas de topología, por supuesto! EIGRP, a diferencia de RIP e IGRP, no se basa en la tabla de ruteo (o reenvío) del router para mantener toda la información necesaria para funcionar. En cambio, crea una segunda tabla, la tabla de topología, desde la cual instala rutas en la tabla de ruteo.

Nota: A partir de las versiones 12.0T y 12.1 de Cisco IOS, RIP mantiene su propia base de datos desde la cual instala las rutas en la tabla de ruteo.

Para ver el formato básico de la tabla de topología de un router que ejecute EIGRP, ejecute el comando show ip eigrp topology. La tabla de topología contiene la información necesaria para crear un conjunto de distancias y vectores para cada red alcanzable, que incluye:

  • el ancho de banda más bajo en el trayecto para este destino según informó el vecino en sentido ascendente

  • retraso total

  • confiabilidad de trayecto

  • carga de trayecto

  • Unidad de transmisión máxima (MTU) del trayecto mínimo

  • distancia factible

  • distancia informada

  • origen de la ruta (las rutas externas están marcadas)

Los conceptos de distancia factible e informada se analizan más adelante en esta misma sección.

Si tiene el resultado de un comando show ip eigrp topology del dispositivo Cisco, podrá utilizar la herramienta intérprete de resultados (solamente clientes registrados) para mostrar posibles problemas y sus soluciones. Para usar la herramienta intérprete de resultados, debe tener JavaScript habilitado.

Métricas EIGRP

EIGRP utiliza el ancho de banda mínimo en el trayecto hasta la red de destino y el retraso total para calcular las métricas de ruteo. Si bien puede configurar otras métricas, no es recomendable, ya que podría provocar bucles de ruteo en su red. El ancho de banda y las métricas de retraso se determinan a partir de los valores configurados en las interfaces de los routers que se encuentran en el trayecto hasta la red de destino.

Por ejemplo, en la figura 2 a continuación, el Router One está calculando el trayecto más adecuado hasta la Red A.

eigrp2.gif

Empieza con dos anuncios para esta red: uno a través del Router Four con un ancho de banda mínimo de 56 y un retraso total de 2.200, y el otro a través del Router Three con un ancho de banda mínimo de 128 y un retraso de 1.200. El Router One elige el trayecto de métrica más baja.

Pasemos a calcular las métricas. EIGRP calcula la métrica total escalando el ancho de banda y las métricas de retraso. EIGRP utiliza la siguiente fórmula para escalar el ancho de banda:

  • ancho de banda = (10000000/bandwidth(i)) * 256

    donde ancho de banda (i) es el ancho de banda menor de todas las interfaces salientes en la ruta hasta la red de destino expresado en kilobits.

EIGRP utiliza la siguiente fórmula para adaptar el retardo:

  • retraso = retraso (i) * 256

    donde retraso (i) es el total de los retrasos configurados en las interfaces de la ruta hasta la red de destino expresado en decenas de microsegundos. El retraso que se muestra en los comandos show ip eigrp topology o show interface se expresa en microsegundos, por lo que deberá dividir la cantidad por 10 antes de utilizarla en la fórmula. A lo largo de todo este documento, utilizamos el retraso tal como está configurado y se muestra en la interfaz.

EIGRP utiliza estos valores escalados para determinar la métrica total hasta la red:

  • métrica = [K1 * ancho de banda + (K2 * ancho de banda) / (256 - carga) + K3 * retraso] * [K5 / (confiabilidad + K4)]

Nota: Estos valores K deben emplearse después de una planificación minuciosa. Los valores K que no coincidan impedirán que se establezca una relación de vecino, lo que podría provocar la imposibilidad de convergencia por parte de la red.

Nota: Si K5 = 0, la fórmula se reducirá a la métrica = [k1 * ancho de banda + (k2 * ancho de banda)/(256 - carga) + k3 * retraso].

Los valores predeterminados para K son:

  • K1 = 1

  • K2 = 0

  • K3 = 1

  • K4 = 0

  • K5 = 0

Para una conducta predeterminada, puede simplificar la fórmula de la siguiente manera:

metric = bandwidth + delay 

Los routers Cisco no realizan aritmética de punto flotante, por lo que en cada fase del cálculo deberá redondear al número entero más cercano para calcular la métrica adecuadamente. En este ejemplo, el costo total en el Router Four es:

En este ejemplo, el costo total en el Router Four es:

minimum bandwidth = 56k



total delay = 100 + 100 + 2000 = 2200



[(10000000/56) + 2200] x 256 = (178571 + 2200) x 256 = 180771 x 256 = 46277376

El costo total a través del Router Three es el siguiente:

minimum bandwidth = 128k



total delay = 100 + 100 + 1000 = 1200



[(10000000/128) + 1200] x 256 = (78125 + 1200) x 256 = 79325 x 256 = 20307200

Por lo tanto, para llegar a la Red A, el Router One selecciona la ruta a través del Router Three.

Tenga en cuenta que los valores de ancho de banda y retraso que hemos empleado son los configurados en la interfaz a través de la cual el router llegará al siguiente salto (next hop) hasta la red de destino. Por ejemplo, el Router Two anunció la Red A con el retraso configurado en su interfaz Ethernet, el Router Four agregó el retraso configurado en su interfaz Ethernet y el Router One agregó el retraso configurado en su interfaz serial.

Distancia factible, distancia informada y sucesor factible

La distancia factible es la métrica más adecuada a lo largo de un trayecto hasta una red de destino e incluye la métrica hasta el vecino que anuncia ese trayecto. La distancia informada es la métrica total a lo largo de un trayecto hasta una red de destino según la anunció un vecino en sentido ascendente. Un sucesor factible es un trayecto cuya distancia informada es menor que la distancia factible (el mejor trayecto actual). La figura 3 ilustra este proceso:

eigrp3.gif

El Router One comprueba que dispone de dos rutas hasta la Red A: una a través del Router Three y otra a través del Router Four.

  • La ruta a través del Router Four tiene un costo de 46.277.376 y una distancia informada de 307.200.

  • La ruta a través del Router Three tiene un costo de 20.307.200 y una distancia informada de 307.200.

Observe que, en cada caso, EIGRP calcula la distancia informada a partir del router que anuncia la ruta hasta la red. Es decir, la distancia informada desde el Router Four es la métrica que se utilizará para llegar a la Red A desde dicho router, y la distancia informada desde el Router Three será la que se utilizará para llegar a la Red A desde dicho router. EIGRP elige la ruta a través del Router Three como el trayecto más adecuado y utiliza la métrica a través del Router Three como distancia factible. Dado que la distancia informada hasta esta red a través del Router Four es inferior a la distancia factible, el Router One considera el trayecto a través del Router Four como el sucesor factible.

Cuando el enlace entre los Routers One y Three se interrumpe, el Router One examina cada trayecto que conoce hasta la Red A y comprueba que dispone de un sucesor factible a través del Router Four. El Router One utiliza esta ruta, empleando para ello la métrica a través del Router Four como la nueva distancia factible. La red converge de manera instantánea, ya que las actualizaciones para los vecinos en sentido descendente constituyen el único tráfico procedente del protocolo de ruteo.

Ahora pasemos a examinar un escenario más complejo, como el que se muestra en la figura 4.

eigrp4.gif

Existen dos rutas hasta la Red A desde el Router One: una a través del Router Two con una métrica de 46.789.376 y otra a través del Router Four con una métrica de 20.307.200. El Router One elige la menor de estas dos métricas como la ruta hasta la Red A, por lo que la métrica pasa a ser la distancia factible. Observemos ahora el trayecto a través del Router Two para comprobar si es apto para ser un sucesor factible. La distancia informada desde el Router Two es de 46.277.376, mayor que la distancia factible, por lo que este trayecto no puede ser un sucesor factible. Si en este momento observa la tabla de topología del Router One (utilizando el comando show ip eigrp topology), sólo verá una entrada para la Red A: la correspondiente a la ruta a través del Router Four. (En realidad, el Router One contiene dos entradas en la tabla de topología, pero sólo una de ellas puede llegar a ser un sucesor factible; por eso la otra no aparece al ejecutar el comando show ip eigrp topology; para ver las rutas que no pueden ser sucesores factibles, utilice el comando show ip eigrp topology all-links.)

Supongamos que el enlace entre el Router One y el Router Four se interrumpe. El Router One comprueba que ha perdido su única ruta hasta la Red A, por lo que consulta a cada uno de sus vecinos (en este caso, únicamente el Router Two) para ver si disponen de una ruta hasta la Red A. Como el Router Two sí dispone de una ruta hasta dicha red, responde a la consulta. Dado que el Router One ya no dispone de la mejor ruta a través del Router Four, acepta esta ruta a través del Router Two hasta la Red A.

Cómo decidir si un trayecto no tiene bucles

¿De qué manera utiliza EIGRP los conceptos de distancia factible, distancia informada y sucesor factible para determinar si un trayecto es válido y no se trata de un bucle? En la figura 4a, el Router Three examina las rutas hasta la Red A. Dado que Split horizon está inhabilitado (por ejemplo, en el caso de interfaces Frame Relay multipunto), el Router Three muestra tres rutas hasta la Red A: una a través del Router Four, otra a través del Router Two (el trayecto es Two, One, Three, Four) y otra a través del Router One (el trayecto es One, Two, Three, Four).

eigrp21.gif

Si el Router Three acepta todas estas rutas, se originará un bucle de ruteo como resultado. El Router Three piensa que puede llegar a la Red A a través del Router Two, pero el trayecto a través del Router Two pasa a través del Router Three para llegar a dicha red. Si la conexión entre los Routers Four y Three se interrumpe, éste último creerá que puede llegar a la Red A a través de uno de los trayectos restantes, pero debido a las reglas existentes de determinación de los sucesores factibles, nunca utilizará estos trayectos como alternativas. Observemos las métricas para comprobar el porqué:

  • métrica total hasta la Red A a través del Router Four: 20.281.600

  • métrica total hasta la Red A a través del Router Two: 47.019.776

  • métrica total hasta la Red A a través del Router One: 47.019.776

Debido a que el trayecto a través del Router Four cuenta con la mejor métrica, el Router Three instalará esta ruta en la tabla de reenvío y utilizará 20.281.600 como distancia factible hasta la Red A. A continuación, el Router Three calculará la distancia informada hasta la Red A a través de los Routers Two y One: 47.019.776 para el trayecto a través del Router Two, y 47.019.776 para el trayecto a través del Router One. Dado que ambas métricas son superiores a la distancia factible, el Router Three no instalará ninguna de ellas como sucesor factible para la Red A.

Suponga que el enlace entre los Routers Three y Four se interrumpe. El Router Three consulta a cada uno de sus vecinos para comprobar si existe una ruta alternativa hasta la Red A. El Router Two recibe la consulta y, como procede de su sucesor, busca en cada una de las entradas restantes de su tabla de topología para comprobar si existe un sucesor factible. La única otra entrada que existe en la tabla de topología procede del Router One, con una distancia informada equivalente a la última mejor métrica conocida a través del Router Three. Dado que la distancia informada a través del Router One no es inferior a la última distancia factible conocida, el Router Two marca la ruta como inalcanzable y consulta a cada uno de sus vecinos (en este caso, únicamente el Router One) por si existe un trayecto hasta la Red A.

El Router Three también envía una consulta sobre la Red A al Router One. El Router One examina su tabla de topología y comprueba que el único trayecto alternativo hasta la Red A es a través del Router Two, con una distancia informada equivalente a la última distancia factible conocida a través del Router Three. Nuevamente, como la distancia informada a través del Router Two no es inferior a la última distancia factible conocida, la ruta no representa un sucesor factible. El Router One marca la ruta como inalcanzable y consulta a su otro único vecino, el Router Two, por si existe un trayecto hasta la Red A.

Éste es el primer nivel de consultas. El Router Three ha consultado a cada uno de sus vecinos en su intento por encontrar una ruta hasta la Red A. A su vez, los Routers One y Two han marcado la ruta como inalcanzable y han consultado a cada uno de sus vecinos restantes en su intento por encontrar un trayecto hasta la Red A. Cuando el Router Two recibe la consulta del Router One, examina su tabla de topología y comprueba que el destino está marcado como inalcanzable. El Router Two responde al Router One que la Red A es inalcanzable. Cuando el Router One recibe la consulta del Router Two, también responde que la Red A es inalcanzable. Por lo tanto, los Routers One y Two han decidido que la Red A es inalcanzable, y responde de este modo a la consulta original del Router Three. La red convergió y todas las rutas regresan al estado pasivo.

Mecanismos Split Horizon y Poison Reverse

En el ejemplo anterior se entendía que Split horizon no estaba activado con el fin de mostrar la manera en que EIGRP utiliza la distancia factible y la distancia informada para determinar si una ruta tiene posibilidades de formar un bucle. Sin embargo, en determinadas circunstancias, EIGRP utiliza Split horizon para evitar también bucles de ruteo. Antes de comprobar con detalle la manera en que EIGRP utiliza Split horizon, repasemos el concepto Split horizon y su funcionamiento. La regla de Split horizon afirma:

  • no anunciar nunca una ruta fuera de la interfaz a través de la que se obtuvo la información.

Por ejemplo, en la figura 4a, si el Router One está conectado a los Routers Two y Three a través de una única interfaz multipunto (como puede ser Frame Relay) y el Router One ha obtenido información acerca de la Red A procedente del Router Two, no anunciará la ruta a la Red A por la misma interfaz al Router Three. El Router One entiende que el Router Three obtendría la información acerca de la Red A directamente del Router Two.

eigrp21.gif

Poison reverse es otra forma de evitar bucles de ruteo. Su regla afirma:

  • una vez que obtenga información acerca de una ruta a través de una interfaz, anúnciela como inalcanzable a través de esa misma interfaz.

Supongamos ahora que los routers de la figura 4a tienen habilitado Poison reverse. Cuando el Router One obtiene información acerca de la Red A procedente del Router Two, anuncia la Red A como inalcanzable a través de su enlace con los Routers Two y Three. Si el Router Three muestra algún trayecto hasta la Red A a través del Router One, lo eliminará debido al anuncio que indica que es inalcanzable. EIGRP combina estas dos reglas para evitar bucles de ruteo.

EIGRP utiliza Split horizon o anuncia que una ruta es inalcanzable cuando:

  • hay dos routers en modo de inicio (están intercambiando tablas de topología por primera vez)

  • anuncio de un cambio en la tabla de topología

  • envía una consulta

Examinemos cada una de estas situaciones.

Modo de inicio

Cuando dos routers pasan a ser vecinos por primera vez, intercambian las tablas de topología durante el modo de inicio. El router vuelve a anunciar cada entrada de tabla que recibe durante el modo de inicio a su vecino nuevo con una métrica máxima (ruta venenosa).

Cambio de la tabla de topología

En la figura 5, el Router One utiliza la varianza para equilibrar el tráfico destinado a la Red A entre los dos enlaces serie: el enlace de 56 k entre los Routers Two y Four, y el enlace de 128 k entre los Routers Three y Four (consulte la sección Balance de carga para obtener información sobre la varianza).

eigrp5.gif

El Router Two considera el trayecto a través del Router Three como un sucesor factible. Si el enlace entre los Routers Two y Four se interrumpe, el Router Two simplemente volverá a converger en el trayecto a través del Router Three. Como la regla de Split horizon afirma que no debe anunciar nunca una ruta fuera de la interfaz a través de la cual ha obtenido información sobre ella, el Router Two no enviaría por lo general una actualización. No obstante, esta situación deja al Router One con una entrada de la tabla de topología no válida. Cuando un router cambia su tabla de topología de manera que se modifica la interfaz a través de la cual el router llega a la red, éste desactiva Split horizon y Poison reverse invierte la ruta anterior por todas las interfaces. En este caso, el Router Two desactiva Split horizon para esta ruta y anuncia la Red A como inalcanzable. El Router One escucha este anuncio y purga su ruta a la Red A a través del Router Two desde su tabla de ruteo.

Consultas

Las consultas provocan un Split horizon sólo cuando un router recibe una consulta o actualización procedente del sucesor que utiliza para el destino en la consulta. Observemos la red de la figura 6.

eigrp6.gif

El Router Three recibe una consulta relacionada con 10.1.2.0/24 (al que llega a través del Router One) procedente del Router Four. Si Three no dispone de un sucesor para este destino debido a un enlace inestable o a otra situación temporal de la red, envía una consulta a cada uno de sus vecinos, en este caso, los Routers One, Two y Four. Sin embargo, si el Router Three recibe una consulta o actualización (como, por ejemplo una modificación de una métrica) del Router One para el destino 10.1.2.0/24, no enviará de nuevo la consulta al Router One, ya que éste último es su sucesor para llegar a esa red. Lo que hará es enviar únicamente consultas a los Routers Two y Four.

Rutas “stuck in active”

En algunas circunstancias, se tarda mucho tiempo en contestar una consulta. En ocasiones, tanto que el router que emitió la consulta renuncia a ella y borra su conexión con el router que no responde, reiniciando de este modo la sesión del vecino. Este proceso se conoce como ruta “stuck in active” (SIA). Las rutas SIA más básicas se producen cuando una consulta tarda demasiado en llegar al otro extremo de la red y para que se devuelva una respuesta. Por ejemplo, en la figura 7, el Router One está grabando una gran cantidad de rutas SIA desde el Router Two.

eigrp7.gif

Después de investigar el problema, éste se debe únicamente al retraso a través del enlace satélite entre los Routers Two y Three. Existen dos soluciones posibles para este tipo de problema. La primera consiste en aumentar el tiempo de espera del router entre el envío de la consulta y la declaración de la ruta SIA. Este valor puede modificarse mediante el comando timers active-time

Una mejor solución, sin embargo, consiste en rediseñar la red para que reduzca el rango de las consultas (para que pocas consultas se transmitan a través del enlace satélite). El rango de consulta se trata en la sección Rango de consulta. El rango de consulta en sí mismo no es, sin embargo, un motivo común para las rutas SIA notificadas. Con mayor frecuencia, un router de la red no puede responder a una consulta por uno de los siguientes motivos:

  • el router está demasiado ocupado como para responder a la consulta (por lo general debido a un alto nivel de uso de la CPU)

  • el router presenta problemas de memoria y no puede asignar la memoria para procesar la consulta o crear el paquete de respuesta

  • el circuito entre ambos routers es deficiente (se transmiten suficientes paquetes como para mantener la relación de vecinos pero algunas consultas o respuestas se pierden entre los enlaces unidireccionales

  • de los routers (enlaces en los que el tráfico sólo puede fluir en una dirección a causa de un fallo)

Solución de problemas en rutas SIA

La resolución de problemas de rutas SIA es generalmente un proceso de tres pasos:

  1. Detectar las rutas que se declaran constantemente como SIA.

  2. Detectar el router que no puede responder de manera constante a las consultas de dichas rutas.

  3. Busque la razón por la que el router no está recibiendo o respondiendo consultas.

El primer paso debería ser bastante fácil. Si registra los mensajes de la consola, una lectura rápida del registro le indicará las rutas marcadas con mayor frecuencia como SIA. El segundo paso es más difícil. Para reunir esta información, utilice el comando show ip eigrp topology active:

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - Reply status



A 10.2.4.0/24, 0 successors, FD is 512640000, Q

    1 replies, active 00:00:01, query-origin: Local origin

         via 10.1.2.2 (Infinity/Infinity), Serial1

    1 replies, active 00:00:01, query-origin: Local origin

         via 10.1.3.2 (Infinity/Infinity), r, Serial3

    Remaining replies:

         via 10.1.1.2, r, Serial0

Los vecinos que muestren una R tienen la respuesta pendiente (el temporizador activo indica el tiempo que la ruta ha permanecido activa). Tenga en cuenta que es posible que los vecinos no aparezcan en la sección de respuestas restantes, sino entre los demás RDB. Preste especial atención a las rutas que tengan respuestas pendientes y hayan permanecido activas durante cierto tiempo, por lo general de dos a tres minutos. Ejecute este comando varias veces para comprobar qué vecinos no están respondiendo a las consultas (o qué interfaces parecen contener una gran cantidad de consultas sin responder). Examine a este vecino para comprobar si espera constantemente respuestas de algunos de sus vecinos. Repita este proceso hasta que encuentre el router que no responde a consultas de forma constante. Intente detectar posibles problemas en el enlace con este vecino, el uso de la memoria o de la CPU u otros problemas con este vecino.

Si en su caso parece que el problema esté en el rango de la consulta, siempre es más recomendable reducirlo que aumentar el temporizador SIA.

Redistribución

Esta sección examina diferentes escenarios que involucran redistribución. Tenga en cuenta que los ejemplos que se indican a continuación muestran los requisitos mínimos necesarios para configurar la redistribución. La redistribución puede llegar a causar problemas, tales como un ruteo por debajo del nivel óptimo, bucles de ruteo o una convergencia lenta. Para evitar este tipo de problemas, consulte "Cómo evitar problemas debido a la redistribución" en la sección Redistribución de protocolos de ruteo.

Redistribución entre dos sistemas autónomos EIGRP

Los routers de la figura 8 se han configurado de la manera siguiente:

eigrp8.gif

Router One

router eigrp 2000

!--- El "2000" es el sistema autónomo 

 network 172.16.1.0 0.0.0.255

Router Two

router eigrp 2000

 redistribute eigrp 1000 route-map to-eigrp2000

 network 172.16.1.0 0.0.0.255

!

router eigrp 1000

 redistribute eigrp 2000 route-map to-eigrp1000

 network 10.1.0.0 0.0.255.255



route-map to-eigrp1000 deny 10

match tag 1000

!

route-map to-eigrp1000 permit 20

set tag 2000

!

route-map to-eigrp2000 deny 10

match tag 2000

!

route-map to-eigrp2000 permit 20

set tag 1000

Router Three

router eigrp 1000

 network 10.1.0.0 0.0.255.255

El Router Three anuncia la red 10.1.2.0/24 al Router Two a través del sistema autónomo 1000; a continuación, el Router Two redistribuye esta ruta hacia el sistema autónomo 2000 y la anuncia al Router One.

Nota: Las rutas procedentes de EIGRP 1000 se etiquetan como 1000 antes de ser redistribuidas a EIGRP 2000. Cuando las rutas procedentes de EIGRP 2000 se vuelven a redistribuir a EIGRP 1000, las rutas con la etiqueta 1000 se rechazan para garantizar una topología sin bucles. Para obtener más información sobre la redistribución entre protocolos de ruteo, consulte Redistribución de protocolos de ruteo.

En el Router One, se ve:

one# show ip eigrp topology 10.1.2.0 255.255.255.0

IP-EIGRP topology entry for 10.1.2.0/24

  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776

  Routing Descriptor Blocks:

  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0

      Composite metric is (46763776/46251776), Route is External

      Vector metric:

        Minimum bandwidth is 56 Kbit

        Total delay is 41000 microseconds

        Reliability is 255/255

        Load is 1/255

        Minimum MTU is 1500

        Hop count is 2

      External data:

        Originating router is 10.1.2.1

        AS number of route is 1000

        External protocol is EIGRP, external metric is 46251776

        Administrator tag is 1000 (0x000003E8)

Observe que aunque el enlace entre los Routers One y Two tiene un ancho de banda de 1.544 Mb, el ancho de banda mínimo que aparece en esta entrada de la tabla de topología es de 56 k. Esto significa que EIGRP conserva todas las métricas durante la redistribución entre dos sistemas EIGRP autónomos.

Redistribución entre EIGRP e IGRP en dos sistemas autónomos diferentes

En la Figura 9, hemos cambiado las configuraciones de la siguiente manera:

eigrp9.gif

Router One

router eigrp 2000

 network 172.16.1.0

Router Two

router eigrp 2000

 redistribute igrp 1000 route-map to-eigrp2000

 network 172.16.1.0

!

router igrp 1000

 redistribute eigrp 2000 route-map to-igrp1000

 network 10.0.0.0

!



route-map to-igrp1000 deny 10

match tag 1000

!

route-map to-igrp1000 permit 20

set tag 2000

!

route-map to-eigrp2000 deny 10

match tag 2000

!

route-map to-eigrp2000 permit 20

set tag 1000

Router Three

router igrp 1000

 network 10.0.0.0

A continuación, se muestra la configuración del Router One:

one# show ip eigrp topology 10.1.2.0 255.255.255.0 

IP-EIGRP topology entry for 10.1.2.0/24

  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776

  Routing Descriptor Blocks:

  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0

      Composite metric is (46763776/46251776), Route is External

      Vector metric:

        Minimum bandwidth is 56 Kbit

        Total delay is 41000 microseconds

        Reliability is 255/255

        Load is 1/255

        Minimum MTU is 1500

        Hop count is 1

      External data:

        Originating router is 10.1.1.1

        AS number of route is 1000

        External protocol is IGRP, external metric is 180671

        Administrator tag is 1000 (0x000003E8)

Las métricas IGRP se conservan durante la redistribución de rutas en EIGRP con un sistema autónomo diferente, aunque se escalan multiplicando la métrica IGRP por la constante 256. Hay algo que es necesario advertir en relación con la redistribución entre IGRP y EIGRP. Si la red se encuentra conectada directamente al router que lleva a cabo la redistribución, anunciará la ruta con una métrica de 1.

Por ejemplo, la red 10.1.1.0/24 se encuentra conectada directamente al Router Two, e IGRP está enrutando para esta red (hay una sentencia de red bajo el router IGRP que cubre esta interfaz). EIGRP no está enrutando para esta red, pero obtiene información acerca de esta interfaz conectada directamente a través de una redistribución desde IGRP. En el Router One, la entrada de la tabla de para 10.1.1.0/24 indica:

one# show ip eigrp topology 10.1.1.0 255.255.255.0 

IP-EIGRP topology entry for 10.1.1.0/24

  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2169856

  Routing Descriptor Blocks:

  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0

      Composite metric is (2169856/1), Route is External



      Vector metric:

        Minimum bandwidth is 1544 Kbit

        Total delay is 20000 microseconds

        Reliability is 0/255

        Load is 1/255

        Minimum MTU is 1500

        Hop count is 1

      External data:

        Originating router is 10.1.1.1

        AS number of route is 1000

        External protocol is IGRP, external metric is 0

        Administrator tag is 1000 (0x000003E8)

Tenga en cuenta que la distancia informada desde el Router Two, que está en negrita, es 1."

Redistribución entre EIGRP e IGRP en el mismo sistema autónomo

Los siguientes cambios se realizan en las configuraciones del router en la figura 10:

eigrp10.gif

Router One

router eigrp 2000

 network 172.16.1.0 

Router Two

router eigrp 2000

 network 172.16.1.0

!

router igrp 2000

 network 10.0.0.0

Router Three

router igrp 2000

 network 10.0.0.0

Por su parte, el Router One se configura de la siguiente manera:

one# show ip eigrp topology 10.1.2.0 255.255.255.0 

IP-EIGRP topology entry for 10.1.2.0/24

  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 46763776

  Routing Descriptor Blocks:

  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0

      Composite metric is (46763776/46251776), Route is External

      Vector metric:

        Minimum bandwidth is 56 Kbit

        Total delay is 41000 microseconds

        Reliability is 255/255

        Load is 1/255

        Minimum MTU is 1500

        Hop count is 1

      External data:

        Originating router is 10.1.1.1

        AS number of route is 2000

        External protocol is IGRP, external metric is 180671

        Administrator tag is 0 (0x00000000)

Esta configuración resulta extraordinariamente similar al resultado anterior cuando realizábamos la redistribución entre dos sistemas autónomos diferentes que ejecutaban IGRP y EIGRP. La red directamente conectada 10.1.1.0/24 recibe el mismo tratamiento en ambos casos:

one# show ip eigrp topology 10.1.1.0 255.255.255.0 

IP-EIGRP topology entry for 10.1.1.0/24

  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2169856

  Routing Descriptor Blocks:

  20.1.1.1 (Serial0), from 20.1.1.1, Send flag is 0x0

      Composite metric is (2169856/1), Route is External

      Vector metric:

        Minimum bandwidth is 1544 Kbit

        Total delay is 20000 microseconds

        Reliability is 255/255

        Load is 1/255

        Minimum MTU is 1500

        Hop count is 1

      External data:

        Originating router is 10.1.1.1

        AS number of route is 2000

        External protocol is IGRP, external metric is 0

        Administrator tag is 0 (0x00000000)

De este modo, la red, que se encuentra conectada directamente al Router One, se redistribuye de IGRP a EIGRP con una métrica de 1, la misma métrica que observamos durante la redistribución entre dos sistemas autónomos diferentes.

Es necesario advertir sobre dos aspectos en relación con la redistribución de EIGRP/IGRP dentro de un mismo sistema autónomo:

  • Siempre se prefieren las rutas EIGRP internas a las rutas EIGRP externas o IGRP.

  • Las métricas de la ruta EIGRP externa se comparan con las métricas escaladas de IGRP (se omite la distancia administrativa).

Examinemos estas advertencias en la figura 11:

eigrp11.gif

El Router One anuncia 10.1.4.0/24 en el sistema autónomo IGRP 100; el Router Four anuncia 10.1.4.0/24 como externa en el sistema autónomo EIGRP 100; El Router Two se ejecuta tanto en EIGRP como en sistema autónomo IGRP 100.

Si omitimos la ruta EIGRP anunciada por el Router Four (por ejemplo, desabilitando mediante "shut down" el enlace entre los Routers Two y Four), el Router Two mostrará el siguiente mensaje:

two# show ip route 10.1.4.0

Routing entry for 10.1.4.0/24

  Known via "igrp 100", distance 100, metric 12001

  Redistributing via igrp 100, eigrp 100

  Advertised by igrp 100 (self originated)

                eigrp 100

  Last update from 10.1.1.2 on Serial1, 00:00:42 ago

  Routing Descriptor Blocks:

  * 10.1.1.2, from 10.1.1.2, 00:00:42 ago, via Serial1

      Route metric is 12001, traffic share count is 1

      Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit

      Reliability 1/255, minimum MTU 1 bytes

      Loading 1/255, Hops 0

Observe que la distancia administrativa es 100. Cuando agregamos la ruta EIGRP, el Router Two muestra el siguiente mensaje:

two# show ip route 10.1.4.0

Routing entry for 10.1.4.0/24

  Known via "eigrp 100", distance 170, metric 3072256, type external

  Redistributing via igrp 100, eigrp 100

  Last update from 10.1.2.2 on Serial0, 00:53:59 ago

  Routing Descriptor Blocks:

  * 10.1.2.2, from 10.1.2.2, 00:53:59 ago, via Serial0

      Route metric is 3072256, traffic share count is 1

      Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit

      Reliability 1/255, minimum MTU 1 bytes

      Loading 1/255, Hops 1

Observe que las métricas de estas dos rutas son idénticas después de ser escaladas de IGRP a EIGRP (consulte la sección Métricas):

  • 12001 x 256 = 3072256

donde 12.001, la métrica IGRP, pasa a través del Router One, y 3.072.256, la métrica EIGRP, pasa a través del Router Four.

El Router Two prefiere la ruta externa EIGRP con la misma métrica (después de escalarse) y una distancia administrativa mayor. Este proceso se aplica cuando se produce la redistribución automática entre EIGRP e IGRP dentro de un mismo sistema autónomo. El router siempre prefiere el trayecto con la métrica de costo más baja y omite la distancia administrativa.

Redistribución a y de otros protocolos

La redistribución entre EIGRP y otros protocolos (RIP y OSPF, por ejemplo) funciona de la misma manera que cualquier otro tipo de redistribución. Siempre se recomienda utilizar la métrica predeterminada al realizar la redistribución entre protocolos. Durante la redistribución entre EIGRP y otros protocolos, deberá tener en cuenta los dos problemas siguientes:

  • Las rutas distribuidas en EIGRP no siempre están resumidas. Consulte la sección Resumen para obtener una explicación.

  • Las rutas EIGRP externas tienen una distancia administrativa de 170.

Redistribución de Rutas estáticas a las interfaces

Cuando instale una ruta estática a una interfaz y configure una sentencia de red mediante router eigrp, el cual incluye la ruta estática, EIGRP redistribuirá dicha ruta como si se tratara de una interfaz directamente conectada. Observemos la red de la figura 12.

eigrp12.gif

El Router One tiene una ruta estática a la red 172.16.1.0/24 configurada a través de la interfaz Serie 0:

ip route 172.16.1.0 255.255.255.0 Serial0

El Router One también cuenta con una sentencia de red para el destino de esta ruta estática:

router eigrp 2000

 network 10.0.0.0

 network 172.16.0.0

 no auto-summary 

El Router One redistribuye esta ruta aunque no redistribuya rutas estáticas, ya que EIGRP la considera como una red conectada directamente. Respecto al Router Two, se muestra lo siguiente:

two# show ip route

    ....

        10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C       10.1.1.0/24 is directly connected, Serial0

    D       10.1.2.0/24 [90/2169856] via 10.1.1.1, 00:00:47, Serial0

         172.16.0.0/24 is subnetted, 1 subnets

    D       172.16.1.0 [90/2169856] via 10.1.1.1, 00:00:47, Serial0

Observe que la ruta a 172.16.1.0/24 aparece como una ruta EIGRP interna en el Router Two.

Producción de resumen

Existen dos formas de resumen en EIGRP: resúmenes automáticos y resúmenes manuales.

Resumen automático

EIGRP ejecuta un resumen automático cada vez que cruza el límite entre dos redes principales distintas. Por ejemplo, en la figura 13, el Router Two sólo anuncia la red 10.0.0.0/8 al Router One, ya que la interfaz que utiliza el Router Two para llegar al Router One se encuentra en otra red principal.

eigrp13.gif

En el Router One, esto es similar a lo siguiente:

one# show ip eigrp topology 10.0.0.0

IP-EIGRP topology entry for 10.0.0.0/8

  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 11023872

  Routing Descriptor Blocks:

  172.16.1.1 (Serial0), from 172.16.1.2, Send flag is 0x0

      Composite metric is (11023872/10511872), Route is Internal

      Vector metric:

        Minimum bandwidth is 256 Kbit

        Total delay is 40000 microseconds

        Reliability is 255/255

        Load is 1/255

        Minimum MTU is 1500

        Hop count is 1

Esta ruta no se marca como ruta de resumen de ningún tipo, sino que parece una ruta interna. La métrica es la mejor métrica de las rutas resumidas. Observe que el ancho de banda mínimo en esta ruta es de 256 k, si bien existen enlaces en la red 10.0.0.0 con un ancho de banda de 56 k.

En el router que realiza el resumen se genera una ruta null0 para la dirección resumida:

two# show ip route 10.0.0.0

Routing entry for 10.0.0.0/8, 4 known subnets

  Attached (2 connections)

  Variably subnetted with 2 masks

  Redistributing via eigrp 2000



C       10.1.3.0/24 is directly connected, Serial2

D       10.1.2.0/24 [90/10537472] via 10.1.1.2, 00:23:24, Serial1

D       10.0.0.0/8 is a summary, 00:23:20, Null0

C       10.1.1.0/24 is directly connected, Serial1

La ruta a 10.0.0.0/8 se marca como un resumen a través de Null0. La entrada de la tabla de topología correspondiente a esta ruta de resumen tiene el siguiente aspecto:

two# show ip eigrp topology 10.0.0.0 

IP-EIGRP topology entry for 10.0.0.0/8

  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 10511872

  Routing Descriptor Blocks:

  0.0.0.0 (Null0), from 0.0.0.0, Send flag is 0x0

          (note: the 0.0.0.0 here means this route is originated by this router)

      Composite metric is (10511872/0), Route is Internal

      Vector metric:

        Minimum bandwidth is 256 Kbit

        Total delay is 20000 microseconds

        Reliability is 255/255

        Load is 1/255

        Minimum MTU is 1500

        Hop count is 0

Para que el Router Two anuncie los componentes de la red 10.0.0.0 en lugar de un resumen, configure no auto-summary en el proceso de EIGRP del Router Two:

En el Router Two

router eigrp 2000

 network 172.16.0.0

 network 10.0.0.0

 no auto-summary

Con el resumen automático desactivado, el Router One puede ver ahora todos los componentes de la red 10.0.0.0:

one# show ip eigrp topology

IP-EIGRP Topology Table for process 2000



Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - Reply status



P 10.1.3.0/24, 1 successors, FD is 46354176

         via 20.1.1.1 (46354176/45842176), Serial0

P 10.1.2.0/24, 1 successors, FD is 11049472

         via 20.1.1.1 (11049472/10537472), Serial0

P 10.1.1.0/24, 1 successors, FD is 11023872

         via 20.1.1.1 (11023872/10511872), Serial0

P 172.16.1.0/24, 1 successors, FD is 2169856

         via Connected, Serial0

Deben tenerse en cuenta algunas advertencias cuando se trabaja con el resumen de rutas externas, tema que se describe más adelante en la sección Resumen automático de rutas externas.

Resumen manual

EIGRP permite resumir rutas internas y externas en prácticamente cualquier límite de bit mediante el método de resumen manual. Por ejemplo, en la figura 14, el Router Two resume 192.1.1.0/24, 192.1.2.0/24 y 192.1.3.0/24 en el bloque CIDR 192.1.0.0/22.

eigrp14.gif

A continuación se muestra la configuración en el Router Two:

two# show run

....

!

interface Serial0

 ip address 10.1.50.1 255.255.255.0

 ip summary-address eigrp 2000 192.1.0.0 255.255.252.0

 no ip mroute-cache

!

....



two# show ip eigrp topology

IP-EIGRP Topology Table for process 2000



Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - Reply status



P 10.1.10.0/24, 1 successors, FD is 45842176

         via Connected, Loopback0

P 10.1.50.0/24, 1 successors, FD is 2169856

         via Connected, Serial0

P 192.1.1.0/24, 1 successors, FD is 10511872

         via Connected, Serial1

P 192.1.0.0/22, 1 successors, FD is 10511872

         via Summary (10511872/0), Null0

P 192.1.3.0/24, 1 successors, FD is 10639872

         via 192.1.1.1 (10639872/128256), Serial1

P 192.1.2.0/24, 1 successors, FD is 10537472

         via 192.1.1.1 (10537472/281600), Serial1

Observe el comando ip summary-address debajo de interface Serial0, y la ruta de resumen a través de Null0. En el Router One aparece como una ruta interna:

  one# show ip eigrp topology

IP-EIGRP Topology Table for process 2000



Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - Reply status



P 10.1.10.0/24, 1 successors, FD is 46354176

         via 10.1.50.1 (46354176/45842176), Serial0

P 10.1.50.0/24, 1 successors, FD is 2169856

         via Connected, Serial0

P 192.1.0.0/22, 1 successors, FD is 11023872

         via 10.1.50.1 (11023872/10511872), Serial0

Resumen automático de rutas externas

EIGRP no resumirá automáticamente las rutas externas a menos que exista un componente de la misma red principal que sea una ruta interna. Para ejemplificarlo, observemos la figura 15.

eigrp15.gif

El Router Three introduce rutas externas a 192.1.2.0/26 y 192.1.2.64/26 en EIGRP mediante el comando redistribute connected, tal como se muestra en las configuraciones siguientes.

Router Three

interface Ethernet0

 ip address 192.1.2.1 255.255.255.192

!

interface Ethernet1

 ip address 192.1.2.65 255.255.255.192

!

interface Ethernet2

 ip address 10.1.2.1 255.255.255.0

!router eigrp 2000

 redistribute connected

 network 10.0.0.0

 default-metric 10000 1 255 1 1500

Con esta configuración en el Router Three, la tabla de ruteo del Router One muestra lo siguiente:

  one# show ip route

....

     10.0.0.0/8 is subnetted, 2 subnets

D       10.1.2.0 [90/11023872] via 10.1.50.2, 00:02:03, Serial0

C       10.1.50.0 is directly connected, Serial0

     192.1.2.0/26 is subnetted, 1 subnets

D EX    192.1.2.0 [170/11049472] via 10.1.50.2, 00:00:53, Serial0

D EX    192.1.2.64 [170/11049472] via 10.1.50.2, 00:00:53, Serial0

Si bien el Router Three resume generalmente las rutas 192.1.2.0/26 y 192.1.2.64/26 en un destino de red principal (192.1.2.0/24) debido al resumen automático, no lo hará en este caso porque ambas rutas son externas. No obstante, si reconfigura el enlace entre los Routers Two y Three para 192.1.2.128/26 y agrega sentencias de red para esta red en dichos Routers, se generará el resumen automático de 192.1.2.0/24 en el Router Two.

Router Three

 interface Ethernet0

 ip address 192.1.2.1 255.255.255.192

!

interface Ethernet1

 ip address 192.1.2.65 255.255.255.192

!

interface Serial0

 ip address 192.1.2.130 255.255.255.192

!

router eigrp 2000

 network 192.1.2.0

Ahora, el Router Two genera el resumen para 192.1.2.0/24:

two# show ip route

....

D       192.1.2.0/24 is a summary, 00:06:48, Null0

....

Y el Router One muestra sólo la ruta de resumen:

 one# show ip route 

....

     10.0.0.0/8 is subnetted, 1 subnets

C       10.1.1.0 is directly connected, Serial0

D    192.1.2.0/24 [90/11023872] via 10.1.50.2, 00:00:36, Serial0

Procesamiento y rango de consultas

Cuando un router procesa una consulta de un vecino, se aplican las siguientes reglas:

Origen de la consulta

Estado de la ruta

Acción

vecino (no el sucesor actual)

pasivo

responder con la información del sucesor actual

sucesor

pasivo

intentar encontrar un sucesor nuevo; si se encuentra uno, responder con la nueva información; si no se encuentra ninguno, marcar el destino como inalcanzable y consultar a todos los vecinos excepto al sucesor anterior

cualquier vecino

sin trayecto a través de este vecino antes de la consulta

responder con el mejor trayecto que se conozca en esos momentos

cualquier vecino

no conocido antes de la consulta

responder que el destino es inalcanzable

vecino (no el sucesor actual)

activo

si no existe ningún sucesor actual para estos destinos (por lo general, ése debería ser el caso), responder diciendo que es inalcanzable

si existe un buen sucesor, responder con la información del trayecto actual

sucesor

activo

intentar encontrar un sucesor nuevo; si se encuentra uno, responder con la nueva información; si no se encuentra ninguno, marcar el destino como inalcanzable y consultar a todos los vecinos excepto al sucesor anterior

Las acciones de la tabla anterior repercuten en el rango de la consulta en la red, ya que determinan el número de routers que recibirán y responderán a la consulta antes de que la red converja en la nueva topología. Para conocer cómo afectan estas reglas al modo en que se gestionan las consultas, observemos la red de la figura 16, la cual se ejecuta en condiciones normales.

eigrp16.gif

Podemos esperar que suceda lo siguiente respecto a la red 192.168.3.0/24 (extremo derecho):

  • El Router One tiene dos trayectos hacia 192.168.3.0/24:

    • a través del Router Two con una distancia de 46.533.485 y una distancia informada de 20.307.200

    • a través del Router Three con una distancia de 20.563.200 y una distancia informada de 20.307.200

  • El Router One elige el trayecto a través del Router Three y mantiene el trayecto a través del Router Two como un sucesor factible

  • Los Routers Two y Three muestran un trayecto hasta 192.168.3.0/24 a través del Router Four

Suponga que 192.168.3.0/24 falla. ¿Qué actividad podemos esperar en esta red? Las figuras de la 16a hasta la 16h ilustran el proceso.

El Router cinco marca 192.168.3.0/24 como inalcanzable y consulta al Router Four:

eigrp16a.gif

El Router Four, al recibir una consulta de su sucesor, intenta encontrar un nuevo sucesor factible para esta red. Si no encuentra ninguno, marca 192.168.3.0/24 como inalcanzable y consulta a los Routers Two y Three:

eigrp16b.gif

Los Routers Two y Three, a su vez, comprueban que han perdido su única ruta factible hasta 192.168.3.0/24 y la marcan como inalcanzable; ambos envían sus consultas al Router One:

eigrp16c.gif

Para simplificar la situación, supongamos que el Router One recibe primero la consulta procedente del Router Three y marca la ruta como inalcanzable. A continuación, el Router One recibe la consulta del Router Two. Aunque es posible que se dé otro orden, el resultado final será el mismo.

eigrp16d.gif

El Router One responde a ambas consultas diciendo que la ruta es inalcanzable, por lo que éste pasará al estado pasivo para la red 192.168.3.0/24:

eigrp16e.gif

Los Routers Two y Three responden a la consulta del Router Four; los Routers Two y Three pasan al estado pasivo para la red 192.168.3.0/24:

eigrp16f.gif

El Router cinco, al recibir la respuesta del Router Four, elimina la red 192.168.3.0/24 de su tabla de ruteo; el Router cinco pasa al estado pasivo para la red 192.168.3.0/24. El Router cinco envía de nuevo las actualizaciones al Router Four, de modo que la ruta se elimina de la topología y las tablas de ruteo de los routers restantes.

eigrp16g.gif

Es importante entender que aunque es posible que existan otros trayectos de consulta u órdenes de procesamiento, todos los routers de la red procesarán una consulta para la red 192.168.3.0/24 cuando se interrumpa ese enlace. Es posible que algunos routers finalizen procesando más de una consulta (el Router One en este ejemplo). De hecho, si las consultas llegaran a los routers en un orden distinto, algunos finalizarían procesando tres o cuatro consultas. Éste es un buen ejemplo de una consulta sin límites en una red EIGRP.

¿Cómo afectan los puntos de resumen al rango de la consulta?

A continuación, observemos los trayectos hasta 10.1.1.0/24 en la misma red:

  • El Router Two contiene una entrada de la tabla de topología correspondiente a la red 10.1.1.0/24 con un costo de 46.251.885 a través del Router One.

  • El Router Three contiene una entrada de la tabla de topología correspondiente a la red 10.1.1.0/24 con un costo de 20.281.600 a través del Router One.

  • El Router Four contiene una entrada de la tabla de topología correspondiente a la red 10.0.0.0/8 (esto es debido a que los Routers Two y Three realizan un resumen automático para el límite de la red principal) a través del Router Three con una métrica de 20.307.200 (la distancia informada a través del Router Two es mayor que la métrica total a través del Router Three, por lo que el trayecto a través del Router Two no se considera un sucesor factible).

eigrp17.gif

Si la red 10.1.1.0/24 se desactiva, el Router One la marcará como inalcanzable y, a continuación, consultará a cada uno de sus vecinos (los Routers Two y Three) por si existe un trayecto nuevo hasta esa red:

eigrp17a.gif

El Router Two, al recibir la consulta del Router One, marca la ruta como inalcanzable (ya que la consulta procede de su sucesor) y, a continuación, consulta a los Routers Four y Three:

eigrp17b.gif

El Router Three, al recibir la consulta del Router One, marca el destino como inalcanzable y consulta a los Routers Two y Four:

eigrp17c.gif

El Router Four, al recibir las consultas de los Routers Two y Three, responde que la red 10.1.1.0/24 es inalcanzable (observe que el Router Four no tiene ningún conocimiento de la subred en cuestión, ya que sólo dispone de la ruta hasta 10.0.0.0/8):

eigrp17d.gif

Los Routers Two y Three se responden mutuamente que 10.1.1.0/24 es inalcanzable:

eigrp17e.gif

Dado que los Routers Two y Three no tienen consultas pendientes, ambos responderán al Router One que 10.1.1.0/24 es inalcanzable:

eigrp17f.gif

La consulta, en este caso, está delimitada por el resumen automático en los Routers Two y Three. El Router cinco no participa en el proceso de la consulta, por lo que no se ve involucrado en la reconvergencia de la red. Las consultas también se pueden delimitar mediante el resumen manual, los límites del sistema autónomo y las listas de distribución.

Cómo influyen los límites del sistema autónomo en el rango de la consulta

Si un router redistribuye rutas entre dos sistemas autónomos EIGRP, responderá a la consulta dentro de las reglas de procesamiento habituales y lanzará una nueva consulta en el otro sistema autónomo. Por ejemplo, si el enlace a la red conectada al Router Three se interrumpe, este último marcará la ruta como inalcanzable y consultará al Router Two por si existe un trayecto nuevo:

eigrp18.gif

El Router Two responderá que la red es inalcanzable y lanzará una consulta en el sistema autónomo 200 dirigida al Router One. Una vez que el Router Three reciba la respuesta a su consulta original, eliminará la ruta de su tabla. El Router Three pasa al estado pasivo para esta red:

eigrp18a.gif

El Router One responde al Router Two, y la ruta se hace pasiva:

eigrp18b.gif

Si bien la consulta original no se propagó por toda la red (ya que estaba delimitada por el límite del sistema autónomo), sí se infiltró en el otro sistema autónomo en forma de una nueva consulta. Esta técnica le puede ayudar a evitar problemas de "stuck in active" (SIA) en una red si limita el número de routers por los que debe pasar una consulta antes de ser respondida, aunque no resuelve el problema general de que cada router debe procesar la consulta. En realidad, este método de delimitación de una consulta podría empeorar el problema al evitar el resumen automático de rutas que de otro modo se resumirían (las rutas externas no se resumen a menos que exista un componente externo en la misma red principal).

Cómo afectan las listas de distribución al rango de consultas

En lugar de bloquear la propagación de una consulta, las listas de distribución de EIGRP marcan cualquier respuesta a la consulta como inalcanzable. Veamos la figura 19 a modo de ejemplo.

eigrp19.gif

En la figura anterior:

  • el Router Three contiene una lista de distribución aplicada para sus interfaces serie que sólo le permite anunciar la Red B.

  • Los Routers One y Two no saben que la Red A es alcanzable a través del Router Three (éste no se utiliza como punto de tránsito entre los Routers One y Two).

  • El Router Three utiliza el Router One como su trayecto preferido hasta la Red A, y no utiliza el Router Two como un sucesor factible.

Cuando el Router One pierde la conexión con la Red A, marca la ruta como inalcanzable y envía una consulta al Router Three. El Router Three no anuncia ningún trayecto a la Red A dada la lista de distribución en sus puertos serie.

eigrp19a.gif

El Router Three marca la ruta como inalcanzable y luego efectúa la siguiente consulta al Router Two:

eigrp19b.gif

El Router Two examina su tabla de topología y comprueba que dispone de una conexión válida a la Red A. Observe que la consulta no se vio afectada por la lista de distribución del Router Three:

eigrp19c.gif

El Router Two responde que la Red A es inalcanzable; el Router Three ahora dispone de una ruta válida:

eigrp19d.gif

El Router Three genera la respuesta a la consulta procedente del Router One, pero debido a la lista de distribución, envía una respuesta indicando que la Red A es inalcanzable aunque disponga de una ruta válida a la Red A:

eigrp19e.gif

Resincronización de paquetes

Algunos protocolos de ruteo consumen todo el ancho de banda disponible en un enlace de ancho de banda bajo cuando convergen (cuando se adaptan a un cambio en la red). EIGRP evita esta congestión mediante la regulación de la velocidad de transmisión de los paquetes a una red, y de esta manera utiliza únicamente parte del ancho de banda disponible. La configuración predeterminada para EIGRP es utilizar hasta el 50 por ciento del ancho de banda disponible, si bien este valor puede modificarse mediante el siguiente comando:

router(config-if)# ip bandwidth-percent eigrp 2 ? 

  <1-999999>  Maximum bandwidth percentage that EIGRP may use

Básicamente, cada vez que EIGRP pone en cola un paquete que se debe transmitir en una interfaz, utiliza la fórmula siguiente para determinar el tiempo que deberá esperar antes de enviar el paquete:

  • (8 * 100 * tamaño del paquete en bytes) / (ancho de banda en kbps * porcentaje del ancho de banda)

Por ejemplo, si EIGRP pone en cola un paquete que debe enviarse a través de una interfaz serie con un ancho de banda de 56 k y el paquete es de 512 bytes, EIGRP esperará el tiempo siguiente:

  • (8 * 100 * 512 bytes) / (56.000 bits por segundo * 50% de ancho de banda) (8 * 100 * 512) / (56.000 * 50) 409.600 / 2.800.000 0,1463 segundos

Esto permite que un paquete (o grupo de paquetes) de al menos 512 bytes puedan transmitirse en este enlace antes de que EIGRP envíe su paquete. El temporizador regulador de tráfico determina cuándo se envía el paquete y normalmente está expresado en milisegundos. El intervalo regulador de tráfico para el paquete del ejemplo anterior es de 0,1463 segundos. Hay un campo en show ip eigrp interface que indica el temporizador regulador de tráfico, tal como se muestra a continuación.

router# show ip eigrp interface

IP-EIGRP interfaces for process 2



                    Xmit Queue   Mean   Pacing Time   Multicast    Pending

Interface    Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes

Se0            1        0/0        28       0/15         127           0

Se1            1        0/0        44       0/15         211           0

router#

El tiempo que aparece corresponde al intervalo regulador de tráfico para la unidad de transmisión máxima (MTU), es decir, el paquete más grande que se puede enviar a través de la interfaz.

ruteo predeterminado

No existe ningún método para introducir una ruta predeterminada en EIGRP: puede redistribuir una ruta estática o resumirla en 0.0.0.0/0. El primer método es recomendable si desea atraer todo el tráfico con destinos desconocidos hacia una ruta predeterminada del núcleo de la red. Este método resulta eficaz para anunciar conexiones a Internet. Por ejemplo:

ip route 0.0.0.0 0.0.0.0 x.x.x.x (next hop to the internet)

!

router eigrp 100

 redistribute static

 default-metric 10000 1 255 1 1500

La ruta estática que se redistribuye en EIGRP no debe ser para la red 0.0.0.0. Si utiliza otra red, deberá utilizar el comando ip default-network para marcarla como red predeterminada. Consulte Configuración de una gateway de último recurso para obtener más información.

El resumen a una ruta predeterminada es efectivo sólo cuando se desean ofrecer sitios remotos con una ruta predeterminada. Dado que los resúmenes se configuran para cada interfaz, no deberá preocuparse de utilizar listas de distribución u otros mecanismos con el fin de evitar que la ruta predeterminada se propague hacia el núcleo de la red. Observe que un resumen en 0.0.0.0/0 anulará la ruta predeterminada obtenida de cualquier otro protocolo de ruteo. La única manera de configurar una ruta predeterminada en un router con este método es configurar una ruta estática a 0.0.0.0/0. (A partir de la versión 12.0(4)T del software Cisco IOS, podrá configurar también una distancia administrativa en la parte final del comando summary-address para que el resumen local no anule la ruta 0.0.0.0/0).

router eigrp 100

 network 10.0.0.0

!

interface serial 0

 encapsulation frame-relay

 no ip address

!

interface serial 0.1 point-to-point

 ip address 10.1.1.1

 frame-relay interface-dlci 10

 ip summary-address eigrp 100 0.0.0.0 0.0.0.0

Balance de carga

EIGRP coloca hasta cuatro rutas de igual costo en la tabla de ruteo, cuya carga es luego equilibrada por el router. El tipo de balance de carga (por paquete o destino) depende del tipo de conmutación que se está llevando a cabo en el router. EIGRP, sin embargo, también puede realizar un balance de carga en enlaces de costos desiguales.

Nota: max-paths le permite configurar EIGRP para que utilice hasta un máximo de seis rutas de igual costo.

Supongamos que existen cuatro trayectos hasta un destino determinado y que las métricas para dichos trayectos son las siguientes:

  • trayecto 1: 1100

  • trayecto 2: 1100

  • trayecto 3: 2000

  • trayecto 4: 4000

El router, de manera predeterminada, coloca el tráfico en los trayectos 1 y 2. Mediante EIGRP, puede utilizar el comando variance para indicarle al router que también coloque tráfico en los trayectos 3 y 4. La varianza es un multiplicador: el tráfico se colocará en cualquier enlace que posea una métrica menor al mejor trayecto multiplicado por la varianza. Para llevar a cabo el balance de carga por los trayectos 1, 2 y 3, utilice la varianza 2, ya que 1.100 x 2 = 2.200, lo cual es mayor que la métrica a través del trayecto 3. De manera similar, para agregar también el trayecto 4, ejecute la varianza 4 mediante el comando router eigrp. Consulte ¿Cómo funciona el balance de carga de trayectos de costo desigual (varianza) en IGRP y EIGRP? para obtener más información.

¿Cómo divide el router el tráfico entre estos trayectos? Divide la métrica a través de cada trayecto entre la métrica mayor, redondea el valor con el entero más próximo y utiliza este número como recuento del tráfico compartido.

router# show ip route 10.1.4.0

Routing entry for 10.1.4.0/24

  Known via "igrp 100", distance 100, metric 12001

  Redistributing via igrp 100, eigrp 100

  Advertised by igrp 100 (self originated)

                eigrp 100

  Last update from 10.1.2.2 on Serial1, 00:00:42 ago

  Routing Descriptor Blocks:

  * 10.1.2.2, from 10.1.2.2, 00:00:42 ago, via Serial1

      Route metric is 12001, traffic share count is 1

      Total delay is 20010 microseconds, minimum bandwidth is 1000 Kbit

      Reliability 1/255, minimum MTU 1 bytes

      Loading 1/255, Hops 0

Los recuentos de tráfico compartido de este ejemplo son los siguientes:

  • para los trayectos 1 y 2: 4000/1100 = 3

  • para el trayecto 3: 4000/2000 = 2

  • para el trayecto 4: 4000/4000 = 1

El router envía los tres primeros paquetes por el trayecto 1, los siguientes tres paquetes por el trayecto 2, los siguientes dos paquetes por el trayecto 3 y el siguiente paquete por el trayecto 4. A continuación, el router vuelve a empezar y envía los tres paquetes siguientes por el trayecto 1, y así sucesivamente.

Nota: Aunque tenga la varianza configurada, EIGRP no enviará el tráfico por un trayecto de costo desigual si la distancia informada es mayor que la factible para esa ruta en particular. Consulte la sección Distancia factible, distancia informada y sucesores factibles para obtener más información.

Uso de las métricas

Cuando realice la configuración inicial de EIGRP, recuerde estas dos reglas básicas cuando intente modificar las métricas de EIGRP:

  • El ancho de banda deberá configurarse siempre en función del ancho de banda real de la interfaz; la excepción a esta regla la presentan los enlaces serie multipunto y otras situaciones en las que la velocidad de los dispositivos no coincide.

  • La demora debería utilizarse siempre para influenciar las decisiones de ruteo de EIGRP.

Dado que EIGRP emplea el ancho de banda de la interfaz para determinar la velocidad con la que debe enviar los paquetes, es importante que estos valores se configuren correctamente. Si es necesario modificar el trayecto elegido por EIGRP, utilice siempre un retraso para ello.

En el caso de un ancho de banda reducido, éste tiene más influencia sobre la métrica total, mientras que con un ancho de banda mayor, el retraso es el elemento con mayor influencia.

Uso de etiquetas administrativas en redistribución

Las etiquetas administrativas externas resultan de utilidad para romper bucles de ruteo de distribución entre EIGRP y otros protocolos. Al etiquetar la ruta cuando se redistribuye en EIGRP, puede bloquear la redistribución desde EIGRP en el protocolo externo. A continuación se incluye un ejemplo básico de configuración de este tipo de etiquetas, si bien este ejemplo no muestra toda la configuración empleada para romper bucles de redistribución.

eigrp20.gif

El Router Three, que está redistribuyendo rutas conectadas en EIGRP, muestra lo siguiente:

three# show run



....



interface Loopback0

 ip address 172.19.1.1 255.255.255.0

!

interface Ethernet0

 ip address 172.16.1.1 255.255.255.0

 loopback

 no keepalive

!

interface Serial0

 ip address 172.17.1.1 255.255.255.0



....



router eigrp 444

 redistribute connected route-map foo

 network 172.17.0.0

 default-metric 10000 1 255 1 1500



....



access-list 10 permit 172.19.0.0 0.0.255.255

route-map foo permit 10

 match ip address 10

 set tag 1



....



three# show ip eigrp topo

IP-EIGRP Topology Table for process 444



Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - Reply status



P 172.17.1.0/24, 1 successors, FD is 2169856

         via Connected, Serial0

         via Redistributed (2169856/0)

P 172.16.1.0/24, 1 successors, FD is 281600

         via Redistributed (281600/0)

P 172.19.1.0/24, 1 successors, FD is 128256, tag is 1

         via Redistributed (128256/0)

El Router Two, que distribuye las rutas de EIGRP a RIP, muestra:

two# show run 



....



interface Serial0

 ip address 172.17.1.2 255.255.255.0

!

interface Serial1

 ip address 172.18.1.3 255.255.255.0



....



router eigrp 444

 network 172.17.0.0

!

router rip

 redistribute eigrp 444 route-map foo

 network 10.0.0.0

 network 172.18.0.0

 default-metric 1

!

no ip classless

ip route 1.1.1.1 255.255.255.255 Serial0

route-map foo deny 10

 match tag 1

!

route-map foo permit 20



....



two# show ip eigrp topo

IP-EIGRP Topology Table for process 444



Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

       r - Reply status



P 172.17.1.0/24, 1 successors, FD is 2169856

         via Connected, Serial0

P 172.16.1.0/24, 1 successors, FD is 2195456

         via 172.17.1.1 (2195456/281600), Serial0

P 172.19.1.0/24, 1 successors, FD is 2297856, tag is 1

         via 172.17.1.1 (2297856/128256), Serial0

Observe la etiqueta 1 en 172.19.1.0/24.

El Router One, que recibe las rutas RIP redistribuidas por el Router 2, indica lo siguiente:

one# show run



....



interface Serial0

 ip address 172.18.1.2 255.255.255.0

 no fair-queue

 clockrate 1000000



router rip

 network 172.18.0.0



....



one# show ip route



Gateway of last resort is not set



R    172.16.0.0/16 [120/1] via 172.18.1.3, 00:00:15, Serial0

R    172.17.0.0/16 [120/1] via 172.18.1.3, 00:00:15, Serial0

     172.18.0.0/24 is subnetted, 1 subnets

C       172.18.1.0 is directly connected, Serial0

Observe que falta la red 172.19.1.0/24.

Información sobre la salida del comando EIGRP

show ip eigrp topology

Este comando sólo muestra los sucesores factibles. Para mostrar todas las entradas de la tabla de topología, utilice el comando show ip eigrp topology all-links. A continuación de la tabla se incluye una explicación de cada campo de resultado.

show ip eigrp topology

eigrp22.gif

Explicaciones sobre la configuración

A significa activo. También podría mostrar una P, la cual significa pasivo.

10.2.4.0/24 es el destino o máscara.

0 successors muestra el número de sucesores (o trayectos) que están disponibles para este destino; si los sucesores aparecen en mayúsculas, significa que la ruta está en transición.

FD is 512640000 indica la distancia factible, que corresponde a la mejor métrica para alcanzar el destino o la mejor métrica conocida en el momento de activar la ruta.

tag is 0x0 puede configurarse o filtrarse con mapas de rutas mediante los comandos set tag y match tag .

Q significa que hay una consulta pendiente. Este campo también puede mostrar U si tiene una actualización pendiente, o bien R si tiene una respuesta pendiente.

1 replies muestra la cantidad de respuestas pendientes.

active 00:00:01 muestra el tiempo que esta ruta ha estado activa.

query origin: Local origin indica que esta ruta originó la consulta. Este campo también puede mostrar Multiple origins, lo cual significa que varios vecinos (no el sucesor) han enviado consultas sobre este destino, o bien Successor origin, que significa que el sucesor ha originado la consulta.

via 10.1.2.2 indica que hemos obtenido esta ruta de un vecino cuya dirección IP es 10.1.2.2. Este campo también puede mostrar Connected, si la red está conectada directamente al router, Redistributed, si la ruta se está redistribuyendo en EIGRP con este router, o Summary, si se trata de una ruta de resumen generada en este router.

(Infinity/Infinity) indica la métrica que permite alcanzar este trayecto a través del vecino del primer campo y la distancia informada a través del vecino del segundo campo.

r indica que hemos consultado a este vecino y que esperamos su respuesta.

Q es el indicador de envío para esta ruta, lo que significa que hay una consulta pendiente. Este campo también puede mostrar U, lo que significa que hay una actualización pendiente o R, lo que significa que hay una respuesta pendiente.

Serial1 es la interfaz a través de la cual este vecino puede ser alcanzado.

Via 10.1.1.2 indica el vecino del que esperamos una respuesta.

r indica que hemos consultado a este vecino acerca de la ruta y que todavía no hemos recibido una respuesta.

Serial0 es la interfaz a través de la cual este vecino puede ser alcanzado.

Via 10.1.2.2 (512640000/128256), Serial1 muestra que estamos utilizando esta ruta (indica el trayecto que tomará el siguiente trayecto o destino si hay varias rutas de igual costo).

show ip eigrp topology <red>

Este comando muestra todas las entradas en la tabla de topología para este destino, no sólo a los sucesores factibles. A continuación de la tabla se incluye una explicación de cada campo de resultado.

show ip eigrp topology network

eigrp23.gif

Explicaciones sobre la configuración

State is Passive significa que la red se encuentra en estado pasivo, es decir, que no estamos buscando un trayecto hasta esta red. La mayoría de las veces, las rutas están en estado pasivo en las redes estables.

Query origin flag is 1 Si la ruta está activa, este campo ofrece información sobre el creador de la consulta.

  • 0: La ruta está activa pero no se ha originado ninguna consulta en relación con ella (buscamos un sucesor factible local).

  • 1: Este router originó la consulta para esta ruta (o bien la ruta es pasiva).

  • 2: Existen varios cálculos difusos para esta consulta. El router ha recibido más de una consulta para esta ruta de más de una fuente.

  • 3: El router del que obtuvimos el trayecto hasta esta red está consultando la existencia de otra ruta.

  • 4: Existen varios orígenes de consulta para esta ruta, incluido el router a través del que obtuvimos la ruta en cuestión. Es similar a 2, pero también significa que existe una cadena de origen de consulta que describe las consultas pendientes para esta ruta.

2 Successor(s) significa que existen dos trayectos factibles hasta esta red.

FD is 307200 muestra la mejor métrica actual a esta red. Si la ruta está activa, indica la métrica del trayecto que se estaba usando anteriormente para enrutar paquetes a esta red.

Routing Descriptor Blocks Cada una de las siguientes entradas describe un trayecto hasta la red.

  • 10.1.1.2 (Ethernet1) representa el siguiente salto (next hop) hacia la red y la interfaz a través de la cual se alcanza el siguiente salto (next hop).

  • from 10.1.2.2 representa el origen de esta información de trayecto.

  • Send flag is:

    • 0x0: Si hay paquetes por enviar en relación con esta entrada, indica el tipo de paquete.

    • 0x1: El router ha recibido una consulta sobre esta red y necesita enviar una respuesta de unidifusión.

    • 0x2: La ruta está activa, por lo que deberá enviarse una consulta de multidifusión.

    • 0x3: La ruta ha cambiado, por lo que deberá enviarse una actualización de multidifusión.

Composite metric is (307200/281600) indica el total de los costos calculados hasta la red. El primer número entre paréntesis representa el costo total hasta la red a través de este trayecto, incluido el costo hasta el siguiente salto. El segundo número entre paréntesis representa la distancia informada, es decir, el costo del router para el siguiente salto (next hop).

Route is Internal significa que la ruta se originó en el propio sistema autónomo (AS) EIGRP. Si la ruta fue redistribuida en este AS EIGRP, este campo indicará que la ruta es externa.

Vector metric muestra las métricas individuales utilizadas por EIGRP para calcular el costo hasta una red. EIGRP no propaga la información sobre el costo total por toda la red, sino que se propagan las métricas del vector y cada router calcula el costo y la distancia informada de manera individual.

  • Minimum bandwidth is 10000 Kbit indica el ancho de banda más bajo en el trayecto hasta esta red.

  • Total delay is 2000 microseconds indica la suma de los retrasos en el trayecto hasta esta red.

  • Reliability is 0/255 indica el factor de fiabilidad. Este número se calcula de forma dinámica, si bien no se utiliza de manera predeterminada en los cálculos de métricas.

  • Load is 1/255 indica la cantidad de carga que lleva el enlace. Este número se calcula de forma dinámica, si bien no se utiliza de manera predeterminada cuando EIGRP calcula el costo del uso del trayecto.

  • Minimum MTU is 1500 Este campo no se utiliza en los cálculos de métricas.

  • Hop count is 2 Este campo no se utiliza en los cálculos de métricas, pero sí limita el tamaño máximo de un AS EIGRP. EIGRP acepta de manera predeterminada un número máximo de 100 saltos, aunque es posible configurar un máximo de 220 con los saltos máximos de métrica.

Si la ruta es externa, se incluye la siguiente información. A continuación de la tabla se incluye una explicación de cada campo de resultado.

Ruta externa

eigrp24.gif

Explicaciones sobre la configuración

Originating Router indica que se trata del router que introdujo esta ruta en el AS EIGRP.

External AS indica el sistema autónomo del que procede esta ruta (si existe).

External Protocol indica el protocolo del que procede esta ruta (si existe).

external metric indica la métrica interna del protocolo externo.

Administrator Tag puede configurarse o filtrarse con mapas de rutas mediante los comandos set tag y match tag.

show ip eigrp topology [active | pending | zero-successors]

El mismo formato de resultado que show ip eigrp topology, con la diferencia de que también muestra una parte de la tabla de topología.

show ip eigrp topology all-links

El mismo formato de resultado que show ip eigrp topology, con la diferencia de que también muestra todos los enlaces de la tabla de topología en lugar de mostrar únicamente los sucesores factibles.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 16406