Voz : Protocolos de gateway

Configuración del relé de hookflash en puertos de voz FXS/FXO

19 Mayo 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (2 Febrero 2006) | Comentarios

Contenidos

Introducción
Requisitos previos
     Requisitos
     Componentes utilizados
     Convenciones
Antecedentes
Configurar
     Configuración de PLAR OPX y del Relé de hookflash
     Diagrama de la red
     Configuraciones
Verificación y resolución de problemas
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

Al integrar tecnologías de telefonía en paquetes como Voz por IP (VoIP) a la central telefónica privada (PBX) y a las redes de telefonía pública conmutada (PSTN), a veces es necesario transmitir un tipo de señal llamada “hookflash”. Un hookflash es una interrupción de la corriente del bucle en troncos de inicio de bucle que el sistema adjunto no interpreta como desconexión de llamada.

Una vez que la PBX o PSTN detecta el hookflash, generalmente pone la llamada actual en espera y proporciona un tono de marcado o acceso secundario a otras funciones como una transferencia o un acceso a llamada en espera.

Un hookflash se realiza pulsando momentáneamente la horquilla del teléfono. Algunos auriculares de teléfono tienen un botón llamado “flash” o “recall” que envía una “interrupción de bucle temporizado”, o un “Flash calibrado” que es un hookflash que tiene temporización precisa.

Requisitos previos

Requisitos

No hay requisitos específicos para este documento.

Componentes utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware:

  • Routers Cisco 1750

  • Versión 12.2.5a del software Cisco IOS®

  • Un requisito previo es el Soporte de la versión 2 de H.323. Éste ha estado disponible a partir de las Versiones 12.05T del software Cisco IOS y posteriores. La detección / generación de un hookflash se soporta en los puertos de voz análogos de la Estación de intercambio remota (FXS) y de la Oficina de intercambio remota (FXO). Éstas están disponibles en estas plataformas de hardware de Cisco:

    • 1750/51/60

    • 2600

    • 3600

    • 3700

    • MC3810

    • Catalyst 4000 con Módulo de gateway de acceso (AGM)

La información que contiene este documento se creó a partir de los dispositivos en un entorno de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración despejada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones de los consejos técnicos de Cisco.

Antecedentes

Muchos clientes utilizan una combinación de puertos FXS y FXO para extender los auriculares de los teléfonos en las redes IP. Desean preservar las funciones del PBX existente, como el reenvío de llamadas, correo de voz sin respuesta, y transferencia / espera en las extensiones remotas. El software Cisco VoIP anterior no proporcionará un control absoluto para permitir integración transparente. Sin embargo con el lanzamiento del Soporte de la versión 2 de H.323 de la Versión 12.05T t posteriores del software Cisco IOS, ahora es posible detectar y transmitir señalización de hookflash en las redes IP.

Cuando se configura el puerto FXS para un valor 'hookflash in' del temporizador (superior a 500 msegs.), los usuarios pueden notar que cuando cuelgan y levantan rápidamente el auricular, no se ha borrado la llamada: Si el valor se establece demasiado bajo, es posible que se interprete el hookflash como si se colgara el teléfono, pero un valor superior significa que se deberá dejar colgado el auricular durante mas tiempo para borrar la llamada. En ciertos casos, el rebote de la horquilla también puede causar problemas. Al colgarse el auricular, la tensión del resorte del botón de la horquilla causa múltiples interrupciones breves en la línea conocidas como rebotes de la horquilla. El ajuste cuidadoso del hookflash en el valor de temporización puede ser necesario para obtener mejores resultados. Una posibilidad en esos casos es utilizar auriculares con botón Flash que envía un hookflash de duración específica. El puerto FXO puede establecerse de modo que coincida con este valor y genere el hookflash saliente. Muchos PBX tienen una opción de Clase de servicio (CoS) llamada “Flash calibrado” o “interrupción de bucle temporizado” que les permite reconocer hookflash de duración específica e ignorar otras interrupciones de bucle más breves o más extensas. Dicha configuración ayuda a eliminar desconexiones falsas y la generación de señales de hookflash inválidas para el PBX.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la herramienta de búsqueda de comandos (solamente clientes registrados).

Configuración de PLAR OPX y del Relé de hookflash

Utilice este procedimiento para configurar la generación de llamada automática por línea privada (PLAR), las extensiones fuera de las instalaciones (OPX) y el relé de hookflash.

  1. Configure el puerto FXO en el router MainSite como conexión plar-opx.

    El modo OPX permite a los usuarios remotos de los puertos FXS que una PBX central los vea como extensiones de conexión directa. Cuando el puerto FXO detecta una señal de timbre de llamada proveniente de la PBX, el router envía una configuración de llamada VoIP al puerto remoto FXS pero no descuelga el puerto FXO. Como resultado, la PBX sólo detecta la señal de respuesta a llamada cuando se accede al puerto FXS del router RemoteSide. Una vez que la PBX llega al tiempo de espera sin respuesta (se interrumpe la llamada), puede finalizar la llamada, transferirla al correo de voz o llamar a otra extensión / grupo de anillos. Sin el modo OPX, el puerto FXO se desconecta inmediatamente después de detectar la llamada y, entonces, la PBX no puede realizar el reenvío de llamadas, enviar respuestas o volcarlas a un correo de voz.

  2. El router RemoteSite debe estar configurado para detectar y, después, transmitir la señal del hookflash al puerto FXS.

    Debido a que el hookflash es una interrupción momentánea de la corriente del bucle en el puerto FXS y no es posible enviarla como una señal de audio, el router transmite la señal del hookflash a través de un relé de multifrecuencia de tonos duales (DTMF) como el carácter'!'. El router con puerto FXO envía luego una breve interrupción del bucle que es vista por el dispositivo externo como un hookflash. Para transmitir la señal del hookflash de manera adecuada, los pares de marcado VoIP deben ser configurados para dtmf-relay h245-signal.

  3. Los temporizadores de los puertos físicos se deben ajustar para adaptarse a las características del auricular en el puerto FXS y la duración de la interrupción del bucle del hookflash fuera del puerto FXO como se muestra a continuación:

    • El puerto de voz FXS (router RemoteSite) utiliza el comando timing hookflash-in msec donde mseg. es el valor máximo para una interrupción de bucle (en milisegundos) desde el auricular del teléfono que se interpreta como hookflash. Una interrupción de bucle mayor al valor configurado se considera desconexión y se desconecta la llamada. Cualquier intervalo inferior a este valor causa que el router envíe el carácter '!' a través del relé DTMF con señal H.245.

    • El puerto de voz FXO (router MainSite) utiliza el comando timing hookflash-out msec donde mseg. es la duración de la interrupción de bucle saliente en milisegundos. Cuando el router recibe una señal de un relé DTMF de señal H.245, el puerto FXO genera una interrupción de bucle en el intervalo configurado.

Diagrama de la red

Este documento utiliza la configuración de red que se muestra en el siguiente diagrama.

pbx_across_ip.gif

Configuraciones

Este documento usa las configuraciones detalladas aquí.

MainSite

MainSite#show run 

Building configuration...



Current configuration : 1121 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname MainSite

!

memory-size iomem 20

ip subnet-zero

!

call rsvp-sync

voice rtp send-recv

!

interface Loopback1

 ip address 205.1.1.1 255.255.255.0

!

interface Serial0

 bandwidth 1500

 ip address 192.168.1.1 255.255.255.252

 no fair-queue

 clockrate 1300000

 ip rtp priority 16384 16383 100

!

router eigrp 1

 network 192.168.1.0

 network 205.1.1.0

 no auto-summary

 no eigrp log-neighbor-changes

!

ip classless

no ip http server

ip pim bidir-enable

!

 puerto de voz 1/0

 temporización de salida de hookflash 500

 !--- El hookflash saliente es 500 msegs. 

 connexión plar opx 200

 !--- Use la opción PLAR OPX en el puerto FXO. 

!

 puerto de voz 1/1

 temporización de salida de hookflash 500

 !--- El hookflash saliente es 500 msegs.

 connexión plar opx 201

 !--- Use la opción PLAR OPX en el puerto FXO..

!

dial-peer voice 100 pots

 destination-pattern 100

 port 1/0

!

dial-peer voice 101 pots

 destination-pattern 101

 port 1/1

!

dial-peer voice 200 voip

 incoming called-number .

 destination-pattern 20.

 session target ipv4:200.1.1.1

 dtmf-relay h245-signal

 !--- señal H.245para transmisión de hookflash.

 ip precedence 5

!

line con 0

line aux 0

line vty 0 4

!

no scheduler allocate

end

Sitio remoto

RemoteSite#show run

Building configuration...



Current configuration : 1096 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname RemoteSite

!

memory-size iomem 25

ip subnet-zero

!

call rsvp-sync

voice rtp send-recv

!

interface Loopback0

 ip address 200.1.1.1 255.255.255.0

!

interface Serial0

 bandwidth 1500

 ip address 192.168.1.2 255.255.255.252

 no fair-queue

 ip rtp priority 16384 16383 100

!

router eigrp 1

 network 192.168.1.0

 network 200.1.1.0

 no auto-summary

 no eigrp log-neighbor-changes

!

ip classless

no ip http server

ip pim bidir-enable

!

!

 puerto de voz 1/0

 temporización de ingreso de hookflash 1000

 !--- Interprete las interrupciones de bucle de hasta 1 segundo. 

 connexión plar 100

 !--- La PLAR proporciona tono de marcado desde una PBX remota. 

!

 puerto de voz 1/1

 temporización de ingreso de hookflash 1000

 !--- Interprete las interrupciones de bucle de hasta 1 segundo.    

 conexión plar 101

 !--- La PLAR proporciona tono de marcado desde la PBX remota..

!

dial-peer voice 100 voip

 incoming called-number .

 destination-pattern 10.

 session target ipv4:205.1.1.1

 dtmf-relay h245-signal

 !--- Use la señal H.245 para la transmisión de hookflash.

 ip precedence 5

!

dial-peer voice 200 pots

 destination-pattern 200

 port 1/0

!

dial-peer voice 201 pots

 destination-pattern 201

 port 1/1

!

!

line con 0

line aux 0

line vty 0 4

!

no scheduler allocate

end

Verificación y resolución de problemas

En esta sección encontrará información que puede utilizar para verificar y solucionar problemas de configuración.

Ciertos comandos show son compatibles con la herramienta intérprete de resultados (solamente clientes registrados) lo cual le permite ver un análisis de resultados de estos comandos show.

Nota: Antes de ejecutar los comandos debug, consulte Información importante sobre comandos de depuración.

  • debug h225 {asn1 | events} - Muestra información adicional acerca de los contenidos reales de los mensajes de Registro, Admisión y Estado (RAS) de H.225.

    asn1

    Indica que sólo se muestran los contenidos ASN 1 de cualquier mensaje H.225 enviado o recibido.

    desactivado

    Indica que se muestran los eventos Q.931 fundamentales que se producen al realizar una llamada H.323 desde una gateway a otra.

El hookflash se transmite como un mensaje H.245 a través de TCP, por lo tanto es posible controlar la señalización utilizando debug h245 asn1 para mostrar los paquetes H.245.

Estos son dos rastreos debug. El primero muestra la recepción del dígito '5' (la señalización de la llamada H.245 transmite el dígito y la duración). El segundo rastreo muestra un hookflash (indicado como '!'). No hay duración para el hookflash. La señal se envía desde el puerto FXO de acuerdo con el valor configurado timing hookflash-out msec.

MainSite#

MainSite#debug h245 asn1

H.245 ASN1 Messages debugging is on

MainSite#

00:52:17: H245 MSC INCOMING ENCODE BUFFER::= 6D 810B66A0 0F9F58AD AF684A00 00

00:52:17:

00:52:17: H245 MSC INCOMING PDU ::=



value MultimediaSystemControlMessage ::= indication : userInput : signal :

    {

      signalType "5"

      !--- El dígito retransmitido es 5. 

      duration 4000

      rtp

      {

        timestamp 2913953866

        logicalChannelNumber 1

      }

    }



00:52:18: H245 MSC INCOMING ENCODE BUFFER::= 6D 82064001 26000000

00:52:18:

00:52:18: H245 MSC INCOMING PDU ::=



value MultimediaSystemControlMessage ::= indication : userInput : signalUpdate :



    {

      duración 295

      !--- La duración del dígito fuera sido de 295 msegs.

      rtp

      {

        logicalChannelNumber 1

      }

    }



MainSite#



!--- Este rastreo del router de destino muestra

!--- que el hookflash se transmitió como un carácter '!'. 

MainSite#

00:52:36: H245 MSC INCOMING ENCODE BUFFER::= 6D 81020420

00:52:36:

00:52:36: H245 MSC INCOMING PDU ::=



value MultimediaSystemControlMessage ::= indication : userInput : signal :

    {

      signalType "!"

     !--- El hookflash se transmite como '!'. 

    }



MainSite#

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 15405