Switching de LAN : Switching the capa 3 y reenvío

Configuración del ruteo de InterVLAN y de la conexión troncal de ISL/802.1Q en switches Catalyst de las series 2900XL/3500XL/2940/2950/2970 mediante un router externo

20 Mayo 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (22 Noviembre 2005) | Comentarios



Contenidos

Introducción
Antes de comenzar
     Convenciones
     Requisitos previos
     Componentes utilizados
     Notas importantes
Configurar
     Diagrama de la red
     Configuraciones
Comandos debug y show
Ejemplo de resultado del comando show
     Switch Catalyst 3500XL
     Router 2600 de Cisco
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

Este documento proporciona configuraciones de muestra para el Enlace entre switches (ISL) y la conexión troncal 802.1Q entre un switch Catalyst 3512-XL y un router Cisco 2600; los resultados de cada comando se muestran a medida que se ejecutan. Cisco 3600 y 4500/4700, u otros routers de la serie 2600 de Cisco, con interfaces FastEthernet, y cualquier Catalyst 2900XL, 3500XL, 2940, 2950 o 2970 pueden utilizarse en los escenarios presentados en este documento para obtener los mismos resultados.

El enlace troncal es una forma de transportar el tráfico de varias VLAN por un enlace punto a punto entre los dos dispositivos. Dos de las formas de implementar los enlaces troncales de Ethernet son:.

  • ISL (protocolo propiedad de Cisco que no es compatible con los switches de las series 2940 y 2950) o

  • Estándar 802.1Q (Instituto de Ingenieros en Electricidad y en Electrónica [IEEE ])

Crearemos una conexión troncal que transportará tráfico de dos VLAN (VLAN1 y VLAN2) a través de un solo enlace entre un Catalyst 3500 y un router Cisco 2600.

Utilizamos el router Cisco 2600 para establecer el enrutamiento Inter VLAN entre VLAN1 y VLAN2. Los switches Catalyst de las series 2900XL/3500XL/2940/2950/2970 son switches de Capa 2 (L2) y no tienen capacidad de enrutamiento ni de comunicación entre las VLAN. Si desea obtener más detalles sobre el enrutamiento Inter VLAN, consulte el capítulo Descripción general de enrutamiento entre LAN virtuales de la Guía de configuración de los servicios de conmutación de IOS® de Cisco, versión 12.1.

Para crear los ejemplos usados en este documento, utilizamos los siguientes switches en un entorno del laboratorio con configuraciones despejadas:

  • Switch Catalyst 3512XL que ejecuta el software IOS de Cisco 12.0(5.x)XU

  • Router Cisco 2621 que ejecuta el IOS de Cisco 12.1(3)T

  • Router Cisco 2621 que ejecuta el IOS de Cisco 12.1(1)T

Las configuraciones en este documento fueron implementadas en un entorno de laboratorio aislado. Asegúrese de comprender el posible efecto de cualquier configuración o comando en su red antes de usarlo . Se borraron las configuraciones de todos los dispositivos con el comando write erase para asegurar que tengan la configuración predeterminada.

Antes de comenzar

Convenciones

Si desea obtener más información sobre las convenciones del documento, consulte las Convenciones de consejos técnicos de Cisco.

Requisitos previos

No hay requisitos previos específicos para este documento.

Componentes utilizados

Este documento no tiene restricciones específicas en cuanto a versiones específicas de software y hardware.

Notas importantes

Para Switches Catalyst 2900XL/3500XL/2940/2950/ 2970:

Los switches Catalyst de las series 2940 y 2950 son compatibles sólo con conexión troncal 802.1q y no soportan conexión troncal ISL.

En un switch Catalyst 2900XL de 4 MB de DRAM, la conexión troncal es compatible sólo con los siguientes módulos con capacidad troncal:

  • WS-X2914-XL-V: módulo de switch de 4 puertos 10/100 ISL/802.1Q

  • WS-X2922-XL-V: módulo de switch de 2 puertos 100BaseFX ISL/802.1Q

  • WS-X2924-XL-V: módulo de switch de 4 puertos 100BaseFX ISL/802.1Q

  • WS-C2924-XL: enlace ascendente 1000BaseX para Catalyst 2900 XL

  • WS-X2932-XL: enlace ascendente 1000BaseT para Catalyst 2900 XL

Consulte la tabla 1 a continuación, para obtener una lista actual de modelos de switches que soportan la conexión de troncal:

Tabla 1

Modelos de switches

Versión mínima requerida para enlace troncal ISL

Versión mínima requerida para IEEE802-1Q Conexión troncal

Versión actual necesaria para la conexión de troncal (ISL/802.1Q)

WS-C2916M-XL (switch de 4 MB)

11.2(8)SA4 (Enterprise Edition)

11.2(8)SA5 (Enterprise Edition)

11.2(8.6)SA6 (Original Edition)

C2912-XL

11.2(8)SA4 (Enterprise Edition)

11.2(8)SA5 (Enterprise Edition)

12.0(5)WC(1) o posterior

C2924-XL

11.2(8)SA4 (Enterprise Edition)

11.2(8)SA5 (Enterprise Edition)

12.0(5)WC(1) o posterior

WS-C2924M-XL

11.2(8)SA4 (Enterprise Edition)

11.2(8)SA5 (Enterprise Edition)

12.0(5)WC(1) o posterior

WS-C2924M-XL

11.2(8)SA4 (Enterprise Edition)

11.2(8)SA5 (Enterprise Edition)

12.0(5)WC(1) o posterior

WS-C2912MF-XL

11.2(8)SA4 (Enterprise Edition)

11.2(8)SA5 (Enterprise Edition)

12.0(5)WC(1) o posterior

WS-C2924M-XL-DC

12.0(5)XU

12.0(5)XU

12.0(5)WC(1) o posterior

WS-C3508G-XL

11.2(8)SA4 (Enterprise Edition)

11.2(8)SA5 (Enterprise Edition)

12.0(5)WC(1) o posterior

WS-C3512-XL

11.2(8)SA4 (Enterprise Edition)

‘11.2(8)SA5 (Original Edition)’

12.0(5)WC(1) o posterior

WS-C3524-XL

11.2(8)SA4 (Enterprise Edition)

11.2(8)SA5 (Enterprise Edition)

12.0(5)WC(1) o posterior

WS-C3548-XL

12.0(5)XP (Enterprise Edition)

12.0(5)XP (Enterprise Edition)

12.0(5)WC(1) o posterior

WS-C3524-PWR-XL

12.0(5)XU

12.0(5)XU

12.0(5)WC(1) o posterior

WS-C2940-8TF

No hay soporte para ISL

12.1(13)AY

12.1(13)WC(1) o posterior para 802.1Q. No hay soporte para ISL.

WS-C2940-8TT

No hay soporte para ISL

12.1(13)AY

12.1(13)WC(1) o posterior para 802.1Q. No hay soporte para ISL.

WS-C2950-12

No hay soporte para ISL

12.0(5)WC(1)

12.0(5)WC(1) o superior para 802.1Q. No hay soporte para ISL.

WS-C2950-24

No hay soporte para ISL

12.0(5)WC(1)

12.0(5)WC(1) o superior para 802.1Q. No hay soporte para ISL.

WS-C2950C-24

No hay soporte para ISL

12.0(5)WC(1)

12.0(5)WC(1) o superior para 802.1Q. No hay soporte para ISL.

WS-C2950T-24

No hay soporte para ISL

12.0(5)WC(1)

12.0(5)WC(1) o superior para 802.1Q. No hay soporte para ISL.

WS-C2950G-12-EI

No hay soporte para ISL

12.0(5)WC(1)

12.0(5)WC(1) o superior para 802.1Q. No hay soporte para ISL.

WS-C2950G-24-EI

No hay soporte para ISL

12.0(5)WC(1)

12.0(5)WC(1) o superior para 802.1Q. No hay soporte para ISL.

WS-C2950G-48-EI

No hay soporte para ISL

12.0(5)WC(1)

12.0(5)WC(1) o superior para 802.1Q. No hay soporte para ISL.

WS-C2950SX-24

No hay soporte para ISL

12.0(5)WC(1)

12.0(5)WC(1) o superior para 802.1Q. No hay soporte para ISL

WS-C2950-24-EI-DC

No hay soporte para ISL

12.0(5)WC(1)

12.0(5)WC(1) o superior para 802.1Q. No hay soporte para ISL

WS-C2955T-12

No hay soporte para ISL

12.1(13)EA1

12.1(13)EA1 o superior para 802.1Q. No hay soporte para ISL

WS-C2955S-12

No hay soporte para ISL

12.1(13)EA1

12.1(13)EA1 o superior para 802.1Q. No hay soporte para ISL

WS-C2955C-12

No hay soporte para ISL

12.1(13)EA1

12.1(13)EA1 o superior para 802.1Q. No hay soporte para ISL

WS-C2970G-24T

12.1(11)AX

12.1(11)AX

12.1(11)AX o posterior

WS-C2970G-24TS

12.1(14)EA1

12.1(14)EA1

12.1(14)EA1 o posterior

Nota: En la tabla anterior, sólo WS-C2916M-XL es un switch con 4 MB de DRAM. El resto de los switches que aparecen en la lista tienen 8 MB de DRAM. Para comprobar si el switch tiene 4 MB u 8 MB de DRAM, introduzca el comando 'show version' en el nivel del usuario. Para obtener más información, consulte la sección Cómo determinar la cantidad de memoria en el switch con la interfaz de la línea de comandos de Actualización del software de switches Catalyst 2900-XL/3500-XL a través de la Interfaz de línea de comandos (CLI).

Nota: En los switches Catalyst 2900XL/3500XL/2940/2950/2970, se puede crear una interfaz VLAN, por ejemplo, int vlan 1, int vlan 2, int vlan x, para cada VLAN configurada en el switch. Sin embargo, sólo puede utilizarse una VLAN como VLAN de administración. Se asigna la dirección IP a la interfaz VLAN de administración solamente. Si se asigna la dirección IP a otra interfaz VLAN cuya VLAN no se utiliza como VLAN de administración, esa interfaz no se activará. Es preferible crear la interfaz VLAN sólo para la VLAN de administración.

Para los routers Cisco 2600:

Para troncales 802.1Q, no se etiqueta una VLAN. Esta VLAN se denomina VLAN nativa. La VLAN nativa se utiliza para el tráfico sin etiquetas cuando el puerto está en modo de concentración de enlaces 802.1Q. Mientras se configuran los troncales 802.1Q, es muy importante tener en cuenta que la VLAN nativa debe configurarse de la misma forma en ambos lados del enlace de troncal. Un error muy común es que no se hagan coincidir las VLAN nativas al configurar la conexión troncal 802.1Q entre el router y el switch. Para obtener más información acerca de las VLAN nativas, consulte la sección IEEE 802.1Q de Conexión en bridge entre redes VLAN IEEE 802.1Q, en Características nuevas de la versión 12.1(3)T.

En esta configuración de ejemplo, VLAN 1 es la VLAN nativa, de forma predeterminada, tanto en el router Cisco 2621 como en el switch Catalyst 3512XL. De acuerdo con las necesidades de su red, es posible que deba usar una VLAN nativa que no sea la VLAN predeterminada. VLAN1. En la sección Configuraciones de este documento se mencionan algunos comandos para cambiar la VLAN nativa en el router Cisco 2600 y en el switch Catalyst 3500XL.

Las configuraciones de ejemplo presentadas en este documento pueden usarse en los routers de las series 2600/3600/4500/4700 de Cisco con interfaces FastEthernet o módulos de red Fast Ethernet. Asegúrese, además, de estar utilizando la versión del IOS de Cisco compatible con la conexión troncal de la VLAN de ISL/802.1Q. Para obtener una lista completa de routers Cisco 2600/3600/4500/4700 compatibles con la conexión troncal de VLAN de ISL/802.1Q y las versiones de software del IOS de Cisco soportadas, consulte la Tabla 2 a continuación.

Tabla 2

Modelos de router

Versión mínima requerida para enlace troncal ISL

Versión mínima requerida para IEEE 802.1Q Conexión troncal

Conjunto mínimo de características requeridas (ISL/802.1Q)

2620 de Cisco

11.3(3a)T

12.0(1)T

IP PLUS / IP PLUS

2621 de Cisco

11.3(3a)T

12.0(1)T

IP PLUS / IP PLUS

2620 de Cisco

12.1(3a)T

12.1(3a)T

IP PLUS / IP PLUS

2650 de Cisco

12.1(3a)T

12.1(3a)T

IP PLUS / IP PLUS

3620 de Cisco

11.3(1)T

12.0(1)T

IP PLUS / IP PLUS

3640 de Cisco

11.3(1)T

12.0(1)T

IP PLUS / IP PLUS

3661 de Cisco

12.0(5)T

12.0(5)T

IP PLUS / IP PLUS

3662 de Cisco

12.0(5)T

12.0(5)T

IP PLUS / IP PLUS

Cisco 4500-M

11.3(1)T

12.0(1)T

IP PLUS / IP PLUS

Cisco 4700-M

11.3(1)T

12.0(1)T

IP PLUS / IP PLUS

Nota: En la Tabla 2 sólo figuran las versiones de actualización/principales mínimas o actuales que son compatibles con esta configuración de ejemplo. Los modelos de router con determinados módulos de red pueden tener distintas versiones mínimas del IOS de Cisco. Para obtener una lista completa del software compatible mínimo requerido para cualquier familia de routers, utilice Software Advisor (solamente clientes registrados) .

Nota: Es posible que la versión compatible mínima no sea la versión recomendada. Para determinar la mejor versión de actualización para su producto Cisco, busque los errores enumerados por componente del producto en Bug Toolkit (solamente clientes registrados) .

Nota: En la Tabla 2 se enumera el conjunto de características mínimas requeridas para realizar el enrutamiento y el enlace troncal Inter-VLAN de IP para que sea compatible con esta configuración de ejemplo. Para obtener una lista completa de otras características compatibles con diferentes versiones del IOS de Cisco y en diferentes plataformas, utilice el Área de Descarga de Software (solamente clientes registrados) .

Configurar

En esta sección, se presenta la información para configurar las características descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, utilice la herramienta de búsqueda de comandos (solamente clientes registrados) .

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

50a.jpg

Configuraciones

Este documento usa las configuraciones detalladas a continuación.

Nota: Los modelos de routers con ciertos módulos de red pueden tener distintas versiones mínimas del IOS de Cisco compatibles con la conexión troncal ISL.

  • Catalyst 3512-XL

  • Router 2600 de Cisco

  • Configuración 802.1Q en el router para las versiones del IOS de Cisco anteriores a 12.1(3)T

Catalyst 3512-XL

Nota: Las siguientes capturas de pantalla muestran los comandos que se introdujeron en el switch 3512XL. Los comentarios entre comandos se agregan en letra azul cursiva para explicar ciertos comandos y pasos.

!-- Establezca el modo privilegiado (
!-- y la contraseña de Telnet en el switch.
switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
switch(config)#hostname 3512xl
3512xl(config)#enable password mysecret
3512xl(config)#line vty 0 4
3512xl(config-line)#login
3512xl(config-line)#password mysecret
3512xl(config-line)#exit
3512xl(config)#no logging console
3512xl(config)#^Z

!-- Establezca la dirección IP y la gateway predeterminada para su manejo.
3512xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3512xl(config)#int vlan 1
3512xl(config-if)#ip address 10.10.10.2 255.255.255.0
3512xl(config-if)#exit
3512xl(config)#ip default-gateway 10.10.10.1
3512xl(config)#end
!-- Establezca el modo VTP.
!--En nuestro ejemplo, hemos establecido el modo en transparente.
!--De acuerdo con su red, configure el modo VTP de manera adecuada.
!-- Para obtener más información acerca de VTP,
!-- consulte
!-- Creación y mantenimiento de VLAN en switches Catalyst 2900XL y 3500XL.
3512xl#vlan database
3512xl(vlan)#vtp transparent
Setting device to VTP TRANSPARENT mode.

!-- Agregando VLAN2. VLAN1 ya existe de forma predeterminada.
3512xl(vlan)#vlan 2
VLAN 2 added:
Name: VLAN0002
3512xl(vlan)#exit
APPLY completed.
Exiting....

!-- Habilite la conexión troncal en la interfaz fastEthernet 0/1.
3512xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3512xl(config)#int fastEthernet 0/1
3512xl(config-if)#switchport mode trunk

!-- Ingrese la encapsulación troncal como isl .
3512xl(config-if)#switchport trunk encapsulation isl
!-- o como dot1q:

3512xl(config-if)#switchport trunk encapsulation dot1q
!-- En el caso de los switches de las series 2940/2950, 
!-- no se utiliza ninguno de los comandos mencionados arriba,
!-- Los switches de las series 2940/2950 sólo soportan encapsulación 802.1q, 
!-- que se configura automáticamente
!-- al habilitarse la conexión troncal en la interfaz mediante el comando 
!-- switchport mode trunk.

!-- En el caso de dot1q, debe asegurarse de que
!-- la VLAN nativa coincida con el enlace.
!-- En 3512XL, por defecto, la VLAN nativa es 1.
!-- De acuerdo con las necesidades de su red, puede cambiar
!-- la VLAN nativa para que no sea VLAN1,
!-- pero es muy importante que cambie la VLAN nativa
!-- en el router de forma acorde.
!-- Si es necesario, puede cambiar la VLAN nativa, usando el siguiente comando:
!-- 3512xl(config-if)#switchport trunk native vlan <vlan ID>

!-- Permita todas las VLAN en el tronco.
3512xl(config-if)#switchport trunk allowed vlan all
3512xl(config-if)#exit

!-- El siguiente conjunto de comandos pondrá FastEthernet 0/2
!-- dentro de VLAN2 y habilitará portfast en la interfaz.
3512xl(config)#int fastEthernet 0/2
3512xl(config-if)#switchport access vlan 2
3512xl(config-if)#spanning-tree portfast
3512xl(config-if)#exit

!-- FastEthernet 0/3 ya está en VLAN1 de forma predeterminada.
!-- Active portfast en la interfaz.
3512xl(config)#int fastEthernet 0/3
3512xl(config-if)#spanning-tree portfast
3512xl(config-if)#^Z
!-- Para obtener detalles sobre por qué habilitar portfast,
!-- consulte
!-- Utilización de PortFast y otros comandos para solucionar retrasos 
!-- al iniciar la conectividad de la estación de trabajo.
!-- Recuerde guardar la configuración.
3512xl#write memory
Building configuration...

3512xl#

--------------------------------------------------------------------------------

3512xl#show running-config
Building configuration...

Current configuration:

!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3512xl
!
no logging console
enable password mysecret
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
switchport mode trunk
!
!-- Si se configura 802.1Q,
!-- verá, en su lugar, el siguiente resultado:
!-- en la interfaz FastEthernet0/1:
!-- interfaz FastEthernet0/1
!-- switchport trunk encapsulation dot1q
!-- switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 2
spanning-tree portfast
!
interface FastEthernet0/3
spanning-tree portfast
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
 ip address 10.10.10.2 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
ip default-gateway 10.10.10.1
!
line con 0
 transport input none
 stopbits 1
line vty 0 4
 password mysecret
 login
line vty 5 15
 login
!
end

Router 2600

Nota: Las siguientes capturas de pantalla muestran los comandos que se introdujeron en el router Cisco 2600. Los comentarios entre comandos se agregan en azul y en cursiva para explicar determinados pasos y comandos.

!-- Establezca el modo privilegiado
!--y la contraseña de Telnet en el router
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname c2600

c2600(config)#enable password mysecret
c2600(config)#line vty 0 4
c2600(config-line)#login
c2600(config-line)#password mysecret
c2600(config-line)#exit
c2600(config)#no logging console
c2600(config)#^Z

c2600#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.

!-- Seleccione FastEthernet 0/0 para la configuración del tronco.
!-- Aquí no se realizan configuraciones de L2 ni de Capa 3 (L3).
c2600(config)#int fastEthernet 0/0
c2600(config-if)#no shut
c2600(config-if)#exit

!-- Active la conexión troncal en la subinterfaz FastEthernet 0/0.1.
!-- Tenga en cuenta que los troncos reales están configurados en las subinterfaces.
c2600(config)#int fastEthernet 0/0.1

!-- Ingrese la encapsulación troncal como isl
c2600(config-subif)#encapsulation isl 1

!-- o como dot1q:
!-- En el caso de dot1q, debe asegurarse de que
!-- la VLAN nativa coincida con el enlace.
!-- En 3512XL, por defecto, la VLAN nativa es 1.
!-- En el router , configure VLAN1 como VLAN nativa.
c2600(config-subif)#encapsulation dot1Q 1 ?
  native  Make this is native vlan
  <cr>
c2600(config-subif)#encapsulation dot1Q 1 native
!-- En el switch, si tiene una VLAN que no es VLAN1,
!-- en el router, configure la misma VLAN como VLAN nativa,
!-- usando el comando de arriba.

Nota: El comando encapsulation dot1Q 1 native fue agregado en la versión 12.1(3)T del IOS de Cisco. Si está usando una versión del IOS de Cisco anterior a la 12.1(3)T, consulte la sección de configuración 802.1Q de versiones del IOS de Cisco anteriores a 12.1(3)T de este documento para configurar el enlace troncal 802.1Q en el router.

!-- Configure la información de L3 en la subinterfaz 0/0.1.
c2600(config-subif)#ip address 10.10.10.1 255.255.255.0
c2600(config-subif)#exit

!-- Active la conexión troncal en la subinterfaz FastEthernet 0/0.2.
!-- Tenga en cuenta que los troncos actuales están configurados en las subinterfaces.
c2600(config)#int fastEthernet 0/0.2

!-- Ingrese la encapsulación troncal como isl
c2600(config-subif)#encapsulation isl 2

!-- o como dot1q:
c2600(config-subif)#encapsulation dot1Q 2

!-- Configure la información de L3 en la subinterfaz 0/0.2.
c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z

!-- Recuerde guardar la configuración.
c2600#write memory
Building configuration...
[OK]
c2600#

Nota: Para que esta configuración funcione y sea posible hacer ping satisfactoriamente entre la estación de trabajo1 y la estación de trabajo2, necesita asegurarse que las gateways predeterminadas en las estaciones de trabajo estén configuradas correctamente. Para la estación de trabajo 1, la gateway predeterminada debe ser 10.10.11.1 y, para la estación de trabajo 2, la gateway predeterminada debe ser 10.10.10.1. Para obtener detalles sobre cómo configurar las gateways predeterminadas en las estaciones de trabajo, consulte las secciones respectivas en este documento.

Nota: El siguiente párrafo se aplica únicamente si se han configurado enlaces troncales 802.1Q entre el router y el switch.

Nota: Si se han seguido los pasos para la configuración enumerados en las: secciones anteriores, y aun no se ha podido hacer ping a través de las VLAN (entre la estación de trabajo1 y la estación de trabajo2), entonces es posible que le ocurra lo indicado en la advertencia CSCds42715, en la que la palabra clave de la VLAN nativa 802.1Q no funciona correctamente cuando la conmutación rápida está habilitada. La corrección del error se incorporó en las siguientes versiones de código: 12.2(0.5), 12.2(0.5)T, 12.1(5)DC, 12.1(5)YB, 12.2(0.18)S, 12.1(5)YD02, 12.2(2)B, 12.2(15)ZN. Puede comprobar el estado y obtener una breve descripción del error usando el Bug Toolkit (solamente clientes registrados) e ingresando el ID de error de funcionamiento CSCds42715.


--------------------------------------------------------------------------------

c2600#show running-config
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2600
!
no logging console
enable password mysecret
!
!
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interfaz FastEthernet0/0.1
 encapsulación isl 1
 dirección IP 10.10.10.1 255.255.255.0
 no ip redirects
!
!-- Si se configura 802.1Q,
!-- Verá, en su lugar, el siguiente resultado:
!-- en la interfaz FastEthernet0/0.1:
!-- interface FastEthernet0/0.1
!--encapsulation dot1Q 1 native
!-- ip address 10.10.10.1 255.255.255.0
!
!
interface FastEthernet0/0.2
 encapsulation isl 2
 ip address 10.10.11.1 255.255.255.0
 no ip redirects
!
!-- Si se configura 802.1Q,
!-- Verá, en su lugar, el siguiente resultado:
!-- en la interfaz FastEthernet0/0.2:
!-- interface FastEthernet0/0.2
!-- encapsulation de dot1Q 2
!-- ip address 10.10.11.1 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password mysecret
 login
!
no scheduler allocate
end

Configuración de 802.1Q en el router para las versiones del IOS de Cisco anteriores a 12.1(3)T

Como se describió anteriormente en este documento, mientras se configura la conexión troncal 802.1Q es importante que la VLAN nativa coincida a través del enlace. En las versiones del software IOS de Cisco anteriores a la versión 12.1(3), no es posible definir la VLAN nativa explícitamente, ya que el comando nativo encapsulation dot1Q 1.de la subinterfaz no está disponible, En las versiones del IOS de Cisco anteriores, es importante no configurar la interfaz de la VLAN nativa como una subinterfaz, que está en nuestra VLAN1 de ejemplo. Si se configura de manera incorrecta, el router esperará una trama con etiqueta dot1q en VLAN1 y el switch no espera una etiqueta en VLAN1. Como resultado, no habrá tráfico entre VLAN1 del switch y el router. En estos casos, ubique siempre la configuración de la VLAN nativa en la interfaz principal y, en el tronco, cree una subinterfaz para todas las demás VLAN.

En la configuración actual del laboratorio, utilice los siguientes pasos para configurar el router 2600 de Cisco:

!-- Establezca el modo privilegiado
!-- y la contraseña de Telnet en el router.
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname c2600
c2600(config)#enable password mysecret
c2600(config)#line vty 0 4
c2600(config-line)#login;
c2600(config-line)#password mysecret
c2600(config-line)#exit
c2600(config)#no logging console
c2600(config)#^Z

c2600#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.

!-- Seleccione FastEthernet 0/0 para la configuración del tronco.
c2600(config)#int fastEthernet 0/0
c2600(config-if)#no shut

!-- Tenga en cuenta que la dirección IP para VLAN 1 se configura en 
!-- la interfaz principal,
!-- y no se producirá ninguna encapsulación para VLAN1 en la subinterfaz.
c2600(config-if)#ip address 10.10.10.1 255.255.255.0
c2600(config-if)#exit

!-- Configure la encapsulación de dot1q para VLAN 2
!-- en la subinterfaz FastEthernet0/0.2:
c2600(config)#int fastEthernet 0/0.2
c2600(config-subif)#encapsulation dot1Q 2
c2600(config-subif)#

!-- Configuración de la información de L3 en la subinterfaz 0/0.2.
c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z

!-- Recuerde guardar la configuración.
c2600#write memory
Building configuration...
[OK]
c2600#

Nota: Para que esta configuración funcione y sea posible hacer ping satisfactoriamente entre la estación de trabajo1 y la estación de trabajo2, necesita asegurarse que las gateways predeterminadas en las estaciones de trabajo estén configuradas correctamente. Para la estación de trabajo 1, la gateway predeterminada debe ser 10.10.11.1 y, para la estación de trabajo 2, la gateway predeterminada debe ser 10.10.10.1. Para obtener detalles sobre cómo configurar las gateways predeterminadas en las estaciones de trabajo, consulte las secciones respectivas en este documento.

c2600#show running-config
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2600
!
no logging console
enable password mysecret
!
!
!
!
!
memory-size iomem 7
ip subnet-zero
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.10.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address 10.10.11.1 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password mysecret
 login
!
no scheduler allocate
end

c2600#

Comandos debug y show

En esta sección encontrará información que puede utilizar para confirmar que su configuración funciona adecuadamente.

Algunos comandos show son soportados por la herramienta intérprete de resultados (solamente clientes registrados) , que le permite ver un análisis del resultado de los show.

En los switches Catalyst 2900XL/3500XL/2940/2950/2970, use los siguientes comandos:

  • show int {FastEthernet | GigabitEthernet} <module/port> switchport

  • show vlan

  • show vtp status

En el router 2600 de Cisco, use los siguientes comandos:

  • show vlan

  • show interface

Ejemplo de resultado del comando show

Switch Catalyst 3500XL

show int {FastEthernet | GigabitEthernet} <module/port> switchport

Este comando se utiliza para verificar el estado administrativo y operacional del puerto. También se usa para garantizar que la VLAN nativa concuerde en ambos lados del tronco. La VLAN nativa se usa para tráfico sin etiquetas cuando el puerto está en modo de concentración de enlaces 802.1Q. Consulte Creación y mantenimiento de VLAN en switches Catalyst 2900XL y 3500XL para obtener detalles sobre las VLAN nativas.

3512xl#show int fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative mode trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none

Nota: Para el enlace troncal 802.1Q el resultado del comando anterior cambia de la siguiente manera:

3512xl#show int fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative mode trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: TODOS
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none

show vlan

Este comando se utiliza para verificar que las interfaces (puertos) pertenezcan a la VLAN correcta. En nuestro ejemplo, solamente la interfaz Fa0/2 pertenece a VLAN2. El resto son miembros de VLAN1.

3512xl#show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6,
                                                Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                Fa0/11, Fa0/12, Gi0/1, Gi0/2
2    VLAN0002                         active    Fa0/2
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

...(resultado suprimido.)

show vtp status

Este comando se utiliza para verificar la configuración del protocolo de concentración de enlaces de la VLAN (VTP) del switch. En nuestro ejemplo, usamos el modo transparente. El modo VTP correcto depende de la topología de su red. Para obtener más información acerca de VTP, consulte Creación y mantenimiento de VLAN en switches Catalyst 2900XL y 3500XL.

3512xl#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 254
Number of existing VLANs        : 6
VTP Operating Mode              : Transparent
VTP Domain Name                 :
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0xC3 0x71 0xF9 0x77 0x2B 0xAC 0x5C 0x97
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

Router 2600 de Cisco

show vlan

Este comando indica qué información de L2 o L3 está configurada para cada VLAN.

c2600#show vlan

Virtual LAN ID: 1 (Inter Switch Link Encapsulation)

   vLAN Trunk Interface:   FastEthernet0/0.1

   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.10.1                  40                  38

Virtual LAN ID:  2 (InterSwitch Link Encapsulation)

   vLAN Trunk Interface:   FastEthernet0/0.2

   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                   9                   9

Nota: Para el enlace troncal 802.1Q el resultado del comando anterior cambia de la siguiente manera:

c2600#show vlan

Virtual LAN ID: 1 (IEEE 802.1Q Encapsulation)

   vLAN Trunk Interface:   FastEthernet0/0.1

Está configurada como VLAN nativa para la(s) siguiente(s) interfaz/interfaces: FastEthernet0/0

   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.10.1                   0                   2

Virtual LAN ID:  2 (IEEE 802.1Q Encapsulation)

   vLAN Trunk Interface:   FastEthernet0/0.2

   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                  42                  19

Nota: Para la conexión troncal 802.1Q en el IOS de Cisco para versiones anteriores a 12.1(3)T el resultado de los comandos cambia de la siguiente manera:

c2600#show vlan

Virtual LAN ID:  2 (IEEE 802.1Q Encapsulation)

   vLAN Trunk Interface:   FastEthernet0/0.2

   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                   6                   4

Nota: No se muestra ninguna encapsulación IEEE 802.1Q para VLAN1 en ninguna de las subinterfaces.

show interface

Este comando se utiliza para verificar el estado administrativo y operacional de la interfaz.

c2600#show interfaces fastEthernet 0/0
FastEthernet0/0 is up, line protocol is up 
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:07, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     217 packets input, 12884 bytes
     Received 217 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     45 packets output, 6211 bytes, 0 underruns(0/0/0)
     0 output errors, 0 collisions, 4 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

c2600#show interfaces fastEthernet 0/0.1
FastEthernet0/0.1 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.10.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ISL Virtual LAN, Color 1.
  ARP type: ARPA, ARP Timeout 04:00:00

c2600#show interfaces fastEthernet 0/0.2
FastEthernet0/0.2 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.11.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ISL Virtual LAN, Color 2.
  ARP type: ARPA, ARP Timeout 04:00:00

Nota: Para el enlace troncal 802.1Q el resultado del comando anterior cambia de la siguiente manera:

c2600#show interfaces fastEthernet 0/0.1
FastEthernet0/0.1 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.10.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1.
  ARP type: ARPA, ARP Timeout 04:00:00

c2600#show interfaces fastEthernet 0/0.2
FastEthernet0/0.2 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.11.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  2.
  ARP type: ARPA, ARP Timeout 04:00:00

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 14976