IP : Servicios de aplicación IP

Distribución de carga con HSRP

19 Mayo 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (10 Agosto 2005) | Comentarios

Contenidos

Introducción
Requisitos previos
     Requisitos
     Componentes utilizados
     Teoría precedente
     Convenciones
Configurar
     Diagrama de la red
     Configuraciones
     Nota importante
Verifique
Resolución de problemas
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

En este documento se proporciona un ejemplo de cómo configurar el protocolo de router de reserva directa (HSRP) con el objetivo de aprovechar los diversos trayectos a un destino determinado.

Requisitos previos

Requisitos

No hay requisitos específicos para este documento.

Componentes utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que se presenta en este documento se originó a partir de dispositivos dentro de un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración despejada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando antes de ejecutarlo.

Teoría precedente

Con frecuencia se utiliza HSRP para mejorar la resistencia en redes, pero esto puede disminuir la eficacia de la red. En el ejemplo de este documento se indican dos trayectos desde la red del host hasta la red del servidor. Por redundancia, HSRP se ejecuta entre R1 y R2 y ambos pueden convertirse en el router activo y "apropiarse" de la dirección IP virtual de HSRP. El otro router se convierte en el router de espera y sólo se convierte en el router activo si el router activo actual deja de funcionar. Para obtener más información acerca de los routers activos y en espera, consulte Cómo utilizar los comandos standby preempt y standby track .

Hemos asignado la dirección de la gateway predeterminada de los hosts como su dirección IP virtual HSRP. Cuando los hosts necesitan enviar paquetes a la red del servidor, los dirigen a su gateway predeterminada o a cualquier router que esté activo. Dado que sólo un router está activo, los paquetes de los hosts a los servidores atraviesan sólo uno de los dos trayectos disponibles.

Nota: Según cómo configure R3, los paquetes que regresen desde los servidores a los hosts podrán utilizar o no ambos trayectos de retorno. Asimismo, los paquetes que regresen de los servidores a los hosts no necesitarán pasar por el router activo.

Para poder utilizar ambos trayectos desde la red del host hasta la red del servidor, puede configurar Multigroup HSRP (MHSRP) entre R1 y R2. Básicamente, R1 se configura con dos grupos HSRP (por ejemplo, el grupo 1 y el grupo 2) y R2 también se configura con los mismos grupos HSRP. Para el grupo 1, R1 es el router activo mientras que R2 es el router en espera. Para el grupo 2, R2 es el router activo mientras que R1 es el router en espera. A continuación, se configura la mitad de las gateways predeterminadas de los hosts con la dirección IP virtual del grupo 1 de HSRP y la otra mitad de las gateways predeterminadas de los hosts con la dirección IP virtual del grupo 2 de HSRP.

Convenciones

Si desea más información sobre convenciones de documentos, consulte las Convenciones sobre consejos técnicos de Cisco.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, use la herramienta de búsqueda de comandos (solamente clientes registrados) .

Diagrama de la red

Este documento utiliza esta configuración de red:

7a.gif

Configuraciones

Este documento usa estas configuraciones:

Configuración del MHSRP del R1

Current configuration:


interface Ethernet0
        ip address 171.16.6.5 255.255.255.0


        standby 1 preempt
        standby 1 ip 171.16.6.100
        standby 1 track Serial0
        standby 2 preempt
        standby 2 ip 171.16.6.200
        standby 2 track serial 0
        standby 2 priority 95

Configuración del MHSRP del R2

Current configuration:


interface Ethernet0
       ip address 171.16.6.6 255.255.255.0
       standby 1 preempt
       standby 1 ip 171.16.6.100
       standby 1 track Serial0
       standby 1 priority 95
       standby 2 preempt
       standby 2 ip 171.16.6.200
       standby 2 track serial 0

Observe en las configuraciones que cuando los dos routers empiezan a ejecutar por primera vez HSRP, R1 tiene una prioridad predeterminada de 100 para el grupo 1 y una prioridad de 95 para el grupo 2. R2 tiene una prioridad predeterminada de 100 para el grupo 2 y una prioridad de 95 para el grupo 1. Por consiguiente, R1 es el router activo del grupo 1 y R2 el router activo del grupo 2. Este ejemplo muestra que puede realizar una distribución de carga con MHSRP. No obstante, deberá utilizar la prioridad HSRP y establecer prioridades para conseguirlo. HSRP no tiene ningún efecto sobre el tráfico de retorno.

Nota importante

Varios controladores Ethernet (Lance y QUICC) en productos de menor capacidad sólo pueden tener una única dirección de control de acceso a medios (MAC) unidifusión en su filtro de direcciones. Estas plataformas sólo soportan un único grupo HSRP y cambian la dirección de interfaz por la dirección MAC virtual del HSRP cuando el grupo pasa a estar activo. La distribución de carga en plataformas con estas limitaciones no es posible con HSRP. El comando use-bia se ha introducido para evitar los problemas que se producen cuando se ejecuta HSRP en productos de baja capacidad, tal como se ha indicado. Por ejemplo, si ejecuta HSRP y DECnet en las mismas interfaces, se producirán problemas, ya que DECnet y HSRP intentarán modificar la dirección MAC. Con el comando use-bia, puede configurar HSRP para utilizar la dirección MAC creada por el proceso DECnet. No obstante, debe tener en cuenta que si utiliza el comando use-bia existen algunos inconvenientes como:

  • Cuando un router se activa, la dirección IP virtual se traslada a una dirección MAC diferente. El nuevo router activo envía una respuesta de protocolo de resolución de dirección (ARP) gratuito, pero no todas las instrumentaciones de host manejan correctamente el ARP gratuito.

  • La configuración de use-bia interrumpe el proxy ARP. Un router en reserva no puede suplir la pérdida de la base de datos del proxy ARP del router activo fallido.

Verifique

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Resolución de problemas

Actualmente, no hay información específica disponible sobre resolución de problemas para esta configuración.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 13781