IP : Servicios de aplicación IP

Cómo utilizar los comandos standby preempt y standby track

23 Marzo 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (10 Agosto 2005) | Comentarios

Contenidos

Introducción
Requisitos previos
     Requisitos
     Componentes utilizados
     Convenciones
Antecedentes
Ejemplos de configuración
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

En este documento se describe cómo funcionan conjuntamente los comandos standby preempt y standby track y cuándo debe utilizarse cada uno de ellos.

El comando standby preempt habilita el Protocolo de ruteo de reserva directa (HSRP) con la prioridad más alta para convertirlo inmediatamente en el router activo. La prioridad se determina primero por el valor de prioridad configurado y después, por la dirección IP. En cada caso, un valor más alto tiene mayor prioridad. Cuando un router de prioridad más alta invalida a un router de prioridad más baja, el router envía un mensaje de golpe. Cuando un router activo de prioridad inferior recibe un mensaje de golpe o un mensaje de saludo desde un router activo de prioridad superior, cambia al estado hablar y envía un mensaje de renuncia.

El comando standby track permite especificar otra interfaz en el router para que el proceso HSRP controle a efectos de modificar la prioridad de HSRP de un grupo determinado. Si se interrumpe el protocolo de línea de la interfaz especificada, se reduce la prioridad de HSRP. Esto significa que otro router HSRP con mayor prioridad puede convertirse en router activo si tiene standby preempt habilitado.

Requisitos previos

Requisitos

No hay requisitos específicos para este documento.

Componentes utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware:

  • Software Cisco IOS® versión 12.2(10b)

  • Routers Cisco 2503

La información que contiene este documento se creó a partir de dispositivos en un entorno de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración despejada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones sobre consejos técnicos de Cisco para obtener más información sobre convenciones del documento.

Antecedentes

Este diagrama muestra un ejemplo en el que se utiliza el comando standby preempt junto con el comando standby track.

6a.gif

Ejemplos de configuración

En el diagrama de red, HSRP está configurado de la siguiente manera:

  • R1 es el router activo y hace el seguimiento del estado de la interfaz serial 0 de R1. Cuando R1 es el router activo, todo el tráfico que va de los hosts (Host 1, 2, 3) a los servidores se direcciona a través de R1.

  • R2 es el router en reserva y hace el seguimiento del estado de la interfaz serial 1 de R2.

  • Si la interfaz serial 0 de R1 se desactiva, la prioridad HSRP de R1 disminuirá en 10, por lo que la prioridad HSRP de R2 será superior a R1 y R2 pasará a ser el router activo. Cuando R2 se convierta en el router activo, todo el tráfico que vaya de los hosts a los servidores se direccionará a través de R2.

Nota: La gateway predeterminada de los hosts 1, 2 y 3 está configurado con la dirección IP virtual de HSRP (en este caso 171.16.6.100). En los routers se ha configurado un protocolo de ruteo como RIP para habilitar la conectividad entre hosts y servidores.

A continuación indicamos la configuración de cada router:

Router 1 (Cisco 2503)

interface Ethernet0
 ip address 171.16.6.5 255.255.255.0

!--- Asigna una dirección IP a la interfaz.

no ip redirects 
standby 1 ip 171.16.6.100

!--- Asigna un grupo de reserva y una dirección IP de reserva

standby 1 priority 105

!--- Asigna una prioridad (en este caso 105) a la interfaz del router (e0)
!--- para un número de grupo determinado (1). El valor predeterminado es 100.

standby 1 preempt

!--- Permite que el router se convierta en el router activo cuando la prioridad 
!--- sea superior a los routers configurados con HSRP restantes del grupo de reserva activo. 
!--- Si no usa el comando standby preempt en la configuración de 
!--- un router, dicho router no se convertirá en el router activo, incluso aunque 
!--- su prioridad sea superior a la de los routers restantes.

 standby 1 track Serial0

!--- Indica que HSRP realiza un seguimiento de la interfaz Serial0. 
!--- La prioridad de la interfaz también se puede configurar e indicar la 
!--- cantidad en que se reducirá la prioridad del router cuando 
!--- la interfaz se desactive. El valor predeterminado es 10.

interface Serial0 ip address 171.16.2.5 255.255.255.0

Router 2 (Cisco 2503)

interface Ethernet0
ip address 171.16.6.6 255.255.255.0


!--- Asigna una dirección IP a la interfaz.

no ip redirects
standby 1 ip

!--- Indica el grupo de reserva activo. Aquí la dirección IP del router virtual 
!--- no está configurada. Consulte la nota posterior a la tabla.

standby 1 preempt

!--- Permite que el router se convierta en el router activo cuando la prioridad 
!--- sea superior a los routers configurados con HSRP restantes en el grupo de reserva activo. 
!--- Si no usa el comando standby preempt en la configuración de 
!--- un router, dicho router no se convertirá en el router activo, incluso aunque 
!--- su prioridad sea superior a la de los routers restantes. 

standby 1 track Serial1

!--- Indica que HSRP hace un seguimiento de la interfaz Serial1. 
!--- La prioridad de la interfaz también se puede configurar e indicar la 
!--- cantidad en que se reducirá la prioridad del router cuando 
!--- la interfaz se desactive. El valor predeterminado es 10.
!--- Tampoco se configura la prioridad, de ahí que se aplique 
!--- el valor 100 de prioridad predeterminada.

interface Serial1
ip address 171.16.7.6 255.255.255.0

Nota: R2 no tiene una dirección IP de reserva configurada. Esto es intencional, tiene como objetivo demostrar que es una configuración válida. Cuando R1 y R2 intercambian saludos HSRP, R2 se informa de la dirección IP de reserva de R1. También es una configuración válida para configurar R2 con una dirección IP de reserva (misma dirección de reserva configurada en R1).

R1# show standby
Ethernet0 - Group 1
Local state is Active, priority 105, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.458
Virtual IP address is 171.16.6.100 configured
Active router is local
Standby router is 171.16.6.6 expires in 8.428
Virtual mac address is 0000.0c07.ac01
2 state changes, last state change 02:09:49
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface    Decrement  State
Serial0         10      Up

R2# show standby
Ethernet0 - Group 1
Local state is Standby, priority 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.814
Virtual IP address is 171.16.6.100
Active router is 171.16.6.5, priority 105 expires in 9.896
Standby router is local
3 state changes, last state change 00:10:21
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface   Decrement  State
Serial1        10      Up

Aunque R2 no tiene una prioridad HSRP configurada, el resultado muestra la prioridad de R2 como el valor 100 predeterminado de HSRP. El resultado de ambos routers indica que los routers realizan un seguimiento del estado de serial 0. El estado de R1 es de activo, mientras que el de R2 es de reserva. Por último, ambos routers se configuran con el comando standby preempt.

¿Qué ocurre si la interfaz serial 0 de R1 se desactiva? El resultado del comando show standby es el que se indica a continuación:

R1# show standby
Ethernet0 - Group 1
Local state is Standby, priority 95 (confgd 105), may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 2.670
Virtual IP address is 171.16.6.100 configured
Active router is 171.16.6.6, priority 100 expires in 8.596
Standby router is local
4 state changes, last state change 00:01:45
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 0 up:
Interface    Decrement  State
Serial0         10      Down   

R2# show standby
Ethernet0 - Group 1
Local state is Active, priority 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 0.810
Virtual IP address is 171.16.6.100
Active router is local
Standby router is 171.16.6.5 expires in 9.028
Virtual mac address is 0000.0c07.ac01
4 state changes, last state change 00:01:38
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface   Decrement  State
Serial1        10      Up

Observe en el resultado que la prioridad HSRP de R1 se ha reducido en 10 hasta 95. Este cambio hace que la prioridad de R2 sea superior y pase a 100. Dado que R2 se configuró para standby preempt en el momento en que la prioridad R2 aumente, R2 se convierte en el router activo y R1 se queda en espera. Ahora bien, si la interfaz serial 0 de R1 vuelve a activarse, la prioridad de R1 volverá a ser 105. En dicho caso, R1 tendrá prioridad y volverá a ser el router activo HSRP.

Nota: Si standby preempt no estuviera configurado en R2, este router no hubiera enviado un mensaje de golpe a R1 que hace que R2 se active. En vez de ello, R1 hubiera seguido siendo el router activo.

Tomemos por ejemplo la configuración siguiente:

standby priority 120
standby track serial 0
standby track serial 1

Se ha configurado una prioridad HSRP de 120 con el comando standby priority y HSRP está configurado para realizar el seguimiento del estado de dos interfaces, Serial0 y Serial 1. Dado que no se ha especificado ningún valor de disminución en el comando standby track, se disminuye la prioridad HSRP según el valor predeterminado de 10 cuando se desactiva la interfaz de la que se hace el seguimiento. Al principio, ambas interfaces están activadas y la prioridad HSRP de la interfaz es de 120, como se indica en el resultado del comando show standby:

R1# show standby
Ethernet0 - Group 1
  Local state is Active, prioridad 120, may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 1.034
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:00:04
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 2 up:
    Interface                  Decrement  State
    Serial0                       10      Up
    Serial1                       10      Up

R1#

Ahora se desactiva la interfaz Serial 0.

R1#1w0d: %LINK-3-UPDOWN: Interface Serial0, changed state to down
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
R1#

Esto reduce en 10 la prioridad HSRP, que pasa de 120 a 110. Puede utilizar el comando show standby para verificarlo:

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 110 (confgd 120), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 2.544
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:00:48
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 1 up:
    Interface                  Decrement  State
    Serial0                       10      Down  (line protocol down)
    Serial1                       10      Up
R1#

A continuación, la segunda interfaz a la que se realiza seguimiento (Serial 1) se desactiva:

R1#1w0d: %LINK-3-UPDOWN: Interface Serial1, changed state to down
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed state to down
R1#

Esto vuelve a reducir en 10 la prioridad HSRP, que pasa de 110 a 100. Puede utilizar el comando show standby para verificarlo:

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 100 (confgd 120), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 1.846
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:01:06
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 0 up:
    Interface                  Decrement  State
    Serial0                       10      Down  (line protocol down)
    Serial1                       10      Down  (line protocol down)
R1#

Cuando se desactiva una de las interfaces serie cuyo seguimiento se realiza (serial 0 o serial 1), la prioridad resultante es de 110. Cuando ambas interfaces serie (serial 0 y serial 1) se desactivan, la prioridad obtenida es de 100.

Nota: En algunas de las versiones más antiguas de Cisco IOS, la disminución de prioridad de HSRP no es acumulativa si no se define explícitamente el valor de disminución en el comando standby track. Para obtener más información, consulte el ID de error CSCdp72834 (solamente clientes registrados) .


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 13780