IP : Routing IP

Cómo utilizar HSRP para proporcionar redundancia en una red BGP con varias conexiones

23 Marzo 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (10 Mayo 2006) | Comentarios

Contenidos

Introducción
Requisitos previos
     Requisitos
     Componentes utilizados
     Convenciones
Antecedentes
Configurar
     Diagrama de la red
     Configuraciones
Verificar
     Paquetes que viajan desde la red local hacia el destino
     Paquetes que vienen del destino hacia la red local
Resolución de problemas
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

En este documento se describe cómo proporcionar redundancia en una red de Border Gateway Protocol (BGP) con varias conexiones cuando se tienen dos proveedores de servicio de Internet (ISP) diferentes. En caso de que falle la conectividad hacia un ISP, el tráfico se volverá a enrutar dinámicamente a través del otro ISP con el comando set as-path {tag | prepend as-path-string} de BGP y el Hot Standby Router Protocol (HSRP).

Requisitos previos

Requisitos

Quienes lean este documento deben tener conocimiento de los siguientes temas:

Componentes utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información de este documento se ha creado a partir de dispositivos en un entorno específico de laboratorio. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración despejada (predeterminada). Si la red está en funcionamiento, asegúrese de que comprende el posible efecto de cualquier comando.

Convenciones

Si desea obtener más información sobre las convenciones utilizadas en este documento, consulte las Convenciones de consejos técnicos de Cisco.

Antecedentes

El objetivo de la configuración en este documento es lograr la siguiente política de red.

  • Todo el tráfico saliente que proviene de hosts de la red 192.168.21.0/24 y tiene como destino Internet debe enrutarse a través de R1 al ISP-A. No obstante, si el enlace falla o R1 falla, deberá reenrutarse todo el tráfico saliente a través de R2 al ISP-B (y, a continuación, a Internet) sin intervención manual.

  • Todo el tráfico entrante con destino a un sistema autónomo, AS 100, desde Internet debe enrutarse a través de R1. En caso de que el enlace del ISP-A con R1 falle, el tráfico entrante deberá reenrutarse automáticamente a través del ISP-B a R2.

Estos requisitos se pueden cubrir con dos tecnologías: BGP y HSRP.

El primer objetivo de proporcionar un trayecto saliente completamente redundante puede realizarse con HSRP. Por lo general, los equipos no tienen la capacidad de recopilar e intercambiar información de ruteo. La dirección IP de la gateway predeterminada se configura estáticamente en un equipo y si el router de la gateway se desactiva, el equipo pierde conectividad con todos los dispositivos que no se encuentren en su mismo segmento de red local. Y esto ocurre incluso aunque haya una gateway alternativa. HSRP ha sido diseñado para responder a estas necesidades. Para obtener más información, consulte HSRP Features and Functionality (Características y funciones de HRSP)

El segundo objetivo se puede conseguir con el comando set as-path prepend de BGP, que permite que BGP propague un trayecto de AS más largo (agregando al principio su propio número de AS más de una vez) mediante el enlace de R2 al ISP-B para el prefijo 192.168.21.0/24. Por consiguiente, todo el tráfico cuyo destino sea 192.168.21.0/24 y provenga de fuera del AS 100 tomará el trayecto de AS más corto mediante el enlace del ISP-A a R1. Si el trayecto principal (del ISP-A a R1) falla, todo el tráfico tomará el trayecto del AS más largo (del ISP-B a R2) para llegar a la red 192.168.21.0/24. Para saber más acerca del comando set as-path prepend de BGP, consulte el diagrama de atributos de AS_PATH del documento Casos de estudio de BGP. Para obtener más información acerca de ladistribución de carga en BGP con el comando set as-path prepend, consulte Curso electrónico de BGP - Balance de cargas en BGP(se necesita Flash para ver este curso electrónico).

Configurar

En esta sección, se presenta la información para configurar las características descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, utilice la herramienta de búsqueda de comandos (solamente clientes registrados) .

Diagrama de la red

Este documento utiliza la configuración de red que se muestra aquí:

En este diagrama, el router 1 (R1) y el router 2 (R2) están en AS 100, que cuenta con una conexión entre pares BGP externa (eBGP) con el ISP-A (AS 300) y el ISP-B (AS 400) respectivamente. El router 6 (R6) es una parte de AS 600, que cuenta con conexión entre pares eBGP con ISP-A e ISP-B. R1. R2 tiene conexión entre pares iBGP, necesaria para asegurar un ruteo óptimo. Por ejemplo, si se intenta llegar a trayectos internos de AS 400, R1 no empleará el trayecto más largo por AS 300. En vez de ello, R1 reenviará el tráfico a R2.

R1 y R2 también se configuran para HSRP sobre un segmento Ethernet común. Los hosts que se encuentran en el mismo segmento de Ethernet tienen una ruta predeterminada que apunta a la dirección IP en espera HSRP 192.168.21.10.

hsrp_bgp-01.gif

Configuraciones

R1

Current configuration


hostname R1
!
interface serial 0
ip address 192.168.31.1 255.255.255.0
!
interface Ethernet1
  ip address 192.168.21.1 255.255.255.0
  standby 1 priority 105
  standby 1 preempt delay minimum 60
  standby 1 ip 192.168.21.10
  standby 1 track Serial0


!--- El comando
 standby track serial hace un seguimiento del estado de la 
!--- interfaz Serial0 y desactiva la prioridad del
!--- grupo de espera 1, si la interfaz se desactiva.
!--- El comando
 standby preempt delay minimum 60 se asegura de que
!--- R1 tenga prioridad y retome su posición como router activo. Asimismo, este comando se asegura de que el
!--- router espere 60 segundos antes de realizar esta operación, a fin de dar a BGP el tiempo suficiente
!--- para converger y completar la tabla de ruteo. De esta manera, se evita
!--- enviar tráfico a R1 antes de que éste esté listo para reenviarlo.

!
!
router bgp 100  no synchronization  network 192.168.21.0
  neighbor 192.168.21.2 remote-as 100
  neighbor 192.168.21.2 next-hop-self
  neighbor 192.168.31.3 remote-as 300
  no auto-summary
!

R2

Current configuration:
  hostname  R2
!
interface serial 0
  ip address 192.168.42.2 255.255.255.0
!
interface Ethernet1
   ip address 192.168.21.2 255.255.255.0
   standby 1 priority 100
   standby 1 preempt
   standby 1 ip 192.168.21.10
!
!
  router bgp 100
   no synchronization
   network 192.168.21.0
   neighbor 192.168.21.1 remote-as 100
   neighbor 192.168.21.1 next-hop-self
   neighbor 192.168.42.4 remote-as 400
   neighbor 192.168.42.4 route-map foo out


 !--- Agrega AS 100 a las actualizaciones de BGP enviadas a AS 400
 !--- para que haga la copia de seguridad del trayecto del ISP-A a R1.

 no auto-summary
!
  access-list 1 permit 192.168.21.0
  route-map foo permit 10
   match ip address 1
   set as-path prepend 100

  end

Verificar

En esta sección encontrará información que puede utilizar para confirmar que su configuración funciona adecuadamente.

Determinados comandos show tienen soporte de la herramienta intérprete de resultados (solamente clientes registrados) , que permite ver un análisis de la salida de comandos show.

Cuando se configura una redundancia en una red, debe tener en cuenta dos cosas:

  • La creación de un trayecto redundante para los paquetes que van desde una red local a otra de destino.

  • La creación de un trayecto redundante para los paquetes que regresan de un destino a una red local.

Paquetes que viajan desde la red local hacia el destino

En este ejemplo, la red local es 192.168.21.0/24. Los routers R1 y R2 ejecutan HSRP en el segmento de Ethernet conectado a la interfaz Ethernet1. R1 está configurado como router activo de HSRP con una prioridad de espera de 105 y R2 está configurado con una prioridad de espera de 100. El comando standby 1 track Serial0 (s0) en R1 permite que el proceso HSRP supervise la interfaz. Si el estado de la interfaz se desactiva, la prioridad de HSRP se reducirá. Cuando el protocolo de línea de la interfaz s0 se desactiva, la prioridad de HSRP se reduce a 95 (el valor predeterminado de reducción de la prioridad es de 10). Esto hace que el otro router HSRP, R2, tenga mayor prioridad (una prioridad de 100). R2 se convierte en el router activo de HSRP y atrae el tráfico con destino a la dirección de HSRP activa 192.169.21.10.

Ejecute el comando show standby para ver el router de HSRP activo cuando la interfaz s0 de R1 está activa:

R1#show standby
    Ethernet1 - Group 1
      Local state is Active, priority 105, may preempt
      Hellotime 3 sec, holdtime 10 sec
      Next hello sent in 0.338
      Virtual IP address is 192.168.21.10 configured
      Active router is local
      Standby router is 192.168.21.2 expires in 8.280
      Virtual mac address is 0000.0c07.ac01
      13 state changes, last state change 00:46:10
      IP redundancy name is "hsrp-Et0-1"(default)
      Priority tracking 1 interface, 1 up:
      Interface                    Decrement   State
      Serial0                          10      Up

 R2#show standby
    Ethernet1 - Group 1
     State is Standby
     56 state changes, last state change 00:05:13
     Virtual IP address is 192.168.21.10
     Active virtual MAC address is 0000.0c07.ac01
     Local virtual MAC address is 0000.0c07.ac01 (default)
     Hello time 3 sec, hold time 10 sec
     Next hello sent in 1.964 secs
     Preemption enabled
     Active router is 192.168.21.1, priority 105 (expires in 9.148 sec)
     Standby router is local
     Prioridad 100 (default 100)
     IP redundancy name is "hsrp-Et0-1" (default)

R1#show standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active addr     Standby addr    Group addr
Et1         1   105  P Activo   local           192.168.21.2    192.168.21.10
R1#

R2#show standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active          Standby         Virtual IP
Et1         1   100  P Standby  192.168.21.1    local           192.168.21.10
R2#

El comando show standby muestra a R1 como el router de HSRP activo, debido a que su prioridad (105) es más elevada. Dado que R1 es el router activo, éste es propietario de la dirección IP en espera 192.168.21.10. Todo el tráfico IP desde el host configurado con la gateway predeterminada a 192.168.21.10 se enruta a través de R1.

Si desactiva la interfaz s0 del router R1, el router activo de HSRP cambiará, ya que HSRP en R1 está configurado con el comando standby track serial 0. Cuando el protocolo de la interfaz Serial 0 se desactiva, HSRP reduce la prioridad de R1 en 10 (valor predeterminado) a 95. R1 cambia su estado a "Standby" (Espera). R2 pasa a ser el router activo y, por consiguiente, es el propietario de la dirección IP en espera 192.168.21.10. A consecuencia de ello, todo el tráfico destinado desde hosts en el segmento 192.168.21.0/24 enruta el tráfico a través de R2. El resultado de los comandos debug y show confirma lo mismo.

R1(config)# interface s0
R1(config-if)# shut
  %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Active         -> Speak
  %LINK-5-CHANGED: Interface Serial0, changed state to administratively down
  %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
  %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Speak  -> Standby
  %LINK-3-UPDOWN: Interface Serial0, changed state to down:
  %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Active       -> Speak
  %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
  %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Speak  -> Standby 

Observe que R1 se convierte en un router en espera.

Si R2 pasa a estado activo, verá un resultado similar al siguiente:

R2#
  %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Standby        -> Active 

Si ejecuta el comando show standby en R1 y R2, observe que las prioridades de espera después de la interfaz s0 se reducen en R1:

R1#show standby
Ethernet1 - Group 1
  Local state is Standby, priority 95 (confgd 105), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 0.808
  Virtual IP address is 192.168.21.10 configured
  Active router is 192.168.21.2, priority 100 expires in 9.008
  Standby router is local  15 state changes, last state change 00:00:40
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 1 interface, 0 up:    Interface               Decrement   State
    Serial0                      10     Down  (administratively down)
R1#

R2#show standby
Ethernet1 - Group 1
  State is Active    57 state changes, last state change 00:00:33
  Virtual IP address is 192.168.21.10
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (bia)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.648 secs
  Preemption enabled
  Active router is local
  Standby router is 192.168.21.1, priority 95 (expires in 7.096 sec)
  Priority 100 (default 100)
  IP redundancy name is "hsrp-Et0-1" (default)
R2#

R2#

R1#sh standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active addr     Standby addr    Group addr
Et0         1   95   P Standby  192.168.21.2    local           192.168.21.10
R1#

R2#sh standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active          Standby         Virtual IP
Et0         1   100  P Activo   local           192.168.21.1    192.168.21.10
R2#

Observe que la prioridad de espera de R1 se ha reducido de 105 a 95 y que R2 se ha convertido en el router activo.

Resumen

En caso de que la conectividad entre el ISP-A y R1 falle, HSRP reducirá la prioridad del grupo de espera en R1. R1 pasará de un estado activo a un estado en espera. R2 pasa del estado de reserva al estado activo. La dirección IP de espera 192.168.21.10 pasa a ser activa en R2 y los hosts que envían tráfico a Internet utilizan R2 y el ISP-B, que proporciona un trayecto alternativo para el tráfico saliente.

Para obtener más información acerca del comando standby track de HSRP, consulte Cómo utilizar los comandos standby preempt y standby track .

Paquetes que vienen del destino hacia la red local

Según la política de red definida en la sección Antecedentes, dado que el ISP-A es su trayecto principal y el ISP-B es el trayecto de reserva para el tráfico que va hacia 192.168.21.0/24 (por motivos como una conexión con mayor ancho de banda hacia el ISP-A), puede agregar su propio número de AS en las actualizaciones de BGP anunciadas hacia ISP-B en R2 para que el trayecto de AS a través del ISP-B parezca más largo. Para ello, configure un mapa de la ruta para el vecino de BGP 192.168.42.4. En dicho mapa de ruta, agregue su propio AS con el comando set as-path prepend. Aplique este mapa de ruta a las actualizaciones salientes al vecino 192.168.42.4.

Nota: En producción, debe agregar el número de AS más de una vez para asegurarse de que la ruta anunciada se convierta en la menos preferida.

Esta es la tabla BGP en R6 para la red 192.168.21.0 cuando la conectividad BGP entre R1 y el ISP-A y R2 y el ISP-B está activa:

R6#
show ip bgp 192.168.21.0BGP routing table entry for 192.168.21.0/24, version 30
Paths: (2 available, best #1)
   Advertised to non peer-group peers:     192.168.64.4
   300 100
     192.168.63.3 from 192.168.63.3 (10.5.5.5)
       Origin IGP, localpref 100, valid, external, best, ref 2
   400 100 100     192.168.64.4 from 192.168.64.4 (192.168.64.4)
       Origin IGP, localpref 100, valid, external

BGP selecciona el mejor trayecto como AS {300 100} mediante el ISP-A ya que tiene una longitud de trayecto AS más pequeña en comparación con el trayecto AS {400 100 100 } del ISP-B. La longitud de trayecto de AS es más larga desde el ISP-B debido a la configuración de adición del trayecto AS en R2.

Cuando la conectividad entre R1 y el ISP-A se interrumpe, R6 tiene que elegir el trayecto alternativo a través del ISP-B para llegar a la red 192.168.21.0/24 en AS 100:

R1(config)#interface s0
R1(config-if)#shut 
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down 

Esta es la tabla BGP en R6 para la red 192.168.21.0/24:

R6#
show ip bgp 192.168.21.0 BGP routing table entry for 192.168.21.0/24, version 31 
Paths: (1 available, best #1)
    Advertised to non peer-group peers:
     192.168.63.3   
	400 100 100   
	  192.168.64.4 from 192.168.64.4 (192.168.64.4)   
    Origin IGP, localpref 100, valid, external, best

Para obtener más información acerca de las configuraciones BGP en una red de varias conexiones, consulte Ejemplo de configuración de BGP con dos proveedores de servicio diferentes (conexiones múltiples).

Resolución de problemas

Actualmente, no hay información específica disponible sobre solución de problemas para esta configuración.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 13768