IP : Routing IP

Distribución de carga con BGP en entornos simples o multihomed (con varias conexiones). Configuraciones de ejemplo

23 Marzo 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (23 Agosto 2005) | Comentarios

Contenidos

Introducción
Requisitos previos
     Requisitos
     Componentes utilizados
     Convenciones
Distribución de carga con la dirección de loopback como vecino de BGP.
     Diagrama de la red
     Configuraciones
     Verificar
     Resolución de problemas
Distribución de carga con dos conexiones a un proveedor de servicio de Internet (ISP) mediante un único router local
     Diagrama de la red
     Configuraciones
     Verificar
     Resolución de problemas
Distribución de carga cuando hay dos conexiones a un ISP a través de varios routers locales.
     Diagrama de la red
     Configuraciones
     Verificar
     Resolución de problemas
Distribución de carga desde varias conexiones a dos ISP a través de un único router local.
     Diagrama de la red
     Configuraciones
     Verificar
     Resolución de problemas
Distribución de carga cuando hay varias conexiones a dos ISP a través de varios routers locales.
     Diagrama de la red
     Configuraciones
     Verificar
     Resolución de problemas
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

La distribución de carga permite que un router distribuya el tráfico entrante y saliente entre varios trayectos. Los trayectos se derivan estáticamente o con los protocolos dinámicos:

  • Routing Information Protocol (RIP)

  • Protocolo de ruteo de gateway interior mejorado (EIGRP)

  • Protocolo Open Shortest Path First (OSPF)

  • Protocolo de ruteo de gateway interior (IGRP)

De forma predeterminada, el Border Gateway Protocol (BGP) selecciona un único mejor trayecto y no realiza balance de carga. En este documento se muestra cómo efectuar una distribución de carga en diferentes situaciones utilizando BGP. Para obtener información adicional acerca del balance de carga, consulte ¿Cómo funciona el balance de carga?.

Requisitos previos

Requisitos

Asegúrese de que cumple con los siguientes requisitos antes de utilizar esta configuración.

Componentes utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información de este documento se ha creado a partir de dispositivos en un entorno específico de laboratorio. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración despejada (predeterminada). Si la red está en funcionamiento, asegúrese de que comprende el posible efecto de cualquier comando.

Convenciones

Consulte Convenciones de consejos técnicos de Cisco para obtener más información sobre las convenciones de este documento.

Distribución de carga con la dirección de loopback como vecino de BGP.

En este ejemplo, se muestra cómo conseguir una distribución de carga cuando hay varios enlaces de igual costo (hasta un máximo de seis). Los enlaces se terminan en un router en un sistema autónomo (AS) local y en otro router en un AS remoto de un entorno BGP sencillo. El Diagrama de red sirve de ejemplo.

Nota: Use la herramienta de Búsqueda de comandos (solamente clientes registrados) para obtener más información acerca de los comandos utilizados en este documento.

Diagrama de la red

Esta sección utiliza esta configuración de red:

40a.gif

Configuraciones

Esta sección usa estas configuraciones:

RouterA

interface loopback 0
 ip address 1.1.1.1 255.255.255.0


interface serial 0
 ip address 160.20.20.1
 255.255.255.0 no ip route-cache


interface serial 1
 ip address 150.10.10.1 255.255.255.0
 no ip route-cache


router bgp 11
neighbor 2.2.2.2 remote-as 10
neighbor 2.2.2.2 update-source loopback 0

!--- Utilice la dirección IP de la interfaz de loopback para las conexiones TCP.

neighbor 2.2.2.2 ebgp-multihop

!--- Tiene que configurar ebgp-multihop siempre que las conexiones de BGP externas (eBGP)
!--- no se encuentren en la misma dirección de red.

router eigrp 12
network 1.0.0.0
network 150.10.0.0
network 160.20.0.0
no auto-summary

RouterB

interface loopback 0
 ip address 2.2.2.2 255.255.255.0


interface serial 0
 ip address 160.20.20.2 255.255.255.0
 no ip route-cache
interface serial 1 ip address 150.10.10.2 255.255.255.0
 no ip route-cache


router bgp 10
neighbor 1.1.1.1 remote-as 11

neighbor 1.1.1.1 update-source loopback 0
!--- Utilice la dirección IP de la interfaz de loopback para las conexiones TCP.

neighbor 1.1.1.1 ebgp-multihop

!--- Tiene que configurar ebgp-multihop siempre que las conexiones eBGP
!--- no se encuentren en la misma dirección de red.

router eigrp 12
network 2.0.0.0
network 150.10.0.0
network 160.20.0.0
no auto-summary

Nota: Puede utilizar rutas estáticas en vez de un protocolo de ruteo para introducir dos trayectos de igual costo para llegar al destino. En este caso, el protocolo de ruteo es EIGRP.

Verificar

Utilice esta sección para confirmar que su configuración funcione correctamente.

La herramienta intérprete de resultados (solamente clientes registrados) (OIT) soporta algunos comandos show. Utilice la OIT para ver un análisis de los resultados del comando show.

El resultado del comando show ip route muestra que los dos trayectos a la red 2.2.2.0 se aprenden a través de EIGRP. El resultado del comando traceroute indica que la carga se distribuye entre dos enlaces serie. En este caso, la distribución de carga se produce paquete por paquete. Puede ejecutar el comando ip route-cache en las interfaces serie para que la distribución de carga se efectúe según el destino. También puede configurar el balance de carga por paquete y por destino con Cisco Express Forwarding. Para obtener más información sobre cómo configurar Cisco Express Forwarding, consulte Configuring Cisco Express Forwarding (Configuración de Cisco Express Forwarding)

RouterA# show ip route
!--- Resultado suprimido.
Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     2.0.0.0/24 is subnetted, 1 subnets
D       2.2.2.0 [90/2297856] via 150.10.10.2, 00:00:45, Serial1
                [90/2297856] via 160.20.20.2, 00:00:45, Serial0
     160.20.0.0/24 is subnetted, 1 subnets
C       160.20.20.0 is directly connected, Serial0
     150.10.0.0/24 is subnetted, 1 subnets
C       150.10.10.0 is directly connected, Serial1

RouterA# traceroute 2.2.2.2
Type escape sequence to abort.
Tracing the route to 2.2.2.2

1 160.20.20.2 16 msec
    150.10.10.2 8 msec *

Resolución de problemas

Actualmente, no hay información específica disponible sobre solución de problemas para esta configuración.

Distribución de carga con dos conexiones a un proveedor de servicio de Internet (ISP) mediante un único router local

En este ejemplo, se muestra cómo conseguir una distribución de carga cuando hay varios enlaces entre un AS remoto y un AS local. Dichos enlaces se terminan en un router en el AS local y en varios routers de AS remotos en un entorno BGP puro. El diagrama de red es un ejemplo de este tipo de red.

Esta configuración de ejemplo, utiliza el comando maximum-paths . De forma predeterminada, BGP elige el mejor trayecto entre los trayectos de igual costo posibles que se obtienen en un AS. No obstante, se puede cambiar el número máximo de trayectos de costo igual paralelos permitidos. Para efectuar este cambio, incluya el maximum-paths comando paths en la configuración de BGP. Utilice un número comprendido entre 1 y 6 para el argumento paths .

Diagrama de la red

Esta sección utiliza esta configuración de red:

40b.gif

Configuraciones

Esta sección usa estas configuraciones:

RouterA

interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Serial 0
 ip address 160.20.20.1 255.255.255.0
!
!
interface Serial 1
 ip address 150.10.10.1 255.255.255.0
!
!
router bgp 11
neighbor 160.20.20.2 remote-as 10
neighbor 150.10.10.2 remote-as 10
network 1.0.0.0maximum-paths 2


!--- Este comando especifica el número máximo de trayectos
!--- que deben instalarse en la tabla de ruteo para el destino específico.

RouterB

interface Ethernet0
 ip address 2.2.2.1 255.255.255.0
!interface Serial 0 ip address 160.20.20.2 255.255.255.0
!
!
router bgp 10
neighbor 160.20.20.1 remote-as 11
network 2.0.0.0auto-summary

RouterC

interface Ethernet0
 ip address 2.2.2.2 255.255.255.0
!
interface Serial 1
 ip address 150.10.10.2 255.255.255.0
!
!
router bgp 10
neighbor 150.10.10.1 remote-as 11
network 2.0.0.0
auto-summary

Verificar

Utilice esta sección para confirmar que su configuración funcione de manera adecuada.

La herramienta intérprete de resultados (solamente clientes registrados) (OIT) soporta algunos comandos show. Utilice la OIT para ver un análisis de los resultados del comando show.

El resultado del comando show ip route muestra que los dos trayectos a la red 2.2.2.0 se aprenden a través de BGP. El resultado del comando traceroute indica que la carga se distribuye entre dos enlaces serie. En este caso, la distribución de carga se produce paquete por destino. El comando show ip bgp da las entradas válidas para la red 2.0.0.0 .

RouterA# show ip route

!--- Resultado suprimido.

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0

B    2.0.0.0/8 [20/0] via 150.10.10.2, 00:04:23
               [20/0] via 160.20.20.2, 00:04:01
     160.20.0.0/24 is subnetted, 1 subnets
C       160.20.20.0 is directly connected, Serial0
     150.10.0.0/24 is subnetted, 1 subnets
C       150.10.10.0 is directly connected, Serial1

RouterA# traceroute 2.2.2.2

Type escape sequence to abort.
Tracing the route to 2.2.2.2

1 160.20.20.2 16 msec
    150.10.10.2 8 msec *

RouterA# show ip bgp

BGP table version is 3, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

Network 	 Next Hop 	     Metric 	LocPrf 	Weight Path
*> 1.0.0.0   0.0.0.0 	        	         0      32768  i
*> 2.0.0.0 	160.20.20.2  0 		            0 	       10 i
*            150.10.10.2  0 		         0  	    10 i

Resolución de problemas

Actualmente, no hay información específica disponible sobre solución de problemas para esta configuración.

Distribución de carga cuando hay dos conexiones a un ISP a través de varios routers locales.

En este ejemplo, se muestra cómo conseguir una distribución de carga cuando hay varias conexiones con el mismo ISP mediante varios routers locales. Los dos pares eBGP terminan en dos routers locales diferentes. No se puede realizar un balance de carga en los dos enlaces, ya que BGP elige el mejor trayecto entre las redes que se obtiene de eBGP y de BGP interno (iBGP). La distribución de carga entre los diversos trayectos a AS 10 es la siguiente mejor opción. Con este tipo de distribución de carga, el tráfico a redes específicas basado en políticas definidas previamente, viaja a través de ambos enlaces. Asimismo, cada enlace actúa de respaldo del otro enlace, por si un enlace falla.

Para mayor claridad, supongamos que la política de ruteo de BGP para AS 11 es:

  • AS 11 acepta las rutas locales de AS 10, junto con un valor predeterminado para las rutas de Internet restantes.

  • La política de tráfico saliente es:

    • Todo el tráfico con destino a Internet desde R101 sale a través del enlace R101-R103.

    • Si el enlace R101-R103 falla, todo el tráfico hacia Internet desde R101 pasará por R102 hasta AS 10.

    • De la misma manera, todo el tráfico con destino a Internet desde R102 pasa por el enlace R102-R104.

    • Si el enlace R102-R104 falla, todo el tráfico hacia Internet desde R102 pasará por R101 hasta AS 10.

  • La política de tráfico entrante es:

    • El tráfico destinado a la red 192.168.11.0/24 desde Internet debe provenir del enlace R103-R101.

    • El tráfico destinado a la red 192.168.12.0/24 desde Internet debe provenir del enlace R104-R102

    • Si falla un enlace con AS 10, el otro enlace debe enrutar el tráfico destinado a todas las redes de vuelta hacia AS 11 desde Internet.

Para ello, se anuncia 192.168.11.0 desde R101 hasta R103 con un AS_PATH más corto que el que se anuncia desde R102 hasta R104. AS 10 encuentra el mejor trayecto a través del enlace R103-R101. Asimismo, 192.168.12.0 se anuncia con un trayecto más corto a través del enlace R102-R104. AS 10 prefiere el enlace R104-R102 para el tráfico con destino a 192.168.12.0 en AS 11.

En el caso del tráfico saliente, BGP determina el mejor trayecto sobre la base de las rutas que se obtienen mediante eBGP. Dichas rutas son preferibles a las rutas obtenidas a través de iBGP. Por consiguiente R101 obtiene 10.10.34.0 de R103 a través de eBGP y de R102 a través de iBGP. El trayecto externo se selecciona sobre el trayecto interno. Por consiguiente, si mira la tabla BGP en la configuración de R101, la ruta hacia 10.10.34.0 pasará a través del enlace R101-R103, con el salto siguiente (next hop) en 10.10.13.3. En R102, la ruta hacia 10.10.34.0 pasará por el enlace R102-R104, con el salto siguiente (next hop) en 10.10.24.4. De esta manera se conseguirá distribuir la carga con destino a 10.10.34.0. El mismo razonamiento se puede aplicar a las rutas predeterminadas en R101 y R102. Para obtener más información acerca de los criterios de selección de trayectos BGP, consulte Algoritmo del mejor trayecto BGP.

Diagrama de la red

Esta sección utiliza esta configuración de red:

40c.gif

Configuraciones

Esta sección usa estas configuraciones:

R101

hostname R101


!

interface Ethernet0/0
 ip address 192.168.11.1 255.255.255.0 secondary
 ip address 192.168.12.1 255.255.255.0
!

interface Serial8/0
 ip address 10.10.13.1 255.255.255.0
!
router bgp 11
 no synchronization
 bgp log-neighbor-changes
 network 192.168.11.0
 network 192.168.12.0
 neighbor 10.10.13.3 remote-as 10
 neighbor 10.10.13.3 route-map R101-103-MAP out


!--- AS_PATH se aumenta para 192.168.12.0.

 neighbor 192.168.12.2 remote-as 11
 neighbor 192.168.12.2 next-hop-self
 maximum-paths 2
 no auto-summary
!
access-list 1 permit 192.168.12.0
access-list 2 permit 192.168.11.0
route-map R101-103-MAP permit 10
 match ip address 1
 set as-path prepend 11 11 11
!
route-map R101-103-MAP permit 20
 match ip address 2

R102

hostname R102
!
interface Ethernet0/0
 ip address 192.168.11.2 255.255.255.0 secondary
 ip address 192.168.12.2 255.255.255.0
!
interface Serial8/0
 ip address 10.10.24.2 255.255.255.0
!
router bgp 11
 no synchronization
 bgp log-neighbor-changes
 network 192.168.11.0
 network 192.168.12.0
 neighbor 10.10.24.4 remote-as 10
 neighbor 10.10.24.4 route-map R102-104-MAP out


!--- AS_PATH se aumenta para 192.168.11.0.

 neighbor 192.168.12.1 remote-as 11
 neighbor 192.168.12.1 next-hop-self
 no auto-summary
!
access-list 1 permit 192.168.11.0
access-list 2 permit 192.168.12.0
route-map R102-104-MAP permit 10
 match ip address 1
 set as-path prepend 11 11 11
!
route-map R102-104-MAP permit 20
 match ip address 2
!

R103

hostname R103
!
interface Ethernet0/0
 ip address 10.10.34.3 255.255.255.0
!
interface Serial8/0
 ip address 10.10.13.3 255.255.255.0
!
router bgp 10
no synchronization
 bgp log-neighbor-changes
 network 10.10.34.0 mask 255.255.255.
0 neighbor 10.10.13.1 remote-as 11
 neighbor 10.10.13.1 default-originate
 neighbor 10.10.34.4 remote-as 10
 neighbor 10.10.34.4 next-hop-self
 no auto-summary
 !

R104

hostname R104
!
interface Ethernet0/0
 ip address 10.10.34.4 255.255.255.0
!
interface Serial8/0
 ip address 10.10.24.4 255.255.255.0
!
router bgp 10
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.10.24.2 remote-as 11
 neighbor 10.10.24.2 default-originate
 neighbor 10.10.34.3 remote-as 10
 neighbor 10.10.34.3 next-hop-self
 no auto-summary
!

Verificar

En esta sección encontrará información que puede utilizar para confirmar que su configuración funciona adecuadamente.

Determinados comandos show tienen soporte de la herramienta intérprete de resultados (solamente clientes registrados) , que permite ver un análisis del resultado de los comandos show.

Verificación cuando ambos enlaces entre AS 11 y AS 10 están activados

Verificación de tráfico saliente

Nota: El signo más grande que (>) del resultado del comando show ip bgp representa el mejor trayecto para utilizarlo con esa red entre todos los trayectos posibles. Consulte Algoritmo de selección del mejor trayecto BGP para obtener más información.

La tabla BGP de R101 muestra que el mejor trayecto para todo el tráfico saliente a Internet pasa por el enlace R101-R103. El resultado del comando show ip route confirma las rutas de la tabla de ruteo.

R101# show ip bgp

BGP table version is 5, local router ID is 192.168.12.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
* i0.0.0.0          192.168.12.2                  100      0 10 i
*>                  10.10.13.3                             0 10 i

  !--- Este es el siguiente salto (next hop) de R103.

* i10.10.34.0/24    192.168.12.2                  100      0 10 i
*>                  10.10.13.3               0             0 10 i

  !--- Este es el siguiente salto (next hop) de R103.

* i192.168.11.0     192.168.12.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i192.168.12.0     192.168.12.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i

R101# show ip route

!--- Resultado suprimido.

Gateway of last resort is 10.10.13.3 to network 0.0.0.0
C    192.168.12.0/24 is directly connected, Ethernet0/0
C    192.168.11.0/24 is directly connected, Ethernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.13.0 is directly connected, Serial8/0
B       10.10.34.0 [20/0] via 10.10.13.3, 00:08:53

 !--- Este es el siguiente salto de R103.

B*   0.0.0.0/0 [20/0] via 10.10.13.3, 00:08:53

     !--- Este es el siguiente salto de R103.
He aquí las tablas de ruteo y BGP para R102. Según la política, R102 debe enrutar todo el tráfico a AS 10 a través del enlace R102-R104:
R102# show ip bgp

BGP table version is 7, local router ID is 192.168.12.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 0.0.0.0          10.10.24.4                             0 10 i

   !--- Este es el siguiente salto (next hop) de R104.

* i                 192.168.12.1                  100      0 10 i
*> 10.10.34.0/24    10.10.24.4                             0 10 i

   !--- Este es el siguiente salto (next hop) de R104.

* i                 192.168.12.1             0    100      0 10 i
* i192.168.11.0     192.168.12.1             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i192.168.12.0     192.168.12.1             0    100      0 i
*>                  0.0.0.0                  0         32768 i

R102# show ip route

!--- Resultado suprimido.

Gateway of last resort is 10.10.24.4 to network 0.0.0.0
C    192.168.12.0/24 is directly connected, Ethernet0/0
C    192.168.11.0/24 is directly connected, Ethernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.24.0 is directly connected, Serial8/0
B       10.10.34.0 [20/0] via 10.10.24.4, 00:11:21

!--- Este es el siguiente salto de R104.

B*   0.0.0.0/0 [20/0] via 10.10.24.4, 00:11:21

!--- Este es el siguiente salto de R104.

Verificación del tráfico entrante desde AS 10 a AS 11

las redes 192.168.11.0 y 192.168.12.0 pertenecen a AS 11. De acuerdo con la política, AS 11 debería preferir el enlace R103-R101 para el tráfico con destino a la red 192.168.11.0 y el enlace R104-R102 para el tráfico con destino a la red 192.168.12.0.

R103# show ip bgp

BGP table version is 4, local router ID is 10.10.34.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.10.34.0/24    0.0.0.0                  0         32768 i
*> 192.168.11.0     10.10.13.1               0             0 11 i             

!--- El salto siguiente (next hop) es R101.

*  192.168.12.0     10.10.13.1               0             0 11 11 11 11 i
*>i                 10.10.34.4               0    100      0 11 i             

!--- El salto siguiente (next hop) es R104.

R103# show ip route

!--- Resultado suprimido.

Gateway of last resort is not set
B    192.168.12.0/24 [200/0] via 10.10.34.4, 00:04:46  

!--- El salto siguiente (next hop) es R104.

B    192.168.11.0/24 [20/0] via 10.10.13.1, 00:04:46   

!--- El salto siguiente (next hop) es R101.

     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.13.0 is directly connected, Serial8/0
C       10.10.34.0 is directly connected, Ethernet0/0

El mejor trayecto para la red 192.168.11.0 en R103 pasa por el enlace R103-R101 y el mejor trayecto para la red 192.168.12.0 pasa por R104 a AS 11. En este caso, la longitud más corta de trayecto determina el mejor trayecto.

Asimismo, en R104, BGP y la tabla de ruteo tienen una apariencia similar a la siguiente:

R104# show ip bgp

BGP table version is 13, local router ID is 10.10.34.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i10.10.34.0/24    10.10.34.3               0    100      0 i
*>i192.168.11.0     10.10.34.3               0    100      0 11 i
*                   10.10.24.2               0             0 11 11 11 11 i
*> 192.168.12.0     10.10.24.2               0             0 11 i

R104# show ip route

!--- Resultado suprimido.

Gateway of last resort is not set
B    192.168.12.0/24 [20/0] via 10.10.24.2, 00:49:06    

!--- El salto siguiente (next hop) es R102.

B    192.168.11.0/24 [200/0] via 10.10.34.3, 00:07:36   

!--- El salto siguiente (next hop) es R103.

     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.24.0 is directly connected, Serial8/0
C       10.10.34.0 is directly connected, Ethernet0/0

Verificación cuando falla el enlace R101-R103

Cuando se produce una falla en el enlace R101-R103, todo el tráfico debe enrutarse nuevamente a través de R102. Este diagrama ilustra este cambio:

40d.gif

Cierre el enlace R103-R101 de R103 para simular esta situación.

R103(config)# interface serial 8/0
R103(config-if)# shutdown

*May 1 00:52:33.379: %BGP-5-ADJCHANGE: neighbor 10.10.13.1 Down Interface flap
*May 1 00:52:35.311: %LINK-5-CHANGED: Interface Serial8/0, changed state to
 administratively down
*May 1 00:52:36.127: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial8/0, changed
 state to down

Verificar la ruta de salida a AS 10.

R101# show ip bgp

BGP table version is 17, local router ID is 192.168.12.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete   

Network          Next Hop            Metric LocPrf Weight Path
*>i0.0.0.0          192.168.12.2                  100      0 10 i   
!--- Este es el siguiente salto (next hop) de R102.

*>i10.10.34.0/24    192.168.12.2                  100      0 10 i
!--- Este es el siguiente salto (next hop) de R102.

* i192.168.11.0     192.168.12.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i192.168.12.0     192.168.12.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i

R101# show ip route

!--- Resultado suprimido.

Gateway of last resort is 192.168.12.2 to network 0.0.0.0
C    192.168.12.0/24 is directly connected, Ethernet0/0
C    192.168.11.0/24 is directly connected, Ethernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
B       10.10.34.0 [200/0] via 192.168.12.2, 00:01:34
B*   0.0.0.0/0 [200/0] via 192.168.12.2, 00:01:34      
!--- Todo el tráfico saliente pasa por R102.

R102# show ip route

!--- Resultado suprimido.

Gateway of last resort is 10.10.24.4 to network 0.0.0.0
C    192.168.12.0/24 is directly connected, Ethernet0/0
C    192.168.11.0/24 is directly connected, Ethernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.10.24.0 is directly connected, Serial8/0
B       10.10.34.0 [20/0] via 10.10.24.4, 00:13:22
B*   0.0.0.0/0 [20/0] via 10.10.24.4, 00:55:22         
!--- Todo el tráfico saliente de R102 pasa por R104.

Verifique la ruta de tráfico entrante cuando R101-R103 está inactivo.

R103# show ip bgp

BGP table version is 6, local router ID is 10.10.34.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete   

Network          Next Hop            Metric Loc Prf Weight Path
*> 10.10.34.0/24    0.0.0.0                  0         32768 i
*>i192.168.11.0     10.10.34.4               0    100      0 11 11 11 11 i
*>i192.168.12.0     10.10.34.4               0    100      0 11 i


R103# show ip route

!--- Resultado suprimido.

Gateway of last resort is not set

B    192.168.12.0/24 [200/0] via 10.10.34.4, 00:14:55
!--- El salto siguiente (next hop) es R104.

B    192.168.11.0/24 [200/0] via 10.10.34.4, 00:05:46      
!--- El salto siguiente (next hop) es R104.     

10.0.0.0/24 is subnetted, 1 subnets
C   10.10.34.0 is directly connected, Ethernet0/0

En R104, el tráfico para 192.168.11.0 y 192.168.12.0 pasa por el enlace R104-R102.

R104# show ip route

!--- Resultado suprimido.

Gateway of last resort is not set

B    192.168.12.0/24 [20/0] via 10.10.24.2, 00:58:35    
!--- El salto siguiente (next hop) es R102.

B    192.168.11.0/24 [20/0] via 10.10.24.2, 00:07:57    
!--- El salto siguiente (next hop) es R102.     

10.0.0.0/24 is subnetted, 2 subnets
C       10.10.24.0 is directly connected, Serial8/0
C       10.10.34.0 is directly connected, Ethernet0/0

Resolución de problemas

Actualmente, no hay información específica disponible sobre solución de problemas para esta configuración.

Distribución de carga desde varias conexiones a dos ISP a través de un único router local.

En este caso, el balance de carga no es una opción en un entorno de varias conexiones, por lo que sólo se puede realizar una distribución de carga. El balance de carga no se puede realizar ya que GBP sólo selecciona un único mejor trayecto a un destino entre las rutas de BGP que obtiene de los diversos AS. La idea de fondo consiste en establecer una mejor métrica para las rutas del rango comprendido entre 1.0.0.0 y 128.0.0.0 cuya información se obtiene del ISP(A) y una mejor métrica para el resto de las rutas cuya información se obtiene del ISP(B). El diagrama de red es un ejemplo.

Consulte Ejemplo de configuración de BGP con dos proveedores de servicio diferentes (conexiones múltiples o multihoming) para obtener información adicional.

Diagrama de la red

Esta sección utiliza esta configuración de red:

40e.gif

Configuraciones

Esta sección usa estas configuraciones:

RouterA

interface Serial 0
 ip address 160.20.20.1 255.255.255.0
 no ip route-cache


interface Serial 1
 ip address 150.10.10.1 255.255.255.0
 no ip route-cache


router bgp 11
neighbor 160.20.20.2 remote-as 10
neighbor 160.20.20.2 route-map UPDATES-1 in

!--- Esto permite sólo las redes hasta 128.0.0.0.

neighbor 150.10.10.2 remote-as 12
neighbor 150.10.10.2 route-map UPDATES-2 in

!--- Esto permite todo lo que esté por encima de la red 128.0.0.0.

auto-summary

route-map UPDATES-1 permit 10
match ip address 1
set weight 100

route-map UPDATES-1 permit 20
match ip address 2

route-map UPDATES-2 permit 10
match ip address 1

route-map UPDATES-2 permit 20
match ip address 2
set weight 100

access-list 1 permit 0.0.0.0  127.255.255.255
access-list 2 deny 0.0.0.0 127.255.255.255
access-list 2 permit any

RouterB

interface Loopback0
 ip address 2.2.2.2 255.255.255.0
int loopback 1
 ip address 170.16.6.5 255.255.255.0


interface Serial 0
 ip address 160.20.20.2 255.255.255.0
 no ip route-cache


router bgp 10
neighbor 160.20.20.1 remote-as 11
network 2.0.0.0
network 170.16.0.0
auto-summary

RouterC

interface Loopback0
 ip address 170.16.6.6 255.255.255.0


interface Loopback1
 ip address 2.2.2.1 255.255.255.0


interface Serial 1
 ip address 150.10.10.2 255.255.255.0
 no ip route-cache


router bgp 12n
eighbor 150.10.10.1 remote-as 11
network 2.0.0.0
network 170.16.0.0
auto-summary

Verificar

Utilice esta sección para confirmar que su configuración funcione de manera adecuada.

La herramienta intérprete de resultados (solamente clientes registrados) (OIT) soporta algunos comandos show. Utilice la OIT para ver un análisis de los resultados del comando show.

El resultado del comando show ip route y el resultado del comando traceroute muestran que cualquier red inferior a 128.0.0.0 sale de RouterA a través de 160.20.20.2. Esta ruta es el salto siguiente (next hop) después de la interfaz serial 0. Las redes restantes salen a través de 150.10.10.2, que es el salto siguiente (next hop) después de la interfaz serial 1.

RouterA# show ip route

!--- Resultado suprimido.

Gateway of last resort is not set

B 	170.16.0.0/16 [20/0] via 150.10.10.2, 00:43:43		 !
--- Este es el salto siguiente (next hop) a través de serial 1.

B 	2.0.0.0/8 [20/0] via 160.20.20.2, 00:43:43			 !
--- Este es el salto siguiente (next hop) a través de serial 0.    

160.20.0.0/24 is subnetted, 1 subnetsC 		
160.20.20.0 is directly connected, Serial0    
150.10.0.0/24 is subnetted, 1 subnetsC 	
150.10.10.0 is directly connected, Serial1

RouterA# show ip bgp

BGP table version is 3, local router ID is 160.20.20.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete 
Network Next Hop Metric LocPrf Weight Path   
Network          Next Hop            Metric LocPrf Weight Path
*  2.0.0.0          150.10.10.2              0             0 12 i
*>                  160.20.20.2              0           100 10 i
*  170.16.0.0       160.20.20.2              0             0 10 i
*>                  150.10.10.2              0           100 12 i

RouterA# traceroute  2.2.2.2

Type escape sequence to abort.
Tracing the route to 2.2.2.2

1   160.20.20.2 16 msec * 16 msec

RouterA# traceroute  170.16.6.6

Type escape sequence to abort.
Tracing the route to 170.16.6.6

1   150.10.10.2 4 msec * 4 msec

Resolución de problemas

Actualmente, no hay información específica disponible sobre solución de problemas para esta configuración.

Distribución de carga cuando hay varias conexiones a dos ISP a través de varios routers locales.

El balance de carga no es posible en un entorno con varias conexiones a dos ISP. BGP sólo selecciona el único mejor trayecto a un destino entre los trayectos BGP que se obtienen de los diversos AS, lo que imposibilita el balance de carga. No obstante, se puede efectuar una distribución de carga en este tipo de redes BGP con varias conexiones. Basándose en políticas predeterminadas, el flujo de tráfico se controla con diversos atributos BGP.

En esta sección se trata la configuración de las diversas configuraciones más utilizadas. La configuración muestra cómo conseguir distribuir la carga. Consulte el diagrama de red, en el que las diversas conexiones de AS 100 obtienen fiabilidad y distribución de carga.

Nota: Las direcciones IP de este ejemplo siguen los estándares RFC 1918leavingcisco.com para espacios de dirección privada y no se pueden enrutar en Internet.

Para mayor claridad, supongamos que la política de ruteo de BGP para AS 100 es:

  • AS 100 acepta las rutas locales de ambos proveedores, junto con un valor predeterminado para las rutas de Internet restantes.

  • La política de tráfico saliente es:

    • El tráfico con destino al AS 300 pasa por el enlace R1-ISP(A) .

    • El tráfico con destino al AS 400 pasa por el enlace R2-ISP(B) .

    • Todo el tráfico restante debe preferir la ruta predeterminada 0.0.0.0 a través del enlace R1-ISP(A).

    • Si el enlace R1-ISP(A) falla, todo el tráfico deberá pasar por el enlace R2-ISP(B).

  • La política de tráfico entrante es:

    • El tráfico con destino a la red 10.10.10.0/24 proveniente de Internet debe llegar del enlace ISP(A)-R1.

    • El tráfico con destino a la red 10.10.20.0/24 proveniente de Internet debe llegar del enlace ISP(B)-R2.

    • Si falla un ISP, el otro ISP debería enrutar el tráfico de vuelta de todas las redes a AS 100 desde Internet .

Diagrama de la red

Esta sección utiliza esta configuración de red:

40f.gif

Configuraciones

Esta sección usa estas configuraciones:

R2

interface Ethernet0
 ip address 192.168.21.2 255.255.255.0 
!
interface Serial0
  ip address 192.168.42.2 255.255.255.0
router bgp 100 no synchronization bgp log-neighbor-changes


!--- Las dos líneas siguientes anuncian las redes a pares de BGP.

 network 10.10.10.0 mask 255.255.255.0 network 10.10.20.0 mask 255.255.255.0

!--- La línea siguiente configura iBGP en R1.

  neighbor 192.168.21.1 remote-as 100
  neighbor 192.168.21.1 next-hop-self

!--- La línea siguiente configura eBGP con ISP(B).

 neighbor 192.168.42.4 remote-as 400

!--- Este es el mapa de ruta de la política entrante para la aplicación
!--- de atributos a rutas específicas. 

neighbor 192.168.42.4 route-map AS-400-INCOMING in

!--- Este es el mapa de ruta de la política saliente para la aplicación
!--- de atributos a rutas específicas. 

neighbor 192.168.42.4 route-map AS-400-OUTGOING out no auto-summary
!
!

!--- Esta línea establece la lista de acceso de trayectos del AS.
!--- Esta línea permite todas las rutas del dominio de ruteo del proveedor.

ip as-path access-list 1 permit ^400$
!

!--- Estas dos líneas establecen la lista de acceso.

access-list 10 permit 10.10.10.0 0.0.0.255access-list 20 permit 10.10.20.0 0.0.0.255

!--- Las tres líneas siguientes configurar LOCAL_PREF para rutas
!--- que cumplen la línea de acceso 1 de trayectos del AS.

route-map AS-400-INCOMING permit 10
 match as-path 1
 set local-preference 150

!--- Aquí, el mapa de ruta agrega delante de AS 100 las actualizaciones BGP para las redes
!--- permitidas por la lista de acceso 10.

route-map AS-400-OUTGOING permit 10
 match ip address 10
 set as-path prepend 100

!--- Esta línea anuncia la red permitida por la
!--- lista de acceso 20 sin ningún cambio en los atributos de BGP.

route-map AS-400-OUTGOING permit 20
 match ip address 20

R1

interface Serial0/0
 ip address 192.168.31.1 255.255.255.0
!
interface Ethernet1/0
 ip address 192.168.21.1 255.255.255.0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 10.10.10.0 mask 255.255.255.0 
network 10.10.20.0 mask 255.255.255.0

!--- Conexión entre pares de IBGP en R2

neighbor 192.168.21.2 remote-as 100
neighbor 192.168.21.2 next-hop-self
!

!--- Esta línea establece la conexión entre pares de eBGP en el ISP(A).

neighbor 192.168.31.3 remote-as 300
!

!--- Este es el mapa de ruta de la política entrante para la aplicación
!--- de atributos a rutas específicas.

 neighbor 192.168.31.3
 route-map AS-300-INCOMING in
!

!--- Este es el mapa de ruta de la política saliente para la aplicación
!--- de atributos a rutas específicas.

neighbor 192.168.31.3
 route-map AS-300-OUTGOING out
 no auto-summary

!--- Esta línea establece la lista de acceso de trayectos del AS.
!--- Esta línea permite todas las rutas del dominio de ruteo del proveedor.

ip as-path access-list 1 permit ^300$
!

!--- Estas dos líneas establecen la línea de acceso de IP.

access-list 10 permit 10.10.20.0 0.0.0.255
access-list 20 permit 10.10.10.0 0.0.0.255

!--- Las tres líneas siguientes configuran LOCAL_PREF para rutas que cumplen
!--- la lista de acceso 1 de trayectos del AS.

route-map AS-300-INCOMING permit 10
 match as-path 1
 set local-preference 200
!

!--- Aquí, el mapa de ruta agrega AS 100 delante de las actualizaciones BGP para las redes
!--- permitidas por la lista de acceso 10.

route-map AS-300-OUTGOING permit 10
 match ip address 10
 set as-path prepend 100
!

!--- Esta línea anuncia la red permitida por la
!--- lista de acceso 20 sin ningún cambio en los atributos de BGP.

route-map AS-300-OUTGOING permit 20 match ip address 20
!

Verificar

Utilice esta sección para confirmar que su configuración funcione correctamente.

La herramienta intérprete de resultados (solamente clientes registrados) (OIT) soporta algunos comandos show. Utilice la OIT para ver un análisis de los resultados del comando show.

Ejecute el comando show ip bgp para verificar que la política entrante/saliente funcione.

Nota: El signo más grande que (>) del resultado del comando show ip bgp representa el mejor trayecto para utilizarlo con la red entre todos los trayectos posibles. Consulte Algoritmo de selección del mejor trayecto BGP para obtener más información.

R1# show ip bgp

BGP table version is 6, local router ID is 192.168.31.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

BGP table version is 6, local router ID is 192.168.31.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

Network          Next Hop            Metric LocPrf Weight Path
*> 0.0.0.0          192.168.31.3                  200      0 300 i

!--- Esta línea muestra que se prefiere que la ruta predeterminada 0.0.0.0/0
!--- pase a través del AS 300, ISP(A).

* i10.10.10.0/24    192.168.21.2             0    100      0
 i*>                  0.0.0.0                  0         32768 i
* i10.10.20.0/24    192.168.21.2             0    100      0
 i*>                  0.0.0.0                  0         32768 i
*> 30.30.30.0/24    192.168.31.3             0    200      0 300 i
*>i40.40.40.0/24    192.168.21.2             0    150      0 400 i

!--- Se prefiere que la ruta a la red 30.30.30.0/24 (AS 300)
!--- pase a través del enlace R1-ISP(A).
!--- Se prefiere que la ruta a la red 40.40.40.0/24 (AS 400)
!--- pase a través del enlace R2-ISP(B).

Ahora, estudiemos el resultado de show ip bgp en R2:

R2# show ip bgp

BGP table version is 8, local router ID is 192.168.42.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  0.0.0.0          192.168.42.4                  150      0 400 i
*>i                 192.168.21.1                  200      0 300 i

!--- Esta línea muestra que se prefiere que la ruta predeterminada 0.0.0.0/0
!--- pase a través de AS 300, por el enlace R2-ISP(B).

*> 10.10.10.0/24    0.0.0.0                  0         32768 i
* i                 192.168.21.1             0    100      0 i
*> 10.10.20.0/24    0.0.0.0                  0         32768 i
* i                 192.168.21.1             0    100      0 i
*>i30.30.30.0/24    192.168.21.1             0    200      0 300 i
*> 40.40.40.0/24    192.168.42.4             0    150      0 400 i

!--- Se prefiere que la ruta a la red 30.30.30.0/24 (AS 300)
!--- pase a través del enlace R1-ISP(A).
!--- Se prefiere que la ruta a la red 40.40.40.0/24 (AS 400)
!--- pase a través del enlace R2-ISP(B).

Ejecute el comando show ip bgp en el router 6 para observar la política entrante de las redes 10.10.10.0/24 y 10.10.20.0/24:

R6# show ip bgp

BGP table version is 15, local router ID is 192.168.64.6
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.10.10.0/24    192.168.63.3                           0 300 100 100 i

!--- Esta línea muestra que la red 10.10.10.0/24 se enruta a través del AS 300
!--- con el enlace ISP(A)-R1.

*                   192.168.64.4                           0 400 100 100 100 i
*  10.10.20.0/24    192.168.63.3                           0 300 100 100 i
*>                  192.168.64.4                           0 400 100 i

!--- Esta línea muestra que la red 10.10.20.0/24 se enruta a través del AS 400
!--- por el enlace ISP(B)-R2.

*> 30.30.30.0/24    192.168.63.3             0             0 300 i
*> 40.40.40.0/24    192.168.64.4             0             0 400 i

Cierre el enlace R1-ISP(A) en R1 y observe la tabla BGP. Verá que todo el tráfico a Internet se enrutará a través del enlace R2-ISP(B):

R1(config)# interface serial 0/0
R1(config-if)# shutdown

*May  2 19:00:47.377: %BGP-5-ADJCHANGE: neighbor 192.168.31.3 Down Interface flap
*May  2 19:00:48.277: %LINK-5-CHANGED: Interface Serial0/0, changed state to administratively  down
*May 23 12:00:51.255: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down

R1# show ip bgp

BGP table version is 12, local router ID is 192.168.31.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i0.0.0.0          192.168.21.2                  150      0 400 i

!--- Ahora, el mejor trayecto predeterminado pasa por el enlace R2-ISP(B).

* i10.10.10.0/24    192.168.21.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i10.10.20.0/24    192.168.21.2             0    100      0 i
*>                  0.0.0.0                  0         32768 i
*>i40.40.40.0/24    192.168.21.2             0    150      0 400 i

R2# show ip bgp

BGP table version is 14, local router ID is 192.168.42.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 0.0.0.0          192.168.42.4                  150      0 400 i

!--- Ahora la mejor ruta predeterminada pasa por ISP(B) con una
!--- preferencia local de 150.

* i10.10.10.0/24    192.168.21.1             0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i10.10.20.0/24    192.168.21.1             0    100      0 i
*>                  0.0.0.0                  0         32768 i
*> 40.40.40.0/24    192.168.42.4             0    150      0 400 i

Observe la ruta para la red 10.10.10.0/24 en el router 6:

R6# show ip bgp

BGP table version is 14, local router ID is 192.168.64.6
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.10.10.0/24    192.168.64.4                           0 400 100 100 i

!--- Se puede llegar a la red 10.10.10.0 a través de ISP(B), que anunciaba
!--- la red con el trayecto del AS como prefijo.

*> 10.10.20.0/24    192.168.64.4                           0 400 100 i
*> 30.30.30.0/24    192.168.63.3             0             0 300 i
*> 40.40.40.0/24    192.168.64.4             0             0 400 i

Resolución de problemas

Actualmente, no hay información específica disponible sobre solución de problemas para esta configuración.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 13762