Switching por etiquetas multiprotocolo (MPLS) : MPLS

Configuración de una VPN MPLS básica

19 Mayo 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (16 Noviembre 2007) | Comentarios

Contenidos

Introducción
Requisitos previos
     Requisitos
     Componentes utilizados
     Productos relacionados
     Convenciones
Configurar
     Diagrama de la red
     Procedimientos de configuración
     Configuraciones
Verificar
Resolución de problemas
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

Este documento contiene una configuración de ejemplo de una VPN de conmutación de etiquetas multiprotocolo (MPLS) sobre ATM cuando el Border Gateway Protocol (BGP) o Routing Information Protocol (RIP) está presente en el lado del cliente

Cuando se utiliza con MPLS, la función VPN permite la interconexión transparente entre varios sitios a través de la red de un proveedor de servicio. Una red proveedora de servicios puede ofrecer soporte a varias VPN IP diferentes. Cada una de éstas se presenta a sus usuarios como una red privada, separada de todas las otras redes. Dentro de una VPN, cada sitio puede enviar paquetes IP a cualquier otro sitio dentro de la misma VPN.

Cada VPN está asociada con una o más instancias de reenvío o enrutamiento VPN (VRF). Un VRF consiste en una tabla IP Routing, una tabla derivada de Cisco Express Forwarding (CEF) y un conjunto de interfaces que usen esta tabla de reenvío.

El router mantiene un enrutamiento separado y una tabla CEF para cada VRF. Esto impide que la información se envíe fuera de la VPN y permite que pueda usarse la misma subred en varias VPN sin causar problemas de dirección IP duplicada.

El router que utiliza Multiprotocol BGP (MP-BGP) distribuye la información de enrutamiento VPN utilizando las comunidades extendidas MP-BGP.

Para obtener más información sobre la transmisión de actualizaciones a través de VPN, visite las siguientes URL:

Requisitos previos

Requisitos

No hay requisitos específicos para este documento.

Componentes utilizados

La información que contiene este documento está basada en las versiones de software y hardware mencionadas a continuación.

P y routers PE

  • El software Cisco IOS® versión 12.2(6h) contiene la función MPLS VPN.

  • Cualquier router de Cisco de las series 7200 o posterior soporta la funcionalidad P. El router Cisco 2691, así como cualquier router de las series 3640 o superior soporta la funcionalidad PE.

Routers C y CE

  • Puede usar cualquier router capaz de intercambiar información de enrutamiento con su router PE.

La información que se presenta en este documento se creó a partir de dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración despejada (predeterminada). Si está trabajando en una red activa, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Productos relacionados

Para implementar la función MPLS, es preciso tener un router del tipo Cisco 2600 o superior. Para seleccionar el Cisco IOS necesario con la función MPLS, use Software Advisor (solamente clientes registrados) . Asimismo, compruebe la memoria Flash y la memoria RAM adicionales necesarias para ejecutar la función MPLS en los routers. WIC-1T, WIC-2T y las interfaces en serie pueden utilizarse.

Convenciones

Si desea obtener más información sobre las convenciones del documento, consulte las Convenciones de consejos técnicos de Cisco.

Las letras que aparecen a continuación representan los distintos tipos de routers y switches usados.

  • P: router principal del proveedor.

  • PE: router de borde del proveedor.

  • CE: router de borde del cliente.

  • C: router del cliente

Este diagrama muestra una configuración típica que representan las convenciones indicadas anteriormente.

mplsvpn.gif

Configurar

En esta sección, se presenta la información para configurar las características descritas en este documento.

Nota: Para obtener información adicional sobre los comandos que se utilizan en este documento, utilice la Herramienta de búsqueda de comandos (solamente clientes registrados) .

Diagrama de la red

Este documento utiliza la instalación de red que se muestra en el siguiente diagrama.

new_mpls_vpn_basic1.gif

Procedimientos de configuración

Para obtener más información, consulte Redes privadas virtuales MPLS.

Habilitación de ip cef

Utilice el siguiente procedimiento para habilitar ip cef. Para mejorar el desempeño, utilice ip cef distributed (siempre que sea posible). Complete los siguientes pasos en los PE después de configurar MPLS (configuración de tag-switching ip en las interfaces).

  1. Cree un VRF por cada VPN conectada mediante el comando ip vrf <VPN routing/forwarding instance name>.

    Al hacerlo:

    • Especifique el discriminador de rutas adecuado usado para esa VPN. Se usa para extender la dirección IP de modo que pueda identificar a qué VPN corresponde.

      rd <VPN route distinguisher>
    • Configure las propiedades de importación y exportación para las comunidades ampliadas MP-BGP. Éstas se usan para filtrar el proceso de importación y exportación.

      route-target [export|import|both] <target VPN extended community>
  2. Configure los detalles de reenvío para las respectivas interfaces mediante el comando ip vrf forwarding <VPN routing/forwarding instance name> y no se olvide de configurar la dirección IP después de esta operación.

  3. En función del protocolo de enrutamiento de PE-CE que utilice, podrá configurar rutas estáticas o protocolos de enrutamiento (RIP, Open Shortest Path First (OSPF) o BGP) entre PE y CE. Se encuentran disponibles configuraciones detalladas en la página de soporte de MPLS sobre ATM.

Configuración de MP-BGP

Configure el MP-BGP entre los routers PE. Existen varias formas de configurar BGP, por ejemplo, usando el reflector de ruta o métodos de confederación. El método utilizado aquí (configuración del vecino directo) es el más sencillo y el menos ampliable.

  1. Declare los diferentes vecinos.

  2. Introduzca el comando address-family ipv4 vrf <VPN routing/forwarding instance name> para cada VPN presente en este router PE.

    Realice uno o más de los siguientes pasos, según sea necesario:

    • Vuelva a distribuir la información de enrutamiento estático, RIP u OSPF.

    • Vuelva a distribuir la información de enrutamiento conectada.

    • Active BGP de vecindad con los routers CE.

  3. Entre en el modo address-family vpnv4 y complete los siguientes pasos:

    • Activar los vecinos.

    • Especificar que debe usarse la comunidad extendida. Esto es obligatorio.

Configuraciones

Este documento usa las configuraciones detalladas a continuación.

Pescara

Current configuration:
!
version 12.2
!
hostname Pescara
!
ip cef
!



!--- Customer A commands.

ip vrf Customer_A

!--- Enables the VPN routing and forwarding (VRF) routing table.
!--- This command can be used in global or 
!--- router configuration mode. 

 rd 100:110

!--- Route distinguisher creates routing and forwarding 
!--- tables for a VRF.

 route-target export 100:1000

!--- Creates lists of import and export route-target extended 
!--- communities for the specified VRF.

 route-target import 100:1000
!


!--- Customer B commands.

ip vrf Customer_B
 rd 100:120
 route-target export 100:2000
 route-target import 100:2000
!
interface Loopback0
 ip address 10.10.10.4 255.255.255.255
 ip router isis


!--- Customer A commands.

interface Loopback101
ip vrf forwarding Customer_A

!--- Associates a VRF instance with an interface or subinterface.

 ip address 200.0.4.1 255.255.255.0

!--- Loopback101 and 102 use the same IP address, 200.0.4.1. 
!--- This is allowed because they belong to two 
!--- different customers' VRFs. 

 no ip directed-broadcast
!


!--- Customer B commands.

interface Loopback102
 ip vrf forwarding Customer_B
 ip address 200.0.4.1 255.255.255.0

!--- Loopback101 and 102 use the same IP address, 200.0.4.1. 
!--- This is allowed because they belong to two 
!--- different customers' VRFs.
 
 no ip directed-broadcast
!
interface Serial2/0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no fair-queue
!
interface Serial2/0.1 point-to-point
 description link to Pauillac
 bandwidth 512
 ip address 10.1.1.14 255.255.255.252
 no ip directed-broadcast
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 401   
!
router isis 
 net 49.0001.0000.0000.0004.00
 is-type level-1
!         
router bgp 100
 bgp log-neighbor-changes

!--- Enables logging of BGP neighbor resets.

 neighbor 10.10.10.6 remote-as 100

!--- Adds an entry to the BGP or multiprotocol BGP neighbor table.

 neighbor 10.10.10.6 update-source Loopback0

!--- Enables BGP sessions to use a specific operational 
!--- interface for TCP connections.

!
 

!--- Customer A and B commands.

 address-family vpnv4

!--- To enter address family configuration mode 
!--- for configuring routing sessions, such as BGP, 
!--- that use standard VPN version 4 address prefixes.

 neighbor 10.10.10.6 activate
 neighbor 10.10.10.6 send-community both
 
!--- Sends the community attribute to a BGP neighbor.

 exit-address-family
 !


!--- Customer B commands.

 address-family ipv4 vrf Customer_B

!--- To enter address family configuration mode 
!--- for configuring routing sessions, such as BGP, 
!--- that use standard VPN version 4 address prefixes.

 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !
 

!--- Customer A commands.

 address-family ipv4 vrf Customer_A
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
!
ip classless
!
end

Pesaro

Current configuration:
!
version 12.1
!
hostname Pesaro
!


!--- Customer A commands.

ip vrf Customer_A
 rd 100:110
 route-target export 100:1000
 route-target import 100:1000
!


!--- Customer B commands.

ip vrf Customer_B
 rd 100:120
 route-target export 100:2000
 route-target import 100:2000
!
ip cef

!
interface Loopback0
 ip address 10.10.10.6 255.255.255.255
 ip router isis 


!--- Customer A commands.

interface Loopback101
 ip vrf forwarding Customer_A
 ip address 200.0.6.1 255.255.255.0
!


!--- Customer B commands.

interface Loopback102
 ip vrf forwarding Customer_B
 ip address 200.0.6.1 255.255.255.0
!


!--- Customer A commands.

interface Loopback111
 ip vrf forwarding Customer_A
 ip address 200.1.6.1 255.255.255.0
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 random-detect
!
interface Serial0/0.1 point-to-point
 description link to Pomerol
 bandwidth 512
 ip address 10.1.1.22 255.255.255.252
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 603   
!
router isis 
 net 49.0001.0000.0000.0006.00
 is-type level-1
!
router bgp 100
 neighbor 10.10.10.4 remote-as 100
 neighbor 10.10.10.4 update-source Loopback0
 !


!--- Customer B commands.

 address-family ipv4 vrf Customer_B
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !


!--- Customer A commands.

 address-family ipv4 vrf Customer_A
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !


!--- Customer A and B commands.

 address-family vpnv4
 neighbor 10.10.10.4 activate
 neighbor 10.10.10.4 send-community both
 exit-address-family
!
ip classless
!         
end

Pomerol

Current configuration:
!
version 12.0
!
hostname Pomerol
!
ip cef

!
interface Loopback0
 ip address 10.10.10.3 255.255.255.255
 ip router isis 

!
interface Serial0/1
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 random-detect
!
interface Serial0/1.1 point-to-point
 description link to Pauillac
 ip address 10.1.1.6 255.255.255.252
 no ip directed-broadcast
 ip router isis 
 tag-switching mtu 1520
 tag-switching ip 
 frame-relay interface-dlci 301   
!
interface Serial0/1.2 point-to-point
 description link to Pulligny
 ip address 10.1.1.9 255.255.255.252
 no ip directed-broadcast
 ip router isis 
 tag-switching ip
 frame-relay interface-dlci 303   
!
interface Serial0/1.3 point-to-point
 description link to Pesaro
 ip address 10.1.1.21 255.255.255.252
 no ip directed-broadcast
 ip router isis 
 tag-switching ip

 frame-relay interface-dlci 306   
!
router isis 
 net 49.0001.0000.0000.0003.00
 is-type level-1
!
ip classless
!
end

Pulligny

Current configuration:
!
version 12.1
!
hostname Pulligny
!
!
ip cef

!
!
interface Loopback0
 ip address 10.10.10.2 255.255.255.255
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 random-detect
!
interface Serial0/1.1 point-to-point
 description link to Pauillac
 ip address 10.1.1.2 255.255.255.252
 ip router isis 
 tag-switching ip 
 frame-relay interface-dlci 201   
!
interface Serial0/1.2 point-to-point
 description link to Pomerol
 ip address 10.1.1.10 255.255.255.252
 ip router isis 
 tag-switching ip 
 frame-relay interface-dlci 203   
!
router isis 
 passive-interface Loopback0
 net 49.0001.0000.0000.0002.00
 is-type level-1
!
ip classless
!
end

Pauillac

!
version 12.1
!
hostname pauillac
!
ip cef

!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
 ip router isis  
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 tag-switching ip
 no fair-queue
!
interface Serial0/0.1 point-to-point
 description link to Pomerol
 bandwith 512
 ip address 10.1.1.1 255.255.255.252
 ip router isis 
 tag-switching ip 
 frame-relay interface-dlci 102   
!
interface Serial0/0.2 point-to-point
 description link to Pulligny ip address 10.1.1.5 255.255.255.252

 ip router isis 
 tag-switching ip 
 frame-relay interface-dlci 103   
!
interface Serial0/0.3 point-to-point
 description link to Pescara
 bandwidth 512
 ip address 10.1.1.13 255.255.255.252
 ip router isis 
 tag-switching ip 
 frame-relay interface-dlci 104   
!
router isis 
 net 49.0001.0000.0000.0001.00
 is-type level-1
!
ip classless
!
end

Verificar

En esta sección encontrará información que puede utilizar para confirmar que su configuración funciona adecuadamente.

Algunos comandos show son soportados por la herramienta intérprete de resultados (solamente clientes registrados) , que le permite ver un análisis del resultado del comando show.

  • show ip vrf : verifica que el VRF correcto existe.

  • show ip vrf interfaces : verifica las interfaces activadas.

  • show ip route vrf Customer_A: verifica la información de enrutamiento en los routers PE.

  • traceroute vrf Customer_A 200.0.6.1: verifica la información de enrutamiento en los routers PE.

  • show ip bgp vpnv4 tag : verifica el BGP.

  • show ip cef vrf Customer_A 200.0.6.1 detail : verifica la información de enrutamiento en los routers PE.

Encontrará más información acerca de los comandos en la Guía de solución de problemas de la solución MPLS VPN.

A continuación, mostramos un ejemplo de resultado del comando show ip vrf .

Pescara#show ip vrf 
  Name                             Default RD          Interfaces
  Customer_A                       100:110             Loopback101
  Customer_B                       100:120             Loopback102

A continuación, mostramos un ejemplo de resultado del comando show ip vrf interfaces.

Pesaro#show ip vrf interfaces 
Interface              IP-Address      VRF                              Protocol
Loopback101            200.0.6.1       Customer_A                       up      
Loopback111            200.1.6.1       Customer_A                       up      
Loopback102            200.0.6.1       Customer_B                       up      

El comando show ip route vrf siguiente muestra el mismo prefijo 200.0.6.0/24 en los dos resultados. Esto se debe a que el PE remoto tiene la misma red para dos clientes Customer_A y Customer_B, lo que está permitido en una solución típica de VPN MPLS.

Pescara#show ip route vrf Customer_A
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR

Gateway of last resort is not set

C    200.0.4.0/24 is directly connected, Loopback101
B    200.0.6.0/24 [200/0] via 10.10.10.6, 05:10:11
B    200.1.6.0/24 [200/0] via 10.10.10.6, 04:48:11
 
Pescara#show ip route vrf Customer_B
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
	   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
	   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
	   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
	   * - candidate default, U - per-user static route, o - ODR       
	   P - periodic downloaded static route
	    
Gateway of last resort is not set
C 200.0.4.0/24 is directly connected, Loopback102
 
B 200.0.6.0/24 [200/0] via 10.10.10.6, 00:03:24

Si ejecuta un traceroute entre dos sitios de Customer_A, podrá ver la etiqueta pegada utilizando la red MPLS (si está configurada para ello con mpls ip ttl ...).

Pescara#traceroute vrf Customer_A 200.0.6.1

Type escape sequence to abort.
Tracing the route to 200.0.6.1

  1 10.1.1.13 [MPLS: Labels 20/26 Exp 0] 400 msec 276 msec 264 msec
  2 10.1.1.6 [MPLS: Labels 18/26 Exp 0] 224 msec 460 msec 344 msec
  3 200.0.6.1 108 msec *  100 msec

Nota: Exp 0 es un campo experimental utilizado para Calidad de Servicio (QoS).

Resolución de problemas

Actualmente, no hay información específica disponible sobre la solución de problemas en esta configuración.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 13733