Calidad de servicio (QoS) : QoS Congestion Management (queueing)

Configuración de CBWFQ y LLQ en interfaces del marcador y MLPP

23 Marzo 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (17 Junio 2009) | Comentarios

Contenidos

Introducción
Requisitos previos
     Requisitos
     Componentes utilizados
     Convenciones
Asignación de colas a interfaces con variedad de anchos de banda
CBWFQ y LLQ en interfaces de marcador
LLQ y CBWFQ con MLPPP distribuido
CBWFQ y LLQ con PPPoA y MLPPPoA
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

El comando service-policy suele aplicar una asignación de políticas configurada con los comandos de la CLI de QoS (MQC) modular a una interfaz principal, subinterfaz o circuito virtual. También puede aplicar este comando a una interfaz de plantilla virtual, una interfaz de enlaces múltiples y una interfaz del marcador configuradas con encapsulación de protocolo punto a punto (PPP) y PPP de enlaces múltiples (MLPPP). Dichas interfaces resultan en una interfaz de acceso virtual, donde, funcionalmente, se realiza la colación en cola. Este documento brinda una sola referencia para entender las configuraciones recomendadas y advertencias relacionadas para aplicar la Colocación en cola equilibrada y ponderada en función de la clase (CBWFQ) y la Colocación en cola de tiempo de baja latencia (LLQ) en interfaces de agrupación MLPPP e interfaces del marcador.

Requisitos previos

Requisitos

No hay requisitos previos específicos para este documento.

Componentes utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte las Convenciones sobre consejos técnicos de Cisco.

Asignación de colas a interfaces con variedad de anchos de banda

RFC 1990leavingcisco.com define un PPP de enlaces múltiples, que combina una o más interfaces físicas en una interfaz de "agrupación" virtual. El ancho de banda de la interfaz de agrupación es equivalente a la suma del ancho de banda de los enlaces de componentes. De esta forma, la interfaz de agrupación tiene un valor máximo de ancho de banda que varía en un momento instantáneo.

Originalmente, los comandos bandwidth y priority sólo soportaban un valor Kbps absoluto. Si se aplicaba una política de servicio con CBWFQ y LLQ a una interfaz de agrupación y la primera interfaz activa no soportaba el valor Kbps absoluto, la política de servicio fracasaba en el control de admisión. El enrutador eliminaba la política de servicios e imprimía mensajes de error similares al resultado siguiente:

May 18 17:32:34.766 MEST: CBWFQ: Not enough available bandwidth for all 
classes Available 48 (kbps) Needed 96 (kbps) 
May 18 17:32:34.766 MEST: CBWFQ: Removing service policy on Dialer100

A partir de la versión 12.2T del software Cisco IOS®, el enrutador intenta volver a aplicar la política cuando detecta que se agrega una interfaz adicional (como un Canal BRI B secundario) a la agrupación. Un enfoque superior es configurar los comandos priority y bandwidth como un porcentaje del ancho de banda disponible. El uso de un valor de porcentaje configura el enrutador para que asigne una cantidad relativa de ancho de banda que se ajusta según si la agrupación contiene uno o más enlaces miembro. La versión 12.2(2)T del software Cisco IOS incorporó compatibilidad para el comando priority percentage de los enrutadores y otras plataformas de la serie 7500 de Cisco. Para obtener más información, consulte Low Latency Queuing with Priority Percentage Support (Colocación en cola de tiempo de baja latencia con compatibilidad para porcentaje de prioridad).

CBWFQ y LLQ en interfaces de marcador

El ruteo de marcación a pedido (DDR) puede configurarse de dos modos:

  • DDR heredado: aplica los parámetros de marcado y de protocolo directamente en la interfaz física.

  • Dialer Profiles: aplica los parámetros de marcado y de protocolo dinámicamente en una interfaz del marcador, que a su vez se vincula con interfaces físicas. Por ejemplo, la interfaz del marcador incluye una o varias cadenas de marcado para alcanzar un sitio remoto, tipo de autenticación PPP y MLPPP.

El DDR heredado originalmente soportaba la colocación en cola Primero en entrar, primero en salir (FIFO) sólo cuando una interfaz serial o ISDN se configurada con MLPPP. Esta restricción se aplicaba incluso cuando los dos extremos de la conexión no negociaban el MLPPP y usaban la interfaz física como una interfaz sin agrupación que ejecuta la encapsulación PPP. Ahora se soporta la Colocación en Weighted Fair Queuing tradicional (WFQ) mediante el comando fair-queue.

Si elige configurar los dialer profiles, tanto la interfaz del marcador como las interfaces físicas subyacentes soportan el comando service-policy. Si aplica una política en la interfaz física, utilice el comando show policy-map interface serial o bien el comando show policy-map interface bri 0/0:1 (y bri0/0:2) para confirmar la configuración. El canal D, identificado en IOS como BRI0/0, soporta la señalización pero no el tráfico de datos. Si aplica una política a la interfaz del marcador, utilice el comando show queueing interface dial <0-255> para confirmar la configuración.

Las versiones 12.2(4) y 12.2(4)T del software Cisco IOS incorporaron compatibilidad para las políticas de servicio basadas en la colocación en cola en interfaces de acceso virtual creadas desde una interfaz del marcador configurada con MLPPP. En versiones anteriores, los parámetros de política de servicio no se copian en la interfaz de acceso virtual clonada, donde se lleva a cabo la colocación en cola. Este resultado ilustra estos síntomas:

Router#show policy interface dialer1
  Dialer1 
   Service-policy output: foo 

     Class-map: class-default (match-any) 
       0 packets, 0 bytes 
       5 minute offered rate 0 bps, drop rate 0 bps 
       Match: any 
       Weighted Fair Queueing 
         Flow Based Fair Queueing 
         Maximum Number of Hashed Queues 256 
         (total queued/total drops/no-buffer drops) 0/0/0 

Router#show policy interface virtual-access 2
 Router#

Nota: Se recomiendan las versiones 12.2(8) y 12.2(8)T del software Cisco IOS para evitar el ID de error CSCdu87408 (solamente clientes registrados) de Cisco, que soluciona las recargas de los enrutadores como un efecto secundario poco frecuente de esta configuración.

Esta configuración de ejemplo muestra cómo aplicar CBWFQ y LLQ a una interfaz del marcador. Esta configuración da como resultado:

  • Uso de una interfaz del marcador para aplicar dinámicamente los parámetros del protocolo de la conexión a las interfaces BRI ISDN. Se dice que la interfaz del marcador está "vinculada" a las interfaces BRI ISDN.

  • Colocación de dos interfaces BRI ISDN en una agrupación de enlaces múltiples.

  • Uso del comando dialer load-threshold load [outbound | inbound | either] para determinar si el enrutador necesita activar canales B adicionales y aumentar el ancho de banda de la interfaz de agrupación.

  • Creación de una interfaz de acceso virtual con el comando ppp multilink.

  • Aplicación de una política de servicio con CBWFQ y LLQ a la interfaz de acceso virtual por medio de la interfaz del marcador.

Configuración de muestra:

access-list 101 permit udp any any range 16384 32767
access-list 101 permit tcp any any eq 1720
!
access-list 102 permit tcp any any eq 23
! 
class-map voice
    match access-group 101

!--- El tráfico que coincide con ACL 101 se clasifica como clase de voz.

class-map data
    match access-group 102

!--- El tráfico que coincide con ACL 102 se clasifica como clase de datos.

policy-map mlppp 
   class voice 
      priority percent 50 
   class data 
      bandwidth percent 25 
   class class-default 
     fair-queue 
!
interface BRI2/1  
  no ip address  
  encapsulation ppp  
  dialer pool-member 1  

!--- Miembro de agrupamiento de marcadores 1.

  isdn switch-type basic-net3  
  no cdp enable  
  ppp authentication chap  
! 
interface BRI2/2 
  no ip address  
  encapsulation ppp  
  dialer pool-member 1  


!--- Miembro de agrupamiento de marcadores 1.

  isdn switch-type basic-net3  
  no cdp enable  
  ppp authentication chap  
!  
interface Dialer2  
  ip unnumbered Loopback0  
  encapsulation ppp  
  dialer pool 1  
  dialer load-threshold 1 either  
  
!--- Nivel de carga (en cualquier dirección) para
  !--- el tráfico en el que se añaden conexiones adicionales
  !--- a los valores del nivel de carga de la agrupación
  !--- MPPP que varían del 1 (descargado)
  !--- al 255 (completamente cargado).

  dialer string 6113 
  dialer string 6114  
  dialer-group 1  
  ppp authentication chap  
  ppp multilink  

!--- Permitir MLPPP en los cuatro canales BRI.

  service-policy output mlppp 
  

!--- Aplicar una política de servicio a la interfaz del marcador.

LLQ y CBWFQ con MLPPP distribuido

La serie 7500 de Cisco utiliza una arquitectura distribuida que garantiza una alta velocidad de transmisión de paquetes al trasladar las decisiones de reenvío de paquetes del Procesador de conmutación de ruta (RSP) a los Procesadores de interfaz versátil (VIP). Esta arquitectura también permite el despliegue de servicios IP mejorados en gran escala, como la Calidad de Servicio (QoS), mediante la propagación de la carga de procesamiento a través de varios procesadores independientes de los VIP.

Según el hardware de interfaz, la serie 7500 de Cisco soporta dos formas de QoS:

QoS

Cómo se habilita

Dónde se soporta

Dónde se procesan

Basado en RSP

Automáticamente en procesadores de interfaz heredada

Procesadores de interfaz heredada No se puede habilitar más en VIP.

RSP CPU

Basado en VIP (distribuido)

Automáticamente cuando se configuran estos dos comandos:

VIP

CPU VIP

Los mecanismos QoS basados en VIP que se aplican a través de la CLI de QoS (MQC) modular se introducen en estas tres series de versiones del software Cisco IOS:

  • La versión 12.0(XE) del software Cisco IOS, que se convirtió en la versión 12.1(E) del software Cisco IOS

  • Versión 12.0(9)S del software Cisco IOS

  • La versión 12.1(5)T del software Cisco IOS, que se convirtió en la versión de línea principal 12.2 del software Cisco IOS y la versión 12.2T del software Cisco IOS

La función de MLPP le permite combinar el ancho de banda de múltiples interfaces T1/E1 de un VIP en una interfaz de agrupación. Para obtener más información, consulte Distributed Multilink Point-to-Point Protocol for Cisco 7500 Series Routers (Protocolo punto a punto de enlaces múltiples distribuido para los enrutadores de la serie 7500 de Cisco). La versión 12.2(13)T del software Cisco IOS incorpora compatibilidad para MLPPP distribuido (dMLPPP) en adaptadores de puertos no canalizados, como el PA-4T+ y PA-8T.

La versión 12.2(8)T del software Cisco IOS incorpora compatibilidad para LLQ y CBWFQ distribuido en interfaces de agrupación dMLPPP en adaptadores de puertos canalizados, como PA-MC-xT1/E1 y PA-MC-xT3/E3. Como la versión no distribuida de esta función, dMLPPP usa una interfaz de enlaces múltiples para crear una interfaz de acceso virtual donde, funcionalmente, se lleva a cabo la colocación en cola. Consulte New and Changed Information for Cisco IOS Software Release 12.2T (Información nueva y modificada para la versión 12.2T del software Cisco IOS). Al aplicar el envío a cola distribuido con dMLPPP, se recomienda la versión 12.2(10)T o posterior del software Cisco IOS para evitar un ID de error CSCdw47678 de Cisco.

Sólo CBWFQ y LLQ tal como se aplican con el comando service-policy se soportan con dMLPPP/dLFI. No se soportan las funciones de envío a cola heredada tales como la colocación en cola equilibrada con el comando fair-queue, la colocación en cola prioritaria con el comando priority-group y la colocación en cola personalizada con el comando queue-list.

El FlexWAN para la serie 7600 de Cisco soporta dLLQ en interfaces sin agrupación. No soporta dLLQ en interfaces de agrupamiento MLPPP. Dicha compatibilidad está disponible con la versión 12.2S del software Cisco IOS.

Este ejemplo de configuración corresponde al dLLQ en el enlace múltiple de una interfaz.

Ejemplo de configuración de dLLQ en una interfaz de agrupación MLPPP

Interface 
! 
access-list 100 permit udp any any range 16384 32000
access-list 100 permit tcp any any eq 1720
access-list 101 permit tcp any any eq 80
access-list 102 permit tcp any any eq 23
!
class-map voip 
   match access-group 100
class-map data1
    match access-group 101
class-map data2 
    match access-group 102
!
policy-map llq-policy
    class voip 
     bandwidth 40 
    class data1 
     bandwidth 15 
    class data2 
     bandwidth 15
    class class-default 
     fair-queue
!
policy-map set-policy
    class voip 
     bandwidth 40 
    class data1 
     bandwidth 15
    class data2 
     bandwidth 15 
    class class-default 
     fair-queue
!
interface Serial5/0/0:0 
   no ip address 
   encapsulation ppp 
   keepalive 10 
   ppp chap hostname G2 
   ppp multilink 
   multilink-group 2 
!  
interface Serial5/1/0:0 
  no ip address 
  encapsulation ppp 
  keepalive 10 
  ppp chap hostname G2 
  ppp multilink 
  multilink-group 2 
!  
interface Multilink2 
  ip address 106.0.0.2 255.0.0.0 
  ppp multilink 
  service-policy output llq-policy 
  service-policy input set-policy 
  multilink-group 2

La fragmentación y entrelazado de enlace (LFI) agrega los comandos ppp multilink fragment-delay y ppp multilink interleave a una interfaz de plantilla virtual configurada con MLPPP y una política de servicio. Esta configuración reduce el retraso en los enlaces más lentos separando grandes datagramas y entrelazando los paquetes de tráfico de poco retraso con los paquetes más pequeños generados desde el datagrama fragmentado. Para obtener más información, consulte la sección Configuring Link Fragmentation and Interleaving for Frame Relay and ATM Virtual Circuits(Configuración de la fragmentación y entrelazado de enlace para circuitos virtuales Frame Relay y ATM).

La versión 12.2(8)T del software Cisco IOS incorpora compatibilidad para LFI distribuido (dLFI) en líneas seriales canalizadas de la serie 7500 de Cisco con VIP. Esta función también está disponible con los switches de la serie Catalyst 6500 y los enrutadores de la serie 7600 de Cisco. Para obtener información acerca de las versiones que soportan dLFI, consulte la herramienta Navegador de funciones (solamente clientes registrados) y las release notes de los productos respectivos. Para obtener más información acerca de esta función, consulte Distributed Link Fragmentation and Interleaving over Leased Lines (Fragmentación y entrelazado de enlaces distribuidos sobre líneas arrendadas).

El FlexWAN para la serie 7600 de Cisco con la versión 2.1E del software Cisco IOS no soporta dLFI.

Tras configurar el máximo retraso del fragmento con el comando ppp multilink fragment-delay <msec>, la función dLFI calcula el tamaño actual del fragmento en interfaces en serie canalizadas mediante esta fórmula (donde el ancho de banda se indica en Kbps):

fragment size = bandwidth x fragment-delay  / 8

Además, el tamaño del fragmento se calcula en función del enlace miembro con la mínima cantidad de ancho de banda. Por ejemplo, en una configuración con enlaces miembro de 64 K y 128 K, el tamaño del fragmento se calcula en función del enlace de 64 K.

CBWFQ y LLQ con PPPoA y MLPPPoA

La versión 12.2(8) del software Cisco IOS fue la primera en soportar el almacenamiento en cola por VC en circuitos virtuales ATM configurados con PPP genérico sobre encapsulación ATM (PPPoA). La versión 12.2(8) del software Cisco IOS soporta esta configuración.

interface ATM2/0.100 point-to-point 
 pvc 0/100 
  abr 704 200 
  broadcast 
  encapsulation aal5mux ppp Virtual-Template20 
  service-policy output dscp

Si ejecuta una versión anterior del software Cisco IOS, puede configurar ATM VC con encapsulación MLPPPoA y aplicar una política de servicio basada en colocación en cola a la interfaz de plantilla virtual. Para obtener más información, consulte Link Fragmentation and Interleaving for Frame Relay and ATM Virtual Circuits (Fragmentación y entrelazado de enlace para circuitos virtuales Frame Relay y ATM) y Link Efficiency Mechanisms Overview (Información general acerca de mecanismos de eficiencia de enlace).

La versión 12.2(4)T3 del software Cisco IOS incorpora una versión distribuida de esta función para la serie 7500 de Cisco. Para obtener más información acerca de esta función, consulte Distributed Link Fragmentation and Interleaving for ATM and Frame Relay (Fragmentación y entrelazado de enlaces distribuidos para Frame Relay y ATM).


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 10102