IP : Servicios de aplicación IP

Funciones y características del Protocolo Hot Standby Router

23 Marzo 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (25 Mayo 2006) | Comentarios

Contenidos

Introducción
Requisitos previos
     Requisitos
     Componentes utilizados
     Convenciones
Operaciones y antecedentes de HSRP
     Mecanismos de detección dinámica de routers
     Operación de HSRP
Direccionamiento HSRP
Versión de Cisco IOS y matriz de funcionalidad de HSRP
Se incluyeron imágenes de inicialización de Cisco IOS y matriz de funcionalidad de HSRP
Funciones de HSRP
     Prioritario
     Seguimiento de interfaz
     Use dirección programada en fábrica
     Grupos HSRP múltiples
     Dirección MAC configurable
     Soporte Syslog
     Depuración de HSRP
     Depuración HSRP mejorada
     Autenticación
     Redundancia IP
     Base de información para administración de SNMP
     Compatibilidad de HSRP con redes privadas virtuales de Multiprotocol Label Switching
     Soporte de HSRP para redirecciones ICMP
Soporte de medios e interfaz HSRP
     Ethernet
     Token Ring
     802.1Q
     ISL
     FDDI
     Actualización de MAC
     Interfaz virtual de grupo de bridge
     Subinterfaces
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

En este documento se describen las funciones y las características del Protocolo Hot Standby Router (HSRP).

Requisitos previos

Requisitos

No hay requisitos específicos para este documento.

Componentes utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Convenciones

Para obtener más información sobre las convenciones del documento, consulte Convenciones sobre consejos técnicos de Cisco.

Operaciones y antecedentes de HSRP

Una forma de lograr que el tiempo de actividad de la red esté cerca del 100% es utilizar HSRP, que ofrece redundancia de red para las redes IP, asegurando que el tráfico de usuarios se recupere de forma inmediata y transparente de los errores de primer salto en los dispositivos de borde de red o circuitos de acceso.

Al compartir una dirección IP y una dirección MAC (Capa 2), dos o más routers pueden funcionar como un solo router “virtual”. Los miembros del grupo del router virtual intercambian continuamente mensajes de estado. De esta forma, un router puede asumir la responsabilidad de ruteo de otro, en el caso de que esté fuera de servicio por razones planificadas o no. Los hosts continúan reenviando paquetes IP a una dirección IP y MAC coherente y el cambio de dispositivos que realizan el ruteo es transparente.

Mecanismos de detección dinámica de routers

A continuación se incluyen descripciones de los mecanismos de descubrimiento dinámico del router que están disponibles para los hosts. Muchos de estos mecanismos no proporcionan la flexibilidad de la red necesaria para los administradores de red. Esto puede deberse a que el objetivo inicial del protocolo no era proporcionar flexibilidad de la red o porque no es posible que cada host en una red ejecute el protocolo. Además de lo mencionado a continuación, es importante destacar que muchos hosts sólo permiten configurar una gateway predeterminada.

Protocolo de resolución de direcciones proxy

Algunos hosts IP usan el Protocolo de resolución de direcciones (ARP) para seleccionar un router. Cuando un host ejecuta un proxy ARP, envía una solicitud ARP para la dirección IP del host remoto que desea contactar. Un router, el Router A, responde en la red en nombre del host remoto y proporciona su propia dirección MAC. Con el proxy ARP, el host se comporta como si el host remoto estuviera conectado al mismo segmento de la red. Si el Router A falla, el host continúa enviando los paquetes destinados al host remoto a la dirección MAC del Router A, aunque estos paquetes no tengan adónde ir y se pierdan. Puede esperar que ARP adquiera la dirección MAC de otro router, el Router B, en el segmento local enviando otra solicitud de ARP o reiniciando el host para forzarlo a enviar una solicitud de ARP. En cualquier caso, durante un período significativo, el host no podrá comunicarse con el host remoto, aunque el protocolo de ruteo haya convergido y el Router B esté preparado para transferir paquetes que, en otras circunstancias, irían a través del Router A.

Protocolo de ruteo dinámico

Algunos hosts IP ejecutan (o indagan) un protocolo de ruteo dinámico como el Routing Information Protocol (RIP) o Abrir trayecto más corto primero (OSPF) para descubrir routers. La desventaja del uso de RIP es que la adaptación a los cambios en la topología es lenta. Es posible que no se pueda ejecutar un protocolo de ruteo dinámico en cada host por numerosos motivos, incluidos los gastos administrativos, los gastos de procesamiento, los problemas de seguridad o la falta de implementación del protocolo de algunas plataformas.

Protocolo de detección del router ICMP

Algunos hosts IP más recientes usan el Protocolo de detección del router ICMP (IRDP) (RFC 1256leavingcisco.com) para buscar un nuevo router cuando no hay una ruta disponible. Un host que ejecuta IRDP escucha los mensajes de saludo de multidifusión de su router configurado y usa un router alternativo cuando ya no recibe este tipo de mensajes. Los valores predeterminados del temporizador de IRDP significan que no es apto para detectar los errores del primer salto. La frecuencia de anuncio predeterminada es una vez cada 7 a 10 minutos, y la vida útil predeterminada es de 30 minutos.

Protocolo de configuración de host dinámico

El Protocolo de configuración de host dinámico (DHCP) (RFC 1531leavingcisco.com) proporciona un mecanismo para transmitir información de configuración a hosts en una red TCP/IP. Un host que ejecuta un cliente DHCP solicita información de configuración de un servidor DHCP cuando se inicia en la red. Esta información de configuración por lo general incluye una dirección IP y una gateway predeterminada. No hay un mecanismo para cambiar a un router alternativo si la gateway predeterminada falla.

Operación de HSRP

Una amplia clase de implementaciones de host heredadas que no soportan la detección dinámica pueden configurar un router predeterminado. Es posible que no pueda ejecutar un mecanismo de detección dinámica de routers en cada host por numerosos motivos, incluidos los gastos administrativos, los gastos de procesamiento, los problemas de seguridad o la falta de implementación del protocolo de algunas plataformas. HSRP proporciona servicios de conmutación por error a estos hosts.

Un conjunto de routers que ejecutan HSRP trabaja en equipo para darle la impresión a los hosts de la LAN de que son un único router virtual. Este conjunto es conocido como un grupo de HSRP o grupo en espera. Un único router seleccionado del grupo es responsable del reenvío de los paquetes que los hosts envían al router virtual. Este router se denomina Router activo. Se elige otro router como router en espera. En el caso de que el router activo falle, el router en espera actúa como router activo y realiza las tareas de reenvío de paquetes. Si bien un número arbitrario de routers puede ejecutar HSRP, sólo el router activo reenvía los paquetes enviados al router virtual.

Para minimizar el tráfico de la red, sólo el router activo y el router en espera envían mensajes de HSRP periódicos una vez que el protocolo ha completado el proceso de selección. Si falla el router activo, el router en espera actúa como router activo. Si el router en espera falla o se convierte en el router activo, entonces se selecciona otro router como router en espera.

En una LAN determinada, pueden coexistir y superponerse varios grupos en espera en caliente. Cada grupo en espera emula un único router virtual. Los routers individuales pueden participar en varios grupos. En este caso, el router mantiene estados y temporizadores separados para cada grupo.

Cada grupo en espera tiene una dirección MAC única y conocida, así como una Dirección IP.

Direccionamiento HSRP

En la mayoría de los casos, cuando se configuran routers para que formen parte de un grupo HSRP, estos escuchan la dirección MAC de HSRP de ese grupo como también su propia dirección MAC establecida en fábrica. La excepción son los routers cuyos controladores Ethernet sólo reconocen una única dirección MAC (por ejemplo, el controlador Lance en los routers Cisco 2500 y Cisco 4500). Estos routers usan la dirección MAC de HSRP cuando actúan como router activo y su dirección establecida en fábrica cuando no actúan como tal.

HSRP usa la siguiente dirección MAC en todos los medios excepto en Token Ring:

0000.0c07.ac**   (where ** is the HSRP group number)

Las interfaces Token Ring utilizan direcciones funcionales para la dirección MAC de HSRP. Las direcciones funcionales son el único mecanismo de multidifusión general disponible. Existe un número limitado de direcciones funcionales de Token Ring disponibles y muchas de ellas se reservan para otras funciones. Puede utilizar las tres direcciones siguientes con HSRP:

c000.0001.0000   (group 0)
c000.0002.0000   (group 1)
c000.0004.0000   (group 2)

Nota: Cuando HSRP se ejecuta en un entorno de conexión en bridge con ruteo (SRB) de origen por anillos múltiples y los routers de HSRP residen en diferentes anillos, el uso de direcciones funcionales puede ocasionar confusión de Campo de información de ruteo (RIF). Por ejemplo, en un entorno SRB, es posible que un router en espera de HSRP resida en un anillo diferente del router activo. Cuando este router en espera pase al estado activo, las estaciones del mismo anillo que el router activo anterior necesitan un nuevo RIF para enviar paquetes al nuevo router activo. No obstante, dado que el router en espera (activo ahora) utiliza la misma dirección funcional que el router activo anterior, las estaciones no advierten que deben enviar exploradores para un nuevo RIF. Por este motivo, se ha introducido el comando use-bia.

Versión de Cisco IOS y matriz de funcionalidad de HSRP

Este documento muestra qué versiones del software Cisco IOS® soportan funciones HSRP. Haga clic en una función para ver una descripción detallada. Un número de versión provisional indica en qué versión apareció por primera vez la función o la versión en la que cambió.

Función

10.0

10.2

10.3

11.0

11.1

11.2

11.3

12.0

12.0T

12.1

12.1T

Prioridad

X

X

X

X

X

X

X

X

X

X

X

Grupos múltiples (MHSRP)

X

X

X

X

X

X

X

X

X

Ethernet 802.10 SDE

X

X

X

X

X

X

X

Seguimiento de interfaces

X

X

X

X

X

X

X

Use BIA

8.0

X

X

X

X

X

X

Demora de retención

X

X

6.1

X

X

X

LANE Ethernet

X

X

X

X

X

X

LANE de Token Ring

X

X

X

X

X

ISL

X

X

X

X

X

Soporte Syslog

X

X

X

X

X

Intervalo de actualización de MAC

1.0

X

X

X

SNMP MIB

3.0

X

X

MHSRP y uso de BIA

3.4

X

X

Redundancia IP

3.4

X

X

BVI

6.2

X

X

802.1Q

8.1

X

X

Depuración HSRP mejorada Depuración

0.2

X

Redirigir HSRP ICMP

3

VPN HSRP MPLS

3

Se incluyeron imágenes de inicialización de Cisco IOS y matriz de funcionalidad de HSRP

en las imágenes de inicialización de Cisco IOS hasta la integración de ID de error de Cisco CSCec16720 (solamente cliente registrados). ID de error de Cisco CSCec16720 eliminó HSRP de las imágenes de inicialización con la excepción de:

  • c7200-boot-mz

  • c7200-kboot-mz

  • c10k-eboot-mz

  • c4500-boot-mz

  • c7200-boot-mz

  • c7200-kboot-mz

  • c7400-kboot-mz

  • ubr7200-boot-mz

  • c6400r-boot-mz

  • rpm-boot-mz

  • rpmxf-boot-mz

  • rsp-boot-mz

  • urm-wboot-mz

  • c5350-boot-mz

  • c5400-boot-mz

  • c7301-boot-mz

  • c5850-boot-mz

  • c4gwy-cboot-mz

  • ubr910-rboot-mz

  • ubr910-rboot-mz

  • ubr925-k8boot-mz

  • c5850tb-boot-mz

Funciones de HSRP

Prioritario

La característica HSRP de prioridad habilita al router con mayor prioridad para que inmediatamente pase a ser el router activo. La prioridad se determina en primer lugar por el valor de prioridad configurado y luego, por la dirección IP. En cada caso, un valor más alto tiene mayor prioridad.

Cuando un router de prioridad más alta invalida a un router de prioridad más baja, envía un mensaje de golpe. Cuando un router activo de prioridad más baja recibe un mensaje de golpe o de saludo de un router activo de prioridad más alta, su estado se modifica al estado hablar y envía un mensaje de retiro.

Demora de retención

La función de demora de retención permite demorar la prioridad durante un período configurable, lo que permite al router poblar su tabla de ruteo antes de convertirse en el router activo.

Antes de la versión 12.0(9) del software Cisco IOS, la demora comenzaba cuando se recargaba el router. En la versión 12.0(9) del software Cisco IOS, la demora comienza cuando se intenta la prioridad por primera vez.

Para configurar la prioridad HSRP y el intento de prioridad, use el comando standby [group] [priority number] [preempt [delay [minimum] seconds] [sync seconds]].

Consulte la Documentación de HSRP para obtener información sobre cómo configurar HSRP.

Seguimiento de interfaz

El seguimiento de interfaz le permite especificar otra interfaz en el router para que el proceso HSRP monitoree y pueda alterar la prioridad HSRP de un grupo determinado.

Si se interrumpe el protocolo de línea de la interfaz especificada, se reduce la prioridad de HSRP de este router y se permite la activación de otro router HSRP con prioridad más alta (en caso de tener habilitada la prioridad ).

Para configurar el rastreo de interfaz HSRP, use el comando standby [group] track interface [priority].

Cuando varias interfaces rastreadas se encuentran desconectadas, la prioridad se reduce por una cantidad acumulativa. Si establece de manera explícita el valor de disminución, entonces el valor disminuye en la cantidad especificada si la interfaz se encuentra inactiva y la disminución es acumulativa. Si no establece de manera explícita el valor de disminución, entonces el valor disminuye en 10 por cada interfaz que se desactiva, y las disminuciones son acumulativas.

El siguiente ejemplo usa la siguiente configuración, con el valor predeterminado de 10.

Nota: Cuando no se especifica un número de grupo HSRP, el número de grupo predeterminado es grupo 0.

interface ethernet0
     ip address 10.1.1.1 255.255.255.0
     standby ip  10.1.1.3
     standby priority 110
     standby track serial0
     standby track serial1

El comportamiento de HSRP con esta configuración es:

  • 0 interfaces inactivas = sin disminución (la prioridad es 110)

  • 1 interfaz inactiva = disminuye en 10 (la prioridad se vuelve 100)

  • 2 interfaz inactiva = disminuye en 10 (la prioridad se vuelve 90)

El comportamiento HSRP anterior es verdadero incluso si los valores decrecientes están configurados explícitamente como sigue:

interface ethernet0
     ip address 10.1.1.1 255.255.255.0
     standby ip  10.1.1.3
     standby priority 110
     standby track serial0 10
     standby track serial1 10

Antes de la versión 12.1 de Cisco IOS, si inicia un router con una interfaz inactiva, el rastreo de la interfaz HSRP considera a la interfaz como activa.

Este defecto tiene el ID de error de Cisco CSCdp32289 (solamente clientes registrados) .

Use dirección programada en fábrica

La función usar dirección programada de fábrica (BIA) permite a los grupos HSRP usar una dirección MAC programada de fábrica de la interfaz en lugar de una dirección MAC de HSRP. El uso de BIA se implementó por primera vez en la versión 11.1(8) del software Cisco IOS. Para configurar HSRP para que utilice BIA, utilice el comando standby use-bia [scope interface].

El comando use-bia se implementó para sobrellevar las limitaciones del uso de una dirección funcional para la dirección MAC de HSRP en las interfaces de Token Ring.

Nota: Cuando HSRP se ejecuta en un entorno de conexión en bridge con ruteo de origen por anillos múltiples y los routers de HSRP residen en diferentes anillos, el uso de direcciones funcionales puede ocasionar confusión del Campo de información de ruteo (RIF). Por este motivo, se ha introducido el comando use-bia.

La función use-bia también habilita el uso de DECnet, Sistemas de red Xerox (XNS) y HSRP en el mismo router al permitir que la dirección MAC DECnet (el BIA) se utilice como la dirección MAC HSRP. El comando use-bia también es útil en situaciones de conexión de redes donde el BIA de un dispositivo se ha configurado en otros dispositivos de la LAN.

No obstante, el comando use-bia presenta varias desventajas:

  • Cuando un router se activa, la dirección IP virtual se traslada a otra dirección MAC. El nuevo router activo envía una respuesta de ARP gratuito, sin embargo, no todas las implementaciones del host administran el ARP gratuito de manera correcta.

  • El ARP del proxy se interrumpe cuando se configura el comando use-bia. Un router en espera no puede suplir la pérdida de la base de datos del ARP del proxy de un router defectuoso.

  • Antes de la versión 12.0(3.4)T de Cisco IOS, se permite sólo un grupo HSRP si use-bia está configurado.

Cuando se configura el comando use-bia en una subinterfaz, realmente aparece en la interfaz principal y se aplica a todas las subinterfaces. En la versión 12.0(6.2) y posteriores de Cisco IOS, el comando use-bia se amplia con las palabras clave opcionales de la interfaz de alcance para poder aplicarlo a una subinterfaz única.

Este defecto tiene el ID de error de Cisco CSCdm25468 (solamente clientes registrados) .

Grupos HSRP múltiples

La característica de grupos de HSRP múltiples (MHSRP) se agregó a la Versión 10.3 de Cisco IOS. Esta función permite mayor redundancia y carga compartida dentro de las redes, así como un uso más extenso de los routers de redundancia. Si bien el router reenvía de forma activa el tráfico para un grupo HSRP, sólo puede estar en el estado en espera o de escucha para otro grupo.

A partir de la versión 12.0(3.4)T de Cisco IOS, puede usar el comando use-bia con varios grupos HSRP habilitados.

Dirección MAC configurable

Normalmente se usa HSRP para ayudar a las estaciones final a ubicar la primera gateway de salto para el IP Routing. Las estaciones final se configuran con una gateway predeterminada. No obstante, HSRP puede proporcionar la primera redundancia de salto para otros protocolos. Algunos protocolos, como la Red avanzada de par a par (APPN), usan la dirección MAC para identificar el primero salto con fines de ruteo.

En este caso, con frecuencia es necesario especificar la dirección MAC virtual utilizando el comando standby mac-address. La dirección IP virtual no es importante para estos protocolos. La sintaxis real del comando es standby [group] mac-address mac-address.

Nota: No puede usar este comando en una interfaz de Token Ring.

Soporte Syslog

La compatibilidad para mensajería de syslog para información de HSRP se incorporó en la versión 11.3 de Cisco IOS. Esta función permite un registro y rastreo más eficaces de los routers activo y en espera actuales en los servidores de syslog.

Depuración de HSRP

Antes de la versión 12.1 de Cisco IOS, el comando de depuración de HSRP era relativamente simple. Para habilitar la depuración de HSRP, simplemente se utilizaba el comando debug standby, el cual habilitaba la salida del estado de HSRP y de la información de paquetes para todos los grupos en todas las interfaces.

En la versión 12.0(2.1) de Cisco IOS se incorporó un estado de depuración que permite filtrar el resultado del comando standby debug en función de la interfaz y del número de grupo. El comando utiliza el paradigma debug condition introducido en la versión 12.0 de Cisco IOS de la siguiente manera: debug condition standby interface group. La interfaz que se especifica debe ser una interfaz válida capaz de soportar HSRP. El grupo puede ser cualquier grupo (0 a 255).

Puede configurar los estados de depuración para grupos que no existen, lo que le permite capturar la información de depuración durante la inicialización de un nuevo grupo.

Debe habilitar la orden standby debug para que se produzca alguna salida de depuración. Si no configura ningún estado standby debug, la salida de depuración se produce para todos los grupos en todas las interfaces. Si configura al menos un estado standby debug, la salida standby debug se filtra de acuerdo con todos los estados standby debug .

Depuración HSRP mejorada

Antes de la versión 12.1(0.2) de Cisco IOS, el uso de la depuración HSRP era limitado dado que la información se perdía en el ruido de los mensajes de saludo periódicos. Por lo tanto, se agregó la función mejorada de depuración en la versión 12.1(0.2) de Cisco IOS.

La siguiente tabla explica las opciones de comando para mejorar la depuración.

Comando

Descripción

debug standby

Muestra todos los errores, eventos y paquetes HSRP.

debug standby terse

Muestra todos los errores, eventos y paquetes HSRP, excepto los paquetes de saludo y de anuncio.

debug standby errors

Muestra errores HSRP.

debug standby events [[all | terse] | [icmp | protocol | redundancy | track]] [detail]

Muestra eventos HSRP.

debug standby packets [[all | terse] | [advertise | coup | hello | resign]] [detail]

Muestra paquetes HSRP.

Puede filtrar la salida de debug utilizando la depuración de interfaces y condicional del grupo HSRP. Para habilitar la depuración condicional de la interfaz, utilice el comando debug condition interface interface. Para habilitar la depuración condicional de HSRP, use el comando debug condition standby interface group.

Una condición de depuración de interfaz se aplica sólo cuando no se ha establecido ninguna condición standby debug. La depuración de HSRP se ha mejorado todavía más en la versión 12.1(1.3) de Cisco IOS, en función de las mejoras realizadas en la tabla de estado de HSRP.

Este defecto tiene el ID de error de Cisco CSCdp57811 (solamente clientes registrados) .

Estas mejoras muestran los eventos de la tabla de estado de HSRP. En el resultado que aparece a continuación, las letras a/, b/, c/, etc. hacen referencia a los eventos de la máquina de estado finito de HSRP, que están documentados en RFC 2281leavingcisco.com.

SB1: Ethernet0/2 Init: a/HSRP enabled
SB1: Ethernet0/2 Active: b/HSRP disabled (interface down)
SB1: Ethernet0/2 Listen: c/Active timer expired (unknown)
SB1: Ethernet0/2 Active: d/Standby timer expired (20.0.0.3)
SB1: Ethernet0/2 Speak: f/Hello rcvd from higher pri Speak router
SB1: Ethernet0/2 Active: g/Hello rcvd from higher pri Active router
SB1: Ethernet0/2 Speak: h/Hello rcvd from lower pri Active router
SB1: Ethernet0/2 Standby: i/Resign rcvd
SB1: Ethernet0/2 Active: j/Coup rcvd from higher pri router
SB1: Ethernet0/2 Standby: k/Hello rcvd from higher pri Standby router
SB1: Ethernet0/2 Standby: l/Hello rcvd from lower pri Standby router
SB1: Ethernet0/2 Active: m/Standby mac address changed
SB1: Ethernet0/2 Active: n/Standby IP address configured

Autenticación

La característica de autenticación HSRP consiste en una clave compartida de texto sin cifrar incluida en los paquetes HSRP. Esta función evita que el router de prioridad más baja obtenga información sobre los valores de la dirección IP y del temporizador en espera del router de mayor prioridad.

Para configurar la cadena de autenticación de HSRP, utilice el comando standby authentication string.

Redundancia IP

HSRP proporciona redundancia sin estado para el IP Routing. HSRP por sí solo se limita al mantenimiento de su propio estado. Supone que cada router crea y mantiene sus propias tablas de ruteo independientemente de otros routers. La función de redundancia IP proporciona un mecanismo que permite a HSRP proporcionar un servicio a aplicaciones cliente de manera que puedan implementar la conmutación por error de estado completo.

La redundancia IP no proporciona un mecanismo para que las aplicaciones de pares intercambien información de estado. Esto se deja a las aplicaciones en sí y es fundamental si se espera que las aplicaciones proporcionen conmutación por error de estado completo.

La redundancia IP se ha implementado actualmente (a partir de enero de 2000) sólo para los Agentes de redes domésticas IP móviles. A continuación se incluye una configuración de ejemplo:

configure terminal
 router mobile
 ip mobile home-agent standby hsrp-group1
!
interface e0/2
 no shutdown
 ip address 20.0.0.1 255.0.0.0
 standby 1 ip 20.0.0.11
 standby 1 name hsrp-group1

Nota: A partir de la versión 12.1(3)T de Cisco IOS, la palabra clave redundancy se acepta además de la palabra clave standby. La palabra clave standby se eliminará por fases en una versión posterior de Cisco IOS. El comando correcto será entonces ip mobile home-agent redundancy hsrp-group1.

Los usos futuros de redundancia IP pueden comprender:

  • NAT: necesita proporcionar gateways redundantes.

  • IPSEC: necesita sincronizar la información de estado para funcionar cuando HSRP está en uso.

  • Servidor DHCP: servidores DHCP implementados en varios routers.

  • NBAR, CBAC: necesitan duplicar los estados del firewall para el ruteo asimétrico.

  • GPRS - Necesita una forma de realizar el seguimiento del estado TCP.

  • PIX

Base de información para administración de SNMP

Se agregó compatibilidad para Base de información para administración (MIB) SNMP a la versión 12.0(3.0)T de Cisco IOS. Hay dos MIB relevantes para HSRP:

  • ciscoMgmt 106: El módulo MIB para administración de HSRP

  • ciscoMgmt 107: El módulo MIB de expansión para administración de HSRP

En las versiones anteriores a la 12.0(6.1)T de Cisco IOS, cuando está presente una Interfaz virtual de grupo de bridge (BVI), un recorrido por el módulo MIB de HSRP extendido provoca un fallo en el router.

Este defecto tiene el ID de error de Cisco CSCdm61257 (solamente clientes registrados) .

Compatibilidad de HSRP con redes privadas virtuales de conmutación de etiquetas de múltiples protocolos (Multiprotocol Label Switching)

En la versión 12.1(3)T de Cisco IOS se ha agregado compatibilidad de HSRP con redes privadas virtuales de Multiprotocol Label Switching (MPLS VPN) .

HSRP en una interfaz MPLS VPN es útil cuando existe una Ethernet conectada entre dos límites del proveedor (PE) y se tiene alguna de las siguientes opciones:

  • Un límite del cliente (CE) con una ruta predeterminada hacia la dirección IP virtual de HSRP.

  • Uno o más hosts con la dirección IP virtual de HSRP configurada como la gateway predeterminada.

El siguiente diagrama de red muestra dos PE con HSRP ejecutándose entre sus interfaces VPN de ruteo/reenvío (VRF). Hemos configurado el CE con la dirección IP virtual HSRP como su ruta predeterminada. Y hemos configurado HSRP para rastrear las interfaces que conectan los PE al resto de la red de proveedores. Por ejemplo, si la interfaz E1 o PE1 falla, la prioridad HSRP se reducirá de manera tal que PE2 asume el reenvío de paquetes a la dirección MAC/IP virtual.

hsrpguide4a.gif

Las configuraciones se muestran a continuación.

Router PE1

Router PE2

conf terminal
!
ip cef
!
ip vrf vrf1
 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
interface ethernet0
 no shutdown
 ip vrf forwarding vrf1
 ip address 10.2.0.1 255.255.0.0
 standby 1 ip 10.2.0.20
 standby 1 priority 105
 standby 1 preempt delay minimum 10
 standby 1 timers 3 10
 standby 1 track ethernet1 10
 standby 1 track ethernet2 10
conf terminal
!
ip cef
!
ip vrf vrf1
 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
interface ethernet0
 no shutdown
 ip vrf forwarding vrf1
 ip address 10.2.0.2 255.255.0.0
 standby 1 ip 10.2.0.20
 standby 1 priority 100
 standby 1 preempt delay minimum 10
 standby 1 timers 3 10
 standby 1 track ethernet1 10
 standby 1 track ethernet2 10

Puede utilizar los siguientes comandos para verificar que la dirección IP virtual de HSRP está en las tablas de VRF ARP y de Cisco Express Forwarding correspondientes:

ed1-pe1# show ip arp vrf vrf1
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.2.0.1                -   00d0.bbd3.bc22  ARPA   Ethernet0/2
Internet  10.2.0.20               -   0000.0c07.ac01  ARPA   Ethernet0/2

ed1-pe1# show ip cef vrf vrf1
Prefix              Next Hop             Interface
0.0.0.0/0           10.3.0.4             Ethernet0/3
0.0.0.0/32          receive
10.1.0.0/16         10.2.0.1             Ethernet0/2
10.2.0.0/16         attached             Ethernet0/2
10.2.0.1/32         receive
10.2.0.20/32        receive
224.0.0.0/24        receive
255.255.255.255/32  receive

Soporte de HSRP para redirecciones ICMP

HSRP está basado en el concepto de que los peer routers HSRP que protegen una subred pueden proporcionar acceso a todas las demás subredes que comprenden la red. En consecuencia, es irrelevante qué router se convierte en un router HSRP activo, ya que todos los routers tenían rutas hacia cada subred.

HSRP utiliza una dirección IP virtual especial y una dirección MAC virtual, lógicamente conectadas al router activo HSRP. Las redirecciones de ICMP están automáticamente desactivadas en una interfaz cuando se utiliza HRSP en esa interfaz. En la versión 12.1(3)T del IOS y posteriores, la función Redirecciones ICMP habilita las redirecciones ICMP en las interfaces configuradas con HSRP. Consulte Soporte HSRP para redirecciones ICMP para obtener más detalles. Esto se lleva a cabo para evitar que los hosts sean redireccionados fuera de la dirección IP virtual de HSPR. Es posible que los dos (o más) routers de una subred no tengan una conectividad idéntica al resto de la red. Es decir, para una dirección IP de destino en particular, un router o el otro puede tener un trayecto mucho mejor que aquella dirección, o puede incluso ser el único router conectado a esa dirección.

El protocolo ICMP permite que un router redireccione una estación extremo para que envíe paquetes para un destino en particular a otro router en la misma subred, si el primer router sabe que el otro router tiene un mejor trayecto a ese destino en concreto. Como en el caso para las gateways predeterminadas, si el router al que se redirecciona una estación extremo para un destino en particular falla, los paquetes de la estación extremo a ese destino no se entregarán. Esto es exactamente lo que sucede en HSRP estándar. Por este motivo, se recomienda inhabilitar las redirecciones ICMP si el HSRP está encendido.

Si se extiende la relación entre las redirecciones ICMP y HSRP proporciona una solución a este problema, podrá aprovechar los beneficios de las redirecciones HSRP e ICMP. Dos (o más) grupos HSRP se ejecutan en cada subred, con al menos tantos grupos HSRP configurados como routers que participan. Las prioridades se configuran a fin de que cada uno de los routers sea el principal de al menos un grupo HSRP. Cuando un router decide redireccionar una estación extremo a un router diferente para un destino específico, en lugar de redireccionar la estación extremo a esta otra dirección IP del router, descubre un grupo HSRP que el router convierte en maestro y redirecciona la estación extremo a la dirección IP virtual correspondiente. Si ese router de destino falla, HSRP garantiza que otro router se responsabilice de su trabajo y, quizás, redirecciona también la estación final a otro router virtual.

Soporte de medios e interfaz HSRP

En esta sección se explica qué interfaces y medios son compatibles con HSRP y las posibles advertencias al ejecutar HSRP en estos medios.

A partir de la versión 10.0 del software Cisco IOS, la funcionalidad HSRP ha estado disponible en Ethernet, Token Ring y la Interfaz de datos distribuidos por fibra (FDDI). HSRP también soporta interfaces Fast Ethernet y ATM.

Las LAN virtuales (VLAN) permiten topologías de red lógicas para superponer la infraestructura física conmutada de manera tal que toda la recolección arbitraria de puertos LAN puede combinarse en un grupo de usuarios autónomo o comunidad de intereses. Se ha agregado compatibilidad para VLAN de HSRP en la versión 11.1 de Cisco IOS para IEEE 802.10 Secure Data Exchange (SDE) y en la versión 11.3 de Cisco IOS para Cisco Inter-Switch Link (ISL).

Ethernet

Varios controladores Ethernet (Lance y QUICC) en productos de menor capacidad sólo pueden tener una sola dirección MAC de unidifusión en su filtro de direcciones. En estas plataformas, sólo se permite un grupo HSRP único y la dirección de la interfaz se cambia a la dirección MAC virtual de HSRP cuando el estado del grupo es activo. Si está utilizando HSRP en routers con varias interfaces de este tipo, debe configurar cada interfaz con un número de grupo HSRP diferente.

Nota: El router Cisco 7200 también usa el controlador Lance Ethernet, pero es compatible con MHSRP en el software.

Cisco recomienda no tener más de veinticuatro Procesadores de interfaz Ethernet (EIP) HSRP debido al tiempo que se requiere para actualizar los filtros de direcciones para HSRP. Tener más de veinticuatro EIP de HSRP puede causar inestabilidad y recarga excesiva de la CPU.

Este defecto tiene el ID de error de Cisco CSCdj29595 (solamente clientes registrados) .

Si tiene más de veinticuatro EIP, intente reemplazarlos con Procesadores de interfaz versátil (VIP) y adaptadores de puertos Ethernet. Los VIP se han aprobado para hasta ochenta grupos HSRP. También puede reducir la cantidad de grupos HSRP e incrementar el tiempo de saludo y espera de HSRP.

Token Ring

Una limitación al ejecutar HSRP en una interfaz de Token Ring es que no se puede reprogramar el filtro de direcciones en el conjunto de chips de Token Ring de la misma forma que en la emulación de ATM, FDDI o Ethernet. Token Ring usa direcciones funcionales, de las cuales sólo hay un pequeño número disponible que no entra en conflicto con otros usos del espacio de direcciones funcionales.

Cuando HSRP se ejecuta en un entorno de conexión en bridge con ruteo de origen (SRB), el uso de direcciones funcionales puede provocar confusión RIF. Consulte la sección Direccionamiento HSRP para obtener más información. Además, intente configurar el comando use-bia.

802.1Q

Cisco recomienda utilizar la versión 12.0(8.1)T o superior de Cisco IOS para HSRP en 802.1Q.

ISL

HSRP en ISL está disponible en las versiones 11.2(6)F, 11.3, 12.X de Cisco IOS. Se recomienda utilizar la versión 12.0(7) o posterior para evitar el problema que se describe en el ID de error de Cisco CSCdm68811 (solamente clientes registrados) .

FDDI

Un adaptador de puerto FDDI separa las tramas del anillo si ve una de sus propias direcciones MAC en la fuente MAC. Si un evento de red hace que ambos routers pasen al estado activo, entonces, ambos envían paquetes de saludo HSRP con la misma dirección MAC virtual. Cada router separa de la red por error el paquete de saludo del otro router y ambos permanecen activos.

Este defecto tiene el ID de error de Cisco CSCdj30049 (solamente clientes registrados) .

La solución a este problema en la versión 11.2(11.1) de Cisco IOS es que los routers HSRP en un entorno FDDI usen su propia dirección MAC, programada en fábrica y exclusiva, para intercambiar mensajes y ejecutar el protocolo HSRP. Para asegurarse de que los bridges y los switches de aprendizaje almacenan en caché la entrada correcta del puerto para la dirección virtual de MAC, el router activo también envía mensajes de actualización periódicos mediante la dirección MAC de HSRP.

Nota: Es posible que la memoria direccionable por contenido (CAM) de hardware del router de Cisco 4500 en una interfaz FDDI no se llene de manera correcta después de una recarga, en caso de que haya configurado varias redes RIP y grupos HSRP. La única alternativa es borrar las interfaces para restaurar CAM. Este defecto tiene el ID de error de Cisco ID CSCdm93122 (solamente clientes registrados) .

Actualización de MAC

Los routers HSRP en un entorno FDDI usan su propia dirección MAC, programada en fábrica y exclusiva, para intercambiar mensajes y ejecutar el protocolo HSRP. Para asegurarse de que los bridges y los switches de aprendizaje almacenan la entrada correcta del puerto para la dirección virtual de MAC, el router activo también envía mensajes de actualización periódicos mediante la dirección MAC de destino Este defecto tiene el ID de error de Cisco CSCdj30049 (solamente clientes registrados) .

Si no dispone de un switch o bridge de aprendizaje en su red, puede inhabilitar el envío de paquetes de actualización como se muestra a continuación:

interface fddi 1/0/0
 ip address 10.1.1.1 255.255.255.0
 standby ip 10.1.1.250
 standby mac-refresh 0

Interfaz virtual de grupo de bridge

Se ha agregado soporte de HSRP para las Interfaces virtuales de grupo de bridge (BVI) en la versión 12.0(6.2)T de Cisco IOS.

Subinterfaces

Los grupos HSRP de las subinterfaces deben tener un número de grupo único entre todos los demás grupos en todas las subinterfaces de la misma interfaz principal. Esto se debe a que las subinterfaces no reciben un índice de interfaz SNMP único. Si tiene dos grupos con el número N en diferentes subinterfaces, en el módulo MIB, el grupo N de la subinterfaz 1 y el grupo N de la subinterfaz 2 parecerán ser el mismo grupo.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 9234