IP : Routing IP

Redistribución de protocolos de enrutamiento

19 Mayo 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (22 Marzo 2012) | Comentarios

Contenidos

Introducción
Requisitos previos
     Requisitos
     Componentes utilizados
     Convenciones
Métrica
Distancia administrativa
Sintaxis y ejemplos de la configuración de redistribución
     IGRP y EIGRP
     OSPF
     RIP
     IS-IS
     Rutas conectadas
Cómo evitar problemas debido a la redistribución
     Ejemplo 1
     Ejemplo 2
     Ejemplo 3
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

El uso de un protocolo de ruteo para publicitar rutas conocidas por algunos otros medios, como por otro protocolo de ruteo, rutas de estadísticas o rutas conectadas directamente, se denomina redistribución. Si bien es preferible ejecutar un único protocolo de ruteo a través de su interconexión entre redes, el ruteo de varios protocolos es frecuente por una gran cantidad de motivos, por ejemplo, fusiones entre compañías, departamentos múltiples administrados por administradores de red y entornos de varios fabricantes. Ejecutar diferentes protocolos de ruteo con frecuencia es parte de un diseño de red. En cualquiera de los casos, tener un entorno de varios protocolos hace que la redistribución sea una necesidad.

Las diferencias en las funciones de los protocolos de ruteo, como la métrica, la distancia administrativa, las capacidades con clase y sin clase pueden afectar la redistribución. Se deben tener en consideración estas diferencias para que la redistribución sea exitosa.

Requisitos previos

Requisitos

No hay requisitos previos específicos para este documento.

Componentes utilizados

La información que contiene este documento está basada en las versiones de software y hardware mencionadas a continuación.

  • Versión 12.3(3) del software Cisco IOS® 12.2(10b)

  • Routers de la serie 2500 de Cisco

La información que se presenta en este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración despejada (predeterminada). Si está trabajando en una red activa, asegúrese de haber comprendido el impacto que puede tener un comando antes de ejecutarlo.

Convenciones

Si desea obtener más información sobre las convenciones del documento, consulte las Convenciones de consejos técnicos de Cisco.

Métrica

Al redistribuir un protocolo en otro, recuerde que la métrica de cada protocolo desempeña un papel importante en la redistribución. Cada protocolo usa métricas diferentes. Por ejemplo, la métrica del Routing Information Protocol (RIP) está basada en el conteo saltos, pero el Protocolo de ruteo de gateway interior (IGRP) y el Enhanced Interior Gateway Routing Protocol (EIGRP) usan una métrica compuesta basada en el ancho de banda, el retraso, la confiabilidad, la carga y la unidad de transmisión máxima (MTU), donde el ancho de banda y el retraso son los únicos parámetros utilizados de forma predeterminada. Cuando las rutas son redistribuidas, debe definir una métrica comprensible para el protocolo receptor. Cuando se redistribuyen rutas, existen dos métodos para definir las métricas.

redist-a.gif

Solamente puede definir la medición para esa redistribución específica:

router rip
redistribute static metric 1
redistribute ospf 1 metric 1

O bien, puede usar las mismas métricas como predeterminadas para toda la redistribución. (Usando el comando default-metric guarda el trabajo porque elimina la necesidad de definir la métrica por separado para cada redistribución):

router rip
redistribute static
redistribute ospf 1
default-metric 1

Distancia administrativa

Si un router está ejecutando más de un protocolo de ruteo y adquiere conocimiento de una ruta al mismo destino utilizando ambos protocolos de ruteo, ¿qué ruta debe seleccionarse como la mejor ruta? Cada protocolo usa su propio tipo de métrica para determinar la mejor ruta. No se puede realizar una comparación de las rutas con los diferentes tipos de métrica. Las distancias administrativas se ocupan de este problema. Las distancias administrativas tienen asignadas orígenes de rutas de manera que se elija la ruta del origen de preferencia como la mejor ruta. Consulte Selección de ruta en routers de Cisco para obtener más información sobre distancias administrativas y selección de ruta.

Las distancias administrativas ayudan en la selección de rutas entre los diferentes protocolos de ruteo, pero pueden presentar problemas para la redistribución. Estos problemas pueden presentarse en la forma de bucles de ruteo, problemas de convergencia o ruteo ineficaz. Consulte a continuación para conocer la topología y la descripción de un posible problema.

redist-b.gif

En la topología anterior, si R1 ejecuta RIP y R2 y R5 están ejecutando RIP e IGRP y realizando la redistribución de RPI en IGRP, existe un posible problema. Por ejemplo, el R2 y el R5 aprenden de la red 192.168.1.0 desde el R1 utilizando RIP. Este conocimiento se redistribuye en IGRP. R2 aprende de la red 192.168.1.0 a través de R2, y R5 aprende acerca de esta red a través de R4 que usa IGRP. IGRP tiene una distancia administrativa más baja que RIP (100 versus 120); por lo tanto, la ruta IGRP es la que se utilizará en la tabla de ruteo. Ahora hay un bucle de ruteo potencial. Aun si la división del horizonte o cualquier otra función que pretenda ayudar a evitar los bucles de ruteo, se presenta en la situación, aún hay un problema de convergencia.

Si R2 y R5 también redistribuyen IGRP en RIP (de lo contrario conocida como redistribución mutua) y la red, 192.168.1.0, no está directamente conectada a R1 (R1 aprende de otro router ascendente de él), existe un problema potencial de que R1 aprenda la red de R2 o R5 con una mejor métrica que la fuente original.

Nota: La mecánica de la redistribución de la ruta es propiedad de los routers de Cisco. Las reglas para la redistribución en un router Cisco dictan que la ruta redistribuida esté presente en la tabla de ruteo. No es suficiente que la ruta esté presente en la topología o la base de datos de ruteo. Las rutas con una menor Distancia administrativa (AD) siempre se instalan en la tabla de ruteo. Por ejemplo, si una ruta estática se redistribuye en IGRP en R5, e IGRP se redistribuye posteriormente en RIP en el mismo router (R5), la ruta estática no se redistribuye en RIP porque nunca ingresó en la tabla de ruteo de IGRP. Esto se debe al hecho de que las rutas estáticas tienen una AD de 1 y las rutas de IGRP tienen una AD de 100 y la ruta estática se instala en la tabla de ruteo. Para redistribuir la ruta estática en IGRP en R5, necesita usar el comando redistribute static en el comando router rip.

El comportamiento predeterminado para RIP, IGRP y EIGRP es publicitar directamente rutas conectadas cuando una sentencia network en el protocolo de ruteo incluye la subred de interfaz conectada. Existen dos métodos para obtener una ruta conectada.

  • Una interfaz se configura con una dirección y una máscara IP, esta subred correspondiente se considera una ruta conectada.

  • Una ruta estática se configura sólo con una interfaz saliente y no con un salto siguiente de IP, esto también se considera una ruta conectada.

Router# conf t
   Router(config)# ip route 10.0.77.0 255.255.255.0 ethernet 0/0
   Router(config)# end

   Router# show ip route static
   10.0.0.0/24 is subnetted, 1 subnets
   S 10.0.77.0 is directly connected, Ethernet0/0

Un comando network configurado en EIGRP, RIP o IGRP que incluye (o “abarca”) cualquiera de estos tipos de rutas conectadas incluye esa subred para publicidad.

Por ejemplo, si una interfaz posee una dirección 10.0.23.1 y una máscara 255.255.255.0, la subred 10.0.23.0/24 es una ruta conectada y será anunciada por estos protocolos de ruteo cuando se configure una sentencia network de la siguiente manera:

router rip | igrp # | eigrp #
   network 10.0.0.0

Esta ruta estática, 10.0.77.0/24, también se anuncia por estos protocolos de ruteo, ya que es una ruta conectada y está "abarcada" por la sentencia network.

Consulte la sección Cómo evitar problemas debido a la redistribución de este documento para obtener sugerencias sobre cómo evitar este problema.

Sintaxis y ejemplos de la configuración de redistribución

IGRP y EIGRP

La siguiente salida muestra un router IGRP/EIGRP que redistribuye rutas estáticas Open Shortest Path First (OSPF), RIP y Sistemas intermedios a sistema intermedio (IS-IS).

router igrp/eigrp 1
network 131.108.0.0
redistribute static
redistribute ospf 1
redistribute rip
redistribute isis
default-metric 10000 100 255 1 1500

IGRP y EIGRP necesitan cinco métricas al redistribuir otros protocolos: ancho de banda, retraso, confiabilidad, carga y MTU, respectivamente. Ejemplo de las métricas de IGRP:

Métrico

Valor

ancho de banda

En unidades de kilobits por segundo, 10000 para Ethernet

retraso

En unidades de decenas de microsegundos, para Ethernet es 100 x 10 microsegundos = 1 ms

confiabilidad

255 para 100 por ciento de confiabilidad

carga

Carga efectiva en el enlace, expresada como un número de 0 a 255 (255 es una carga del 100 por ciento)

MTU (unidad de transmisión básica)

MTU mínimo de la ruta, generalmente equivalente a aquél para la interfaz Ethernet, que es 1500 bytes

Varios procesos IGRP y EIGRP pueden ejecutarse en el mismo router, con una redistribución entre ellos. Por ejemplo, IGRP1 e IGRP2 pueden funcionar en el mismo router. No obstante, ejecutar dos procesos del mismo protocolo en el mismo router pocas veces es necesario y puede consumir la memoria del router y la CPU.

La redistribución de IGRP/EIGRP en otro proceso IGRP/EIGRP no requiere necesariamente ninguna conversión métrica, por lo que no es necesario definir métricas ni usar el comando default-metric durante la redistribución

OSPF

La siguiente salida muestra un router OSPF que redistribuye rutas estáticas, RIP, IGRP, EIGRP e IS-IS.

router ospf 1
network 131.108.0.0 0.0.255.255 area 0
redistribute static metric 200 subnets
redistribute rip metric 200 subnets
redistribute igrp 1 metric 100 subnets
redistribute eigrp 1 metric 100 subnets
redistribute isis metric 10 subnets

La métrica OSPF es un valor de costo basado en 108/el ancho de banda del vínculo en bits/seg. Por ejemplo, el costo OSPF de Ethernet es 10: 108/107 = 10

Nota: Si no se especifica una métrica, OSPF coloca un valor predeterminado de 20 al redistribuir rutas de todos los protocolos excepto las rutas del Protocolo de gateway de frontera (BGP), que obtienen una métrica de 1.

Cuando hay una red principal que se divide en subredes, necesita usar la subred de palabra clave para redistribuir protocolos en OSPF. Sin esta palabra clave, OSPF sólo redistribuye redes principales que no están conectadas en subredes.

Es posible ejecutar más de un proceso OSPF en el mismo router, sin embargo, la ejecución de más de un proceso del mismo protocolo es poco común y consume recursos de memoria del router y de la CPU.

No es necesario que defina métricas ni use el comando default-metric al redistribuir un proceso OSPF en otro.

RIP

Nota: Los principios en este documento se aplican a las versiones I y II.

La siguiente salida muestra un router RIP que redistribuye rutas estáticas, IGRP, EIGRP, OSPF e IS-IS.

router rip
network 131.108.0.0
redistribute static
redistribute igrp 1
redistribute eigrp 1
redistribute ospf 1
redistribute isis
default-metric 1

La métrica RIP está compuesta por conteo de saltos y la métrica válida máxima es 15. Cualquier número mayor a 15 es considerado infinito, puede usar 16 para describir una métrica infinita en RIP. Al redistribuir un protocolo en RIP, Cisco recomienda que use una métrica baja, como 1. Una métrica alta, como 10, limita aún más a RIP. Si define una métrica de 10 para las rutas redistribuidas, estas rutas sólo pueden anunciarse en routers de hasta 5 saltos de distancia, en los que la métrica (conteo de saltos) supera 15. Al definir una métrica de 1, habilita una ruta para que transmita el número máximo de saltos en un dominio RIP. Al hacerlo: aumenta las posibilidades de bucles de ruteo si hay múltiples puntos de redistribución y un router aprende sobre la red con una mejor métrica desde el punto de redistribución en lugar de desde la fuente original, según se explicó en la sección Distancia administrativa de este documento. Por lo tanto, debe asegurarse de que la métrica no sea demasiado alta, y evitar que se anuncie en todos los routers, ni demasiado baja que genere bucles de ruteo cuando haya varios puntos de redistribución.

IS-IS

La siguiente salida muestra un router IS-IS que redistribuye rutas estáticas, RIP, IGRP, EIGRP y OSPF.

router isis
network 49.1234.1111.1111.1111.00
redistribute static
redistribute rip metric 20
redistribute igrp 1 metric 20
redistribute eigrp 1 metric 20
redistribute ospf 1 metric 20

La métrica IS-IS debe ser entre 1 y 62. No hay una opción de métrica predeterminada en IS-IS, debe definir una métrica para cada protocolo, como se muestra en el ejemplo anterior. Si no se especificaron métricas para las rutas que se estaban redistribuyendo en IS-IS, se utiliza un valor de métrica de 0 de forma predeterminada.

Rutas conectadas

Redistribuir directamente las redes conectadas en protocolos de ruteo no es una práctica frecuente y no se muestra en ninguno de los ejemplos anteriores por este motivo. No obstante, es importante destacar que puede realizarse, directa e indirectamente. Para redistribuir directamente rutas conectadas, use el comando de configuración del router redistribute connected. También debe definir una métrica en este caso. También puede redistribuir indirectamente las rutas conectadas en los protocolos de ruteo tal como se muestra en el siguiente ejemplo:

redist-cnctd.gif

En este ejemplo, el Router B tiene dos interfaces Fast Ethernet. FastEthernet 0/0 está en la red 10.1.1.0/24 y FastEthernet 0/1 está en la red 20.1.1.0/24. El router B está ejecutando EIGRP con el router A y OSPF con el router C. El router B se redistribuye mutuamente entre los procesos EIGRP y OSPF. Ésta es la información de configuración pertinente para el router B:

Router B

interface FastEthernet0/0
 ip address 10.1.1.4 255.255.255.0

interface FastEthernet0/1
 ip address 20.1.1.4 255.255.255.0

router eigrp 7
 redistribute ospf 7 metric 10000 100 255 1 1500
 network 10.1.1.0 0.0.0.255
 auto-summary
 no eigrp log-neighbor-changes
!
router ospf 7
 log-adjacency-changes
 redistribute eigrp 7 subnets
 network 20.1.1.0 0.0.0.255 area 0

Si observa la tabla de ruteo para el Router B, verá lo siguiente:

routerB# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0

De la configuración y de la tabla de ruteo anteriores, hay tres elementos que debemos tener en cuenta:

  • Las redes en cuestión figuran en la tabla de ruteo del router B como redes con conexión directa.

  • La red 10.1.1.0/24 es parte del proceso EIGRP y la red 20.1.1.0/24 es parte del proceso OSPF.

  • El router B se redistribuye mutuamente entre los procesos EIGRP y OSPF.

A continuación, se encuentran las tablas de ruteo para los Routers A y C.

routerA# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0
     20.0.0.0/24 is subnetted, 1 subnets
D EX    20.1.1.0 [170/284160] via 10.1.1.4, 00:07:26, FastEthernet0


routerC# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet1
O E2    10.1.1.0 [110/20] via 20.1.1.4, 00:07:32, FastEthernet1

El router A aprendió sobre la red 20.1.1.0/24 a través de EIGRP, que se muestra como una ruta externa, dado que se redistribuyó desde OSPF en EIGRP. El router C aprendió sobre la red 10.1.1.0/24 a través de OSPF, como una ruta externa dado que se redistribuyó desde EIGRP en OSPF. Si bien el router B no está redistribuyendo redes conectadas, no anuncia la red 10.1.1.0/24, que es parte del proceso EIGRP redistribuido en OSPF. De igual forma, el router B anuncia la red 20.1.1.0/24, que es parte del proceso OSPF redistribuido en EIGRP.

Consulte Redistribución de redes conectadas en OSPF para obtener más información acerca la redistribución de rutas conectadas en OSPF.

Cómo evitar problemas debido a la redistribución

En la sección sobre distancia administrativa observó que la redistribución puede llegar a causar problemas potenciales tales como ruteo por debajo del nivel óptimo, bucles de ruteo y convergencia lenta. Evitar estos tipos de problemas es realmente bastante simple: nunca anuncie la información originalmente recibida desde el proceso de ruteo X nuevamente en el proceso de ruteo X.

Ejemplo 1

redist-b.gif

En la topología anterior, R2 y R5 están realizando la redistribución mutua. RIP está siendo redistribuida en IGRP e IGRP está redistribuyendo en RIP, como muestra la configuración debajo.

R2:

router igrp 7
network 181.16.0.0

redistribute rip metric 1 1 1 1 1

router rip
network 178.1.0.0
redistribute igrp 7 metric 2

R5:

router igrp 7
network 181.16.0.0

redistribute rip metric 1 1 1 1 1

router rip
network 178.1.0.0
redistribute igrp 7 metric 2

Con la configuración previa, puede tener cualquiera de los problemas descritos anteriormente. Para evitar estos problemas, puede filtrar las actualizaciones de ruteo de la siguiente manera:

R2:

router igrp 7
network 181.16.0.0

redistribute rip metric 1 1 1 1 1
distribute-list 1 in s1

router rip
network 178.1.0.0
redistribute igrp 7 metric 2

access-list 1 deny 192.168.1.0
access-list 1 permit any

R5:

router igrp 7
network 181.16.0.0

redistribute rip metric 1 1 1 1 1
distribute-list 1 in s1

router rip
network 178.1.0.0

redistribute igrp 7 metric 2

access-list 1 deny 192.168.1.0
access-list 1 permit any

Las listas de distribución agregadas a las configuración, como se muestra anteriormente, filtran cualquier actualización de IGRP entrante en la interfaz serie 1 de los routers. Si las rutas en las actualizaciones están permitidas por la lista de acceso 1, el router las acepta en la actualización. De lo contrario, no. En este ejemplo, los routers reciben una indicación de que no deben aprender de la red 192.168.1.0 a través de las actualizaciones de IGRP que reciben en su interfaz serie 1, por lo tanto, el único conocimiento que tienen estos routers con respecto a la red 192.168.1.0 es a través del RIP del R1.

También debe tener en cuenta que, en este caso, no es necesario usar la misma estrategia de filtro para el proceso RIP dado que RIP posee una distancia administrativa más alta que IGRP. Si las rutas que se originan en el dominio IGRP se alimentaron a través de R2 y R5 a través de RIP, las rutas IGRP aún tendrían prioridad.

Ejemplo 2

redist-c.gif

Utilizando la topología anterior, podemos demostrar otro método (que con frecuencia se prefiere) para evitar problemas de redistribución. Este método usa mapas de rutas para establecer etiquetas para varias rutas. Los procesos de ruteo pueden redistribuirse en función de las etiquetas. Tenga en cuenta que la redistribución basada en etiquetas no funciona con la versión 1 de RIP o IGRP.

Uno de los problemas que puede ejecutar en la topología anterior es el siguiente:

R1 anuncia la red 192.168.1.0 a R2. R2 y luego la redistribuye a EIGRP. R5 conoce la red a través de EIGRP y la redistribuye a RIPv2. En función de la métrica que R5 configura para la ruta de RIPv2, R6 posiblemente prefiera una ruta menos deseable a través de R5 en lugar de a través de R1 para alcanzar la red. La siguiente configuración ayuda a evitar esto mediante la configuración de etiquetas y su posterior redistribución en base a las etiquetas.

R2:

router eigrp 7
network 181.16.0.0
redistribute rip route-map rip_to_eigrp metric 1 1 1 1 1
!--- Redistribuye rutas RIP que están
!--- permitidas por route-map rip_to_eigrp


router rip
version 2
network 178.1.0.0
redistribute eigrp 7 route-map eigrp_to_rip metric 2
!--- Redistribuye rutas EIGRP y configura las etiquetas
!--- de acuerdo con la sentencia eigrp_to_rip route-map

route-map rip_to_eigrp deny 10
match tag 88
!--- Route-map para rechazar cualquier ruta que tenga una etiqueta de "88"
!--- de redistribuirse en EIGRP
!--- Tenga en cuenta que las rutas etiquetas con "88" deben ser las rutas EIGRP
!--- redistribuidas en RIPv2

route-map rip_to_eigrp permit 20
set tag 77
!--- Sentencia Route-map para configurar la etiqueta 
!--- en las rutas RIPv2 redistribuidas en EIGRP a "77"

route-map eigrp_to_rip deny 10
match tag 77
!--- Sentencia Route-map para rechazar cualquier ruta que tenga una etiqueta 
!--- de "77" de su redistribución a RIPv2
!--- Tenga en cuenta que las rutas etiquetas con "77" deben ser las rutas RIPv2
!--- redistribuidas en EIGRP


route-map eigrp_to_rip permit 20
set tag 88
!--- Sentencia Route-map para configurar la etiqueta en rutas EIGRP
!--- redistribuidas en RIPv2 a "88"

R5:

router eigrp 7
network 181.16.0.0
redistribute rip route-map rip_to_eigrp metric 1 1 1 1 1
!--- Redistribuye rutas RIPv2 que están permitidas 
!--- por el route-map rip_to_eigrp


router rip
version 2
network 178.1.0.0
redistribute eigrp 7 route-map eigrp_to_rip metric 2
!--- Redistribuye rutas EIGRP y configura las etiquetas 
!--- de acuerdo con la sentencia eigrp_to_rip route-map


route-map rip_to_eigrp deny 10
match tag 88
!--- Sentencia Route-map para rechazar cualquier ruta que tenga una etiqueta
!--- de "88" de su redistribución en EIGRP
!--- Advierta que las rutas con la etiqueta "88" deben ser las rutas EIGRP
!--- redistribuidas en RIPv2

route-map rip_to_eigrp permit 20
set tag 77
!--- Sentencia Route-map para configurar la etiqueta en las rutas RIP 
!--- redistribuidas en EIGRP a "77"

route-map eigrp_to_rip deny 10
match tag 77
!--- Sentencia Route-map para rechazar cualquier ruta que tenga una etiqueta 
!--- de "77" de su redistribución en RIPv2
!--- Advierta que las rutas con la etiqueta con “77” deben ser las rutas RIPv2
!--- redistribuidas en EIGRP

route-map eigrp_to_rip permit 20
set tag 88
!--- Sentencia Route-map para configurar la etiqueta en las rutas EIGRP 
!--- redistribuidas en RIPv2 a "88"

Con la configuración anterior, puede analizar algunas rutas específicas en la tabla de ruteo para observar que las etiquetas se han configurado. A continuación se muestra la salida del comando show ip route para rutas específicas en R3 y R1:

R3# show ip route 178.1.10.8
Routing entry for 178.1.10.8/30
  Known via "eigrp 7", distance 170, metric 2560512256
  Etiqueta 77, type external
  Redistributing via eigrp 7
  Last update from 181.16.2.10 on Serial0, 00:07:22 ago
  Routing Descriptor Blocks:
  * 181.16.2.10, from 181.16.2.10, 00:07:22 ago, via Serial0
      Route metric is 2560512256, traffic share count is 1
      Total delay is 20010 microseconds, minimum bandwidth is 1 Kbit
      Reliability 1/255, minimum MTU 1 bytes
      Loading 1/255, Hops 1


R1# show ip route 181.16.2.4
Routing entry for 181.16.0.0/16
  Known via "rip", distance 120, metric 2
  Etiqueta 88
  Redistributing via rip
  Last update from 178.1.10.5 on Serial0, 00:00:15 ago
  Routing Descriptor Blocks:
  * 178.1.10.5, from 178.1.10.5, 00:00:15 ago, via Serial0
      Route metric is 2, traffic share count is 1

Ejemplo 3

La redistribución también puede llevarse a cabo entre diferentes procesos del mismo protocolo de ruteo. La siguiente configuración es un ejemplo de una política de redistribución utilizada para la redistribución del proceso de dos EIGRP que se ejecutan en el mismo router o en múltiples routers.

router eigrp 3
 redistribute eigrp 5 route-map to_eigrp_3
 default-metric 10000 100 255 1 1500
!--- Redistribuye EIGRP 5 en EIGRP 3, configurando las etiquetas 
!--- de acuerdo al mapa de rutas "to_eigrp_3"


router eigrp 5
 redistribute eigrp 3 route-map to_eigrp_5
 default-metric 10000 100 255 1 1500
!--- Redistribuye EIGRP 3 en EIGRP 5
!--- Las rutas con la etiqueta 33 no se redistribuirán
!--- a causa de un mapa de rutas "to_eigrp_5"
!--- Si bien el comando default-metric no es necesario al realizar la
!--- redistribución entre diferentes procesos de EIGRP,
!--- puede utilizarlo opcionalmente como se mostró anteriormente para anunciar
!--- las rutas con valores específicos para calcular la métrica.

route-map to_eigrp_3 deny 10
match tag 55
!--- Sentencia de mapa de rutas utilizado para rechazar rutas que tienen una etiqueta
!--- de "55" de su redistribución en EIGRP 3
!--- Advierta que las rutas con la etiqueta "55" deben ser las rutas EIGRP 3
!--- redistribuidas en EIGRP 5

route-map to_eigrp_3 permit 20
 set tag 33
!--- Sentencia de mapa de rutas utilizado para configurar la etiqueta en las rutas
!--- redistribuidas desde EIGRP 5 a EIGRP 3 a "33"

route-map to_eigrp_5 deny 10
 match tag 33
!--- Sentencia de mapa de rutas utilizado para rechazar rutas que tienen una etiqueta
!--- de "33" de su redistribución en EIGRP 5
!--- Advierta que las rutas con la etiqueta "33" deben ser las rutas EIGRP 5
!--- redistribuidas en EIGRP 3

route-map to_eigrp_5 permit 20
set tag 55
!--- Sentencia de mapa de rutas utilizado para configurar la etiqueta en las rutas
!--- redistribuidas desde EIGRP 3 a EIGRP 5 a "55"

Estos son algunos ejemplos de estrategias de filtrado utilizadas para el objetivo de este documento, sin embargo, es posible que existan otras estrategias válida que puede utilizar. Consulte la sección sobre Filtrado de información de ruteo en Configuración de funciones de IP Routing independientes del protocolo para obtener más información.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 8606