Marcado y acceso remotos : Conexiones asíncronas

Configuración de un terminal o servidor de comunicaciones

23 Junio 2008 - Traducción manual
Otras Versiones: PDFpdf | Traducción Automática (31 Julio 2013) | Inglés (29 Enero 2008) | Comentarios

Contenidos

Introducción
Requisitos previos
     Requisitos
     Componentes utilizados
     Convenciones
Cableado
Estrategia de diseño
Configuración
     Diagrama de la red
     Configuraciones
     Resumen de comandos
     Intercambio entre sesiones activas
     Terminación de sesiones activas
Verificación
Resolución de problemas
     Procedimiento de resolución de problemas
Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

Un servidor terminal o de comunicaciones proporciona comúnmente acceso fuera de banda para varios dispositivos. Un servidor terminal es un router con varios puertos asíncronos de baja velocidad que están conectados a otros dispositivos serie, por ejemplo, módems o puertos de consola en routers o switches.

El servidor terminal permite utilizar un único punto para acceder a los puertos de consola de distintos dispositivos. Su uso evita la necesidad de configurar escenarios de respaldo, como módems en puertos auxiliares para cada dispositivo. También se puede configurar un solo módem en el puerto auxiliar del servidor terminal para proporcionar servicios de marcado en caso de fallo de conectividad en la red.

Este documento muestra cómo configurar un servidor terminal para acceder sólo a los puertos de consola en otros routers mediante Telnet inverso. Telnet inverso permite establecer una conexión Telnet desde el mismo dispositivo que se utiliza para este tipo de comunicación, pero en otra interfaz. Para obtener más información acerca de Telnet inverso, consulte Establishing a Reverse Telnet Session to a Modem (Establecimiento de una sesión de Telnet inverso con un módem).

Requisitos previos

Requisitos

No hay requisitos específicos para este documento.

Componentes utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y hardware.

Convenciones

Si desea más información sobre las convenciones del documento, consulte Cisco Technical Tips Conventions (Convenciones sobre consejos técnicos de Cisco).

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración despejada (predeterminada). Si la red está en producción, asegúrese de comprender el impacto que pueda tener cualquier comando.

Cableado

Los routers Cisco series 2509-2512 utilizan un conector de 68 pines y un cable de conexión. Este cable (CAB-OCTAL-ASYNC) proporciona ocho puertos asíncronos de cable enrollado RJ-45 en cada conector de 68 pines. Puede conectar cada puerto asíncrono de cable enrollado RJ-45 al puerto de consola de un dispositivo. El router 2511 permite tener acceso de forma remota a un máximo de 16 dispositivos. Asimismo, los módulos de red asíncronos de alta densidad NM-16A o NM-32A están disponibles para los routers Cisco series 2600 y 3600 para ofrecer la misma función. Para obtener más información sobre el cableado, consulte Let's Connect:Your Serial Cable Guide (Establezcamos conexión: La guía del cableado serie) y Cabling Guide for Console and AUX Ports (Guía de cableado para puertos de consola y AUX).

Nota: los puertos asíncronos del conector de 68 pines son dispositivos de equipos de terminales de datos (DTE). Los dispositivos DTE a DTE requieren un cable enrollado (módem nulo) y los dispositivos DTE a equipos de terminación de circuitos de datos (DCE), un cable de conexión directa. El cable CAB-OCTAL-ASYNC es enrollado. Por tanto, es posible conectar cada cable directamente a los puertos de consola de los dispositivos con interfaces RJ-45. No obstante, si el puerto de consola del dispositivo en el que realiza la conexión es una interfaz de 25 pines (DCE), se debe utilizar el adaptador RJ-45 a 25 pines marcado como "Modem" (para invertir el "enrollado") a fin de completar la conexión.

En esta tabla se muestran los tipos de puerto de consola y auxiliares en routers y switches de Cisco:

Tipo de interfaz

Interfaz DB25

Interfaz RJ-45

Consola

DCE

DTE

AUX

DTE

DTE

Estrategia de diseño

Configure el servidor terminal para que pueda tener acceso a él desde cualquier sitio. Para ello, asigne una dirección de Internet pública registrada y ubique el servidor fuera del firewall, de modo que los problemas del firewall no interrumpan su conexión. Puede mantener en todo momento la conectividad con el servidor terminal y tener acceso a los dispositivos conectados. Si le preocupa la seguridad, configure listas de acceso para permitir sólo el acceso al servidor terminal desde ciertas direcciones. Para contar con una solución de seguridad más fiable, también puede configurar el subsistema de autenticación, autorización y contabilidad (AAA) basado en servidor, por ejemplo, RADIUS o TACACS+. Para obtener más información acerca de AAA, consulte Cisco AAA Implementation Case Study (Estudio de caso de implementación de AAA de Cisco).

Puede configurar un módem en el puerto auxiliar del servidor terminal como respaldo de marcado en caso de fallo en la conexión principal (a través de Internet). Un módem como éste elimina la necesidad de configurar un respaldo de marcado para cada dispositivo. El servidor terminal está conectado a través de sus puertos asíncronos a los puertos de consola de los demás dispositivos. Para obtener más información sobre cómo conectar un módem al puerto AUX, consulte Modem-Router Connection Guide (Guía de conexión de un módem y un router).

Utilice el comando ip default gateway y señale el router de salto siguiente en Internet. Este comando le permite tener conectividad con el servidor terminal a través de Internet aunque el enrutamiento no esté habilitado. Por ejemplo, el servidor terminal está en modo de monitor ROM (ROMmon) debido a un reinicio incorrecto después de una interrupción en el suministro eléctrico.

Configuración

En esta sección se presenta la información para configurar las funciones descritas en este documento.

Nota: para buscar información adicional sobre los comandos utilizados en este documento, emplee la herramienta de búsqueda de comandos ( sólo para clientes registrados) .

Diagrama de la red

Este documento utiliza esta configuración de red:

Com_Srv.gif

Configuraciones

En este documento se utiliza la siguiente configuración:

  • Cisco 2511

Cisco 2511

aus-comm-server#show running-config
!
version 12.0

service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname aus-comm-server
!
enable secret  <deleted>
!
username cisco password <deleted>
!
ip subnet-zero
ip domain-list cisco.com
no ip domain-lookup

ip host 3600-3 2014 172.21.1.1

                     !--- El host 3600-3 se conecta al puerto 14 del servidor de comunicaciones.
!--- Asegúrese de que la dirección IP sea la de una interfaz en el servidor de comunicaciones.
                  
ip host 3600-2 2013 172.21.1.1
ip host 5200-1 2010 172.21.1.1
ip host 2600-1 2008 172.21.1.1
ip host 2509-1 2007 172.21.1.1
ip host 4500-1 2015 172.21.1.1
ip host 3600-1 2012 172.21.1.1
ip host 2511-2 2002 172.21.1.1
ip host 2511-rj 2003 172.21.1.1
ip host 2511-1 2001 172.21.1.1
ip host 5200-2 2011 172.21.1.1
ip host 2520-1 2004 172.21.1.1
ip host 2520-2 2005 172.21.1.1
ip host 2600-2 2009 172.21.1.1
ip host 2513-1 2006 172.21.1.1
ip host pix-1 2016 172.21.1.1
!
!
process-max-time 200
!
interface Loopback1
 ip address 172.21.1.1 255.0.0.0

                     !--- Esta dirección se utiliza en los comandos de host IP.
!--- Trabaje con interfaces de bucle de retorno, que son virtuales y están siempre disponibles.
                  
 no ip directed-broadcast
!
interface Ethernet0
 ip address 171.55.31.5 255.255.255.192

                     !---  Utilice una dirección IP pública para garantizar la conectividad.
                  
No ip directed-broadcast
 no ip mroute-cache
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
!
ip default-gateway 171.55.31.1

                     !--- Esta es la gateway predeterminada cuando el enrutamiento está inhabilitado.
!--- Por ejemplo, cuando el router está en modo de ROM de inicio.
                  
ip classless
ip route 0.0.0.0 0.0.0.0 171.55.31.1

                     !--- Establezca la ruta predeterminada para la red externa.
                  
no ip http server
!
line con 0
 transport input all
 line 1 16
 session-timeout 20

                     !--- El tiempo de espera de la sesión se agota después de 20 minutos de inactividad.
                  
no exec

                     !--- No se inician señales no deseadas desde el dispositivo conectado.
!--- Una sesión EXEC garantiza que la línea no deje de estar disponible
!--- debido a un proceso EXEC no autorizado.
                  
 exec-timeout 0 0

                     !--- Esto inhabilita exec timeout transport input all.
!--- Permita que todos los protocolos utilicen la línea.
!--- Configure las líneas 1-16 con al menos Telnet de entrada de transporte.
                  
line aux 0

                     !--- El puerto auxiliar puede proporcionar respaldo de marcado a la red.
!--- Nota: esta configuración no implementa el módem en la entrada y salida de su puerto AUX.
!--- Permita que el puerto auxiliar admita conexiones de marcado de entrada y de salida.
                  
 transport preferred telnet
 transport input all
 speed 38400
 flowcontrol hardware
line vty 0 4
 exec-timeout 60 0
 password <deleted>
login
!
end

Nota: si utiliza Cisco 3600 como servidor de acceso, consulte How Async Lines are Numbered in Cisco 3600 Series Routers (Cómo se numeran las líneas asíncronas en los routers Cisco serie 3600) para conocer detalles de los números de línea.

Resumen de comandos

ip host: use este comando para definir la correlación entre el nombre y la dirección del host estático en la caché del host. Para eliminar la correlación entre el nombre y la dirección, utilice la forma no de este comando.

  • ip host name [tcp-port-number] address1 [address2...address8]

    • name : este campo indica el nombre del host. No es necesario que el campo de nombre coincida con el nombre real del router al que desea conectarse. De todos modos, asegúrese de escribir un nombre que desee utilizar en Telnet inverso. Cuando se utiliza este comando y el campo de nombre, no es necesario conocer el número de puerto real del dispositivo remoto.

    • tcp-port-number : este campo representa el número de puerto TCP al que desea conectarse cuando utiliza el nombre de host definido junto con un comando EXEC connect o telnet. En la configuración de ejemplo se emplea Telnet inverso para que el número de puerto sea el número de línea 2000+.

    • address1 : este campo representa una dirección IP asociada. En nuestro ejemplo de configuración se usa la dirección IP de bucle de retorno.

transport input: ejecute este comando para definir los protocolos que se utilizan para conectarse a una línea específica del router.

  • transport input {all | lat | mop | nasi | none | pad | rlogin | telnet | v120}

    • all : selecciona todos los protocolos.

    • none : impide cualquier selección de protocolo en la línea. En este caso, el puerto queda inutilizable para conexiones entrantes.

    Nota: en nuestro ejemplo de configuración, las líneas asíncronas emplean la configuración mínima del comando transport input telnet. Puede comunicarse vía Telnet con los dispositivos en la línea asíncrona.

telnet: utilice este comando EXEC para iniciar sesión en un host que admita Telnet.

  • telnet host [port] [keyword]

    • host : indica un nombre de host o dirección IP. El host puede ser uno de los campos de nombre definidos en el comando ip host.

    • port : este campo indica un número decimal de puerto TCP. El puerto del router Telnet (decimal 23) en el host indica el número decimal predeterminado del puerto TCP. Para Telnet inverso, el número de puerto debe ser el número de línea 2000+. Los números de línea van de 1 a 16 en nuestra configuración. Utilice el comando EXEC show line para ver las líneas disponibles.

Intercambio entre sesiones activas

Siga estos pasos para alternar entre sesiones activas:

  1. Utilice la secuencia de escape Ctrl-Mayús-6 y, a continuación, x para salir de la sesión actual.

  2. Use el comando show sessions para mostrar todas las conexiones abiertas.

    aus-comm-server#show sessions
    
                      Conn Host      Address         Byte Idle  Conn Name
       1 2511-1    171.69.163.26   0     0     2511-1
       2 2511-2    171.69.163.26   0     0     2511-2
     * 3 2511-3    171.69.163.26   0     0     2511-3

    Nota: el asterisco (*) indica la sesión de terminal actual.

  3. Introduzca el número de sesión (conn) para conectarse al dispositivo correspondiente. Por ejemplo, para conectarse al router 2511-1, escriba 1, que es el número de conexión. Sin embargo, si pulsa la tecla de retorno, se conecta a la sesión de terminal actual, que en este caso es el router 2511-3.

Terminación de sesiones activas

Siga estos pasos para terminar una determinada sesión de Telnet:

  1. Utilice la secuencia de escape Ctrl-Mayús-6 y, a continuación, x para salir de la sesión de Telnet actual.

    Nota: asegúrese de ejecutar en forma fiable la secuencia de escape para suspender una sesión de Telnet. Algunos paquetes de emuladores de terminales no pueden enviar la secuencia correcta, Ctrl-Mayús-6 y, a continuación, x.

  2. Ejecute el comando show sessions para mostrar todas las conexiones abiertas.

  3. Ejecute el comando disconnect [connection] para desconectar la sesión requerida.

Verificación

En esta sección encontrará información que puede utilizar para confirmar que la configuración funciona adecuadamente.

Algunos comandos show son compatibles con la herramienta intérprete de resultados ( sólo para clientes registrados) , que permite ver un análisis del resultado del comando show.

  • show ip interface brief : indica si la interfaz que utiliza para la sesión de Telnet está activa.

Resolución de problemas

En esta sección encontrará información que puede utilizar para solucionar problemas sobre la configuración.

Procedimiento de resolución de problemas

Siga estas instrucciones para resolver los problemas de configuración.

Si no puede conectarse a un router de su elección con un nombre configurado en el comando ip host:

  1. Compruebe si la dirección de puerto está configurada correctamente.

  2. Verifique si la dirección (interfaz) utilizada por Telnet inverso está activa. El resultado del comando show ip interface brief proporciona este tipo de información. Cisco recomienda utilizar bucles de retorno, dado que siempre están activos.

  3. Asegúrese de tener el tipo de cable correcto. Por ejemplo, no debe utilizar un cable de cruce para ampliar la longitud. Consulte la sección Cableado para obtener más información.

  4. Establezca una conexión Telnet con el puerto de la dirección IP para probar la conectividad directa. Debe comunicarse vía Telnet desde un dispositivo externo y el servidor terminal. Por ejemplo, telnet 172.21.1.1 2003.

  5. Asegúrese de que el comando transport input telnet está debajo de la línea para el dispositivo de destino. El dispositivo de destino es el conectado al servidor terminal.

  6. Utilice un terminal o equipo en silencio para conectarse directamente a la consola del router objetivo. El router objetivo es el dispositivo conectado al servidor terminal. Este paso le ayuda a identificar si hay algún problema con el puerto.

  7. Si se desconecta, verifique los tiempos de espera. Puede quitarlos o ajustarlos.

    Nota: si se producen fallos de autenticación, recuerde que el servidor terminal realiza la primera autenticación (si está configurado para ello), mientras que el dispositivo al que intenta conectarse realiza la segunda autenticación (si también está configurado para ello). Verifique si el subsistema AAA está configurado correctamente tanto en el servidor terminal como en el dispositivo de conexión.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 5466