Switches : Cisco Nexus 9000 Series Switches

Configure y verifique la Unidad máxima de transmisión (MTU) en las Plataformas del nexo de Cisco

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (11 Agosto 2015) | Comentarios

Introducción

Este documento describe cómo configurar y verificar la Unidad máxima de transmisión (MTU) (MTU) en el Switches del nexo de Cisco.

Contribuido por la caza de Amanda, ingeniero de Cisco TAC.

Prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

Configurar

Configuraciones de la capa 3 MTU

MTU en una configuración del Switched Virtual Interface (SVI)

Switch(config)#interface vlan 1
Switch(config-if)#mtu 9216

MTU en una configuración del puerto de la capa 3

Switch(config)#interface ethernet 1/1
Switch(config-if)#no switchport
Switch(config-if)#mtu 9216

Configuraciones de la capa 2 MTU

La capa 2 MTU se puede fijar a través de la red política de calidad de servicio (QoS) o configurando el puerto sí mismo en el Switches que soporta el MTU por puerto. Solamente los nexos 3048, 3064, 7000, 7700, 9000, y 9300 soportan el MTU por puerto.

Nexo 3100, configuración 3500, 5000, 5500, y 6000

Para configurar el MTU elevado en los 5000, 5500, y 6000 switchess del nexo 3100, 3500, crear una directiva de la red-qos o modificar una política existente para especificar el MTU elevado. Esta configuración se aplica a todos los puertos. Esto incluye cualquier puerto del suplemento de la tela de Cisco (FEX) conectado con el Switch. El MTU por puerto no se soporta.

policy-map type network-qos jumbo
class type network-qos class-default
mtu 9216
system qos
service-policy type network-qos jumbo

Nexo 3048, configuración 3064, 7000, 7700, 9000, y 9300

Para configurar el MTU en una basada en cada puerto, esta configuración es necesaria:

Switch(config)#interface ethernet 1/1
Switch(config-if)#mtu 9216

Configuración del nexo 7000

Cuando usted configura FEX MTU, un más extenso política de calidad de servicio (QoS) se necesita en la versión 6.2 y posterior:

Switch(conf)#class-map type network-qos match-any c-nq-8e-custom
(config-cmap-nqos)#match cos 0-7

Nota: Si usted no está seguro que la plantilla para utilizar, ingresa el comando de la red-qos del tipo del sistema del directiva-mapa de la demostración para considerar la plantilla actualmente usada.

Switch(config)#policy-map type network-qos nq-8e-custom template 8e    
Switch(config-pmap-nqos)#class type network-qos c-nq-8e-custom
Switch(config-pmap-nqos-c)#congestion-control tail-drop
Switch(config-pmap-nqos-c)#mtu 9216

Switch(config)#system qos
Switch(config-sys-qos)#service-policy type network-qos nq-8e-custom

Configuración 2000 del nexo

Nota: El nexo 2000 MTU se fija con la configuración de las Tramas gigantes en el Switch del padre. Para el Switches del padre que permite el jumbo en una basada en cada puerto, configure el canal del puerto de la tela FEX (FPC). Si el Switch del padre requiere una directiva de la red-qos entonces el jumbo se fija con la configuración del Switch del padre política de calidad de servicio (QoS). Estos cambios se empujan automáticamente hacia abajo al FEX en ambos casos.

Canal de puerto de la tela (FPC) en la configuración del switch del nexo del padre

interface port-channel136
switchport mode fex-fabric
fex associate 136
vpc 136
mtu 9216

Nota: El nexo 7000 no permite que usted fije FEX MTU con el FPC en la versión 6.2 y posterior. Usted debe en lugar de otro crear una aduana política de calidad de servicio (QoS) mientras que la configuración siguiente muestra.

Permita las Tramas gigantes en configuración del nexo 7000 FEX

Nota: Modifique la plantilla actualmente funcionando. Para encontrar la plantilla actual funcionando, ingrese el comando de la red-qos del tipo del sistema del directiva-mapa de la demostración.

Switch(conf)#class-map type network-qos match-any c-nq-8e-custom 
(config-cmap-nqos)#match cos 0-7

Switch(config)#policy-map type network-qos nq-8e-custom template 8e
Switch(config-pmap-nqos)#class type network-qos c-nq-8e-custom
Switch(config-pmap-nqos-c)#congestion-control tail-drop
Switch(config-pmap-nqos-c)#mtu 9216

Switch(config)#system qos
Switch(config-sys-qos)#service-policy type network-qos nq-8e-custom

Red política de calidad de servicio (QoS) en la configuración del switch del nexo del padre

policy-map type network-qos jumbo
class type network-qos class-default
mtu 9216
system qos
service-policy type network-qos jumbo

Verificación

Utilize esta sección para confirmar que su configuración funcione correctamente.

La herramienta del Output Interpreter (clientes registrados solamente) soporta los ciertos comandos show. Utilice la herramienta del Output Interpreter para ver una análisis de la salida del comando show.

Capa 3 MTU

Verifique la capa 3 MTU en todas las Plataformas del nexo con el comando del x/y del eth de la interfaz de la demostración como este ejemplo muestra:

Nexus#show interface ethernet 1/19
Ethernet1/19 is up
Dedicated Interface
Hardware: 100/1000/10000 Ethernet, address: 547f.ee5d.413c (bia 547f.ee5d.40fa)
MTU 9216 bytes, BW 1000000 Kbit, DLY 10 usec

Verifique SVI MTU con el comando x vlan de la interfaz de la demostración como esta salida muestra:

Leaf3#show interface vlan 1
Vlan1 is down (Non-routable VDC mode), line protocol is down
Hardware is EtherSVI, address is 547f.eed8.ec7c
Internet Address is 1.1.1.1/23
MTU 9216 bytes, BW 1000000 Kbit, DLY 10 usec

Capa 2 MTU

Esta sección describe cómo verificar la capa 2 MTU por la plataforma. Los comandos se funcionan con del Switch del padre.

Nexo 3100, 3500, 5000, 5500, y 6000

Nexus#show queuing interface ethernet 1/1
Ethernet1/1 queuing information:
TX Queuing
qos-group sched-type oper-bandwidth
0 WRR 100
RX Queuing
qos-group 0
q-size: 469760, HW MTU: 9216 (9216 configured)

Nexo 3000, 7000, 7700, 9000

Nexus#show interface ethernet 1/12
Ethernet1/12 is up
admin state is up, Dedicated Interface
Hardware: 1000/10000 Ethernet, address: 7c0e.ceca.f183 (bia 7c0e.ceca.f183)
MTU 9216 bytes, BW 10000000 Kbit, DLY 10 usec

Nexo 2000

Nota: Cuando usted cambia el FEX MTU, el FEX aumenta su MTU a una cantidad más alta pero predeterminada que no haga juego el valor configurado exactamente. El dispositivo del padre aplica el MTU configurado en el canal del puerto de la tela FEX (FPC).

Para FEX conectado con el nexo 5000, 6000, y 7000:

Nexus#show queuing interface ethernet 136/1/1
if_slot 68, ifidx 0x1f870000
Ethernet136/1/1 queuing information:
Input buffer allocation:
Qos-group: 0
frh: 3
drop-type: drop
cos: 0 1 2 3 4 5 6 7
xon xoff buffer-size
---------+---------+-----------
19200 78080 90880

Queueing:
queue qos-group cos priority bandwidth mtu
--------+------------+--------------------+---------+----------------+--------
3 0 0 1 2 3 4 5 6 WRR 100 9280

Para FEX conectado con el nexo 9000:

9396-B#show interface ethernet 104/1/1
Ethernet104/1/1 is up
admin state is up,
Hardware: 100/1000 Ethernet, address: 5475.d0e0.e5c2 (bia 5475.d0e0.e5c2)
MTU 9216 bytes, BW 1000000 Kbit, DLY 10 usec

Troubleshooting

Esta sección proporciona la información que usted puede utilizar para resolver problemas su configuración.

La herramienta del Output Interpreter (clientes registrados solamente) soporta los ciertos comandos show. Utilice la herramienta del Output Interpreter para ver una análisis de la salida del comando show.

Nota: Consulte Información Importante sobre Comandos de Debug antes de usar un comando debug.

Es a veces necesario verificar los cambios en el software. Para hacer esto, marque al administrador del acceso de Ethernet (ethpm) para verificar que los cambios fueron avanzados a través del software en cualquier plataforma:

Switch#show system internal ethpm info interface eth 6/5 | egrep -i mtu
medium(broadcast), snmp trap(on), MTU(4000)

Es también posible en los módulos M1, M2, F1 y F2 verificar en hardware que los cambios fueran empujados hacia abajo:

module-1#show hardware internal mac port 20 state | i MTU
GD: Port speed Undecided GD MTU 10240 (fixed to max), PL MTU 9238 mode 0

Defectos conocidos

Id. de bug Cisco CSCuf20035 - (nexo 7000) los cambios FEX MTU no toman el efecto sobre las colas de administración del tráfico FEX.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 118994