Switches : Switches Cisco Nexus de la serie 7000

Ejemplo de la Configuración de RSPAN del 7000 Series Switch del nexo

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento describe cómo configurar una sesión remota del Switched Port Analyzer (RSPAN) sobre un 7000 Series Switch del nexo que monitoree el tráfico entre los accesos de Ethernet en dos diversos 7000 Series Switch del nexo.

prerrequisitos

Requisitos

Asegúrese de cumplir estos requisitos antes de intentar esta configuración:

  • Tenga conocimiento básico de la configuración en los 7000 Series Switch del nexo

  • Tenga conocimiento básico del Switched Port Analyzer remoto (el RSPAN)

Componentes Utilizados

La información en este documento se basa en los dispositivos de las 7000 Series NX-OS del nexo.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las convenciones sobre documentos.

Antecedentes

Usted puede utilizar el Switched Port Analyzer (SPAN) para analizar el tráfico de la red que pasa con los puertos o los VLA N del Switch, que envían una copia del tráfico a un puerto destino en donde el analizador de red conecta con el Switch.

Para ampliar el SPAN, el RSPAN habilita la supervisión remota de los switches múltiples a través de su red. El 7000 Series Switch del nexo se limita en lo que puede hacer con el RSPAN. Un VLA N RSPAN no se puede utilizar como destino del SPAN. Por lo tanto, el 7000 Switch del nexo puede utilizar solamente el RSPAN como un VLA N del transitar o VLA N de la fuente y tirar de los datos del VLA N RSPAN. Usted no puede poner cualquier cosa en el VLA N RSPAN del 7000 Switch del nexo.

Configurar

Este ejemplo de configuración utiliza los puertos de origen en dos diversos 7000 Series Switch del nexo y un puerto destino en un 7000 Switch del nexo en donde el analizador de red ha conectado. Los Ethernetes separados 1/1 link se configuran entre los dos dispositivos: un link como destino del palmo y el otro conectan como acceso al VLA N RSPAN.

Nota: Utilice la herramienta Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos utilizados en esta sección.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

http://www.cisco.com/c/dam/en/us/support/docs/switches/nexus-7000-series-switches/113438-rspan-nexus-7000-01.jpg

Este ejemplo utiliza los puertos enumerados en esta tabla:

Dispositivo Puerto de Origen Puerto de Destino
Nexo 1 Ethernetes 2/15 y 2/16 Ethernetes 1/1
Nexo 2 Ethernetes 1/1, 2/26 a 2/28 Ethernetes 2/37 a 2/40

Del 1 Switch del nexo, el tráfico del SPAN de la fuente se lleva al puerto destino y se copia sobre el VLA N RSPAN. El tráfico entonces se remite sobre el link al 2 Switch del nexo en los Ethernetes 1/1 interfaz. Después, el tráfico VLAN RSPAN se envía al puerto destino en donde el dispositivo, tal como el dispositivo de SwitchProbe o la otra sonda o dispositivo de seguridad del Monitoreo remoto (RMON), puede recibir y analizar los paquetes.

Configuraciones

En este documento, se utilizan estas configuraciones:

Nexo 1
Nexus1#configure terminal


!--- Configure the interface VLAN 15 as RSPAN VLAN.

Nexus1(config)#vlan 15 
Nexus1(config-vlan)#remote-span
Nexus1(config-vlan)#exit



!--- Configure the switchport interface as a SPAN destination.

Nexus1(config)#interface ethernet 1/1
Nexus1(config-if)#switchport monitor
Nexus1(config-if)#no shutdown
Nexus1(config-if)#exit



!--- Configure the SPAN session.

Nexus1(config)#monitor session 1


!---Configure the source port.

Nexus1(config-monitor)#source interface ethernet 2/15-16


!--- Configure the destination port.

Nexus1(config-monitor)#destination interface ethernet 1/1


!--- Enable the SPAN session (by default the session is in shutdown state).

Nexus1(config-monitor)#no shut
Nexus1(config-monitor)#exit

Nexo 2
Nexus2#configure terminal


!--- Configuration of interface VLAN 15 as RSPAN VLAN.

Nexus2(config)#vlan 15 
Nexus2(config-vlan)#remote-span
Nexus2(config-vlan)#exit


!--- Configure the switchport interface to access in RSPAN VLAN.

Nexus2(config)#interface ethernet 1/1
Nexus2(config-if)#switchport mode access
Nexus2(config-if)#switchport access vlan 15
Nexus2(config-if)#no shutdown
Nexus2(config-if)#exit



!--- Configure the switchport interfaces as a SPAN destination.

Nexus2(config)#interface ethernet 2/37-40
Nexus2(config-if)#switchport monitor
Nexus2(config-if)#exit



!--- Configure the SPAN session.

Nexus2(config)#monitor session 1


!--- Configure the source port.

Nexus2(config-monitor)#source interface ethernet 2/26-28
Nexus2(config-monitor)#source vlan 15


!--- Configure the destination port.

Nexus2(config-monitor)#destination interface ethernet 2/37-40


!--- Enable the SPAN session (by default the session is in shutdown state).

Nexus2(config-monitor)#no shut
Nexus2(config-monitor)#exit

Verificación

Use esta sección para confirmar que su configuración funciona correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilice la OIT para ver un análisis del resultado del comando show.

Aquí están algunos de los Comandos de verificación del SPAN y RSPAN:

Nexo 1:

  • Utilice el comando show monitor para visualizar el estatus de las sesiones de RSPAN.

    Nexus1# show monitor
    Session  State        Reason                  Description
    -------  -----------  ----------------------  --------------------------------
    1        up           The session is up
  • Utilice el comando del [session session_number] de la sesión de monitoreo de la demostración para visualizar ERSPAN la configuración de la sesión.

    Nexus1# show monitor session 1
       session 1
    ---------------
    type              : local
    state             : up
    source intf       :
        rx            : Eth1/15       Eth1/16
        tx            : Eth1/15       Eth1/16
        both          : Eth1/15       Eth1/16
    source VLANs      :
        rx            :
        tx            :
        both          :
    filter VLANs      : filter not specified
    destination ports : Eth1/1
    
    Legend: f = forwarding enabled, l = learning enabled
  • Utilice el comando all de la sesión de monitoreo de la demostración para visualizar todos ERSPAN configuración de las sesiones en el dispositivo.

Nexo 2:

  • Utilice el comando show monitor para visualizar el estatus ERSPAN de las sesiones.

    Nexus2# show monitor
    Session  State        Reason                  Description
    -------  -----------  ----------------------  --------------------------------
    1        up           The session is up
  • Utilice el comando del [session session_number] de la sesión de monitoreo de la demostración para visualizar ERSPAN la configuración de la sesión.

    Nexus2# show monitor session 1
       session 1
    ---------------
    type              : local
    state             : up
    source intf       :
        rx            : Eth1/21       Eth1/22       Eth1/23
        tx            : Eth1/21       Eth1/22       Eth1/23
        both          : Eth1/21       Eth1/22       Eth1/23
    source VLANs      :
        rx            : 15
        tx            : 15
        both          : 15
    filter VLANs      : filter not specified
    destination ports : Eth1/27       Eth1/28       Eth1/29       Eth1/30
    
    Legend: f = forwarding enabled, l = learning enabled

Información Relacionada


Document ID: 113438