Administración de redes : Cisco Discovery Protocol (CDP)

Comportamiento del protocolo cisco discovery entre el Routers y el Switches

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios

Introducción

Este documento describe el comportamiento del Cisco Discovery Protocol (CDP) entre un router y un Switch que ejecuten el ® del Cisco IOS.

El CDP es el protocolo propietario de la capa 2 de Cisco que es media y protocolo independiente, y se ejecuta en todo el equipo Cisco-manufacturado. Los dispositivos de Cisco mandan los avisos CDP a la dirección de destino de Multicast 01-00-0c-cc-cc-cc cada interfaz de red conectada. Estos paquetes de multidifusión son recibidos por los switches Cisco y otros dispositivos de red que soportan el CDP a través de su interfaz de red conectada.

Contribuido por Meghana Tandon, Sumanth Srinath, y Vishnu Asok, ingenieros de Cisco TAC.

Prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware. Este documento se aplica a todos los routeres Cisco y Switches que funcionen con el Cisco IOS.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Temporizador CDP y tiempo en espera CDP

Por abandono, los avisos CDP se envían cada 60 segundos en las interfaces que soportan las encabezados (RÁPIDAS) del Subnetwork Access Protocol, que incluyen los Ethernetes, Frame Relay, y atmósfera. El tiempo en espera especifica el curso de la vida de una entrada en la tabla. Es decir, si no se recibe ningunos avisos de un dispositivo por un período superior al holdtime, se desecha la información del dispositivo (valor por defecto 180 segundos).

Para cambiar el temporizador CDP predeterminado (60 segundos) y el holdtime CDP (180 segundos), ingrese el temporizador cdp y los comandos de configuración del Cisco IOS del holdtime cdp respectivamente. Los cambios se pueden verificar con el comando show cdp, que muestra la configuración CDP de los dispositivos actuales.

Router#show cdp
Global CDP information:
        Sending CDP packets every 60 seconds
        Sending a holdtime value of 180 seconds
        Sending CDPv2 advertisements is enabled

El CDP, por abandono, se habilita en todas las interfaces. Sin embargo, hay una opción para inhabilitar el CDP para el router en su conjunto o en a por la base de la interfaz.

Topología

Configuración del switchConfiguración del router
Switch#show run int fa1/0/23

Building configuration...
Current configuration : 267 bytes
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 10
 switchport mode trunk
 power inline never 
 spanning-tree portfast
 spanning-tree guard root
end


int vlan 10
ip address 10.111.51.3 255.255.255.224
int vlan 21
ip address 10.111.48.3 255.255.255.128
Router#show run int gi0/1
interface GigabitEthernet0/1
  no ip address
  no ip redirects
  duplex auto
  speed auto
 media-type rj45
end


interface GigabitEthernet0/1.1
  encapsulation dot1Q 1
  shutdown
end

interface GigabitEthernet0/1.10
 encapsulation dot1Q 10
 ip address 10.111.51.1 255.255.255.224
 end

interface GigabitEthernet0/1.21
 encapsulation dot1Q 21
 ip address 10.111.48.1 255.255.255.128
 end

La interfaz en el router tiene subinterfaces gi0/0.1, gi0/0.10, y gi0/0.21 del dot1q configurado con el VLAN1, 10, y 21 respectivamente. La interfaz en el Switch es un link de troncal donde se permiten todos los VLA N.

Router#show ip int brief

Interface                  IP-Address      OK? Method Status             Protocol
GigabitEthernet0/0         10.106.68.151   YES DHCP   up                    up
GigabitEthernet0/1         unassigned      YES NVRAM  up                    up
GigabitEthernet0/1.1       unassigned      YES unset  administratively down down
GigabitEthernet0/1.10      10.111.51.1     YES manual up                    up
GigabitEthernet0/1.21      10.111.48.1     YES manual up                    up

El Switch muestra al router como vecino CDP válido como se muestra aquí:

Switch#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Router           Fas 1/0/23        145             R S I  3845      Gig 0/1.10

El mismo comando en el router no revela directamente el switch conectado.

Router#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID

Ejecute un debug para el CDP para ayudar a determinar la razón (debug cdp {paquetes | adyacencia | eventos}).

Abre una sesión al router

Esta entrada se encuentra en el caché.

CDP-PA: version 2 packet sent out on GigabitEthernet0/1 --->the packet is sent out on gi0/1

Abre una sesión el Switch

CDP-PA: version 2 packet sent out on FastEthernet1/0/23
CDP-EV: No space for insertion of civic location
CDP-EV: No space (1068) for insertion of location information.
CDP-PA: Packet received from Router on interface FastEthernet1/0/23

Según los registros anteriores, el router no recibió ninguna paquetes CDP del Switch en las interfaces conectadas unas de los. La interfaz con la encapsulación del dot1q administrativo se apaga. Así, cuando el Switch envía el paquete CDP, el paquete es desechado por el router.

Nota: En el router, la subinterfaz con la encapsulación más baja VLAN/dot1q se selecciona como la subinterfaz preferida para llevar los paquetes CDP. En el Switch, el tráfico CDP se prefiere siempre en el VLA N más bajo configurado. Es decir, VLAN1 siempre, que no se pueden borrar de la base de datos de VLAN. El protocolo CDP se comporta diferentemente cuando el Switch envía el CDP como dependiente del paquete con Tag o del paquete sin Tag sobre el VLAN nativo configurado en el link de troncal.

En el Switch, el tráfico CDP se prefiere siempre en el VLA N más bajo configurado. Es decir, VLAN1 siempre, que no se pueden borrar de la base de datos de VLAN.

El protocolo CDP se comporta diferentemente cuando el Switch envía el CDP como dependiente del paquete con Tag o del paquete sin Tag sobre el VLAN nativo configurado en el link de troncal.

Escenario 1: El Switch envía un paquete CDP marcado con etiqueta

Switch configuration:
interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 10
 switchport mode trunk
 end

Caso 1: La subinterfaz que tiene VLAN1 configurado en el router es up/up

interface GigabitEthernet0/1.1
  encapsulation dot1Q 1
end


interface GigabitEthernet0/1.10
 encapsulation dot1Q 10
 ip address 10.111.51.1 255.255.255.224
end

interface GigabitEthernet0/1.21
 encapsulation dot1Q 21
 ip address 10.111.48.1 255.255.255.128
 end


GL.S.14-3800-8#show ip int brief

Interface                  IP-Address      OK? Method Status             Protocol
GigabitEthernet0/0         10.106.68.151   YES DHCP   up                    up
GigabitEthernet0/1         unassigned      YES NVRAM  up                    up
GigabitEthernet0/1.1       unassigned      YES unset  up                    up
GigabitEthernet0/1.10      10.111.51.1     YES manual up                    up
GigabitEthernet0/1.21      10.111.48.1     YES manual up                    up

El Switch envía el paquete CDP en el VLAN1 que serán recibidos por el router como paquete con Tag. El router marca para ver si ningunas de sus subinterfaces se configuran con la encapsulación del dot1q del VLAN1 y están PARA ARRIBA. Si este control es acertado entonces el paquete CDP es procesado por el router en el gigabitethernet 0/1.1.

El router generará un paquete CDP en la subinterfaz con el número menor que es up/up y configurado con la encapsulación del dot1q del VLAN1 (o el VLA N más bajo).

En este escenario, el router envía los paquetes CDP untagged en gi0/1.1 que sean recibidos por el Switch en FastEthernet1/0/23.

Abre una sesión el Switch

CDP-PA: paquete de la versión 2 enviado en FastEthernet1/0/23. Esta entrada se encuentra en el caché.

CDP-PA: Packet received from Router on interface FastEthernet1/0/23

Abre una sesión al router 

CDP-PA: paquete de la versión 2 enviado en GigabitEthernet0/1.1. CDP-PA: Paquete recibido del Switch en la interfaz GigabitEthernet0/1.1. Esta entrada se encuentra en el caché.

CDP-EV: Lookup for ip phone with idb= GigabitEthernet0/1.1
ip= 10.111.51.3 mac= 0021.567e.e219 platform= cisco WS-C3750-24P

Ingrese el comando show cdp neighbor en el router.

Switch#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Router          Fas 1/0/23        149             R S I  3845      Gig 0/1.1

Ingrese el comando show cdp neigh en el router.

Router#show cdp neigh

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge>
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,>
                  D - Remote, C - CVTA, M - Two-port Mac Relay>

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID>
Switch          Gig 0/1.1          158             S I   WS-C3750- Fas 1/0/23

Caso 2: Cambie la configuración en las interfaces del router de modo que usted no tenga ninguna subinterfaz con el VLAN1

!

interface GigabitEthernet0/1.1
 end
!

Router#show ip interface brief

Interface                  IP-Address      OK? Method Status             Protocol
GigabitEthernet0/0         10.106.68.151   YES DHCP   up                    up
GigabitEthernet0/0.1       unassigned      YES unset  up                    up
GigabitEthernet0/1         unassigned      YES NVRAM  up                    up
GigabitEthernet0/1.1       unassigned      YES unset  up                    up
GigabitEthernet0/1.10      10.111.51.1     YES manual up                    up
GigabitEthernet0/1.21      10.111.48.1     YES manual up                    up

Análisis

El Switch envía el paquete con Tag CDP en fa1/0/23. Cuando el router recibe el paquete, marca para ver si una subinterfaz en el router se configura para el dot1q de la encapsulación para el VLAN1. No hay actualmente subinterfaz configurada.

Así el router recibe el paquete CDP en la interfaz principal. La razón que el router recibe el paquete en la interfaz principal es porque el VLAN1 es activo. Ingrese el comando del VLAN-Switch de la demostración para la confirmación. Incluso si el router no tiene ninguna interfaz configurada para el VLAN1 el paquete CDP todavía se recibe.

Router#show vlan-switch

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------

1    default                          active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1    enet  100001     1500  -      -      -        -    -        1002   1003
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0

En tales escenarios el paquete CDP del router se envía con gi0/1.

Abre una sesión el Switch

CDP-PA: version 2 packet sent out on FastEthernet1/0/23
CDP-PA: Packet received from Router on interface FastEthernet1/0/23

Esta entrada se encuentra en el caché.

CDP-PA: version 2 packet sent out on FastEthernet1/0/23

Abre una sesión al router

CDP-PA: version 2 packet sent out on GigabitEthernet0/1>
CDP-PA: Packet received from Switch on interface GigabitEthernet0/1

Esta entrada se encuentra en el caché.

CDP-EV: Lookup for ip phone with idb= GigabitEthernet0/1 ip= 10.111.51.3 
mac= 0021.567e.e219 platform= cisco WS-C3750-24P

En el switch:

Switch#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Router          Fas 1/0/23        123             R S I  3845      Gig 0/1

En el router:

Router#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Switch          Gig 0/1            160             S I   WS-C3750- Fas 1/0/23

Usted ve el comportamiento similar cuando cualquier interfaz se configura con el VLA N de la encapsulación como natural.

Escenario 2: El Switch envía un paquete CDP untagged

Switch configuration:

interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 1
 switchport mode trunk
 end

Caso 1: La interfaz donde está Configured el VLAN1 es up/up

interface GigabitEthernet0/1.1
  encapsulation dot1Q 1
end


interface GigabitEthernet0/1.10
 encapsulation dot1Q 10
 ip address 10.111.51.1 255.255.255.224
end


interface GigabitEthernet0/1.21
 encapsulation dot1Q 21
 ip address 10.111.48.1 255.255.255.128
 end

Cuando el Switch envía el paquete CDP al router, envía un paquete sin Tag como el VLAN nativo se utiliza para esta comunicación. Así el router recibe el paquete en la interfaz donde se configura el VLAN1. El router marca si hace el VLAN1 de la encapsulación del dot1q configurar y la interfaz es up/up. Si este control es acertado, el router envía el paquete a través de esa interfaz.

Switch#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Router          Fas 1/0/23        5               R S I  3845      Gig 0/1.1

Router#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Switch          Gig 0/1.1          8               S I   WS-C3750- Fas 1/0/23

Abre una sesión al router

CDP-PA: version 2 packet sent out on GigabitEthernet0/1.1
CDP-PA: Packet received from Switch on interface GigabitEthernet0/1.1

Una entrada no se encuentra en el caché.

Abre una sesión el Switch

CDP-AD: Aging entry for Router, on interface FastEthernet1/0/23
CDP-PA: Packet received from Router on interface FastEthernet1/0/23

Una entrada no se encuentra en el caché.

CDP-PA: version 2 packet sent out on FastEthernet1/0/23

Caso 2: La interfaz en el router donde está Configured el VLA N es up/up y ninguno de las interfaces tiene un VLAN nativo especificadas

interface GigabitEthernet0/1.1
encapsulation dot1Q 1
end


interface GigabitEthernet0/1.10
encapsulation dot1Q 10 native
ip address 10.111.51.1 255.255.255.224
end


interface GigabitEthernet0/1.21
encapsulation dot1Q 21
ip address 10.111.48.1 255.255.255.128
end

Análisis

Cuando el Switch envía el paquete CDP al router, envía el paquete sin Tag como el VLAN nativo se utiliza para la comunicación. El router recibe el paquete sobre gi0/1.1 pues tiene VLAN1 configurado en sí mismo. El router marca si hace el VLAN1 configurar o cualquier otro VLAN nativo ser configurado. En el caso actual, la interfaz gi0/1.10 se configura con la palabra clave nativa. Así el router envía el paquete con la subinterfaz gi0/1.10.

Esta salida se considera en este escenario:

Switch#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Router          Fas 1/0/23        5               R S I  3845      Gig 0/1.1

El resultado del vecino CDP en el router se muestra aquí:

Router#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Switch          Gig 0/1.10         7               S I   WS-C3750- Fas 1/0/23

Abre una sesión al router

CDP-PA: version 2 packet sent out on GigabitEthernet0/1.10
CDP-PA: Packet received from Switch on interface GigabitEthernet0/1.1

Una entrada no se encuentra en el caché.

Abre una sesión el Switch

CDP-AD: Aging entry for Router, on interface FastEthernet1/0/23
CDP-PA: Packet received from Router on interface FastEthernet1/0/23

Una entrada no se encuentra en el caché.

CDP-PA: paquete de la versión 2 enviado en FastEthernet1/0/23

Caso 3: No hay interfaz donde se configura el VLAN1, pero ningunas de las interfaces tienen una palabra clave nativa configurada

interface GigabitEthernet0/1.1
 end

interface GigabitEthernet0/1.10
 encapsulation dot1Q 10 native
 ip address 10.111.51.1 255.255.255.224
end


interface GigabitEthernet0/1.21
 encapsulation dot1Q 21
 ip address 10.111.48.1 255.255.255.128
 end

Cuando el Switch envía el paquete al router, envía el paquete sin Tag sobre el VLAN nativo. El router recibe el paquete sobre gi0/1. El router marca si hace el VLAN1 configurar o cualquier otro VLAN nativo ser configurado.

Aquí, la interfaz gi0/1.10 se configura para la encapsulación como natural, así el router envía el paquete con gi0/1.10.

Switch#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Router          Fas 1/0/23        156             R S I  3845      Gig 0/1

Router#sh cdp neigh

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Switch          Gig 0/1.10         0               S I   WS-C3750- Fas 1/0/23

Abre una sesión al router 

CDP-PA: version 2 packet sent out on GigabitEthernet0/1.10
CDP-PA: Packet received from Switch on interface GigabitEthernet0/1

Una entrada no se encuentra en el caché.

Abre una sesión el Switch

CDP-AD: Aging entry for Router, on interface FastEthernet1/0/23
CDP-PA: Packet received from Router on interface FastEthernet1/0/23

Una entrada no se encuentra en el caché.

CDP-PA: version 2 packet sent out on FastEthernet1/0/23

Caso 4: El router no tiene una encapsulación del dot1q del VLA N y el VLAN nativo no se especifica

interface GigabitEthernet0/1.1

 end


interface GigabitEthernet0/1.10
 encapsulation dot1Q 10
 ip address 10.111.51.1 255.255.255.224
end


interface GigabitEthernet0/1.21
 encapsulation dot1Q 21
 ip address 10.111.48.1 255.255.255.128
 end

Cuando el Switch envía el paquete al router, envía el paquete CDP untagged mientras que la comunicación está sobre el VLAN nativo. El router recibe el paquete sobre gi0/1. El router marca si hace el VLAN1 configurar o cualquier otro VLAN nativo ser configurado. Aquí no hay interfaz como tal, así el router envía el paquete con gi0/1 (sobre la interfaz principal).

Esta salida se considera en este escenario:

Switch#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Router          Fas 1/0/23        7               R S I  3845      Gig 0/1

La salida en el router se muestra aquí:

Router#show cdp neighbor

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Switch          Gig 0/1           7               S I   WS-C3750- Fas 1/0/23

Abre una sesión al router

CDP-PA: version 2 packet sent out on GigabitEthernet0/1
CDP-PA: Packet received from Switch on interface GigabitEthernet0/1

Una entrada no se encuentra en el caché.

Abre una sesión el Switch

CDP-AD: Aging entry for Router, on interface FastEthernet1/0/23
CDP-PA: Packet received from Router on interface FastEthernet1/0/23

Una entrada no se encuentra en el caché.

CDP-PA: version 2 packet sent out on FastEthernet1/0/23

Resumen

El router recibe un paquete CDP marcado con etiqueta:

La subinterfaz configurada con el VLAN1 es administrativo abajo de/abajo.

El router desecha el paquete CDP. El Switch no sería enumerado como vecino CDP. 

La subinterfaz configurada con el VLAN1 es UP/UP. Un VLAN nativo no se especifica.

El router envía y recibe el paquete en esta subinterfaz.

El router no hace el VLAN1 configurar y las subinterfaces unas de los son con configurado/sin la palabra clave nativa.

Los paquetes atraviesan sobre la interfaz principal. El CDP trabaja en la amb dirección.

El router recibe un paquete CDP untagged:

La subinterfaz configurada con el VLAN1 es administrativo abajo de/abajo.

El router desecha el paquete CDP. El Switch no sería enumerado como vecino CDP.

La subinterfaz configurada con el VLAN1 es UP/UP. Un VLAN nativo no se especifica.

El router envía y recibe los paquetes en esta subinterfaz. El CDP trabaja en las ambas direcciones.

El router no hace el VLAN1 configurar y no se configura ningunas de las subinterfaces con la palabra clave nativa.

El router recibe los paquetes CDP en la interfaz principal, pero los envía sobre la subinterfaz donde se configura la palabra clave nativa.

El router hace ni el VLAN1 ni la palabra clave nativa configurar.

Los paquetes CDP atraviesan sobre la interfaz principal. El CDP trabaja en las ambas direcciones.



Document ID: 118736