IP : Traducción de direcciones de red (NAT)

Ejemplo de la configuración de alta disponibilidad del Cuadro-a-cuadro NAT ASR 1000

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios

Introducción

Este documento describe la configuración para la Alta disponibilidad Cuadro-a-Cuadro-NAT (B2B NAT HA) en los dispositivos del Cisco IOS ®-XE, con el foco en el router de los servicios de la agregación (familia ASR)1000.

B2B EL NAT HA es un método para alcanzar la Alta disponibilidad de las aplicaciones tales como Firewall Zona-basado (ZBFW), Network Address Translation (NAT), VPN, el regulador de la frontera de la sesión (SBC) y así sucesivamente entre el Routers de la familia ASR 1000. Este documento describe cómo configurar B2B NAT HA en la plataforma de Cisco ASR 1000 junto con la verificación.

Contribuido por el Uma Mohanty y Girish Devgan, ingenieros de Cisco TAC.

Prerrequisitos

Requisitos

Cisco recomienda que tenga conocimiento sobre estos temas:

  • Conocimiento de la descripción de la arquitectura de la plataforma ASR 1000
  • Conocimiento básico en la Alta disponibilidad y las Tecnologías NAT

Componentes Utilizados

La información en este documento se basa en la familia ASR 1000 con las versiones de la versión deL Cisco IOS XE 3.10 y posterior. B2B EL NAT HA se soporta en la versión 3.5 del Cisco IOS XE y posterior.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Configurar

Nota: Use la Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos usados en esta sección.

Activadores de la Conmutación por falla B2BHA

Algunos de los activadores comunes de la Conmutación por falla son:

  • Pérdida de energía/recarga (esto incluye las caídas) en el active.
  • Recarga del Encapsulating Security Payload (ESP) (o planeado o imprevisto).
  • La interfaz de control para el grupo de redundancia (RG) es apaga/link abajo.
  • La Interfaz de datos para RG es apaga/link abajo.
  • Error seguido del objeto (acuerdo llano del servicio del IP).
  • Error señal de mantenimiento del protocolo.
  • La prioridad del tiempo de ejecución del active va abajo debajo de la del umbral configurado.
  • La prioridad del tiempo de ejecución del active va abajo debajo de la del recurso seguro.

Configuración mínima

Esta sección describe cómo configurar B2B NAT HA junto con la información de topología.

Las implementaciones del AHB B2 podían tener estas tres topologías:

  • LAN-LAN
  • LAN-WAN
  • Malla LAN

Nota: El tamaño de paquetes medio de la Redundancia es los bytes 256.

Diagrama de la red con la Conectividad básica L2/L3

Conectividad básica L2/L3

La configuración se podía dividir en dos mayores parte. Una porción es la configuración básica que habilita RG, el Redundancy Protocol, los temporizadores, el control, y las Interfaces de datos. La segunda parte se relaciona con los datos reales/las interfaces del tráfico y su asociación con RG.

Este ejemplo intenta alcanzar B2B NAT HA en el ASR con el servidor 192.168.5.5 del otro extremo del LAN 172.16.1.4. Estas configuraciones se preparan con la configuración NAT ESTÁTICA en el momento.

ip nat pool POOL1 200.200.200.200 200.200.200.200 netmask 255.255.255.252
ip nat inside source list NAT pool POOL1 redundancy 1 mapping-id 252

Extended IP access list NAT
    10 permit ip host 172.16.1.4 host 192.168.5.5

ASR-1 

redundancy
 mode none
 application redundancy
 group 1
 name TEST
 preempt
 priority 150
 control GigabitEthernet0/0/2

protocol 1
 data GigabitEthernet0/0/3
ASR-2
    
redundancy
mode none
application redundancy
group 1
name TEST
preempt
priority 50
control GigabitEthernet0/0/2

protocol 1
data GigabitEthernet0/0/3

Ambos los ASR deben poder alcanzar al IP Address público proporcionado por el ISP.

ASR-1#ping 200.200.200.200
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.200.200, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
ASR-2#ping 200.200.200.200
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.200.200, timeout is 2 seconds:
!!!!!

El LAN que hace frente a la interfaz está conectado con los switches de distribución, que a su vez están conectados con los host.

ASR-1#show run int GigabitEthernet0/0/0
interface GigabitEthernet0/0/0
 ip address 172.16.1.2 255.255.255.248
 ip nat inside
 negotiation auto
 cdp enable
 redundancy rii 100
 redundancy group 1 ip 172.16.1.5
exclusive decrement 100
end
ASR-2#show run int GigabitEthernet0/0/0
interface GigabitEthernet0/0/0
 ip address 172.16.1.3 255.255.255.248
 ip nat inside
 negotiation auto
 cdp enable
 redundancy rii 100
 redundancy group 1 ip 172.16.1.5
exclusive decrement 100
end

El ISP que hace frente a la interfaz tiene esta configuración:

ASR-1#show run int gi0/0/1
interface GigabitEthernet0/0/1
 ip address 192.168.3.2 255.255.255.252
 ip nat outside
 negotiation auto
 cdp enable
 redundancy rii 101
 redundancy asymmetric-routing enable
 redundancy group 1 decrement 20
end
ASR-2#show run int gi0/0/1
interface GigabitEthernet0/0/1
 ip address 192.168.4.2 255.255.255.252
 ip nat outside
 negotiation auto
 cdp enable
 redundancy rii 101
 redundancy asymmetric-routing enable
 redundancy group 1 decrement 20
end


Los datos y las interfaces de control entre los ASR se han configurado tal y como se muestra en de estas secciones.

Interfaz de control
ASR-1#show run int gi0/0/2
interface GigabitEthernet0/0/2
description CONTROL-INTERFACE
ip address 10.10.10.1 255.255.255.252
negotiation auto
cdp enable
end
ASR-2#show run int gi0/0/2
interface GigabitEthernet0/0/2
description CONTROL INTERFACE
ip address 10.10.10.2 255.255.255.252
negotiation auto
cdp enable
end

Interfaz de datos
ASR-1#show run int gi0/0/3
interface GigabitEthernet0/0/3
description DATA INTERFACE
encapsulation dot1Q 10
ip address 10.11.11.1 255.255.255.252
end
ASR-2#show run int gi0/0/3
interface GigabitEthernet0/0/3
description DATA INTERFACE
encapsulation dot1Q 10
ip address 10.11.11.2 255.255.255.252
end

Nota:
- Usted no debe configurar un identificador de la interfaz redundante (RII) en una interfaz que se configure como Interfaz de datos o como interfaz de control.
- Usted debe configurar el RII y el Asymmetric Routing en el active y los dispositivos en espera.
- Usted no puede habilitar el Asymmetric Routing en la interfaz que tiene una dirección IP virtual configurada.

Verificación

Comandos de verificación y resultado esperado

La herramienta del Output Interpreter (clientes registrados solamente) apoya los ciertos comandos show. Utilice la herramienta del Output Interpreter para ver una análisis de la salida del comando show.

ASR-1#show redundancy application group 
Group ID    Group Name                      State
--------    ----------                      -----
1           TEST                           ACTIVE

ASR-2#show redundancy application group
Group ID    Group Name                      State
--------    ----------                      -----
1           TEST                           STANDBY

ASR-1#show redundancy application group 1
Group ID:1
Group Name:TEST

Administrative State: No Shutdown
Aggregate operational state : Up
My Role: ACTIVE
Peer Role: STANDBY
Peer Presence: Yes
Peer Comm: Yes
Peer Progression Started: Yes

RF Domain: btob-one
     RF state: ACTIVE
     Peer RF state: STANDBY HOT

ASR-2#show redundancy application group 1
Group ID:1
Group Name:TEST

Administrative State: No Shutdown
Aggregate operational state : Up
My Role: STANDBY
Peer Role: ACTIVE
Peer Presence: Yes
Peer Comm: Yes
Peer Progression Started: Yes

RF Domain: btob-one
     RF state: STANDBY HOT
     Peer RF state: ACTIVE

ASR-1#show ip nat translations
Pro  Inside global         Inside local          Outside local         Outside global
---  200.200.200.200       172.16.1.4            ---                   ---
icmp 200.200.200.200:98    172.16.1.4:98         192.168.5.5:98        192.168.5.5:98
Total number of translations: 2

ASR-2#show ip nat translations
Pro  Inside global         Inside local          Outside local         Outside global
---  200.200.200.200       172.16.1.4            ---                   ---
icmp 200.200.200.200:98    172.16.1.4:98         192.168.5.5:98        192.168.5.5:98
Total number of translations: 2

ASR-1#show redundancy application protocol group 1

RG Protocol RG 1
------------------
    Role: Active
    Negotiation: Enabled
    Priority: 150
    Protocol state: Active
    Ctrl Intf(s) state: Up
    Active Peer: Local
    Standby Peer: address 10.10.10.2, priority 50, intf Gi0/0/2
    Log counters:
        role change to active: 7
        role change to standby: 7
        disable events: rg down state 7, rg shut 0
        ctrl intf events: up 7, down 8, admin_down 7
        reload events: local request 0, peer request 0

RG Media Context for RG 1
--------------------------
    Ctx State: Active
    Protocol ID: 1
    Media type: Default
    Control Interface: GigabitEthernet0/0/2
        Current Hello timer: 3000
    Configured Hello timer: 3000, Hold timer: 9000
    Peer Hello timer: 3000, Peer Hold timer: 9000
    Stats:
        Pkts 386597, Bytes 23969014, HA Seq 0, Seq Number 386597, Pkt Loss 0
        Authentication not configured
        Authentication Failure: 0
        Reload Peer: TX 0, RX 0
        Resign: TX 0, RX 1
    Standby Peer: Present. Hold Timer: 9000
        Pkts 386589, Bytes 13144026, HA Seq 0, Seq Number 1503658, Pkt Loss 0

ASR-2#show redundancy application protocol group 1

RG Protocol RG 1
------------------
    Role: Standby
    Negotiation: Enabled
    Priority: 50
    Protocol state: Standby-hot
    Ctrl Intf(s) state: Up
    Active Peer: address 10.10.10.1, priority 150, intf Gi0/0/2
    Standby Peer: Local
    Log counters:
        role change to active: 8
        role change to standby: 16009
        disable events: rg down state 1, rg shut 0
        ctrl intf events: up 9, down 10, admin_down 1
        reload events: local request 15999, peer request 2

RG Media Context for RG 1
--------------------------
    Ctx State: Standby
    Protocol ID: 1
    Media type: Default
    Control Interface: GigabitEthernet0/0/2
        Current Hello timer: 3000
    Configured Hello timer: 3000, Hold timer: 9000
    Peer Hello timer: 3000, Peer Hold timer: 9000
    Stats:
        Pkts 1503674, Bytes 93227788, HA Seq 0, Seq Number 1503674, Pkt Loss 0
        Authentication not configured
        Authentication Failure: 0
        Reload Peer: TX 2, RX 2
        Resign: TX 8, RX 7
    Active Peer: Present. Hold Timer: 9000
        Pkts 386603, Bytes 13144502, HA Seq 0, Seq Number 386613, Pkt Loss 0

ASR-1#show platform hardware qfp active system rg 1
Redundancy Group 1
    State:        RG_ACTIVE
    Bulksync:    NO BULKSYNC REQ
    Transport:    
        SYNC_B2B    LISTEN
            cp hdl 0x01013e8d dp hdl 0x03010006, platfm hdl 0x0000fa35
        L3_IPV4
            src addr 10.11.11.1    dest addr 10.11.11.2
        L4_UDP_RELIABLE
            src port   19510    dest port   3497

        AR transport not available
    Stats:
        RG Request:
            CREATE        0
            UPDATE        32048
            DELETE        0
        RG State:
            RG_PREINIT        0
            RG_INIT            7
            RG_STANDBY        21
            RG_ACTIVE        32020
        RG Transport Request:
                    NA            0
            OPEN            16014
            CLOSE            0
        RG Transport Status:
            CONN_ESTB        7
            CONN_FAIL        0
            TRANS_DOWN        0
            TRANS_DOWN_GRACEFUL    8
        Bulksync:
            Request            7
            Success            7
            Fail            0

ASR-1#show platform hardware qfp active system rg 1 stats
    trans index:    00000006  Trans Type:    00000001  RG    1
    mf_flags    0x40000000  seq_flags    0x700003ff
    ha_control_state    0x5
    pending ack        00000000
    keepalive_timeout    00000100
    rx_seq_flags        0x8000000
    rx_seq_num    0x2c0d4a44
    tx_seq        0xb4965908
    tx_ack_tail    0xb4965908
    tx_seq_flags    0x700003ff
    tx    0000000000580126
    rx    0000000000580089
    retx    0000000000000000
    rx dropped    0000000000000000
    records dropped    0000000000000000
    tx dropped    0000000000000000
    ack dropped    00000000  oob pkts dropped 00000000
    send dropped 00000000  rx_control_msgs 00580090
    tx control_msgs 00580078   for_us_hits 01160217
    sync_alloc_failures 00000000  status_notifications 00000001
    sync_msgs_received 00580093  sync_msgs_sent 00580133
    for_us_udp_checksum_drops 00000000
    acks sent 00580089 rcvd 00580126  nacks sent 00000000 rcvd 00000000

Comandos útiles

  • RG en el active se recarga con el comando del uno mismo del <rg-number> del grupo de la recarga de la aplicación de la Redundancia en el modo EXEC.
  • RG en el active se apaga con el uso de estos comandos CLI en el modo de configuración de la Redundancia:
    ISR1(config-red-app)#group 1
    ISR1(config-red-app-grp)#shutdown

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.



Document ID: 118768