IP : Multidifusión

Perfiles del mVPN de la configuración dentro del Cisco IOS

18 Junio 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (21 Abril 2016) | Comentarios

Contenido

Discusiones relacionadas de la comunidad de soporte de Cisco

Introducción

Este documento describe cómo configurar cada perfil del Multicast VPN (mVPN) dentro del ® del Cisco IOS.

Nota: Las configuraciones que se describen en este documento se aplican al Routers del borde del proveedor (PE).

Contribuido por Lucas De Ghein, ingeniero de Cisco TAC.

Prerrequisitos

Requisitos

Antes de que usted proceda con la configuración que se describe en este documento, verifique si haya soporte para un perfil del mVPN en la plataforma específica que funciona con el Cisco IOS.

Componentes Utilizados

La información en este documento se basa en todas las versiones del Cisco IOS.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Configurar

Esta sección describe cómo configurar los perfiles del mVPN dentro del Cisco IOS.

Nota: Use la Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos usados en esta sección.

perfiles del mVPN

Nota: No todos los perfiles se soportan actualmente en el Cisco IOS.

Nota: El ruteo virtual/la expedición (VRF) que se utiliza en este documento es VRF uno. El Rosen MLDP se ha retitulado para omitir el MDT.

Un perfil del mVPN se configura para el contexto global o por el VRF. Usted puede utilizar el viejo o nuevo método para definir un VRF cuando usted configura los perfiles del mVPN en el Cisco IOS.

Aquí está un ejemplo del viejo método:

ip vrf one
rd 1:1
route-target export 1:1
route-target import 1:1

Aquí está un ejemplo del nuevo método:

vrf definition one
rd 1:1
!
address-family ipv4
  route-target export 1:1
  route-target import 1:1
exit-address-family

Para los perfiles en el contexto global, el ruteo multicast debe ser habilitado:

ip multicast-routing

Para los perfiles en el contexto VRF, el ruteo multicast se debe habilitar para el VRF:

ip multicast-routing vrf one

Usted puede habilitar el registro del Label Distribution Protocol de múltiples puntos (MLDP) con este comando global para los perfiles con MLDP:

mpls mldp logging notifications

La multidifusión independiente de protocolo (PIM) se debe habilitar para el router del borde del proveedor (PE) en el link del borde del Borde-cliente del proveedor (PE-CE) para ambos los casos (globales o contexto VRF):

interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

FRR para MLDP

Rápido reencamine (FRR) para MLDP está disponible en el Cisco IOS. El tráfico Multicast para el cual MLDP es el protocolo del avión del control debe utilizar un túnel primario de la ingeniería de tráfico (TE) para tener el tráfico protegido por el FRR. El primario túnel TE puede ser un manual túnel TE o un auto-túnel primario. El link se debe proteger por TE FRR, por un túnel del respaldo manual o un auto-túnel de reserva.

Este ejemplo utiliza un túnel manual del respaldo primario y manual.

Este comando global debe ser configurado para que MLDP utilice los túneles del Multiprotocol Label Switching (MPLS) TE:

mpls mldp path traffic-eng

Esta configuración se utiliza para la interfaz protegida que es utilizada por el túnel primario del uno-salto:

interface Ethernet3/0
 ip address 10.1.6.6 255.255.255.0
 load-interval 30
 mpls ip
 mpls traffic-eng tunnels
 mpls traffic-eng backup-path Tunnel0
 ip rsvp bandwidth 10000
end

Esta configuración se utiliza para el túnel de reserva:

interface Tunnel0
 ip unnumbered Loopback0
 load-interval 30
 tunnel source Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 10.100.1.3
 tunnel mpls traffic-eng path-option 1 explicit name P6-to-P3

Esta configuración se utiliza para el túnel primario del uno-salto:

interface Tunnel1
 ip unnumbered Loopback0
 load-interval 30
 mpls ip
 tunnel source Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 10.100.1.3
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng path-option 1 explicit name P6-to-P3-direct
 tunnel mpls traffic-eng fast-reroute

Nota: La configuración del IP de los mpls se requiere en el túnel primario porque MLDP se debe habilitar en el túnel protegido. El autoroute anuncia que la configuración está requerida para asegurarse de que túnel TE esté utilizado para remitir el tráfico.

MBB para MLDP

Haga antes de la característica de la rotura (MBB) se soporta en el Cisco IOS, pero solamente el método que utiliza un retraso fijo después de que la nueva trayectoria esté disponible. No hay interrogación/reconoce el mecanismo en el Cisco IOS.

Éste es el comando global que se utiliza para configurar el retraso fijo MBB:

P1(config)#mpls mldp make-before-break delay ?
<0-60000> Delay in milliseconds

El valor predeterminado es 0, tan allí no es ningún MBB por abandono.

Perfiles

Esta sección describe las configuraciones necesarias para cada perfil del mVPN.

Perfil 0 MDT predeterminado - GRE - Señalización del C-mcast PIM

Utilice esta configuración para el perfil 0:

vrf definition one
rd 1:1
!
address-family ipv4
  mdt default 232.1.1.1
  route-target export 1:1
  route-target import 1:1
exit-address-family
!       
ip multicast-routing
ip multicast-routing vrf one

interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
  neighbor 10.100.1.7 route-reflector-client
exit-address-family
!
address-family ipv4 mdt
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!

Nota: Para este perfil, el PIM se debe habilitar en el Loopback Interface global. El árbol de distribución del Multicast del IPv4 de la familia del direccionamiento (AF) (MDT) se debe utilizar para todos los tipos de señalización PIM en la base (no sólo para el Source Specific Multicast (SSM) PIM).

Perfil 1 MDT predeterminado - MLDP MP2MP - Señalización del C-mcast PIM

Utilice esta configuración para el perfil 1:

vrf definition one
rd 1:2
vpn id 1000:2000
!
address-family ipv4
  mdt default mpls mldp 10.100.1.1
  route-target export 1:1
  route-target import 1:1
exit-address-family
!

ip multicast-routing vrf one

mpls mldp logging notifications

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.2.9 remote-as 65002
  neighbor 10.2.2.9 activate
exit-address-family

Perfil 2 MDT dividido - MLDP MP2MP - Señalización del C-mcast PIM

     

El perfil 2 no se soporta actualmente en el Cisco IOS, y MLDP no soporta el MDT dividido con De múltiples puntos-a-de múltiples puntos (MP2MP).

Perfil 3 MDT predeterminado - GRE - BGP-AD - Señalización del C-mcast PIM

Utilice esta configuración para el perfil 3:

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery pim
  mdt default 232.1.1.1
  route-target export 1:1
  route-target import 1:1
exit-address-family
!

ip multicast-routing vrf one
!
interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family

  

Nota: Para este perfil, el PIM se debe habilitar en el Loopback Interface global. Porque la detección Protocolo-auto del gateway de frontera (BGP-AD) para el PIM se utiliza, hay no más una necesidad del IPv4 MDT AF, que era necesaria para el perfil 0.

Perfil 4 MDT dividido - MLDP MP2MP - BGP-AD - Señalización del C-mcast PIM

El perfil 4 no se soporta actualmente en el Cisco IOS, y MLDP no soporta el MDT dividido con el MP2MP.

Perfil 5 MDT dividido - MLDP P2MP - BGP-AD - Señalización del C-mcast PIM

El perfil 5 no se soporta actualmente en el Cisco IOS, y la señalización PIM no se soporta sobre el MDT dividido.

Perfil 6 VRF MLDP - Señalización dentro de la banda

Utilice esta configuración para el perfil 6:

vrf definition one
rd 1:1
!
address-family ipv4
  route-target export 1:1
  route-target import 1:1
exit-address-family
!
ip multicast-routing vrf one
ip multicast vrf one mpls mldp


!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
bgp log-neighbor-changes
neighbor 10.2.1.8 remote-as 65001
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!


ip pim vrf one mpls source Loopback0

Perfile la señalización dentro de la banda global 7 MLDP

Utilice esta configuración para el perfil 7:

ip multicast-routing

ip multicast mpls mldp

interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!

interface Ethernet2/0
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

router bgp 1
bgp log-neighbor-changes
neighbor 10.2.1.8 remote-as 65001
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4
  redistribute connected
  neighbor 10.2.1.8 activate
  neighbor 10.100.1.7 activate
exit-address-family

ip pim ssm default

ip pim mpls source Loopback0

Parásitos atmosféricos globales del perfil 8 - P2MP-TE

Esta sección describe las configuraciones necesarias para el perfil 8 en el Routers del centro distribuidor TE y del fin de cola TE.

Router de centro distribuidor TE

Utilice esta configuración para el perfil 8 en el router de centro distribuidor TE:

ip multicast-routing
ip multicast mpls traffic-eng

mpls traffic-eng tunnels
mpls traffic-eng destination list name from-PE3
ip 10.100.1.1 path-option 1 dynamic
ip 10.100.1.2 path-option 1 dynamic
ip 10.100.1.4 path-option 1 explicit name to-PE4

interface Tunnel0
ip unnumbered Loopback0
ip pim passive
ip igmp static-group 232.1.1.1 source 10.2.3.10
tunnel mode mpls traffic-eng point-to-multipoint
tunnel destination list mpls traffic-eng name from-PE3
!

interface Ethernet1/0
ip address 10.1.10.3 255.255.255.0
mpls traffic-eng tunnels
ip rsvp bandwidth 10000

!
router ospf 1
network 10.1.7.0 0.0.0.255 area 0
network 10.1.10.0 0.0.0.255 area 0
network 10.100.0.0 0.0.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4
  redistribute connected
  neighbor 10.100.1.7 activate
exit-address-family

ip pim ssm default

Nota: Una lista del destino se requiere para el Routers del fin de cola de la punta a de múltiples puntos (P2MP) túnel TE. La opción de trayecto hacia el router del fin de cola puede ser explícita o dinámica.

Router del fin de cola TE

Utilice esta configuración para el perfil 8 en el router del fin de cola TE:

ip multicast-routing
ip multicast mpls traffic-eng

mpls traffic-eng tunnels
interface Ethernet0/0
ip address 10.1.1.1 255.255.255.0
mpls traffic-eng tunnels
ip rsvp bandwidth 10000
        

router bgp 1
bgp log-neighbor-changes
neighbor 10.2.1.8 remote-as 65001
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4
  redistribute connected
  neighbor 10.2.1.8 activate
  neighbor 10.100.1.7 activate
exit-address-family

ip pim ssm default

ip mroute 10.2.3.0 255.255.255.0 10.100.1.3

Nota: El mRoute estático se requiere para la fuente hacia el router de centro distribuidor TE en el contexto global.

Perfil 9 MDT predeterminado - MLDP - MP2MP - BGP-AD - Señalización del C-mcast PIM

Utilice esta configuración para el perfil 9:

vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp 10.100.1.3
  route-target export 1:1
  route-target import 1:1
exit-address-family
!       
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!

Parásitos atmosféricos del perfil 10 VRF - P2MP TE - BGP-AD

El perfil 10 no se soporta actualmente en el Cisco IOS, y BGP-AD no se soporta para P2MP TE.

Perfil 11 MDT predeterminado - GRE - BGP-AD - Señalización del C-mcast BGP

Utilice esta configuración para el perfil 11:

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery pim
  mdt default 232.1.1.1 
  mdt overlay use-bgp
route-target export 1:1
  route-target import 1:1
exit-address-family
!

ip multicast-routing vrf one
!
interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family

Nota: Para este perfil, el PIM se debe habilitar en el Loopback Interface global. Porque BGP-AD para el PIM se utiliza, hay no más una necesidad del IPv4 MDT AF, que era necesaria para el perfil 0.

Perfil 12 MDT predeterminado - MLDP - P2MP - BGP-AD - Señalización del C-mcast BGP

Utilice esta configuración para el perfil 12:

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp p2mp
  mdt overlay use-bgp
  route-target export 1:1
  route-target import 1:1
exit-address-family
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!

Perfil 13 MDT predeterminado - MLDP - MP2MP - BGP-AD - Señalización del C-mcast BGP

Utilice esta configuración para el perfil 13:

vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp 10.100.1.3
  mdt overlay use-bgp
  route-target export 1:1
  route-target import 1:1
exit-address-family
!       

interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!

Perfil 14 MDT dividido - MLDP P2MP - BGP-AD - Señalización del C-palo BGP

Utilice esta configuración para el perfil 14:

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery mldp
mdt strict-rpf interface
  mdt partitioned mldp p2mp
  mdt overlay use-bgp
  route-target export 1:1
  route-target import 1:1
exit-address-family
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!

Perfil 15 MDT dividido - MLDP MP2MP - BGP-AD - Señalización del C-palo BGP

El perfil 15 no se soporta actualmente en el Cisco IOS, y MLDP no soporta el MDT dividido con el MP2MP.

Parásitos atmosféricos predeterminados del perfil 16 MDT - P2MP TE - BGP-AD - Señalización del C-mcast BGP

El perfil 16 no se soporta actualmente en el Cisco IOS.

Perfil 17 MDT predeterminado - MLDP - P2MP - BGP-AD - Señalización del C-mcast PIM

Utilice esta configuración para el perfil 17:

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp p2mp
  route-target export 1:1
  route-target import 1:1
exit-address-family
!

interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!

Parásitos atmosféricos predeterminados del perfil 18 MDT - P2MP TE - BGP-AD - Señalización del C-mcast PIM

El perfil 18 no se soporta actualmente en el Cisco IOS.

Perfil 19 MDT predeterminado - IR - BGP-AD - Señalización del C-mcast PIM

El perfil 19 y la replicación del ingreso (IR) no se soportan actualmente en el Cisco IOS.

Perfil 20 MDT predeterminado - P2MP-TE - BGP-AD - PIM - señalización del C-mcast

El perfil 20 y los Auto-túneles TE P2MP no se soportan actualmente en el Cisco IOS.

Perfil 21 MDT predeterminado - IR - BGP-AD - BGP - señalización del C-mcast

El perfil 21 y IR no se soporta actualmente en el Cisco IOS.       

Perfil 22 MDT predeterminado - P2MP-TE - BGP-AD BGP - señalización del C-mcast

El perfil 22 y los Auto-túneles TE P2MP no se soportan actualmente en el Cisco IOS.  

   

Perfil 23 MDT dividido - IR - BGP-AD - Señalización del C-mcast PIM

El perfil 23 y IR no se soporta actualmente en el Cisco IOS.          

Perfil 24 MDT dividido - P2MP-TE - BGP-AD - Señalización del C-mcast PIM

El perfil 24 y los Auto-túneles TE P2MP no se soportan actualmente en el Cisco IOS.

Perfil 25 MDT dividido - IR - BGP-AD - Señalización del C-mcast BGP

El perfil 25 y IR no se soporta actualmente en el Cisco IOS.       

Perfil 26 MDT dividido - P2MP TE - BGP-AD - Señalización del C-mcast BGP

El perfil 26 y los Auto-túneles TE P2MP no se soportan actualmente en el Cisco IOS.

MVPN Inter-autónomo

La información en esta sección se proporciona bajo suposición que la configuración adecuada está implementada en el Routers para hacer el Inter-AS MPLS VPN operativo para el unicast.

La opción D no se soporta para el mVPN.

Opción A

La configuración regular del mVPN se requiere para la opción A. Usted puede tener cualquier perfil en los sistemas autónomos, y los perfiles no tienen que hacer juego en los sistemas autónomos diferentes.

PIM

Para las opciones B y el C, si los IP Addresses del Loopback Interface se redistribuyen del Border Gateway Protocol (BGP) en el Interior Gateway Protocol (IGP) de los otros sistemas autónomos (COMO), después el vector PIM no se requiere.

Opción B

Solamente (inter-COMO) el mVPN entre sistemas autónomos se soporta con el perfil 0 (con los túneles no segmentados).

La configuración regular del mVPN se requiere para la opción B. Solamente el IPv4 MDT AF puede ser utilizado; El IPv4 MVPN AF no se soporta.

La creación del vector PIM con el Route Distinguisher (RD) se requiere en el Routers PE, con esta configuración adicional:

ip multicast vrf one rpf proxy rd vector

Los routeres de margen de sistema autónomo (ASBR) deben tener PIM habilitado en el link ASBR-a-ASBR. Los ASBR deben también tener IPv4 MDT AF configurado para los vecinos del Internal Border Gateway Protocol (iBGP) y el vecino del Border Gateway Protocol externo ASBR (eBGP).

Esta configuración adicional se requiere en el ASBR:

interface Ethernet0/0
description inter-as link
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls bgp forwarding

router bgp 1
bgp log-neighbor-changes
no bgp default route-target filter
neighbor 10.3.1.4 remote-as 2
neighbor 10.100.1.6 remote-as 1
neighbor 10.100.1.6 update-source Loopback0
!
address-family vpnv4
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
exit-address-family

C de la opción

Solamente (inter-COMO) el mVPN entre sistemas autónomos se soporta con el perfil 0 (con los túneles no segmentados).

La configuración regular del mVPN se requiere para el C de la opción. Los prefijos del loopback PE de los otros AS son hechos publicidad por el BGP en el IPv4 AF.

La creación del vector PIM sin el RD se requiere en el Routers PE también, con esta configuración adicional:

ip multicast rpf proxy vector

Los ASBR deben tener PIM habilitado en el link ASBR-a-ASBR. Los ASBR deben también tener IPv4 MDT AF configurado para los vecinos iBGP y el vecino eBGP ASBR.

Esta configuración adicional se requiere en el ASBR:

interface Ethernet0/0
description inter-as link
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls bgp forwarding

router bgp 1
bgp log-neighbor-changes
neighbor 10.3.1.4 remote-as 2
neighbor 10.100.1.6 remote-as 1
neighbor 10.100.1.6 update-source Loopback0
!
address-family ipv4
redistribute ospf 1 metric 100 route-map loopbacks-into-BGP
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.3.1.4 send-label
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
neighbor 10.100.1.6 send-label
exit-address-family
!     
address-family ipv4 mdt
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
exit-address-family
!        

Nota: El IPv4 MDT AF entre los sistemas autónomos se puede también configurar en los reflectores de ruta (RR) en una sesión del eBGP Multihop en vez sobre de los ASBR.

MLDP

La opción B no se soporta actualmente.

C de la opción

No hay soporte para el Forwarding Equivalence Class recurrente (FEC) en el Cisco IOS. Por lo tanto, redistribución de los loopback PE por el iBGP en el otro COMO no es suficiente, mientras que el Routers P (proveedor) falta el conocimiento del Routers PE en el otro COMO.

Hay soporte si los loopback PE son redistribuidos por el IGP en el otro COMO. En este caso, los perfiles con el MDT dividido y la interconexión total P2MP MLDP se soportan. El IPv4 MDT AF no se puede utilizar aquí; El IPv4 MVPN AF debe ser utilizado. La sesión del mVPN BGP puede ejecutarse entre los PE y los RR. Entre los RR, hay ya una sesión del eBGP Multihop que se ejecuta para el AF VPNv4/6.

El MLDP BGP-AD debe ser habilitado. Inter-como la palabra clave se requiere en el Routers PE para asegurarse de que las rutas del tipo 1 BGP-AD no tengan la comunidad sin exportación.

Perfiles con la interconexión total P2MP MLDP

Esta sección describe las configuraciones para los perfiles 12 y 17.

Configuración del perfil 17

Aquí está la configuración en el Routers PE para el perfil 17:

vrf definition one
rd 1:2
!
address-family ipv4
mdt auto-discovery mldp inter-as
mdt default mpls mldp p2mp
mdt data mpls mldp 100
route-target export 1:1
route-target import 1:1
exit-address-family

Aquí está la configuración en los ASBR para el perfil 17:

interface Ethernet0/0
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls ip
mpls bgp forwarding
end

Nota: La configuración del IP de los mpls se requiere en el link entre los ASBR para tener una vecindad MLDP entre ellos.

Aquí está la configuración en los RR para el perfil 17:

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.1 remote-as 1
neighbor 10.100.1.1 update-source Loopback0
neighbor 10.100.1.3 remote-as 1
neighbor 10.100.1.3 update-source Loopback0
neighbor 10.100.1.8 remote-as 2
neighbor 10.100.1.8 ebgp-multihop 244
neighbor 10.100.1.8 update-source Loopback0
!
address-family ipv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.1 send-label
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.3 send-label
no neighbor 10.100.1.8 activate
exit-address-family
!
address-family ipv4 mvpn
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
exit-address-family
!     
address-family vpnv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 send-community extended
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
neighbor 10.100.1.8 next-hop-unchanged
exit-address-family
!

Configuración del perfil 12

Esta configuración es lo mismo que ésa usada para el perfil 17, pero hay la señalización adicional del C-Multicast por el BGP.

Aquí está la configuración en el Routers PE para el perfil 12:

vrf definition one
rd 1:2
!
address-family ipv4
mdt auto-discovery mldp inter-as
mdt default mpls mldp p2mp
mdt data mpls mldp 100
mdt overlay use-bgp
route-target export 1:1
route-target import 1:1
exit-address-family

Perfiles con el MDT dividido MLDP

Esta sección describe la configuración para el perfil 14.

Configuración del perfil 14

Aquí está la configuración en el Routers PE para el perfil 14:

vrf definition one
rd 1:2
!
address-family ipv4
mdt auto-discovery mldp inter-as
mdt default mpls mldp p2mp
mdt data mpls mldp 100
mdt overlay use-bgp
route-target export 1:1
route-target import 1:1
exit-address-family

Aquí está la configuración en los ASBR para el perfil 14:

interface Ethernet0/0
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls ip
mpls bgp forwarding

Nota: El IP de los mpls se requiere en el link entre los ASBR para tener una vecindad MLDP entre ellos.

Aquí está la configuración en los RR para el perfil 14:

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.1 remote-as 1
neighbor 10.100.1.1 update-source Loopback0
neighbor 10.100.1.3 remote-as 1
neighbor 10.100.1.3 update-source Loopback0
neighbor 10.100.1.8 remote-as 2
neighbor 10.100.1.8 ebgp-multihop 244
neighbor 10.100.1.8 update-source Loopback0
!
address-family ipv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.1 send-label
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.3 send-label
no neighbor 10.100.1.8 activate
exit-address-family
!
address-family ipv4 mvpn
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
exit-address-family
!     
address-family vpnv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 send-community extended
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
neighbor 10.100.1.8 next-hop-unchanged
exit-address-family
!

Csc

Esta información se proporciona bajo suposición que la configuración adecuada está implementada en el Routers para tener MPLS VPN del portador del portador (csc) operativo para el unicast.

Solamente el perfil 0 se soporta para el csc. Esto significa que puede haber csc jerárquico con los VPN habilitados para multicast. El VPN del csc tiene perfil 0 del mVPN configurado. La red del portador tiene perfil 0 del mVPN configurado también. Esto significa que hay la configuración regular del mVPN, en el Routers Csc-PE del csc y en el Routers PE del portador, y entonces no hay configuración adicional necesaria para el Multicast.

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 118985