IP : Protocolo de puerta de enlace fronteriza (BGP)

Configure el atributo de métrica AIGP para el BGP

18 Junio 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (21 Abril 2016) | Comentarios

Introducción

Este documento describe cómo configurar el atributo de métrica acumulado del protocolo Interior Gateway Protocols (AIGP) que es llevado por el Border Gateway Protocol (BGP) en el ® del Cisco IOS.

Contribuido por Lucas De Ghein, ingeniero de Cisco TAC.

Prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Antecedentes

Esta sección proporciona una descripción del atributo de métrica AIGP y de algunas consideraciones importantes con respecto a su uso.

Descripción del atributo de métrica AIGP

Las compañías pudieron desear de implementar un diseño de red donde la red está partida con los protocolos Interior Gateway Protocols múltiples (IGP), cada uno con un sistema autónomo BGP. Esto se utiliza por los motivos de escalabilidad, donde la red llega a ser demasiado grande para un IGP. El BGP ayuda a escalar cuando lleva algunas de las rutas que serían llevadas de otra manera por el IGP. La solución que utiliza AIGP se piensa para las redes con diversos sistemas autónomos BGP bajo un control administrativo.

Aquí tiene un ejemplo:

El servicio de extremo a extremo es el (MPLS) VPN del Multi-Protocol Label Switching. Cuando hay un gran número de Routers del borde del proveedor (PE) en la red, el IGP debe llevar demasiadas rutas. La solución es hacer que el BGP lleve las interfaces del loopback del Routers PE. La solución que se utiliza para asegurarse de que la trayectoria conmutada de etiquetas MPLS (LSP) no es de punta a punta interrumpido es utilizar el IPv4 + la escritura de la etiqueta BGP. El significa que el RFC 3107 está utilizado entre el Routers PE y los Router del borde, que conecta los diversos dominios IGP.

El problema con esta solución es que los Router del borde o el Routers PE pueden tomar no más una decisión sobre el mejor trayecto, sobre la base de punta a punta métrico más corto, porque hay no más un IGP que se ejecuta en la red completa. La solución a este problema es el nuevo atributo BGP, llamado el atributo de métrica acumulado IGP o atributo de métrica AIGP. Este atributo NON-transitivo BGP lleva el métrico acumulada para las trayectorias de modo que los BGP de conversaciones reciban el conocimiento del métrico de punta a punta para esas trayectorias.

Los BGP de conversaciones deben agregar la ruta al Next-Hop métrico al valor actual en el atributo de métrica AIGP antes de que se remita la ruta.

Nota: La comparación de las trayectorias para una ruta se realiza inmediatamente después de la comparación de la preferencia local. Refiera al documento de Cisco del algoritmo de selección del mejor trayecto BGP para más detalles sobre el algoritmo de selección del mejor trayecto BGP.

Esta solución es similar a la solución donde el Multi Exit Discriminator (MED) se fija al IGP métrico. Sin embargo, en este caso, el paso 6 (el MED más bajo) decide al mejor trayecto. Este paso viene después del paso 4, donde el trayecto más corto decide al mejor trayecto. El mejor trayecto a menudo se encuentra ya antes de que se alcance el paso 6. Con la solución AIGP, se cambia la decisión BGP normal para marcar el AIGP después de que el paso 3 para determinar si la ruta fue hecha publicidad localmente. Si diversos sistemas autónomos vecinos (AS) miran con el BGP de conversación, significa que el valor del always-compare-med debe ser habilitado.

El atributo de métrica AIGP se especifica en el RFC 7311, que es el atributo de métrica acumulado IGP para el BGP. Para llevar el valor métrico AIGP en la comunidad del coste, los procedimientos especificados en la proyecto-retana-IDR-aigp-coste-comunidad (uso de la comunidad del coste de llevar el IGP acumulado métrico) se utilizan.

Nota: El métrico BGP AIGP atribuido proporciona el ruteo óptimo en las redes donde diversos dominios de ruteo se interconectan con el BGP.

Cambios al algoritmo de selección del mejor trayecto BGP

Cuando se utiliza AIGP, estos cambios al algoritmo de selección del mejor trayecto BGP se realizan:

  • El algoritmo de selección del mejor trayecto BGP se modifica para comparar el AIGP inmediatamente después del paso 3 (localmente rutas anunciadas) y después de que la verificación del salto siguiente es válida.

  • Cuando el router considera una trayectoria AIGP contra una trayectoria AIGP, después el valor del AIGP métrico se agrega al métrico hacia el Next-Hop.

  • Cuando el router considera una trayectoria AIGP contra una trayectoria NON-AIGP, después el BGP prefiere la trayectoria con el atributo AIGP por abandono.

  • Cuando el IGP más bajo métrico se compara al salto siguiente BGP, después se tiene en cuenta el coste AIGP.

  • Si la ruta hacia el salto siguiente tiene un AIGP métrico, el métrico se agrega al IGP métrico hacia el salto siguiente. Esta suma es el nuevo IGP métrico (costo interior) para la ruta. Esto ocurre cuando una ruta BGP es recurrente a otra ruta BGP.

Consideraciones importantes

Si los IGP en la red son de diversos tipos (Open Shortest Path First (OSPF), Intermediate System-to-Intermediate System (IS-IS), el Enhanced Interior Gateway Routing Protocol (EIGRP)), es inverosímil que el métrico que los resultados del uso del atributo AIGP llevan a los resultados constantes o sensatos. Si el mismo IGP se utiliza en los diversos dominios, después las mismas configuraciones métricas se deben utilizar para garantizar los resultados constantes.

Para que los Router del borde o el Routers PE tengan la capacidad de decidir entre los trayectos múltiples (basados en el métrico derivada AIGP) deben primero recibir los trayectos múltiples. Por este motivo, usted puede ser que sea requerido habilitar la trayectoria adicional (Agregar-trayectoria) o hacer publicidad de la mejor característica del BGP externo.

Colocan a los peeres BGP que se habilitan para AIGP y los que no son en los grupos separados de la actualización. Además, colocan a los peeres BGP que se habilitan para AIGP en la comunidad del coste en los grupos separados de la actualización.

Solución para el Routers de la herencia

Si hay el Routers en la red que no es capaz de AIGP (Routers de la herencia), después hay dos Soluciones posibles:

  • Un router puede traducir el AIGP a una comunidad del coste, asociarlo a la ruta, y hacer publicidad de la ruta al router de la herencia.

  • Un router puede traducir el AIGP al MED, asociarlo a la ruta, y hacer publicidad de la ruta al router de la herencia.

Configurar

Esta sección describe cómo configurar el atributo de métrica AIGP.

Transmisión del permiso del atributo AIGP

El AIGP se debe habilitar explícitamente para el Internal BGP (iBGP) y las sesiones del BGP externo (eBGP) con el aigp del neighbor ip-address ordenan.

Éste es cómo verificar si el AIGP está habilitado para el peer BGP:

P3#show bgp ipv4 unicast neighbors 10.1.9.2 | in AIGP

For address family: IPv4 Unicast

  AIGP is enabled

Origine el AIGP

El AIGP se puede fijar al IGP métrico o a un valor. También, el AIGP se puede fijar para algunas rutas determinado solamente para un IGP vía un route-map. Cuando el terminal original del AIGP ve un cambio en el IGP métrico, debe enviar una nueva actualización de BGP con los nuevos valores AIGP para las rutas afectadas.

El AIGP métrico se puede fijar automáticamente al IGP métrico o a un cierto valor de 32 bits arbitrario:

P1(config-route-map)#set aigp-metric ?
  <0-4294967295>  manual value
  igp-metric      metric value from rib

Este ejemplo muestra cómo fijar el AIGP métrico al métrico de la ruta IGP:

ip prefix-list loopback seq 5 permit 10.100.1.1/32
!
route-map redistribute-loopback permit 10
match ip address prefix-list loopback
set aigp-metric igp-metric

Botón para inhabilitar la Lazo-fractura AIGP

Si se habilita este botón, después el BGP no utiliza AIGP lazo-que se rompe a menos que ambas trayectorias tengan el atributo de métrica AIGP. Esto significa que el atributo AIGP no está evaluado durante el proceso de selección del mejor trayecto entre dos trayectorias cuando una trayectoria no tiene el atributo AIGP.

Aquí tiene un ejemplo:

router bgp 65000
  bgp bestpath aigp ignore

Solución para el Routers de la herencia

Si el router que el PE2 no tiene software que soporte el atributo de métrica AIGP (él es un router de la herencia), después hay dos soluciones que usted puede utilizar.

Traducción del AIGP para costar a la comunidad

Configure el p3 del Routers y el P4 para traducir el IGP costó en una comunidad del coste de que el router puede hacer publicidad a un router de la herencia:

P3#show run | beg router bgp
router bgp 65000
address-family ipv4
  neighbor 10.1.9.2 activate
  neighbor 10.1.9.2 send-community both
  neighbor 10.1.9.2 aigp send cost-community 100 poi igp-cost transitive
P4#show run | beg router bgp
router bgp 65000
address-family ipv4
  neighbor 10.1.10.2 activate
  neighbor 10.1.10.2 send-community both
  neighbor 10.1.10.2 aigp send cost-community 100 poi igp-cost transitive

Usted debe permitir al router que envía para enviar las comunidades ampliadas. Esto significa que usted debe especificar la enviar-comunidad extendida o a la enviar-comunidad ambos atributos (enviar-comunidad vecina x.x.x.x) para el peer BGP.

Aquí tiene un ejemplo:

PE2#show bgp ipv4 unicast 10.100.1.1
BGP routing table entry for 10.100.1.1/32, version 6
Paths: (2 available, best #1, table default)
  Advertised to update-groups:
     6        
  Refresh Epoch 2
  65000 65001
    10.1.9.4 from 10.1.9.4 (10.100.1.4)
      Origin incomplete, localpref 100, valid, external, best
      Extended Community: Cost(transitive):igp:100:6
      mpls labels in/out 17/16
      rx pathid: 0, tx pathid: 0x0
  Refresh Epoch 15
  65000 65001
    10.1.10.6 from 10.1.10.6 (10.100.1.6)
      Origin incomplete, localpref 100, valid, external
      Extended Community: Cost(transitive):igp:100:11
      mpls labels in/out 17/30
      rx pathid: 0, tx pathid: 0

Como se muestra, el router PE2 escogió la trayectoria con el más barato (100:6 contra 100:11) como el mejor trayecto.

Traducción del AIGP al MED

Configure el p3 del Routers y el P4 para traducir el IGP costó en el MED de que el router puede hacer publicidad a un router de la herencia.

Aquí está la configuración en el p3 del router:

router bgp 65000
address-family ipv4
  neighbor 10.1.9.2 activate
  neighbor 10.1.9.2 send-community both
  neighbor 10.1.9.2 aigp send med

Aquí está la configuración en el router P4:

router bgp 65000
address-family ipv4
  neighbor 10.1.10.2 activate
  neighbor 10.1.10.2 send-community both
  neighbor 10.1.10.2 aigp send med

Verificación

La salida de las actualizaciones del unicast BGP ipv4 del debug en el comando muestra el uso del atributo de métrica AIGP:

PE2#
BGP(0): 10.1.9.4 rcvd UPDATE w/ attr: nexthop 10.1.9.4, origin ?, aigp-metric 22,
merged path 65000 65001, AS_PATH

Cuando usted ve la imagen proporcionada en la Sección de descripción general del atributo de métrica AIGP de este documento, usted puede ver que todos los links en la red COMO 6500 tienen un costo de OSPF de 10, los links entre el Routers P1 y P4 y entre el P2 y el p3 tenga un costo de OSPF de 100, y el link entre el p3 del Routers y el P1 tiene un coste de 5.

Ésta es la ruta para 10.100.1.1/32, según lo visto en el p3 del router:

P3#show bgp ipv4 unicast 10.100.1.1
BGP routing table entry for 10.100.1.1/32, version 9
Paths: (2 available, best #1, table default)
  Additional-path-install
  Path advertised to update-groups:
     5         
  Refresh Epoch 5
  65001
    10.100.1.3 (metric 6) from 10.100.1.7 (10.100.1.7)
      Origin incomplete, metric 0, localpref 100, valid, internal, best
      Originator: 10.100.1.3, Cluster list: 10.100.1.7
      mpls labels in/out 29/16
      rx pathid: 0x0, tx pathid: 0x0
  Path not advertised to any peer
  Refresh Epoch 5
  65001
    10.100.1.5 (metric 21) from 10.100.1.7 (10.100.1.7)
      Origin incomplete, metric 0, localpref 100, valid, internal, backup/repair, all
      Originator: 10.100.1.5, Cluster list: 10.100.1.7
      mpls labels in/out 29/16
      rx pathid: 0x1, tx pathid: 0x1

Ésta es la ruta para 10.100.1.1/32, según lo visto en el router P4:

P4#show bgp ipv4 unicast 10.100.1.1
BGP routing table entry for 10.100.1.1/32, version 9
Paths: (2 available, best #2, table default)
  Additional-path-install
  Path not advertised to any peer
  Refresh Epoch 5
  65001
    10.100.1.3 (metric 16) from 10.100.1.7 (10.100.1.7)
      Origin incomplete, metric 0, localpref 100, valid, internal, backup/repair, all
      Originator: 10.100.1.3, Cluster list: 10.100.1.7
      mpls labels in/out 29/16
      rx pathid: 0x0, tx pathid: 0x1
  Path advertised to update-groups:
     35        
  Refresh Epoch 5
  65001
    10.100.1.5 (metric 11) from 10.100.1.7 (10.100.1.7)
      Origin incomplete, metric 0, localpref 100, valid, internal, best
      Originator: 10.100.1.5, Cluster list: 10.100.1.7
      mpls labels in/out 29/16
      rx pathid: 0x1, tx pathid: 0x0

Ésta es la ruta para 10.100.1.1/32, según lo visto en el router PE2:

PE2#show bgp ipv4 unicast 10.100.1.1
BGP routing table entry for 10.100.1.1/32, version 4
Paths: (2 available, best #2, table default)
  Advertised to update-groups:
     5        
  Refresh Epoch 1
  65000 65001
    10.1.9.4 from 10.1.9.4 (10.100.1.4)
      Origin incomplete, localpref 100, valid, external
      mpls labels in/out 18/17
      rx pathid: 0, tx pathid: 0
  Refresh Epoch 1
  65000 65001
    10.1.10.6 from 10.1.10.6 (10.100.1.6)
      Origin incomplete, localpref 100, valid, external, best
      mpls labels in/out 18/30
      rx pathid: 0, tx pathid: 0x0

El mejor trayecto en el p3 del router es la trayectoria con el IGP 6 métricos, con el router P1 como el salto siguiente. El mejor trayecto en el router P4 es la trayectoria con el IGP 11 métricos, con el router P2 como el salto siguiente. El p3 del Routers y el P4 envían su mejor trayecto hacia el router PE2. El router PE2 escoge la trayectoria del router P4 como el mejor, que era decidido porque ambos trayectos BGP en el router PE2 son muy similares y el paso 10 era los cortacircuítos del lazo: el trayecto externo más viejo ganado. Esto significa que el tráfico del router PE2 al router PE1 toma la trayectoria PE2-P4-P2-PE1. Sin embargo, la trayectoria total más corta, cuando usted considera el IGP costar, es PE2-P3-P1-PE1.

Utilice la información que sigue para verificar el atributo de métrica AIGP en el p3 del Routers y el P4 hacia el router PE2 (10.100.1.7):

Aquí está la salida para el p3 del router:

router bgp 65000
address-family ipv4
  bgp additional-paths select all
  bgp additional-paths receive
  bgp additional-paths install
  neighbor 10.1.9.2 activate
  neighbor 10.1.9.2 aigp
  neighbor 10.1.9.2 send-label
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 aigp
  neighbor 10.100.1.7 next-hop-self
  neighbor 10.100.1.7 send-label

Aquí está la salida para el router P4:

router bgp 65000
address-family ipv4
  bgp additional-paths select all
  bgp additional-paths receive
  bgp additional-paths install
  neighbor 10.1.10.2 activate
  neighbor 10.1.10.2 aigp
  neighbor 10.1.10.2 send-label
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 aigp
  neighbor 10.100.1.7 next-hop-self
  neighbor 10.100.1.7 send-label

Usted puede ver que el p3 del router ahora tiene:

P3#show bgp ipv4 unicast 10.100.1.1
BGP routing table entry for 10.100.1.1/32, version 30
Paths: (2 available, best #2, table default)
  Additional-path-install
  Path not advertised to any peer
  Refresh Epoch 11
  65001
    10.100.1.5 (metric 21) from 10.100.1.7 (10.100.1.7)
      Origin incomplete, aigp-metric 0, metric 0, localpref 100, valid, internal,
backup/repair, all
      Originator: 10.100.1.5, Cluster list: 10.100.1.7
      mpls labels in/out 28/31
      rx pathid: 0x1, tx pathid: 0x1
  Path advertised to update-groups:
     5         
  Refresh Epoch 11
  65001
    10.100.1.3 (metric 6) from 10.100.1.7 (10.100.1.7)
      Origin incomplete, aigp-metric 0, metric 0, localpref 100, valid, internal, best
      Originator: 10.100.1.3, Cluster list: 10.100.1.7
      mpls labels in/out 28/30
      rx pathid: 0x0, tx pathid: 0x0

El router P4 ahora tiene:

P4#show bgp ipv4 unicast 10.100.1.1
BGP routing table entry for 10.100.1.1/32, version 30
Paths: (2 available, best #1, table default)
  Additional-path-install
  Path advertised to update-groups:
     35        
  Refresh Epoch 11
  65001
    10.100.1.5 (metric 11) from 10.100.1.7 (10.100.1.7)
      Origin incomplete, aigp-metric 0, metric 0, localpref 100, valid, internal, best
      Originator: 10.100.1.5, Cluster list: 10.100.1.7
      mpls labels in/out 16/31
      rx pathid: 0x1, tx pathid: 0x0
  Path not advertised to any peer
  Refresh Epoch 11
  65001
    10.100.1.3 (metric 16) from 10.100.1.7 (10.100.1.7)
      Origin incomplete, aigp-metric 0, metric 0, localpref 100, valid, internal,
backup/repair, all
      Originator: 10.100.1.3, Cluster list: 10.100.1.7
      mpls labels in/out 16/30
      rx pathid: 0x0, tx pathid: 0x1

El IGP métrico para las trayectorias en el p3 del Routers y el P4 no cambiaron, pero el router PE2 ahora recibe las rutas con el atributo AIGP del p3 del Routers y del P4.

El router PE2 ve las dos trayectorias. Cada trayectoria tiene el atributo AIGP, y la trayectoria con el atributo de métrica más bajo AIGP ahora gana:

PE2#show bgp ipv4 unicast 10.100.1.1
BGP routing table entry for 10.100.1.1/32, version 6
Paths: (2 available, best #1, table default)
  Advertised to update-groups:
     5        
  Refresh Epoch 1
  65000 65001
    10.1.9.4 from 10.1.9.4 (10.100.1.4)
      Origin incomplete, aigp-metric 6, localpref 100, valid, external, best
      mpls labels in/out 18/17
      rx pathid: 0, tx pathid: 0x0
  Refresh Epoch 1
  65000 65001
    10.1.10.6 from 10.1.10.6 (10.100.1.6)
      Origin incomplete, aigp-metric 11, localpref 100, valid, external
      mpls labels in/out 18/30
      rx pathid: 0, tx pathid: 0

Si la trayectoria que se recibe del p3 del router es más larga que la trayectoria que se recibe del router P4 en el router PE2, después el router PE2 todavía escoge la trayectoria del p3 del router como el mejor. Usted puede aumentar la trayectoria de que el p3 del router hace publicidad por uno vía un route-map y como-prepending.

router bgp 65000
address-family ipv4
neighbor 10.1.9.2 route-map as_path out

route-map as_path permit 10
set as-path prepend last-as 1

El router PE2 ahora tiene la ruta del p3 del router con un suplemento TAN en COMO la trayectoria:

PE2#show bgp ipv4 unicast 10.100.1.1
BGP routing table entry for 10.100.1.1/32, version 7
Paths: (2 available, best #1, table default)
  Advertised to update-groups:
     5        
  Refresh Epoch 1
  65000 65001 65001
    10.1.9.4 from 10.1.9.4 (10.100.1.4)
      Origin incomplete, aigp-metric 6, localpref 100, valid, external, best
      mpls labels in/out 18/nolabel
      rx pathid: 0, tx pathid: 0x0
  Refresh Epoch 1
  65000 65001
    10.1.10.6 from 10.1.10.6 (10.100.1.6)
      Origin incomplete, aigp-metric 11, localpref 100, valid, external
      mpls labels in/out 18/30
      rx pathid: 0, tx pathid: 0

Debido al atributo de métrica AIGP, el router PE2 todavía escoge la trayectoria del p3 del router como el mejor. Se realiza el control AIGP antes de que MIENTRAS QUE se marca la longitud del trayecto.

Si usted quita la capacidad de enviar el AIGP en el router P4 hacia el router PE2, después el router PE2 recibe la trayectoria sin el atributo de métrica AIGP del router P4. Sin embargo, el router PE2 todavía tiene la trayectoria del p3 del router con AIGP. El router PE2 prefiere la trayectoria con AIGP sobre una trayectoria sin AIGP, y escoge la trayectoria del p3 del router como el mejor:

PE2#show bgp ipv4 unicast 10.100.1.1
BGP routing table entry for 10.100.1.1/32, version 2
Paths: (2 available, best #2, table default)
  Advertised to update-groups:
     6        
  Refresh Epoch 1
  65000 65001
    10.1.10.6 from 10.1.10.6 (10.100.1.6)
      Origin incomplete, localpref 100, valid, external
      mpls labels in/out 17/30
      rx pathid: 0, tx pathid: 0
  Refresh Epoch 1
  65000 65001 65001
    10.1.9.4 from 10.1.9.4 (10.100.1.4)
      Origin incomplete, aigp-metric 6, localpref 100, valid, external, best
      mpls labels in/out 17/nolabel
      rx pathid: 0, tx pathid: 0x0

Nota: Si usted quisiera que el router PE2 ignorara el AIGP durante el proceso de selección del mejor trayecto BGP, después configure bgp bestpath el comando ignore del aigp.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 119001