IP : Open Shortest Path First (OSPF)

OSPF con el ejemplo de configuración de la adyacencia del Multi-área

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios

Introducción

Este documento describe cómo configurar el Routing Protocol del estado del link del Open Shortest Path First (OSPF) para la adyacencia del Multi-área.

Contribuido por Narendra Naukwal, ingeniero de Cisco TAC.

Prerrequisitos

Requisitos

Cisco recomienda que tenga conocimiento sobre estos temas:

  • OSPF

  • Adyacencia del Multi-área

Cisco también recomienda que estos requisitos estén cumplidos antes de que usted intente la configuración que se describe en este documento:

  • El Routing Protocol del estado del link OSPF se debe preconfigurar en la red.

  • Solamente dos altavoces OSPF utilizan la interfaz entre la cual las funciones del Multi-área OSPF trabajan. El Multi-área OSPF trabaja solamente en los tipos del red Point-to-Point.

Componentes Utilizados

La información en este documento se basa en el Multi-área OSPF.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Antecedentes

El Routing Protocol del estado del link OSPF utiliza el concepto de áreas, que son sub-dominios dentro del dominio OSPF. Un router dentro de un área mantiene la información de topología completa de esa área. Por abandono, una interfaz puede pertenecer solamente a una área OSPF. Esto puede no sólo causar el ruteo por debajo del nivel óptimo en la red, pero puede también llevar a otros problemas si la red no se diseña correctamente.

Cuando la adyacencia del Multi-área se configura en una interfaz, los altavoces OSPF forman más de una adyacencia (ADJ) sobre ese link. La interfaz del Multi-área es una lógica, la interfaz Point-to-Point sobre la cual se forma el ADJ. Este documento describe un escenario donde el Multi-área OSPF ADJ se puede utilizar para trabajar alrededor de un problema y cumplir los requisitos de la red.

Configurar

Diagrama de la red

En este diagrama de la red, se utiliza un dominio network/OSPF. El sistema requiere que el tráfico del router 5 (R5) al r1 (10.1.1.1) pase siempre con el R3. Asuma que el R3 es un Firewall en la red a través de la cual todo el tráfico debe ser ruteado, o que el link entre el R3 y el R4 tiene más ancho de banda que el link entre el r2 y el R4. En ambos casos, el sistema requiere que el tráfico deba atravesar el R3 cuando pasa del R5 al r1 (prefijo 10.1.1.1/32).

Configuraciones iniciales

Esta sección describe las configuraciones iniciales para el r1 con el R5.

R1

!
interface Ethernet0/0
ip address 192.168.12.1 255.255.255.0
end

!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
end

!
ip route 0.0.0.0 0.0.0.0 192.168.12.2
!

R2

!
interface Ethernet0/0
ip address 192.168.12.2 255.255.255.0
end

!
interface Ethernet0/1
ip address 192.168.23.2 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
end

!
interface Ethernet0/2
ip address 192.168.24.2 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Loopback0
ip address 10.2.2.2 255.255.255.255
end

!
ip route 10.1.1.1 255.255.255.255 192.168.12.1

!
router ospf 1
router-id 0.0.0.2
redistribute static metric-type 1 subnets
!

R3

!
interface Ethernet0/0
ip address 192.168.34.3 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Ethernet0/1
ip address 192.168.23.3 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
end

!
interface Loopback0
ip address 10.3.3.3 255.255.255.255
end

!
router ospf 1
router-id 0.0.0.3
!

R4

!
interface Ethernet0/0
ip address 192.168.34.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Ethernet0/1
ip address 192.168.45.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Loopback0
ip address 10.4.4.4 255.255.255.255
end

!
router ospf 1
router-id 0.0.0.4
!

R5

!
interface Ethernet0/1
ip address 192.168.45.5 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Loopback0
ip address 10.5.5.5 255.255.255.255
end

!
router ospf 1
router-id 0.0.0.5
!

Comportamiento predeterminado

Con las configuraciones previas en el lugar, esta sección describe los comportamientos del router predeterminado.

Aquí está la traza del R5 a 10.1.1.1. Note que el tráfico pasa con el r2, no R3:

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 6 msec 6 msec 6 msec   <<< R4
2 192.168.24.2 6 msec 6 msec 8 msec   <<< R2
3 192.168.12.1 8 msec * 3 msec        <<< R1

En esta red, el router R4 debe tomar la decisión y debe rutear el tráfico al R3, no al r2 directamente, según el requisito del sistema.

Aquí está un ejemplo de la tabla de ruteo en el R4:

R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 30, type extern 1
Last update from 192.168.24.2 on Ethernet0/2, 00:14:33 ago
Routing Descriptor Blocks:
* 192.168.24.2, from 0.0.0.2, 00:14:33 ago, via Ethernet0/2 <<< Towards R2
Route metric is 30, traffic share count is 1

Un métrico de 30 se asocia a esta ruta para el prefijo 10.1.1.1/32. Esto es debido a un valor por defecto métrico de 20 que sea utilizado por el Autonomous System Boundary Router (ASBR) (r2) y un coste de 10 en la interfaz Eth0/2 en el R4.

La trayectoria del R4 al prefijo 10.1.1.1/32 vía el R3 es más larga. Aquí, el coste para las interfaces Ethernet 0/2 en R4 (la trayectoria hacia el r2) se altera para verificar si cambia el comportamiento:

!
interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
ip ospf cost 100
end

Aquí está la traza del R5 y el comando show ip route hizo salir del R4:

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 4 msec 9 msec 8 msec   <<< R4
2 192.168.24.2 8 msec 9 msec 10 msec  <<< R2
3 192.168.12.1 10 msec * 5 msec       <<< R1
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 120, type extern 1
Last update from 192.168.24.2 on Ethernet0/2, 00:01:50 ago
Routing Descriptor Blocks:
* 192.168.24.2, from 0.0.0.2, 00:01:50 ago, via Ethernet0/2
  Route metric is 120, traffic share count is 1

Mientras que la traza muestra, el tráfico del R5 toma la misma trayectoria, y el tráfico no fluye vía el R3. También, tal y como se muestra en de la salida del comando de 10.1.1.1 de la ruta de IP de la demostración en el R4, el coste de 100 que fue agregado en R4 (interfaz Ethernet 0/2) lleva el efecto y el coste de la ruta el prefijo es 120 (opuesto a 30). Sin embargo, la trayectoria todavía no cambió y el requisito para que el tráfico fluya a través del R3 todavía no se cumple.

Para determinar la causa de este comportamiento, aquí es el comando show ip ospf border-routers R4 hecho salir (el coste en R4 las interfaces Ethernet 0/2 todavía se fija a 100):

R4#show ip ospf border-routers
            OSPF Router with ID (0.0.0.4) (Process ID 1)
                Base Topology (MTID 0)
 Internal Router Routing Table
Codes: i - Intra-area route, I - Inter-area route

i 0.0.0.2 [100] via 192.168.24.2, Ethernet0/2, ABR/ASBR, Area 99, SPF 3
i 0.0.0.3 [10] via 192.168.34.3, Ethernet0/0, ABR, Area 99, SPF 3

En el R4, usted puede ver que hay dos routeres del borde del área (ABR) (0.0.0.2, que es r2, y 0.0.0.3, que es R3) y que el r2 es el ASBR. Esta salida también muestra la información del intra-area (i) para el ASBR.

Ahora, la interfaz Ethernet 0/2 se apaga en el R4 para determinar si los flujos de tráfico vía el R3 y para ver cómo aparece la salida del comando show ip ospf border-routers:

interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
ip ospf cost 100
shutdown 
end

Aquí está la traza del R5 y el comando show ip route hizo salir del R4:

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 7 msec 7 msec 8 msec   <<< R4
2 192.168.34.3 9 msec 8 msec 8 msec   <<< R3
3 192.168.23.2 9 msec 9 msec 7 msec   <<< R2
4 192.168.12.1 8 msec * 4 msec        <<< R1
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 40, type extern 1 <<< Metric 40
Last update from 192.168.34.3 on Ethernet0/0, 00:01:46 ago  <<< Traffic to R2
Routing Descriptor Blocks:
* 192.168.34.3, from 0.0.0.2, 00:01:46 ago, via Ethernet0/0
  Route metric is 40, traffic share count is 1

Como se muestra, cuando la interfaz Ethernet 0/2 se apaga en el R4, el tráfico pasa con el R3. También, el coste que se asocia a la ruta hacia el R3 es solamente 40, mientras que el coste hacia 10.1.1.1/32 vía el r2 era 120. El protocolo OSPF todavía prefiere rutear el tráfico vía el r2 en vez del R3, aunque el coste para alcanzar 10.1.1.1/32 es más bajo vía el R3.

Aquí está la salida de los Router del borde OSPF del IP de la demostración de nuevo en el R4:

R4#show ip ospf border-routers
           OSPF Router with ID (0.0.0.4) (Process ID 1)
               Base Topology (MTID 0)
Internal Router Routing Table
Codes: i - Intra-area route, I - Inter-area route

I 0.0.0.2 [20] via 192.168.34.3, Ethernet0/0, ASBR, Area 99, SPF 4
i 0.0.0.3 [10] via 192.168.34.3, Ethernet0/0, ABR, Area 99, SPF 4

La información que se requiere para alcanzar el ASBR es la información del inter-area. Sin embargo, la información del intra-area esa los detalles cómo alcanzar el ASBR se prefiere sobre la información del inter-area con independencia del costo de OSPF que se asocia a las dos trayectorias.

Por este motivo, la trayectoria vía el R3 no fue preferida, aunque el coste vía el R3 es más bajo.

Aquí, la interfaz Ethernet 0/2 se trae la salvaguardia en el R4:

interface Ethernet0/2
no shutdown
end
!

La traza del R5 indica que ruteando las acciones vuelva a ésos observados previamente (el tráfico no fluye vía el R3):

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 6 msec 7 msec 7 msec   <<< R4
2 192.168.24.2 7 msec 8 msec 7 msec   <<< R2
3 192.168.12.1 8 msec * 12 msec       <<< R1

Hay distintas maneras que usted puede resolver este problema (esta lista no es exhaustiva):

  • Cambie el área entre el r2 y el R3 a 90, y después modifique el coste.

  • Agregue otro link entre el r2 y el R3 y configurelo para estar en el área 99.

  • Utilice el Multi-área ADJ.

Refiera a la siguiente sección para ver la manera de la cual el Multi-área OSPF ADJ trabaja y cómo puede solucionar este problema a mano.

Configuración de la adyacencia del Multi-área

Como se mencionó anteriormente, el Multi-área ADJ se puede utilizar para formar el punto múltiple para señalar las adyacencias lógicas sobre un solo link. El requisito es que debe haber solamente dos altavoces OSPF en el link, y en una red de broadcast, usted debe cambiar manualmente el tipo de red OSPF al Punto a punto en el link.

Esta característica permite que un solo vículo físico sea compartido por las áreas múltiples y crea una trayectoria del intra-area en cada uno de las áreas que comparten el link.

Para cumplir este requisito, usted debe configurar el Multi-área ADJ OSPF entre el r2 y el R3 sobre el Ethernet 0/1 del link, que está actualmente solamente en el área 0.

Aquí está la configuración para el r2:

!
interface Ethernet0/1
ip address 192.168.23.2 255.255.255.0
ip ospf network point-to-point
ip ospf multi-area 99
ip ospf 1 area 0
end

Aquí está la configuración para el R3:

!
interface Ethernet0/1
ip address 192.168.23.3 255.255.255.0
ip ospf network point-to-point
ip ospf multi-area 99
ip ospf 1 area 0
end

El OSPF ADJ sube sobre el link virtual:

%OSPF-5-ADJCHG: Process 1, Nbr 0.0.0.2 on OSPF_MA0 from LOADING to FULL, Loading Done

%OSPF-5-ADJCHG: Process 1, Nbr 0.0.0.3 on OSPF_MA0 from LOADING to FULL, Loading Done

Aquí está el ADJ recién formado:

R2#show ip ospf neighbor 0.0.0.3
<Snip>
Neighbor 0.0.0.3, interface address 192.168.23.3
   In the area 99 via interface OSPF_MA0
   Neighbor priority is 0, State is FULL, 6 state changes
   DR is 0.0.0.0 BDR is 0.0.0.0
   Options is 0x12 in Hello (E-bit, L-bit)
   Options is 0x52 in DBD (E-bit, L-bit, O-bit)
   LLS Options is 0x1 (LR)
   Dead timer due in 00:00:39
   Neighbor is up for 00:03:01
   Index 2/3, retransmission queue length 0, number of retransmission 0
   First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
   Last retransmission scan length is 0, maximum is 0
   Last retransmission scan time is 0 msec, maximum is 0 msec
R3#show ip ospf neighbor 0.0.0.2
<Snip>
Neighbor 0.0.0.2, interface address 192.168.23.2
   In the area 99 via interface OSPF_MA0
   Neighbor priority is 0, State is FULL, 6 state changes
   DR is 0.0.0.0 BDR is 0.0.0.0
   Options is 0x12 in Hello (E-bit, L-bit)
   Options is 0x52 in DBD (E-bit, L-bit, O-bit)
   LLS Options is 0x1 (LR)
   Dead timer due in 00:00:39
   Neighbor is up for 00:01:41
   Index 2/3, retransmission queue length 0, number of retransmission 0
   First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0
   Last retransmission scan length is 0, maximum is 0
   Last retransmission scan time is 0 msec, maximum is 0 msec

Verificación

Para verificar si su configuración trabaje correctamente, ingrese el comando show ip ospf border-routers en el R4:

R4#show ip ospf border-routers
           OSPF Router with ID (0.0.0.4) (Process ID 1)
                Base Topology (MTID 0)
Internal Router Routing Table
Codes: i - Intra-area route, I - Inter-area route

i 0.0.0.3 [10] via 192.168.34.3, Ethernet0/0, ABR, Area 99, SPF 10
i 0.0.0.2 [20] via 192.168.34.3, Ethernet0/0, ABR/ASBR, Area 99, SPF 10

Como se muestra, la información del intra-area que se utiliza para rutear el tráfico al r2 (0.0.0.2)/ASBR está vía el R3. Esto debe resolver el problema previamente mencionado.

Aquí está la traza del R5:

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 8 msec 9 msec 8 msec   <<< R4
2 192.168.34.3 8 msec 8 msec 8 msec   <<< R3
3 192.168.23.2 7 msec 8 msec 8 msec   <<< R2
4 192.168.12.1 8 msec * 4 msec        <<< R1

Como se muestra, el tráfico del R5 que se destina a 10.1.1.1 fluye correctamente vía el R3, y el requisito del sistema se cumple.

Ingrese el comando show ip ospf neighbor en el r2, el R3, y el R4 para verificar si los ADJ están establecidos:

R2#show ip ospf neighbor
Neighbor ID Pri  State    Dead Time  Address        Interface
0.0.0.3       0  FULL/ -  00:00:39   192.168.23.3   Ethernet0/1 
0.0.0.4       0  FULL/ -  00:00:37   192.168.24.4   Ethernet0/2
0.0.0.3       0  FULL/ -  00:00:33   192.168.23.3   OSPF_MA0 
R3#show ip ospf neighbor
Neighbor ID Pri  State    Dead Time  Address        Interface
0.0.0.2       0  FULL/ -  00:00:34   192.168.23.2   Ethernet0/1 
0.0.0.2       0  FULL/ -  00:00:35   192.168.23.2   OSPF_MA0 
0.0.0.4       0  FULL/ -  00:00:39   192.168.34.4   Ethernet0/0
R4#show ip ospf neighbor
Neighbor ID Pri  State    Dead Time  Address        Interface
0.0.0.2       0  FULL/ -  00:00:32   192.168.24.2   Ethernet0/2  
0.0.0.5       0  FULL/ -  00:00:32   192.168.45.5   Ethernet0/1
0.0.0.3       0  FULL/ -  00:00:35   192.168.34.3   Ethernet0/0

Nota: En estas salidas, las entradas de la interfaz Ethernet0/1 indican el ADJ sobre el área 0, y las entradas de la interfaz OSPF_MA0 indican el Multi-área ADJ sobre el área 99.

R4 la interfaz Ethernet 0/2 todavía tiene un coste de 100, y la trayectoria vía el R3 se prefiere en el R4. Si se quita este coste, después el R4 rutea el tráfico directamente al r2 como antes.

Aquí está la configuración y la salida del comando show ip route en el R4 con el costo de OSPF IP de 100 todavía configurados en R4 las interfaces Ethernet 0/2:

!
interface Ethernet0/2
 ip address 192.168.24.4 255.255.255.0
 ip ospf network point-to-point
 ip ospf 1 area 99
 ip ospf cost 100
!
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 40, type extern 1
Last update from 192.168.34.3 on Ethernet0/0, 00:28:45 ago
Routing Descriptor Blocks:
* 192.168.34.3, from 0.0.0.2, 00:28:45 ago, via Ethernet0/0
  Route metric is 40, traffic share count is 1

Aquí está la configuración y el comando show ip route hizo salir en el R4 cuando usted quita el coste:

interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 30, type extern 1
Last update from 192.168.24.2 on Ethernet0/2, 00:00:13 ago
Routing Descriptor Blocks:
* 192.168.24.2, from 0.0.0.2, 00:00:13 ago, via Ethernet0/2 <<< Route changed back to R2
     Route metric is 30, traffic share count is 1

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.



Document ID: 118879