Switches : Switches Cisco Catalyst de la serie 3850

3750 MLS a la conversión de 3850 MQC de la configuración de QoS

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios

Introducción

El documento describe la diferencia básica entre 3750 Calidad de Servicio (QoS) y el Modular QoS CLI (MQC) QoS del Multilayer Switching (MLS) de los Cisco Catalyst 3850 Switch. También proporciona la información detallada sobre la conversión con las configuraciones de muestra. Este documento se aplica solamente al QoS atado con alambre. Este documento está para los profesionales de redes que son responsables del diseño, del implemention, o del administation de una red que incluya un Cisco Catalyst 3850 Switch independiente o un stack del Cisco Catalyst 3850 Switch, designado el Switch.

Contribuido por Jaroslaw Gawron y Vivek Sharma, ingenieros de Cisco TAC.

Prerrequisitos

Requisitos

Cisco recomienda que tenga conocimiento sobre estos temas:

  • Cisco IOS ® Software
  • Conceptos y terminología de MLS y de MQC QoS

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Descripción para la diferencia entre 3750 MLS QoS y 3850 MQC QoS

La configuración de QoS en la línea 3850 ha sido mejorado debido a su implementación de la configuración MQC (modelo universal de la configuración de QoS) en vez de los viejos comandos MLS QoS (configuración de QoS dependiente de la plataforma) de las 3750 y 3560 líneas de Switches.

Las diferencias principales se resaltan en esta tabla:

Tipo de switch

3750

3850

Estructura básica

MLS

MQC

Valor por defecto de QoS

Inhabilitado

Habilitado

Configuración global

Soporte MLS QoS

Soporte algo de MQC en el ingreso

No soporta MLS QoS

[class-map, policy-map] del soporte MQC

Config de la interfaz

Soporte los config MLS QoS y algunos de MQC CLI en el ingreso

Asocie la directiva a la interfaz

Valor por defecto de la confiabilidad del puerto

Inhabilitado

Habilitado

Ingreso del puerto

Clasificación/policing/marca

Envío a cola

Clasificación/policing/marca

[NO Iingress Queuing!]

Salida del puerto

Envío a cola

Clasificación/policing/marca/Datos en espera

Ingreso de la interfaz virtual del Switch (SVI)

Clasificación/policing/marca

Clasificación /Marcado

Salida SVI

Ninguno

Clasificación /Marcado

Es importante reconocer el cambio fundamental principal en el acercamiento de QoS.

En los 3750, por abandono el QoS se inhabilita mientras que en los 3850, se habilita. También para preservar la capa 2 marca (L2)/Layer 3 (L3) QoS en la plataforma 3750, una configuración de la confianza deben ser aplicados.

En el caso de los 3850, todos los paquetes por abandono se confían en (la marca L2/L3 se preserva QoS), a menos que usted la cambie con una aplicación de una correspondencia de políticas específica en el ingreso o la interfaz de egreso.

Modelo de 3750 QoS

Modelo de 3850 QoS

Tabla de comparación del detalle de la característica

Acceso

Función

3750

3850

Clasificación

Differentiated Services Code Point de la coincidencia del Clase-mapa (DSCP), precedencia (Prec), lista de control de acceso (ACL)

Soporta corresponda con todos y el match-any

Clase de Servicio (CoS) del Clase-mapa, Prec, DSCP, ACL

Y VLA N

Soporta el match-any solamente

Marcación

[unconditional set]

Fije el DSCP y Prec

Fije CoS, Prec, el DSCP y al QoS-grupo

Marcación

[conditional marking]

Mutación DSCP

Tabla-mapa del class-default

Control de tráfico

1r2c

1r2c y 2r3c

Vigilancia de la disminución

El policing excede la disminución

[Only supports DSCP]

El policing excede y viola la disminución

[Supports CoS, DSCP, Prec]

Policing global

Soportes

[one type of  HQoS] del Agg-policing

Datos en espera del ingreso

Los soportes solamente en 3750 pero no soportan en 3750x

No soporta

QoS jerárquico (HQoS)

El VLA N basó HQoS solamente

Agg-policing y por el VLAN (PV) del acceso basado

Egress

Función

3750

3850

Soporte de la clasificación para ningunos acción de los Datos en espera

No soporta

CoS, Prec, DSCP, QoS-grupo, ACL

y VLA N

Soporte de la clasificación para la acción de espera

CoS y DSCP

CoS, Prec, DSCP y QoS-grupo

Marcación

No soporta

Fije CoS, Prec, y el DSCP

Control de tráfico

No soporta

1r2c, 2r3c con exceden/violan la marca abajo a través del tabla-mapa

Número máximo de colas de administración del tráfico y de tipos de cola

[4 queues] 1P3Q3T

Apresure el priority queue del queue->

[up to 8 queues] 2P6Q3T

Datos en espera de la salida

Comparta el modo, el modo de la dimensión de una variable, el cola-límite, la prioridad y el búfer de cola

Ancho de banda, el permanecer del ancho de banda, el formar, cola-límite, prioridad y búfer de cola

HQoS

No soporta

HQoS: Agg-policing, PV, Puerto-shaper y shaper del usuario del padre con la acción de los NON-Datos en espera del niño

Comandos show comunes de QoS

3750

Comandos show de la entrada:

show run class-map  [name_of_class-map]
show run policy-map [name of policy-map]
show policy-map int [interface_name]

Comandos show generales:

show mls qos maps
show mls qos maps <options>
show mls qos queue-set
show mls qos interface [interface_name] queuing
show platform port-asic stats drop [interface_name] statistics
show mls qos aggregate-policer

3850

show run class-map [name_of_class-map]
show run policy-map [name of policy-map]
show table-map [name_of_table-map]
show run policy-map [name_of_policy-map]
show policy-map int [interface_name]
show platform qos policies port sw [sw#]
show platform qos queue config interface_type [interface_name]
show platform qos queue stats interface_type [interface_name]

3750 a la muestra de la conversión de 3850 QoS

Config de QoS

3750

[Global]

           3750

        [interface]

     3850 *

 

Link de la muestra

Neutralización de QoS

Ningún MLS QoS

Dos colas de administración del tráfico

Cola de Control-> (2)

Datos - > cola (4)

Salida sin la directiva

Control - > queue(1)

Datos - > queue(2)

Ejemplo 1

Confianza o conjunto en el ingreso y la salida

Acción de espera basada en el ingreso

Confianza o conjunto

MLS QOS

a)

Confianza CoS MLS QoS

La política de colocación encola de la salida clasifica en el [ingress need config trust CoS] de CoS

‘Ejemplo 2’

b)

Confianza DSCP MLS QoS

la política de colocación encola de la salida clasifica en el DSCP

Ejemplo 3

c)

Política de entrada con la acción del conjunto para marcar el valor DSCP

La política de colocación encola de la salida clasifica en el DSCP

Ejemplo 4

d)

Ningún [both CoS/DSCP will be set zero] de los config de la confianza MLS QoS

Política de entrada con el class-default

Fije el CoS/DSCP 0

Ejemplo 5

Mapeo de cola del CoS/DSCP

El MLS QoS compartió el ordenamiento cíclico (SRR) - [CoS-map/DSCP-map] de la salida de la cola

A, b, c y d utilizarán la nueva asignación correspondiente

[CoS/DSCP] explícito de la clasificación de la salida con la acción de los Datos en espera

Ejemplo 6

Mutación DSCP

Mutación MLS QoS DSCP

Configuración de la necesidad de la interfaz

Confianza DSCP MLS QoS

DSCP-mutación MLS QoS [name]

Directiva de la entrada de la interfaz con el tabla-mapa

Ejemplo 7

Agg-policing

MLS QoS aggregatepolicing

Configuración del interfaz-nivel de la necesidad

[one type of HQoS] del Agg-policing

Ejemplo 8

Policía-disminución

Correspondencia limpiar-DSCP MLS QoS [10] [11] a [63]

La política de establecimiento de políticas que asocia para interconectar, excede no el descenso, el limpiar-DSCP global tomará el efecto

[Input]

Un tabla-mapa para se excede y una acción del forviolate del tabla-mapa del policing

[Input and output]

Ejemplo 9

Límite de cola

El cola-conjunto MLS QoS hizo salir [1] el umbral [1] [100] [100] [50] [200]

1-> cola-conjunto 1

cola 1 <1->

Umbral 1

Umbral 2

Buffer reservado

Umbral máximo

Cola-conjunto de los Config [2]

[Cola-conjunto predeterminado 1]

Política de colocación encola de la salida con la acción de los Datos en espera y la configuración del cola-límite

Ejemplo 10

Búferes de cola

Buffers [1] hechos salir cola-conjunto MLS QoS

[15] [25] [40] [20]

Cola-conjunto de los config de la interfaz

Directiva-mapa con la acción y la relación de transformación [0-100] de los Datos en espera de los búferes de cola

Ejemplo 11

Parte/ancho de banda

MLS QOS

Config del nivel de la interfaz

“parte 1 del ancho de banda de la SRR-cola 30 35 [Share mode] del 5"

Ancho de banda en el directiva-mapa

Ejemplo 12

priority queue

[Expedite queue]

MLS QOS

Los config “prioridad-cola del nivel de la interfaz hacia fuera”, esto harán la 1ra cola de los cola-conjuntos correspondientes como priority queue

Nivel de prioridad 1 en el directiva-mapa

Ejemplo 13

Shaper

MLS QOS

[shape mode] de la dimensión de una variable del ancho de banda de la SRR-cola

Media de la dimensión de una variable en el directiva-mapa

Ejemplo 14

Puerto-shaper

MLS QOS

límite del ancho de banda de la SRR-cola

Puerto-shaper

Ejemplo 15

HQoS

MLS QOS

[attach policy to SVI] SVI y configuración “MLS QoS VLAN_based” de las necesidades de la interfaz

Directiva PV

Y directiva de la fijación al puerto en la dirección de la entrada

Ejemplo 16

Ejemplo 1: Neutralización de QoS

3750 (configuración global)

3750 (interfaz)

3850

Ningún MLS QoS

Cola dos [cola 2 del control uno, datos una cola 4]

 

Salida sin la directiva

[Pkts del control en la cola 1 y paquetes de datos en la cola 2]

3750

3750#show mls qos
QoS is disabled <- disable
QoS ip packet dscp rewrite is enabled

3750#show mls qos interface gig1/0/1 statistics | b output queues enqueued
output queues enqueued:
queue: threshold1 threshold2 threshold3
-----------------------------------------------
queue 0: 4 0 0
queue 1: 0 0 0 <- control
queue 2: 0 0 0
queue 3: 0 0 0 <- data

output queues dropped:
queue: threshold1 threshold2 threshold3
-----------------------------------------------
queue 0: 0 0 0
queue 1: 0 0 0 <- control
queue 2: 0 0 0
queue 3: 0 0 0 <- data

Policer: Inprofile: 0 OutofProfile: 0

3850

3850#show ru int gig1/0/1
interface GigabitEthernet1/0/1
end

3850#show platform qos queue config gigabitEthernet 1/0/1 sw 1
DATA Port:21 GPN:1 AFD:Disabled QoSMap:0 HW Queues: 168 - 175
DrainFast:Disabled PortSoftStart:1 - 600
----------------------------------------------------------
DTS Hardmax Softmax PortSMin GlblSMin PortStEnd
--- -------- -------- -------- --------- ---------
0 1 5 120 6 480 0 0 0 0 0 800 <- control
1 1 4 0 7 720 2 480 2 180 2 800 <- data
2 1 4 0 5 0 0 0 0 0 0 800
3 1 4 0 5 0 0 0 0 0 0 800
4 1 4 0 5 0 0 0 0 0 0 800
5 1 4 0 5 0 0 0 0 0 0 800
6 1 4 0 5 0 0 0 0 0 0 800
7 1 4 0 5 0 0 0 0 0 0 800
Priority Shaped/shared weight shaping_step
-------- ------------ ------ ------------
0 0 Shared 50 0
1 0 Shared 75 0
2 0 Shared 10000 179
3 0 Shared 10000 0
4 0 Shared 10000 0
5 0 Shared 10000 0
6 0 Shared 10000 192
7 0 Shared 10000 0

Weight0 Max_Th0 Min_Th0 Weigth1 Max_Th1 Min_Th1 Weight2 Max_Th2 Min_Th2
------- ------- ------ ------ ------ ------ ------ ------ ------
0 0 478 0 0 534 0 0 600 0
1 0 573 0 0 641 0 0 720 0
2 0 0 0 0 0 0 0 0 0
3 0 0 0 0 0 0 0 0 0
4 0 0 0 0 0 0 0 0 0
5 0 0 0 0 0 0 0 0 0
6 0 0 0 0 0 0 0 0 0
7 0 0 0 0 0 0 0 0 0

Ejemplo 2: Confianza COS del permiso de QoS

3750 (global)

3750 (interfaz)

3850

MLS QOS

Interfaz “confianza CoS MLS QoS” (basado en la CoS-asignación predeterminada al cola-conjunto 1)

Política de colocación encola de la salida basada en CoS (confianza CoS de los config de la necesidad del ingreso)

 

3750

Global config:
3750(config)#mls qos

Interface config:

interface GigabitEthernet1/0/1
mls qos trust cos

Related show cli:

3750#sh mls qos
QoS is enabled
QoS ip packet dscp rewrite is enabled

3750#sh mls qos int gig1/0/1
GigabitEthernet1/0/1
trust state: trust cos
trust mode: trust cos
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: none
qos mode: port-based

3750 #show mls qos maps cos-output-q
Cos-outputq-threshold map:
cos: 0 1 2 3 4 6 7
------------------------------------------------------------
queue-threshold: 2-1 2-1 3-1 3-1 4-1 1-1 4-1 4-1

Note: cos value 0 maps to 2-1 [queue-set1 : queue2 threshold 1]

3850

Ingress: apply policy-map trust-cos
Egress: create class based on cos and have queuing action for each class

Ingress policy:
3850#show run policy-map trust-cos
class class-default
set cos cos table default

3850#show table-map default
Table Map default
default copy

Egress policy:
3850#show run policy-map example2
class cos5
bandwidth percent 15
class cos0_1
bandwidth percent 25
class cos2_3
bandwidth percent 40
class cos4_6_7
bandwidth percent 20

3850#show run class-map cos5
class-map match-any cos5
match cos 5

3850#show run class-map cos0_1
class-map match-any cos0_1
match cos 0
match cos 1

3850#show run class-map cos2_3
class-map match-any cos2_3
match cos 2
match cos 3

3850#show run class-map cos4_6_7
class-map match-any cos4_6_7
match cos 4
match cos 6
match cos 7

Ejemplo 3: Confianza DSCP del permiso de QoS

3750 (global)

3750 (interfaz)

3850

MLS QOS

Interfaz “confianza DSCP MLS QoS” [basada en el Mapeo de DSCP predeterminado al cola-conjunto 1]

Confianza predeterminada DSCP de la entrada

Política de colocación encola de la salida basada en el DSCP

3750

config
3750(config)#mls qos <- Global
interface GigabitEthernet1/0/1 <- Interface
mls qos trust dscp


3750#sh mls qos int gig1/0/1
GigabitEthernet1/0/1
trust state: trust dscp
trust mode: trust dscp
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: none
qos mode: port-based

3750#show mls qos maps dscp-output-q
Dscp-outputq-threshold map:
d1 :d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------------------------------
0 : 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
1 : 02-01 02-01 02-01 02-01 02-01 02-01 03-01 03-01 03-01 03-01
2 : 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01
3 : 03-01 03-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01
4 : 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 04-01 04-01
5 : 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01
6 : 04-01 04-01 04-01 04-01

3850

Ingress: default trust dscp, no policy needed

Egress: use dscp as classification and add queuing action based on customer need

One Sample config:
Plolicy-map:
3850#show run policy-map dscp-shape
class dscp56
shape average percent 10
class dscp48
shape average percent 11
class dscp40
shape average percent 12
class dscp32
shape average percent 13
Class-map:
3850#show run class-map dscp56
class-map match-any dscp56
match dscp cs7

3850#show run class-map dscp48

class-map match-any dscp48
match dscp cs6

3850#show run class-map dscp40
class-map match-any dscp40
match dscp cs5

3850#show run class-map dscp32
class-map match-any dscp32
match dscp cs4

Ejemplo 4: Permiso de QoS con una interfaz que tiene una directiva del conjunto

3750 (global)

3750 (interfaz)

3850

MLS QOS

Directiva de la entrada de la interfaz con la acción del conjunto para marcar el valor del CoS/DSCP

[Marked value will be used for egress mapping]

Política de egress explícita de la necesidad para hacer la asignación de los Datos en espera

3750

3750#show run class-map dscp-1
class-map match-any dscp-1
match ip dscp 1

c3750#show run policy-map set-dscp-63
class dscp-1
set dscp 63

3750#show run int f7/0/2
interface FastEthernet7/0/2
mls qos trust dscp
service-policy input set-dscp-63

3750#show policy-map int f7/0/2
FastEthernet7/0/2

Service-policy input: set-dscp-63

Class-map: dscp-1 (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp 1

Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
0 packets, 0 bytes
5 minute rate 0 bps

Note: Pkts come in interface fa7/0/2, dscp1 will be marked to dscp63 which mapping
based on the existing mapping table, other pkts will retain original dscp value
mapping accordingly

3850

Input will be same as 3750 config 

Egress: will add queuing action under class dscp-63


One sample config:

3850#show run policy-map dscp63-queuing
class dscp63
bandwidth percent 50

3850#show class-map dscp63
Class Map match-any dscp63

Match dscp 63

Ejemplo 5: Permiso de QoS sin la confianza MLS QoS en la interfaz

3750 (global)

3750 (interfaz)

3850

MLS QOS

CoS/DSCP de la confianza de los config MLS QoS de la interfaz no

[El CoS/DSCP será fijado a 0]

Directiva de la entrada de la interfaz con el class-default

Fije DSCP 0, política de resultado con la clase DSCP0 con la acción de los Datos en espera

3750

Global:
c3750(config)#mls qos

Interface:
interface GigabitEthernet2/0/45
!

3850

Input policy:
c3850#show run policy-map example5-input
class class-default
set dscp default

Output policy:
c3850#show run policy-map example5-output
class dscp0
shape average percent 10 <- queuing action based on customer need

Attach to the ingress port:
c3850#show run int gig1/0/1
interface GigabitEthernet1/0/1
service-policy input example5-input

Attach to the egress port:
c3850#show ru int gig1/0/2
interface GigabitEthernet1/0/2
service-policy output example5-output

Ejemplo 6: Permiso de QoS con el mapeo de cola del CoS/DSCP del cambio

3750 (global)

3750 (interfaz)

3850

Config de la asignación de la SRR-cola MLS QoS

(SRR-cola MLS QoS hecha salir [del mapa de CoS de la cola umbral [3] [4 5] [1])

A, b, c y d utilizarán la nueva tabla de correspondencia

[CoS 4 y 5 será correspondencia para hacer cola 1 umbral 3]

Clasificación explícita de la salida con la acción de los Datos en espera

3750

Before config:
3750#show mls qos maps cos-output-q
Cos-outputq-threshold map:
cos: 0 1 2 3 4 5 6 7
------------------------------------------------
queue-threshold: 2-1 2-1 3-1 3-1 4-1 1-1 4-1 4-1

User config mapping:
3750(config)#mls qos srr-queue output cos-map queue 3 threshold 3 0

New mapping table after config
3750#show mls qos maps cos-output-q
Cos-outputq-threshold map:
cos: 0 1 2 3 4 5 6 7
------------------------------------------------
queue-threshold: 3-3 2-1 3-1 3-1 4-1 1-1 4-1 4-1

3850

Input : need apply trust-cos policy:
3850#show run policy-map trust-cos
class class-default
set cos cos table default

3850#show table-map default
Table Map default
default copy


Egress policy:

Before changing mapping:
Sample config:
3850#show run policy-map example2
class cos5
bandwidth percent 15
class cos0_1
bandwidth percent 25
class cos2_3
bandwidth percent 40
class cos4_6_7
bandwidth percent 20

3850#show run class-map cos5
class-map match-any cos5
match cos 5

3850#show run class-map cos0_1
class-map match-any cos0_1
match cos 0
match cos 1

3850#show run class-map cos2_3
class-map match-any cos2_3
match cos 2
match cos 3

3850#show run class-map cos4_6_7
!
class-map match-any cos4_6_7
match cos 4
match cos 6
match cos 7

After mapping changing , corresponding sample config:

3850#show run policy-map example6
class cos5
bandwidth percent 15
class cos1
bandwidth percent 25
class cos0_2_3
bandwidth percent 40
class cos4_6_7
bandwidth percent 20

3850#show class-map cos5
Class Map match-any cos5 (id 25)
Match cos 5

3850#show run class-map cos1
class-map match-any cos1
match cos 1

3850#show run class-map cos0_2_3
class-map match-any cos0_2_3
match cos 0
match cos 2
match cos 3

3850#show run class-map cos4_6_7
class-map match-any cos4_6_7
match cos 4
match cos 6
match cos 7

Ejemplo 7: Permiso MLS con la mutación DSCP

3750 (global)

3750 (interfaz)

3850

Mutación MLS QoS DSCP

Confianza DSCP de los config MLS QoS de la necesidad de la interfaz

[name is defined in global] del nombre de la DSCP-mutación MLS QoS

Directiva de la entrada de la interfaz con el tabla-mapa que asocia diverso DSCP

3750

Global config :
3750(config)#mls qos map dscp-mutation dscp-mutation 0 1 to 63
3750(config)#mls qos map dscp-mutation dscp-mutation 2 3 to 62

Global show cli:
c3750#show mls qos maps dscp-mutation

Dscp-dscp mutation map:
dscp-mutation:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 63 63 62 62 04 05 06 07 08 09
1 : 10 11 12 13 14 15 16 17 18 19
2 : 20 21 22 23 24 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 46 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63
Dscp-dscp mutation map:
Default DSCP Mutation Map:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 00 01 02 03 04 05 06 07 08 09
1 : 10 11 12 13 14 15 16 17 18 19
2 : 20 21 22 23 24 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 46 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63

Interface config:

interface FastEthernet7/0/3
description trust dscp
mls qos trust dscp
mls qos dscp-mutation dscp-mutation

c3750#show mls qos int f7/0/3
FastEthernet7/0/3
trust state: trust dscp
trust mode: trust dscp
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: dscp-mutation
Trust device: none
qos mode: port-based

Interface using default dscp-table:

c3750#show mls qos int g3/0/1
GigabitEthernet3/0/1
trust state: not trusted
trust mode: not trusted
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: none
qos mode: port-based

3850

Ingress : apply policy with dscp table-map
Egress: classify on new dscp value with queuing action

Ingress:
3850#show table-map dscp-2-dscp
Table Map dscp-2-dscp
from 0 to 63
from 1 to 63
from 2 to 62
from 3 to 62
default copy
3850#show run policy-map example7-input
class class-default
set dscp dscp table dscp-2-dscp

Egress:
3850#show run policy-map example7-output

class dscp63
shape average percent 20 [ queuing action based on the user need]
class dscp62
shape average percent 30 [queuing action based on user need]

Ejemplo 8: Permiso MLS QoS con el policing global

3750 (global)

3750 (interfaz)

3850

Policing del agregado MLS QoS

[All classes using the agg-policing will share the policing rate]

Config del nivel de la interfaz de la necesidad

Agg-policing (HQoS)

Acción de excedente descartada agg_traffic 8000 8000 del supervisor de agregados MLS QoS

Interfaz que tiene directiva que tiene agg_traffic como nombre del policer del agg

3750

Global:
mls qos aggregate-policer agg_traffic 8000 8000 exceed-action drop

Access-list:
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 2 permit 10.0.0.0 0.0.0.255

Class-map:
class-map match-all agg1
match access-group 1
class-map match-all agg2
match access-group 2

Policy-map:
policy-map agg_policer
class agg1
set dscp 40
police aggregate agg_traffic
class agg2
set dscp 55
police aggregate agg_traffic

Note: class agg1 and agg2 will share the same policing rate

3850

policy-map agg_police
class class-default
police cir 8000
service-policy child

policy-map child
class agg1
set dscp 40
class agg2
set dscp 55

Ejemplo 9: Permiso MLS con la marca del policing abajo

3750 (configuración global)

3750 (interfaz)

3850

Correspondencia limpiar-DSCP x MLS QoS a y

Mientras la interfaz tenga política de establecimiento de políticas, excédase es transmiten, el CLI global tomará el [input only] del efecto

Un tabla-mapa para se excede y uno para la acción de violación del policing, de la entrada, y de la salida

3750

Default policed-dscp map:
3750#show mls qos map policed-dscp
Policed-dscp map:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 00 01 02 03 04 05 06 07 08 09
1 : 10 11 12 13 14 15 16 17 18 19
2 : 20 21 22 23 24 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 46 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63

User define policed-dscp map:
3750(config)#mls qos map policed-dscp 0 10 18 24 46 to 8
3750#show mls qos map policed-dscp
Policed-dscp map:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 08 01 02 03 04 05 06 07 08 09
1 : 08 11 12 13 14 15 16 17 08 19
2 : 20 21 22 23 08 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 08 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63

Policy config:
class-map match-all policed-dscp
match access-group 2
class policed-dscp
police 8000 8000 exceed-action policed-dscp-transmit

Attach the above policy at ingress:

Note : Mark down table can be used by policing and interface policing
as long as exceed action is transmit

3850

3850(config)#table-map policed-dscp
3850(config-tablemap)#map from 0 to 8
3850(config-tablemap)#map from 10 to 8
3850(config-tablemap)#map from 18 to 8
3850(config-tablemap)#map from 24 to 8
3850(config-tablemap)#map from 46 to 8
3850#show table-map policed-dscp
Table Map policed-dscp
from 0 to 8
from 10 to 8
from 18 to 8
from 24 to 8
from 46 to 8
default copy

3850#show policy-map policed-dscp
Policy Map policed-dscp
Class class-default
police cir percent 10
conform-action transmit
exceed-action set-dscp-transmit dscp table policed-dscp

Ejemplo 10: Permiso MLS QoS con la configuración del Cola-límite

3750 (global)

3750 (interfaz)

3850

El cola-conjunto MLS QoS hizo salir 1 umbral 1100 100 50 200 (el cola-límite)

[1 - >queue-set 1,

cola 1->first,

100 - >threshold 1,

100 - >threshold 2,

50 - > reservó el buffer,

200 - > umbral máximo]

Cola-conjunto de los config de la interfaz

[El valor por defecto es el cola-conjunto 1]

Política de colocación encola de la salida con la acción de los Datos en espera y los config del q-límite

3750

Global config:
mls qos srr-queue output cos-map queue 2 threshold 1 2
mls qos srr-queue output cos-map queue 2 threshold 2 3
mls qos srr-queue output cos-map queue 2 threshold 3 6 7


If no interface config, the queue-set 1 will be used:

3750#show mls qos queue-set 1
Queueset: 1
Queue : 1 2 3 4
----------------------------------------------
buffers : 15 25 40 20
threshold1: 100 125 100 60
threshold2: 100 125 100 150
reserved : 50 100 100 50
maximum : 200 400 400 200

For interface config queue-set 2 explicitly:

3750#show mls qos queue-set 2
Queueset: 2
Queue : 1 2 3 4
----------------------------------------------
buffers : 25 25 25 25
threshold1: 100 200 100 100
threshold2: 100 200 100 100
reserved : 50 50 50 50
maximum : 400 400 400 400

3850

(multiple class with queue-limit turn on)
3850#show policy-map q-limit
Policy Map q-limit
Class users-class
Queuing action ( shaper, bandwidth and bandwidth remaining)
queue-limit cos 2 percent 50
queue-limit cos 3 percent 50
queue-limit cos 6 percent 70
queue-limit cos 7 percent 70
Note: using the above config, cos 2 and cos 3 will be dropped earlier then cos 6 and 7

Ejemplo 11: Permiso MLS QoS con la configuración del búfer de cola

3750 (global)

3750 (interfaz)

3850

El cola-conjunto MLS QoS hecho salir [1] mitiga [15 25 40 20]

Cola-conjunto de los config de la interfaz [cola-conjunto predeterminado 1]

Directiva-mapa con la acción y la relación de transformación [0-100] de los Datos en espera de los búferes de cola

3750

Default queue-buffer :
3750#show mls qos queue-set 1
Queueset: 1
Queue : 1 2 3 4
----------------------------------------------
buffers : 25 25 25 25
threshold1: 100 200 100 100
threshold2: 100 200 100 100
reserved : 50 50 50 50
maximum : 400 400 400 400

User define queue-buffer:
mls qos queue-set output 1 buffers 15 25 40 20

3750#show mls qos queue-set 1
Queueset: 1
Queue : 1 2 3 4
----------------------------------------------
buffers : 15 25 40 20
threshold1: 100 125 100 60
threshold2: 100 125 100 150
reserved : 50 100 100 50
maximum : 200 400 400 200

3850

3850#show policy-map  queue-buffer
Policy Map queue-buffer
Class cos7
bandwidth percent 10
queue-buffers ratio 15
Class cos1
bandwidth percent 30
queue-buffers ratio 25

class-map:
========
3850#show class-map cos7
Class Map match-any cos7 (id 22)

Match cos 7

3850#show class-map cos1
Class Map match-any cos1 (id 28)

Match cos 1

Attach to the interface at egress direction:

Ejemplo 12: Permiso MLS QoS con la configuración de ancho de banda

3750 (global)

3750 (interfaz)

3850

MLS QoS (modo de la parte)

Config del nivel de la interfaz

“parte 1 del ancho de banda de la SRR-cola 30 35 5"

Ancho de banda en el directiva-mapa

3750

Default share and shape mode:
3750-3stack#show mls qos interface gig 1/0/1 queueing
GigabitEthernet1/0/1
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 25 0 0 0
Shared queue weights : 25 25 25 25
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

User config share mode under interface:
interface GigabitEthernet1/0/1
srr-queue bandwidth share 40 30 20 10
srr-queue bandwidth shape 0 0 0 0


3750#show mls qos interface gig1/0/1 queueing
GigabitEthernet1/0/1
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 0 0 0 0
Shared queue weights : 40 30 20 10
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

3850

3850#show policy-map  bandwidth
Policy Map bandwidth
Class cos1
bandwidth percent 40
Class cos2
bandwidth percent 30
Class cos3
bandwidth percent 20
Class class-default
bandwidth percent 10
3850#show class-map cos1
Class Map match-any cos1

Match cos 1

3850#show class-map cos2
Class Map match-any cos2

Match cos 2

3850#show class-map cos3
Class Map match-any cos3 (id 26)

Match cos 3

3850#show class-map cos4
Class Map match-any cos4 (id 25)

Match cos 4

Ejemplo 13: Permiso MLS QoS con la prioridad

3750 (global)

3750 (interfaz)

3850

[expedite queue] MLS QoS

Nota: apresure la cola lo mismo que el priority queue

Del nivel de la interfaz de los config de la “prioridad-cola [make corresponding queue-set's 1st queue as strict priority queue] hacia fuera”

Nivel 1 de Prioriy en el directiva-mapa

3750

interface GigabitEthernet1/0/2
priority-queue out
end

3750#show mls qos interface gig1/0/2 queueing
GigabitEthernet1/0/2
Egress Priority Queue : enabled
Shaped queue weights (absolute) : 25 0 0 0
Shared queue weights : 25 25 25 25
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

3850

3850#show run policy-map  priority-queue
class cos7
priority level 1 ? strict priority
class cos1
shape average percent 10
Attach the above policy to interface at egress side:

Ejemplo 14: Permiso MLS QoS con la configuración del shaper

3750

Default shape mode:
GigabitEthernet1/0/3
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 25 0 0 0
Shared queue weights : 25 25 25 25
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

User define shape mode:
interface GigabitEthernet1/0/3
srr-queue bandwidth shape 4 4 4 4


3750-3stack#show mls qos interface gigabitEthernet 1/0/3 queueing
GigabitEthernet1/0/3
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 4 4 4 4
Shared queue weights : 25 25 25 25
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

3850

3850#show policy-map shape
Policy Map shape
Class cos1
Average Rate Traffic Shaping
cir 25%
Class cos2
Average Rate Traffic Shaping
cir 25%
Class cos3
Average Rate Traffic Shaping
cir 25%
Class cos4
Average Rate Traffic Shaping
cir 25%

Ejemplo 15: Permiso MLS QoS con el ancho de banda

3750 (global)

3750 (interfaz)

3850

MLS QOS

límite del ancho de banda de la SRR-cola

Velocidad, ancho de banda

3750

interface GigabitEthernet1/0/4
srr-queue bandwidth limit 50


3750-3stack#show mls qos interface g1/0/4 queueing
GigabitEthernet1/0/4
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 25 0 0 0
Shared queue weights : 25 25 25 25
The port bandwidth limit : 50 (Operational Bandwidth:50.0)
The port is mapped to qset : 1

3850

3850#show policy-map default-shape
Policy Map default-shape
Class class-default
Average Rate Traffic Shaping
cir 50%
service-policy child [ queuing based on customer need]

Ejemplo 16: HQoS

3750 (configuración global)

3750 (interfaz)

3850

Clase-mapa,

Directiva-mapa

Asocie la directiva al SVI

La interfaz necesita la configuración “MLS QoS vlan_based”

Política de ingreso PV

3750

Note:
SVI: Parent [class acl based class-map->policing]

Child [class interface range class-map->marking]


Child class-map:

3750(config)# class-map cm-interface-1
3750(config-cmap)# match input gigabitethernet3/0/1 - gigabitethernet3/0/2

Child policy-map:
3750(config)# policy-map port-plcmap-1
3750(config-pmap)# class cm-interface-1
3750(config-pmap-c)# police 900000 9000 drop


Parent class-map matching acl:
3750(config)# access-list 101 permit ip any any

Parent class-map:
3750(config)# class-map cm-1
3750(config-cmap)# match access 101

3750(config)# policy-map vlan-plcmap
3750(config-pmap)# class cm-1
3750(config-pmap-c)# set dscp 7
3750(config-pmap-c)# service-policy port-plcmap-1
3750(config-pmap-c)# exit
3750(config-pmap)# class cm-2
3750(config-pmap-c)# service-policy port-plcmap-1
3750(config-pmap-c)# set dscp 10

Attach the policy to the interface:
3750(config)# interface vlan 10
3750(config-if)# service-policy input vlan-plcmap

3850

Note: Due to target change, this can't be one to one mapping, need config based on
customer requirement.


Target is at port level
Parent classify on vlan
Child: none vlan classification [for example cos/dscp]


3850#sh run policy-map PV_parent_marking_child_policing
class vlan10
set dscp 63
service-policy child_class_dscp_policing
class vlan11
set cos 5
service-policy child_class_dscp_policing
class vlan12
set precedence 6
service-policy child_class_dscp_policing

3850#sh run policy-map child_class_dscp_policing
class dscp1
police cir percent 12
class dscp2
police cir percent 15
class dscp3
police cir percent 20
class class-default
police cir percent 22

3850#sh run class-map vlan10
class-map match-any vlan10
match vlan 10

3850#sh run class-map vlan11
class-map match-any vlan11
match vlan 11

3850#sh run class-map vlan12
class-map match-any vlan12
match vlan 12

3850#sh run class-map dscp1
class-map match-any dscp1
match dscp 1

3850#sh run class-map dscp2
class-map match-any dscp2
match dscp 2

3850#sh run class-map dscp3
class-map match-any dscp3
match dscp 3


Document ID: 118629