Switches : Switches Cisco Nexus de la serie 5000

Configuración de FCoE entre el adaptador VIC en el 5500 Switch del servidor y del nexo del estante UCS

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios

Introducción

Este documento describe cómo configurar el Fibre Channel sobre la Conectividad de los Ethernetes (FCoE) entre los adaptadores del indicador luminoso LED amarillo de la placa muestra gravedad menor de interfaz virtual (VIC) instalados en los servidores del estante del Cisco Unified Computing System (UCS) y el nexo de Cisco 5500 (nexo 5K) switches de la serie. Dos topologías de ejemplo incluyen los dispositivos del suplemento de la tela de Cisco (FEX), y una topología de ejemplo no hace.

Contribuido por Padmanabhan, ingeniero de Cisco TAC.

Prerrequisitos

Requisitos

Cisco recomienda que tenga conocimiento sobre estos temas:

  • 5500 Series Switch del nexo de Cisco
  • Servidor del estante de Cisco UCS - Configuración del regulador de la administración integrada de Cisco (CIMC)
  • Comprensión básica de FCoE

Esta configuración existe en el entorno:

  • El arsenal de la Red de área de almacenamiento (SAN) se configura para proporcionar el acceso a los números de unidad lógica (LUN) para los adaptadores virtuales del bus del host (vHBAs) en el indicador luminoso LED amarillo de la placa muestra gravedad menor de Cisco VIC.
  • La versión 5.1(3)N1(1a) o posterior del nexo de Cisco está instalada en los 5K Switch del nexo de Cisco.
  • Las licencias necesarias están instaladas en los 5K Switch del nexo.

Refiera a la guía de configuración de cada dispositivo de hardware específico para las limitaciones y la información sobre compatibilidad.

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • Servidor de Cisco UCS C220 M3 con VIC 1225
  • CIMC 1.5.4 conjuntos del firmware
  • Nexo 5548UP con la versión 6.0(2)N2(1)
  • Modelo FEX - Nexo 2232PP

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Información general

Ésta es una descripción del proceso de configuración:

  1. Para una nueva configuración, realice la configuración básica en los 5K Switch del nexo. Usted puede saltar este paso si usted está agregando un servidor a una red existente.
  2. Configure el adaptador VIC en el servidor UCS.
  3. Configure los 5K Switch del nexo basados en su topología.

El servidor se puede desplegar en una de estas tres topologías:

  • Topología 1 - Canal del puerto virtual (vPC) configurado en los 5K Switch del nexo, y los puertos del adaptador de red con convergencia (PUEDA) conectados directamente con un 5K Switch del nexo
  • Topología 2 - FEX conectado con un 5K Switch del nexo en el modo continuo, y PUEDE conectado con los puertos FEX
  • Topología 3 - FEX conectado con un 5K Switch del nexo en el modo aumentado del vPC, y PUEDE conectado con los puertos FEX

El documento proporciona las configuraciones de muestra para la Conectividad de FCoE para cada topología.

Notas:

Use la Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos usados en esta sección.

La herramienta del Output Interpreter (clientes registrados solamente) apoya los ciertos comandos show. Utilice la herramienta del Output Interpreter para ver una análisis de la salida del comando show.

Paso 1: Nueva configuración de la configuración

Aunque este documento se centra en la configuración de FCoE en los adaptadores VIC y los 5K Switch del nexo, también incluye la configuración básica requerida en el vPC y de las características de FCoE para lo completo.

La topología en este ejemplo utiliza la red de área del almacenamiento virtual (VSAN) 100 y VSAN 200 como dos telas SAN. Estos VSAN se crean en el lado A y lado B del 5K Switch del nexo y se asocian a FCoE VLANS 100 y 200, respectivamente.

Para una nueva configuración, este procedimiento describe cómo realizar la configuración básica en los 5K Switch del nexo:

  1. Habilite las características necesarias ([LLDP] del Discovery Protocol de la capa de link, [LACP] del protocolo link aggregation control, FCoE, FEX, vPC) en los 5K Switch del nexo. Vea la configuración de las características necesarias para un ejemplo de este paso.
  2. Complete la configuración básica del vPC:
    1. Cree el dominio del vPC.
    2. Establezca las relaciones del keepalive del par del vPC.
    3. Configure los links del par del vPC. Vea la configuración básica del vPC para un ejemplo de cómo realizar los pasos 1-3 y de cómo habilitar el vPC en ambos 5K Switch del nexo.
    4. Cree el vPC, o reutilice los Canales de puerto.
    5. Verifique el vPC.
  3. Configure los VSAN. Vea la configuración VSAN para un ejemplo de este paso.

Nota: Usted puede saltar estos pasos si usted está agregando un servidor a una red existente; proceda al paso 2: Configure el servidor UCS y el adaptador VIC.

Configuración de las características necesarias

5548-switch# configure terminal
5548-switch(config)# feature lldp
5548-switch(config)# feature lacp
5548-switch(config)# feature fcoe
5548-switch(config)# feature fex
5548-switch(config)# feature vpc
5548-switch(config)# end

Configuración básica del vPC

5548-switch# configure terminal
5548-switch(config)# vpc domain 150
5548-switch (config-vpc-domain)# peer-keepalive destination <peer-switch-ip>
source <source-ip> vrf management
5548-switch(config-vpc-domain)# interface port-channel 150
5548-switch(config-if)# switchport mode trunk
5548-switch(config-if)# vpc peer-link
5548-switch(config-if)# no shut

Configuración VSAN

5548-switch-A # configure terminal
5548-switch-A(config)# vsan database
5548-switch-A(config-vsan-db)#vsan 100
5548-switch-A(config)#exit

5548-switch-A(config)#vlan 100
5548-switch-A(config-vlan)#fcoe vsan 100

5548-switch-B # configure terminal
5548-switch-B(config)#vsan database
5548-switch-B(config-vsan-db)#vsan 200
5548-switch-B(config)#exit

5548-switch-B(config)#vlan 200
5548-switch-B(config-vlan)#fcoe vsan 200

Paso 2: Servidor UCS de la configuración y adaptador VIC

Configure el adaptador VIC en el servidor UCS. Este procedimiento describe cómo aplicar esta configuración a todos los adaptadores de Cisco VIC (P81E o VIC 1225 o VIC 1225T):

  1. Utilice la utilidad de la actualización del host para poner al día el firmware de los componentes de hardware del servidor a la última versión. Esté seguro de poner al día el firmware VIC.
  2. Por abandono, el adaptador VIC actúa en el modo clásico de los Ethernetes (CE) y se configura con dos reguladores de la interfaz de red virtual (vNICs) y dos vHBAs. Cada uno de estos vNICs y los vHBAs se fijan a una interfaz física del uplink DCE; es decir, fc0 se fija al puerto 0 del uplink DCE, y el fc1 se fija al puerto 1 del uplink DCE del adaptador:

    117280-config-fcoe-01.png
  3. El poder en el servidor, y observa que los detalles del adaptador VIC están poblados en la sección del inventario.
  4. Haga clic la lengueta de los vHBAs, y seleccione una interfaz del vHBA (fc0 o fc1).
  5. Haga clic las propiedades, después configure las propiedades de FCoE en el adaptador VIC. Esté seguro de definir el FCoE VLAN ID en el campo de texto del VLAN predeterminado:

    117280-config-fcoe-02.png

    Si usted planea iniciar del SAN, marcar el checkbox del inicio FC SAN, y agregar la blanco WWPN a la tabla del inicio:

    117280-config-fcoe-03.png
  6. Reinicie el servidor para que los cambios de configuración tomen el efecto.

Paso 3: 5K Switch del nexo de la configuración para diversas topologías

El servidor se puede desplegar en una de tres topologías. Esta sección describe cómo configurar los 5K Switch del nexo basados en su topología.

Las guías de consulta de la configuración común para las tres topologías son:

  1. La interfaz virtual del Fibre Channel (VFC) está limitada a un puerto de miembro (interfaz de Ethernet física) del Canal de puerto.
  2. Los Switchports están en el modo tronco, y el VLA N de FCoE se configura como VLA N extranjero.
  3. Configuran al tipo del atravesar-árbol de puertos del switch así que conectan con el servidor como trunk del borde.

Este documento proporciona las configuraciones de muestra para la tela A; usted debe realizar una configuración similar en el otro Switch para la tela B.

Topología 1: PUEDEN los puertos conectados directamente con el 5K Switch del nexo

Información general

En este escenario, los 5K Switch del nexo están en el vPC, y el servidor PUEDE los puertos está conectado directamente con ambos 5K Switch del nexo. Este procedimiento describe la configuración para esta topología:

  1. Asocie la interfaz de Ethernet a la nueva interfaz de canal de puerto.
  2. Configure el Canal de puerto como un trunk con el VLA N de FCoE marcó con etiqueta, y asocie el Canal de puerto al vPC ID.
  3. Cree la interfaz VFC, y átela al miembro de canal del puerto (interfaz de Ethernet).
  4. Asocie la interfaz VFC al VSAN correspondiente ID. Vea la configuración de muestra en un lado del 5K Switch del nexo para un ejemplo de los pasos 1-4.
  5. Relance los pasos 1-4 para configurar lado B del 5K Switch del nexo.
  6. Verifique la configuración.

117280-config-fcoe-04.png

Configuración de muestra en un lado del 5K Switch del nexo

N5548UP-A(config)# int eth 1/1
N5548UP-A(config-if)# channel-group 1
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit
N5548UP-A# configure terminal
N5548UP-A(config)# interface port-channel 1
N5548UP-A(config-if)# switchport mode trunk
N5548UP-A(config-if)# switchport trunk native vlan 10
N5548UP-A(config-if)# switchport trunk allowed vlan 10,100
N5548UP-A(config-if)# spanning-tree port type edge trunk
N5548UP-A(config-if)# vpc 1
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit
N5548UP-A(config)# int vfc 1
N5548UP-A(config-if)# bind interface ethernet 1/1
N5548UP-A(config-if)# switchport trunk allowed vsan 100
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exitN5548UP-A(config)# vsan database
N5548UP-A(config-vsan-db)# vsan 100 interface vfc 1
N5548UP-A(config-vsan-db)# end

Verificación

N5548UP-A# show run int port-channel 1 membership

interface port-channel 1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
spanning-tree port type edge trunk
speed 10000
vpc 1
interface Ethernet1/1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
channel-group 1

N5548UP-A# show run int vfc 1
interface vfc1
bind interface Ethernet1/1
switchport trunk allowed vsan 100
no shutdown

Topología 2: FEX conectó con el 5K Switch del nexo en el modo continuo y PUEDE conectado con los puertos FEX

Información general

En este escenario, el FEX está conectado con el 5K Switch del nexo en el modo continuo, y la PODER está conectada con los puertos FEX. Este procedimiento describe la configuración para esta topología:

Configuración continua FEX:

  1. Asigne un FEX ID.
  2. Asocie la interfaz de Ethernet con la nueva interfaz de canal de puerto ID, y configure el nuevo Canal de puerto con los parámetros de la tela FEX. Vea la configuración de muestra para un ejemplo de los pasos 1-2.

    Reciba la configuración del vPC:

  3. Asocie las interfaces del host FEX (HIF) con la nueva interfaz de canal de puerto ID, y configure los parámetros del canal del puerto.
  4. Asocie el Canal de puerto HIF a la interfaz del vPC.
  5. Cree la interfaz VFC, y átela al puerto del miembro (Ethernet) del canal del puerto de host. Vea la configuración del vPC del host para un ejemplo de los pasos 3-5.
  6. Verifique la configuración.

Relance los pasos 1-4 en lado B del 5K Switch del nexo, y utilice el mismo Número de interfaz del vPC bajo Canal de puerto HIF.

117280-config-fcoe-05.png

Configuración de muestra:

N5548UP-A# configure terminal 
N5548UP-A(config)# fex 101
N5548UP-A(config-fex)# exit

N5548UP-A(config)# interface ethernet 1/5 - 6
N5548UP-A(config-if-range)# channel-group 210
N5548UP-A(config-if-range)#no shut
N5548UP-A(config-if-range)# exit

N5548UP-A(config)# interface port-channel 210
N5548UP-A(config-if)# switchport mode fex-fabric
N5548UP-A(config-if)# fex associate 101
N5548UP-A(config-if)#no shut
N5548UP-A(config-if)# exit

Configuración del vPC del host

<---Create HIF port-channel-->

N5548UP-A(config-if)# interface ethernet 101/1/1
N5548UP-A(config-if)# channel-group 1
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

<---Configure port-channel parameters-->

N5548UP-A(config)# interface port-channel 1
N5548UP-A(config-if)#switchport mode trunk
N5548UP-A(config-if)# switchport trunk native vlan 10
N5548UP-A(config-if)# switchport trunk allowed vlan 10,100
N5548UP-A(config-if)# spanning-tree port type edge trunk
N5548UP-A(config-if)# vpc 10
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

<---Create vfc interfvace and bind to port-channel (Ethernet interface)-->

N5548UP-A(config)# int vfc 1
N5548UP-A(config-if)# bind interface ethernet 101/1/1
N5548UP-A(config-if)# switchport trunk allowed vsan 100
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

<---Associate vfc interface to corresponding VSAN ID-->

N5548UP-A(config)# vsan database
N5548UP-A(config-vsan-db)# vsan 100 interface vfc 1
N5548UP-A(config-vsan-db)# end

Verificación

N5548UP-A# show run int port-channel 210 membership

interface port-channel210
switchport mode fex-fabric
fex associate 101

interface Ethernet1/5
switchport mode fex-fabric
fex associate 101
channel-group 210

interface Ethernet1/6
switchport mode fex-fabric
fex associate 101
channel-group 210

N5548UP-A# show int fex
Fabric Fabric Fex FEX
Fex Port Port State Uplink Model Serial
---------------------------------------------------------------
101 Eth1/5 Active 1 N2K-C2232PP-10GE SSI142602QN
101 Eth1/6 Active 2 N2K-C2232PP-10GE SSI142602QN

N5548UP-A# show run int port-channel 1 membership

interface port-channel 1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
spanning-tree port type edge trunk
speed 10000
vpc 10

interface Ethernet101/1/1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
channel-group 1

N5548UP-A# show run int vfc 1
interface vfc1
bind interface Ethernet101/1/1
switchport trunk allowed vsan 100
no shutdown

Topología 3: FEX conectó con el 5K Switch del nexo en el modo aumentado del vPC y PUEDE conectado con los puertos FEX

Información general

En este escenario, el FEX está conectado con el 5K Switch del nexo en el modo aumentado del vPC, y la PODER está conectada con los puertos FEX.

El tráfico de la tela A SAN (VLAN 100 de FCoE) se asocia al lado FEX 101/A del 5K Switch del nexo. El tráfico de la tela B SAN (VLA N 200 de FCoE) se asocia a FEX 102/lado B del 5K Switch del nexo.

Para un canal del puerto de host de dos miembros, usted debe configurar los puertos HIF en ambos dispositivos FEX en ambos 5K Switch del nexo; es decir, un total de cuatro configuraciones del puerto HIF se requieren.

Este procedimiento describe la configuración para esta topología:

Activo - Configuración activa FEX:

  1. Asigne el FEX ID.
  2. Agregue la palabra clave del “fcoe” bajo un solo FEX en cada 5K Switch del nexo para habilitar el aislamiento de la tela SAN.
  3. Cree el Canal de puerto de la tela FEX.
  4. Relance los pasos 1 y 3 para el otro FEX en el mismo 5K Switch del nexo.
  5. Relance los pasos 1-4 en lado B del 5K Switch del nexo. Vea el Active - Configuración FEX y palabra clave activas de FCoE en FEX 102 encendido lado B del 5K Switch del nexo por un ejemplo.

    Configuración del vPC del host:

  6. Cree la interfaz de canal de puerto, y configure los VLA N necesarios.
  7. Configure el puerto HIF (la interfaz FEX conectada con la PODER) en ambos FEXs, y permita el VLA N y las redes Ethernet VLAN de FCoE, después asocie el puerto HIF al canal del puerto ID del host creado en el paso 6.
  8. Cree la interfaz VFC, y átela al puerto del miembro (Ethernet) del canal del puerto de host.
  9. Relance los pasos 6-8 en lado B del 5K Switch del nexo, y utilice la misma interfaz de canal de puerto ID del host. Vea la configuración del vPC del host para un ejemplo.

    Configuración de la interfaz VFC:

  10. Cree la interfaz del VC, y átela al puerto del miembro de canal del puerto (HIF).
  11. Asigne la interfaz VFC al VSAN apropiado.
  12. Relance los pasos 10-11 en lado B del 5K Switch del nexo. Vea la configuración VFC para un ejemplo.
  13. Verifique la configuración.

117280-config-fcoe-06.png

Activo - Configuración activa FEX

N5548UP-A# configure terminal 
N5548UP-A(config)# fex 101
N5548UP-A(config-fex)# fcoe
N5548UP-A(config-fex)# exit

N5548UP-A(config)# interface ethernet 1/3 - 4
N5548UP-A(config-if-range)# channel-group 201
N5548UP-A(config-if-range)#no shut
N5548UP-A(config-if-range)# exit
N5548UP-A(config)# interface port-channel 201
N5548UP-A(config-if)# switchport mode fex-fabric
N5548UP-A(config-if)# fex associate 101
N5548UP-A(config-if)# vpc 201
N5548UP-A(config-if)#no shut
N5548UP-A(config-if)# exit

N5548UP-A# configure terminal
N5548UP-A(config)# fex 102
N5548UP-A(config-fex)# exit

N5548UP-A(config)# interface ethernet 1/5 - 6
N5548UP-A(config-if-range)# channel-group 202
N5548UP-A(config-if-range)#no shut
N5548UP-A(config-if-range)# exit

N5548UP-A(config)# interface port-channel 202
N5548UP-A(config-if)# switchport mode fex-fabric
N5548UP-A(config-if)# fex associate 102
N5548UP-A(config-if)# vpc 202
N5548UP-A(config-if)#no shut
N5548UP-A(config-if)# exit

Palabra clave de FCoE en FEX 102 encendido lado B del 5K Switch del nexo

N5548UP-B# configure terminal 
N5548UP-B(config)# fex 102
N5548UP-B(config-fex)# fcoe
N5548UP-B(config-fex)# exit

Configuración del vPC del host

N5548UP-A(config-if)# interface ethernet 101/1/1
N5548UP-A(config-if)# channel-group 1
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

N5548UP-A(config)# interface ethernet 102/1/1
N5548UP-A(config-if)# channel-group 1
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

N5548UP-A(config)# interface port-channel 1
N5548UP-A(config-if)#switchport mode trunk
N5548UP-A(config-if)# switchport trunk native vlan 10
N5548UP-A(config-if)# switchport trunk allowed vlan 10,100
N5548UP-A(config-if)# spanning-tree port type edge trunk
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

Configuración VFC

<---Create vfc interface and bind to port-channel member (ethernet interface)-->

N5548UP-A(config)# int vfc 1
N5548UP-A(config-if)# bind interface ethernet 101/1/1
N5548UP-A(config-if)# switchport trunk allowed vsan 100
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

<---Associate vfc interface to corresponding VSAN ID-->

N5548UP-A(config)# vsan database
N5548UP-A(config-vsan-db)# vsan 100 interface vfc 1
N5548UP-A(config-vsan-db)# end

Verificación

N5548UP-A# show fex
FEX FEX FEX FEX
Number Description State Model Serial
------------------------------------------------------------------------
101 FEX0101 Online N2K-C2232PP-10GE SSI142602QN
102 FEX0102 Online N2K-C2232PP-10GE SSI14260EVV

N5548UP-A# show interface fex
Fabric Fabric Fex FEX
Fex Port Port State Uplink Model Serial
---------------------------------------------------------------
101 Eth1/3 Active 2 N2K-C2232PP-10GE SSI142602QN
102 Eth1/4 Active 1 N2K-C2232PP-10GE SSI14260EVV

N5548UP-A# show fex 101 detail
FEX: 101 Description: FEX0101 state: Online
FEX version: 6.0(2)N2(1) [Switch version: 6.0(2)N2(1)]
FEX Interim version: 6.0(2)N2(1)
Switch Interim version: 6.0(2)N2(1)
Extender Serial: SSI142602QN
FCoE Admin: true
FCoE Oper: true
FCoE FEX AA Configured: true

N5548UP-A# show run interface port-channel 1 membership

interface port-channel1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
spanning-tree port type edge trunk
speed 10000

interface Ethernet102/1/1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
spanning-tree port type edge trunk
channel-group 1

interface Ethernet101/1/1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
spanning-tree port type edge trunk
channel-group 1

N5548UP-A# show int vfc 1
vfc1 is trunking
Bound interface is Ethernet101/1/1
Port WWN is 20:00:54:7f:ee:e1:6a:bf
Admin port mode is F, trunk mode is on
Port mode is TF
Port vsan is 100
Trunk vsans (admin allowed and active) (100)
Trunk vsans (up) (100)
Trunk vsans (isolated) ()
Trunk vsans (initializing) ()

N5548UP-A# show run int port-channel 201 membership

interface port-channel201
switchport mode fex-fabric
fex associate 101
vpc 201

interface Ethernet1/3
switchport mode fex-fabric
fex associate 101
channel-group 201

interface Ethernet1/4
switchport mode fex-fabric
fex associate 101
channel-group 201

N5548UP-A# show run int port-channel 202 membership

interface port-channel202
switchport mode fex-fabric
fex associate 102
vpc 202

interface Ethernet1/5
switchport mode fex-fabric
fex associate 102
channel-group 202

interface Ethernet1/6
switchport mode fex-fabric
fex associate 102
channel-group 202

Esta captura de pantalla de la secuencia de arranque del servidor valida la configuración del switch mientras que el firmware VIC detecta con éxito el LUN y pone al día la tabla del inicio:

117280-config-fcoe-07.png

Verificación

Los procedimientos de verificación son incluidos dentro de los ejemplos de configuración.

Troubleshooting

Esta sección proporciona la información que usted puede utilizar para resolver problemas su configuración.

Realice estos controles para determinar si está subiendo el VFC:

  1. Verifique que los cables estén conectados correctamente entre los puertos del adaptador asociados con el vHBA y que los puertos del 5K Switch del nexo tienen los VSAN necesarios.
  2. Aseegurese las interfaces administrativo no se apagan.
  3. Verifique que el VLA N de FCoE esté configurado en la interfaz de Ethernet limitada por el VFC.

Utilice estos comandos para verificar la configuración:

  • muestre el fcoe del funcionamiento
  • muestre el vsan
  • muestre el fcoe vlan
  • muestre el vfc ID de la interfaz
  • muestre el vpc
  • muestre la base de datos del flogi

Información Relacionada



Document ID: 117280