Switches : Switches Cisco Nexus de la serie 1000V

Ejemplos de la configuración de canal de puerto de los 1000V Series Switch del nexo

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios

Introducción

Este documento describe las mejores prácticas de utilizar cuando usted despliega los Canales de puerto en el 1000V Series Switch del nexo de Cisco (N1KV). El N1KV requiere los Canales de puerto para los perfiles del puerto que contienen más de una interfaz por el host.

Contribuido por Carlos López y Matthew Wronkowski, ingenieros de Cisco TAC.

Prerrequisitos

Requisitos

Cisco recomienda que tenga conocimiento sobre estos temas:

  • N1KV
  • Cisco Unified Computing System (UCS)
  • Nexo y Catalyst Series Switch de Cisco

Componentes Utilizados

La información que contiene este documento se basa en las siguientes versiones de software y hardware.

  • N1KV
  • UCS

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Configurar

Esta sección contiene estas configuraciones:

N1KV en los servidores de las B-series UCS en el modo del host extremo

Cisco UCS utiliza dos trayectorias diversas entre la cuchilla y la red ascendente. Actualmente, la tela Interconnects no hace Canal de puerto /virtual del Control Protocol de la agregación del link de soporte (LACP) (vPC) en dirección del sur hacia las cuchillas. Esto significa que un canal del puerto estático de la perspectiva N1KV debe ser utilizado. Se requiere la fijación MAC, puesto que el Switches por aguas arriba no soporta el EtherChannel del multichassis.

# VSM configuration
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode on mac-pinning
no shutdown
system vlan 100,101,102,103
state enabled

# Upstream switch configuration
-None required

N1KV en los servidores de la serie C UCS o los servidores de los montajes en bastidor conectó con el nexo 5000/7000 Switches con el vPC

En esta topología, cada servidor del estante está conectado físicamente con dos diverso Switches del nexo - un cable con cada Switch. El LACP es el modo preferido, porque permite la mejor distribución del tráfico y la adición no quebrantadora/la substracción de los links. Se asume que el Switches por aguas arriba del nexo tiene ya un link del par del vPC configurado.

# VSM configuration
feature lacp
lacp offload
port-channel load-balance ethernet source-mac
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode active
no shutdown
system vlan 100,101,102,103
state enabled

# Nexus 5k/7k switches #1 & #2 configuration
interface port-channel1000
switchport mode trunk
vpc 1000
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable

no lacp suspend-individual <- Nexus 7k only!!!
!
interface Ethernet1/11
description ESX-Host1
switchport mode trunk
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode active

N1KV en los servidores de la serie C UCS o los servidores de los montajes en bastidor conectó con el Switches sin el vPC

En esta topología, cada servidor del estante está conectado físicamente con dos diverso Switches, pero el vPC no está disponible. La única configuración admitida es fijación MAC. Esta configuración es idéntica a ésa usada en los servidores de las B-series UCS. Un canal del puerto estático (modo encendido) no se soporta, puesto que el Switches por aguas arriba no soporta una tecnología EtherChannel del multichassis.

# VSM configuration
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode on mac-pinning
no shutdown
system vlan 100,101,102,103
state enabled

# Upstream switch configuration
-None required

N1KV en los servidores de la serie C UCS o los servidores de los montajes en bastidor conectados con 6500 VSS o interruptores de apilado

En esta topología, el Switches por aguas arriba actúa como chasis único. Esto permite que el N1KV conecte con el LACP.

# VSM configuration
feature lacp
lacp offload
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode active
no shutdown
system vlan 100,101,102,103
state enabled

# 6500 VSS configuration
interface Port-channel1000
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-103,200-300
switchport mode trunk
spanning-tree portfast edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
!
interface GigabitEthernet1/1/1
description ESX-Host1 adapter 1
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-103,200-300
switchport mode trunk
spanning-tree portfast edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode active
!
interface GigabitEthernet2/1/1
description ESX-Host1 adapter 2
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-103,200-300
switchport mode trunk
spanning-tree portfast edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode active

N1KV en los servidores de la serie C UCS o los servidores de los montajes en bastidor conectados con un solo Switch por aguas arriba con un canal del puerto estático

En esta topología, los servidores son escoja dirigidos a un Switch por aguas arriba. Esta topología no proporciona ninguna Redundancia del Switch y no es una mejor práctica.

# VSM configuration
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode on
no shutdown
system vlan 100,101,102,103
state enabled

# Upstream Nexus switch
interface port-channel 1000
switchport mode trunk
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
!
interface Ethernet1/11
description ESX-Host1
switchport mode trunk
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode on

Verificación

Utilize esta sección para confirmar que su configuración funcione correctamente.

show run interface po{X} membership
show port-channel summary

Troubleshooting

Esta sección proporciona la información que usted puede utilizar para resolver problemas su configuración.

show port-channel summary
show port-channel internal event-history [all|errors]debug lacp all

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 116739