Routers : Routers de agregación de servicios Cisco ASR de la serie 9000

Configuración de la transferencia L2 al proceso de conversión de la configuración XR L2VPN

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios

Introducción

Este documento describe cómo convertir una configuración del Layer 2 Switching del ® del Cisco IOS a una configuración de Virtual Private Network de la capa 2 del Cisco IOS XR (L2VPN).

Contribuido por Manuel Irizarry, los poderes de David, y Samuel Milstead, ingenieros de Cisco TAC.

Prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no se restringe al software específico sino se restringe al router agregado las 9000 Series del servicio (ASR) - las versiones de hardware relacionadas que utilizan el modelo del circuito virtual de los Ethernetes (EVC) para configurar el L2VPN. Los 9000 Series Router ASR utilizan el modelo EVC mientras que no lo hace el Routers del sistema de ruteo del portador (CRS) que funciona con el Cisco IOS XR.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Antecedentes

El 9000 Series Router ASR no sigue el modelo de IEEE de la configuración de la capa 2 (L2), especialmente 802.1Q y 802.1AD. En lugar utiliza el modelo EVC. El modelo EVC permite que el Cisco IOS XR leverage las etiquetas actuales del VLA N del 802.1Q de una nueva manera. Tradicionalmente, la etiqueta del VLA N define la clasificación, el VLA N, la expedición, y que tabla del Content Addressable Memory (CAM) a utilizar para realizar las operaciones de búsqueda de la dirección MAC. Con el modelo EVC, este concepto se desempareja para permitir más flexibilidad y escala más alta. El modelo EVC elimina la restricción del Cisco IOS de 4,096 VLA N máximos.

EVC utiliza estos bloques de construcción:

  • Los Ethernetes fluyen la punta (el EFP) - El EFP es una subinterfaz lógica L2 que se utiliza para clasificar el tráfico bajo una comprobación o bundle interface.

  • EVC - EVC es una representación de punta a punta de una instancia única del L2. Un EFP se define como punto final de un EVC dentro de un nodo. Porque EVCs múltiple puede pasar a través de una interfaz física, el propósito principal de una configuración EFP es reconocer el tráfico que pertenece a un EVC específico en esa interfaz y aplicar la conducta de reenvío y las características específicas a ésa EVC.

  • Dominio de Bridge (BD) - UN BD es un dominio de broadcast de los Ethernetes interno al dispositivo. El BD le permite para desemparejar el VLA N del dominio de broadcast. El BD tiene asignaciones de muchos a uno con los EFPs: todos los EFPs en un nodo para un EVC específico se agrupan con el uso del BD. Si los EFPs pertenecen al mismo BD y tienen el mismo número del BD, después los EFPs reciben el tráfico incluso si tienen diversos números VLAN.

Problema

El Cisco IOS XR en los 9000 Series Router ASR utiliza el modelo del circuito virtual de los Ethernetes (EVC). El modelo EVC no tiene el concepto de trunks, de interfaces VLAN, o de una interfaz virtual del Switch (SVI). Los links troncales, las interfaces VLAN, y los SVI del Cisco IOS se deben convertir a las configuraciones del Cisco IOS XR vía los subinterfaces, L2VPN BDs, y las interfaces virtuales del Bridge (BVI). El modelo EVC pudo ser nuevo a algunos usuarios del Cisco IOS cuando primero emigran al Cisco IOS XR.

Solución

La configuración en el Cisco IOS XR consiste en tres pasos:

  1. Cree el EFP vía la configuración de una interfaz o de una sub-interfaz con la opción l2transport, que representa un VLA N.

  2. Cree un BD para agrupar los EFPs.

  3. Cuando la capa 3 (L3) SVI es necesaria, la configuración vía la interfaz BVI en el Cisco IOS XR, en vez de la interfaz vlan en el Cisco IOS, para proporcionar el L3 básico funciona para las interfaces L2 que pertenecen al BD.

Nota: Las interfaces BVI no soportan las etiquetas del VLA N; tan para que el BVI maneje el Tráfico de ingreso en el EFP, la etiqueta del VLA N se debe hacer estallar en el ingreso y agregar en la salida. Esto se completa con el comando de la reescritura.

Convierta una configuración

Este ejemplo ilustra cómo convertir una configuración del Cisco IOS al Cisco IOS XR.

Configuración IOS

interface GigabitEthernet3/13
switchport
switchport access vlan 4
speed 1000
duplex full
!
interface GigabitEthernet3/14
switchport
switchport access vlan 130
speed 1000
duplex full
!
interface GigabitEthernet3/15
switchport
switchport access vlan 133
speed 1000
duplex full
!
interface TenGigabitEthernet13/3
description IOS Trunk
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1*,4,130,133
switchport mode trunk
no ip address
!
interface Vlan 4
ip address 10.10.4.1 255.255.255.0

interface Vlan 130
ip address 10.10.130.1 255.255.255.0
!

*Vlan 1 is the native vlan

Cree una interfaz EFP. El Cisco IOS XR implementa un CLI estructurado para la configuración EFP y EVC. Para configurar un EFP, utilice estos comandos interface configuration:

  • comando l2transport - Este comando identifica una subinterfaz, un puerto físico, o una interfaz del padre del conjunto-puerto como EFP.

  • comando encapsulation - Este comando se utiliza para especificar los criterios VLA N-que corresponden con.

  • comando de la reescritura - Este comando se utiliza para especificar los criterios de la reescritura de la etiqueta del VLA N.

Configuración ASR 9000 para Interfate TenGigabitEhternet 13/3 (puerto troncal)

interface GigabitEthernet 0/0/0/1
!
interface GigabitEthernet 0/0/0/1.1 l2transport
encapsulation dot1q untagged **
!

interface GigabitEthernet 0/0/0/1.4 l2transport
encapsulation dot1q 4
rewrite ingress tag pop 1 symmetric

interface GigabitEthernet 0/0/0/2
!
interface GigabitEthernet 0/0/0/2.130 l2transport
encapsulation dot1q 130
rewrite ingress tag pop 1 symmetric
!
interface GigabitEthernet 0/0/0/3
!
interface GigabitEthernet 0/0/0/3.133 l2transport
encapsulation dot1q 133
rewrite ingress tag pop 1 symmetric
!
interface tengig0/0/0/0
!
interface tengig0/0/0/0.4 l2transport
no ip address
encapsulation dot1q 4
rewrite ingress tag pop 1 symmetric
!
interface tengig0/0/0/0.130 l2transport
no ip address
encapsulation dot1q 130
rewrite ingress tag pop 1 symmetric
!
interface tengig0/0/0/0.133 l2transport
no ip address
encapsulation dot1q 133
rewrite ingress tag pop 1 symmetric
!

Para agregar el VLAN nativo 1, el tráfico del untag, y crear una sub-interfaz l2transport con la encapsulación untagged del dot1q. Utilice el comando untagged del dot1q de la encapsulación bajo una interfaz l2transport o sub-interfaz si el puerto está conectado con una configuración del puerto para el acceso a SwitchPort en el dispositivo IOS.

Aquí tiene un ejemplo:

IOS:

interface Gigabitethernet 1/1
switchport
switchport access vlan 3

IOSXR:

interfage GigabitEthernet 0/1/1/1.1 l2transport
encapsulation dot1q untagged

Después de que se cree el EFP, una interfaz BVI se puede crear y agregar al BD. La interfaz BVI se utiliza para acomodar el VLA N de la interfaz en el Cisco IOS.

interface BVI4
ipv4 address 10.10.4.1 255.255.0.0
!
interface BVI130
ipv4 address 10.130.1.1 255.255.0.0
!

El número de la interfaz BVI no necesita necesariamente hacer juego el identificador de VLAN. Lo mismo es verdad para el número de la subinterfaz de las interfaces de transporte L2. Sin embargo, para mayor clareza en este ejemplo, el número BVI hace juego la etiqueta del dot1q así como el número de la subinterfaz EFP.

En este ejemplo, un BD l2-VPN se crea para interligar los EFPs y los BVI juntos:

l2vpn
bridge group VLAN4
bridge-domain VLAN4
interface ten0/0/0/0.4
!
interface GigabitEthernet 0/0/0/1.4
!
routed interface bvi4
!
!
bridge-domain VLAN130
interface ten0/0/0/0.130
!
interface GigabitEthernet 0/0/0/2.130
!
routed interface bvi130
!
!
bridge-domain VLAN133
interface ten0/0/0/0.133
!
interface GigabitEthernet 0/0/0/3.133
!
!
!
!

El Grupo de Bridge (BG) es una jerarquía de configuración no funcional que une vario BDs en la parte del mismo grupo funcional. Funciona apenas como la creación de los grupos individuales múltiples con sus dominios hace, en comparación con un grupo con los dominios múltiples.

Comandos equivalentes

Esta tabla enumera otros comandos disponibles en el Cisco IOS, y los comandos equivalentes en el Cisco IOS XR configurado bajo el BD:

IOSIOS XR
unicast del bloque del switchport}inundar la neutralización de la unidifusión desconocida
máximo de la Seguridad de puerto del switchportmáximo del límite del mac (rango 5-512000)
infracción de Seguridad de puerto del switchportnotificación del límite del mac de la acción del límite del mac (la inundación, ninguno-inundación, apaga) (ambas, ningunas, desvío)
mac-movimiento de la notificación de la tabla de direcciones del macNecesidad de configurar el siguiente: acción segura del mac ningunos registro seguro del mac
MAC address de la Seguridad de puerto del switchportStatic MAC Address máximo H.H.H del límite y del mac de la interfaz x

Información Relacionada



Document ID: 116500