IP : Protocolo de túnel de capa 2 (L2TP)

Bridging L2 a través de un ejemplo de la configuración de red L3

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (23 Abril 2015) | Comentarios

Introducción

Este documento describe cómo interligar una red de la capa 2 (L2) a través de una red de la capa 3 (L3).

Contribuido por Atri Basu, Jay Taylor joven, y Mani Ganesan, ingenieros de Cisco TAC.

Prerrequisitos

Requisitos

Cisco recomienda que tenga conocimiento sobre estos temas:

  • Protocolo Layer 2 Tunneling Protocol versión 3 (L2TPv3)
  • Generic Routing Encapsulation (GRE)

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Antecedentes

En muchas situaciones, usted requiere una solución para agregar el tráfico de WiFi de los hotspots a una ubicación central. En estos casos, la solución necesita permitir que los dispositivos del equipo en las instalaciones del cliente (CPE) interliguen el tráfico de Ethernet del host extremo, y encapsula los paquetes a través del tráfico de Ethernet a un punto final.

Si usted utiliza al Routers de los servicios de la agregación (ASR), la forma sencilla de hacer esto es utilizar los Ethernetes sobre el GRE suave. Sin embargo, para el Routers del servicio integrado (ISR) y el resto de los dispositivos CPE, esto no es una opción. En más viejas versiones del ® del Cisco IOS, era posible hacer un túnel el L2 sobre el GRE interligando la interfaz física con una interfaz de túnel GRE. Aunque el Bridging común elimine el encabezado VLAN de los paquetes entrantes, el uso del Integrated Routing and Bridging (IRB) en el router puede rutear y interligar el mismo protocolo de capa de red en la misma interfaz y todavía permitir que el router mantenga el encabezado VLAN a partir de una interfaz a otra.

Nota: Cuando usted configura el bridge-group en la interfaz del túnel en más viejas versiones deL Cisco IOS, el IOS señala que el comando está inédito y sin apoyo, pero todavía valida el comando. En más versiones recientes, este comando es totalmente Obsoleto, y las visualizaciones de mensaje de error.

La solución previa no es soportada por Cisco. La solución soportada para interligar una red L2 es utilizar el L2TPv3 según lo descrito en este documento. El L2TPv3 proporciona el soporte para el transporte de los diversos protocolos L2 como los Ethernetes, 802.1q (VLA N), Frame Relay, High-Level Data Link Control (HDLC), y Point-to-Point Protocol (PPP). El foco de este documento es extensión de los Ethernetes.

Configurar

Esta configuración es muy básica. Servicio r101 y r201 del Routers como hosts en la misma red, mientras que r100 y r202 tienen una interfaz L3 y una interfaz L2. El objetivo es configurar la conexión del L2TPv3 tales que r101 y r201 pueden hacerse ping sin el requisito de cualquier ruta.

Diagrama de la red

Configuración del túnel

La configuración del túnel L2TP implica tres pasos:

  1. Configure un L2TP-class (opcional)

    Esta clase se utiliza para definir una cierta autenticación y los parámetros de control para el L2TP hacen un túnel. Si se utiliza, los dos extremos deben duplicarse.
    l2tp-class test
    hostname stanford
    password 7 082E5C4B071F091805

  2. Configure la Pseudowire-clase

    Mientras que el nombre sugiere, esta sección se utiliza para configurar el túnel o el “pseudowire real” entre los dos puntos finales. Defina una plantilla que contenga la encapsulación del pseudowire, un punto final, y el protocolo del canal de control.
    pseudowire-class test
    encapsulation l2tpv3
    ip local interface Loopback0
    ip pmtu

  3. Utilice Xconnect para proporcionar el destino del túnel

    Ate el pseudowire L2TP al circuito de la conexión (interfaz hacia el lado local L2) y defina su destino. 

Puntas a observar:

  • El circuito sí mismo de la conexión no tiene ninguna dirección IP configurada.
  • El origen de túnel configurado con la interfaz local IP está en la sección de la pseudowire-clase.
  • El destino del túnel se define con el comando del xconnect.

Consideraciones

  • Como con la solución de la tunelización GRE, el uso de un router en quien terminar el túnel L2 todavía no permite que los mensajes del unidad de datos del protocolo (PDU) L2 sean remitidos a través del túnel. Sin el Tunelización apropiado del protocolo L2, que no se soporta en este dispositivo, estos mensajes son consumidos por la interfaz L2.

  • El soporte para el Tunelización del protocolo L2 (protocolo cisco discovery, Spanning Tree Protocol, protocolo VLAN trunking, y Discovery Protocol de la capa de link) requiere que el dispositivo sea un Switch. Este Switch necesita ser L3 enterado para poder al tráfico de túnel y limitar las opciones posibles.

  • La encapsulación del Tunelización L3 depende del dispositivo que hace el Tunelización:
    1. Encapsulación del L2TPv3 de los soportes del Cisco 7301.
    2. Cisco 65xx no soporta la extensión L2 con el túnel del L2TPv3. Sin embargo, el L2 puede ser extendido a través de una base MLPS con el cualquier transporte sobre la opción MPLS (átomo).
    3. El túnel L2TP no se soporta en los Cisco 4500 Switch.

  • Solamente una sola interfaz del túnel del xconnect se puede configurar en una interfaz física o una sub-interfaz. Una interfaz diferente es necesaria para cada punto final del pseudowire. Usted no puede configurar las interfaces múltiples con el xconnect con la misma picovatio-clase y el mismo L2TP ID.

  • Los tamaños máximos de la Unidad máxima de transmisión (MTU) del payload para un túnel L2TP son generalmente 1460 bytes para el tráfico que viaja sobre los Ethernetes estándars. En el caso del L2TP sobre el User Datagram Protocol (UDP), los gastos indirectos son el resultado del encabezado IP (20 bytes), del encabezado UDP (8 bytes), y de la encabezado L2TP (12 bytes).

Configuración de muestra:

Configuración del router r101

interface Ethernet0/0
ip address 172.16.1.100 255.255.255.0

Configuración del router r100

pseudowire-class test
encapsulation l2tpv3
protocol none
ip local interface fast 0/0
!
interface FastEthernet0/0
description WAN
ip address 198.51.100.100 255.255.255.0
!
interface FastEthernet0/1
description LAN
no ip address
speed 100
full-duplex
xconnect 203.0.113.102 1 encapsulation l2tpv3 manual pw-class test
l2tp id 1 2
!
ip route 0.0.0.0 0.0.0.0 198.51.100.1

Configuración del router r202

pseudowire-class test
encapsulation l2tpv3
protocol none
ip local interface fast 0/0
!
interface FastEthernet0/0
description WAN
ip address 203.0.113.102 255.255.255.255

interface FastEthernet0/1
no ip address
duplex auto
speed auto
xconnect 198.51.100.100 1 encapsulation l2tpv3 manual pw-class test
l2tp id 2 1

Configuración del router r201

interface Ethernet0/0
ip address 172.16.1.201 255.255.255.0

Nota: Use la Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos usados en esta sección.

Verificación

Para visualizar la información detallada sobre los canales de control L2TP que se configuran a otros dispositivos habilitado para L2TP para todas las sesiones L2TP sobre el router, utilice el comando show l2tun tunnel all.

Para verificar que la encapsulación del L2TPv3 trabaje correctamente, haga ping un host en el sitio remoto que se supone para estar en el mismo VLA N. Si el ping es acertado, usted puede utilizar este comando para confirmar que su configuración trabaja correctamente. La herramienta del Output Interpreter (clientes registrados solamente) soporta los ciertos comandos show. Utilice la herramienta del Output Interpreter para ver una análisis de la salida del comando show.

  • El comando show arp visualiza el caché del Address Resolution Protocol (ARP).

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 116266