Computación unificada : Cisco UCS Manager

Ejemplo de configuración del uplink UCS FCoE

25 Agosto 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (23 Abril 2015) | Comentarios

Introducción

Este documento describe cómo configurar el Fibre Channel sobre el uplinks de los Ethernetes (FCoE). En las versiones de la versión 2.1 y posterior del Cisco Unified Computing System (UCS), el Fibre Channel multihop sobre el soporte de los Ethernetes (FCoE) fue introducido. Este soporte permite la consolidación del uplink a partir de dos links separados a un solo uplink que lleva el Fibre Channel (FC) y los Ethernetes.

Nota: El uplinks unificado es diferente de los puertos unificados. Cualquier interconexión de la tela (FI), que incluye la generación 1, puede haber unificado el uplinks. Sin embargo, solamente la generación 2 FIs ha unificado los puertos.

Contribuido por Christopher Brown, ingeniero de Cisco TAC.

Prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

La información en este documento se basa en la versión 2.1 del administrador UCS (UCSM). Usted debe funcionar con por lo menos la versión 2.1(1a) para utilizar este documento.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Configurar

Configuraciones admitidas

En todas estas configuraciones, usted puede substituir cualquier link con un canal del puerto del mismo tipo. Por ejemplo, si la configuración muestra un link, puede ser configurado con un canal del puerto en lugar de otro. Sin embargo, usted no puede tener un Ethernet y un puerto unificado en el mismo canal del puerto.

Uplink de FCoE con el canal del puerto virtual (vPC)

Esta configuración no contiene ningún link unificado, sino que es la manera más fácil integrar el uplinks de FCoE en su entorno actual. Esta configuración elimina la necesidad de cruzar las telas FC.

Cruz conectada con la fijación

En esta configuración, los 5000 Series Switch del nexo (N5ks) y FIs son cruz conectada, pero puerto-no canalizado juntos. Esto permite que usted tenga algún uplinks unificado, pero usted todavía mantiene un diseño de red bien conocido.

Todo el uplinks unificado

Esta configuración proporciona la mayoría de la consolidación. Recuerde que estos links pueden también ser canales del puerto, solamente todos los links debe ser uplinks unificado. Esto es probable ser la mayoría de la implementación frecuente.

Configuración en el UCS

Hay tres pasos para configurar el UCS:

  1. Red de área del almacenamiento virtual de la configuración (VSAN).
  2. Uplinks unificado configuración.
  3. Canales del puerto de la configuración (opcionales).

Configuración VSAN

En esta configuración, el VSAN 500 está fuera de la tela A, y el VSAN 600 está fuera de la tela B. Ésta es la misma configuración que usted utilizaría para crear un VSAN para un FC normal.

Uplinks unificado configuración

El uplink unificado se oculta en el GUI. Para hacer un puerto unificado, usted debe primero configurarlo como un uplink o uplink de FCoE. Entonces, usted puede configurarlo como un puerto unificado. Esta configuración no quita el primer papel. En lugar, crea una interfaz que tenga ambos.

Aseegurese para fijar su VSAN en este momento.

En este momento, su UCS se configura para el tráfico unificado. Este ejemplo no utiliza los canales del puerto. Sin embargo, usted puede configurar los canales del puerto normalmente en este momento. Aseegurese para fijar el VSAN bajo la lengueta VSAN para el canal del puerto.

Configuración en el N5k

La configuración en el N5k consiste en 3 pasos:

  1. Permiso FCoE y configuraciones predeterminadas del Calidad de Servicio (QoS). Cree el VLA N de FCoE y ate el VSAN a él.
  2. Configure la interfaz de Ethernet (o el canal del puerto).
  3. Cree un Fibre Channel virtual (vFC) y átelo a la interfaz de Ethernet.

Nota: El UCS es un Switch de la virtualización del puerto N (NPV) por abandono así que el Switch por aguas arriba necesita estar en el modo de Identifer Virtulization (NPIV) del puerto N (ingrese el comando del npiv de la característica para habilitar).  Vea configurar la virtualización del puerto N para más información sobre esta característica.

Habilite FCoE y omita las configuraciones de QoS

Usted puede saltar este paso si el N5k se configura ya para FCoE. Si el N5k no se configura para FCoE, refiera al Apéndice A en el extremo de este documento para la instrucción.

Configure las interfaces de Ethernet (o los canales del puerto)

Ésta es la configuración para la interfaz que conecta normalmente con el UCS.  Aseegurese para permitir el VLA N de FCoE.

f340-31-15-5596-1(config)# interface ethernet 1/32
f340-31-15-5596-1(config-if)# switchport mode trunk
f340-31-15-5596-1(config-if)# switchport trunk allowed vlan all

Éste es un ejemplo de una configuración de conexión de troncal muy básica. Note que no hay configuración de FCoE en esta interfaz.

Configure el vFC

Ésta es la configuración para el vFC, que maneja todo el tráfico de FCoE del UCS:

f340-31-15-5596-1(config-if)# int vfc 25
f340-31-15-5596-1(config-if)# switchport trunk allowed vsan 500
f340-31-15-5596-1(config-if)# no shut
f340-31-15-5596-1(config-if)# bind interface ethernet 1/32
f340-31-15-5596-1(config-if)#

Hay algunas puntas a notar en este ejemplo:

  • El número del vFC no importa. Puede ser cualquier cosa, mientras no sea ya funcionando.
  • Esto es un puerto de la tela del enlace (TF), así que aseegurese para permitir su VSAN.
  • Ate esto a la interfaz que hace frente al UCS. Ésta es la interfaz física en la cual se envía/se recibe el tráfico de FCoE. Se envía en el VLA N asociado al VSAN.

En este momento, usted tiene todo de configuración completa. Ingrese el comando del vfc xx de la interfaz de la demostración para asegurarse de que sube el VSAN.

f340-31-15-5596-1(config-if)# show interface vfc 25
vfc25 is trunking
Bound interface is Ethernet1/32
Hardware is Ethernet
Port WWN is 20:18:54:7f:ee:d3:f8:bf
Admin port mode is F, trunk mode is on
snmp link state traps are enabled
Port mode is TF
Port vsan is 500
Trunk vsans (admin allowed and active) (500)
Trunk vsans (up) (500)
Trunk vsans (isolated) ()
Trunk vsans (initializing) ()
1 minute input rate 4448 bits/sec, 556 bytes/sec, 1 frames/sec
1 minute output rate 610448 bits/sec, 76306 bytes/sec, 27 frames/sec
27347 frames input, 45743308 bytes
0 discards, 0 errors
114710 frames output, 218235936 bytes
0 discards, 0 errors
last clearing of "show interface" counters Thu May 9 13:37:42 2013

Interface last changed at Thu May 9 14:03:44 2013

Si el VSAN no está para arriba, verifique su configuración y sus conexiones. Si todavía está trague, agite el acceso de Ethernet en el N5k.

En este momento, usted aplica su configuración normal FC (directiva del inicio, dividiendo en zonas).

f340-31-15-5596-1(config-if)# show flogi database
--------------------------------------------------------------------------------
INTERFACE VSAN FCID PORT NAME NODE NAME
--------------------------------------------------------------------------------
fc2/3 500 0xd80000 20:42:00:0d:ec:b1:34:c0 21:f4:00:0d:ec:b1:34:c1
fc2/3 500 0xd80001 20:00:00:25:b5:12:dc:5f 20:00:00:25:b5:13:dc:2f
[svinfra-esxi-1]
fc2/3 500 0xd80003 20:00:00:25:b5:12:dc:3f 20:00:00:25:b5:13:dc:0f
[svinfra-esxi-2]
vfc7 500 0xd80060 25:f6:00:0d:ec:cc:d3:ff 21:f4:00:0d:ec:cc:d3:c1
vfc7 500 0xd80061 20:00:00:25:b5:19:70:28 20:00:00:25:b5:19:70:18
vfc25 500 0xd80042 20:00:00:25:b5:ab:1a:01 20:00:00:25:b5:00:00:8f
vfc25 500 0xd80043 20:00:00:25:b5:ab:1a:02 20:00:00:25:b5:00:00:9f
vfc25 500 0xd80044 20:00:00:25:b5:00:3a:08 20:00:00:25:b5:00:00:5f
vfc25 500 0xd80045 20:00:00:25:b5:00:3a:09 20:00:00:25:b5:00:00:4f
vfc25 500 0xd80048 2d:9a:00:05:73:c2:c6:3f 21:f4:00:05:73:c2:c6:01

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Apéndice A - Configuración básica N5k FCoE

Para configurar el N5k para FCoE, ingrese:

feature fcoe
system qos
service-policy type network-qos fcoe-default-nq-policy
service-policy type queuing input fcoe-default-in-policy
service-policy type queuing output fcoe-default-out-policy
service-policy type qos input fcoe-default-in-policy

Estos comandos primero habilitan FCoE, y en seguida habilitan las directivas predeterminadas de QoS que son necesarias para FCoE. Si usted tiene configuraciones de encargo de QoS, utilice ésos como base. Aquí están las configuraciones predeterminadas:

  policy-map type qos fcoe-default-in-policy
class type qos class-fcoe
set qos-group 1
class type qos class-default
set qos-group 0

policy-map type queuing fcoe-default-in-policy
class type queuing class-fcoe
bandwidth percent 50
class type queuing class-default
bandwidth percent 50
policy-map type queuing fcoe-default-out-policy
class type queuing class-fcoe
bandwidth percent 50
class type queuing class-default
bandwidth percent 50

policy-map type network-qos fcoe-default-nq-policy
class type network-qos class-fcoe

pause no-drop
mtu 2158
class type network-qos class-default

mtu 1500
multicast-optimize

Como usted puede ver, estas directivas crean la clase de tráfico de FCoE, la marcan para el ninguno-descenso, y le dan el Ancho de banda dedicado. Usted puede modificar éstos mientras que usted necesita (por ejemplo, para agregar las Tramas gigantes).

Después, usted necesita atar el VSAN al VLA N:

f340-31-15-5596-1(config)# vlan 500
f340-31-15-5596-1(config-vlan)# name VNX_500
f340-31-15-5596-1(config-vlan)# fcoe vsan 500
f340-31-15-5596-1(config-vlan)#

Esto dice a N5k que el VLA N 500 es un VLA N de FCoE y que cualquier tráfico que venga adentro se debe conmutar a VSAN 500.

En este momento, su N5k se configura para FCoE y alista para la conexión UCS.


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 116188