Switching por etiquetas multiprotocolo (MPLS) : MPLS

Ejemplo unificado de la configuración de MPLS

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios

Introducción

Este documento describe el propósito del Multiprotocol Label Switching (MPLS) unificado y proporciona un ejemplo de configuración.

Contribuido por Lucas De Ghein, ingeniero de Cisco TAC.

Prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Antecedente

El propósito del MPLS unificado está todo sobre el escalamiento. Para escalar una red MPLS, donde hay diversos tipos de patforms y servicios en las partes de la red, tiene sentido de partir la red en diversas áreas. Un diseño típico introduce una jerarquía que tenga una base en el centro con la agregación en el lado. Para escalar, allí puede ser diversos protocolos Interior Gateway Protocols (IGP) en el base contra la agregación. Para escalar, usted no puede distribuir los prefijos IGP a partir de un IGP en el otro. Si usted no distribuye los prefijos IGP a partir de un IGP en el otro IGP, las trayectorias conmutadas de etiquetas de punta a punta (LSP) no son posibles.

Para entregar los servicios MPLS de punta a punta, usted necesita el LSP ser de punta a punta. La meta es guardar los servicios MPLS (MPLS VPN, MPLS L2VPN) pues son, sino introducir el mayor scalability. Para hacer esto, trasládese algunos de los prefijos IGP al Border Gateway Protocol (BGP) (los prefijos del loopback del Routers del borde del proveedor (PE)), que entonces distribuye los prefijos de punta a punta.

Arquitectura

El cuadro 1 muestra una red con tres diversas áreas: una base y dos áreas de la agregación en el lado. La cada área ejecuta su propio IGP, sin la redistribución entre ellas en el router del borde del área (ABR). El uso del BGP es necesario para proporcionar un MPLS de punta a punta LSP. El BGP hace publicidad de los loopback del Routers PE con una escritura de la etiqueta a través de la totalidad del dominio, y proporciona un LSP de punta a punta. El BGP se despliega entre los PE y los ABR con el RFC 3107, así que significa que el BGP envía el prefijo + la escritura de la etiqueta (AFI/SAFI 1/4) del IPv4.

Puesto que las partes de la base y de la agregación la red son integradas y se proporcionan los LSP de punta a punta, las Soluciones MPLS unificadas también se refieren como “MPLS inconsútil.”

Las tecnologías nuevas o los protocolos no se utilizan aquí, solamente MPLS, Protocolo de distribución de etiquetas (LDP), IGP, y el BGP. Puesto que usted no quiere distribuir los prefijos del loopback del Routers PE a partir de una parte de la red en otra parte, usted necesita llevar los prefijos en el BGP. El Internal Border Gateway Protocol (iBGP) se utiliza en una red, así que la dirección del salto siguiente de los prefijos es los prefijos del loopback del Routers PE, que no es conocida por el IGP en las otras partes de la red. Esto significa que la dirección del salto siguiente no puede ser utilizada al recurse a un prefijo IGP. El truco es hacer los routeres ABR los reflectores de ruta (RR) y fijar el salto siguiente al uno mismo, incluso para los prefijos reflejados del iBGP. Para que esto trabaje, un nuevo botón es necesario.

Solamente los RR necesitan un más nuevo software soportar esta arquitectura. Puesto que los RR hacen publicidad de los prefijos BGP con el salto siguiente fijado a ellos mismos, asignan una escritura de la etiqueta local MPLS a los prefijos BGP. Esto significa que en el avión de los datos, los paquetes remitidos en estos LSP de punta a punta tienen una escritura de la etiqueta adicional MPLS en la pila de etiquetas. Los RR están en el trayecto de reenvío.

Nota: Sobre esta arquitectura, se proporciona cualquier servicio MPLS. Por ejemplo, el MPLS VPN o el MPLS L2VPN se proporciona entre el Routers PE. La diferencia en el avión de los datos para estos paquetes es que él ahora tiene tres escrituras de la etiqueta en la pila de etiquetas, mientras que él tenía dos escrituras de la etiqueta en la pila de etiquetas cuando el MPLS unificado no fue utilizado.

Hay dos escenarios posibles:

  • El ABR no fija el salto siguiente al uno mismo para los prefijos des divulgación (reflejado por el BGP) por el ABR en la parte de la agregación la red. Debido a esto, el ABR necesita redistribuir los prefijos del loopback de los ABR de la base IGP en la agregación IGP. Si se hace esto, todavía hay scalability. Solamente los prefijos del loopback ABR (de la base) necesitan ser hechos publicidad en la pieza de la agregación, no los prefijos del loopback del Routers PE de las piezas remotas de la agregación.

  • El ABR fija el salto siguiente al uno mismo para los prefijos des divulgación (reflejado por el BGP) por el ABR en la partición de la agregación debido a esto, el ABR no necesita redistribuir los prefijos del loopback de los ABR de la base IGP en la agregación IGP.

En ambos escenarios, el ABR fija el salto siguiente al uno mismo para los prefijos des divulgación (reflejado por el BGP) por el ABR de la parte de la agregación la red en la partición de la base. Si esto no se hace, el ABR necesita redistribuir los prefijos del loopback de los PE de la agregación IGP en la base IGP. Si se hace esto, no hay scalability.

Para fijar el salto siguiente al uno mismo para las rutas reflejadas del iBGP, usted debe configurar el comando all del siguiente-salto-uno mismo del vecino x.x.x.x.

Configurar

Ésta es la configuración del Routers PE y de los ABR para el escenario 2.

Nota: El toplogy se muestra en el cuadro 2. El servicio de ejemplo es el xconnect (MPLS L2VPN). Entre el Routers PE y los ABR, hay BGP para el IPv4 + la escritura de la etiqueta.

PE1

interface Loopback0
 ip address 10.100.1.4 255.255.255.255

!
interface Ethernet1/0
 no ip address
 xconnect 10.100.1.5 100 encapsulation mpls
!
router ospf 2
 network 10.2.0.0 0.0.255.255 area 0
 network 10.100.1.4 0.0.0.0 area 0
!
router bgp 1
 bgp log-neighbor-changes
 network 10.100.1.4 mask 255.255.255.255
 neighbor 10.100.1.1 remote-as 1
 neighbor 10.100.1.1 update-source Loopback0
 neighbor 10.100.1.1 send-label

RR1


interface Loopback0
 ip address 10.100.1.1 255.255.255.255
router ospf 1
 network 10.1.0.0 0.0.255.255 area 0
 network 10.100.1.1 0.0.0.0 area 0
!
router ospf 2
 redistribute ospf 1 subnets match internal route-map ospf1-into-ospf2
 network 10.2.0.0 0.0.255.255 area 0
!
router bgp 1
 bgp log-neighbor-changes
 neighbor 10.100.1.2 remote-as 1
 neighbor 10.100.1.2 update-source Loopback0
 neighbor 10.100.1.2 next-hop-self all
 neighbor 10.100.1.2 send-label
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 route-reflector-client
 neighbor 10.100.1.4 next-hop-self all
 neighbor 10.100.1.4 send-label

ip prefix-list prefix-list-ospf1-into-ospf2 seq 5 permit 10.100.1.1/32

route-map ospf1-into-ospf2 permit 10
 match ip address prefix-list prefix-list-ospf1-into-ospf2


RR2

interface Loopback0
 ip address 10.100.1.2 255.255.255.255

router ospf 1
 network 10.1.0.0 0.0.255.255 area 0
 network 10.100.1.2 0.0.0.0 area 0
!
router ospf 3
 redistribute ospf 1 subnets match internal route-map ospf1-into-ospf3
 network 10.3.0.0 0.0.255.255 area 0
!
router bgp 1
 bgp log-neighbor-changes
 neighbor 10.100.1.1 remote-as 1
 neighbor 10.100.1.1 update-source Loopback0
 neighbor 10.100.1.1 next-hop-self all
 neighbor 10.100.1.1 send-label
 neighbor 10.100.1.5 remote-as 1
 neighbor 10.100.1.5 update-source Loopback0
 neighbor 10.100.1.5 route-reflector-client
 neighbor 10.100.1.5 next-hop-self all
 neighbor 10.100.1.5 send-label

ip prefix-list prefix-list-ospf1-into-ospf3 seq 5 permit 10.100.1.2/32

route-map ospf1-into-ospf3 permit 10
 match ip address prefix-list prefix-list-ospf1-into-ospf3


PE2

interface Loopback0
 ip address 10.100.1.5 255.255.255.255

interface Ethernet1/0
 no ip address
 xconnect 10.100.1.4 100 encapsulation mpls

router ospf 3
 network 10.3.0.0 0.0.255.255 area 0
 network 10.100.1.5 0.0.0.0 area 0

router bgp 1
 bgp log-neighbor-changes
 network 10.100.1.5 mask 255.255.255.255
 neighbor 10.100.1.2 remote-as 1
 neighbor 10.100.1.2 update-source Loopback0
 neighbor 10.100.1.2 send-label

Nota: Redistribución de la base IGP (OSPF 1) en la agregación IGP (ospf2 o el OSPF 3) se realiza con un route-map. Este route-map permite que los prefijos del loopback del RR redistribuyan en la agregación IGP. La razón de esto es que el prefijo del loopback del RR está hecho publicidad solamente directamente en la base IGP (OSPF 1). Sin embargo, el prefijo del loopback del RR se debe saber en la agregación IGP también, de modo que el BGP en el router PE pueda mirar con el loopback del RR.

Verificación

Véase el cuadro 2 para verificar la operación del avión del control.

Véase el cuadro 3 para verificar los anuncios de la escritura de la etiqueta MPLS.

Véase el cuadro 4 para el verificar el reenvío de paquete.

Éste es cómo los paquetes se remiten del PE1 al PE2. El prefijo del loopback del PE2 es 10.100.1.5/32, de modo que el prefijo esté de interés.

PE1#show ip route 10.100.1.5

Routing entry for 10.100.1.5/32
  Known via "bgp 1", distance 200, metric 0, type internal
  Last update from 10.100.1.1 00:11:12 ago
  Routing Descriptor Blocks:
  * 10.100.1.1, from 10.100.1.1, 00:11:12 ago
    Route metric is 0, traffic share count is 1
    AS Hops 0
    MPLS label: 22


PE1#show ip cef 10.100.1.5
10.100.1.5/32
  nexthop 10.2.2.6 Ethernet0/0 label 19 22


PE1#show ip cef 10.100.1.5 detail
10.100.1.5/32, epoch 0, flags rib defined all labels
  1 RR source [no flags]
  recursive via 10.100.1.1 label 22
    nexthop 10.2.2.6 Ethernet0/0 label 19

PE1#show bgp ipv4 unicast labels

   Network          Next Hop      In label/Out label
   10.100.1.4/32    0.0.0.0         imp-null/nolabel
   10.100.1.5/32    10.100.1.1      nolabel/22


P1#show mpls forwarding-table labels 19 detail
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop  
Label      Label      or Tunnel Id     Switched      interface             
19         Pop Label  10.100.1.1/32    603468        Et1/0      10.2.1.1  
        MAC/Encaps=14/14, MRU=1504, Label Stack{}
        AABBCC000101AABBCC0006018847
        No output feature configured


RR1#show mpls forwarding-table labels 22 detail
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop  
Label      Label      or Tunnel Id     Switched      interface            
22         21         10.100.1.5/32    575278        Et0/0      10.1.1.3  
        MAC/Encaps=14/22, MRU=1496, Label Stack{17 21}
        AABBCC000300AABBCC0001008847 0001100000015000
        No output feature configured


RR1#show bgp ipv4 unicast labels
   Network          Next Hop      In label/Out label
   10.100.1.4/32    10.100.1.4      19/imp-null
   10.100.1.5/32    10.100.1.2      22/21


P3#show mpls forwarding-table labels 17 detail
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop  
Label      Label      or Tunnel Id     Switched      interface            
17         Pop Label  10.100.1.2/32    664306        Et1/0      10.1.2.2  
        MAC/Encaps=14/14, MRU=1504, Label Stack{}
        AABBCC000201AABBCC0003018847
        No output feature configured


RR2#show mpls forwarding-table labels 21 detail
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop  
Label      Label      or Tunnel Id     Switched      interface            
21         17         10.100.1.5/32    615958        Et0/0      10.3.1.7  
        MAC/Encaps=14/18, MRU=1500, Label Stack{17}
        AABBCC000700AABBCC0002008847 00011000
        No output feature configured


RR2#show bgp ipv4 unicast labels
   Network          Next Hop      In label/Out label
   10.100.1.4/32    10.100.1.1      22/19
   10.100.1.5/32    10.100.1.5      21/imp-null


P2#show mpls forwarding-table labels 17 detail
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop  
Label      Label      or Tunnel Id     Switched      interface            
17         Pop Label  10.100.1.5/32    639957        Et1/0      10.3.2.5  
        MAC/Encaps=14/14, MRU=1504, Label Stack{}
        AABBCC000500AABBCC0007018847
        No output feature configured


PE1#trace
Protocol [ip]:
Target IP address: 10.100.1.5
Source address: 10.100.1.4

DSCP Value [0]:
Numeric display [n]:
Timeout in seconds [3]:
Probe count [3]:
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Port Number [33434]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Type escape sequence to abort.
Tracing the route to 10.100.1.5
VRF info: (vrf in name/id, vrf out name/id)
  1 10.2.2.6 [MPLS: Labels 19/22 Exp 0] 3 msec 3 msec 3 msec
  2 10.2.1.1 [MPLS: Label 22 Exp 0] 3 msec 3 msec 3 msec
  3 10.1.1.3 [MPLS: Labels 17/21 Exp 0] 3 msec 3 msec 2 msec
  4 10.1.2.2 [MPLS: Label 21 Exp 0] 2 msec 3 msec 2 msec
  5  *  *  *
  6 10.3.2.5 4 msec *  4 msec

Nota: ¿Demostraciones del salto 5? 5 * * *?. Esto es porque el router P2 no tiene una ruta para la dirección IP de origen 10.100.1.4 (PE1) del traceroute. Así, el router P2 no puede enviar el mensaje de error del Internet Control Message Protocol (ICMP) de nuevo al PE1. Esto es normal, pues la punta del MPLS unificado es no tener los prefijos del loopback de todo el Routers PE en una pieza de la agregación a aparecer en los IGP de las otras piezas de la agregación. El router P2 no intenta remitir el mensaje de error ICMP con la pila de etiquetas original. Esto es porque la pila de etiquetas original tiene solamente una escritura de la etiqueta. Si esta pila de etiquetas original del paquete tiene dos o más escrituras de la etiqueta, el mensaje de error ICMP se remite a lo largo del LSP y puede volver a la fuente del traceroute. Si la pila de etiquetas original tiene solamente una escritura de la etiqueta, el router que genera el mensaje de error ICMP intenta las operaciones de búsqueda de la ruta e intenta rutearlas con el uso de la tabla de ruteo (sin el uso de la pila de etiquetas original).

P2#show ip route 10.100.1.4
% Subnet not in table

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.

Información Relacionada



Document ID: 116127