Módulos e interfaces de Cisco : Cisco Unified SIP Proxy

Cómo configurar la Conmutación por falla para Cisco unificó el proxy del SORBO

18 Junio 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (21 Abril 2016) | Comentarios

Introducción

Este documento discute dos opciones para utilizar para configurar la Redundancia (Conmutación por falla) para Cisco unificó el proxy del SORBO.

Contribuido por Randy Yuan Wu, ingeniero de Cisco TAC.

Prerrequisitos

Requisitos

Cisco recomienda que tenga conocimiento sobre estos temas:

  • Hot Standby Router Protocol (HSRP)
  • DNS
  • Cisco unificó el proxy del SORBO (el CAMBIO DE SIGNO)

Componentes

La información en este documento se basa en el CAMBIO DE SIGNO.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos usados en este documento comenzado con una configuración borrada del valor por defecto). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Cree un default gateway Incidente-resistente

La capacidad de crear un default gateway incidente-resistente es una característica fundamental que el proxy unificado Cisco del SORBO (CAMBIO DE SIGNO) proporciona. Hay dos opciones que usted puede utilizar para alcanzar la Redundancia para el CAMBIO DE SIGNO. Uno es utilizar el servidor DNS SRV del Sistema de nombres de dominio (DNS); el otro es crear a un servidor virtual. El Hot Standby Router Protocol (HSRP) es el mecanismo por el cual un servidor virtual puede ser creado. La primera parte de este documento describe abreviadamente cómo implementar DNS SRV. ¿El resto y la mayoría de este documento describe cómo HSRP? las características s se pueden implementar para detectar los problemas en el chasis del router de los Servicios integrados (ISR) o en el módulo de servicio sí mismo del CUSP.

Opción uno — DNS SRV

En esta opción, configure el elemento por aguas arriba (cualquier elemento adelante llama al CAMBIO DE SIGNO) para utilizar el DNS. Si la tentativa de alcanzar cusp1 falla, las interrogaciones por aguas arriba del elemento para la entrada siguiente en DNS SRV y tentativas de utilizar cusp2. El DNS se debe configurar correctamente para que esto trabaje.

  1. Primero, dos expedientes DNS SRV (servicio) se deben crear, uno para cada cambio de signo. El expediente que señala a cusp1 tiene una prioridad más alta.

  2. En segundo lugar, dos expedientes DNS A (nombre de host) deben ser creados para poder resolver los destinos en los expedientes DNS SRV. Este ejemplo muestra lo que debe contener el servidor DNS en sus expedientes.

116015-configure-failover-cusp-01.png

Opción dos — HSRP

Este diagrama proporciona una arquitectura básica de cómo configurar el CAMBIO DE SIGNO para el HSRP. El lado izquierdo es un elemento por aguas arriba del SORBO, y el lado derecho es el elemento rio abajo del SORBO. Entre estos elementos es un router virtual con una dirección IP de 192.168.20.7. Ambos los elementos en sentido ascendente y descendentes llevan el tráfico del SORBO hacia la dirección IP del router virtual. Dentro del router virtual son dos routeres reales: un primario y un secundario. Este dos Routers comparte a esta misma dirección IP virtual, y sus configuraciones son idénticas con dos excepciones. Por lo tanto, las configuraciones dadas en este documento son lo mismo para ambo Routers.

Nota: La configuración HSRP para dos cambios de signo en un único router no se ha probado. Puede ser que sea posible tomar esta solución y ampliarla para los cambios de signo múltiples, pero no se soporta ahora.

116015-configure-failover-cusp-02.png

Conectividad básica de la configuración

Primero, Conectividad puesta entre el router y la cuchilla. Aunque esto se cubra en otros documentos, se discute redundante en este documento también. En este ejemplo, el router primario tiene un direccionamiento de 192.168.20.80 y su CAMBIO DE SIGNO tiene un direccionamiento de 192.168.20.81.

interface GigabitEthernet0/1
ip address 192.168.20.80 255.255.252.0
!!
interface Integrated-Service-Engine1/0
ip unnumbered GigabitEthernet0/1
service-module ip address 192.168.20.81 255.255.252.0
service-module ip default-gateway 192.168.20.80
!!
ip route 192.168.20.81 255.255.255.255 Integrated-Service-Engine1/0

El router secundario tiene un direccionamiento de 192.168.20.90 y su CAMBIO DE SIGNO tiene un direccionamiento de 192.168.20.81.

interface GigabitEthernet0/1
ip address 192.168.20.90 255.255.252.0
!!
interface Integrated-Service-Engine1/0
ip unnumbered GigabitEthernet0/1
service-module ip address 192.168.20.81 255.255.252.0
service-module ip default-gateway 192.168.20.90
!!
ip route 192.168.20.81 255.255.255.255 Integrated-Service-Engine1/0

Conmutación por falla del Router-nivel de la configuración

Después, la Conmutación por falla llana del router debe ser configurada. Esto implica la designación de una del Routers como el primario y de la otra como el secundario. Hay una leve diferencia en la configuración del dos Routers.

Aquí está la configuración para el router primario:

interface GigabitEthernet0/1
standby 0 ip 192.168.20.7
standby 0 priority 100

Aquí está la configuración para el router secundario:

interface GigabitEthernet0/1
standby 0 ip 192.168.20.7
standby 0 priority 90

Ambo Routers hace sus IP Address en Standby fijar al router virtual; sin embargo, el router primario tiene una prioridad más alta que la secundaria. Eso significa, mientras que el resto de las cosas son idénticas, el router primario se considera active, y todo el tráfico del SORBO va a través del router primario y entonces al CAMBIO DE SIGNO en ese router. El router secundario está en el recurso seguro y asume el control solamente si va el router primario abajo por cualquier motivo, por ejemplo una interrupción de la alimentación eléctrica.

Siga las interfaces

El HSRP también se debe poner para detectar un error del nivel del CAMBIO DE SIGNO. ¿Qué sucede si el CAMBIO DE SIGNO en el router primario muere por alguien razón, pero el router sí mismo es inafectado? El tráfico del SORBO continúa siendo enviado al CAMBIO DE SIGNO en el router primario. La prioridad del router se debe cambiar basó en el estado del CAMBIO DE SIGNO situado en cada router.

La manera de hacer esto es poner un eco ICMP al CAMBIO DE SIGNO de cada router. En este caso, la generación de eco se envía cada dos (2) segundos, con un (1) un segundo descanso. Cuanto más bajos estos valores son, después más aprisa el router puede detectar que el CAMBIO DE SIGNO está abajo. Sin embargo, si el eco ICMP se fija demasiado bajo, esto podría dar lugar a los falsos positivos. La línea de configuración más reciente de este ejemplo comienza la generación de eco y la fija para ocurrir para siempre.

Nota: Los ecos ICMP no pueden seguir el estado del puerto del SORBO. La falla de HSRP no puede ser iniciada si el problema está en el nivel del puerto. Para reiterar; si el router falla, el otro router asume el control; si los ping para los acuerdos del nivel del servicio del IP (SLA) fallan, el otro router asume el control; si el puerto del SORBO falla, esto no se detecta.

ip sla 1
icmp-echo 192.168.20.81
timeout 1000
frequency 2
!!
ip sla schedule 1 life forever start-time now

Un objeto se debe poner para seguir el estado de esa generación de eco. El número del objeto es 100 en este caso. La interfaz se debe fijar para decrement la prioridad del router por 20, si el estatus de este objeto está abajo. Esto significa si el CAMBIO DE SIGNO en el router primario va inactivo por alguna razón, su prioridad caerá a partir del 100 a 80. Su prioridad es entonces menos que el del secundario, que tiene una prioridad de 90. Si se fija el recurso seguro 0 se apropia, fuerza al router secundario a la toma de posesión para el primario, y entonces el tráfico del SORBO va al CAMBIO DE SIGNO secundario.

track 100 ip sla 1 reachability
!!
interface GigabitEthernet0/1
standby 0 track 100 decrement 20
standby 0 preempt

Configuración HSRP del router primario

ip sla 1
icmp-echo 192.168.20.81
timeout 1000
frequency 2
!!
ip sla schedule 1 life forever start-time now
!!
track 100 ip sla 1 reachability
!!
interface GigabitEthernet0/1
ip address 192.168.20.80 255.255.252.0
standby 0 ip 192.168.20.7
standby 0 priority 100
standby 0 preempt
standby 0 track 100 decrement 20
!!
interface Integrated-Service-Engine1/0
ip unnumbered GigabitEthernet0/1
service-module ip address 192.168.20.81 255.255.252.0
service-module ip default-gateway 192.168.20.80
!!
ip route 192.168.20.81 255.255.255.255 Integrated-Service-Engine1/0

Configuración HSRP del router secundario

ip sla 1
icmp-echo 192.168.20.81
timeout 1000
frequency 2
!!
ip sla schedule 1 life forever start-time now
!!
track 100 ip sla 1 reachability
!!
interface GigabitEthernet0/1
ip address 192.168.20.90 255.255.252.0
standby 0 ip 192.168.20.7
standby 0 priority 90
standby 0 preempt
standby 0 track 100 decrement 20
!!
interface Integrated-Service-Engine1/0
ip unnumbered GigabitEthernet0/1
service-module ip address 192.168.20.81 255.255.252.0
service-module ip default-gateway 192.168.20.90
!!
ip route 192.168.20.81 255.255.255.255 Integrated-Service-Engine1/0

Información Relacionada


Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Document ID: 116015