Módulos e interfaces de Cisco : Cisco Wireless LAN Controller Module

Malla y ejemplo de configuración del soporte del VLAN múltiple WGB

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra para soporte del VLAN múltiple del (WGB) de la malla y del Workgroup Bridge con la autenticación abierta (auth abierto) y con el protocolo lightweight extensible authentication (SALTO).

Nota: Contribuido por Surendra BG, ingeniero de Cisco TAC.

Otros documentos en esta serie

prerrequisitos

Requisitos

No hay requisitos específicos para este documento.

Componentes Utilizados

Este documento no tiene restricciones específicas en cuanto a versiones de software y de hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos Técnicos de Cisco para obtener más información sobre las convenciones sobre documentos.

Configurar

En esta sección encontrará la información para configurar las funciones descritas en este documento.

Nota: Utilice la herramienta Command Lookup Tool (clientes registrados solamente) para obtener más información sobre los comandos utilizados en esta sección.

Diagrama de la red

Este documento utiliza esta configuración de la red, que muestra cómo alcanzar el soporte del VLAN múltiple en el Switch detrás del WGB con el auth abierto. El SALTO se agrega en el extremo.

La topología es:

Servidor DHCP — Switch — Regulador del Wireless LAN (WLC) — Punta de acceso a raíz (RAP) (malla))))) (((((WGB — Switch

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-01.gif

  • El servidor del Protocolo de configuración dinámica de host (DHCP) se configura para el VLA N 50 y 100.

  • El WLC tiene las interfaces dinámicas creadas para el VLA N 50 y 100.

  • El WGB tiene subinterfaces para los VLA N requeridos — 50 y 100.

  • El Switch detrás del WGB ha requerido los VLA N — 50 y 100.

En la configuración de laboratorio, el VLA N 40 está para la Administración del WLC, el VLA N 40 en el RAP de la malla, y el VLA N 50 en el WGB. Los clientes detrás del Switch WGB consiguen la dirección IP del VLA N 50 y del VLAN 100 sobre el aire a través del WGB y del RAP de la malla.

Nota: La misma configuración se considera bueno para la punta de acceso de modo local (AP) también.

Configuraciones

En este documento, se utilizan estas configuraciones:

  • WLC WGB

  • Switch

  • SALTO

WLC WGB

En el comando line interface(cli) del WLC, ingrese el comando enable vlan del wgb de los config.

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-02.gif

En el WGB CLI, ingrese el comando del unificar-VLAN-cliente del Workgroup Bridge.

workgroup-bridge unified-vlan-client
dot11 ssid WGB_LWAPP
   vlan 50
   authentication open
   guest-mode
   infrastructure-ssid
end

interface Dot11Radio0
 no ip address
 no ip route-cache
 ssid WGB_LWAPP
 station-role workgroup-bridge
 
interface Dot11Radio0.50
 encapsulation dot1Q 50 native
 no ip route-cache
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Dot11Radio0.100
 encapsulation dot1Q 100
 no ip route-cache
 bridge-group 100
 
interface FastEthernet0.50
 encapsulation dot1Q 50 native
 no ip route-cache
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface FastEthernet0.100
 encapsulation dot1Q 100
 no ip route-cache
 bridge-group 100

interface BVI1

!--- Grab the IP address from VLAN 50 which is across wireless
 
 ip address dhcp  
 no ip route-cache

Switch

La configuración para el Switch es:

Switch#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
 
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
BGL14-TACLAB-ASW-S8
                 Fas 0/2           150          R S I     WS-C3550- Fas 0/27
SURBG-AP         Fas 0/1           130           T I      AIR-AP124 Fas 0
Switch#
Switch#sh run int fa 0/1
Building configuration...

Current configuration : 127 bytes
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 50
 switchport mode trunk
end

Switch#sh vlan br
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                         
12   VLAN0012                         active
40   VLAN0040                         active
50   VLAN0050                         active
100  VLAN0100                         active
Switch#sh run int vlan 50
Building configuration...
Current configuration : 41 bytes
!
interface Vlan50
 ip address dhcp
end

Switch#sh run int vlan 100
Building configuration...
 
Current configuration : 42 bytes
!
interface Vlan100
 ip address dhcp
end

Switch#sh ip int br | i up
Vlan12                 unassigned      YES DHCP    up                    up
Vlan50                 172.16.1.7      YES DHCP    up                    up
Vlan100                100.0.0.21      YES DHCP    up                    up

En conclusión, las interfaces del VLA N 50 y 100 obtienen la dirección IP del servidor DHCP, que está detrás del Switch en el sitio central a través de la Tecnología inalámbrica vía el RAP de la malla y el WGB.

En el WLC, el VLA N correcto se asocia a las interfaces correctas.

El VLAN 100 ase la dirección IP y esa entrada en el WLC.

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-03.gif

El VLA N 50 ase la dirección IP y esa entrada en el WLC.

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-04.gif

SALTO

Configure la red inalámbrica (WLAN) para el WPA2 - perfil local del eap del 802.1x.

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-05.gif

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-06.gif

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-07.gif

Asegure la prioridad de la autenticación en las puntas locales del Protocolo de Autenticación Extensible (EAP) a la base de datos de usuarios locales.

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-08.gif

WGP AP

dot11 ssid WGB_LWAPP
   vlan 50
   authentication open eap eap
   authentication network-eap eap
   authentication key-management wpa version 2
   dot1x credentials wgb
   dot1x eap profile eapfast
   infrastructure-ssid
   no ids mfp client
!

!--- Profile configured -- LEAP

eap profile eapfast                
 method leap
!
!
!

!--- Credentials used by this WGB AP to get auth with WLC (Local net users)

dot1x credentials wgb         
 username cisco123
 password 7 0822455D0A16544541
 

interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption mode ciphers aes-ccm
 !
 encryption vlan 50 mode ciphers aes-ccm
 !
 ssid WGB_LWAPP
 !
 packet retries 128
 station-role workgroup-bridge
!
interface Dot11Radio0.50
 encapsulation dot1Q 50 native
 no ip route-cache
 bridge-group 1
!
interface Dot11Radio0.100
 encapsulation dot1Q 100
 no ip route-cache
 bridge-group 100
 bridge-group 100 spanning-disabled

El cliente está en el estado de funcionamiento con la Seguridad del SALTO.

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-09.gif

Verificación

Actualmente, no hay un procedimiento de verificación disponible para esta configuración.

Troubleshooting

Actualmente, no hay información específica de troubleshooting disponible para esta configuración.


Información Relacionada


Document ID: 115752