Switching de LAN : 802.1Q

Pérdida del paquete sobre un túnel Dot1Q/L2P

18 Octubre 2015 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento discute sobre la localización de averías de la pérdida del paquete sobre un túnel Dot1Q/L2P debido al diseño de red pobre en el � del Cisco IOS con un caso práctico.

prerrequisitos

Requisitos

Cisco recomienda que tenga conocimiento sobre estos temas:

  • Conocimientos básicos en hacer un túnel del dot1q

  • Conocimientos básicos del OSPF

Componentes Utilizados

Este documento no se limita a una versión específica de software o de hardware.

La información que contiene este documento se creó a partir de los dispositivos en un ambiente de laboratorio específico. Todos los dispositivos que se utilizan en este documento se pusieron en funcionamiento con una configuración verificada (predeterminada). Si la red está funcionando, asegúrese de haber comprendido el impacto que puede tener cualquier comando.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Diagrama de la red

En esta configuración de la red, la interfaz Gi1/44 y el soldado enrollado en el ejército 1/43 del router 7600-Core tiene router en un palillo puesto con Fa0/13 y Fa0/12 del router 3400-Metro-1 respectivamente. En el 7600-Dot1Q Switch se habilitan la interfaz Gi9/44 y el soldado enrollado en el ejército 9/45 con el modo túnel del dot1q. Las interfaces vlan SVI se crean en el borde 3400-Metro y Fa0/13 y Fa0/12 se configuran como puertos troncales. El Routers utiliza el OSPF para comunicar con uno a.

http://www.cisco.com/c/dam/en/us/support/docs/lan-switching/8021q/113632-packet-loss-dot1q-l2p-01.gif

Configuraciones

Base 7609
!
version 15.0
hostname 7609-CORE
interface GigabitEthernet1/43
 mtu 9216
 no ip address
 no ip redirects
 no ip proxy-arp
 load-interval 60
 carrier-delay 2
 flowcontrol send off
 storm-control broadcast level 1.00
!
interface GigabitEthernet1/43.3503
 encapsulation dot1Q 3503
 ip address 172.16.41.17 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip mtu 1500
 ip ospf authentication-key 7 072C0E6B6B272D
 ip ospf network point-to-point
 ip ospf hello-interval 3
 ip ospf dead-interval 10
!
!
interface GigabitEthernet1/44
 mtu 9216
 no ip address
 no ip redirects
 no ip proxy-arp
 load-interval 60
 carrier-delay 2
 flowcontrol send off
 storm-control broadcast level 1.00
!
interface GigabitEthernet1/44.3803
 encapsulation dot1Q 3803
 ip address 172.16.73.137 255.255.255.248 secondary
 ip address 172.16.41.21 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip mtu 1500
 ip ospf authentication-key 7 072C0E6B6B272D
 ip ospf network point-to-point
 ip ospf cost 5
 ip ospf hello-interval 3
 ip ospf dead-interval 10

!--- Output omitted.

!
end

7609 DOT1Q
!
version 12.2
!
interface GigabitEthernet9/44
  switchport
 switchport access vlan 24
 switchport mode dot1q-tunnel
 mtu 9216
 load-interval 60
 carrier-delay 2
 flowcontrol send off
 storm-control broadcast level 1.00
 l2protocol-tunnel cdp
 l2protocol-tunnel stp
 l2protocol-tunnel vtp
 no cdp enable
 spanning-tree portfast disable
 spanning-tree bpdufilter enable
!
!
interface GigabitEthernet9/45
 switchport
 switchport access vlan 24
 switchport mode dot1q-tunnel
 mtu 9216
 load-interval 60
 carrier-delay 2
 flowcontrol send off
 storm-control broadcast level 1.00
 l2protocol-tunnel cdp
 l2protocol-tunnel stp
 l2protocol-tunnel vtp
 no cdp enable
 spanning-tree portfast disable
 spanning-tree bpdufilter enable
!

!--- Output omitted.

!
end

3400-Metro-1
!
version 12.2
!
interface FastEthernet0/3
  port-type nni
 switchport trunk allowed vlan 1052,3503
 switchport mode trunk
 load-interval 60
!
interface FastEthernet0/4
 port-type nni
 switchport trunk allowed vlan 1052,3803
 switchport mode trunk
 load-interval 60
!
!
interface FastEthernet0/12
 port-type nni
 switchport trunk allowed vlan 2-4094
 switchport mode trunk

!
interface FastEthernet0/13
 port-type nni
 switchport trunk allowed vlan 2-4094
 switchport mode trunk
!
end

borde 3400-Metro
!
version 12.2
!
interface FastEthernet0/12
 port-type nni
 switchport mode trunk
 load-interval 60
 storm-control broadcast level 1.00
 spanning-tree portfast disable
 spanning-tree bpdufilter disable
!
interface FastEthernet0/13
 port-type nni
 switchport mode trunk
 load-interval 60
 storm-control broadcast level 1.00
 spanning-tree portfast disable
 spanning-tree bpdufilter disable
!
!
interface Vlan3503
 ip address 172.16.41.18 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip ospf authentication-key 7 072C0E6B6B272D
 ip ospf network point-to-point
 ip ospf hello-interval 3
 ip ospf dead-interval 10
!
interface Vlan3803
 ip address 172.16.73.139 255.255.255.248 secondary
 ip address 172.16.41.22 255.255.255.252
 no ip redirects
 no ip proxy-arp
 ip ospf authentication-key 7 072C0E6B6B272D
 ip ospf network point-to-point
 ip ospf cost 5
 ip ospf hello-interval 3
 ip ospf dead-interval 10
!

!--- Output omitted.

!
end

Observación

Los descensos al azar del ping ocurren cuando el paquete atraviesa a través del túnel del dot1q. Pero, no hay descensos de la entrada-salida en las interfaces y también no hay síntomas de los problemas de la capa física. Publique el comando show interface <interface> para marcar los descensos de la entrada-salida en la interfaz:

7609-Dot1Q#show interface gi9/44 

!--- Output omitted.

 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    0 input errors, 0 CRC, 1 frame, 0 overrun, 0 ignored
    0 output errors, 0 collisions, 1 interface resets
    0 lost carrier, 0 no carrier, 0 PAUSE output

!--- Output omitted.

Cuando un tráfico ICMP de cerca de 100 ping se envía del Metro-borde, sólo 95 generaciones de eco se reciben en la base, que sugiere que los paquetes icmp estén consiguiendo cayó en la trayectoria.

Metro-Edge#ping 172.16.41.21 re 100

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 172.16.41.21, timeout is 2 seconds:
.....!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 95 percent (95/100), round-trip min/avg/max = �/9 ms

Nota: El comando show ip traffic en los 7609 muestra que solamente 95 echos están recibidos mientras que en el Metro-borde y él muestra que 100 echos están enviados.

muestre el tráfico del IP
En el Metro-borde
ICMP statistics:
  Rcvd: 0 format errors, 0 checksum errors, 0 redirects, 0 unreachable
        0 echo, 95 echo reply, 0 mask requests, 0 mask replies, 0 quench
        0 parameter, 0 timestamp, 0 info request, 0 other
        0 irdp solicitations, 0 irdp advertisements
  Sent: 0 redirects, 0 unreachable, 100 echo, 0 echo reply
        0 mask requests, 0 mask replies, 0 quench, 0 timestamp
        0 info reply, 0 time exceeded, 0 parameter problem
        0 irdp solicitations, 0 irdp advertisements

!--- The above output shows that 100 echos are sent
!--- but received 95 replies from 7609-Core.

En 7609-Core
ICMP statistics:
  Rcvd: 0 format errors, 0 checksum errors, 0 redirects, 0 unreachable
        95 echo, 0 echo reply, 0 mask requests, 0 mask replies, 0 quench
        0 parameter, 0 timestamp, 0 info request, 0 other
        0 irdp solicitations, 0 irdp advertisements
  Sent: 0 redirects, 0 unreachable, 0 echo, 95 echo reply
        0 mask requests, 0 mask replies, 0 quench, 0 timestamp
        0 info reply, 0 time exceeded, 0 parameter problem
        0 irdp solicitations, 0 irdp advertisements

Resolución de problemas

Verifique si las direcciones MAC estén aprendidas correctamente para resolver problemas el descenso en los paquetes.

Utilice el comando de la tabla del MAC address de la demostración para verificar las entradas de MAC Address.

Para el ping exitoso

7609-DOT1q#sh mac-address-table address E05F.B972.1F00 all
Legend: * - primary entry
age - seconds since last seen
n/a - not available
vlan mac address type learn age ports
------+----------------+--------+-----+----------+--------------------------
Active Supervisor:
* 24 e05f.b972.1f00 dynamic Yes 0 Gi9/44

!--- This output displays the MAC address learnt
!--- and its associated port, in this case the associated 
!--- port for successful ping is Gi9/44.

Para el ping del error

7609-DOT1q#sh mac-address-table address E05F.B972.1F00 all
Legend: * - primary entry
age - seconds since last seen
n/a - not available
vlan mac address type learn age ports
------+----------------+--------+-----+----------+--------------------------
Active Supervisor:
* 24 e05f.b972.1f00 dynamic Yes 5 Gi9/45

!--- This output displays the MAC address learnt
!--- and its associated port, in this case, 
!--- the port number is Gi9/45.

Para ver el índice detallado MAC el programar, utilice el comando show mac-address-table.

7609-DOT1q#sh mac-address-table address E05F.B972.1F00 det

MAC Table shown in details
========================================

PI_E RM RMA Type Alw-Lrn Trap Modified Notify Capture Flood Mac Address Age Pvlan SWbits Index XTag
----+---+---+----+-------+----+--------+------+-------+------+--------------+----+------+------+----

Active Supervisor:

Yes No No DY No No Yes No No No e05f.b972.1f00 0xE0 24 0 0x22C 0

Publique los comandos del number> del <Index del índice del mcast LTL-Info del Switch y de la prueba del registro remoto para saber qué número del puerto que el valor hex anterior denotó.

7609-DOT1q-sp#test mcast ltl-info index 22B
index 0x22B contain ports 9/44
7609-DOT1q-sp#test mcast ltl-info index 22C
index 0x22C contain ports 9/45

!--- The output shows that hex number 22B 
!--- points to 9/44 port and hex 22C points to 9/45.

Para el ping fallido la fuente y el índice del destino son el mismo puerto y por lo tanto el descenso. Cuando el Mac-movimiento habilitado con el comando del mac-movimiento de la notificación del mac-address-table en los 7600 él muestra las aletas MAC entre dos diversos puertos y éste es el mensaje de error:

Nota: Puesto que 6500/7600 utiliza una dirección MAC común para el Switch., la misma dirección MAC asignó entre diversos puertos. El comando del chasis-mac-direccionamiento del Catalyst 6000 de la demostración muestra la dirección MAC reservada del Switch.

* Jul 2 10:29:44.011: %MAC_MOVE-SP-4-NOTIF: Host e05f.b972.1f00 in 
vlan 24 is flapping between port Gi9/45 and port Gi9/44

!--- The previous error message indicates 
!--- that the same MAC address is assigned between 
!--- two different ports: Gi9/45 and port Gi9/44.

Solución

La red anterior es una configuración de la red de la interconexión total que tiene puntos finales del túnel del DOT1Q en el mismo Switch. En esta clase de configuración de la red se esperan las MAC-aletas. Para evitar el MAC-cambio, una de estas soluciones puede ser implementado.

  • Mueva el punto final del túnel a un diverso Switch, por ejemplo, la encapsulación y el decapsulation deben suceder en diverso Switch.

  • VLAN Pruning puede ser hecho para regular el VLANS en los puertos troncales uces de los.

Discusiones relacionadas de la comunidad de soporte de Cisco

La Comunidad de Soporte de Cisco es un foro donde usted puede preguntar y responder, ofrecer sugerencias y colaborar con colegas.


Información Relacionada


Document ID: 113632