IP : IP versión 6 (IPv6)

Redistribuya la ruta predeterminado del IPv6 BGP en el ejemplo de configuración EIGRPv6

17 Octubre 2016 - Traducción Automática
Otras Versiones: PDFpdf | Inglés (22 Agosto 2015) | Comentarios


Contenido


Introducción

Este documento proporciona una configuración de muestra de cómo redistribuir una ruta predeterminado del protocolo Protocolo de la puerta de enlace marginal (BGP) (IPv6 BGP) adentro al protocolo enhanced interior gateway routing (EIGRPv6) usando la redistribución recíproca entre EIGRPv6 y el IPv6 BGP.

prerrequisitos

Aseegurese que usted cumple estos requisitos antes de que usted intente esta configuración:

  • Tenga un conocimiento básico de EIGRPv6

  • Tenga un conocimiento básico del IPv6 BGP

  • Tenga un conocimiento básico de la dirección del IPv6

Versiones de hardware y de software

Las configuraciones en este documento se basan en el Cisco 7200 Series Router con el Software Release 15.0(1) del½ del¿Â del Cisco IOSïÂ.

Convenciones

Consulte Convenciones de Consejos TécnicosCisco para obtener más información sobre las convenciones del documento.

Configurar

En este ejemplo, el r2 y el r1 del Routers comunican con uno a usando el eBGP del IPv6. El r1 del Routers y el R3 utilizan EIGRPv6. La ruta predeterminado es creada en el r2 del router publicando el comando neighbor default-originate. Para redistribuir mutuamente las rutas del eBGP del IPv6 adentro a EIGRPv6, utilice el comando bgp de la redistribución con la Métrica EIGRP. Semejantemente, para redistribuir las rutas EIGRPv6 adentro a IPv6BGP, utilice el eigrp de la redistribución COMO comando number bajo modo de configuración de la direccionamiento-familia.

Nota: Utilice la herramienta de búsqueda de comandos (clientes registrados solamente) para encontrar más información sobre los comandos usados en este documento.

Diagrama de la red

En este documento, se utiliza esta configuración de red:

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6-ipv6/113598-redis-ipv6-default-route-01.gif

Configuraciones

En este documento, se utilizan estas configuraciones:

R1 del router
R1#show run
Building configuration...
!
version 15.0
!
hostname R1
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback10
 no ip address
 ipv6 address BB10::10/128
!
interface Loopback20
 no ip address
 ipv6 address BB20::20/128
!
interface Loopback30
 no ip address
 ipv6 address BB30::30/128
 ipv6 eigrp 1
!
interface Serial1/0
 no ip address
 ipv6 address 3030:1:1:1::11/64
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 ipv6 address 4040:1:1:1::10/64
 ipv6 eigrp 1
 serial restart-delay 0
!
!
router bgp 505
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 neighbor 3030:1:1:1::10 remote-as 500
 no auto-summary
 !
 address-family ipv6
  redistribute eigrp 1

!--- EIGRP is redistributed in to BGP.

  no synchronization
  network BB10::10/128
  network BB20::20/128
  neighbor 3030:1:1:1::10 activate
 exit-address-family
!
!
ipv6 router eigrp 1
 eigrp router-id 1.1.1.1
 redistribute bgp 505 metric 100 1 255 1 1500

!--- EIGRP for IPv6 has a shutdown feature.
!--- Make sure that the routing process is in "no shut" mode 
!--- in order to start running the protocol.


!--- BGP is redistributed with EIGRP default metrics.

!
end

R2 del router
R2#show run
Building configuration...
!
hostname R2
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback10
 no ip address
 ipv6 address AB10::10/128
!
interface Loopback20
 no ip address
 ipv6 address AB20::20/128
!
interface Serial1/0
 no ip address
 ipv6 address 3030:1:1:1::10/64
 serial restart-delay 0
!
router bgp 500
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 3030:1:1:1::11 remote-as 505
 neighbor 3030:1:1:1::11 default-originate
 no auto-summary
!
 address-family ipv6
  no synchronization
  network AB10::10/128
  network AB20::20/128
  neighbor 3030:1:1:1::11 activate
  neighbor 3030:1:1:1::11 default-originate
 exit-address-family
!
end

!--- Originates default route to the 
!--- neighbor 3030:1:1:1::11.

Router R3
R3#show run
!
version 15.0
!
hostname R3
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback10
 no ip address
 ipv6 address CC10::10/128
 ipv6 eigrp 1
!
interface Loopback20
 no ip address
 ipv6 address CC20::20/128
 ipv6 eigrp 1
!
interface Serial1/0
 no ip address
 ipv6 address 4040:1:1:1::11/64
 ipv6 eigrp 1
 serial restart-delay 0
!
!
ipv6 router eigrp 1
 eigrp router-id 3.3.3.3
!
end

Verificación

Utilize esta sección para confirmar que su configuración funcione correctamente.

La herramienta Output Interpreter Tool (clientes registrados solamente) (OIT) soporta ciertos comandos show. Utilize el OIT para ver una análisis de la salida del comando show.

Comandos show

Para verificar que el router R3 esté recibiendo la ruta predeterminado redistribuida del IPv6 BGP, utilice el comando eigrp de la show ipv6 route en el router R3.

eigrp de la show ipv6 route
En el router R3
R3#show ipv6 route eigrp
IPv6 Routing Table - default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       D - EIGRP, EX - EIGRP external, ND - Neighbor Discovery
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
EX  ::/0 [170/26112256]
     via FE80::C806:16FF:FE08:0, Serial1/0
EX  AB10::10/128 [170/26112256]
     via FE80::C806:16FF:FE08:0, Serial1/0
EX  AB20::20/128 [170/26112256]
     via FE80::C806:16FF:FE08:0, Serial1/0
D   BB30::30/128 [90/2297856]
     via FE80::C806:16FF:FE08:0, Serial1/0

!--- The above output shows that the default route
!--- is redistributed in EIGRP. EX indicates EIGRP external routes.

Para verificar las rutas EIGRPv6 se redistribuyen en el r2 del router correctamente, utilizan el comando bgp de la show ipv6 route en el r2 del router.

BGP de la show ipv6 route
En el r2 del router
R2#show ipv6 route bgp
IPv6 Routing Table - default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       D - EIGRP, EX - EIGRP external, ND - Neighbor Discovery
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B   BB10::10/128 [20/0]
     via FE80::C806:16FF:FE08:0, Serial1/0
B   BB20::20/128 [20/0]
     via FE80::C806:16FF:FE08:0, Serial1/0
B   CC10::10/128 [20/2297856]
     via FE80::C806:16FF:FE08:0, Serial1/0
B   CC20::20/128 [20/2297856]
     via FE80::C806:16FF:FE08:0, Serial1/0

!--- The above output shows that the eigrp routes
!--- are redistributed in to BGP.

Verifique el accesibilidad entre el r2 del Routers y el R3 usando el comando ping.

ping
Del r2 del router:
 
R2#ping  CC10::10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to CC10::10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/40/96 ms

R2#ping CC20::20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to CC20::20, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/44/100 ms
Del router R3:
 
R3#ping AA10::10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to AA10::10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/33/92 ms

R3#ping AA20::20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to AA20::20, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/33/92 ms

!--- The above ping responses shows that R1 and R3 are able
!--- to communicate with each other.


Información Relacionada


Document ID: 113598