Guía de configuración de la interfaz y del componente de hardware, Cisco IOS Release 12.2SR
MPLS VPN sobre el mGRE
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 180 KB | Inglés (13 Diciembre 2011) | Comentarios

MPLS VPN sobre el mGRE

Última actualización: De diciembre el 12 de 2011

El MPLS VPN sobre la característica del mGRE supera el requisito que un Multiprotocol Label Switching (MPLS) del soporte del portador permitiendo que usted proporcione la Conectividad MPLS entre las redes que son conectadas por los ip-only network. Esto permite que las trayectorias conmutadas de etiquetas MPLS (LSP) utilicen los túneles del Generic Routing Encapsulation (GRE) para cruzar rutear las áreas, los sistemas autónomos, y los proveedores de servicio de Internet (ISP). cuando el MPLS VPNs se configura sobre GRE de múltiples puntos (mGRE) usted puede desplegar los servicios basados del Red privada virtual (VPN) del borde del proveedor de la capa 3 (L3) (PE) usando un núcleo IP basado en estándares. Esto permite que usted provision los servicios VPN sin usar el método del recubrimiento.

Usted puede configurar los túneles del mGRE para crear una red de túneles de múltiples puntos que sobreponga una estructura básica IP. Este recubrimiento conecta al Routers PE para transportar el tráfico VPN. Además, cuando el MPLS VPNs se configura sobre el mGRE usted puede desplegar los servicios PE-basados L3 VPN usando un núcleo IP basado en estándares. Esto permite que usted provision los servicios VPN sin usar el método del recubrimiento. Cuando el MPLS VPN sobre el mGRE se configura, el sistema utiliza los túneles basado en IPv4 del mGRE para encapsular los paquetes VPN-etiquetados del IPv4 y del IPv6 entre los PE.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea la tabla de información de la característica en el extremo de este documento.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Requisitos previos para el MPLS VPN sobre el mGRE

Antes de que usted configure el MPLS VPN con los túneles del mGRE, asegúrese de que el MPLS VPN sea configurado y de trabajo correctamente. Vea “configurando MPLS el módulo de la capa 3 VPN” para la información sobre configurar el MPLS VPNs.

Restricciones para el MPLS VPN sobre el mGRE

  • El MPLS VPN sobre el mGRE se soporta en los Cisco 7600 Series Router que usan el linecard ES-40 y el linecard del SORBO 400 como indicadores luminosos LED amarillo de la placa muestra gravedad menor que hacen frente de la base.
  • El tráfico hecho un túnel de la etiqueta debe ingresar al router con un linecard que soporta el MPLS VPN sobre el mGRE.
  • Soportes para router cada PE una configuración del túnel solamente.
  • El MPLS VPN sobre el mGRE no soporta el transporte del tráfico Multicast entre los VPN.
  • Cuando un túnel GRE tiene la misma dirección destino y dirección de origen que el mGRE, el túnel consigue el route-cache conmutado.
  • Los paquetes que requieren la fragmentación consiguen la ruta caché-conmutada.
  • Cuando un perfil L3VPN se quita y se agrega detrás, después usted debe borrar el Border Gateway Protocol (BGP) usando el softcommand claro BGP del IP.
  • Cuando se crea un túnel del mGRE, un túnel simulado también se crea.
  • El loopback o la dirección IP usada en la fuente de la actualización de la configuración BGP debe ser lo mismo que el de la fuente del transporte del perfil L3VPN.
  • el mGRE no es el Stateful Switchover (SSO) obediente. Sin embargo, el mGRE y el SSO coexisten.
  • el mGRE y el túnel del árbol de distribución del Multicast (MDT) no se deben configurar con el mismo Loopback Address.

Las limitaciones para el MPLS VPN sobre la característica del mGRE son como sigue:

    • No todas las opciones GRE se soportan en el hardware (por ejemplo, encabezado extendida GRE y clave GRE).
    • Marcar los VLA N idénticos (el [ICMP] del protocolo Protocolo de control de mensajes de Internet (ICMP) reorienta) no se soporta en los túneles.
    • Las características tales como Unicast Reverse Path Forwarding (uRPF) y las estadísticas de la política de BGP no se soportan en los túneles.

Información sobre el MPLS VPN sobre el mGRE

MPLS VPN sobre el mGRE

El GRE es un protocolo Point-to-Point Tunneling donde dos pares forman los puntos finales del túnel. Se diseña para encapsular los paquetes de capas de red dentro de los paquetes del Tunelización IP. el mGRE es un protocolo similar con un solo punto final en un lado del túnel conectado con los puntos finales múltiples en el otro lado del túnel. El túnel del mGRE proporciona un link común entre las sucursales que conectan con el mismo VPN. Porque el mGRE es un modelo de la punta a de múltiples puntos, los túneles GRE completamente enredados no se requieren para interconectar los dispositivos del MPLS VPN PE.

El MPLS es una arquitectura de Internet extensamente desplegada VPN. El MPLS requiere que todos los routeres del núcleo en la red soporten el MPLS. Esta característica es útil en las redes donde el proveedor de servicio utiliza un portador de la estructura básica para proporcionar la Conectividad.

El MPLS VPN sobre la característica del mGRE supera el requisito del soporte MPLS del portador permitiendo que usted proporcione la Conectividad MPLS entre las redes que son conectadas por los ip-only network. Esto permite que el MPLS LSP utilice los túneles GRE para cruzar rutear las áreas, los sistemas autónomos, y los ISP.

Cuando el MPLS VPNs se configura sobre el mGRE usted puede desplegar los servicios PE-basados L3 VPN usando un núcleo IP basado en estándares. Esto permite que usted provision los servicios VPN sin usar el LSP o un Protocolo de distribución de etiquetas (LDP). El sistema utiliza los túneles basado en IPv4 del mGRE para encapsular los paquetes VPN-etiquetados del IPv4 y del IPv6 entre los PE.

El MPLS VPN sobre la característica del mGRE también permite que usted despliegue la tecnología LSP-encapsulada MPLS VPN existente simultáneamente al MPLS VPN sobre el mGRE y permite al sistema para determinar qué método de encapsulación se utiliza para rutear el tráfico específico. El router del ingreso PE determina que tecnología de la encapsulación a utilizar cuando un paquete se envía al router alejado PE.

Esta sección incluye la información sobre los temas siguientes en el MPLS VPN sobre la característica del mGRE:

Mapas de Ruta

Por abandono, el tráfico VPN se envía usando un LSP. El MPLS VPN sobre la característica del mGRE utiliza los mapa del ruta definidos por el usario para determinar que los prefijos VPN son accesibles sobre un túnel del mGRE y que son accesibles los prefijos VPN usando un LSP. El Route Map se aplica a los anuncios para el VPNv4 y las familias del direccionamiento VPNv6. El Route Map utiliza una tabla del túnel del salto siguiente para determinar el método de encapsulación para el tráfico VPN.

Para rutear el tráfico sobre el túnel del mGRE, el sistema crea un espacio de la dirección alternativo que muestre que todos los saltos siguientes son alcanzados encapsulando el tráfico en un túnel del mGRE. Para configurar una ruta específica para utilizar un túnel del mGRE, el usuario agrega una entrada para esa ruta al Route Map. La nueva entrada remaps la Información de alcance de la capa de red (NLRI) de la ruta al espacio de la dirección alternativo. Si hay ningún remap la entrada en el Route Map para una ruta, después trafique en esa ruta se remite sobre un LSP.

Cuando el usuario configura el MPLS VPN sobre el mGRE, el sistema provisions automáticamente el espacio de la dirección alternativo, llevado a cabo normalmente en el caso túnel-encapsulado del ruteo virtual y de la expedición (VRF). Para asegurarse de que todo trafique accesible a través del espacio de la dirección se encapsula en un túnel del mGRE, el sistema instala una sola ruta predeterminado fuera de un túnel. El sistema también crea un túnel predeterminado en el Route Map. El usuario puede asociar esta correspondencia de la ruta predeterminado a las actualizaciones de BGP apropiadas.

Tunnel Endpoint Discovery y expedición

Para que el MPLS VPN sobre la característica del mGRE a funcionar correctamente, el sistema debe poder descubrir el telecontrol PE en la información de reenvío del túnel del sistema y de la construcción para estos el telecontrol PE. Además el sistema debe poder detectar cuando un telecontrol PE es no más válido y quitar la información de reenvío del túnel para ese PE.

Si un ingreso PE recibe un anuncio VPN sobre el BGP, utiliza los atributos de la blanco de la ruta (que inserta en el VRF) y la escritura de la etiqueta del MPLS VPN del anuncio, para asociar los prefijos al cliente apropiado. El salto siguiente de la ruta insertada se fija al NLRI del anuncio.

Los prefijos des divulgación contienen la información sobre el telecontrol PE en el sistema (bajo la forma de NLRI), y el PE utiliza esta información para notificar el sistema cuando un NLRI llega a estar activo o inactivo. El sistema utiliza esta notificación para poner al día la información de reenvío PE.

Cuando el sistema recibe la notificación de un nuevo telecontrol PE, agrega la información a la base de datos del punto final del túnel, que hace el sistema crear una adyacencia asociada a la interfaz del túnel. La descripción de la adyacencia incluye la información sobre la encapsulación y otra que procesan que el sistema debe realizarse para enviar los paquetes encapsulados al nuevo telecontrol PE.

La información de adyacencia se pone en el VRF encapsulado túnel. Cuando un usuario remaps un VPN NLRI a una ruta en el VRF (usando el Route Map), el sistema conecta el NLRI a la adyacencia; por lo tanto el VPN se conecta a un túnel.

Decapsulation del túnel

Cuando la salida PE recibe un paquete de una interfaz del túnel que utilice el MPLS VPN sobre la característica del mGRE, los decapsulates PE el paquete para crear un paquete con Tag de la escritura de la etiqueta VPN, y envían el paquete al código de la expedición MPLS (MFI).

Origen de túnel

El MPLS VPN sobre la característica del mGRE utiliza un solo túnel configurado como túnel del mGRE para configurar un sistema con un gran número de puntos finales (telecontrol PE). Para identificar el origen de los paquetes túnel-encapsulados, el sistema utiliza la información del origen de túnel.

En (ingreso) el PE que transmite, cuando un paquete VPN se envía a un túnel, el destino del túnel es el NLRI. En (salida) un PE de recepción, el origen de túnel es el direccionamiento que los paquetes encapsulados en el túnel del mGRE se reciben encendido. Por lo tanto, en la salida PE el destino del paquete debe hacer juego el NLRI del PE local.

IPv6 VPN

Si el router de la publicidad PE tiene un direccionamiento del IPv6 entonces el NLRI debe también ser un direccionamiento del IPv6 (sin importar la red entre los PE). Si la red entre los PE es IPv4 basado, el sistema crea el direccionamiento del IPv6 del PE publicitario usando un direccionamiento asociado IPv4 en la forma siguiente: :: FFFF:IPv4-PE-address. El PE de recepción fija el salto siguiente para los prefijos del IPv6 de la etiqueta VPN al direccionamiento del IPv4 integrado en el IPv6 NLRI. Esto permite al PE para conectar el tráfico VPNv6 a un LSP o un túnel del mGRE asocia de la misma manera el tráfico del VPNv4.

Cuando un PE recibe las actualizaciones VPNv6, aplica el Route Map del IPv6. El MPLS VPN sobre la característica del mGRE utiliza el Route Map del IPv6 para fijar la información del salto siguiente en el Tunnel_Encap VRF.

Cómo configurar el MPLS VPN sobre el mGRE

Para desplegar el MPLS VPN sobre los túneles del mGRE, usted crea un caso VRF, habilita y configura la encapsulación L3 VPN, conecta el Route Map a la plantilla de la aplicación, y configura el VPNv4 BGP y el intercambio VPNv6 para filtrar las actualizaciones con el Route Map.

Configurar un perfil de la encapsulación L3VPN

Esta sección describe cómo configurar un perfil de la encapsulación L3VPN.


Nota


Los protocolos de transporte tales como IPv6, MPLS, IP, y protocolo Layer 2 Tunneling Protocol versión 3 (L2TPv3) se pueden también utilizar en esta configuración.
PASOS SUMARIOS

1. permiso

2. configuró terminal

3. nombre del perfil del IP de la encapsulación l3vpn

4. [source interface-type interface-number] del transporte ipv4

5. [key gre-key] del gre del protocolo

6. extremo

7. muestre el nombre del perfil del IP de la encapsulación l3vpn


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
nombre del perfil del IP de la encapsulación l3vpn


Ejemplo:

Encap del túnel del IP de la encapsulación de Router(config)# l3vpn

 

Ingresa al modo de configuración de la encapsulación L3 VPN para crear el túnel.

 
Paso 4
[source interface-type interface-number] del transporte ipv4


Ejemplo:

Loopback0 de la fuente del transporte ipv4 Router(config-l3vpn-encap-ip)#

 

(Opcional) especifica al modo de origen del transporte del IPv4 y define la interfaz de origen del transporte.

  • Si usted utiliza el comando del interface-type interface-number de la fuente del transporte ipv4, aseegurese que utilizan a la dirección de origen especificada como el salto siguiente en las actualizaciones de BGP des divulgación por el PE.
  • Si usted no utiliza este comando, el comando del Next-Hop BGP del sourceor de la actualización de BGP se utiliza automáticamente como el origen de túnel.
 
Paso 5
[key gre-key] del gre del protocolo


Ejemplo:

Clave 1234 del gre del protocolo Router(config-l3vpn-encap-ip)#

 

Especifica el GRE como el modo túnel y fija la clave GRE.

 
Paso 6
Finalizar


Ejemplo:

Extremo Router(config-l3vpn-encap-ip)#

 

Modo de configuración y devoluciones de la encapsulación de las salidas L3 VPN al modo EXEC privilegiado.

 
Paso 7
muestre el nombre del perfil del IP de la encapsulación l3vpn


Ejemplo:

Encap del túnel del IP de la encapsulación de la demostración l3vpn del Router-

 

(Opcional) visualiza la salud del perfil y la interfaz del túnel subyacente.

 

Configurar el BGP y el Route Maps

Realice esta tarea de configurar el BGP y los mapa del ruta. Los pasos siguientes también le permiten para conectar el Route Map a la plantilla de la aplicación y para configurar el VPNv4 BGP y el intercambio VPNv6 para filtrar las actualizaciones con el Route Map.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. como-número BGP del router

4. log-neighbor-changes BGP

5. neighbor ip-address telecontrol-como el como-número

6. nombre de la interfaz de la actualización-fuente del neighbor ip-address

7. direccionamiento-familia ipv4

8. ninguna sincronización

9. redistribuya conectado

10. el neighbor ip-address activa

11 ningún automóvil summary

12.    salida

13.    direccionamiento-familia vpnv4

14.    el neighbor ip-address activa

15.    enviar-comunidad ambas del neighbor ip-address

16.    nombre de asignación del route-map del neighbor ip-address adentro

17.    salida

18.    direccionamiento-familia vpnv6

19.    el neighbor ip-address activa

20.    enviar-comunidad ambas del neighbor ip-address

21.    nombre de asignación del route-map del neighbor ip-address adentro

22.    salida

23.    posición del permiso del Map Tag del route-map

24.    fije el Next-Hop del IP encapsulan el nombre del perfil l3vpn

25.    fije el Next-Hop del IPv6 encapsulan el nombre del perfil l3vpn

26.    salga

27.    salga


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
como-número BGP del router


Ejemplo:

BGP 100 del router de Router(config)#

 

Especifica el número de un sistema autónomo que identifique al router a otros routeres BGP y marque la información de ruteo con etiqueta pasajera adelante, y ingresa al modo de configuración del router.

 
Paso 4
log-neighbor-changes BGP


Ejemplo:

Router (config-router) # log-neighbor-changes BGP

 

Habilita el registro de reinicios del vecino BGP.

 
Paso 5
neighbor ip-address telecontrol-como el como-número


Ejemplo:

Router (config-router) # vecino 209.165.200.225 telecontrol-como 100

 

Añade una entrada al BGP o a la tabla de vecinos BGP multiprotocolo.

 
Paso 6
nombre de la interfaz de la actualización-fuente del neighbor ip-address


Ejemplo:

Router (config-router) # loopback0 de la actualización-fuente de 209.165.200.225 del vecino

 

Permite que las sesiones de BGP utilicen cualquier interfaz operativa para las conexiones TCP.

 
Paso 7
direccionamiento-familia ipv4


Ejemplo:

Router (config-router) # direccionamiento-familia ipv4

 

Ingresa al modo de configuración de la familia del direccionamiento para configurar las sesiones de la encaminamiento que utilizan los prefijos de dirección del IPv4.

 
Paso 8
ninguna sincronización


Ejemplo:

Router (config-router-AF) # ninguna sincronización

 

Permite al Cisco IOS Software para hacer publicidad de una ruta de la red sin esperar un IGP.

 
Paso 9
redistribuya conectado


Ejemplo:

El router (config-router-AF) # redistribuye conectado

 

Redistribuye las rutas a partir de un dominio de ruteo en otro dominio de ruteo y permite que el protocolo de la blanco redistribuya las rutas aprendidas por el protocolo de la fuente y los prefijos conectados en esas interfaces sobre las cuales el protocolo de la fuente se esté ejecutando.

 
Paso 10
el neighbor ip-address activa


Ejemplo:

El router (config-router-AF) # vecino 209.165.200.225 activa

 

Habilita el intercambio de información con un vecino BGP.

 
Paso 11
ningún automóvil summary


Ejemplo:

Router (config-router-AF) # ningún automóvil summary

 

Inhabilita el resumen automático y envía la información de ruteo de subprefijo a través de los límites de la red con clase.

 
Paso 12
salida


Ejemplo:

Router (config-router-AF) # salida

 

Sale del modo de configuración de familia de direcciones.

 
Paso 13
direccionamiento-familia vpnv4


Ejemplo:

Router (config-router) # direccionamiento-familia vpnv4

 

Ingresa al modo de configuración de la familia del direccionamiento para configurar las sesiones de la encaminamiento, tales como BGP, que utilizan los prefijos de dirección estándar del VPNv4.

 
Paso 14
el neighbor ip-address activa


Ejemplo:

El router (config-router-AF) # vecino 209.165.200.225 activa

 

Habilita el intercambio de información con un vecino BGP.

 
Paso 15
enviar-comunidad ambas del neighbor ip-address


Ejemplo:

Router (config-router-AF) # enviar-comunidad ambas de 209.165.200.225 del vecino

 

Especifica que un atributo de las comunidades, para el estándar y las comunidades ampliadas, se debe enviar a un vecino BGP.

 
Paso 16
nombre de asignación del route-map del neighbor ip-address adentro


Ejemplo:

Router (config-router-AF) # route-map SELECT_UPDATE_FOR_L3VPN de 209.165.200.225 del vecino adentro

 

Aplica el Route Map Nombrado a la ruta entrante.

 
Paso 17
salida


Ejemplo:

Router (config-router-AF) # salida

 

Sale del modo de configuración de familia de direcciones.

 
Paso 18
direccionamiento-familia vpnv6


Ejemplo:

Router (config-router) # direccionamiento-familia vpnv6

 

Ingresa al modo de configuración de la familia del direccionamiento para configurar las sesiones de la encaminamiento, tales como BGP, que utilizan los prefijos de dirección VPNv6.

 
Paso 19
el neighbor ip-address activa


Ejemplo:

El router (config-router-AF) # vecino 209.165.200.252 activa

 

Habilita el intercambio de información con un vecino BGP.

 
Paso 20
enviar-comunidad ambas del neighbor ip-address


Ejemplo:

Router (config-router-AF) # enviar-comunidad ambas de 209.165.200.252 del vecino

 

Especifica que un atributo de las comunidades, para el estándar y las comunidades ampliadas, se debe enviar a un vecino BGP.

 
Paso 21
nombre de asignación del route-map del neighbor ip-address adentro


Ejemplo:

Router (config-router-AF) # route-map SELECT_UPDATE_FOR_L3VPN de 209.165.200.252 del vecino adentro

 

Aplica el Route Map Nombrado a la ruta entrante.

 
Paso 22
salida


Ejemplo:

Router (config-router-AF) # salida

 

Sale del modo de configuración de familia de direcciones.

 
Paso 23
posición del permiso del Map Tag del route-map


Ejemplo:

Router (config-router) # permiso 10 del route-map SELECT_UPDATE_FOR_L3VPN

 

Ingresa al modo de configuración del route-map y define las condiciones para redistribuir las rutas a partir de un Routing Protocol en otro.

  • El comando router configuration de la redistribución utiliza el Map Tag especificado para referirse a este Route Map. Los mapa del ruta múltiples pueden compartir el mismo nombre del Map Tag.
  • Si los criterios de concordancia se cumplen para este Route Map, la ruta se redistribuye según lo controlado por las acciones del conjunto.
  • Si los criterios de concordancia no se cumplen, el Route Map siguiente con el mismo Map Tag se prueba. Si una ruta no pasa ningunos de los criterios de concordancia para el conjunto de los mapa del ruta que comparten el mismo nombre, no es redistribuida por ésa fijó.
  • El argumento de la posición indica que la posición que un nuevo Route Map tendrá en la lista de mapa del ruta configuró ya con el mismo nombre.
 
Paso 24
fije el Next-Hop del IP encapsulan el nombre del perfil l3vpn


Ejemplo:

El router (config-route-map) # fijó el Next-Hop del IP encapsula l3vpn mi perfil

 

Indica que los paquetes del IPv4 de la salida que pasan una cláusula de la coincidencia del Route Map están enviados al VRF para la encapsulación de túnel.

 
Paso 25
fije el Next-Hop del IPv6 encapsulan el nombre del perfil l3vpn


Ejemplo:

El router (config-route-map) # fijó el Next-Hop del IP encapsula el encap del túnel l3vpn

 

Indica que los paquetes del IPv6 de la salida que pasan una cláusula de la coincidencia del Route Map están enviados al VRF para la encapsulación de túnel.

 
Paso 26
salida


Ejemplo:

Router (config-route-map) # salida

 

Da salida al modo de configuración del route-map y ingresa al modo de configuración global.

 
Paso 27
salida


Ejemplo:

Salida de Router(config)#

 

Sale del modo de configuración global.

 

Ejemplos de configuración para el MPLS VPN sobre el mGRE

Ejemplo que verifica El MPLS VPN sobre la configuración del mGRE

Utilice los siguientes ejemplos para verificar que la configuración está trabajando correctamente:

El conmutar del Cisco Express Forwarding (CEF)

Usted puede verificar que el CEF Switching esté trabajando como se esperaba:

Router# show ip cef vrf Customer_A tunnel 0

209.165.200.250
/24
    nexthop 209.165.200.251 Tunnel0 label 16

Creación del punto final

Usted puede verificar el punto final del túnel se ha creado que:

Router# show tunnel endpoints tunnel 0 
             
 Tunnel0 running in multi-GRE/IP mode
 Endpoint transport 209.165.200.251 Refcount 3 Base 0x2AE93F0 Create Time 00:00:42
   overlay 209.165.200.254 Refcount 2 Parent 0x2AE93F0 Create Time 00:00:42

Adyacencia

Usted puede verificar que se haya creado la adyacencia correspondiente:

Router# show adjacency tunnel 0
   Protocol Interface                 Address
  IP       Tunnel0                   209.165.200.251(4)
  TAG      Tunnel0                   209.165.200.251(3)

Salud del perfil

Usted puede utilizar el comando del nombre del perfil de la encapsulación de la demostración l3vpn de conseguir la información sobre el estado básico de la aplicación. La salida de este comando le proporciona los detalles en las referencias al túnel subyacente.

Router# show l3vpn encapsulation ip tunnel encap
	Profile: tunnel encap
	transport ipv4 source Auto: Loopback0
	protocol gre
  	Tunnel Tunnel0 Created [OK]
  	Tunnel Linestate [OK]
  	Tunnel Transport Source (Auto) Loopback0 [OK]

Secuencia del ejemplo de configuración para el MPLS VPN sobre el mGRE

Este ejemplo muestra la secuencia de configuración para el MPLS VPN sobre el mGRE:

vrf definition Customer A
 rd 100:110
 route-target export 100:1000
 route-target import 100:1000
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
!
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
!
l3vpn encapsulation ip sample profile name 
 transport source loopback 0 
 protocol gre key 1234 
!
!
 interface Loopback0
  ip address 209.165.200.252 255.255.255.224
  ip router isis 
!
interface Serial2/0
 vrf forwarding Customer A
 ip address 209.165.200.253 255.255.255.224
 ipv6 address 3FFE:1001::/64 eui-64
 no fair-queue
 serial restart-delay 0
! 
router bgp 100
 bgp log-neighbor-changes
 neighbor 209.165.200.254 remote-as 100
 neighbor 209.165.200.254 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  redistribute connected
  neighbor 209.165.200.254 activate
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 209.165.200.254 activate
  neighbor 209.165.200.254 send-community both
  neighbor 209.165.200.254 route-map SELECT_UPDATE_FOR_L3VPN in
 exit-address-family
 !
 address-family vpnv6
  neighbor 209.165.200.254 activate
  neighbor 209.165.200.254 send-community both
  neighbor 209.165.200.254 route-map SELECT_UPDATE_FOR_L3VPN in
 exit-address-family
 !
 address-family ipv4 vrf Customer A
  no synchronization
  redistribute connected
 exit-address-family
 !
 address-family ipv6 vrf Customer A
  redistribute connected
  no synchronization
 exit-address-family
!
!
route-map SELECT_UPDATE_FOR_L3VPN permit 10
set ip next-hop encapsulate sample profile name 
set ipv6 next-hop encapsulate sample profile name 

Referencias adicionales

Documentos Relacionados

Tema relacionado

Título del documento

Configuración de VPNs de Capa 3 MPLS

Guía de Configuración de Multiprotocol Label Switching de Cisco IOS

Capa dinámica 3 VPN con los túneles GRE de múltiples puntos

Guía de configuración de la interfaz del Cisco IOS y del componente de hardware

Cisco Express Forwarding

Guía de configuración del Switching IP del Cisco IOS

Generic Routing Encapsulation

Guía de configuración de la interfaz del Cisco IOS y del componente de hardware

Estándares

Estándar

Título

Ninguno

--

MIB

MIB

Link del MIB

IETF-PPVPN-MPLS-VPN-MIB

Para localizar y descargar el MIB para las plataformas elegidas, las versiones de software de Cisco, y los conjuntos de características, utilizan el localizador MIB de Cisco encontrado en el URL siguiente:

http://www.cisco.com/cisco/web/LA/support/index.html

RFC

RFC

Título

RFC 2547

BGP/MPLS VPN

RFC 2784

Generic Routing Encapsulation (GRE)

RFC 2890

Extensiones del número de la secuencia clave al GRE

RFC 4023

Encapsulado del MPLS en el IP o el Generic Routing Encapsulation

RFC 4364

Redes privadas virtuales (VPN) IP BGP/MPLS

Asistencia Técnica

Descripción

Link

El sitio Web de soporte técnico de Cisco proporciona los recursos en línea extensos, incluyendo la documentación y las herramientas para localizar averías y resolver los problemas técnicos con los Productos Cisco y las Tecnologías.

Para recibir la Seguridad y la información técnica sobre sus Productos, usted puede inscribir a los diversos servicios, tales como la herramienta de alerta del producto (accedida de los Field Notice), el hoja informativa de los servicios técnicos de Cisco, y alimentaciones realmente simples de la sindicación (RSS).

El acceso a la mayoría de las herramientas en el sitio Web de soporte técnico de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html

Información de la característica para el MPLS VPN sobre el mGRE

La tabla siguiente proporciona la información sobre la versión sobre la característica o las características descritas en este módulo. Esta tabla enumera solamente la versión de software que introdujo el soporte para una característica dada en un tren de versión de software dado. A menos que se indicare en forma diferente, las versiones posteriores de ese tren de versión de software también soportan esa característica.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Tabla 1Información de la característica para el MPLS VPN sobre el mGRE

Nombre de la función

Versiones

Información sobre la Función

MPLS VPN sobre el mGRE

12.2(33)SRE 15.1(2)T

Esta característica proporciona el soporte para llevar el tráfico de la capa 3 VPN MPLS sobre el mGRE. Esta característica también soporta el SIP-400 y ES-40 en los Cisco 7600 Series Router.

Los siguientes comandos fueron introducidos o modificados por esta característica: el gre de la encapsulación l3vpn protocolo IP, IP de la encapsulación de la demostración l3vpn, el transporte ipv4, fijó el Next-Hop del IP, fijó el Next-Hop del IPv6.

Cisco y el logotipo de Cisco son marcas registradas o marcas registradas de Cisco y/o de sus afiliados en los E.E.U.U. y otros países. Para ver una lista de marcas registradas de Cisco, vaya a este URL: www.cisco.com/go/trademarks. Las marcas registradas de tercera persona mencionadas son la propiedad de sus propietarios respectivos. El uso de la palabra Partner no implica en una relación de sociedad entre Cisco y ninguna otra compañía. (1110R)

Las direcciones IP (Internet Protocol) y los números de teléfono utilizados en este documento no son direcciones y números de teléfono reales. Cualesquiera ejemplos, muestra de la salida de comandos, diagramas de topología de red y otras figuras incluidos en el documento se muestran solamente con fines ilustrativos. El uso de direcciones IP o números de teléfono reales en contenido ilustrativo es involuntario y fortuito.

Cisco Systems, Inc. del © 2011 todos los derechos reservados.