Guía de configuración de la interfaz y del componente de hardware, Cisco IOS Release 12.2SR
Capa dinámica 3 VPN con los túneles GRE de múltiples puntos
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 267 KB | Inglés (13 Diciembre 2011) | Comentarios

Capa dinámica 3 VPN con los túneles GRE de múltiples puntos

Última actualización: De diciembre el 12 de 2011

La capa dinámica 3 VPN con la característica de múltiples puntos de los túneles GRE proporciona un mecanismo de transporte de la capa 3 (L3) basado en una tecnología de tunelización de múltiples puntos aumentada del Generic Routing Encapsulation (mGRE) para el uso en las redes IP. El transporte dinámico del Tunelización de la capa 3 se puede también utilizar dentro de las redes IP para transportar el tráfico del Red privada virtual (VPN) a través del proveedor de servicio y de las redes para empresas, y para proporcionar la Interoperabilidad para el transporte del paquete entre IP y el Multiprotocol Label Switching (MPLS) VPN. Esta característica proporciona el soporte para el RFC 2547, que define la externalización de los servicios de la estructura básica IP para las redes para empresas.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea la información de la característica para L3 dinámico VPN con los túneles del mGRE.

Utilice Cisco Feature Navigator para buscar información sobre el soporte de plataformas y el soporte de imágenes del software Cisco IOS y Catalyst OS. Para acceder a Cisco Feature Navigator, vaya a http://www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Los requisitos previos para L3 dinámico VPN con el mGRE hacen un túnel

Antes de que usted configure la capa dinámica 3 VPN con los túneles GRE de múltiples puntos ofrece, se asegura de que su MPLS VPN es configurado y de trabajo correctamente. Vea “configurando MPLS el módulo de la capa 3 VPN” para la información sobre configurar el MPLS VPNs.

Las restricciones para L3 dinámico VPN con el mGRE hacen un túnel

  • El despliegue de un MPLS VPN usando la encapsulación IP/GRE y MPLS dentro de una red única no se soporta.
  • Soportes para router de cada borde del proveedor (PE) una configuración del túnel solamente.

La información sobre L3 dinámico VPN con el mGRE hace un túnel

Usted puede configurar los túneles del mGRE para crear una red de túneles de múltiples puntos que sobreponga una estructura básica IP. Este recubrimiento conecta al Routers PE para transportar el tráfico VPN. Para desplegar los túneles del mGRE L3 VPN, usted crea un caso VRF, crea el túnel del mGRE, reorienta el tráfico IP VPN al túnel, y configura el intercambio del VPNv4 BGP para filtrar las actualizaciones con un Route Map y los prefijos interesantes se resuelvan en la tabla VRF.

Además, cuando el MPLS VPNs se configura sobre el mGRE, usted puede desplegar los servicios PE-basados L3 VPN usando un núcleo IP basado en estándares. Esto permite que usted provision los servicios VPN sin usar el método del recubrimiento. Cuando un MPLS VPN sobre el mGRE se configura, el sistema utiliza los túneles basado en IPv4 del mGRE para encapsular los paquetes VPN-etiquetados del IPv4 y del IPv6 entre los PE.

Túneles del mGRE de la capa 3

Configurando los túneles del mGRE, usted crea una red de túneles de múltiples puntos como recubrimiento a la estructura básica IP. Este recubrimiento interconecta al Routers PE para transportar el tráfico VPN con la estructura básica. Esta red de túneles de múltiples puntos utiliza el Border Gateway Protocol (BGP) para distribuir la información de ruteo del VPNv4 entre el Routers PE, manteniendo la relación de peer entre el proveedor de servicio o la red para empresas y los sitios del cliente. El salto siguiente de divulgación en el VPNv4 BGP acciona el Tunnel Endpoint Discovery. Esta característica proporciona la capacidad para que los proveedores de servicio múltiples cooperen y ofrezcan un servicio de la junta VPN con el tráfico tunneled directamente del router del ingreso PE en un proveedor de servicio directamente al router de la salida PE en un diverso sitio del proveedor de servicio.

Además de proporcionar a la capacidad de transporte VPN, los túneles del mGRE crean una topología de mallado completo y reducen los gastos indirectos administrativos y operativos asociados previamente a una interconexión total de los túneles Point-to-Point usados para interconectar los sitios de cliente múltiple. Los requisitos para la configuración se reducen y permiten grandemente a la red para crecer con la configuración adicional mínima.

Los túneles dinámicos L3 preven un mejor escalamiento al crear la Interconexión parcial o el full-mesh VPN. Se simplifica agregar a los nuevos pares del telecontrol VPN porque solamente el nuevo router necesita ser configurado. El nuevo direccionamiento se aprende dinámicamente y se propaga a los Nodos en la red. La capacidad del Dynamic Routing reduce dramáticamente los tamaños de la configuración necesarios en todo el Routers en el VPN, tales que con el uso de los túneles de múltiples puntos, sólo una interfaz del túnel necesita ser configurada en un PE que mantenga muchos VPN. Los túneles del mGRE L3 necesitan ser configurados solamente en el router PE. Las características disponibles con el GRE están todavía disponibles con el mGRE, incluyendo el Dynamic IP Routing y conmutar del Multicast IP y del Cisco Express Forwarding (CEF) del mGRE/del tráfico de túnel del protocolo next hop routing (NHRP).

Las secciones siguientes describen cómo se utilizan los túneles del mGRE:

Interconexión de los routeres de borde del proveedor dentro de una red del IP

La capa dinámica 3 VPN con la característica de múltiples puntos de los túneles GRE permite que usted cree una red de túneles multiaccesa para interconectar al Routers PE que mantiene su red del IP. Esta red de túneles transporta el tráfico IP VPN a todo el Routers PE. La figura abajo ilustra la red de recubrimiento del túnel usada en una red del IP para transportar el tráfico VPN entre el Routers PE.

Figura 1del Routers cubierto túnel del mGRE conexión PE dentro de una red del IP


La red de recubrimiento multiaccesa del túnel proporciona la total conectividad entre el Routers PE. Las rutas del intercambio VPN del Routers PE usando el BGP según lo definido en el RFC 2547. El tráfico IP se reorienta a través de la red de recubrimiento de múltiples puntos del túnel usando los espacios de IP Address distintos para el recubrimiento y las redes de transporte y cambiando el espacio de la dirección en vez de cambiar el valor numérico del direccionamiento.

Transporte del paquete entre el IP y las redes MPLS

Los túneles del mGRE de la capa 3 se pueden utilizar como mecanismo de transporte del paquete entre el IP y las redes MPLS. Para habilitar el transporte del paquete entre los dos diversos protocolos, un router PE en un lado de la conexión entre las dos redes debe ejecutar el MPLS. La figura debajo de las demostraciones cómo los túneles del mGRE se pueden utilizar para transportar el tráfico VPN entre el Routers PE.

Figura 2mGRE usado para transportar el tráfico VPN entre el IP y la red MPLS


Para que el transporte del paquete ocurra entre el IP y la red MPLS, la escritura de la etiqueta del MPLS VPN se asocia a la clave GRE. La asignación ocurre en el router donde se configuran el mGRE y el MPLS. En la figura sobre la asignación de la escritura de la etiqueta a la clave ocurre en el router M, que se sienta en la red MPLS.

Verificación del salto siguiente BGP

El BGP realiza la selección de trayecto BGP, o la verificación del salto siguiente, en el PE. Para un trayecto BGP a una red que se considerará en el proceso de selección de trayecto, el salto siguiente para la trayectoria debe ser accesible en el Interior Gateway Protocol (IGP). Cuando un prefijo IP se recibe y se hace publicidad como el IP Address de Next Hop, el tráfico IP es tunneled de la fuente al destino conmutando el espacio de la dirección del salto siguiente.

Cómo configurar los túneles del mGRE L3 VPN

Crear el túnel VRF y del mGRE

El túnel que transporta el tráfico VPN a través de la red del proveedor de servicios reside en su propio espacio de la dirección. Un caso especial VRF se debe crear llamó la resolución en VRF (RiV). Esta sección describe cómo crear el VRF y el túnel GRE.

Antes de comenzar

La dirección IP en la interfaz debe ser lo mismo que el de la interfaz de origen especificada en la configuración. La interfaz de origen especificada debe hacer juego eso usado por el BGP como fuente para la actualización del VPNv4.


Nota


El IPSec del modo túnel no se soporta en el MPLS sobre el túnel GRE.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. IP VRF vrf-name

4. rd 1:1

5. nombre de túnel del túnel de la interfaz

6. subred-identificación del IP address del IP Address

7. loopback n del origen de túnel

8. gre l3vpn de múltiples puntos del modo túnel

9. túnel GRE-KE dominante y

10. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
IP VRF vrf-name


Ejemplo:

Cliente de Router(config)# IP VRF un riv

 

Crea la resolución especial en el caso y la tabla VRF (RiV) VRF que serán utilizados para el túnel y el cambio de dirección de la dirección IP.

 
Paso 4
rd 1:1


Ejemplo:

Router (config-VRF) # rd 1:1

 

Ingresa el modo de la configuración de VRF y especifica un Route Distinguisher (RD) para un caso VPN VRF.

 
Paso 5
nombre de túnel del túnel de la interfaz


Ejemplo:

Router (config-VRF) # túnel 1 de la interfaz

 

Ingresa al modo de configuración de la interfaz para crear el túnel.

 
Paso 6
subred-identificación del IP address del IP Address


Ejemplo:

Router (config-if) # IP address 209.165.200.225 255.255.255.224

 

Especifica la dirección IP para el túnel.

 
Paso 7
loopback n del origen de túnel


Ejemplo:

Router (config-if) # loopback test1 del origen de túnel

 

Crea el Loopback Interface.

 
Paso 8
gre l3vpn de múltiples puntos del modo túnel


Ejemplo:

Router (config-if) # gre l3vpn de múltiples puntos del modo túnel

 

Fija el modo para el túnel como “gre el l3vpn" de múltiples puntos.

 
Paso 9
túnel GRE-KE dominante y


Ejemplo:

Router (config-if) # clave 18 del túnel

 

Especifica la clave GRE para el túnel.

 
Paso 10
Finalizar


Ejemplo:

Router(config-if)#end

 

Sale el modo y las devoluciones de la configuración actual al modo EXEC privilegiado.

 

Configurar el intercambio BGP VPN

La tarea de configuración descrita en esta sección configura el intercambio del VPNv4 BGP para filtrar las actualizaciones con un Route Map y los prefijos interesantes se resuelvan en la tabla VRF.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. nombre de túnel del túnel de la interfaz

4. túnel n del subnet mask del IP address del riv-VRF-nombre del vrf de la ruta de IP

5. como-número BGP del router

6. red-identificación de la red

7. vecino {IP address | par-grupo-nombre} telecontrol-como el como-número

8. vecino {IP address | tipo de interfaz de la actualización-fuente del par-grupo-nombre}

9. [unicast] de la direccionamiento-familia vpnv4

10. vecino {IP address | el par-grupo-nombre} activa

11 vecino {IP address | nombre de asignación del route-map del par-grupo-nombre} {en | hacia fuera}

12.    fije el vrf-name del Next-Hop resolución-en-VRF del IP

13.    Finalizar


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
nombre de túnel del túnel de la interfaz


Ejemplo:

Túnel 1 de la interfaz de Router(config)#

 

Ingresa al modo de configuración de la interfaz para el túnel.

 
Paso 4
túnel n del subnet mask del IP address del riv-VRF-nombre del vrf de la ruta de IP


Ejemplo:

Router (config-if) # túnel 1 del vrf vrf1 209.165.200.226 255.255.255.224 de la ruta de IP

 

Fija el reenvío de paquete al RiV especial VRF.

 
Paso 5
como-número BGP del router


Ejemplo:

BGP 100 del router de Router(config)#

 

Especifica el número de un sistema autónomo que identifique al router a otros routeres BGP y marque la información de ruteo con etiqueta pasajera adelante.

 
Paso 6
red-identificación de la red


Ejemplo:

Red 209.165.200.255 de Router(config)#

 

Especifica el ID de la red para que las redes sean hechas publicidad por el BGP y los procesos de ruteo del Multiprotocol BGP.

 
Paso 7
neighbor {ip-address | par-grupo-nombre} telecontrol-como el como-número


Ejemplo:

Vecino 209.165.200.227 de Router(config)# telecontrol-como 100

 

Añade una entrada al BGP o a la tabla de vecinos BGP multiprotocolo.

 
Paso 8
neighbor {ip-address | tipo de interfaz de la actualización-fuente del par-grupo-nombre}


Ejemplo:

FastEthernet0/1 de la actualización-fuente de 209.165.200.228 del vecino de Router(config)#

 

Especifica una interfaz operativa específica que las sesiones de BGP utilicen para las conexiones TCP.

 
Paso 9
[unicast] de la direccionamiento-familia vpnv4


Ejemplo:

Direccionamiento-familia vpnv4 de Router(config)#

 

Especifica al modo de configuración de la familia del direccionamiento para configurar las sesiones de la encaminamiento, tales como BGP, que utilizan los prefijos de dirección estándar VPN4.

 
Paso 10
neighbor {ip-address | el par-grupo-nombre} activa


Ejemplo:

El vecino 209.165.200.229 de Router(config)# activa

 

Habilita el intercambio de información con un router vecino.

 
Paso 11
neighbor {ip-address | nombre de asignación del route-map del par-grupo-nombre} {en | hacia fuera}


Ejemplo:

Mpt del route-map de 209.165.200.230 del vecino de Router(config)# adentro

 

Aplica un route map a las rutas de entrada o de salida.

  • Utilice una vez para cada ruta entrante.
 
Paso 12
fije el vrf-name del Next-Hop resolución-en-VRF del IP


Ejemplo:

Vrft determinado del Next-Hop resolución-en-VRF del IP de Router(config)#

 

Especifica que el salto siguiente debe ser resuelto en la tabla VRF para el VRF especificado.

 
Paso 13
Finalizar


Ejemplo:

Router(config)# end

 

Sale el modo y las devoluciones de la configuración actual al modo EXEC privilegiado.

 
Pasos Siguientes

Habilitando el MPLS VPN sobre los túneles y configurar del mGRE un perfil de la encapsulación L3VPN

Esta sección describe cómo definir el VRF, habilitar el MPLS VPN sobre el mGRE, y configurar un perfil de la encapsulación L3VPN.


Nota


Los protocolos de transporte tales como IPv6, MPLS, IP, y protocolo Layer 2 Tunneling Protocol versión 3 (L2TPv3) se pueden también utilizar en esta configuración.
Antes de comenzar

Para habilitar y configurar el MPLS VPN sobre el mGRE, usted debe primero definir el VRF para la encapsulación de túnel y habilitar la encapsulación L3VPN en el sistema.


PASOS SUMARIOS

1. permiso

2. configuró terminal

3. vrf-name de la definición del vrf

4. rd 1:1

5. salida

6. cef del IP

7. Unicast Routing del IPv6

8. cef del IPv6

9. nombre del perfil del IP de la encapsulación l3vpn

10. interfaz de origen n del transporte ipv4

11 [key gre-key] del gre del protocolo

12.    salida

13.    número del tipo de la interfaz

14.    máscara del IP address del IP Address

15.    ISIS del router del IP

16.    Finalizar


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
vrf-name de la definición del vrf


Ejemplo:

Encap del túnel de la definición del vrf de Router(config)#

 

Configura un caso de la tabla de ruteo VPN VRF y ingresa el modo de la configuración de VRF.

 
Paso 4
rd 1:1


Ejemplo:

Router (config-VRF) # rd 1:1

 

Especifica un RD para un caso VPN VRF.

 
Paso 5
salida


Ejemplo:

Router (config-VRF) # salida

 

Modo de la configuración de VRF de las salidas.

 
Paso 6
ip cef


Ejemplo:

Cef del IP de Router(config)#

 

Cisco Express Forwarding de los permisos en el router.

 
Paso 7
Unicast Routing del IPv6


Ejemplo:

Unicast Routing del IPv6 de Router(config)#

 

Habilita la expedición de los datagramas del unicast del IPv6.

 
Paso 8
cef del IPv6


Ejemplo:

Cef del IPv6 de Router(config)#

 

Cisco Express Forwarding de los permisos para el IPv6 en el router.

 
Paso 9
nombre del perfil del IP de la encapsulación l3vpn


Ejemplo:

Encap del túnel del IP de la encapsulación de Router(config)# l3vpn

 

Ingresa al modo de configuración de la encapsulación L3 VPN para crear el túnel.

 
Paso 10
interfaz de origen n del transporte ipv4


Ejemplo:

Loopback0 de la fuente del transporte ipv4 Router(config-l3vpn-encap-ip)#

 

Especifica al modo de origen del transporte del IPv4 y define la interfaz de origen del transporte.

 
Paso 11
[key gre-key] del gre del protocolo


Ejemplo:

Clave 1234 del gre del protocolo Router(config-l3vpn-encap-ip)#

 

Especifica el GRE como el modo túnel y fija la clave GRE.

 
Paso 12
salida


Ejemplo:

Salida Router(config-l3vpn-encap-ip)#

 

Modo de configuración de la encapsulación de las salidas L3 VPN.

 
Paso 13
número del tipo de la interfaz


Ejemplo:

Interface Loopback 0 de Router(config)#

 

Ingresa al modo de configuración de la interfaz para configurar el tipo de interfaz.

 
Paso 14
máscara del IP address del IP Address


Ejemplo:

Router (config-if) # dirección IP 10.10.10.4 255.255.255.255

 

Especifica el IP Address principal y la máscara para la interfaz.

 
Paso 15
ISIS del router del IP


Ejemplo:

Router (config-if) # ISIS del router del IP

 

Configura un proceso de ruteo del Intermediate System-to-Intermediate System (IS-IS) para el IP en la interfaz y asocia un diseñador nulo del área al proceso de ruteo.

 
Paso 16
Finalizar


Ejemplo:

Router(config-if)#end

 

Sale el modo y las devoluciones de la configuración actual al modo EXEC privilegiado.

 

Definiendo el espacio de la dirección y especificar el address resolution para el MPLS VPNs sobre el mGRE

Esta sección describe cómo definir el espacio de la dirección y especificar el address resolution para el MPLS VPNs sobre el mGRE. Los pasos siguientes también le permiten para conectar el Route Map a la plantilla de la aplicación y para configurar el VPNv4 BGP y el intercambio VPNv6 para filtrar las actualizaciones con el Route Map.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. como-número BGP del router

4. log-neighbor-changes BGP

5. neighbor ip-address telecontrol-como el como-número

6. interface name del tipo de interfaz de la actualización-fuente del neighbor ip-address

7. direccionamiento-familia vpn4

8. ninguna sincronización

9. redistribuya conectado

10. el neighbor ip-address activa

11 ningún automóvil summary

12.    salida

13.    direccionamiento-familia vpnv4

14.    el neighbor ip-address activa

15.    enviar-comunidad ambas del neighbor ip-address

16.    nombre de asignación del route-map del neighbor ip-address adentro

17.    salida

18.    direccionamiento-familia vpnv6

19.    el neighbor ip-address activa

20.    enviar-comunidad ambas del neighbor ip-address

21.    IP address del route-map del neighbor ip-address adentro

22.    salida

23.    posición del permiso del Map Tag del route-map

24.    fije el Next-Hop del IP encapsulan el encap del túnel l3vpn

25.    fije el Next-Hop del IPv6 encapsulan el nombre del perfil l3vpn

26.    Finalizar

27.    Finalizar


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
como-número BGP del router


Ejemplo:

Router (config) # BGP 100 del router

 

Especifica el número de un sistema autónomo que identifique al router a otros routeres BGP, marque la información de ruteo con etiqueta pasajera adelante, y ingrese al modo de configuración del router.

 
Paso 4
log-neighbor-changes BGP


Ejemplo:

Router (config-router) # log-neighbor-changes BGP

 

Habilita el registro de reinicios del vecino BGP.

 
Paso 5
neighbor ip-address telecontrol-como el como-número


Ejemplo:

Router (config-router) # vecino 10.10.10.6 telecontrol-como 100

 

Añade una entrada al BGP o a la tabla de vecinos BGP multiprotocolo.

 
Paso 6
interface name del tipo de interfaz de la actualización-fuente del neighbor ip-address


Ejemplo:

Router (config-router) # loopback0 de la actualización-fuente de 10.10.10.6 del vecino

 

Permite que las sesiones de BGP utilicen cualquier interfaz operativa para las conexiones TCP.

 
Paso 7
direccionamiento-familia vpn4


Ejemplo:

Router (config-router) # direccionamiento-familia vpnv4

 

Ingresa al modo de configuración de la familia del direccionamiento para configurar las sesiones de la encaminamiento, los prefijos de dirección del IPv4 de ese uso.

 
Paso 8
ninguna sincronización


Ejemplo:

Router (config-router-AF) # ninguna sincronización

 

Permite al Cisco IOS Software para hacer publicidad de una ruta de la red sin esperar un IGP.

 
Paso 9
redistribuya conectado


Ejemplo:

El router (config-router-AF) # redistribuye conectado

 

Redistribuye las rutas a partir de un dominio de ruteo en otro dominio de ruteo y permite que el protocolo de la blanco redistribuya las rutas aprendidas por el protocolo de la fuente y los prefijos conectados en esas interfaces sobre las cuales el protocolo de la fuente se esté ejecutando.

 
Paso 10
el neighbor ip-address activa


Ejemplo:

El router (config-router-AF) # vecino 10.10.10.6 activa

 

Habilita el intercambio de información con un vecino BGP.

 
Paso 11
ningún automóvil summary


Ejemplo:

Router (config-router-AF) # ningún automóvil summary

 

Inhabilita el resumen automático y envía la información de ruteo del subprefix a través de los límites de la red classful

 
Paso 12
salida


Ejemplo:

Router (config-router-AF) # salida

 

Sale del modo de configuración de familia de direcciones.

 
Paso 13
direccionamiento-familia vpnv4


Ejemplo:

Router (config-router) # direccionamiento-familia vpnv4

 

Ingresa al modo de configuración de la familia del direccionamiento para configurar las sesiones de la encaminamiento, tales como BGP, que utilizan los prefijos de dirección estándar del VPNv4.

 
Paso 14
el neighbor ip-address activa


Ejemplo:

El router (config-router-AF) # vecino 10.10.10.6 activa

 

Habilita el intercambio de información con un vecino BGP.

 
Paso 15
enviar-comunidad ambas del neighbor ip-address


Ejemplo:

Router (config-router-AF) # enviar-comunidad ambas de 10.10.10.6 del vecino

 

Especifica que un atributo de la comunidad, para el estándar y las comunidades ampliadas, se debe enviar a un vecino BGP.

 
Paso 16
nombre de asignación del route-map del neighbor ip-address adentro


Ejemplo:

Router (config-router-AF) # ACTUALIZACIÓN SELECTA del route-map de 10.10.10.6 del vecino PARA L3VPN adentro

 

Aplica el Route Map Nombrado a la ruta entrante.

 
Paso 17
salida


Ejemplo:

Router (config-router-AF) # salida

 

Sale del modo de configuración de familia de direcciones.

 
Paso 18
direccionamiento-familia vpnv6


Ejemplo:

6Router (config-router) # direccionamiento-familia vpnv4

 

Ingresa al modo de configuración de la familia del direccionamiento para configurar las sesiones de la encaminamiento, tales como BGP, que utilizan los prefijos de dirección VPNv6.

 
Paso 19
el neighbor ip-address activa


Ejemplo:

El router (config-router-AF) # vecino 209.165.200.252 activa

 

Habilita el intercambio de información con un vecino BGP.

 
Paso 20
enviar-comunidad ambas del neighbor ip-address


Ejemplo:

Router (config-router-AF) # enviar-comunidad ambas de 209.165.200.252 del vecino

 

Especifica que un atributo de las comunidades, para el estándar y las comunidades ampliadas, se debe enviar a un vecino BGP.

 
Paso 21
IP address del route-map del neighbor ip-address adentro


Ejemplo:

Router (config-router-AF) # ACTUALIZACIÓN SELECTA del route-map de 209.165.200.252 del vecino PARA L3VPN adentro

 

Aplica el Route Map Nombrado a la ruta entrante.

 
Paso 22
salida


Ejemplo:

Router (config-router-AF) # salida

 

Sale del modo de configuración de familia de direcciones.

 
Paso 23
posición del permiso del Map Tag del route-map


Ejemplo:

Router (config-router) # permiso 10 de 192.168.10.1 del route-map

 

Ingresa al modo de configuración del route-map y define las condiciones para redistribuir las rutas a partir de un Routing Protocol en otro.

  • El comando router configuration de la redistribución utiliza el Map Tag especificado para referirse a este Route Map. Los mapa del ruta múltiples pueden compartir el mismo nombre del Map Tag.
  • Si los criterios de concordancia se cumplen para este Route Map, la ruta se redistribuye según lo controlado por las acciones del conjunto.
  • Si los criterios de concordancia no se cumplen, el Route Map siguiente con el mismo Map Tag se prueba. Si una ruta no pasa ningunos de los criterios de concordancia para el conjunto de los mapa del ruta que comparten el mismo nombre, no es redistribuida por ésa fijó.
  • El argumento de la posición indica la posición que el nuevo Route Map tendrá en la lista de mapa del ruta configurados ya con el mismo nombre.
 
Paso 24
fije el Next-Hop del IP encapsulan el encap del túnel l3vpn


Ejemplo:

El router (config-route-map) # fijó el Next-Hop del IP encapsula l3vpn mi perfil

 

Indica que los paquetes del IPv4 de la salida que pasan una cláusula de la coincidencia del Route Map están enviados al VRF para la encapsulación de túnel.

 
Paso 25
fije el Next-Hop del IPv6 encapsulan el nombre del perfil l3vpn


Ejemplo:

El router (config-route-map) # fijó el Next-Hop del IP encapsula el encap del túnel l3vpn



Ejemplo:

 

Indica que los paquetes del IPv6 de la salida que pasan una cláusula de la coincidencia del Route Map están enviados al VRF para la encapsulación de túnel.

 
Paso 26
Finalizar


Ejemplo:

Router (config-route-map) # salida

 

Da salida al modo de configuración del route-map y ingresa al modo de configuración global.

 
Paso 27
Finalizar


Ejemplo:

Router (config) # salida

 

Sale del modo de configuración global.

 
Pasos Siguientes

Pasos Siguientes

Usted puede realizar el siguiente para aseegurarse que la configuración está trabajando correctamente.

Marque el prefijo VRF

Verifique que el prefijo especificado VRF haya sido recibido por el BGP. La entrada de tabla BGP debe mostrar que el Route Map ha trabajado y que el salto siguiente está mostrando en el RiV. Utilice el comando show ip bgp vpnv4 tal y como se muestra en de este ejemplo.

Router# show ip bgp vpnv4 vrf customer 209.165.200.250
BGP routing table entry for 100:1:209.165.200.250/24, version 12
Paths: (1 available, best #1)
  Not advertised to any peer
  Local
209.165.200.251 in "my riv" from 209.165.200.251 (209.165.200.251)
      Origin incomplete, metric 0, localpref 100, valid, internal, best
      Extended Community: RT:100:1

Confirme que la misma información se ha propagado a la tabla de ruteo:

Router# show ip route vrf customer 209.165.200.250
 
Routing entry for 209.165.200.250
/24
  Known via "bgp 100", distance 200, metric 0, type internal
  Last update from 209.165.200.251 00:23:07 ago
  Routing Descriptor Blocks:
  * 209.165.200.251 (my riv), from 209.165.200.251, 00:23:07 ago
      Route metric is 0, traffic share count is 1
      AS Hops 0
CEF Switching

Usted puede también verificar que el CEF Switching esté trabajando como se esperaba:

Router# show ip cef vrf customer
 209.165.200.250

209.165.200.250
/24, version 6, epoch 0
0 packets, 0 bytes
  tag information set
    local tag: VPN-route-head
    fast tag rewrite with Tu1, 123.1.1.2, tags imposed: {17}
  via 209.165.200.251, 0 dependencies, recursive
    next hop 209.165.200.251, Tunnel1 via 209.165.200.251/32 (my riv)
    valid adjacency
    tag rewrite with Tu1, 209.165.200.251, tags imposed: {17}
Creación del punto final

Observe que en esta visualización del ejemplo el punto final del túnel se ha creado correctamente:

Router# show tunnel endpoint tunnel 1
Tunnel1 running in multi-GRE/IP mode
  RFC2547/L3VPN Tunnel endpoint discovery is active on Tu1
  Transporting l3vpn traffic to all routes recursing through "my riv"
 Endpoint 209.165.200.251 via destination 209.165.200.251
 Endpoint 209.165.200.254 via destination 209.165.200.254
Adyacencia

Confirme que se ha creado la adyacencia correspondiente.

Router# show adjacency Tunnel 1 interface
Protocol Interface                 Address
TAG      Tunnel1                   209.165.200.251(4)
                                   15 packets, 1980 bytes
                                   4500000000000000FF2FC3C77B010103
                                   7B01010200008847
                                   Epoch: 0
                                   Fast adjacency disabled
                                   IP redirect disabled
                                   IP mtu 1472 (0x0)
                                   Fixup enabled (0x2)
                                         GRE tunnel
                                   Adjacency pointer 0x624A1580, refCount 4
                                   Connection Id 0x0
                                   Bucket 121

Observe que porque el MPLS se está transportando sobre el mGRE, la adyacencia LINK_TAG es la adyacencia relevante. El MTU señalado en la adyacencia es la magnitud de carga útil (escritura de la etiqueta incluyendo MPLS) que el paquete validará. La cadena MAC mostrada en la visualización de la adyacencia puede ser interpretada como sigue:

45000000 -> Beginning of IP Header (Partially populated, tl & chksum
00000000    are fixed up per packet)
FF2FC3C7
7B010103 -> Source IP Address in transport network 209.165.200.253
7B010102 -> Destination IP address in transport network 209.165.200.252
00008847 -> GRE Header

Refiera a la guía de configuración del Multiprotocol Label Switching del Cisco IOS para la información sobre configurar la capa 3 VPN MPLS.

Usted puede utilizar el comando del nombre del perfil de la encapsulación de la demostración l3vpn de conseguir la información sobre el estado básico de la aplicación. La salida de este comando le proporciona los detalles en las referencias al túnel y al VRF.

Los ejemplos de configuración para el soporte dinámico L3 VPN usando el mGRE hacen un túnel

Configurar el ejemplo de los túneles del mGRE de la capa 3 VPN

Este ejemplo muestra la secuencia de configuración para crear los túneles del mGRE. Incluye la definición del caso especial VRF.

ip vrf my riv
 rd 1:1
interface Tunnel1
 ip vrf forwarding my_riv
 ip address 209.165.200.250 255.255.255.224
 tunnel source Loopback0
 tunnel mode gre multipoint l3vpn
 tunnel key 123
end
ip route vrf my riv ip address subnet mask Tunnel1
router bgp 100
 network 209.165.200.251
 neighbor 209.165.200.250 remote-as 100
 neighbor 209.165.200.250 update-source Loopback0
 !
 address-family vpnv4
 neighbor 209.165.200.250 activate
 neighbor 209.165.200.250 route-map SELECT_UPDATES_FOR_L3VPN_OVER_MGRE in
!
route-map SELECT UPDATES FOR L3VPN OVER MGRE permit 10
 set ip next-hop in-vrf my riv

Este ejemplo muestra la configuración para conectar un Route Map a la aplicación:

vrf definition Customer A
 rd 100:110
 route-target export 100:1000
 route-target import 100:1000
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
vrf definition tunnel encap
 rd 1:1
!
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
!
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
!
l3vpn encapsulation ip profile name 
 transport source loopback 0 
 protocol gre key 1234 
!
!
 interface Loopback0
  ip address 209.165.200.252 255.255.255.224
  ip router isis 
!
interface Serial2/0
 vrf forwarding Customer A
 ip address 209.165.200.253 255.255.255.224
 ipv6 address 3FFE:1001::/64 eui-64
 no fair-queue
 serial restart-delay 0
! 
router bgp 100
 bgp log-neighbor-changes
 neighbor 209.165.200.254 remote-as 100
 neighbor 209.165.200.254 update-source Loopback0
 !
 address-family ipv4
  no synchronization
  redistribute connected
  neighbor 209.165.200.254 activate
  no auto-summary
 exit-address-family
 !
 address-family vpnv4
  neighbor 209.165.200.254 activate
  neighbor 209.165.200.254 send-community both
  neighbor 209.165.200.254 route-map SELECT UPDATE FOR L3VPN in
 exit-address-family
 !
 address-family vpnv6
  neighbor 209.165.200.254 activate
  neighbor 209.165.200.254 send-community both
  neighbor 209.165.200.254 route-map SELECT UPDATE FOR L3VPN in
 exit-address-family
 !
 address-family ipv4 vrf Customer A
  no synchronization
  redistribute connected
 exit-address-family
 !
 address-family ipv6 vrf Customer A
  redistribute connected
  no synchronization
 exit-address-family
!
!
route-map SELECT UPDATE FOR L3VPN permit 10
set ip next-hop encapulate <profile_name>          
set ipv6 next-hop encapsulate <profile_name> 

Referencias adicionales

Para relacionado con la información adicional a los túneles dinámicos del mGRE L3 VPN, refiera a las referencias siguientes:

Documentos Relacionados

Tema relacionado

Título del documento

Configuración de VPNs de Capa 3 MPLS

Guía de Configuración de Multiprotocol Label Switching de Cisco IOS

MPLS VPN sobre el mGRE

Guía de configuración de la interfaz del Cisco IOS y del componente de hardware

Cisco Express Forwarding

Guía de configuración del Switching IP del Cisco IOS

Generic Routing Encapsulation

Guía de configuración de la interfaz del Cisco IOS y del componente de hardware

Estándares

Estándar

Título

Ninguno

--

MIB

MIB

Link del MIB

IETF-PPVPN-MPLS-VPN-MIB

Para localizar y descargar MIB de plataformas, versiones de Cisco IOS y conjuntos de funciones seleccionados, utilice Cisco MIB Locator, que se encuentra en la siguiente URL:

http://www.cisco.com/cisco/web/LA/support/index.html

RFC

RFC

Título

RFC 2547

BGP/MPLS VPN

RFC 2784

Generic Routing Encapsulation (GRE)

RFC 2890

Extensiones del número de la secuencia clave al GRE

RFC 4023

Encapsulado del MPLS en el IP o el Generic Routing Encapsulation

RFC 4364

Redes privadas virtuales (VPN) IP BGP/MPLS

Asistencia Técnica

Descripción

Link

El Web site del soporte y de la documentación de Cisco proporciona los recursos en línea para descargar la documentación, el software, y las herramientas. Utilice estos recursos para instalar y para configurar el software y para resolver problemas y para resolver los problemas técnicos con los Productos Cisco y las Tecnologías. El acceso a la mayoría de las herramientas en el Web site del soporte y de la documentación de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/LA/support/index.html

Ofrezca la información para L3 dinámico VPN con los túneles del mGRE

La tabla siguiente proporciona la información sobre la versión sobre la característica o las características descritas en este módulo. Esta tabla enumera solamente la versión de software que introdujo el soporte para una característica dada en un tren de versión de software dado. A menos que se indicare en forma diferente, las versiones posteriores de ese tren de versión de software también soportan esa característica.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Tabla 1Ofrezca la información para L3 dinámico VPN con los túneles del mGRE

Nombre de la función

Versiones

Información sobre la Función

Capa dinámica 3 VPN con los túneles GRE de múltiples puntos

12.0(23)S

Esta característica proporciona un mecanismo de transporte L3 basado en una tecnología de tunelización aumentada del mGRE para el uso en las redes IP.

Cisco y el logotipo de Cisco son marcas registradas o marcas registradas de Cisco y/o de sus afiliados en los E.E.U.U. y otros países. Para ver una lista de marcas registradas de Cisco, vaya a este URL: www.cisco.com/go/trademarks. Las marcas registradas de tercera persona mencionadas son la propiedad de sus propietarios respectivos. El uso de la palabra Partner no implica en una relación de sociedad entre Cisco y ninguna otra compañía. (1110R)

Las direcciones IP (Internet Protocol) y los números de teléfono utilizados en este documento no son direcciones y números de teléfono reales. Cualesquiera ejemplos, muestra de la salida de comandos, diagramas de topología de red y otras figuras incluidos en el documento se muestran solamente con fines ilustrativos. El uso de direcciones IP o números de teléfono reales en contenido ilustrativo es involuntario y fortuito.

Cisco Systems, Inc. del © 2011 todos los derechos reservados.