Guía de configuración de la interfaz y del componente de hardware, Cisco IOS Release 12.2SR
La tarifa basó el Control Protocol por satélite
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 245 KB | Inglés (13 Diciembre 2011) | Comentarios

La tarifa basó el Control Protocol por satélite

Última actualización: De diciembre el 12 de 2011

El Control Protocol por satélite basado tarifa (RBSCP) fue diseñado para la Tecnología inalámbrica o los links de larga distancia del retardo con los altos índices de error, tales como links satelitales. Usando los túneles, RBSCP puede mejorar el funcionamiento de ciertos protocolos IP, tales como TCP y seguridad IP (IPSec), sobre los links satelitales sin la fractura del modelo de punta a punta.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea la tabla de información de la característica en el extremo de este documento.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Las restricciones para la tarifa basaron el Control Protocol por satélite

  • RBSCP fue diseñado para la Tecnología inalámbrica o los links de larga distancia del retardo con los altos índices de error tales como links satelitales. Si usted no tiene de larga distancia el retardo conecta a los altos índices de error, no implementa esta característica.
  • Si las listas de IP Access (ACL) se configuran en una interfaz que sea utilizada por un túnel RBSCP, el RBSCP protocolo IP (199) se debe permitir ingresar y salir esa interfaz o el túnel no funcionará.
  • RBSCP tiene algunas limitaciones de rendimiento porque el tráfico a través del túnel es process-switched.

La información sobre la tarifa basó el Control Protocol por satélite

IP sobre los links satelitales

Los links satelitales tienen varias características que afecten al funcionamiento de los protocolos IP sobre el link. La figura abajo muestra que los links satelitales pueden tener un retraso unidireccional de 275 milisegundos. Un Round-Trip Time (RTT) de 550 milisegundos es mismo un retardo prolongado para el TCP. El Otro problema es los altos índices de error (tarifas de la pérdida del paquete) que son típicos de los links satelitales con respecto a los links atados con alambre en los LAN. Incluso el tiempo afecta a los links satelitales, causando una disminución del ancho de banda disponible, y un aumento en el RTT y la pérdida del paquete.

Figura 1Link satelital típico


El RTT largo mantiene el TCP un modo lento del comienzo, que aumenta el tiempo antes de que el ancho de banda del link satelital se utilice completamente. El TCP y el Stream Control Transmission Protocol (SCTP) interpretan los eventos de la pérdida del paquete como congestión en la red y comienzan a realizar los Procedimientos de recuperación de la congestión, que reducen el tráfico que es enviado sobre el link.

Aunque los anchos de banda disponibles del link satelital estén aumentando, el RTT y los altos índices de error largos experimentaron por los protocolos IP sobre los links satelitales están produciendo un alto producto de retraso de ancho de banda (BDP).

Proxy de aumento del funcionamiento sobre los links satelitales

Para abordar el problema del TCP que es mantenido un modo lento del comienzo cuando se utiliza un link satelital, un funcionamiento perturbador que aumenta la solución del proxy (PEP) se introduce en la red. En la figura debajo de usted puede ver que la conexión del transporte está quebrada para arriba en tres secciones con los hosts en el lado remoto que conecta con Internet a través de su router predeterminado. El router envía todo el tráfico del Internet-límite al TCP PEP, que termina la conexión TCP a Internet. El PEP genera un TCP local ACK (spoofing TCP) para todos los datos. El tráfico está mitigado y retransmitido a través de una sola conexión del protocolo PEP sobre el link satelital. El segundo PEP recibe los datos del link satelital y retransmite los datos sobre las conexiones TCP separadas a Internet. Se interrumpe la transmisión TCP, así que los paquetes perdidos no se interpretan como congestión TCP y se pueden retransmitir de los datos mitigados. El TCP mínimo ACK y comienzo lento reducido TCP permite que más ancho de banda sea utilizado.

Figura 2Solución perturbadora TCP PEP


Una de las desventajas a usar TCP perturbador PEP es la fractura del modelo de punta a punta. Algunas aplicaciones no pueden trabajar cuando el flujo de tráfico está quebrado, y el PEP no tiene ninguna disposición para manejar el tráfico encriptado (IPSec). Los nuevos protocolos de transporte tales como SCTP requieren la dirección del special o el código adicional para funcionar con TCP perturbador PEP. Un componente adicional de la red administrada también se requiere en cada router por satélite.

RBSCP sobre los links satelitales

RBSCP se ha diseñado para preservar el modelo de punta a punta y para proporcionar las mejoras del rendimiento sobre el link satelital sin usar una solución PEP. La encripción de IPSec del tráfico del texto claro (por ejemplo una configuración de servicio VPN) a través del link satelital se soporta. RBSCP permite que dos Routers controle y monitoree los índices de envío del link satelital, de tal modo aumentando el uso del ancho de banda. Los paquetes perdidos son retransmitidos sobre el link satelital por RBSCP que evita que los emisores TCP del host extremo entren el modo lento del comienzo.

RBSCP se implementa usando una interfaz del túnel tal y como se muestra en de la figura abajo. El túnel se puede configurar sobre cualquier interfaz de la red soportada por el Cisco IOS Software que se puede utilizar por un módem por satélite o un módulo de red del módem por satélite interno. El tráfico IP se envía a través del link satelital con las modificaciones y las mejoras apropiadas que son determinadas por la configuración del router. La encaminamiento estándar o el Policy-Based Routing se puede utilizar para determinar el tráfico que se enviará a través del túnel RBSCP.

Figura 3Solución no disruptiva RBSCP


Los túneles RBSCP se pueden configurar para un de los después de las características.

Retardo

Uno del Routers RBSCP se puede configurar para llevar a cabo las tramas debidas para la transmisión a través del túnel RBSCP. El tiempo de retraso aumenta el RTT en el host extremo y da un plazo del tiempo RBSCP para retransmitir las tramas perdidas TCP u otras tramas de protocolo. Si la retransmisión es acertada, evita que los eventos perdidos de la trama alcancen el host extremo donde los procedimientos de la congestión serían habilitados. La retransmisión se puede completar en algunos casos por RBSCP sin la inserción del retardo.

El partir ACK

Las mejoras del rendimiento se pueden llevar a cabo para el texto claro tráfico TCP usando el acuse de recibo (ACK) que parte en el cual vario TCP adicional los ACK se genera para cada TCP ACK recibido. El TCP abrirá una ventana de congestión por una Unidad máxima de transmisión (MTU) (MTU) para cada TCP ACK recibido. La apertura de la ventana de congestión da lugar al mayor ancho de banda que está disponible. Configure esta característica solamente cuando el link satelital no está utilizando todo el ancho de banda disponible. El tráfico encriptado no puede utilizar partir ACK.

Relleno de la ventana

El texto claro TCP y el tráfico SCTP pueden beneficiarse de la ventana RBSCP que rellena la característica. RBSCP puede mitigar el tráfico para poder incrementar la ventana de divulgación hasta el ancho de banda disponible del link satelital o la memoria disponible en el router. El host extremo que envía los paquetes se engaña en el pensamiento de que una ventana más grande existe en el host de extremo receptor y envía más tráfico. Utilice esta característica con cautela porque el host extremo puede enviar demasiado tráfico para que el link satelital dirija y la pérdida resultante y la retransmisión de los paquetes pueden causar la congestión de link.

El SCTP cae la información

El SCTP utiliza un método de cuenta apropiado del byte en vez del ACK que cuenta para determinar los tamaños de la ventana de la transmisión, así que el partir ACK no trabaja con el SCTP. El túnel RBSCP puede generar un informe paquete-caído SCTP para los paquetes caídos a través del satélite pero no como resultado de la pérdida de la congestión. Esta información del descenso SCTP está prendido por abandono y proporciona una ocasión de retransmitir el paquete sin afectar a los tamaños de la ventana de congestión. Las pérdidas reales de la congestión todavía están señaladas, y se activan los mecanismos de recuperación normales.

Cómo configurar la tarifa basó el Control Protocol por satélite

Configurar el túnel RBSCP

Realice esta tarea de configurar el túnel RBSCP. Recuerde configurar al router en cada extremo del túnel.

Antes de comenzar

Asegúrese de que la interfaz física que se utilizará como el origen de túnel en esta tarea esté configurada ya.


PASOS SUMARIOS

1. permiso

2. configuró terminal

3. número del tipo de la interfaz

4. interface-type interface-number innumerable del IP

5. origen de túnel {IP address | interface-type interface-number}

6. destino del túnel {nombre de host | IP address}

7. ancho de banda del túnel {reciba | transmita} el ancho de banda

8. modo túnel {aurp | caimán| dvmrp| eón| gre| gre de múltiples puntos| [decapsulate-any] del ipip| iptalk| mpls| no. | rbscp}

9. fractura-tamaños del ack_split del rbscp del túnel

10. retardo del rbscp del túnel

11 informe del rbscp del túnel

12.    tamaños del escalón del window_stuff del rbscp del túnel

13.    salida


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
número del tipo de la interfaz


Ejemplo:

Interface tunnel 0 de Router(config)#

 

Especifica el tipo de interfaz y el número y ingresa al modo de configuración de la interfaz.

 
Paso 4
interface-type interface-number innumerable del IP


Ejemplo:

Router (config-if) # Ethernet1 innumerable del IP

 

Permisos procesamiento de IP en una interfaz sin la asignación de un IP Address explícito.

  • Siempre que la interfaz sin numerar genere un paquete (por ejemplo, para una actualización de ruteo), utiliza el direccionamiento de la interfaz especificada como la dirección de origen del paquete del IP.
 
Paso 5
origen de túnel {IP address | interface-type interface-number}


Ejemplo:

Router (config-if) # Ethernet1 del origen de túnel

 

Configura el origen de túnel.

  • Utilice el IP-addressargument para especificar la dirección IP del proveedor de servicio.
  • Utilice la interfaz-numberarguments de la interfaz-typeand para especificar la interfaz para utilizar. Para RBSCP recomendamos el especificar de una interfaz como el origen de túnel.
 
Paso 6
destino del túnel {nombre de host | IP address}


Ejemplo:

Router (config-if) # destino del túnel 172.17.2.1

 

Configura el destino del túnel.

  • Utilice el hostnameargument para especificar la dirección IP del proveedor de servicio.
  • Utilice el IP-addressargument para especificar la interfaz para utilizar.
 
Paso 7
ancho de banda del túnel {reciba | transmita} el ancho de banda


Ejemplo:

El router (config-if) # ancho de banda del túnel transmite 1000

 

Especifica el ancho de banda del túnel que se utilizará para transmitir los paquetes.

  • Utilice el bandwidthargument para especificar el ancho de banda.
Nota    La palabra clave de la recepción es no se utilizan más.
 
Paso 8
modo túnel {aurp | caimán| dvmrp| eón| gre| gre de múltiples puntos| [decapsulate-any] del ipip| iptalk| mpls| no. | rbscp}


Ejemplo:

Router (config-if) # rbscp del modo túnel

 

Especifica el protocolo que se utilizará en el túnel.

  • Utilice la palabra clave rbscp para especificar que RBSCP se utilizará como protocolo de túnel.
 
Paso 9
fractura-tamaños del ack_split del rbscp del túnel


Ejemplo:

Router (config-if) # ack_split 6 del rbscp del túnel

 

Reconocimiento de TCP (opcional) de los permisos (ACK) que parte con los túneles RBSCP.

  • Utilice el argumento split-size para especificar el número de ACKs que se enviarán por cada ACK recibido.
  • El número predeterminado de ACK es 4.
 
Paso 10
retardo del rbscp del túnel


Ejemplo:

Router (config-if) # retardo del rbscp del túnel

 

Retardo (opcional) del túnel de los permisos RBSCP.

  • Utilice este comando solamente cuando el RTT es mayor de 700 milisegundos.
 
Paso 11
informe del rbscp del túnel


Ejemplo:

Router (config-if) # informe del rbscp del túnel

 

Los informes (opcionales) cayeron los paquetes RBSCP al SCTP.

  • Señalar los paquetes perdidos al SCTP proporciona un mejor uso del ancho de banda porque el SCTP dice los host extremos retransmitir los paquetes perdidos y éste evita que los host extremos si se asume que la red está congestionada.
 
Paso 12
tamaños del escalón del window_stuff del rbscp del túnel


Ejemplo:

Router (config-if) # window_stuff 3 del rbscp del túnel

 

Ventana TCP (opcional) de los permisos que rellena aumentando el valor de la escala de la ventana TCP para los túneles RBSCP.

  • Use el argumento step-size para especificar el número de incremento del paso.
 
Paso 13
salida


Ejemplo:

Router(config-if)# exit

 

Salidas modo de configuración de la interfaz y devoluciones al modo de configuración global.

  • Relance esto paso uno más hora de dar salida al modo de configuración global.
 

Pasos Siguientes

Esta tarea se debe relanzar en el router en el otro lado del link satelital. Substituya los IP Addresses de la muestra, los nombres del host, y otros parámetros para los valores apropiados en el segundo router.

El verificar que el túnel RBSCP sea activo

Realice esta tarea de verificar que el túnel RBSCP configurado en configurar la tarea del túnel RBSCP es activo.

PASOS SUMARIOS

1. permiso

2. muestre el rbscp [todo| estado| [tunnel tunnel-number] de las estadísticas]

3. salida


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
muestre el rbscp [todo| estado| [tunnel tunnel-number] de las estadísticas]


Ejemplo:

Túnel 1 del estado del rbscp de la demostración del Router-

 

Utilice este comando con el estado y los tunnelkeywords al mostrar información sobre el estado actual del túnel. En la salida de muestra siguiente el túnel se muestra en un estado abierto. Todos los contadores muestran los totales acumulados desde la última ejecución del comando clear rbscp.

 
Paso 3
salida


Ejemplo:

Salida de Router>#

 

Las salidas priviliged al modo de configuración del EXEC.

 

Verificar el tráfico RBSCP

Realice esta tarea de verificar que el tráfico se está transmitiendo a través del túnel RBSCP y a través del link satelital.

PASOS SUMARIOS

1. permiso

2. show interfaces tunnel number [estadísticas

3. salida


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
show interfaces tunnel number [estadísticas


Ejemplo:

Show interfaces tunnel 0 del Router-

 

Utilice este comando de mostrar que el tráfico se está transmitiendo a través del túnel RBSCP.

 
Paso 3
salida


Ejemplo:

Salida de Router>#

 

Las salidas priviliged al modo de configuración del EXEC.

 

Los ejemplos de configuración para la tarifa basaron el Control Protocol por satélite

Configurar el ejemplo del túnel RBSCP

En el siguiente ejemplo, el router1 y el router2 se configuran para enviar el tráfico a través de un túnel RBSCP sobre un link satelital.

Router 1

interface Tunnel 0
 ip unnumbered ethernet1
 tunnel source ethernet1
 tunnel destination 172.17.2.1
 tunnel bandwidth transmit 1000
 tunnel mode rbscp
 tunnel rbscp ack_split 6
 tunnel rbscp report
!
interface ethernet1
 description Satellite Link
 ip address 172.20.1.2 255.255.255.0

Router 2

interface Tunnel 0
 ip unnumbered ethernet1
 tunnel source ethernet1
 tunnel destination 172.20.1.2
 tunnel bandwidth transmit 1000
 tunnel mode rbscp
 tunnel rbscp ack_split 6
 tunnel rbscp report
!
interface ethernet1
 description Satellite Link
 ip address 172.17.2.1 255.255.255.0

Configurar la encaminamiento por el ejemplo del túnel RBSCP

Para controlar el tipo de tráfico que utiliza el túnel RBSCP, usted debe configurar la encaminamiento apropiada. Si usted quiere dirigir todo el tráfico a través del túnel, usted puede configurar una Static ruta.


Nota


Recuerde configurar la interfaz del túnel mientras que voz pasiva si los Dynamic Routing Protocol se utilizan para evitar el rutear de las aletas.

El siguiente ejemplo muestra cómo utilizar la encaminamiento basada directiva para rutear algunos Tipos de protocolo específicos a través del túnel. En este ejemplo, una lista de acceso ampliada permite que el TCP, el protocolo del Stream Control Transmission Protocol (SCTP), del Encapsulating Security Payload (ESP), y el tráfico del Encabezado de autenticación viajen a través del túnel. Se niega todo el tráfico IP.

Router1 (lado local)

interface Tunnel1
 ip unnumbered FastEthernet1/1
 tunnel source FastEthernet1/1
 tunnel destination 10.12.0.20
 tunnel mode rbscp
 tunnel ttl 5
 tunnel bandwidth transmit 30000
 tunnel rbscp window_stuff 1
 tunnel rbscp ack_split 4
!
interface FastEthernet0/0
 ip address 10.13.0.1 255.255.255.0
 ip policy route-map rbscp-pbr
 duplex auto
 speed auto
!
interface FastEthernet1/1
 description Satellite Link
 ip address 10.12.0.1 255.255.255.0
 duplex auto
 speed auto
!
ip route 10.15.0.0 255.255.255.0 FastEthernet1/1
!
ip access-list extended rbscp-acl
 permit tcp any 10.15.0.0 0.0.0.255
 permit 132 any 10.15.0.0 0.0.0.255
 permit esp any 10.15.0.0 0.0.0.255
 permit ahp any 10.15.0.0 0.0.0.255
 deny ip any any
!
!
route-map rbscp-pbr permit 10
 match ip address rbscp-acl
 set interface Tunnel1

Router2 (lado remoto)

ip dhcp pool CLIENT
 import all
 network 10.15.0.0 255.255.255.0
 default-router 10.15.0.1
 domain-name engineer.chicago.il.us
 dns-server 10.10.0.252
!
interface Tunnel1
 ip unnumbered FastEthernet0/1
 tunnel source FastEthernet0/1
 tunnel destination 10.12.0.1
 tunnel mode rbscp
 tunnel ttl 5
 tunnel bandwidth transmit 30000
 tunnel rbscp window_stuff 1
 tunnel rbscp ack_split 4
!
interface FastEthernet0/0
 description Local LAN
 ip address 10.15.0.1 255.255.255.0
 ip policy route-map rbscp-pbr
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description Satellite Link
 ip address 10.12.0.20 255.255.255.0
 duplex auto
 speed auto
!
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
!
ip access-list extended rbscp-acl
 permit tcp any any
 permit 132 any any
 permit esp any any
 permit ahp any any
 deny ip any any
!
route-map rbscp-pbr permit 10
 match ip address rbscp-acl
 set interface Tunnel1

Referencias adicionales

Documentos Relacionados

Tema relacionado

Título del documento

Comandos de la interfaz del túnel: sintaxis, modo de comando, valores por defecto, Pautas para el uso, y ejemplos del comando complete

Referencia de comandos de la interfaz del Cisco IOS y del componente de hardware

Configuración del túnel

Guía de configuración de la interfaz del Cisco IOS y del componente de hardware

Estándares

Estándares

Título

Esta función no soporta estándares nuevos o modificados, y el soporte de los estándares existentes no ha sido modificado por ella.

--

MIB

MIB

Link del MIB

Esta función no soporta MIBs nuevas o modificadas, y el soporte para las MIBs existentes no ha sido modificado por esta función.

Para localizar y descargar MIB de plataformas, versiones de Cisco IOS y conjuntos de funciones seleccionados, utilice Cisco MIB Locator, que se encuentra en la siguiente URL:

http://www.cisco.com/cisco/web/LA/support/index.html

RFC

RFC

Título

RFC 1323

Extensiones TCP para el rendimiento alto

RFC 2018

Opciones del acuse de recibo selectivo TCP

Asistencia Técnica

Descripción

Link

Página de inicio del Centro de Asistencia Técnica (TAC), que contiene 30.000 páginas de contenido técnico que permite la búsqueda, incluyendo links a productos, tecnologías, soluciones, consejos técnicos y herramientas. Los usuarios registrados de cisco.com pueden iniciar sesión desde esta página para acceder a otros contenidos.

http://www.cisco.com/cisco/web/LA/support/index.html

La información de la característica para la tarifa basó el Control Protocol por satélite

La tabla siguiente proporciona la información sobre la versión sobre la característica o las características descritas en este módulo. Esta tabla enumera solamente la versión de software que introdujo el soporte para una característica dada en un tren de versión de software dado. A menos que se indicare en forma diferente, las versiones posteriores de ese tren de versión de software también soportan esa característica.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Tabla 1Información de la característica para el átomo NSF cualquier transporte sobre el MPLS y el graceful restart del átomo

Nombre de la función

Versiones

Información sobre la Función

La tarifa basó el Control Protocol por satélite

12.3(7)T

Esta función fue introducida.

Se han insertado o modificado los siguientes comandos:

borre el rbscp, haga el debug del rbscp del túnel, rbscp de la demostración, ancho de banda del túnel, modo túnel, ack_split del rbscp del túnel, retardo del rbscp del túnel, input_drop del rbscp del túnel, long_drop del rbscp del túnel, informe del rbscp del túnel, rbscp del túnel, window_stuff.

Cisco y el logotipo de Cisco son marcas registradas o marcas registradas de Cisco y/o de sus afiliados en los E.E.U.U. y otros países. Para ver una lista de marcas registradas de Cisco, vaya a este URL: www.cisco.com/go/trademarks. Las marcas registradas de tercera persona mencionadas son la propiedad de sus propietarios respectivos. El uso de la palabra Partner no implica en una relación de sociedad entre Cisco y ninguna otra compañía. (1110R)

Las direcciones IP (Internet Protocol) y los números de teléfono utilizados en este documento no son direcciones y números de teléfono reales. Cualesquiera ejemplos, muestra de la salida de comandos, diagramas de topología de red y otras figuras incluidos en el documento se muestran solamente con fines ilustrativos. El uso de direcciones IP o números de teléfono reales en contenido ilustrativo es involuntario y fortuito.

Cisco Systems, Inc. del © 2011 todos los derechos reservados.