Routing IP: Guía de configuración de RIP, Cisco IOS Release 12.2SR
Configuración de Routing Information Protocol
2 Agosto 2013 - Traducción Automática | Otras Versiones: PDFpdf 286 KB | Inglés (26 Octubre 2011) | Comentarios

Contenido

Configuración de Routing Information Protocol

Última actualización: De octubre el 26 de 2011

El Routing Information Protocol (RIP) es un Routing Protocol de uso general en las redes pequeñas-medias TCP/IP. Es un protocolo estable que utiliza un algoritmo del vector de distancia para calcular las rutas.

Encontrar la información de la característica

Su versión de software puede no soportar todas las características documentadas en este módulo. Para la últimas información y advertencias de la característica, vea los Release Note para su plataforma y versión de software. Para encontrar la información sobre las características documentadas en este módulo, y ver una lista de las versiones en las cuales se soporta cada característica, vea la tabla de información de la característica en el extremo de este documento.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Requisitos previos para configurar el RIP

Antes de configurar el RIP, configuran al comando ip routing. Para más información sobre configurar el comando ip routing, vea el Routing IP del Cisco IOS: RASGUE la referencia de comandos.

Restricciones para configurar el RIP

El métrico que RASGA las aplicaciones de valorar el valor de diversas rutas es conteo saltos. El conteo saltos es el número de Routers que pueda ser atravesado en una ruta. Una red conectada tiene directamente un métrico de cero; una red inalcanzable tiene un métrico de 16. Este pequeño rango de la métrica hace RIP un Routing Protocol inadecuado para las Redes grandes.

Información sobre configurar el RIP

Descripción del RIP

El Routing Information Protocol utiliza los paquetes de datos del User Datagram Protocol (UDP) del broadcast para intercambiar la información de ruteo. El Cisco IOS Software envía la información de ruteo pone al día cada 30 segundos, que se llama publicidad. Si un router no recibe una actualización de otro router para 180 segundos o más, marca las rutas servidas por el router nonupdating como estando inutilizable. Si todavía no hay actualización después de 240 segundos, el router quita todas las entradas de la tabla de ruteo para el router nonupdating.

Un router que está ejecutando el RIP puede recibir una red predeterminada vía una actualización de otro router que esté ejecutando el RIP, o al router puede fuente (genere) la red predeterminada sí mismo con el RIP. En ambos casos, la red predeterminada se hace publicidad con el RIP a otros vecinos del RIP.

La implementación de Cisco de la versión de RIP 2 soporta el sólo texto y autenticación, resumen de Route, Classless Interdomain Routing (CIDR), y las máscaras de subred de longitud variable de la publicación de mensaje 5 (MD5) (VLS).

Actualizaciones de RIP Routing

El RIP envía los mensajes de actualización de ruteo a intervalos regulares y cuando los cambios de la topología de red. Cuando un router recibe una actualización de RIP Routing que incluya los cambios a una entrada, el router pone al día su tabla de ruteo para reflejar la nueva ruta. El valor métrico para la trayectoria es aumentado en 1, y el remitente se indica como el salto siguiente. El Routers del RIP mantiene solamente la mejor ruta (la ruta con el valor métrico más bajo) a un destino. Después de poner al día su tabla de ruteo, el router comienza inmediatamente a transmitir las actualizaciones de RIP Routing para informar a otros routeres de la red el cambio. Estas actualizaciones se envían independientemente de las actualizaciones regularmente programadas que RASGAN al Routers envían.

Métrica de ruteo del RIP

El RIP utiliza una sola métrica de ruteo (conteo saltos) para medir la distancia entre la fuente y una red de destino. Cada salto en una trayectoria de la fuente al destino se asigna un valor de conteo saltos, que es típicamente 1. Cuando un router recibe una actualización de ruteo que contenga una nueva o cambiada entrada de la red de destino, el router agrega 1 al valor métrico indicado en la actualización y ingresa la red en la tabla de ruteo. La dirección IP del remitente se utiliza como el salto siguiente. Si la red de una red de la interfaz no se especifica, no será hecha publicidad en ninguna actualización del RIP.

Versión de RIP 2 y habilitar la autenticación

La implementación de Cisco de la versión de RIP 2 soporta la autenticación, la administración de claves, el resumen de Route, el CIDR, y los VLS. Para más información sobre los manejos de las claves de autenticación ven “manejo la sección de las claves de autenticación” el “configurar del módulo de la característica IP Routing Protocol-Independent”.

Por abandono, el software recibe los paquetes de la versión de RIP 1 y de la versión 2, pero envía solamente los paquetes de la versión 1. Usted puede configurar el software para recibir y para enviar solamente los paquetes de la versión 1. Alternativamente, usted puede configurar el software para recibir y para enviar solamente los paquetes de la versión 2. Para reemplazar el comportamiento predeterminado, usted puede configurar que la versión de RIP una interfaz envía. Semejantemente, usted puede también controlar cómo los paquetes recibidos de una interfaz se procesan.

La versión de RIP 1 no soporta la autenticación. Si usted es de envío y de recepción de la versión de RIP 2 paquetes, usted puede habilitar la autenticación del RIP en una interfaz.

El encadenamiento dominante determina el conjunto de las claves que se pueden utilizar en la interfaz. Si un llavero no se configura, no se realiza ninguna autenticación en esa interfaz, ni siquiera la autenticación predeterminada. Por lo tanto, usted debe también realizar las tareas en la sección “manejo de las claves de autenticación” en de las “que configura el módulo características IP Routing Protocol-Independent”.

Apoyamos a dos modos de autenticación en una interfaz para la cual se habilite la autenticación del RIP: autenticación de texto únicamente y autenticación de MD5. La autenticación predeterminada en cada paquete de la versión de RIP 2 es autenticación de texto únicamente.


Nota


No utilice el autenticación de texto únicamente en los paquetes RIP por motivos de seguridad, porque la clave de autenticación unencrypted se envía en cada paquete de la versión de RIP 2. Utilice el autenticación de texto únicamente cuando la Seguridad no es un problema, por ejemplo, asegurarse de que los hosts mal configurado no participan en la encaminamiento.

Intercambio de la información de ruteo

El RIP es normalmente un protocolo del broadcast, y para que las actualizaciones de RIP Routing alcancen las redes del nonbroadcast, usted debe configurar el Cisco IOS Software para permitir este intercambio de la información de ruteo.

Para controlar el conjunto de las interfaces por las cuales usted quiere intercambiar las actualizaciones de ruteo, usted puede inhabilitar el envío de las actualizaciones de ruteo en las interfaces especificadas configurando el comando router configuration de la pasivo-interfaz. Vea la discusión sobre la filtración en “la sección de la información de ruteo del filtro” en de las “que configura el módulo características IP Routing Protocol-Independent”.

Una lista del desplazamiento es el mecanismo para aumentar la métrica entrante y saliente a las rutas aprendidas vía el RIP. Opcionalmente, puede limitar la lista del desplazamiento con una lista de acceso o una interfaz. Para aumentar el valor de las métricas de ruteo, utilice el siguiente comando en el modo de configuración del router:

Los Routing Protocol utilizan varios temporizadores que determinen las variables tales como la frecuencia de las actualizaciones de ruteo, la longitud del tiempo antes de que una ruta llegue a ser inválida, y otros parámetros. Usted puede ajustar estos temporizadores para ajustar el funcionamiento del Routing Protocol para adaptarse mejor a sus necesidades de la red interna. Usted puede hacer los ajustes del temporizador siguientes:

  • La tarifa (tiempo en los segundos entre las actualizaciones) en la cual se envían las actualizaciones de ruteo
  • El intervalo del tiempo (en los segundos) después de lo cual de una ruta es inválido declarado
  • El intervalo (en los segundos) durante los cuales la información de ruteo con respecto a mejores trayectorias se suprime
  • La cantidad de tiempo (en los segundos) que debe pasar antes de que una ruta se quite de la tabla de ruteo
  • La cantidad de tiempo para la cual las actualizaciones de ruteo serán pospuestas

También es posible ajustar el soporte de IP Routing en el software para habilitar una convergencia más rápida de los diversos algoritmos del Routing IP, y, por lo tanto, un retraso más rápido a los routeres redundantes. El efecto total es minimizar las interrupciones a los usuarios finales de la red en las situaciones donde está esencial la recuperación rápida

Además, una familia del direccionamiento puede haber especificado explícitamente los temporizadores que se aplican a esa direccionamiento-familia (o al VRF) solamente. El comando timers basic debe ser especificado para una familia del direccionamiento o los valores predeterminados del sistema para el comando timers basic se utilizan sin importar qué se configura para rutear del RIP. El VRF no hereda los valores del temporizador de la configuración de RIP baja. El VRF utilizará siempre los temporizadores del valor predeterminado del sistema a menos que esté cambiado explícitamente usando el comando timers basic.

Vea “la sección del ejemplo de los temporizadores de la familia del direccionamiento” en el final de este capítulo por ejemplos del ajuste de los temporizadores según una familia del direccionamiento (VRF).

Resumen del RIP Route

Resumir las rutas en la versión de RIP 2 mejora el scalability y la eficacia en las Redes grandes. Resumir los IP Addresses significa que no hay entrada para las rutas del niño (rutas que se crean para cualquier combinación de los IP Addresses individuales contenidos dentro de una dirección de resumen) en la tabla de ruteo del RIP, reduciendo los tamaños de la tabla y de permitir que el router maneje más rutas.

La dirección IP sumaria funciona más eficientemente que las rutas de IP individualmente des divulgación del múltiplo por las razones siguientes:

  • Las rutas resumidas en las bases de datos de RIP se procesan primero.
  • Se salta cualquier ruta asociada del niño que se incluya en una ruta resumida como el RIP mira a través de las bases de datos de ruteo, reduciendo el tiempo de procesamiento requerido. Los routeres Cisco pueden resumir las rutas en dos maneras:
  • Automáticamente, resumiendo los subprefixes al límite de la red classful al cruzar los límites de la red classful (resumen automático).

Nota


El resumen automático se habilita por abandono.
  • Según lo configurado específicamente, haciendo publicidad de un pool resumido del IP Address local en la interfaz especificada (en un servidor de acceso a la red) para poder proporcionar la agrupación de direcciones a los clientes de marcación manuales.

Cuando el RIP determina que requieren a una dirección de resumen en las bases de datos de RIP, una entrada sumaria se crea en las bases de datos de ruteo del RIP. Mientras haya rutas del niño para una dirección de resumen, sigue habiendo el direccionamiento en las bases de datos de ruteo. Cuando se quita la ruta más reciente del niño, la entrada sumaria también se quita de la base de datos. Este método de manejar las entradas de la base de datos reduce el número de entradas en la base de datos porque cada ruta del niño no se enumera en una entrada, y se quita la entrada global sí mismo cuando hay no más cualquier ruta válida del niño para ella.

El resumen de Route de la versión de RIP 2 requiere que el métrico métrico de la “mejor ruta” de una entrada agregada, o más bajo más bajo de todas las rutas actuales del niño, esté hecho publicidad. El mejor métrico para las rutas resumidas agregadas se calcula en la inicialización de la ruta o cuando hay modificaciones métricas de las rutas específicas en el tiempo del anuncio, y no cuando las rutas agregadas se hace publicidad.

El comando del routerconfiguration del RIP del resumen-direccionamiento del IP hace al router resumir un conjunto dado de las rutas aprendidas vía la versión de RIP 2 o redistribuido en las rutas del host de la versión de RIP 2. sea especialmente aplicable para el resumen.

Vea “la sección del ejemplo del resumen de Route” en el final de este capítulo por ejemplos de usar el horizonte partido.

Usted puede verificar que las rutas se resumen para una interfaz usando el comando exec de los protocolos del IP de la demostración. Usted puede marcar las entradas de la dirección de resumen en las bases de datos de RIP. Estas entradas aparecerán en la base de datos solamente si se están resumiendo las rutas relevantes del niño. Para visualizar las entradas de la dirección de resumen en las entradas de las bases de datos de ruteo del RIP si hay rutas relevantes que son resumidas basadas sobre una dirección de resumen, utilice el comando show ip rip database en el modo EXEC. Cuando la ruta más reciente del niño para una dirección de resumen llega a ser inválida, quitan a la dirección de resumen también de la tabla de ruteo.

Mecanismo partido del horizonte

Normalmente, el Routers que están conectados con las redes IP del tipo de broadcast y que utiliza los Routing Protocol del vector de distancia emplea el mecanismo del horizonte de la fractura para reducir la posibilidad de los loopes de la encaminamiento. Información de bloques partida del horizonte sobre las rutas de la publicidad por un router fuera de cualquier interfaz de la cual esa información originara. Este comportamiento optimiza generalmente las comunicaciones entre los routeres múltiples, determinado cuando los links están quebrados. Sin embargo, con las redes del nonbroadcast (tales como Frame Relay y [SMDS] conmutado del sistema digital Multimegabit), las situaciones pueden presentarse para cuál es este comportamiento menos que el ideal. Para estas situaciones, usted puede querer inhabilitar el horizonte partido con el RIP.

Si una interfaz se configura con las driección IP secundarias y horizonte se habilita de la fractura, las actualizaciones no pudieron ser originadas por la dirección secundaria. Una actualización de ruteo es originada por el network number a menos que se inhabilite el horizonte de la fractura.

Retardo de Interpacket para las actualizaciones del RIP

Por abandono, el software no agrega ningún retardo entre los paquetes en una actualización del RIP del paquete múltiple que es enviada. Si usted tiene un router de mayor capacidad que envía a un router de poca velocidad, usted puede ser que quiera agregar tal retardo del interpacket PARA RASGAR las actualizaciones, en el rango de 8 a 50 milisegundos.

Optimización del RIP sobre los circuitos PÁLIDOS

Utilizan al Routers en las redes orientadas a la conexión para permitir la Conectividad potencial a muchos destinos remotos. Los circuitos en WAN se establecen a pedido y se abandonan cuando se desploma el tráfico. Dependiendo de la aplicación, la conexión entre cualquier dos sitios para los datos del usuario podía ser corta y relativamente infrecuente.

Dirección IP de origen

Por abandono, el software valida la dirección IP de origen de las actualizaciones de RIP Routing entrantes. Si esa dirección de origen es inválida, el software desecha la actualización de ruteo. Usted puede ser que quiera inhabilitar esta característica si usted tiene un router que esté “de red” y usted quiere recibir sus actualizaciones. Sin embargo, inhabilitar esta característica no se recomienda en circunstancias normales.

Autenticación del Router Vecino

Usted puede evitar que su router reciba las actualizaciones fraudulentas de la ruta configurando la autenticación del router vecino. Cuando está configurada, la autenticación de vecino ocurre siempre que las actualizaciones de ruteo se intercambien entre los routeres vecinos. Esta autenticación se asegura de que un router reciba la información de ruteo confiable de una fuente confiable.

Sin las actualizaciones de ruteo desautorizadas o deliberadamente malévolas de la autenticación de vecino, podía comprometer la Seguridad de su tráfico de la red. Un compromiso de la Seguridad podría ocurrir si un partido hostil desvía o analiza su tráfico de la red. Por ejemplo, un router desautorizado podría enviar una actualización de ruteo ficticia para convencer a su router enviar el tráfico a un destino incorrecto. Este tráfico desviado se podía analizar para aprender la información confidencial sobre su organización o utilizar simplemente para interrumpir la capacidad de su organización de comunicar con eficacia usando la red. La autenticación de vecino evita que tales actualizaciones fraudulentas de la ruta sean recibidas por su router.

Cuando la autenticación de vecino se ha configurado en un router, el router autentica la fuente de cada paquete de actualización de ruteo que recibe. Esto es lograda por el intercambio de una clave de autenticidad (designada a veces una contraseña) que se sepa al router de envío y de recepción.

Hay dos tipos de autenticación de vecino usados: autenticación de texto únicamente y autenticación de la versión 5 del algoritmo condensado de mensaje (MD5). Ambas formas trabajan de la misma manera, con excepción del hecho que el MD5 envía una “publicación de mensaje” en vez de la clave de autenticidad sí mismo. La publicación de mensaje se crea usando la clave y un mensaje, pero la clave sí mismo no se envía, evitando que sea leído mientras que se está transmitiendo. El autenticación de texto únicamente envía la clave de autenticidad sí mismo sobre el alambre.


Nota


Observe que el autenticación de texto únicamente no está recomendado para el uso como parte de su estrategia de la Seguridad. Su uso primario es evitar los cambios accidentales a la infraestructura de ruteo. El usar autenticación de MD5, sin embargo, es una práctica recomendada de la Seguridad.

En el autenticación de texto únicamente, cada router vecino participante debe compartir una clave de autenticidad. Esta clave se especifica en cada router durante la configuración. Las claves múltiples se pueden especificar con algunos protocolos; cada clave se debe entonces identificar por un número dominante.

Generalmente cuando se envía una actualización de ruteo, la secuencia siguiente de la autenticación ocurre:

  1. Un router envía una actualización de ruteo con una clave y el número dominante correspondiente al router vecino. En los protocolos que pueden tener solamente una clave, el número dominante es siempre cero. El router (vecino) de recepción marca la clave recibida contra la misma clave salvada en su propia memoria.
  2. Si las dos claves hacen juego, el router de recepción valida el paquete de actualización de ruteo. Si las dos claves no hacen juego, se rechaza el paquete de actualización de ruteo.

Autenticación de MD5 trabaja semejantemente al autenticación de texto únicamente, salvo que la clave nunca se envía sobre el alambre. En lugar, el router utiliza el algoritmo MD5 para presentar una “publicación de mensaje” de la clave (también llamada un “hash”). La publicación de mensaje entonces se envía en vez de la clave sí mismo. Esto se asegura de que nadie pueda escuchar detras de las puertas en la línea y aprender las claves durante la transmisión.

Otra forma de autenticación del router vecino es configurar la administración de claves usando los llaveros. Cuando usted configura un llavero, usted especifica una serie de claves con los cursos de la vida, y el Cisco IOS Software gira con cada uno de estas claves. Esto disminuye la probabilidad que las claves serán comprometidas. Para encontrar la información de la configuración completa para los llaveros, refiera “manejo a la sección de las claves de autenticación” en el módulo IP Routing Protocol-Independent de las características que configura del Routing IP del Cisco IOS: Guía de configuración del protocolo independiente.

Comienzo del retardo IP-RIP

La característica del comienzo del retardo IP-RIP se utiliza en los routeres Cisco para retrasar el lanzamiento de las sesiones vecinas del RIPv2 hasta que la conectividad de red entre los routeres vecinos esté completamente - operativas, de tal modo asegurándose de que el número de secuencia del primer paquete MD5 que el router envía al no Cisco el router vecino es 0. El comportamiento predeterminado para un router configurado para establecer a las sesiones vecinas del RIPv2 con un router vecino usando autenticación de MD5 es comenzar a enviar los paquetes MD5 cuando la interfaz física está para arriba.

La característica del comienzo del retardo IP-RIP es de uso frecuente cuando configuran a un router Cisco para establecer una relación de vecino del RIPv2 usando autenticación de MD5 con a dispositivo no Cisco sobre una red Frame Relay. Cuando los vecinos del RIPv2 están conectados sobre el Frame Relay, es posible para la interfaz serial conectada con la red Frame Relay para estar para arriba mientras que los circuitos de Frame Relay subyacentes no están todavía listos para transmitir y para recibir los datos. Cuando una interfaz serial es ascendente y los circuitos de Frame Relay no son todavía operativos, cualquier paquetes MD5 que las tentativas del router de transmitir sobre la interfaz serial se caigan. Cuando se caen los paquetes MD5 porque los circuitos de Frame Relay sobre los cuales los paquetes necesitan ser transmitidos no son todavía operativos, el número de secuencia del primer paquete MD5 recibido por el router vecino después de que los circuitos de Frame Relay lleguen a ser activos serán mayores de 0. Algunos routeres no perteneciente a Cisco no permitirán que una sesión vecina del RIPv2 MD5-authenticated comience cuando el número de secuencia del primer paquete MD5 recibido del otro router es mayor de 0.

Las diferencias en las instrumentaciones de vendedor de autenticación de MD5 para el RIPv2 son probablemente un resultado de la ambigüedad del RFC relevante (RFC 2082) en lo que respecta a la pérdida del paquete. El RFC 2082 sugiere que el Routers esté listo para validar un número de secuencia de 0 o un número de secuencia más alto que el número de secuencia más reciente recibido. Para más información sobre la recepción del mensaje MD5 para el RIPv2, vea la sección 3.2.2 del RFC 2082 en el URL siguiente: http://www.ietf.org/rfc/rfc2082.txt.

Offset-list

Una lista del desplazamiento es el mecanismo para aumentar la métrica entrante y saliente a las rutas aprendidas vía el RIP. Esto se hace para proporcionar un mecanismo local para aumentar el valor de las métricas de ruteo. Opcionalmente, puede limitar la lista del desplazamiento con una lista de acceso o una interfaz.

Cronómetros

Los Routing Protocol utilizan varios temporizadores que determinen las variables tales como la frecuencia de las actualizaciones de ruteo, la longitud del tiempo antes de que una ruta llegue a ser inválida, y otros parámetros. Usted puede ajustar estos temporizadores para ajustar el funcionamiento del Routing Protocol para adaptarse mejor a sus necesidades de la red interna. Usted puede hacer los ajustes del temporizador siguientes:

  • La tarifa (tiempo en los segundos entre las actualizaciones) en la cual se envían las actualizaciones de ruteo
  • El intervalo del tiempo (en los segundos) después de lo cual de una ruta es inválido declarado
  • El intervalo (en los segundos) durante los cuales la información de ruteo con respecto a mejores trayectorias se suprime
  • La cantidad de tiempo (en los segundos) que debe pasar antes de que una ruta se quite de la tabla de ruteo
  • La cantidad de tiempo para la cual las actualizaciones de ruteo serán pospuestas

También es posible ajustar el soporte de IP Routing en el software para habilitar una convergencia más rápida de los diversos algoritmos del Routing IP, y, por lo tanto, un retraso más rápido a los routeres redundantes. El efecto total es minimizar las interrupciones a los usuarios finales de la red en las situaciones donde está esencial la recuperación rápida.

Cómo configurar el RIP

Habilitando el RIP y configurar los parámetros del RIP

Realice los pasos en esta sección para habilitar el RIP y para configurar los parámetros del RIP.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. RIP del router

4. IP Address de red

5. neighbor ip-address

6. offset-list [access-list-number | acceso-lista-nombre] {en | hacia fuera} compense el [interface-type interface-number]

7. [sleeptime] inválido del rubor del asentamiento de la actualización de los temporizadores básicos

8. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
RIP del router


Ejemplo:

RIP del router de Router(config)#

 

Habilita un proceso de ruteo del RIP y ingresa al modo de configuración del router.

 
Paso 4
IP Address de red


Ejemplo:

Router (config-router) # red 10.1.1.0

 

Asocia una red a un proceso de ruteo del RIP.

 
Paso 5
neighbor ip-address


Ejemplo:

Router (config-router) # vecino 1.1.1.2

 

Define un router de la vencidad con el cual intercambiar la información de ruteo.

 
Paso 6
offset-list [access-list-number | acceso-lista-nombre] {en | hacia fuera} compense el [interface-type interface-number]


Ejemplo:

Router (config-router) # offset-list 98 en 1 Ethernet 1/0

 

(Opcional) aplica un desplazamiento a las métricas de ruteo.

 
Paso 7
[sleeptime] inválido del rubor del asentamiento de la actualización de los temporizadores básicos


Ejemplo:

Router (config-router) # temporizadores básicos 1 2 3 4

 

(Opcional) ajusta los temporizadores del Routing Protocol.

 
Paso 8
Finalizar


Ejemplo:

Router (config-router) # extremo

 

Sale del modo de configuración del router y vuelve al modo EXEC privilegiado.

 

Especificando una versión de RIP y habilitar la autenticación

Realice esta tarea de especificar una versión de RIP y de habilitar la autenticación.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. RIP del router

4. versión {1 | 2}

5. salida

6. número del tipo de la interfaz

7. el RIP del IP envía la versión [1] [2]

8. el RIP del IP recibe la versión [1] [2]

9. nombre-de-encadenamiento de la cadena de claves de autenticación del RIP del IP

10. modo de autenticación del RIP del IP {texto | md5}

11 extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
RIP del router


Ejemplo:

RIP del router de Router(config)#

 

Ingresa en el modo de configuración del router.

 
Paso 4
versión {1 | 2}


Ejemplo:

Router (config-router) # versión 1

 

Configura una interfaz para enviar solamente los paquetes de la versión de RIP 1.

 
Paso 5
salida


Ejemplo:

Router (config-router) # salida

 

Da salida al modo de configuración del router y ingresa al modo de configuración global.

 
Paso 6
número del tipo de la interfaz


Ejemplo:

Interfaces Ethernet 3/0 de Router(config)#

 

Ingresa en el modo de configuración de la interfaz.

 
Paso 7
el RIP del IP envía la versión [1] [2]


Ejemplo:

El router (config-if) # RIP del IP envía la versión 1

 

Configura una interfaz para enviar solamente los paquetes de la versión de RIP 1.

 
Paso 8
el RIP del IP recibe la versión [1] [2]


Ejemplo:

El router (config-if) # RIP del IP recibe la versión 1

 

Configura una interfaz para validar solamente los paquetes de la versión de RIP 1.

 
Paso 9
nombre-de-encadenamiento de la cadena de claves de autenticación del RIP del IP


Ejemplo:

Router (config-if) # chainname de la cadena de claves de autenticación del RIP del IP

 

Autenticación del RIP de los permisos.

 
Paso 10
modo de autenticación del RIP del IP {texto | md5}


Ejemplo:

Router (config-if) # md5 del modo de autenticación del RIP del IP

 

Configura la interfaz para utilizar el asimilar autenticación MD5 (o déjelo omitir el autenticación de texto únicamente).

 
Paso 11
Finalizar


Ejemplo:

Router(config-if)#end

 

Salidas modo de configuración de la interfaz y devoluciones al modo EXEC privilegiado.

 

Resumir las rutas del RIP

Resumen de Route automático de los soportes de la versión de RIP 2 por abandono. El software resume los subprefixes al límite de la red classful cuando se cruzan los límites de la red classful. Si usted ha desconectado las subredes, inhabilite el resumen de Route automático para hacer publicidad de las subredes. Cuando se inhabilita el resumen de Route, el software envía la información de ruteo de la subred y del host a través de los límites de la red classful. Para inhabilitar el resumen automático, utilice el comando no auto-summary en el modo de configuración del router.


Nota


El anuncio del supernet (que hace publicidad de cualquier Prefijo de red menos que su red principal classful) no se permite en el resumen del RIP Route, con excepción de hacer publicidad un supernet aprendido en las tablas de ruteo. El supernets aprendido en cualquier interfaz que esté conforme a la configuración todavía se aprende. Por ejemplo, el resumen siguiente es inválido: (resumen inválido del supernet)

Router(config)# interface Ethernet 1 
Router(config-if)# ip summary-address rip 10.0.0.0 252.0.0.0 
.
.
>
PASOS SUMARIOS

1. permiso

2. configuró terminal

3. número del tipo de la interfaz

4. máscara de la red del IP address del RIP del resumen-direccionamiento del IP

5. salida

6. RIP del router

7. ningún automóvil summary

8. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
número del tipo de la interfaz


Ejemplo:

Interfaces Ethernet 3/0 de Router(config)#

 

Ingresa al modo de configuración de la interfaz.

 
Paso 4
máscara de la red del IP address del RIP del resumen-direccionamiento del IP


Ejemplo:

Router (config-if) # RIP 10.2.0.0 255.255.0.0 del resumen-direccionamiento del IP

 

Especifica la dirección IP y la máscara de la red que identifican las rutas que se resumirán.

 
Paso 5
salida


Ejemplo:

Router(config-if)# exit

 

Da salida al modo de configuración de la interfaz.

 
Paso 6
RIP del router


Ejemplo:

RIP del router de Router(config)#

 

Ingresa al modo de configuración del router.

 
Paso 7
ningún automóvil summary


Ejemplo:

Router (config-router) # ningún automóvil summary

 

Utilizado en el modo de configuración del router, resumen automático de las neutralizaciones.

 
Paso 8
Finalizar


Ejemplo:

Router (config-router) # extremo

 

Sale del modo de configuración del router y vuelve al modo EXEC privilegiado.

 

Habilitación o Inhabilitación de Split Horizon

Para habilitar o inhabilitar el horizonte partido, utilice los siguientes comandos en el modo de configuración de la interfaz, según las necesidades.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. número del tipo de la interfaz

4. horizonte partido del IP

5. ningún horizonte partido del IP

6. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
número del tipo de la interfaz


Ejemplo:

Interfaces Ethernet 3/0 de Router(config)#

 

Ingresa en el modo de configuración de la interfaz.

 
Paso 4
horizonte partido del IP


Ejemplo:

Router (config-if) # horizonte partido del IP

 

Los permisos partieron el horizonte.

 
Paso 5
ningún horizonte partido del IP


Ejemplo:

Router (config-if) # ningún horizonte partido del IP

 

Inhabilita el split horizon.

 
Paso 6
Finalizar


Ejemplo:

Router(config-if)#end

 

Salidas modo de configuración de la interfaz y devoluciones al modo EXEC privilegiado.

 

Inhabilitar la validación de las dirección IP de origen

Realice esta tarea de inhabilitar la función predeterminada que valida las dirección IP de origen de las actualizaciones de ruteo entrantes.


Nota


Parta el horizonte para el Frame Relay y la encapsulación S DS se inhabilita por abandono. El horizonte partido no se inhabilita por abandono para las interfaces usando las encapsulaciones unas de los X.25. Para el resto de las encapsulaciones, el horizonte partido se habilita por abandono.

Generalmente el cambio del estado del valor por defecto no se recomienda a menos que usted esté seguro que su aplicación requiere realizar un cambio para hacer publicidad de las rutas correctamente. Recuerde que si el horizonte partido se inhabilita en una interfaz serial (y que la interfaz está asociada a un Packet Switched Network), usted debe inhabilitar el horizonte partido para todo el Routers en cualquier grupo de multidifusión relevante en esa red.


Nota


La red resumida no será hecha publicidad cuando se habilita el horizonte de la fractura.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. número del tipo de la interfaz

4. horizonte partido del IP

5. salida

6. RIP del router

7. ninguna validar-actualización-fuente

8. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
número del tipo de la interfaz


Ejemplo:

Interfaces Ethernet 3/0 de Router(config)#

 

Ingresa en el modo de configuración de la interfaz.

 
Paso 4
horizonte partido del IP


Ejemplo:

Router (config-if) # horizonte partido del IP

 

Los permisos partieron el horizonte.

 
Paso 5
salida


Ejemplo:

Router(config-if)# exit

 

Sale del modo de configuración de interfaz.

 
Paso 6
RIP del router


Ejemplo:

RIP del router de Router(config)#

 

Ingresa en el modo de configuración del router.

 
Paso 7
ninguna validar-actualización-fuente


Ejemplo:

Router (config-router) # ninguna validar-actualización-fuente

 

Inhabilita la validación de la dirección IP de origen de las actualizaciones de RIP Routing entrantes.

 
Paso 8
Finalizar


Ejemplo:

Router (config-router) # extremo

 

Sale del modo de configuración del router y vuelve al modo EXEC privilegiado.

 

Configurar el retardo de Interpacket

Realice esto para configurar el retardo del interpacket.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. número del tipo de la interfaz

4. salida

5. RIP del router

6. milisegundos del salida-retardo

7. extremo


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
número del tipo de la interfaz


Ejemplo:

Interfaces Ethernet 3/0 de Router(config)#

 

Ingresa en el modo de configuración de la interfaz.

 
Paso 4
salida


Ejemplo:

Router(config-if)# exit

 

Sale del modo de configuración de interfaz.

 
Paso 5
RIP del router


Ejemplo:

RIP del router de Router(config)#

 

Ingresa en el modo de configuración del router.

 
Paso 6
milisegundos del salida-retardo


Ejemplo:

Router (config-router) # salida-retardo 8

 

Retardo del interpacket de las configuraciones para las actualizaciones salientes del RIP.

 
Paso 7
Finalizar


Ejemplo:

Router (config-router) # extremo

 

Sale del modo de configuración del router y vuelve al modo EXEC privilegiado.

 

RIP óptimo sobre WAN

Hay dos problemas cuando el RIP no se optimiza:

  • El broadcast periódico por el RIP evita generalmente que los circuitos PÁLIDOS sean cerrados.
  • Incluso en fijo, los links punto a punto, los gastos indirectos de las transmisiones del RIP periódico podrían interrumpir seriamente la transferencia de datos normales debido a la cantidad de información que pasa a través de la línea cada 30 segundos.

Para superar estas limitaciones, extensiones activadas PARA RASGAR EL RIP de la causa para enviar la información sobre WAN solamente cuando ha habido una actualización a las bases de datos de ruteo. Los paquetes de la actualización periódica se suprimen sobre la interfaz en la cual se habilita esta característica. El RIP que rutea el tráfico se reduce en el Punto a punto, las interfaces seriales. Por lo tanto, usted puede salvar el dinero en un circuito a pedido para el cual le carguen para el uso. Extensiones activadas PARA RASGAR parcialmente el RFC 2091 del soporte, extensiones activadas PARA RASGAR para soportar los circuitos de la demanda.

Realice la tarea siguiente de permitir a las extensiones activadas PARA RASGAR y para visualizar el contenido de las bases de datos privadas del RIP.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. regulador-número del serial de la interfaz

4. ip rip triggered

5. extremo

6. muestre el [prefix mask] de las bases de datos de RIP del IP


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
regulador-número del serial de la interfaz


Ejemplo:

Interfaz serial3/0 de Router(config)#

 

Configura una interfaz serial.

 
Paso 4
ip rip triggered


Ejemplo:

Router (config-if) # ip rip triggered

 

Permite a las extensiones activadas PARA RASGAR.

 
Paso 5
Finalizar


Ejemplo:

Router(config-if)#end

 

Vuelve al modo EXEC privilegiado.

 
Paso 6
muestre el [prefix mask] de las bases de datos de RIP del IP


Ejemplo:

Bases de datos de RIP del IP de la demostración del Router-

 

Visualiza el contenido de las bases de datos privadas del RIP.

 

Configurando el comienzo del retardo IP-RIP para el Routers conectado por una red Frame Relay

Las tareas en esta sección explican cómo configurar a un router para utilizar la característica del comienzo del retardo IP-RIP en una interfaz de Frame Relay.


Timesaver


Los routeres Cisco permiten que una sesión vecina del RIPv2 MD5-authenticated comience cuando el número de secuencia del primer paquete MD5 recibido del otro router es mayor de 0. Si usted está utilizando solamente a los routeres Cisco en su red, usted no necesita utilizar la característica del comienzo del retardo IP-RIP.


Prerrequisitos

Su router debe ser Cisco IOS Release 12.4(12) corriente o una versión posterior.


Nota


La característica del comienzo del retardo IP-RIP se soporta sobre otros tipos de interfaz tales como fast ethernet y Gigabits Ethernet. Si su router Cisco no puede establecer a las sesiones vecinas del RIPv2 que usan autenticación de MD5 con dispositivo no Cisco, la característica del comienzo del retardo IP-RIP pudo resolver el problema.

Restricciones

Se requiere la característica del comienzo del retardo IP-RIP solamente cuando configuran a su router Cisco para establecer una relación de vecino del RIPv2 con dispositivo no Cisco y usted quiere utilizar la autenticación de vecino MD5.

Configurar el RIPv2

Esta tarea requerida configura el RIPv2 en el router.

Esta tarea proporciona las instrucciones para solamente una de las muchas permutaciones posibles para configurar el RIPv2 en su router.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. RIP del router

4. IP-red de la red

5. versión {1 | 2}

6. [no] automóvil summary


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
RIP del router


Ejemplo:

RIP del router de Router(config)#

 

Habilita un proceso de ruteo del RIP, que le coloca en el modo de configuración del router.

 
Paso 4
IP-red de la red


Ejemplo:

Router (config-router) # red 192.168.0.0

 

Asocia una red a un proceso de ruteo del RIP.

 
Paso 5
versión {1 | 2}


Ejemplo:

Router (config-router) # versión 2

 

Configura el software para recibir y para enviar solamente la versión de RIP 1 o solamente la versión de RIP 2 paquetes.

 
Paso 6
[no] automóvil summary

Ejemplo:

Router (config-router) # ningún automóvil summary

 

Las neutralizaciones o restablecen el comportamiento predeterminado del resumen automático de las rutas de subred en las rutas del nivel de red.

 

Configurar el Frame Relay en un Subinterfaz serial

Esta tarea requerida configura un Subinterfaz serial para el Frame Relay.


Nota


Esta tarea proporciona las instrucciones para solamente una de las muchas permutaciones posibles para configurar el Frame Relay en una subinterfaz. Para más información sobre e instrucciones para configurar el Frame Relay, vea la parte del Frame Relay que configura la Guía de Configuración de redes de área ancha del Cisco IOS.
PASOS SUMARIOS

1. permiso

2. configuró terminal

3. número del tipo de la interfaz

4. ningún IP Address

5. Frame Relay de la encapsulación [número del mfr | IETF]

6. tipo LMI del Frame Relay {Cisco | ANSI | q933a}

7. salida

8. número del tipo de la interfaz/subinterfaz-número {Punto a punto | de múltiples puntos}

9. dlci de la interfaz DLCI de Frame Relay [IETF | Cisco]


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
número del tipo de la interfaz


Ejemplo:

Interfaz serial3/0 de Router(config)#

 

Especifica una interfaz e ingresa en el modo de configuración de la interfaz.

 
Paso 4
sin dirección de IP


Ejemplo:

Router (config-if) # ningún IP Address

 

Quita previamente un IP Address configurado de la interfaz.

 
Paso 5
Frame Relay de la encapsulación [número del mfr | IETF]


Ejemplo:

Router (config-if) # IETF de Frame Relay de la encapsulación

 

Especifica el tipo de Encapsulación de Frame Relay para la interfaz.

 
Paso 6
tipo LMI del Frame Relay {Cisco | ANSI | q933a}


Ejemplo:

Router (config-if) # ANSI del tipo LMI del Frame Relay

 

Especifica el tipo de la interfaz de administración local de Frame Relay (LMI) para la interfaz.

 
Paso 7
salida


Ejemplo:

Router(config-if)# exit

 

Sale del modo de configuración de interfaz.

 
Paso 8
número del tipo de la interfaz/subinterfaz-número {Punto a punto | de múltiples puntos}


Ejemplo:

Punto a punto de la interfaz serial3/0.1 de Router(config)#

 

Especifica una subinterfaz y el Tipo de conexión para la subinterfaz y ingresa el modo de la configuración de la subinterfaz.

 
Paso 9
dlci de la interfaz DLCI de Frame Relay [IETF | Cisco]


Ejemplo:

Router (config-subif) # IETF de la interfaz DLCI de Frame Relay 100

 

Asigna un identificador de conexión de link de datos (DLCI) a una subinterfaz del Frame Relay.

 

Configurar el IP con autenticación de MD5 para el RIPv2 y el retardo IP-RIP en una subinterfaz del Frame Relay

Esta tarea requerida configura el IP, autenticación de MD5 para el RIPv2 y la característica del comienzo del retardo IP-RIP en una subinterfaz del Frame Relay.

PASOS SUMARIOS

1. permiso

2. configuró terminal

3. nombre-de-encadenamiento del llavero

4. número dominante

5. cadena de la clave-cadena

6. salida

7. salida

8. número del tipo de la interfaz/subinterfaz-número

9. no cdp enable

10. subnet mask del IP address del IP Address

11 modo de autenticación del RIP del IP {texto | md5}

12.    nombre-de-encadenamiento de la cadena de claves de autenticación del RIP del IP

13.    retardo del retraso inicial del RIP del IP

14.    Finalizar


PASOS DETALLADOS
 Comando o acciónPropósito
Paso 1
permiso


Ejemplo:

Router> enable

 

Habilita el modo EXEC privilegiado.

  • Ingrese su contraseña si se le pide que lo haga.
 
Paso 2
configure terminal


Ejemplo:

Router# configure terminal

 

Ingresa en el modo de configuración global.

 
Paso 3
nombre-de-encadenamiento del llavero


Ejemplo:

Rip-md5 del llavero de Router(config)#

 

Especifica el nombre de un encadenamiento dominante y ingresa al modo de configuración del encadenamiento dominante.

 
Paso 4
número dominante


Ejemplo:

Router (config-llavero) # clave 123456

 

Especifica el identificador dominante y ingresa al modo de configuración de la clave del encadenamiento dominante. Rango: 0 a 2147483647.

 
Paso 5
cadena de la clave-cadena


Ejemplo:

Router (config-llavero-clave) # abcde de la clave-cadena

 

Configura la cadena dominante.

 
Paso 6
salida


Ejemplo:

Router (config-llavero-clave) # salida

 

Da salida al modo de configuración dominante del llavero.

 
Paso 7
salida


Ejemplo:

Router (config-llavero) # salida

 

Da salida al modo de configuración del llavero.

 
Paso 8
número del tipo de la interfaz/subinterfaz-número


Ejemplo:

Interfaz serial3/0.1 de Router(config)#

 

Especifica una subinterfaz y ingresa el modo de la configuración de la subinterfaz.

Nota    La palabra clave del Tipo de conexión no se requiere para este paso en esta tarea porque especificaron al Tipo de conexión para esta subinterfaz en la tarea anterior.
 
Paso 9
no cdp enable


Ejemplo:

Router (config-subif) # no cdp enable

 

Opciones del Cisco Discovery Protocol (CDP) de las neutralizaciones en la interfaz.

Nota    El CDP no es soportado por los dispositivos del no Cisco; y se requiere la característica del comienzo del retardo IP-RIP solamente cuando usted está conectando con un router no perteneciente a Cisco. Por lo tanto, usted debe inhabilitar el CDP en cualquier interfaz en las cuales usted quiera configurar la característica del comienzo del retardo IP-RIP.
 
Paso 10
subnet mask del IP address del IP Address


Ejemplo:

Router (config-subif) # dirección IP 172.16.10.1 255.255.255.0

 

Configura una dirección IP para la subinterfaz del Frame Relay.

 
Paso 11
modo de autenticación del RIP del IP {texto | md5}


Ejemplo:

Router (config-subif) # md5 del modo de autenticación del RIP del IP

 

Especifica el modo para la autenticación del RIPv2.

 
Paso 12
nombre-de-encadenamiento de la cadena de claves de autenticación del RIP del IP


Ejemplo:

Router (config-subif) # rip-md5 de la cadena de claves de autenticación del RIP del IP

 

Especifica un llavero previamente autenticación de MD5 configurado para el RIPv2.

 
Paso 13
retardo del retraso inicial del RIP del IP


Ejemplo:

Router (config-subif) # retraso inicial 45 del RIP del IP

 

Configura la característica del comienzo del retardo IP-RIP en la interfaz. El router retrasará el enviar del primer autenticación de MD5 paquete al vecino del RIPv2 para el número de segundos especificados por el argumento del retardo. Rango: 0 a 1800.

 
Paso 14
Finalizar


Ejemplo:

Router (config-subif) # extremo

 

Sale el modo de configuración y las devoluciones de la sub-interfaz al modo EXEC privilegiado.

 

Ejemplos de configuración para el RIP

Ejemplo de Resumen de Ruta

El siguiente ejemplo muestra cómo el comando configuration del riprouter del resumen-direccionamiento del IP puede ser utilizado para configurar el resumen en una interfaz. En este ejemplo, las subredes 10.1.3.0/25, 10.1.3.128/25, 10.2.1.0/24, 10.2.2.0/24, 10.1.2.0/24 y 10.1.1.0/24 se pueden resumir como se muestra abajo mientras que envían las actualizaciones sobre una interfaz.

Router(config)#interface GigabitEthernet 0/2
Router(config-if)#ip summary-address rip 10.1.0.0 255.255.0.0
Router(config-if)#ip summary-address rip 10.2.0.0 255.255.0.0
Router(config-if)#ip summary-address rip 10.3.0.0 255.255.0.0

Ejemplos de Split Horizon

Dos ejemplos de configurar el horizonte partido se proporcionan.

Ejemplo 1

La configuración siguiente muestra un ejemplo simple de inhabilitar el horizonte partido en un link serial. En este ejemplo, el link serial está conectado con una red X.25.

Router(config)# interface Serial 0 
Router(config-if)# encapsulation x25
 
Router(config-if)# no ip split-horizon
 

‘Ejemplo 2’

En el próximo ejemplo, la figura abajo ilustra una situación típica en la cual no hay el comando interface configuration del horizonte partido del IP útil. Esta figura representa dos subredes IP que sean ambo accesibles vía una interfaz serial en el C del router (conectado con una red Frame Relay). En este ejemplo, la interfaz serial en el C del router acomoda una de las subredes vía la asignación de una driección IP secundaria.

Las interfaces de Ethernet para el router A, el router B, y el C del router (conectado con las redes IP 10.13.50.0, 10.155.120.0, y 10.20.40.0, respectivamente todo han partido el horizonte habilitado por abandono, mientras que las interfaces seriales conectaron con las redes 172.16.1.0 y 192.168.1.0 todo ha partido el horizonte inhabilitado con el comando no ip split-horizon. La figura abajo muestra la topología y las interfaces.

Figura 1Ejemplo partido del horizonte de los minusválidos para la red Frame Relay


En este ejemplo, el horizonte partido se inhabilita en todas las interfaces seriales. El horizonte partido se debe inhabilitar en el C del router para que la red 172.16.0.0 que se hará publicidad en la red 192.168.0.0 y vice versa. Estas subredes solapan en el C del router, s0 de la interfaz. Si el horizonte partido fuera habilitado en el s0 de la interfaz serial, no haría publicidad de una ruta nuevamente dentro de la red Frame Relay para cualquiera de estas redes.

Configuración para el Router A

interface ethernet 1
 ip address 10.13.50.1
!
interface serial 1
 ip address 172.16.2.2
 encapsulation frame-relay
 no ip split-horizon 

Configuración para el Router B

interface ethernet 2
 ip address 10.155.120.1
!
interface serial 2
 ip address 192.168.1.2
 encapsulation frame-relay 
 no ip split-horizon

Configuración para el Router C

interface ethernet 0
 ip address 10.20.40.1
!
interface serial 0
 ip address 172.16.1.1
 ip address 192.168.1.1 secondary
 encapsulation frame-relay 
 no ip split-horizon

Ejemplo de Temporizadores de la Familia de Direcciones

El siguiente ejemplo muestra cómo ajustar los temporizadores individuales de la familia del direccionamiento. Observe que la familia “notusingtimers” del direccionamiento utilizarán los valores predeterminados del sistema de 30, 180, 180, y 240 aunque los valores del temporizador de 5, 10, 15, y 20 se utilizan bajo configuración de RIP general. Los temporizadores de la familia del direccionamiento no se heredan de la configuración de RIP general.

Router(config)# router rip
Router(config-router)# version 2
Router(config-router)# timers basic 5 10 15 20
Router(config-router)# redistribute connected
Router(config-router)# network 5.0.0.0
Router(config-router)# default-metric 10
Router(config-router)# no auto-summary
Router(config-router)#
Router(config-router)# address-family ipv4 vrf abc
Router(config-router-af)# timers basic 10 20 20 20
Router(config-router-af)# redistribute connected
Router(config-router-af)# network 10.0.0.0
Router(config-router-af)# default-metric 5
Router(config-router-af)# no auto-summary
Router(config-router-af)# version 2
Router(config-router-af)# exit-address-family
Router(config-router)# 
Router(config-router)# address-family ipv4 vrf xyz
Router(config-router-af)# timers basic 20 40 60 80
Router(config-router-af)# redistribute connected
Router(config-router-af)# network 20.0.0.0
Router(config-router-af)# default-metric 2
Router(config-router-af)# no auto-summary
Router(config-router-af)# version 2
Router(config-router-af)# exit-address-family
Router(config-router)#
Router(config-router)# address-family ipv4 vrf notusingtimers
 
Router(config-router-af)# redistribute connected 
Router(config-router-af)# network 20.0.0.0 
Router(config-router-af)# default-metric 2 
Router(config-router-af)# no auto-summary 
Router(config-router-af)# version 2 
Router(config-router-af)# exit-address-family 
Router(config-router)#

Comienzo del retardo IP-RIP en los ejemplos de una interfaz de Frame Relay

Este extracto de un archivo de configuración del router contiene los comandos required mínimos de configurar la característica del comienzo del retardo IP-RIP en su router.

!
key chain rip-md5
 key 123456
  key-string abcde
!
router rip
 version 2
 network 172.16.0.0
 no auto-summary
!
interface Serial3/0
 no ip address
 encapsulation frame-relay ietf
 frame-relay lmi-type ansi
!
interface Serial3/0.1 point-to-point
 ip address 172.16.10.1 255.255.255.0
 ip rip initial-delay 45
 ip rip authentication mode md5
 ip rip authentication key-chain rip-md5
 frame-relay interface-dlci 100

Referencias adicionales

Las secciones siguientes proporcionan las referencias relacionadas con configurar el Routing Information Protocol.

Documentos Relacionados

Tema relacionado

Título del documento

Características del protocolo independiente, información de filtración del RIP, administración de claves (disponible en la versión de RIP 2), y el VLS

Configuración de las Funciones de IP Routing Independientes del Protocolo

Comandos del RIP: sintaxis de comandos completa, modo de comandos, historial de comandos, valores predeterminados, directrices de uso y ejemplos

Routing IP del Cisco IOS: Referencia de comandos del RIP

Configuración de Frame Relay

Guía de Configuración de redes de área ancha del Cisco IOS

Estándares

Estándar

Título

Ninguno

--

MIB

MIB

Link del MIB

Se soporta el MIB no nuevo o modificado y el soporte para el MIB existente no se ha modificado.

Para localizar y descargar MIB de plataformas, versiones de Cisco IOS y conjuntos de funciones seleccionados, utilice Cisco MIB Locator, que se encuentra en la siguiente URL:

http://www.cisco.com/cisco/web/LA/support/index.html

RFC

RFC

Título

RFC 1058

Routing Information Protocol

RFC 2082

RIP-2 autenticación de MD5

RFC 2091

Extensiones activadas A RASGAR para soportar los circuitos de la demanda

RFC 2453

Versión de RIP 2

Asistencia Técnica

Descripción

Link

El sitio Web de soporte técnico de Cisco proporciona los recursos en línea extensos, incluyendo la documentación y las herramientas para localizar averías y resolver los problemas técnicos con los Productos Cisco y las Tecnologías.

Para recibir la Seguridad y la información técnica sobre sus Productos, usted puede inscribir a los diversos servicios, tales como la herramienta de alerta del producto (accedida de los Field Notice), el hoja informativa de los servicios técnicos de Cisco, y alimentaciones realmente simples de la sindicación (RSS).

El acceso a la mayoría de las herramientas en el sitio Web de soporte técnico de Cisco requiere una identificación del usuario y una contraseña del cisco.com.

http://www.cisco.com/cisco/web/support/index.html

Información de la característica para configurar el RIP

La tabla siguiente proporciona la información sobre la versión sobre la característica o las características descritas en este módulo. Esta tabla enumera solamente la versión de software que introdujo el soporte para una característica dada en un tren de versión de software dado. A menos que se indicare en forma diferente, las versiones posteriores de ese tren de versión de software también soportan esa característica.

Utilice el Cisco Feature Navigator para encontrar la información sobre el soporte del Soporte de la plataforma y de la imagen del software de Cisco. Para acceder el Cisco Feature Navigator, vaya a www.cisco.com/go/cfn. Una cuenta en el cisco.com no se requiere.

Tabla 1Información de la característica para configurar el Routing Information Protocol

Nombre de la función

Versiones

Información sobre la Función

Comienzo del retardo IP-RIP

12.4(12),

el 15.0(1)M,

12.2(33)SRE,

15.0(1)SY

La característica del comienzo del retardo IP-RIP se utiliza en los routeres Cisco para retrasar el lanzamiento de las sesiones vecinas del RIPv2 hasta que la conectividad de red entre los routeres vecinos esté completamente - operativas, de tal modo asegurándose de que el número de secuencia del primer paquete MD5 que el router envía al no Cisco el router vecino es 0. El comportamiento predeterminado para un router configurado para establecer a las sesiones vecinas del RIPv2 con un router vecino usando autenticación de MD5 es comenzar a enviar los paquetes MD5 cuando la interfaz física está para arriba.

Se han insertado o modificado los siguientes comandos: retraso inicial del RIP del IP.

Dirección de resumen IP para el RIPv2

12.0(7)T 12.1(3)T 12.1(14) 12.2(2)T 12.2(27)SBB el 15.0(1)M 12.2(33)SRE 15.0S

El IP Adddress sumario para la característica del RIPv2 introdujo la capacidad de resumir las rutas. Resumir las rutas en la versión de RIP 2 mejora el scalability y la eficacia en las Redes grandes. Resumir los IP Addresses significa que no hay entrada para las rutas del niño (rutas que se crean para cualquier combinación de los IP Addresses individuales contenidos dentro de una dirección de resumen) en la tabla de ruteo del RIP, reduciendo los tamaños de la tabla y de permitir que el router maneje más rutas.

Los siguientes comandos fueron introducidos o modificados por esta característica: RIP del resumen-direccionamiento del IP.

Routing Information Protocol

12.2(27)SBB el 15.0(1)M 12.2(33)SRE 15.0S

El Routing Information Protocol (RIP) es un Routing Protocol de uso general en las redes pequeñas-medias TCP/IP. Es un protocolo estable que utiliza un algoritmo del vector de distancia para calcular las rutas.

RIP activado

12.0(1)T el 15.0(1)M 12.2(33)SRE 15.0S

El RIP activado fue introducido para superar las actualizaciones constantes del RIP sobre los links PÁLIDOS basados en el circuito costosos. Extensiones activadas PARA RASGAR EL RIP de la causa para enviar la información sobre WAN solamente cuando ha habido una actualización a las bases de datos de ruteo. Los paquetes de la actualización periódica se suprimen sobre la interfaz en la cual se habilita esta característica. El RIP que rutea el tráfico se reduce en el Punto a punto, las interfaces seriales.

Se han insertado o modificado los siguientes comandos: ip rip triggered, bases de datos de RIP del IP de la demostración.

Glosario

familia del direccionamiento --Un grupo de Network Protocol que comparten un formato común de la dirección de red. El RFC 1700 definen a las familias del direccionamiento.

IS-IS --Intermediate System-to-Intermediate System. Protocolo del ruteo jerárquico del link-state OSI basado el la fase V del DECNet que rutea, donde el Routers intercambia la información de ruteo basada en un solo métrico, para determinar la topología de red.

RIP --El Routing Information Protocol .RIP es un Dynamic Routing Protocol usado en el local y las redes de área extensa.

VRF --Caso del VPN Routing and Forwarding. Un VRF consta de una tabla de IP Routing, una tabla de reenvío derivada, un conjunto de interfaces que utiliza la tabla de reenvío y un conjunto de reglas y protocolos de ruteo que determina qué incluye la tabla de reenvío. En general, un VRF incluye la información de ruteo que define un sitio de cliente VPN conectado a un router PE.

Cisco y el logotipo de Cisco son marcas registradas o marcas registradas de Cisco y/o de sus afiliados en los E.E.U.U. y otros países. Para ver una lista de marcas registradas de Cisco, vaya a este URL: www.cisco.com/go/trademarks. Las marcas registradas de tercera persona mencionadas son la propiedad de sus propietarios respectivos. El uso de la palabra Partner no implica en una relación de sociedad entre Cisco y ninguna otra compañía. (1110R)

Las direcciones IP (Internet Protocol) y los números de teléfono utilizados en este documento no son direcciones y números de teléfono reales. Cualesquiera ejemplos, muestra de la salida de comandos, diagramas de topología de red y otras figuras incluidos en el documento se muestran solamente con fines ilustrativos. El uso de direcciones IP o números de teléfono reales en contenido ilustrativo es involuntario y fortuito.

Cisco Systems, Inc. del © 2011 todos los derechos reservados.